Многопротокольная коммутация по меткам (MPLS) : MPLS для виртуальных частных сетей

Перераспределение маршрутов в сетях MPLS/VPN

16 ноября 2010 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (10 августа 2005) | Отзыв

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе в действующей сети необходимо понимать последствия выполнения любой команды.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе рассмотрены следующие два примера конфигурации.

  • Перераспределение маршрута из глобальной таблицы маршрутизации в экземпляр маршрутизации/переадресации (VRF) виртуальной частной сети (VPN) и перераспределение маршрута из VRF в глобальную таблицу маршрутизации.

  • Перераспределение маршрутов между различными VRF

Примечание. Для поиска дополнительных сведений о командах, описываемых в данном документе, используйте средство поиска команд (только для зарегистрированных заказчиков).

Перераспределение маршрутов из глобальной таблицы маршрутизации в экземпляр VRF и в обратном направлении

Эта конфигурация описывает перераспределение маршрутов из глобальной таблицы маршрутизации в экземпляр маршрутизации/пересылки VPN VRF) и из VPN в глобальную таблицу маршрутизации.

Схема сети

Данная конфигурация использует следующую настройку сети.

/image/gif/paws/47807/routeleaking_01.gif

Конфигурация

В этом примере доступ к станции системы управления сетью (NMS), расположенной в VRF, осуществляется из глобальной таблицы маршрутизации. Маршрутизаторы на стороне провайдера (PE) и маршрутизаторы провайдера (P) должны экспортировать данные NetFlow на станцию NMS (10.0.2.2) в VRF. Адрес 10.0.2.2 достижим через интерфейс VRF на стороне поставщика услуг 4.

Для доступа к 10.0.2.0/30 из глобальной таблицы на PE-4 вводится статический маршрут к 10.0.2.0/30, выходящий из интерфейса VRF. Этот статический маршрут далее перераспределяется через внутренний протокол маршрутизации по всем маршрутизаторам PE и P. Это гарантирует, что все маршрутизаторы PE и P смогут добраться до 10.0.2.0/30 через PE-4.

Также добавляется статический маршрут VRF. Статический маршрут VRF указывает на подсеть в глобальной сети, которая отправляет трафик в адрес этой станции NMS. Без этого добавления PE-4 отклонял бы трафик от станции NMS, т.е. трафик, принимаемый на интерфейсе VRF, отправляя станции NMS сообщение ICMP: host unreachable rcv (хост при приеме недоступен).

В этом разделе используется следующая конфигурация:

PE-4

!
ip cef
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
!
interface Serial1/0
ip address 10.1.2.5 255.255.255.252
no ip directed-broadcast
!
interface Serial2/0
ip vrf forwarding vpn2
ip address 10.0.2.1 255.255.255.0
no ip directed-broadcast
!
ip classless
ip route 10.0.2.0 255.255.255.252 Serial2/0
ip route vrf vpn2 10.1.2.4 255.255.255.252 Serial1/0
!

Статические маршруты теперь могут быть перераспределены в любой маршрутизатор IGP для объявления в масштабе всей сети. То же самое имеет место и в том случае, если интерфейс VRF является интерфейсом локальной сети (например, Ethernet). Точная команда конфигурации будет иметь следующий вид:

ip route 10.0.2.0 255.255.255.252 Ethernet2/0 10.0.2.2

Примечание. IP-адрес, настраиваемый после имени интерфейса, используется только протоколом разрешения адресов (ARP) для определения конкретного адреса, подлежащего разрешению.

Примечание. Для коммутаторов серии 4500 необходимо настроить статические записи ARP в таблицах VRF, указав соответствующие адреса следующего перехода.

Примечание. По умолчанию программное обеспечение Cisco IOS® принимает статические маршруты VRF в том виде, в котором они настроены. Это может быть небезопасным, поскольку открывает возможность для перераспределения маршрутов между различными экземплярами VRF. Установку подобных статических маршрутов VRF можно запретить командой no ip route static inter-vrf. Подробное описание команды no ip route static inter-vrf см. в разделе Виртуальные частные сети (VPN) с протоколом MPLS.

Проверка

В этом разделе описана проверка работоспособности существующей конфигурации.

Некоторые команды show поддерживаются интерпретатором выходных данных (доступен только для зарегистрированных заказчиков); интерпретатор позволяет просматривать анализ выходных данных команды show.

  • show ip route 10.0.2.0 – отображает запись маршрутизации для указанного IP-адреса.

  • show ip route vrf vpn2 10.1.2.4 – отображает запись маршрутизации VRF для указанного IP-адреса.

PE-4# show ip route 10.0.2.0

Routing entry for 10.0.2.0/30
Known via "static", distance 1, metric 0 (connected)
Routing Descriptor Blocks:
* directly connected, via Serial2/0
Route metric is 0, traffic share count is 1

PE-4# show ip route vrf vpn2 10.1.2.4

Routing entry for 10.1.2.4/30
Known via "static", distance 1, metric 0 (connected)
Redistributing via bgp 1
Advertised by bgp 1
Routing Descriptor Blocks:
* directly connected, via Serial1/0
Route metric is 0, traffic share count is 1

Перераспределение маршрутов между экземплярами VRF

Эта конфигурация описывает перераспределение маршрутов между разными экземплярами VRF.

Схема сети

В этой конфигурации используется следующая схема сети.

/image/gif/paws/47807/routeleaking_02.gif

Конфигурация

Настроить два статических маршрута для объявления каждого префикса между разными экземплярами VRF нельзя, поскольку этот метод не поддерживается – пакеты не будут перенаправляться маршрутизатором. Для обеспечения распределения маршрутов между различными экземплярами VRF необходимо использовать функцию импорта мест назначения маршрутов и включить в маршрутизаторе протокол граничного шлюза (BGP). Соседний узел BGP не требуется.

В этом разделе используется следующая конфигурация:

PE-4

!
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 route-target import 200:1
!
ip vrf vpn2
 rd 200:1
 route-target export 200:1
 route-target import 200:1
 route-target import 100:1
!
interface Serial1/0
 ip vrf forwarding vpn1
 ip address 10.1.2.5 255.255.255.252
 no ip directed-broadcast
!
interface Serial2/0
 ip vrf forwarding vpn2
 ip address 10.0.2.1 255.255.255.0
 no ip directed-broadcast
router bgp 1
!
address-family ipv4 vrf vpn2
 redistribute connected
 !
address-family ipv4 vrf vpn1
 redistribute connected
!

Проверка

В данном разделе представлена информация по устранению неполадок конфигурации.

Некоторые команды show поддерживаются интерпретатором выходных данных (доступен только для зарегистрированных заказчиков); интерпретатор позволяет просматривать анализ выходных данных команды show.

  • show ip bgp vpnv4 all – отображает все префиксы VPNv4, запомненные посредством BGP.

PE-4# show ip bgp vpnv4 all

BGP table version is 13, local router ID is 7.0.0.4
Status codes: s suppressed, d damped, h history, * valid,
> best, i - internal, r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf vpn1)
*> 10.0.2.0/24 0.0.0.0 0 32768 ?
*> 10.1.2.4/30 0.0.0.0 0 32768 ?
Route Distinguisher: 200:1 (default for vrf vpn2)
*> 10.0.2.0/24 0.0.0.0 0 32768 ?
*> 10.1.2.4/30 0.0.0.0 0 32768 ?

Примечание. Перераспределение маршрутов между экземплярами VRF можно реализовать и другим способом: подключить два интерфейса Ethernet на маршрутизаторе PE-4 и связать каждый из них с одним из экземпляров VRF. Также необходимо настроить статические записи ARP в таблицах VRF, указав соответствующие адреса следующего перехода. Однако подобное решение не рекомендуется использовать для перераспределения маршрутов между экземплярами VRF; предпочтителен ранее описанный метод.

Поиск и устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении неполадок.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 47807