Протокол IP : Сервисы IP-адресации

Распределение нагрузки IOS NAT для двух подключений ISP

22 сентября 2010 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (13 сентября 2013) | Английский (22 февраля 2008) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Настройка
      Схема сети
      Варианты конфигурации
Проверка
Устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документе описана конфигурация маршрутизатора Cisco IOS® для подключения сети к Интернету с помощью преобразования сетевых адресов (NAT) с использованием двух соединений с ISP. Преобразование сетевых адресов ПО Cisco IOS может распределить последующие соединения TCP и сеансы UDP по нескольким сетевым соединениям, если для данного пункта доступны равноценные маршруты.

ios-nat-load-balancing-2isp-01.gif

Предварительные условия

Требования

Данный документ предполагает начало работы с LAN и WAN-подключениями; в документе не представлены базовые сведения о конфигурации и устранении неполадок для установки первоначального подключения. В данном документе не описано, как различать маршруты, поэтому здесь не предлагается способ предпочесть более желательное соединение менее желательному.

Используемые компоненты

Данная конфигурация разработана с использованием маршрутизатора Cisco 1811 и ПО Cisco IOS Advanced IP Services версии 12.4(15)T3. Если используется другая версия ПО, некоторые функции могут быть недоступны, или команды конфигурации могут отличаться от команд в документе. Идентичная конфигурация доступна на всех платформах маршрутизаторов Cisco IOS, хотя конфигурация интерфейса отличается в различных платформах.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе в действующей сети необходимо понимать последствия выполнения любой команды.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

Необходимо добавить маршрутизацию на основе политики для особого трафика, чтобы обеспечить использование им только одного соединения с ISP. Примеры трафика, для которого необходим данный режим, включают в себя трафик клиентов IPSec VPN, голосовой трафик VoIP и любой другой трафик, для которого должно использоваться только одно определенное соединение с ISP, имеющее определенные характеристики: одинаковый IP-адрес, более высокая скорость или более низкая задержка соединения.

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание. Для получения дополнительной информации об используемых в данном документе командах служит Средство поиска команд (только для зарегистрированных пользователей).

Схема сети

В настоящем документе используется следующая схема сети:

ios-nat-load-balancing-2isp-02.gif

В данном примере конфигурации описан доступ к маршрутизатору, который использует IP-подключение с поддержкой конфигурации DHCP к одному ISP (как показано FastEthernet 0) и подключение PPPoE через другое соединение с ISP. Тип соединений не особенно влияет на конфигурацию, хотя некоторые типы соединений могут быть неудобными для такой конфигурации при особых сценариях возникновения отказов, особенно в тех случаях, когда используется IP-соединение поверх Ethernet с использованием WAN, например, при использовании кабельного модема или DSL, где используются дополнительные оконечные устройства, завершающие WAN-соединение и предоставляющие возможность подключения маршрутизатора Cisco IOS с помощью Ethernet. При использовании статической IP-адресации (вместо использования динамического назначения адресов с помощью DHCP) или при использовании PPPoE, в случае возникновения сбоя подключения к WAN порт Ethernet по-прежнему будет поддерживать Ethernet соединение к устройству подключения к WAN, а маршрутизатор будет продолжать пытаться выполнять распределение нагрузки между хорошим и плохим соединением с WAN. Если при развертывании необходимо, чтобы неактивные маршруты были удалены из распределения нагрузки, обратитесь к конфигурации, рассмотренной в документе Распределение нагрузки и брандмауэр зональных политик NAT IOS с оптимизированной граничной маршрутизацией для двух подключений к Интернету, в котором описывается добавление оптимизированной граничной маршрутизации для наблюдения за состоянием маршрутов.

Варианты конфигурации

В данном документе используется следующая конфигурация:

interface FastEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!


!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452


!---Define LAN-facing interfaces with "ip nat inside".

!

!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss


!---Define ISP-facing interfaces with "ip nat outside".

!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
 
!
ip nat inside source route-map fixed-nat interface Dialer0 overload
ip nat inside source route-map dhcp-nat interface FastEthernet0 overload
!

!--- Configure NAT overload (PAT) in order to use route-maps.

 
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!

!--- Define ACLs for traffic that are NATed to 
!--- the ISP connections.


!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0


!--- Route-maps associate NAT ACLs with NAT outside on 
!--- the ISP-facing interfaces.

Проверка

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Интерпретатор выходных данных – OIT (доступный только зарегистрированным пользователям) поддерживает ряд команд show. Посредством OIT можно анализировать выходные данные команд show.

  • show ip nat translation — отображает активность NAT между внутренними и внешними хостами NAT. Данная команда предоставляет подтверждение, что внутренние хосты переводятся на внешние адреса NAT.

    Router#show ip nat translation
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
  • show ip route — проверяет доступность нескольких маршрутов к Интернету.

    Router#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Если соединения не работают после настройки маршрутизатора Cisco IOS с помощью NAT, убедитесь, что:

  • NAT применяется соответствующим образом на внешних и внутренних интерфейсах.

  • Конфигурация NAT выполнена, а списки ACL отображают трафик, для которого необходимо преобразование сетевых адресов.

  • Доступны несколько маршрутов к Интернету/WAN.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 100658