Протокол IP : IP версии 6 (IPv6)

Пример конфигурации для OSPFv3

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

OSPF представляет собой протокол маршрутизации для IP. Это - протокол состояния соединений, в противоположность протоколу вектора пути. Протокол состояния соединений принимает решения о маршрутизации на основе состояний ссылок, которые подключают источник и устройства назначения. Состояние ссылки является описанием того интерфейса и отношения к его соседним сетевым устройствам. Интерфейсная информация включает префикс IPv6 интерфейса, маски сети, тип сети, это связано с, маршрутизаторы, связанные с той сетью, и т.д. Эта информация распространяется в различном типе описаний локального состояния соединениий (LSA).

Версия 3 OSPF, которая описана в RFC 2740, поддерживает IPv6.

Предварительные условия

Требования

Перед включением OSPF для IPv6 на интерфейсе необходимо выполнить придерживающееся:

  • Завершите стратегию сети OSPF и планирующий сеть IPv6. Например, необходимо решить, требуются ли множественные области.

  • Включите одноадресную маршрутизацию IPv6.

  • Включите IPv6 на интерфейсе.

  • Настройте IP-безопасность (IPSec) прикладной программный интерфейс (API) защищенного сокета на OSPF для IPv6 для включения аутентификации и шифрования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/112100/ospfv3-config-guide-01.gif

Конфигурация

Это - конфигурация OSPFv3 для маршрутизаторов, показанных в схеме:

Тупиковый маршрутизатор
ipv6 unicast-routing
ipv6 cef
!
interface serial 0/0
 no ip address
 ipv6 enable
 ipv6 address 2001:ABAB::/64 eui-64
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 3.3.3.3
 area 2 stub
!

Маршрутизатор ABR1
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 speed auto
 ipv6 address 2003::1/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2002:ABAB::/64 eui-64
 ipv6 enable
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 1.1.1.1
 area 2 stub no-summary
!

Граничный маршрутизатор автономной системы
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 ipv6 address 2003::2/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:1/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router ospf 1
 router-id 2.2.2.2
 default-metric 25
 redistribute rip EXT metric-type 1 include-connected
!
ipv6 router rip EXT
 redistribute ospf 1 match internal external 1 external 2 include-connected
!

Внешний маршрутизатор
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address 2004:ABAB::/64 eui-64
 ipv6 enable
 ipv6 rip EXT enable
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:2/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router rip EXT

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Команда show ipv6 ospf database показывает Базу данных Состояния канала (LSDB) маршрутизатора.

Stub_Router#show ipv6 ospf database

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 2)

ADV Router      Age         Seq#            Fragment ID  Link count  Bits
1.1.1.1             885         0x80000007      0                    1           B
3.3.3.3             919         0x80000008      0                    1           None

                Inter Area Prefix Link States (Area 2)

ADV Router      Age         Seq#                Prefix
1.1.1.1             373         0x80000002          ::/0

                Link (Type-8) Link States (Area 2)

ADV Router      Age         Seq#            Link ID    Interface
1.1.1.1             964         0x80000006      5          Se0/0
3.3.3.3             1165        0x80000006     5          Se0/0

                Intra Area Prefix Link States (Area 2)

ADV Router      Age         Seq#            Link ID    Ref-lstype  Ref-LSID
1.1.1.1             964         0x80000005      0          0x2001      0
3.3.3.3             1172        0x80000005     0          0x2001      0

Маршрутизатор show ipv6 ospf database самопроисходит , команда показывает LSA маршрутизатора (локальный администратор безопасности), где маршрутизатор инициирует и получает. LSA маршрутизатора (локальный администратор безопасности) не переносят адреса или снабжают префиксом информацию.

Stub_Router#

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 2)

  Routing Bit Set on this LSA
  LS age: 753
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Router Links
  Link State ID: 0
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000007
  Checksum: 0xFCA4
  Length: 40
  Area Border Router
  Number of Links: 1

    Link connected to: another Router (point-to-point)
      Link Metric: 64
      Local Interface ID: 5
      Neighbor Interface ID: 5
      Neighbor Router ID: 3.3.3.3


  LS age: 791
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Router Links
  Link State ID: 0
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000008
  Checksum: 0x178A
  Length: 40
  Number of Links: 1

    Link connected to: another Router (point-to-point)
      Link Metric: 64
      Local Interface ID: 5
      Neighbor Interface ID: 5
      Neighbor Router ID: 1.1.1.1

LSA переносят поле Options, которое имеет эти биты:

  • V6 укусил — Указывает, должен ли маршрутизатор/ссылка использоваться в маршрутизации вычисления.

  • R бит — Это - "Бит маршрутизатора". Это указывает, является ли инициатор активным маршрутизатором.

  • DC укусил — Указывает на обработку маршрутизатора Канала Требования.

Ссылка show ipv6 ospf database самопроисходит , команда показывает, что LSA Ссылки переносят специфичные для ссылки адреса.

Stub_Router#show ipv6 ospf database link self-originate

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Link (Type-8) Link States (Area 2)

  LS age: 627
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Link-LSA (Interface: Serial0/0)
  Link State ID: 5 (Interface ID)
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000006
  Checksum: 0x215C
  Length: 56
  Router Priority: 1
  Link Local Address: FE80::D20E:16FF:FE50:0
  Number of Prefixes: 1
  Prefix Address: 2002:ABAB::
  Prefix Length: 64, Options: None

  LS age: 828
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Link-LSA (Interface: Serial0/0)
  Link State ID: 5 (Interface ID)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000006
  Checksum: 0xB4C2
  Length: 56
  Router Priority: 1
  Link Local Address: FE80::D20D:16FF:FE50:0
  Number of Prefixes: 1
  Prefix Address: 2001:ABAB::
  Prefix Length: 64, Options: None

Поскольку Тупиковый маршрутизатор принадлежит Общим-образом-изолированной-области, Маршрутизатор ABR1 передает только маршрут по умолчанию к Тупиковому маршрутизатору.

Stub_Router#
show ipv6 route

IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OI  ::/0 [110/65]
     via FE80::D20E:16FF:FE50:0, Serial0/0
C   2001:ABAB::/64 [0/0]
     via ::, Serial0/0
L   2001:ABAB::D20D:16FF:FE50:0/128 [0/0]
     via ::, Serial0/0
O   2002:ABAB::/64 [110/128]
     via FE80::D20E:16FF:FE50:0, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

Маршрутизатором ABR1 является Пограничный маршрутизатор области.

ABR1#
show ipv6 ospf

 Routing Process "ospfv3 1" with ID 1.1.1.1
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x00A1E0
 Number of areas in this router is 2. 1 normal 1 stub 0 nssa
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 5 times
        Number of LSA 8. Checksum Sum 0x052E71
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 2
        Number of interfaces in this area is 1
        It is a stub area, no summary LSA in this area
          generates stub default route with cost 1
        SPF algorithm executed 6 times
        Number of LSA 7. Checksum Sum 0x042237
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Маршрутизатор ABR1 получает внешние маршруты (Маршруты RIP) от Граничного маршрутизатора автономной системы.

ABR1#
show ipv6 route

IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O   2001:ABAB::/64 [110/128]
     via FE80::D20D:16FF:FE50:0, Serial0/0
C   2002:ABAB::/64 [0/0]
     via ::, Serial0/0
L   2002:ABAB::D20E:16FF:FE50:0/128 [0/0]
     via ::, Serial0/0
C   2003::/124 [0/0]
     via ::, FastEthernet0/0
L   2003::1/128 [0/0]
     via ::, FastEthernet0/0
OE1  2003::1:0/124 [110/26]
     via FE80::D20F:BFF:FE24:0, FastEthernet0/0
OE1  2004:ABAB::/64 [110/26]
     via FE80::D20F:BFF:FE24:0, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

Граничным маршрутизатором автономной системы является Граничный маршрутизатор автономной системы для сети. Это связано с сетью RIP через Последовательный интерфейс 0/0.

ASBR#
show ipv6 ospf

 Routing Process "ospfv3 1" with ID 2.2.2.2
 It is an autonomous system boundary router
 Redistributing External Routes (with default metric 25) from,
    rip with metric-type 1 include-connected
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x00A1E0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 2 times
        Number of LSA 8. Checksum Sum 0x052E71
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

ASBR#
show ipv6 rip

RIP process "EXT", port 521, multicast-group FF02::9, pid 156
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 69, trigger updates 6
  Interfaces:
    Serial0/0
  Redistribution:
    Redistributing protocol ospf 1 include-connected

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

отладка ipv6

Как только OSPFv3 включен на Тупиковом маршрутизаторе, он отсылает Тип OSPFv3 1 Приветственное сообщение в FF02:: 5 адресов групповой адресации. Как только это получает Пакеты приветствия от Маршрутизатора ABR1, они выполняют согласование о Ведущем устройстве/Подчиненном отношении и затем начинают передавать Пакеты dbd.

Stub_Router#debug ipv6 ospf events

Stub_Router# debug ipv6 ospf packet
*Mar  1 00:14:20.999: OSPFv3: rcv. v:3 t:1 l:36 rid:1.1.1.1
      aid:0.0.0.2 chk:142A inst:0 from Serial0/0
*Mar  1 00:14:21.023: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:EB8A inst:0 from Serial0/0
*Mar  1 00:14:21.027: OSPFv3: rcv. v:3 t:1 l:40 rid:1.1.1.1
      aid:0.0.0.2 chk:E1C inst:0 from Serial0/0
*Mar  1 00:14:21.027: OSPFv3: 2 Way Communication to 1.1.1.1 on Serial0/0, state 2WAY
*Mar  1 00:14:21.027: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1737 opt 0x0011 
flag 0x7 len 28
*Mar  1 00:14:21.031: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x2402 opt 0x0011 
flag 0x7 len 28  mtu 1500 state EXSTART
*Mar  1 00:14:21.031: OSPFv3: First DBD and we are not SLAVE
*Mar  1 00:14:21.035: OSPFv3: rcv. v:3 t:2 l:88 rid:1.1.1.1
      aid:0.0.0.2 chk:5CF3 inst:0 from Serial0/0
*Mar  1 00:14:21.039: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1737 opt 0x0011 flag 
0x2 len 88  mtu 1500 state EXSTART
*Mar  1 00:14:21.039: OSPFv3: NBR Negotiation Done. We are the MASTER
*Mar  1 00:14:21.039: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1738 opt 0x0011 flag 
0x3 len 88
*Mar  1 00:14:21.043: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:F85B inst:0 from Serial0/0
*Mar  1 00:14:21.047: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1738 opt 0x0011 flag 
0x0 len 28  mtu 1500 state EXCHANGE
*Mar  1 00:14:21.047: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1739 opt 0x0011 flag 
0x1 len 28Send LS REQ to 1.1.1.1 length 36 LSA count 3
*Mar  1 00:14:21.051: OSPFv3: rcv. v:3 t:3 l:52 rid:1.1.1.1
      aid:0.0.0.2 chk:C326 inst:0 from Serial0/0
*Mar  1 00:14:21.055: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:F85A inst:0 from Serial0/0

Как только Пакетами dbd обмениваются, маршрутизаторы отправляют Запрос Состояния канала (REQ LS) и Обновление состояния соединения (UPD LS) сообщения для построения их LSDB. После последовательного REQ LS и сообщений UPD LS, и когда состояние достигает FULL, маршрутизаторы продолжают обмениваться Пакетами приветствия.

Stub_Router#
*Mar  1 00:14:21.055: OSPFv3: rcv. v:3 t:4 l:144 rid:1.1.1.1
      aid:0.0.0.2 chk:58BC inst:0 from Serial0/0Rcv LS REQ from 1.1.1.1 on Serial0/0 length 52 
LSA count 3Send UPD to 131.88.101.156 on Serial0/0 length 128 LSA count 3
*Mar  1 00:14:21.059: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1739 opt 0x0011 flag 
0x0 len 28  mtu 1500 state EXCHANGE
*Mar  1 00:14:21.063: OSPFv3: Exchange Done with 1.1.1.1 on Serial0/0Rcv LS UPD from 
1.1.1.1 on Serial0/0 length 144 LSA count 3
*Mar  1 00:14:21.067: OSPFv3: Synchronized with 1.1.1.1 on Serial0/0, state FULL
*Mar  1 00:14:21.067: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/0 from 
LOADING to FULL, Loading Done
*Mar  1 00:14:21.687: OSPFv3: rcv. v:3 t:4 l:60 rid:1.1.1.1
      aid:0.0.0.2 chk:66EB inst:0 from Serial0/0Rcv LS UPD from 1.1.1.1 on Serial0/0 length 60 
LSA count 1
*Mar  1 00:14:23.683: OSPFv3: rcv. v:3 t:5 l:96 rid:1.1.1.1
      aid:0.0.0.2 chk:4BB5 inst:0 from Serial0/0

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 112100