Голосовая связь и система унифицированных коммуникаций : Cisco Unified Border Element

Высокая доступность (HA) Cisco Unified Border Element Использование примера конфигурации HSRP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Унифицированный граничный элемент Cisco (CUBE) позволяет строить системы высокой доступности (HA) за счет конфигураций с физической избыточностью, реализуемых на платформе маршрутизатора Cisco ISR 2-го поколения (ISR G2). Физическое резервирование CUBE усиливает длинную доступную основанную на маршрутизаторе технологию маршрутизатора протокола маршрутизации с горячим резервированием (HSRP).

Технология HSRP предоставляет высокий уровень доступности сети путем маршрутизации IP - трафика от хостов в сетях, не полагаясь на доступность никакого одиночного маршрутизатора. HSRP используется в группе маршрутизаторов для выбора Активного маршрутизатора и Резервного маршрутизатора. HSRP контролирует обоих внутренние и внешние интерфейсы – если какой-либо интерфейс выключается, целое устройство рассматривают вниз, Резервное устройство становится активным и берет на себя ответственность Активного маршрутизатора.

Физическое резервирование использует протокол HSRP для формирования HSRP Активная/Резервная пара маршрутизаторов. Активная/Резервная пара совместно использует тот же виртуальный IP - адрес и непрерывно обменивается сообщениями о статусе. Информация о сеанса CUBE отмечена контрольной точкой по Активной/Резервной паре маршрутизаторов. Если Активный маршрутизатор должен пойти вне обслуживания для запланированного или незапланированных причин, это позволяет Резервному маршрутизатору сразу взять на себя всю ответственность обработки вызова CUBE.

Физическое резервирование CUBE HA сохранение сред поддержки внедрения по переключателю HSRP ВЫЗОВОВ SIP SIP, но никакая передача вызовов сохранено. Эта возможность поддерживается с Cisco Выпуск ПО IOS� 15.1.2T. Сохранение передачи вызовов поддерживается в последнем Cisco IOS Software Release 15.2.3T.

Примечание: Для получения дополнительной информации обратитесь к Cisco Unified Border Element независимые от протокола Функции и Руководство по конфигурации Настройки, Cisco IOS Release 15.2M&T .

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

  • Базовые знания о том, как настроить и использовать Обмен голосовыми данными с помощью Cisco IOS

  • Базовые знания о том, как настроить и использовать CUBE

  • Базовые знания о том, как высокая доступность HSRP работает на общие платформы маршрутизатора

Основные требования для того, чтобы установить физическое резервирование CUBE ISR G2 включают:

  • Два идентичных ISR G2s, оборудованные лицензией Комплексной технологии UC (SL-29-UC-K9 или SL-39-UC-K9) установленный, память DRAM 1G и Cisco IOS Software Release 15.1.2T или позже

  • Оба маршрутизатора должны быть физически расположены на той же Локальной сети Ethernet.

  • Конфигурация CUBE обоих маршрутизаторов идентична и должна быть вручную скопирована от одного маршрутизатора до другого.

  • Один маршрутизатор определяется активный маршрутизатор HSRP, вторым является Резерв. Существуют небольшие различия в конфигурации HSRP между Активными и резервными маршрутизаторами.

  • Потоки ВЫЗОВА SIP SIP

Используемые компоненты

Сведения в этом документе основываются на минимальном релизе программного обеспечения CUBE 8.5 (Cisco IOS Release 15.1.2T), внедренный на Cisco 2900 или Поколении 2 Маршрутизатора Интегрированного сервиса серии 3900 (ISR G2).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Общие сведения

Физическое резервирование требует двух идентичных платформ ISR-G2: один настроенный как Активное, другой как Резерв. HSRP настроен на физических интерфейсах для формирования группы HSRP.

Если существует сбой передачи контрольных сообщений, когда Активный маршрутизатор выключается, второй Резервный маршрутизатор принимает адреса IP routing первого маршрутизатора и продолжает передавать те же пакеты RTP, которые ранее маршрутизировались к первому маршрутизатору.

Потоки RTP установленных вызовов отмечены контрольной точкой между Активными и резервными маршрутизаторами через протокол HSRP. Поэтому потоки мультимедиа установленных вызовов сохранены по аварийному переключению HSRP от Активного до Резервных маршрутизаторов. Разъединены вызовы в переходном состоянии (вызовы, которые еще не установлены или находятся в процессе того, чтобы быть модифицируемым с передачей или держат функцию) во время аварийного переключения. Кроме того, любые вызовы с помощью сервисов DSP, таких как перекодировка не сохранены.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Конфигурация HSRP CUBE придерживается определенного заказа шагов, который включает:

  1. Включите резервирование CUBE и CUBE

  2. Включите HSRP

  3. Настройте транспорт связи HSRP

  4. Настройте HSRP на интерфейсах

  5. Настройте таймеры HSRP

  6. Настройте таймер бездействия носителя

  7. Настройте привязку SIP с адресом HSRP

  8. Повторно загрузите маршрутизаторы

  9. Укажите подключенные программные коммутаторы к виртуальному адресу HSRP CUBE

Повторно загрузите обоих маршрутизаторы после того, как будут завершены шаги 1-5. Повторная загрузка требуется только, когда HSRP настроен впервые на маршрутизаторе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

Эта схема показывает топологию Активной/Резервной пары маршрутизаторов ISR G2, используемых в развертываниях магистрали SIP между Cisco Unified Communications Manager (CUCM) и магистралью SIP поставщика услуг (SP) для доступа к тфоп.

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-01.gif

Шаг 1: Включите резервирование CUBE и CUBE

Включите CUBE на обоих маршрутизаторах:

voice service voip 
  mode border-element
  allow-connections sip to sip

Включите резервирование CUBE и установку контрольных точек вызова на обоих маршрутизаторах:

voice service voip 
  redundancy

Шаг 2 ---- -------------------------------- --------- : Включите HSRP

Включите схемы резервирования маршрутизатора на обоих маршрутизаторах, где:

  • схема – схема отслеживания состояния избыточности

  • резерв – включает резерв (HSRP) государственное отслеживание схемы

  • SB – имя группы резервного режима HSRP

redundancy inter-device
  scheme standby SB

Шаг 3: Настройте транспорт связи HSRP

Настройте Транспорт Связи Межустройства HSRP следующим образом:

Активная конфигурация:

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13

Резервная конфигурация:

ipc zone default
  association 1
   no shutdown
   protocol sctp
     local-port 5000
       local-ip 10.10.24.13
     remote-port 5000
       remote-ip 10.10.24.14

Примечание: Выход от “локального sctp” побуждает настраивать удаленные параметры SCTP следующим образом:

XFR-2(config)#ipc zone default
XFR-2(config-ipczone)#association 1
XFR-2(config-ipczone-assoc)#protocol sctp 
XFR-2(config-ipc-protocol-sctp)#no sh
XFR-2(config-ipczone-assoc)#protocol sctp
XFR-2(config-ipc-protocol-sctp)#local-port 5000
XFR-2(config-ipc-local-sctp)#local-ip 10.10.24.13
XFR-2(config-ipc-local-sctp)#exit
XFR-2(config-ipc-protocol-sctp)#remote-port 5000
XFR-2(config-ipc-remote-sctp)#remote-ip 10.10.24.14
XFR-2(config-ipc-remote-sctp)#end

Это пояснение полей, используемых в этой конфигурации:

  • ipc zone default – Настраивает Протокол связи Межустройства (IPC) и вводит режим конфигурации зоны IPC. Используйте эту команду для инициирования соединения связи между Активным и Резервными устройствами.

  • ассоциация 1 – Настраивает ассоциацию между этими двумя устройствами и вводит режим конфигурации ассоциации IPC. Под этим настройте подробные данные ассоциации, такие как транспортный протокол, локальный порт, local IP address, удаленный порт и удаленный IP-адрес. Допустимые ID ассоциации колеблются от 1 до 255. Нет никаких ID ассоциации по умолчанию.

  • no shutdown Перезапускает отключенную ассоциацию и ее cвязанный транспортный протокол. Для любых изменений к параметрам транспортного протокола эта ассоциация должна быть завершением.

  • sctp протокола – Настраивает Протокол SCTP как транспортный протокол для этой ассоциации и включает режим конфигурации протокола SCTP.

  • port_num local-port – Определяет локальный номер порта SCTP для использования для передачи с избыточным узлом.

  • ip_addr локального IP – Определяет IP-адрес локального маршрутизатора для использования для передачи с избыточным узлом. local IP address должен совпасть с удаленным IP-адресом на избыточном маршрутизаторе.

  • port_num remote-port – Определяет удаленный номер порта SCTP для использования для передачи с избыточным узлом.

  • удаленный IP ip_addr – Определяет удаленный IP-адрес равного маршрутизатора, используемого для передачи с локальным устройством. Все удаленные IP-адреса должны указать к тому же устройству.

Примечание: Local-port и remote-port должны быть установлены в 5000 на Активных и резервных маршрутизаторах.

Шаг 4. : Настройте HSRP на интерфейсах

Настройте Транспорт Связи Межустройства HSRP следующим образом:

Активная конфигурация

interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

Резервная конфигурация

interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt		  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

Это - пояснение полей, используемых в этой конфигурации:

  • 0/6 – Определяет Количество Резервной группы.

  • keepalive – Позволяет поддержке активности для HSRP следить за развитием/вниз событий.

  • резервная задержка – Задерживает инициализацию HSRP, пока не произошел физический интерфейс.

  • резерв x ip – Определяет действительный IP-адрес IPv4, разделенный между Активным и Резервными устройствами. Эта команда включает HSRP на интерфейсе.

  • резерв x вытесняет – Позволяет маршрутизатору становиться активным маршрутизатором, когда приоритет выше, чем все другие настроенные маршрутизаторы HSRP в группе горячего резервирования. Если вы не используете команду standby preempt в конфигурации для маршрутизатора, тот маршрутизатор не становится активным маршрутизатором, даже если приоритет выше, чем все другие маршрутизаторы.

  • резерв x приоритет – Определяет приоритет Горячего резервирования, используемый в выборе активного маршрутизатора. Это колеблется от 1 до 255, где 1 обозначает самый низкий приоритет и 255 наивысший приоритет.

    Примечание: В случаях, где приоритет режима ожидания является тем же, устройство с более высоким IP-адресом принимает роль Активного маршрутизатора.

  • резерв x название – Определяет название резервной группы, которая совпадает со схемой, определенной в шаге 2 (“SB”). Для несколько групп HSRP используется тот же standby name, как только одна резервная схема позволена в конфигурациях.

  • резерв 6 дорожек 1 декремент 10 – Определяет приоритетное отслеживание. Для получения дополнительной информации об отслеживании интерфейса щелкнуть здесь.

  • интервал bfd 500 множителей min_rx 500 3 – Определяет Двунаправленное Передающее Обнаружение.

Для предотвращения состояний гонки, когда загрузки маршрутизатора и интерфейс подходит для установления контакта (“Hello”) между Активными и резервными маршрутизаторами также рекомендуется настроить придерживающееся:

interface GigabitEthernet0/0
  standby delay minimum 30 reload 60

Для получения дополнительной информации об этой команде щелкнуть здесь.

Шаг 5: Настройте таймеры HSRP

Существует два важных таймера HSRP:

  • Таймер приветствия: Интервал между успешными сообщениями приветствия HSRP от заданного маршрутизатора. Этот таймер может быть настроен в секундах или миллисекундах под интерфейсом HSRP. Значение по умолчанию составляет 3 секунды.

  • Таймер удержания: Интервал между приемом приветственного сообщения и предположением о сбое на отправляющем маршрутизаторе. На этот раз может быть настроен в секундах или миллисекундах под интерфейсом HSRP. Значение по умолчанию составляет 8 секунд.

В конфигурациях в шаге 4 Пакет приветствия HSRP и Таймеры Ожидания установлены в их значения по умолчанию. Поэтому они не обнаруживаются явно в конфигурациях. Рекомендуемые значения для Таймеров Hello/Ожидания являются значениями по умолчанию.

Примечание: Если необходимо использовать нестандартные значения, необходимо настроить каждый маршрутизатор для использования того же Времени приветствия и значений таймера Ожидания.

Hello и таймеры Ожидания могут быть настроены под интерфейсом HSRP использование придерживающегося CLI:

Router(config-if)#standby 0 timers ?
  <1-254>  Hello interval in seconds
  msec     Specify hello interval in milliseconds

Router (config-if)#standby 0 timers 2 ?
  <3-255>  Hold time in seconds
  msec     Specify hold interval in milliseconds
Router(config-if)#standby 0 timers 2 msec 40

В предыдущей конфигурации Таймер приветствия установлен в 2 секунды и таймер Ожидания к 40 миллисекундам.

Примечание: Можно понизить настройки таймера для ускорения аварийного переключения или приоритетного прерывания обслуживания. Однако для предотвращения использования повышенной загрузки CPU и ненужной переброски резервного состояния рекомендуется не установить Таймер приветствия меньше чем в 1 секунду, и таймер Ожидания меньше чем в 4 секунды.

Шаг 6: Настройте таймер бездействия носителя

Если никакие пакеты Протокола RTP не получены в настраиваемом периоде времени, Таймер бездействия носителя позволяет Активному парному / Резервному маршрутизатору, парному контролировать и разъединить вызовы.

Когда пакеты RTP для вызова не получены Активным / Резервным маршрутизатором, Таймер бездействия носителя SIP освобождает сеанс. Это используется для принятия мер против любых зависаний сеанса, которые, возможно, следовали из аварийного переключения, если разъединение обычного вызова не очищает вызов.

Та же продолжительность для Таймера бездействия носителя должна быть настроена на обоих маршрутизаторах. Значение по умолчанию составляет 28 секунд. Этот таймер настроен следующим образом:

ip rtcp report interval 3000
gateway
  media-inactivity-criteria all
  timer receive-rtp 86400
  timer receive-rtcp 5

Шаг 7: Настройте привязку SIP с адресом HSRP

Настройте SIP CUBE, обменивающийся сообщениями для использования виртуального адреса HSRP в обмене сообщениями SIP.

dial-peer voice 100 voip
  description to-SIP
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1

Как только HSRP настроен под физическим интерфейсом, и команда bind была выполнена, вызовы к физическому IP-адресу откажут. Это вызвано тем, что SIP, слушая сокет теперь связан с виртуальным IP - адресом, но пакеты сигнализации используют физический IP-адрес, и поэтому не могут быть обработаны.

Шаг 8: Повторно загрузите маршрутизаторы

Как только все вышеупомянутые конфигурации были завершены, выходные данные show резервирования следующие:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
  Pending Scheme: Standby (Will not take effect until next reload)
      Pending Groupname: b2bha
  Scheme: <NOT CONFIGURED>
  Peer present: UNKNOWN
  Security: Not configured

После повторной загрузки маршрутизатора конфигурация HSRP включена следующим образом:

Активный маршрутизатор

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
  Scheme: Standby
      Groupname: b2bha Group State: Active
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

Резервный маршрутизатор

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
  Scheme: Standby
      Groupname: b2bha Group State: Standby
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

Шаг 9: Укажите подключенные программные коммутаторы к виртуальному адресу HSRP CUBE

CUCM, IP-PBX, прокси SIP или SP SBCs или программные коммутаторы SP, которые направляют вызовы к CUBE, должны использовать виртуальный адрес HSRP в их обмене сообщениями SIP. Сообщения SIP к CUBE физические IP-адреса не обработаны через конфигурацию HSRP.

Полные примеры конфигурации для с дублированный подсоединением резервирования HSRP CUBE

Вот конфигурации полной выборки и для Активных и для Резервных маршрутизаторов CUBE. В этих конфигурациях Пакет приветствия HSRP и таймеры Ожидания используют их значения по умолчанию 3 и 8 секунд соответственно и не показаны явно в выходных данных CLI.

Конфигурация активного маршрутизатора

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
   standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

Конфигурация резервного маршрутизатора

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.13
      remote-port 5000
        remote-ip 10.10.24.14
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

Полный пример конфигурации для одиночно подключенного резервирования HSRP CUBE

В то время как с дублированный подсоединением CUBE является наиболее распространенной конфигурацией, специально для соединений магистрали SIP SP, также возможно настроить физическое резервирование HSRP CUBE с одиночно подключенными развертываниями CUBE, как дали в этом разделе.

Конфигурация активного маршрутизатора

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.8
     remote-port 5000
       remote-ip 1.2.175.12
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.8 255.255.0.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
 standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

Конфигурация резервного маршрутизатора

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.12
     remote-port 5000
       remote-ip 1.2.175.8
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.12 255.255.0.0
  duplex auto
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
  standby 0 priority 50
		standby 0 preempt
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

Удаление HA конфигураций

Выполните эти шаги для удаления ранее введенной конфигурации HSRP из маршрутизатора CUBE:

  1. Удалите конфигурацию резервирования прикладного уровня.

    Router(config)#voice service voip 
    Router(config-voice service voip)#no redundancy
  2. Удалите резервную схему, настроенную под режимом межконфигурации устройства.

    Router(config)#redundancy inter-device 
    Router(config-red-interdevice)#no scheme standby b2bha
    % Redundancy interdevice scheme change will not take effect until 
    configuration is saved and device reloaded
  3. Сохраните изменения конфигурации к памяти и повторно загрузите маршрутизатор.

    Router(config)#write
    Router#reload
  4. После повторной загрузки выполните эту команду, чтобы проверить, что был отключен HSRP:

    Router#show redundancy inter-device
    Redundancy inter-device state: RF_INTERDEV_STATE_INIT
      Scheme: <NOT CONFIGURED>
      Peer present: UNKNOWN
      Security: Not configured
    
  5. Отключите ассоциацию между этими двумя устройствами и удалите конфигурацию SCTP.

    Router(config)#ipc zone default
    Router(config-ipczone)#association 1
    Router(config-ipczone-assoc)#shutdown
    Router(config-ipczone-assoc)#no protocol sctp
    Router(config-ipczone-assoc)#no association 1
    Router(config-ipczone)#exit
    Router(config)#no ipc zone default
  6. Удалите конфигурацию HSRP из интерфейса при помощи форм “нет” команд HSRP.

    Router(config)#interface gigabitEthernet 0/0
    Router(config-if)#no standby 0 name
    Router(config-if)#no standby 0 priority 
    Router(config-if)#no standby 0 ip
  7. Save configuration changes.

    Router(config)#write

Примечания использования функции

  • Два маршрутизатора, используемые для пары HSRP, должны быть идентичными (для обеспечения той же производительности и уровня емкости вызовов).

  • Поддержка конфигурации физического резервирования на потоках ВЫЗОВОВ SIP SIP, транспорт SIP может быть или UDP UDP или TCP UDP

  • Виртуальные адреса HSRP поддерживают только адресацию IPv4.

  • Поток мультимедиа установленных вызовов сохранен по аварийному переключению, но сигнализация не. Поэтому сохраненные вызовы не могут модифицироваться (Ожидание/Резюме, передача, конференция, и т.д.).

  • Вызывает дополнительные сервисы включения, такие как перекодировка, взаимодействие DTMF, IVR, SIP-TLS, RSVP, STUN, преобразование SRTP RTP, или факс/функции модема не сохранен в аварийном переключении.

  • Видеопотки не сохранены после переключателя, невзирая на то, что может быть сохранен аудиопоток.

  • Несколько групп HSRP на маршрутизатор поддерживаются, но только одиночная группа HSRP на физический интерфейс.

  • Адреса обратной связи с HSRP не поддерживаются, команда bind SIP должна использовать виртуальный IP - адрес HSRP.

  • Синхронизация настроек между Активным и резервным маршрутизатором является ручной, нет никакой автоматизации. Изменения конфигурации должны быть сделаны вручную к обоим маршрутизаторам.

Проверка.

Используйте CLI ниже, чтобы проверить, что конфигурация HSRP является корректной и рабочей.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Проверьте состояние избыточности

Проверьте состояние избыточности с межустройством show redundancy и командами show redundancy state. Эти команды показывают информацию о redundancy inter-device, такую как состояния redundancy inter-device.

Прежде чем межконфигурация устройства сделана, выходные данные show следующие:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Protocol: <NOT CONFIGURED>

XFR-2#show redundancy states
my state = 3  -NEGOTIATION 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Down      Reason: Simplex mode

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

После того, как межконфигурация устройства сделана, но перед перезагрузкой маршрутизатора, выходные данные show следующие:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
Pending Scheme: Standby (Will not take effect until next reload)
Pending Groupname: b2bha
Scheme: <NOT CONFIGURED>
Peer present: UNKNOWN
Security: Not configured

После перезагрузки маршрутизатора выходные данные show следующим образом показывают состояние “Init”:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Peer present: UNKNOWN
Security: Not configured

CUBE_XFR#show redundancy states 
my state = 3  -NEGOTIATION 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (this unit is still initializing)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Во время переключателя например Активный маршрутизатор не работает и в то время как Резервный маршрутизатор переключается к становлению Активным, выходные данные show следующие:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

После переключателя, но прежде чем маршрутизаторы обменивались сообщениями о статусе Hello, выходные данные show следующие:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_HSRP_STDBY_PNC
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

После обмена сообщениями о статусе Hello выходные данные show следующие:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
  
XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 8  -STANDBY HOT 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (peer unit not yet in terminal standby state)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0  
 
CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
        
CUBE_XFR#show redundancy states
my state = 8  -STANDBY HOT 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = cannot be initiated from this the standby unit
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Проверьте состояние протокола HSRP

Проверьте состояние протокола HSRP с командой show standby brief. Эта команда показывает краткие выходные данные на HSRP включая интерфейсы HSRP, Количество Резервной группы, Приоритеты, Активные и Резервные IP - адреса, а также виртуальные IP - адреса. Команда show standby дает полные, подробные сведения.

Router1#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active     Standby      Virtual IP
Gi0/0       0    50    Active  local      9.13.25.134  9.13.25.22

Router2#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active       Standby  Virtual IP
Gi0/0       0    50    Standby 9.13.25.133  local    9.13.25.22

Проверьте Режим вызова после Переключателя

Команда show voice high-availability summary используется для подтверждения:

  • Установка контрольных точек запросов к Резервному маршрутизатору после переключателя

  • Когда вызовы закончены, бездействие сред рассчитывает на Активное

  • Когда оба типа вызовов присутствуют, проверять для собственного компонента и несобственного компонента (например, сохраненный) звонит

  • Определить присутствие пропущенного RTP, HA, сеансов SPI

Покажите установку контрольных точек запросов к Резервному маршрутизатору после переключателя

В данном примере 800 вызовов были отмечены контрольной точкой от Активного до Резерва после переключателя.

CUBE_XFR#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 3100
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state STANDBY HOT
Peer current rf state ACTIVE
Voice HA Standby is not available.
System has not experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer NOT READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 0
Total number of checkpoint requested received (Standby): 971
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 800
Media Inactivity event count: 0

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
Checkpoint get buffer failure count: 0

Покажите, что бездействие сред рассчитывает на Активное, когда вызовы закончены

В данном примере 800 вызовов очищены таймером бездействия носителя.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 4213
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state ACTIVE
Peer current rf state STANDBY HOT
Voice HA Active and Standby are in sync.
System has experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
   Checkpoint get buffer failure count: 0

Проверять для собственного компонента и несобственного компонента (сохранило) вызовы, когда оба присутствуют

Количество запросов к системе показывают следующим образом:

  • Общее число вызовов = “Количество вызовов в DB HA” + “Количество вызовов в синхронизовании HA DB в состоянии ожидания”. Это равняется 100 + 50 = 150 в примере выходных данных ниже.

  • Общее число сохраненных (несобственных) вызовов = “Количество вызовов в HA сохранило DB сеанса”. Это 70 в примере выходных данных ниже.

  • Общее число собственных вызовов (вызовы, установленные начиная с аварийного переключения и поэтому не сохраненное по аварийному переключению), является различием в предыдущих двух количестве. В данном примере это 150 – 70 = 80.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 100
Number of calls in HA sync pending DB: 50
Number of calls in HA preserved session DB: 70

Определить присутствие пропущенного RTP, HA, сеансов SPI

Общее число сохраненных (несобственных) вызовов, очищенных бездействием сред, = “Общее количество, СОЗДАЮТ полученный на Резерве” – “Общее количество, УДАЛЯЮТ полученный на Резерве” как выходные данные ниже показов. Сравните это количество с “Количеством события Media Inactivity”, а также количество сред вниз события, показанные выходными данными команды show voip fpi stats.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

Проверьте связывания IP-адреса SIP

Команда show sip-ua status отображает SIP обязательный статус.

Router1#show sip-ua status
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED

SIP User Agent for TLS over TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
Snapshot of SIP listen sockets : 2
            Local Address      Listen Port  Secure Listen Port
=============================  ===========  ==================
 10.10.25.14                     5060         5061
 10.10.24.14                     5060         5061
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 70

Проверьте текущее использование ЦПУ

Команда show process cpu history используется для подтверждения процента загрузки ЦПУ через определенные промежутки времени.

Проверьте загрузку ЦПУ прежде, чем выполнить переключатель и продолжите принудительное аварийное переключение только, когда загрузка ЦПУ составит меньше чем 70%. Команда show process cpu sorted может также быть выполнена неоднократно для понимания загрузку ЦПУ для определенного процесса.

Проверьте, Что Вызовы Обрабатываются Во время Переключателя

Команда show sip-ua statistics используется для подтверждения сбросов вызова во время переключателя путем проверки количества ПОКА сообщений. Идеты звонок во время переключателя отброшены. Только установленные вызовы сохранены.

Команда show interface accounting используется для подтверждения подтверждения коммуникационного тракта во время переключателя.

Router#show interfaces g0/0 accounting
GigabitEthernet0/0 
Protocol  Pkts In   Chars In   Pkts Out   Chars Out
Other     1         58         6          360
IP        406       178841     201        16394
ARP       569       34292      0          0
CDP       116       31672      22         7304

Регистрируйте IP “Pkt” и “Pkt” счетчики – они должны увеличиваться на разумной скорости. Например, при использовании пакетизации G.711 20 мс и no VAD необходимо видеть, что счетчики пакетов увеличиваются на приблизительно 50 каждую секунду.

Принуждение аварийного переключения в ручном режиме для тестирования

Физическое резервирование с помощью поддержки HSRP переключение с синхронизацией состояния сред вызовов, что означает среды (RTP) вызовов, сохранено, но не сигнализация. В то время как вызовы в переходном состоянии (неактивное состояние, коммуникационный тракт не в “sendrecv” режиме подключения) не сохранены во время переключателя, Поэтому только вызовы в активном состоянии (коммуникационный тракт в “sendrecv” режиме подключения) сохранены.

Переключает появление в реальных средах, где существует постоянная смесь вызовы в переходном процессе (настройка вызова или модифицируемый) и установленное состояние, всегда будет определенное число вызовов, отброшенных во время аварийного переключения. Общее количество ожидаемых разрывов связи может быть оценено: (0.3 + держать-таймер HSRP) * CPS.

Завершите процедуру ниже, чтобы вынудить переключение вручную проверить, что конфигурация и операция корректны.

Для обеспечения плавного Принудительного переключения сделайте придерживающееся:

  • Контролируйте % загрузки ЦПУ на Активной/Резервной паре. Активное будет иметь повышенную загрузку ЦП, поскольку она активно обрабатывает вызовы, в то время как Резерв покажет 0 загрузок ЦПУ, поскольку это является простаивающим, пока не происходит переключатель.

  • Гарантируйте, что переключение вручную выполнено, когда загрузка ЦПУ Активного маршрутизатора - не больше, чем 70%. Все переключатели приводят к скачку в загрузке ЦПУ.

  • Используйте команды покажите соединение voip rtp и show voice high-availability summary, чтобы удостовериться, что существующие вызовы синхронизировались по Активному парному / парному Резервному маршрутизатору.

Переключатель HSRP включает раньше повторная загрузка Активного маршрутизатора, в то время как раньше Резервный маршрутизатор вступает во владение и становится новым Активным маршрутизатором, обрабатывающим новые вызовы и поддерживающим потоки мультимедиа для сохраненных вызовов, пока они не завершены. Новый Активный маршрутизатор останется как Активный маршрутизатор, пока не произойдет другой переключатель.

(Вызванные) переключатели руководства могут быть достигнуты любым из этих способов:

  • Инициируйте его CLI “сила действия избыточной коммутации” на Активном маршрутизаторе.

  • Повторная загрузка Активного маршрутизатора

  • "Жесткий" перезапуск Активного маршрутизатора

  • Вытащите интерфейсный кабель HSRP или шнур питания Активного маршрутизатора.

  • Завершите работу интерфейса HSRP Активного маршрутизатора.

  • Изменение в любом параметре интерфейса HSRP Активного / Резервного маршрутизатора, не завершая ассоциация под режимом IPC приводит к перезагрузке маршрутизатора. Поэтому интерфейс должен быть завершением, прежде чем любые изменения будут внесены, пока вы не используете это в качестве спускового механизма для принуждения переключателя.

Команда show voip rtp connections показывает количество активных соединений на обоих Активные и резервные маршрутизаторы после переключателя.

Команда show call active voice brief не показывает выходных данных на Резервном маршрутизаторе после переключателя, потому что сигнальная информация не отмечена контрольной точкой.

Шаги, чтобы выполнить и проверить одиночный переключатель

Выполните следующие действия:

  1. Настройте физическое резервирование HSRP согласно Настраивать разделу в этом документе.

  2. Повторно загрузите и поддержите оба маршрутизатора в rommon.

  3. Загрузите один маршрутизатор. После того, как это произошло, выполните команду show redundancy state и удостоверьтесь, что это показывает мое состояние как Активное и одноранговое состояние как Отключенное. Это может требовать времени, после загружаются.

    XFR-2#show redundancy states
    my state = 13 -ACTIVE 
    peer state = 1  -DISABLED
  4. Загрузите второй маршрутизатор. После того, как это произошло, выполните команду show redundancy state, чтобы удостовериться, что это показывает мое состояние как Резервно-горячее и одноранговое состояние как Активное.

    CUBE_XFR#show redundancy states
    my state = 8  -STANDBY HOT 
    peer state = 13 -ACTIVE
  5. Запустите один или несколько вызовов по системе. Выполните команды покажите речевую сводку высокой доступности и show voip rtp connection на обоих Активные и резервные маршрутизаторы, чтобы удостовериться, что вызовы закончились и отмеченный контрольной точкой.

  6. Тестовый переключатель путем повторной загрузки Активного маршрутизатора. При использовании телефона для совершения вызовов, можно слушать телефон, чтобы удостовериться, что сохранен коммуникационный тракт. При использовании тестового оборудования можно использовать пакетные показы, чтобы определить, текут ли среды для вызовов:

    Router#show interfaces g0/0 accounting
    GigabitEthernet0/0 
    Protocol  Pkts In   Chars In   Pkts Out   Chars Out
    Other     1         58         6          360
    IP        406       178841     201        16394
    ARP       569       34292      0          0
    CDP       116       31672      22         7304
  7. Тестовое бездействие сред: Остановите вызов. Повторное соединение rtp voip показа. После истечения таймера бездействия носителя не должно быть никаких более активных RTP - подключений. Можно также проверить это через команду show voice high-availability summary и искать:

    Router#show voice high-availability summary | include media
    Media Inactivity event count: 1

    Media Inactivity event count должен показать 1.

Снимки экрана для подтверждения одиночного вызова, сохраненного по аварийному переключению

Показ перед аварийным переключением:

  • Активный маршрутизатор (#01)

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-02.gif

  • Резервный маршрутизатор (#02)

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-03.gif

Повторная загрузка Активного маршрутизатора (#01) для принуждения аварийного переключения:

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-04.gif

Резервный маршрутизатор (#02) вступает во владение как новый Активный, вызов сохранен (Резерв = Новый Активный):

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-05.gif

Ранее Активный маршрутизатор (#01) повторные загрузки как новый Резервный маршрутизатор и вызов сохранен на новом Резерве.

  • Новый Резерв (#01) маршрутизатор:

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-06.gif

  • Новый Активный (#02) маршрутизатор:

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-07.gif

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

Они показывают, и команды отладки полезны во время устранения проблем физического резервирования:

show redundancy state
show redundancy inter-device
show standby brief
show standby internal
show sip-ua status
show sip-ua statistics
show voice high-availability summary
show voip rtp connection | include connection
show arp
debug voip ccapi all
debug voip ccapi error
debug voip rtp session
debug voip rtcp session
debug voip rtp error
debug voip rtcp error
debug voice high-availability all
debug voice high-availability error
debug ccsip info
debug ccsip messages
debug ccsip media
debug ccsip error
debug standby terse

Примечание: Не включайте большое число отладок в системе, переносящей большой объем трафика активного вызова.

Примечание: На каждом переключателе, после перезагрузки маршрутизатора, отладкам нужно реактивировать на новом Резервном маршрутизаторе.

Каждый маршрутизатор в группе HSRP участвует в протоколе путем осуществления простого механизма состояний. Все маршрутизаторы начинаются в Первоначальном состоянии.

  1. Начальный: Это исходное состояние, которое показывает, что HSRP не запущен. Это состояние введено при помощи изменения конфигурации или во время первой установки интерфейса.

  2. Учитесь: маршрутизатор не определил виртуальный IP - адрес, и еще не видел аутентифицированное приветственное сообщение от активного маршрутизатора. В этом состоянии маршрутизатор по-прежнему ждет сигнала от активного маршрутизатора.

  3. Слушайте: маршрутизатор знает виртуальный IP - адрес, но не является ни один активным или резервным маршрутизатором. Он слушает приветственные сообщения от этих маршрутизаторов.

  4. Говорите: Маршрутизатор направляет периодические приветственные сообщения и активно участвует в процессе выбора активного и/или резервного маршрутизатора. Маршрутизатор не может перейти в состояние разговора, если у него нет виртуального IP-адреса.

  5. Standby Маршрутизатор может стать следующим активным маршрутизатором и периодически посылает сообщения приветствия., Исключая переменные состояния, там MUST быть самое большее одним маршрутизатором в группе в Резервном состоянии.

  6. Активный: маршрутизатор в настоящее время передает пакеты, которые передаются действительному адресу MAC/IP группы. Маршрутизатор периодически посылает сообщения приветствия. Помимо переменных состояний, там MUST быть самое большее одним маршрутизатором в Активном состоянии в группе.

Совет по устранению неполадок: Почему там два Активных маршрутизатора?

Когда оба маршрутизатора не в состоянии видеть Пакеты приветствия HSRP от друг друга, это происходит.

  • Проверьте, может ли каждый маршрутизатор пропинговать адрес IP - интерфейс других. В противном случае тогда связь между маршрутизаторами не работает.

  • Используйте команду debug standby, чтобы видеть, передают ли маршрутизаторы и/или получают Пакеты приветствия HSRP. Если узел передает Hellos, но они не получаются тогда команды show interface или show controller проверки, чтобы видеть, слушает ли интерфейс адрес групповой адресации HSRP.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 112095