Голосовая связь и система унифицированных коммуникаций : Cisco Unified Border Element

Пример конфигурации Unified Border Element (CUBE) с Cisco Unified Communications Manager (CUCM)

14 мая 2010 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (31 октября 2007) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Настройка
      Варианты конфигурации
      Настройка пользовательского агента SIP
      Соединение с Cisco Unified Communications Manager
      Перекодирование на граничном элементе Cisco Unified Border Element
      Использование интерактивного автоответчика со сценариями Tcl в Cisco Unified Border Element
      Пример полной конфигурации
Проверка
Устранение неполадок
      Команды для устранения неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

Cisco Unified Border Element позволяет легко и с минимальными затратами организовывать соединение между магистральными каналами SIP в корпоративной среде унифицированных коммуникаций и коммутируемой телефонной сетью общего пользования (ТфОП). Cisco Unified Border Element (CUBE) – это интегрированное приложение Cisco IOS®, ориентированное на потребности аппаратных граничных контроллеров сеансов (SBC) в корпоративных окружениях и системах провайдеров услуг.

  • Маршрутизаторы с интеграцией сервисов Cisco серии 2800

  • Маршрутизаторы с интеграцией сервисов Cisco серии 3800

  • Платформы с мультисервисным доступом Cisco серии 2600XM

  • Маршрутизаторы Cisco серии 3700

  • Маршрутизаторы Cisco 7200VXR

  • Маршрутизаторы Cisco 7301

  • Шлюзы доступа Cisco AS5400XM и AS5350XM

С точки зрения поддержки перспективных сервисов прямые соединения по протоколу IP между сетями унифицированных коммуникаций обеспечивают большую степень гибкости по сравнению с традиционными коммутируемыми телефонными сетями общего пользования (ТфОП) на основе TDM-мультиплексирования.

Cisco Unified Border Element предоставляет точку интерфейса между сетями, которую можно использовать для следующих целей:

  • взаимодействие между сигнальными протоколами – H.323, SIP;

  • взаимодействие между различными типами передающих сред (DTMF, факс, модем, перекодировка посредством кодеков);

  • преобразование адресов и портов (сокрытие личных данных и топологии);

  • выставление счетов и нормализация записей детализации вызовов (CDR);

  • управление качеством обслуживания (QoS) и полосой пропускания: маркировка QoS с использованием дифференцированных числовых кодов служб (DSCP), типов служб (ToS), принудительное регулирование полосы пропускания с использованием протокола резервирования ресурсов [RSVP] и фильтрация кодеков.

Граничный элемент Cisco Unified Border Element способен взаимодействовать с широким кругом различных сетевых элементов, включая голосовые шлюзы, IP-телефоны и серверы управления вызовами в различных прикладных средах, включая развитые корпоративные системы голосовой связи и/или видеосвязи с использованием Cisco Unified Communications Manager или Cisco Unified Communications Manager Express, а также более простые транспортные приложения для обхода междугородних АТС и голосовой связи по IP (VoIP).

Cisco Unified Border Element предоставляет организациям все функции граничного контроллера в составе сетевого уровня для объединения архитектур предприятия и провайдера услуг в части систем унифицированных коммуникаций для голосовой связи и видеосвязи. Cisco Unified Border Element может использоваться крупными предприятиями, равно как малыми и средними организациями для объединения систем доступа к ТфОП на основе протокола SIP с корпоративными сетями унифицированных коммуникаций на основе SIP и H.323.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к приложению Cisco Unified Border Element (CUBE).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе в действующей сети необходимо понимать последствия выполнения любой команды.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание. Для поиска дополнительной информации о командах, приведенных в данном документе, используйте инструмент Command Lookup Tool (только для зарегистрированных пользователей).

Варианты конфигурации

Эта конфигурация активирует на платформе основные функциональные возможности Cisco Unified Border Element. Эти возможности включают в себя оконечную обработку входящих вызовов VoIP и их ретрансляцию в исходящем режиме с оконечного устройства VoIP. Вызовы могут выполняться между устройством, использующим H.323, и SIP-устройством либо между двумя SIP-устройствами.

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

При настройке точек оконечной обработки входящих и исходящих вызовов укажите соответствующий протокол, тип двухтонального многочастотного набора (DTMF) и параметры кодека.

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

Настройка пользовательского агента SIP

Для регистрации и аутентификации настройте пользовательский агент (UA) протокола SIP.

Пользовательский агент SIP

sip-ua
registrar ipv4:10.1.1.10
or
registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

Соединение с Cisco Unified Communications Manager

Cisco Unified Communications Manager можно соединить с Cisco Unified Border Element по магистральному каналу унифицированных коммуникаций H.323 или SIP.

Соединение с Cisco Unified Border Element по магистральному каналу H.323

Определить магистраль H.323 к Cisco Unified Border Element в Cisco Unified Communications Manager можно двумя способами:

  • с гейткипером – настраивается магистраль H.225 (под управлением гейткипера) к Cisco Unified Border Element;

  • без гейткипера – Cisco Unified Border Element настраивается в качестве шлюза H.323.

Требования к точке подключения передающей среды (MTP):

  • при осуществлении посредством Cisco Unified Border Element вызовов между двумя устройствами H.323 использовать MTP не требуется при условии использования Cisco Unified Border Element 12.4(6)T или более позднего выпуска и Cisco Unified Communications Manager 4.1 или более поздней версии;

  • аппаратная или программная точка MTP может быть размещена в составе того же маршрутизатора, что и Cisco Unified Border Element (на платформах маршрутизаторов, поддерживающих передаточные MTP CUCM, в т.ч. маршрутизаторах с интеграцией сервисов серий Cisco 2800 и 3800).

Требования для использования функции быстрого соединения H.323:

  • при организации взаимодействия между H.323 и SIP для Cisco Unified Communications Manager посредством Cisco Unified Border Element большинство прокси-серверов SIP требуют осуществления вызовов SIP в режиме упреждающего объявления (Early Offer). Это подразумевает, что сторона H.323 должна функционировать в режиме быстрого соединения (Fast Start). Следовательно, Cisco Unified Communications Manager необходимо настроить в режиме быстрого соединения H.323 как для входящих, так и для исходящих вызовов, для чего также требуется точка MTP.

На рис. 1 показана конфигурация, в которой Cisco Unified Border Element является шлюзом H.323 на Cisco Unified Communications Manager.

Рис. 1. Конфигурация с использованием Cisco Unified Border Element в качестве шлюза H.323 на Cisco Unified Communications Manager

/image/gif/paws/99863/cube-config01.gif

cube-config02.gif

На рис. 2 показана конфигурация Cisco Unified Border Element, соответствующая предыдущей конфигурации Cisco Unified Communications Manager.

Рис. 2. Конфигурация Cisco Unified Border Element для магистрального канала H.323

cube-config03.gif

Соединение с Cisco Unified Border Element по магистральному каналу SIP

Для задания магистрали унифицированных коммуникаций SIP до Cisco Unified Border Element необходимо использовать Unified Communications Manager 5.x или более поздних версий.

Требования к точкам MTP:

  • магистраль SIP без MTP. Магистраль унифицированных коммуникаций SIP без точки подключения передающей среды (MTP) следует настраивать в том случае, если допускается отложенное подключение передающей среды или приглашение без пакета протокола SDP;

  • магистраль SIP с MTP. Магистраль унифицированных коммуникаций SIP (с точкой MTP) следует настраивать при упреждающем подключении передающей среды и необходимости приглашений с SDP (только в случае вызовов G.711).

На рис. 3 показана конфигурация, в которой на Cisco Unified Border Element определена магистраль унифицированных коммуникаций SIP до Cisco Unified Communications Manager.

Рис. 3. Конфигурация Cisco Unified Border Element с магистралью SIP на Cisco Unified Communications Manager

/image/gif/paws/99863/cube-config04.gif

На рис. 4 показана конфигурация Cisco Unified Border Element, соответствующая предыдущей конфигурации Cisco Unified Communications Manager.

Рис. 4. Конфигурация Cisco Unified Border Element для магистрали SIP

/image/gif/paws/99863/cube-config05.gif

Размещение точки MTP на одном маршрутизаторе с Cisco Unified Border Element

Если для конфигурации Cisco Unified Communications Manager требуется программная точка MTP, ее можно настроить на том же маршрутизаторе, который используется для Cisco Unified Border Element.

Настройка MTP на Cisco Unified Border Element выполняется следующим образом:

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

Перекодирование на граничном элементе Cisco Unified Border Element

Cisco Unified Border Element может выполнять перекодирование между G.711 с µ- и a-характеристиками, а также различными разновидностями G.729. Перекодирование может быть активировано для любого вызова, как из Cisco Unified Communications Manager в сеть ТфОП, так и из сети ТфОП на Cisco Unified Communications Manager. Главный критерий – использование разных кодеков (G.711 и G.729) на двух участках маршрута вызова, между которыми находится Cisco Unified Border Element . Для настройки перекодирования на Cisco Unified Border Element необходимо наличие сигнальных процессоров (DSP) на платформе.

Настройка перекодирования на Cisco Unified Border Element выполняется следующим образом:

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

Использование интерактивного автоответчика со сценариями Tcl в Cisco Unified Border Element

Cisco Unified Border Element поддерживает сценарии на языке Tcl, которые можно настроить на уровне оконечных точек VoIP. Для использования сценариев Tcl сигнальный процессор не требуется. В составе программного обеспечения IOS Cisco имеется ряд готовых встроенных Tcl-приложений, которые можно использовать в среде Cisco Unified Border Element. Функции аутентификации, авторизации и учета (AAA) в Cisco IOS можно также использовать совместно с Tcl-сценариями и Cisco Unified Border Element для обеспечения аутентификации и авторизации вызовов.

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

Пример полной конфигурации

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa new-model
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip 

!--- key command

allow-connections sip to h323 

!--- key command

allow-connections sip to sip 

!--- key command

allow-connections h323 to h323 

!--- key command

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard 

!--- TCL Application

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric 

!--- DTMF config for h.245 alphanumeric

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte 

!--- DTMF config for RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
registrar ipv4:200.1.1.10 or registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Интерпретатор выходных данных – OIT (доступный только зарегистрированным пользователям) поддерживает ряд команд show. Посредством OIT можно анализировать выходные данные команд show.

Примечание. Перед использованием команд debug обратитесь к документу Важные сведения о командах отладки.

  • logging. Важно настроить Cisco Unified Border Element для ведения журналов, как показано в этом примере, и по возможности выполнять отладку в те периоды, когда нагрузка не достигает пиковых значений, поскольку команды отладки формируют большой объем выходных данных.

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • show. Эта команда отображает непосредственные выходные данные.

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • debug. Перед осуществлением телефонного вызова в режиме отладки не забудьте очистить журнал, а по завершении вызова – сохранить выходные данные команды show logging.

    Сценарии соединения H.323 – H.323

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    Сценарии соединения H.323 – SIP

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    Сценарии соединения SIP – SIP

    debug ccsip all
    debug voip ccapi inout
  • debug. В дополнение к командам отладки для описанного выше сценария необходимо активировать следующие команды отладки транскодера:

    debug dspfarm all
    debug sccp messages
  • debug voip rtp session named-events – в случае использования RFC2833 (dtmf-relay rtp-nte) необходимо также активировать эту команду debug.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Document ID: 99863