Голосовая связь и система унифицированных коммуникаций : Cisco Unified Border Element

Унифицированный элемент границы (CUBE) с унифицированной видеоконференцсвязью (CUVC) пример конфигурации IVR

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Принятие на основе IP передач видеоданных в предприятии идет хорошо полным ходом. В сегодняшней экономической обстановке клиенты используют видео более часто в качестве программного средства для связи внутрикомпании с основными преимуществами этого принятия, являющегося усилениями и в эффективности работы сотрудника и в в рабочем состоянии эффективности.

Большая часть предприятия на основе IP сети передач видеоданных сегодня походит на острова относительно других таких корпоративных сетей, соединенных с помощью более старой технологии Цифровой сети с интеграцией услуг (ISDN). ISDN очень обычно используется для всего дополнительного предприятия или связи дополнительного кампуса с другими компаниями и, в некоторых случаях, даже с удаленными ответвлениями в самом предприятии. Далеко идущие преимущества на основе IP передач видеоданных могут действительно быть поняты со сквозной возможностью подключения с помощью IP-адреса в или между организациями для упрощения связи (B2B) для корпоративных клиентов. Это требует перехода от ISDN до на основе IP решений, которые пересекают Интернет вместо PSTN, включая менее дорогую установившуюся опцию для внутрикомпании и связи B2B.

Оптовый переход от цепей ISDN до IP - подключений через Интернет не является тривиальным обязательством. Цепи ISDN и видео шлюзы, которые связывают ISDN в на основе IP мир передач видеоданных, являются широко развернутыми, доказанными временем и надежными решениями. Несмотря на ограничения в размещении сервисов передач видеоданных следующего поколения, ISDN все еще устанавливает норму, против которой новые решения измерены при учете безопасности, конфиденциальности, составления счетов и разграничения. Новые решения должны предложить подобные обеспечения уровня обслуживания для предприятий и поставщиков услуг для рассмотрения их как реальную альтернативу. Предприятиям таким образом нужен способ поддержать все преимущества, привязанные к ISDN при использовании эффективности расширения на основе IP передач видеоданных вне предприятия.

Этот пример конфигурации выделяет функции Cisco Unified Border Element (CUBE) и в частности иллюстрирует, как CUBE поддерживает способность к оконечной точке, которая находится где-нибудь в Интернете для набора номера через IP-адрес к Устройству управления многосторонней связью (MCU) или оконечной точке, которая находится позади корпоративного межсетевого экрана. Эта функциональность демонстрирует функцию замены null-called-number, доступную в 12.4 (22) выпуск септибайта CUBE 1.3 и функциональных возможностей IVR, доступных в 5.6 выпусках Cisco Унифицированная Видеоконференцсвязь (CUVC) MCU. Этот документ содержит рекомендации по конфигурации и возможные отправные точки для предприятий, предпринимающих это развитие.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Базовые знания о том, как настроить и использовать Обмен голосовыми данными с помощью Cisco IOS (такой как точки вызова)

  • Базовые знания о том, как настроить и использовать CUBE

  • Основное понимание того, как работают межсетевые экраны

Используемые компоненты

Информация в данном документе основана на следующих положениях:

  • Cisco Unified Border Element и Сторожевое устройство Cisco IOS, которое работает на маршрутизаторе Cisco 2800 и использует Cisco IOS Release 12.4.22 (септибайт) или Cisco IOS Release 15.0.1M

  • Видеоконференцсвязь IP Cisco 3545 Решений, которые работают под управлением ПО версии 5.6 или позже

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

Эта схема показывает CUBE внешние оконечные точки, надежно набирающие в сеть заказчика через внутренний IP-адрес оконечной точки.

/image/gif/paws/111313/cube-cuvc-01.gif

Поток вызовов схемы

  1. Внешняя оконечная точка в Интернете набирает открытый IP - адрес CUBE (192.168.1.2) для присоединения к видеоконференции, которая находится на внутреннем Устройстве управления многосторонней связью (MCU) Cisco. Сообщения настройки вызова H.323 поступают в CUBE на основании начального крошечного отверстия для порта TCP 1720, настроенный в устройстве адаптивной защиты Cisco (ASA), который является межсетевым экраном, который предоставляет границу безопасности для сети. В данном примере CUBE имеет закрытый IP - адрес так публично, маршрутизируемый адрес, предназначенный внешней оконечной точкой, является результатом статического NAT (Трансляция сетевых адресов), выполненная ASA.

    Примечание: В целях рисунка Cisco использует только пробелы закрытого IP - адреса в документации.

  2. Так как сообщение входящей настройки не включает обычные цифры набора, которыми CUBE обычно предназначался бы для следующего участка вызова, CUBE использует цифры (1234567890) настроенный командой настройки замены null-called-number. Использование этого адреса, сообщения настройки вызова продолжаются к сети внутреннего потребителя.

  3. ASA имеет два крошечных отверстия для поддержки этого этапа вызова: один, чтобы позволить CUBE поиску нужный адрес через Внутреннюю функцию Сторожевого устройства CUVC-M и один позволять результирующему Сообщению SETUP от CUBE добираться до CUVC-M для установления вызова к MCU на основе адреса E.164, настроенного в точке вызова на CUBE. Используя функцию контроля H.323 на ASA, остающаяся сигнализация и среды текут, TCP и UDP - подключения открыты динамично согласно информации, подбираемой от сигнализации настройки вызова.

  4. Внутреннее Сторожевое устройство CUVC-M направляет вызов к IPVC-MCU, который включает новую видео функцию IVR, которая представляет графическое меню Options внешнему пользователю. По этому меню перемещаются путем ввода Тонов DTMF через наборную панель или дистанционное управление оконечной точкой вызова. Конечный пользователь просто выбирает идентификатор конференции от опции меню конференции по соединению и затем вводит необходимый пароль, если настроено.

  5. Внутренняя оконечная точка видео присоединяется к конференции путем набора номера того же идентификатора конференции как внешняя оконечная точка.

Конфигурации

Эти конфигурации используются в данном документе:

Конфигурация CUBE
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname cube1
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9_ivs-mz.124-22.YB.bin
boot-end-marker
!
ip source-route
!
!
multilink bundle-name authenticated
!
!
!
voice service voip
  allow-connections h323 to h323
  h323
  emptycapability
  null-called-number override 1234567890
  h225 start-h245 on-connect
  call start slow 
  h245 passthru all
!
!
!
voice class h323 10
!
!
voice-card 0
!
!
!
!
interface GigabitEthernet0/0
 ip address 172.16.1.100 255.255.255.0
 ip route-cache same-interface
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip id vgk1 ipaddr 172.16.1.100 1719 priority 1 

!--- vgk1 defines zone the cube to register with the local Gatekeeper service
 
 h323-gateway voip h323-id cube1

!--- Defines the ID of CUBE
 
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 172.16.1.100
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip http server
no ip http secure-server
!
!
!
!
dial-peer voice 1 voip
destination-pattern .T

!--- To match outbound call leg to send to GK process

session target ras
incoming called-number .

!--- For inbound call leg

codec transparent



!
!
gateway
timer receive-rtp 1200
!
!
!
gatekeeper
zone local vgk1 cisco.com 
zone remote CUVCM cisco.com 10.1.1.26 invia vgk1 outvia vgk1
enable-intrazone
zone prefix CUVCM 1234567890
gw-type-prefix 1#* default-technology
no use-proxy GK1 default inbound-to terminal
no use-proxy GK1 default outbound-from terminal
bandwidth interzone default 1000000
no shutdown
!

end

Конфигурация ASA
ASA Version 8.2(1)
! 

!--- This is only a portion of the ASA config.
!--- In a typical production scenario, these commands would
!--- be in addition to the current security policies configured.

!
interface Ethernet0/0
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/0.2
 vlan 2
 nameif inside
 security-level 100
 ip address 10.1.1.1 255.255.255.0 
!
interface Ethernet0/0.12
 vlan 12
 nameif dmz
 security-level 50
 ip address 172.16.1.1 255.255.255.0 
!
interface Ethernet0/0.500
 vlan 500
 nameif outside
 security-level 0
 ip address 192.168.1.2 255.255.255.0 
!
boot system disk0:/asa821-k8.bin
ftp mode passive
clock timezone CDT -6
access-list dmz-in extended permit icmp any any 
access-list dmz-in extended permit udp host 172.16.1.100any eq 1719 
access-list dmz-in extended permit tcp host 172.16.1.100any eq h323

!--- The access list allows CUBE address lookups and call
!--- signaling respectively to get to the interior of the network.

!
access-list outside_access_in extended permit icmp any any 
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq h323 
access-list outside_access_in extended permit udp any host 192.168.1.2 eq 1719

!--- The access list allows exterior call setups and address
!--- look ups respectively to get to the CUBE.

!  
! 
access-list inside-to-DMZ-exemption extended permit ip 10.0.0.0 255.0.0.0 10.150
.150.0 255.255.255.0

!--- This access list prevents the global NAT translation intended
!--- for the outside interface from being used on the conversations
!--- between internal endpoints and CUBE.

!
mtu inside 1500
mtu dmz 1500
mtu outside 1500
nat-control
global (outside) 1 192.168.1.5-192.168.1.100 netmask 255.255.255.0

!--- Note that the general NAT pool should not overlap the
!--- ASA interface nor the static NAT used for CUBE.

!
nat (inside) 0 access-list inside-to-DMZ-exemption
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 1 172.168.1.0 255.255.255.0
static (dmz,outside) 192.168.1.2 172.16.1.100 netmask 255.255.255.255

!--- The previous statement is what establishes the publicly
!--- routed address for CUBE on the outside interface.

! 
access-group dmz-in in interface dmz
access-group outside_access_in in interface outside
route inside 10.0.0.0 255.255.255.0 10.1.1.2 1
route outside 0.0.0.0 0.0.0.0 192.168.1.254 1

!--- These two static route statements assume the existence of
!--- a next hop router on both inside and outside interfaces.

!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:10:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:10:00 h225 1:00:00 mgcp 0:10:00 mgcp-pat 0:10:00

!--- Note: It is a good idea to increase the H.225 timeout. Not all endpoints
!--- send enough traffic on this connection to keep it alive. The H.225 command
!--- includes the H.245 attributes.

!
policy-map global_policy
 class inspection_default
  inspect h323 h225 
  inspect h323 ras

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Этот образ показывает Сторожевое устройство Cisco IOS, добавляемое к Cisco Unified Videoconferencing Manager. Модель Сторожевого устройства Cisco IOS выбрана в выпадающем списке.

cube-cuvc-02.gif

Этот образ показывает проверку в разделе Управления ресурсами Cisco Унифицированный Менеджер Видеоконференцсвязи, что Сторожевое устройство Cisco IOS было добавлено успешно. Здесь вы видите Сторожевое устройство H.323 Cisco IOS, перечисленное с IP-адресом 172.16.1.100.

cube-cuvc-03.gif

Этот образ показывает конфигурацию Автоответчика в Cisco Унифицированная Видеоконференцсвязь, которая отображает адрес e.164 (1234567890), который соответствует Пустому вызываемому номеру, настроенному на CUBE.

cube-cuvc-04.gif

Это отображает, показывает то, что Cisco IVR Видео IPVC передаст обратно в Оконечную точку видео вызова. Использование дистанционного управления или контроля за клавиатурой оконечной точки видео, пользователь выбирает видео, встречающееся через DTMF (внутриполосный), который размещен на MCU CUVC, и присоединитесь к соответствующему видео совещанию.

/image/gif/paws/111313/cube-cuvc-05.gif

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 111313