Маршрутизаторы : Маршрутизаторы Cisco ISR серии 3800

VPN AnyConnect (SSL) клиент на маршрутизаторе IOS с примером конфигурации CCP

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (22 сентября 2010) | Английский (29 февраля 2016) | Отзыв

Введение

Этот документ описывает, как установить маршрутизатор Cisco IOS® для выполнения VPN Уровня защищенных сокетов (SSL) на палке с Клиентом AnyConnect VPN Client Cisco с помощью Cisco Configuration Professional (CCP). Эта настройка применяется к конкретному случаю, где AnyConnect на маршрутизаторе настроен с разделенным туннелированием, и это позволяет клиентский безопасный доступ корпоративным ресурсам и также предоставляет необеспеченный доступ к Интернету.

VPN SSL или технология WebVPN поддерживаются на большинстве платформ маршрутизатора, таких как Поколение 1 Маршрутизатора ISR (ISR), Поколение 2 (Обратитесь продукты ISR для списка продуктов ISR). Клиентам рекомендуют обратиться руководство навигатора функции для получения полного списка платформ Cisco IOS, которые поддерживают VPN AnyConnect (SSL) клиент (или любая другая функция / технология в этом отношении). Эта информация доступна в Навигаторе Функции.

CCP на основе GUI программное средство управления устройствами, которое позволяет вам настраивать Cisco на основе IOS маршрутизаторы доступа. CCP установлен на ПК и упрощает маршрутизатор, безопасность, унифицированную связь, радио, глобальную сеть (WAN) и основные конфигурации LAN через на основе GUI, простые в использовании мастера.

Внесенный Брэтином Саа и Рахулом Говиндэном, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Подходящая клиентская операционная система. Обратитесь Комментарии к выпуску AnyConnect для поддерживаемых операционных систем.

  • Web-браузер с Версией JRE 1.4 SUN или позже или ActiveX управлял браузером

  • Права локального администратора у клиента

  • Маршрутизатор Cisco IOS с образом улучшенной безопасности версии 12.4(20)T или более поздней версии

  • Версия 1.3 Cisco Configuration Professional или позже

Если Cisco Configuration Professional уже не загружен на вашем компьютере, можно получить бесплатный экземпляр программного обеспечения и установить .exe (cisco-config-pro-k9-pkg-2_8-en.zip) файл от Загрузки программного обеспеченияДополнительные сведения об установке и настройке CCP можно найти в документе Руководство по началу работы с Cisco Configuration Professional.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Серия Cisco IOS маршрутизатор CISCO2811 с версией программного обеспечения 15.1 (4) M8

  • Версия 2.8 CCP

  • Версия VPN-клиента SSL (SVC) AnyConnect Cisco для Windows 3.1.05160

Данные для документа были получены в специально созданных лабораторных условиях. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. Если используемая сеть является действующей, убедитесь в понимании возможного влияния любой из применяемых команд.

Настройка

Схема сети

В настоящем документе используется следующая схема сети:

Предварительные действия

  1. Настройте маршрутизатор для CCP.

    Маршрутизаторам с соответствующей лицензией связки (bundle) безопасности уже загрузили приложение CCP во Флэше. См. Краткое руководство по началу работы Cisco Configuration Professional , чтобы получить и настроить программное обеспечение.

  2. Загрузите копию VPN-клиента Anyconnect (PKG-файл) на ваш управляющий компьютер.

Конфигурации

В этом разделе вам предоставляют шаги, необходимые для настройки функций, описанных в этом документе. Конфигурация данного примера использует Мастера CCP для включения использования VPN Anyconnect на маршрутизаторе IOS.

Выполните эти шаги, чтобы настроить Anyconnect VPN на маршрутизаторе Cisco IOS:

  1. Установите CCP и обнаружьте маршрутизатор Cisco IOS.

  2. Установите и активируйте программное обеспечение Anyconnect VPN на маршрутизаторе Cisco IOS.

  3. Настройте SSL VPN контекст и SSL VPN шлюз с помощью мастера CCP.

  4. Настройте базу данных пользователей Anyconnect VPN.

  5. Настройте AnyConnect полный туннель.

Каждый из этих шагов описан более подробно в следующих разделах этого документа.

Шаг 1: Установите CCP и Обнаружьте маршрутизатор Cisco IOS

  1. Нажмите Router Status на окне CCP для просмотра информации об устройстве маршрутизатора.



  2. Нажмите Configure для начала конфигурации.



Шаг 2: Установите и включите программное обеспечение VPN Anyconnect на маршрутизаторе IOS

Выполните эти шаги, чтобы установить и включить программное обеспечение VPN Anyconnect на маршрутизаторе IOS:

  1. Откройте приложение CCP, перейдите, чтобы Настроить> Security, и затем нажать VPN.

  2.  Разверните SSLVPN и выберите Packages. 



    Гарантируйте, что Характеристика лицензирования VPN SSL установлена на устройстве, иначе вы могли бы показать предупреждение в предыдущем образе. Обратитесь ссылку Характеристики лицензирования для просмотра раздела Сведений о порядке оформления заказов.

  3.  В области "Cisco SSLVPN Client Software" нажмите кнопку Browse.

    Отобразится диалоговое окно "Select SVC location".



  4. Задайте местоположение образа Клиента AnyConnect VPN Client Cisco (выберите любую из этих двух доступных опций).

    • Если образ Клиента AnyConnect VPN Client Cisco находится во флэше - памяти маршрутизатора, нажмите  диалоговое окно кнопки с зависимой фиксацией File System маршрутизатора и нажмите Browse.





    • Если образ Клиента AnyConnect VPN Client Cisco не находится во флэше - памяти маршрутизатора, нажмите  диалоговое окно радио Моего компьютера и нажмите Browse.


  5.  Выберите образ клиента, который необходимо установить, и нажмите кнопку OK.

  6.  После указания местонахождения образа клиента нажмите кнопку Install.

  7.  Нажмите кнопку Yes, а затем OK. 

  8. Как только клиентский образ успешно установлен, вы получаете сообщение об успешном завершении. Нажмите OK, чтобы продолжить. 

  9. После того, как установленный, посмотрите детали установленного пакета под Безопасностью> VPN> VPN SSL> Пакеты.

Шаг 3: Настройте SSL VPN контекст и SSL VPN шлюз с помощью мастера CCP

Выполните эти шаги для настройки контекста VPN SSL и Шлюза VPN SSL:

  1.  Перейдите Configure > Security > VPN и выберите SSL VPN. 

  2. Нажмите SSL VPN Manager и затем нажмите  вкладку Create SSL VPN.



  3. Придерживайтесь приглашений для включения Аутентификации, авторизации и учета (AAA), если она уже не включена.









  4.  Установите переключатель в положение Create a New SSL VPN и нажмите кнопку Launch the selected task.  

    Отобразится диалоговое окно мастера настройки "SSL VPN Wizard".



  5.  Нажмите кнопку Next.



    Примечание: Если VPN SSL настроена под интерфейсом, через который вызван CP Cisco, это могло бы вызвать CP Cisco к disconnet от маршрутизатора. В то время как VPN SSL настроена под FastEthernet0/0 внешнего интерфейса (в данном примере, 10.105.130.149), как лучшая практика, можно обратиться к маршрутизатору Cisco IOS через CCP от внутреннего интерфейса (в данном примере, 10.106.44.141) или любой другой интерфейс.





  6. Введите IP-адрес нового SSL VPN-шлюза и уникальное имя SSL VPN-контекста.

    Можно создать различные SSL VPN-контексты для одного IP-адреса (SSL VPN-шлюза), но каждое имя должно быть уникальным. В данном примере используется следующий IP-адрес: https://10.105.130.149/

  7.  Нажмите Next и продолжите к следующему разделу.

Шаг 4: Настройте базу данных пользователей Anyconnect VPN

Для аутентификации можно использовать сервер AAA и/или локальных пользователей. В данном примере конфигурации для аутентификации используются локально созданные учетные записи пользователей.

Выполните эти шаги, чтобы настроить базу данных пользователей Anyconnect VPN:

  1. После завершения Шага 3 нажмите Locally на этой кнопке с зависимой фиксацией маршрутизатора, расположенной в диалоговом окне SSL VPN Wizard User Authentication.



    Данное диалоговое окно предназначено для внесения пользователей в локальную базу данных.

  2.  Нажмите кнопку Add и введите данные пользователя.



  3.  Нажмите кнопку OK и при необходимости добавьте пользователей.

  4. После того, как вы добавляете необходимых пользователей, нажимаете Next и продолжаете к следующему разделу.

Шаг 5. Настройте туннель Anyconnect

Выполните эти шаги для настройки туннеля Anyconnect и пула IP-адресов для пользователей:

  1. Поскольку Anyconnect предоставляет прямой доступ к ресурсам корпоративной внутренней сети, Список URL - адресов не необходим для настройки. Нажмите кнопку Next, расположенную в диалоговом окне "Configure Intranet Websites". 



  2.  Убедитесь, что установлен флажок Enable Full Tunnel. 



  3. Создайте пул IP-адресов, которые могут использовать клиенты контекста SSL VPN.

    Адресный пул должен соответствовать адресам, доступным и используемым в вашей сети интранет.

  4. Нажмите кнопку (...), расположенную рядом с полем "IP Address Pool" и выберите Create a new IP Pool. 

  5.  В диалоговом окне "Add IP Local Pool" введите название пула (например, новый) и нажмите кнопку Add. 



  6.  В диалоговом окне "Add IP address range" введите диапазон адресов для VPN-клиентов Anyconnect и нажмите кнопку OK.

    Примечание: Перед Версией 12.4 (20) T пул IP-адреса должен быть в диапазоне интерфейса, непосредственно связанного с маршрутизатором. Если вы хотите использовать другой диапазон пула, можно создать адрес обратной связи, привязанный к новому пулу для удовлетворения этого требования.



  7.  Нажмите кнопку OK.

  8. Настройте дополнительные параметры туннеля, такие как разделенное туннелирование, разделение DNS, параметры прокси браузера и серверы Системы доменных имен (DNS) и Сервиса имен Интернета для Windows (WINS).

    Примечание: Cisco рекомендует настроить, по крайней мере, серверы WINS и DNS.



    Выполните эти шаги для настройки дополнительных параметров туннеля, таких как разделенное туннелирование:

    1.  Нажмите кнопку Advanced Tunnel Options. 

    2.  Перейдите на вкладку DNS and WINS Servers и введите первичные IP-адреса серверов DNS и WINS. 



    3. Нажмите  вкладку Split Tunneling для настройки разделенного туннелирования.



      Возможность передавать через один интерфейс как защищенный трафик, так и открытый называется разделенным туннелированием. Раздельное туннелирование требует точного указания, какой трафик является защищённым и откуда он происходит, таким образом только указанный трафик попадает в туннель, в то время как другой передается в незашифрованном виде через публичную сеть (Интернет).

      В примере разделение туннеля настроено для включения трафика.


  9.  После настройки необходимых параметров нажмите кнопку Next. Выберите соответствующий Параметр интерфейса VPN-туннеля SSL и нажмите Next.



  10. Измените страницу портала SSL VPN или выберите значения по умолчанию.

    Окно "Customize SSL VPN Portal Page" позволяет вам изменить внешний вид страницы портала.



  11.  После внесения изменений на странице портала SSL VPN нажмите кнопку Next.

  12.  Нажмите кнопку Finish.



  13.  Нажмите кнопку Deliver, чтобы сохранить конфигурацию, а затем нажмите кнопку OK.  

    Мастер VPN SSL отправляет ваши команды маршрутизатору.





В основном это команды, которые освобождены от CCP до маршрутизатора:

AAA commands:

aaa new-model
aaa authorization exec default local
aaa authentication login default local
line vty 0 4
login authentication default
authorization exec default
exit

Remaining commands:

aaa authentication login ciscocp_vpn_xauth_ml_1 local
ip local pool IP_Pool 192.168.1.10 192.168.1.15
interface Virtual-Template1
exit
default interface Virtual-Template1
interface Virtual-Template1
no shutdown
ip unnumbered FastEthernet0/0
exit
webvpn gateway gateway_1
ip address 10.105.130.149 port 443
http-redirect port 80
inservice
ssl trustpoint TP-self-signed-1878971148
exit
webvpn context Test
aaa authentication list ciscocp_vpn_xauth_ml_1
gateway gateway_1
virtual-template 1
max-users 1000
inservice
secondary-color white
title-color #FF9900
text-color black
policy group policy_1
svc split include 10.106.44.0 255.255.255.0
svc keep-client-installed
functions svc-enabled
svc address-pool IP_Pool netmask 255.255.255.255
svc default-domain cisco.com
svc dns-server primary 10.106.44.10
svc wins-server primary 10.106.44.12
exit
default-group-policy policy_1
exit
! IP address / user account command
username user1 privilege 1 secret 0 *********

Примечание: При получении сообщения об ошибках лицензия VPN SSL могла бы быть неправильной.

Выполните эти шаги для исправления проблемы лицензии:

  1.  Перейдите Configure > Security > VPN и выберите SSL VPN. 

  2.  Щелкните SSL VPN Manager, а затем по вкладке Edit SSL VPN.  



  3.  Выделите созданный контекст и нажмите кнопку Edit. 



  4. В поле "Maximum Number of users" введите правильное количество пользователей для вашей лицензии.

  5.  Нажмите кнопку OK, а затем кнопку Deliver. 

    Команды записаны в файл конфигурации.

Конфигурация интерфейса командой строки CLI

CCP создает следующие конфигурации командных строк:

Router#show running-config
Building configuration...

Current configuration : 3590 bytes
!
! Last configuration change at 06:30:34 UTC Sat Nov 29 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login ciscocp_vpn_xauth_ml_1 local
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-1878971148
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1878971148
 revocation-check none
 rsakeypair TP-self-signed-1878971148
!
!
crypto pki certificate chain TP-self-signed-1878971148
 certificate self-signed 01
 3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
 31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
 69666963 6174652D 31383738 39373131 3438301E 170D3134 31313239 30353537
 32355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
 4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38373839
 37313134 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
 8100C77D F135BBCA 8A84DE7D A3330085 3694EC3B 9BAE2F94 AF19CAEC 89A4AA6A
 DC098301 AC996CA7 BE1C6AB2 BF4745F4 911E9812 97BC1A1F 15D1AFD0 384878C6
 8781D8A7 3BFCFCFF 5626EF1A BCF73C78 B07E4587 710B6F18 B4E0017F 807606EA
 03E398B0 A2DE06B6 2D39B122 32D82E1B 7AE55554 63D8BDD6 222CF884 C9D5570D
 74BD0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
 551D2304 18301680 1455F1A2 00753895 04EB04BE 13273EEF D48D86C6 84301D06
 03551D0E 04160414 55F1A200 75389504 EB04BE13 273EEFD4 8D86C684 300D0609
 2A864886 F70D0101 05050003 81810013 B72A05AE E7816FB7 377FC3B3 8EE7D2AC
 9211B78D 8B6A604A DA7D571F 6E083B78 279F0EB1 95B5ADC8 79572616 53B52B90
 1BF1A39B 46F8C88C 3335F498 E2CF5ABC 5D942A23 7DE35239 04D509EF 88E60201
 8B111BD6 FE82E159 67E05A62 03BFBCA6 E99EA1CE DA52F66A 8CE502C1 B9FAA488
 8A5B022A 3003F718 E8E1C6CC 2EB03C
       quit
!
!
license udi pid CISCO2811 sn FHK1404F3X2
username username privilege 15 secret 5 $1$hPnV$zwQ6MMwLA7HUC/NJRCMyt1
username user1 secret 5 $1$X3Vu$h5/xHipon7Fym16G2SCrz1
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip unnumbered FastEthernet0/0
!
ip local pool IP_Pool 192.168.1.10 192.168.1.15
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 transport input all
!
scheduler allocate 20000 1000
!
webvpn gateway gateway_1
 ip address 10.105.130.149 port 443
 http-redirect port 80
 ssl trustpoint TP-self-signed-1878971148
 inservice
 !
webvpn install svc flash:/webvpn/anyconnect-win-3.1.05160-k9.pkg sequence 1
 !
webvpn context Test
 secondary-color white
 title-color #FF9900
 text-color black
 ssl authenticate verify all
 !
 !
 policy group policy_1
  functions svc-enabled
  svc address-pool "IP_Pool" netmask 255.255.255.255
  svc default-domain "cisco.com"
  svc keep-client-installed
  svc split include 10.106.44.0 255.255.255.0
  svc dns-server primary 10.106.44.10
  svc wins-server primary 10.106.44.12
 virtual-template 1
 default-group-policy policy_1
 aaa authentication list ciscocp_vpn_xauth_ml_1
 gateway gateway_1
 inservice
!
end

Router#sh run int Virtual-Access2
Building configuration...

Current configuration : 104 bytes
!
interface Virtual-Access2
 description ***Internally created by SSLVPN context Test***
 mtu 1406
end

Установление подключения с помощью AnyConnect VPN Client

Выполните эти шаги для установления VPN-подключения AnyConnect с маршрутизатором.

Примечание: Добавьте маршрутизатор к списку надежных узлов в Internet Explorer. Для получения дополнительных сведений обратитесь к разделу Добавление устройства защиты/маршрутизатора в список доверенных сайтов (IE).

  1. Введите URL или IP-адрес маршрутизатора интерфейс WebVPN в вашем web-браузере в формате как показано.

    https://<url>


    Или

    https://<IP address of the Router WebVPN interface>


  2. Введите имя пользователя и пароль.



  3. Нажмите Start для инициирования туннельного соединения VPN Anyconnect.



    Это окно будет отображаться перед тем, как VPN-соединения по протоколу SSL будет установлено.



    Примечание: Программное обеспечение ActiveX должно быть установлено на вашем компьютере перед загрузкой VPN Anyconnect.





  4.  После успешного соединения перейдите на вкладку Statistics. 

    На вкладке "Statistics" отображается информация о SSL-соединении.



    Диалоговое окно Statistics Details отображает подробную статистическую информацию соединения, которая включает состояние туннеля и режим, продолжительность соединения, количество байтов и структурирует передаваемый и полученный, адресная информация, транспортная информация и статус оценки положения Cisco Secure Desktop. Кнопка "Reset" на этой вкладке служит для сброса статистической информации о переданных данных. Кнопка Stats Экспорта позволяет вам экспортировать текущую статистику, интерфейс и таблицу маршрутизации к текстовому файлу. При этом клиент AnyConnect выдаст запрос об имени и местоположении текстового файла . По умолчанию на рабочем столе создается файл AnyConnect-ExportedStats.txt.

  5. Проверьте подробные данные маршрута (на основе конфигурации разделения туннеля) под вкладкой Route Details.



  6. В диалоговом окне Cisco AnyConnect VPN Client нажмите  вкладку About для отображения Сведений о версии Cisco AnyConnect VPN Client.



Проверка

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Команды

Примечание: Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show.     Посредством OIT можно анализировать выходные данные команд show. 

 Некоторые команды show связаны с WebVPN. Можно выполнить эти команды в CLI для показа статистики и другой информации. Дополнительные сведения о командах show см. в разделе Проверка конфигурации WebVPN.  

покажите контексту сеанса webvnp все

Router#show webvpn session context all
WebVPN context name: Test
Client_Login_Name Client_IP_Address No_of_Connections Created Last_Used
user1             10.106.42.10               1        00:01:22 00:00:01

пользовательский Тест контекста user1 show webvpn session

Router#show webvpn session user user1 context Test detail
Session Type     : Full Tunnel
Client User-Agent : AnyConnect Windows 3.1.05160

Username         : user1               Num Connection : 1
Public IP        : 10.106.42.10        VRF Name      : None
Context          : Test                Policy Group  : policy_1
Last-Used        : 00:00:00            Created       : *06:33:24.505 UTC Sat
Nov 29 2014
Session Timeout  : Disabled            Idle Timeout  : 2100
DNS primary serve : 10.106.44.10        WINS primary s : 10.106.44.12
DPD GW Timeout   : 300                 DPD CL Timeout : 300
Address Pool     : IP_Pool             MTU Size      : 1199
Rekey Time       : 3600                Rekey Method  :
Lease Duration   : 43200
Tunnel IP        : 192.168.1.10        Netmask       : 255.255.255.255
Rx IP Packets    : 0                   Tx IP Packets : 617
CSTP Started     : 00:01:22            Last-Received : 00:00:00
CSTP DPD-Req sent : 0                   Virtual Access : 2
Msie-ProxyServer : None                Msie-PxyPolicy : Disabled
Msie-Exception   :
Split Include    : 10.106.44.0 255.255.255.0
Client Ports     : 60304

Detail Session Statistics for User:: user1
----------------------------------

CSTP Statistics::
Rx CSTP Frames   : 618               Tx CSTP Frames  : 0
Rx CSTP Bytes    : 46113             Tx CSTP Bytes   : 0
Rx CSTP Data Fr  : 617               Tx CSTP Data Fr : 0
Rx CSTP CNTL Fr  : 1                 Tx CSTP CNTL Fr : 0
Rx CSTP DPD Req  : 0                 Tx CSTP DPD Req : 0
Rx CSTP DPD Res  : 0                 Tx CSTP DPD Res : 0
Rx Addr Renew Req : 0                 Tx Address Renew : 0
Rx CDTP Frames   : 0                 Tx CDTP Frames  : 0
Rx CDTP Bytes    : 0                 Tx CDTP Bytes   : 0
Rx CDTP Data Fr  : 0                 Tx CDTP Data Fr : 0
Rx CDTP CNTL Fr  : 0                 Tx CDTP CNTL Fr : 0
Rx CDTP DPD Req  : 0                 Tx CSTP DPD Req : 0
Rx CDTP DPD Res  : 0                 Tx CDTP DPD Res : 0
Rx IP Packets    : 0                 Tx IP Packets   : 617
Rx IP Bytes      : 0                 Tx IP Bytes     : 41122

CEF Statistics::
Rx CSTP Data Fr  : 0                 Tx CSTP Data Fr : 0
Rx CSTP Bytes    : 0                 Tx CSTP Bytes   : 0

show webvpn stats

Router#show webvpn stats
User session statistics:
   Active user sessions    : 1         AAA pending reqs        : 0
   Peak user sessions      : 1         Peak time               : 00:02:29
   Active user TCP conns   : 1         Terminated user sessions : 0
   Session alloc failures  : 0         Authentication failures : 0
   VPN session timeout     : 0         VPN idle timeout        : 0
   User cleared VPN sessions: 0         Exceeded ctx user limit : 0
   Exceeded total user limit: 0
   Client process rcvd pkts : 57        Server process rcvd pkts : 0
   Client process sent pkts : 8134      Server process sent pkts : 0
   Client CEF received pkts : 664       Server CEF received pkts : 0
   Client CEF rcv punt pkts : 29        Server CEF rcv punt pkts : 0
   Client CEF sent pkts    : 0         Server CEF sent pkts    : 0
   Client CEF sent punt pkts: 0         Server CEF sent punt pkts: 0

   SSLVPN appl bufs inuse  : 0         SSLVPN eng bufs inuse  : 0
   Active server TCP conns : 0

Mangling statistics:
   Relative urls           : 0         Absolute urls           : 0
   Non-http(s) absolute urls: 0         Non-standard path urls  : 0
   Interesting tags        : 0         Uninteresting tags      : 0
   Interesting attributes  : 0         Uninteresting attributes : 0
   Embedded script statement: 0         Embedded style statement : 0
   Inline scripts          : 0         Inline styles           : 0
   HTML comments           : 0         HTTP/1.0 requests       : 0
   HTTP/1.1 requests       : 3         Unknown HTTP version    : 0
   GET requests            : 3         POST requests           : 0
   CONNECT requests        : 0         Other request methods   : 0
   Through requests        : 0         Gateway requests        : 3
   Pipelined requests      : 0         Req with header size >1K : 0
   Processed req hdr bytes : 844       Processed req body bytes : 0
   HTTP/1.0 responses      : 0         HTTP/1.1 responses      : 0
   HTML responses          : 0         CSS responses           : 0
   XML responses           : 0         JS responses            : 0
   Other content type resp : 0         Chunked encoding resp   : 0
   Resp with encoded content: 0         Resp with content length : 0
   Close after response    : 0         Resp with header size >1K: 0
   Processed resp hdr size : 0         Processed resp body bytes: 0
   Backend https response  : 0         Chunked encoding requests: 0

HTTP Authentication stats :
   Successful NTLM Auth    : 0         Failed NTLM Auth        : 0
   Successful Basic Auth   : 0         Failed Basic Auth       : 0
   Unsupported Auth        : 0         Unsup Basic HTTP Method : 0
   NTLM srv kp alive disabld: 0         NTLM Negotiation Error  : 0
   Oversize NTLM Type3 cred : 0         Internal Error          : 0
   Num 401 responses       : 0         Num non-401 responses   : 0
   Num Basic forms served  : 0         Num NTLM forms served   : 0
   Num Basic Auth sent     : 0         Num NTLM Auth sent      : 0

CIFS statistics:
 SMB related Per Context:
   TCP VC's                : 0         UDP VC's                : 0
   Active VC's             : 0         Active Contexts         : 0
   Aborted Conns           : 0
 NetBIOS related Per Context:
   Name Queries            : 0         Name Replies            : 0
   NB DGM Requests         : 0         NB DGM Replies          : 0
   NB TCP Connect Fails    : 0         NB Name Resolution Fails : 0
 SMB related Global:
   Sessions in use         : 0         Mbufs in use            : 0
   Mbuf Chains in use      : 0         Active VC's             : 0
   Active Contexts         : 0         Browse Errors           : 0
   Empty Browser List      : 0         NetServEnum Errors      : 0
   Empty Server List       : 0         NBNS Config Errors      : 0
   NetShareEnum Errors     : 0
 HTTP related Per Context:
   Requests                : 0         Request Bytes RX        : 0
   Request Packets RX      : 0         Response Bytes TX       : 0
   Response Packets TX     : 0         Active Connections      : 0
   Active CIFS context     : 0         Requests Dropped        : 0
 HTTP related Global:
   Server User data        : 0         CIFS User data          : 0
   Net Handles             : 0         Active CIFS context     : 0
   Authentication Fails    : 0         Operations Aborted      : 0
   Timers Expired          : 0         Pending Close           : 0
   Net Handles Pending SMB : 0         File Open Fails         : 0
   Browse Network Ops      : 0         Browse Network Fails    : 0
   Browse Domain Ops       : 0         Browse Domain Fails     : 0
   Browse Server Ops       : 0         Browse Server Fails     : 0
   Browse Share Ops        : 0         Browse Share Fails      : 0
   Browse Dir Ops          : 0         Browse Network Fails    : 0
   File Read Ops           : 0         File Read Fails         : 0
   File Write Ops          : 0         File Write Fails        : 0
   Folder Create Ops       : 0         Folder Create Fails     : 0
   File Delete Ops         : 0         File Delete Fails       : 0
   File Rename Ops         : 0         File Rename Fails       : 0
   URL List Access OK      : 0         URL List Access Fails   : 0

Socket statistics:
   Sockets in use          : 1         Sock Usr Blocks in use  : 1
   Sock Data Buffers in use : 0         Sock Buf desc in use    : 0
   Select timers in use    : 1         Sock Select Timeouts    : 0
   Sock Tx Blocked         : 150       Sock Tx Unblocked       : 150
   Sock Rx Blocked         : 0         Sock Rx Unblocked       : 0
   Sock UDP Connects       : 0         Sock UDP Disconnects    : 0
   Sock Premature Close    : 0         Sock Pipe Errors        : 13
   Sock Select Timeout Errs : 0

Smart Tunnel statistics:
 Client                               Server
   proc pkts               : 0         proc pkts                : 0
   proc bytes              : 0         proc bytes               : 0
   cef pkts               : 0         cef pkts                : 0
   cef bytes              : 0         cef bytes               : 0

Port Forward statistics:
 Client                               Server
   proc pkts               : 0         proc pkts                : 0
   proc bytes              : 0         proc bytes               : 0
   cef pkts                : 0         cef pkts                 : 0
   cef bytes               : 0         cef bytes                : 0

WEBVPN Citrix statistics:

              Server                  Client
 Packets in : 0                       0
 Packets out : 0                       0
 Bytes in   : 0                       0
 Bytes out  : 0                       0

ACL statistics:
   Permit web request      : 0         Deny web request        : 0
   Permit cifs request     : 0         Deny cifs request       : 0
   Permit without ACL      : 0         Deny without match ACL  : 0
   Permit with match ACL   : 0         Deny with match ACL     : 0

Single Sign On statistics:
   Auth Requests           : 0         Pending Auth Requests   : 0
   Successful Requests     : 0         Failed Requests         : 0
   Retranmissions          : 0         DNS Errors              : 0
   Connection Errors       : 0         Request Timeouts        : 0
   Unknown Responses       : 0

URL-rewrite splitter statistics:
   Direct access request   : 0         Redirect request        : 0
   Internal request        : 0

Tunnel Statistics:
   Active connections      : 1
   Peak connections        : 1         Peak time               : 00:01:44
   Connect succeed         : 2         Connect failed          : 0
   Reconnect succeed       : 1         Reconnect failed        : 0
   DPD timeout             : 0
 Client
   in CSTP frames         : 671       in CSTP control        : 1
   in CSTP data           : 670       in CSTP bytes          : 50002
   out CSTP frames         : 0         out CSTP control        : 0
   out CSTP data           : 0         out CSTP bytes          : 0
   in CDTP frames         : 0         in CDTP control        : 0
   in CDTP data           : 0         in CDTP bytes          : 0
   out CDTP frames         : 0         out CDTP control        : 0
   out CDTP data           : 0         out CDTP bytes          : 0
   cef in CSTP data frames : 0         cef in CSTP data bytes : 0
   cef out CSTP data frames : 0         cef out CSTP data bytes : 0
   cef in CDTP data frames : 0         cef in CDTP data bytes : 0
   cef out CDTP data frames : 0         cef out CDTP data bytes : 0
 Server
   In IP pkts             : 0         In IP bytes            : 0
   Out IP pkts             : 670       Out IP bytes            : 44587

В CCP выберите > Security Monitoring> Состояние VPN> VPN SSL (Все Контексты) для просмотра текущих списков пользователя VPN SSL в маршрутизаторе.

Устранение неполадок

Этот раздел обеспечивает информацию, которую вы можете использовать для того, чтобы устранить неисправность в вашей конфигурации.

Команды для устранения неполадок

 Некоторые команды clear ассоциированы с WebVPN. Дополнительную информацию о данных командах см. в документе Использование команд WebVPN "clear".

 Некоторые команды debug связаны с WebVPN. Дополнительную информацию о данных командах см. в документе Использование команд WebVPN debug.

Примечание: Использование команд debug может неблагоприятно сказаться на производительности модуля Cisco.  Перед использованием команд debug ознакомьтесь с документом Важные сведения о командах debug.  

Дополнительные сведения



Document ID: 110608