Совместная работа : Cisco Unified Web Interaction Manager

Обновление Cisco Interaction Manager 4.2(5) не удалось в силу несовместимости с SQL Collation

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Менеджер Взаимодействия Cisco 4.2 (5) обновление отказывает из-за несовместимости Сопоставления SQL. В этом документе обсуждается способ устранения данной проблемы.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

Установка Cisco Unified Web and E-Mail Interaction Manager

Используемые компоненты

Сведения в этом документе основываются на версии 4.2 (5) Cisco Unified Web and E-Mail Interaction Manager.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

warningПредупреждение: Только конфигурации, которые соответствуют определенным, некоторый критериям, могут быть обновлены Менеджеру Взаимодействия Cisco 4.2 (5).

Перед переходом обновление необходимо проверить, что текущая система имеет эти параметры настройки:

  • На ведущем устройстве, активных, и архивных базах данных, параметры настройки сопоставления должны быть установлены в SQL_Latin1_General_CP1_CI_AS.

  • На конфигурациях, которые уже находятся на Сервере SQL 2005, значение сопоставления Сервера SQL должно быть установлено в SQL_Latin1_General_CP1_CI_AS.

  • Параметры настройки сложного пароля не должны быть принуждены на Сервере SQL 2005.

  • На всех серверах в Конфигурации менеджера Взаимодействия Cisco региональная опция должна быть установлена в английский язык.

warningПредупреждение: Если какое-либо из этих условий не соблюдают, не продолжайте обновление Менеджеру Взаимодействия Cisco 4.2 (5). Необходимо загрузить 4.2 (5a) от Загрузок программного обеспечения (только зарегистрированные клиенты).

Проблема

Cisco Unified E-Mail Interaction Manager / веб-Менеджер Взаимодействия (EIM/WIM) 4.2 (5) обновление отказывает из-за несовместимости Сопоставления SQL. Когда заказ сопоставления сервера SQL не является SQL_Latin1_General_CP1_CI_AS, сбоями обновления.

Эта проблема задокументирована идентификатором ошибки Cisco CSCsx24230 (только зарегистрированные клиенты) и устранена в Cisco Унифицированная версия 4 EIM/WIM. 2,5 А.

Решение

На всех серверах

Выполните эти шаги для подтверждения значения региональных параметров на файле, сервисах, базе данных, и всех серверах приложений и Web-серверах:

  1. Выберите Start > Settings > Control Panel.

  2. Дважды нажмите Regional и Language Options.

  3. В Региональном окне и окне Language Options, на вкладке Regional Options, в разделе стандартов и форматов, проверяют, что выбран английский язык (США).

На сервере базы данных

Выполните эти шаги для подтверждения параметров настройки региональных параметров на сервере базы данных:

  1. Проверьте, что значение сопоставления для ведущего устройства, активного, и, архивирует базы данных, установлен в SQL_Latin1_General_CP1_CI_AS. Для подтверждения сопоставления базы данных выполните этот запрос на активном, основном, и заархивируйте базы данных:

    Примечание: Если вы уже обновили к Microsoft SQL Server 2005, выполните запрос на базах данных по Серверу SQL 2005. Если базы данных находятся все еще на SQL Server 2000, выполните запрос на SQL Server 2000.

    SELECT convert(sysname,DatabasePropertyEx('Database_Name','Collation'))
  2. На сервере базы данных Сервера SQL 2005 года проверьте, что значение сопоставления установлено в SQL_Latin1_General_CP1_CI_AS. Выполните этот запрос:

    SELECT convert(sysname,ServerProperty(‘Collation’))
  3. На Сервере SQL 2005 проверьте, что политика сложного пароля не принуждена экземпляром Сервера SQL 2005 года. Для подтверждения этого выполните этот запрос:

    IF (SELECT distinct 1 FROM sys.sql_logins
    WHERE is_policy_checked = 1) = 1
    PRINT ‘Complex password policy is enforced’
    ELSE
    PRINT ‘Complex password policy is not enforced’

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения