Коммутаторы : ??????????? ??????? ?????????? 1440 ?? ???? ???????????? Cisco Catalyst 6500

Замена модуля супервизора виртуальной системы коммутации 1440 на Cisco Catalyst 6500

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (10 февраля 2011) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пошаговую процедуру для замены плохого супервизора в Cisco Catalyst 6500 Систем виртуальной коммутации.

Система виртуальной коммутации (VSS) состоит из двух шасси Catalyst 6500. Каждое шасси оборудовано одиночным Supervisor Engine. Если один из супервизоров умирает из-за отказа оборудования, заменяющий супервизор, который идет с конфигурацией по умолчанию, не становится участником VSS автоматически. Этот новый супервизор изначально загружается в автономном режиме, а для загрузки в режиме VSS требует настройки VSS.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Скопируйте действительный образ из активного супервизора VSS на устройство CompactFlash.

  • Скопируйте активную конфигурацию VSS на устройство CompactFlash (можно использовать одно и то же устройство).

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

Система 1440 виртуальной коммутации для Cisco Catalyst 6500 на Cisco Выпуск ПО IOS� 12.2 (33) SXH1 или позже

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Если используемая сеть является действующей, убедитесь в понимании возможного влияния любой из применяемых команд.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Новый супервизор требует загрузки с действительным образом и конфигурацией. Образ можно скопировать при помощи упрощенного протокола передачи файлов (TFTP) или устройства CompactFlash. Если устройство CompactFlash недоступно, то образ программного обеспечения и файл конфигурации можно также скопировать по протоколу TFTP.

  1. Скопируйте действительный образ из активного супервизора VSS на устройство CompactFlash.

    VSS#dir sup-bootdisk:
    Directory of sup-bootdisk:/
    1 -rwx 117668516 Jan 22 2008 11:53:58 +00:00 s72033-
       ipservices_wan-vz.122-33.SXH1
    2 -rwx 33554432 Aug 16 2007 12:40:22 +00:00 sea_log.dat
    3 -rwx 7366 Aug 22 2007 20:05:42 +00:00 default-config
    

    Следует заметить, что в режиме VSS активные и резервные супервизоры работают с одной и той же версией образа ПО.

    VSS#copy sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1 disk0:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress...CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
       CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    
    !--- Output suppressed.
    
    
  2. Скопируйте текущую конфигурацию из активного супервизора VSS на устройство CompactFlash.

    VSS#copy running-config disk0:
    Destination filename [startup-config]? <VSS.cfg>
    11196 bytes copied in 0.712 secs (15725 bytes/sec)

Схема сети

В настоящем документе используется следующая схема сети:

Выход из строя супервизора коммутатора 2

replace_vss_sup_proc_v1.gif

Установка и настройка нового супервизора

Выполните эти шаги, чтобы установить и настроить новый супервизор:

  1. Установите новый супервизор в шасси и, если для VSL используются восходящие каналы супервизора, подключите их физически. Загрузите образ с носителя CompactFlash.

  2. Удалите начальный файл конфигурации нового супервизора; этот шаг необходим, чтобы гарантировать отсутствие старой конфигурации в новом супервизоре.

  3. Скопируйте образ программного обеспечения, который был ранее скопирован к компактному флэш - устройству к новому sup-bootdisk супервизора:

    Router#copy disk0:s72033-ipservices_wan-vz.122-33.SXH1 sup-bootdisk:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    117668516 bytes copied in 332.283 secs (354121 bytes/sec)
    
    !--- Output suppressed.
    
    
    !--- If you choose to download software image from a tftp server,
         connect one of the switch interfaces to the network in order to have connectivity 
         to the tftp server. Configure IP address to the management interface; verify 
         the connectivity between the switch and the tftp server.
    
    
    !--- The management IP address should be different from what is 
         already assigned to active VSS switch.
    !--- Configure management IP address
    
    Router(config)#interface gig 1/3
    Router(config-if)#ip address 10.10.10.100 255.255.255.0
    Router(config-if)#no shutdown
    
    !--- verify Management interface status and configuration
    
    Router#show interface gig 1/3
    GigabitEthernet1/3 is up, line protocol is up (connected)
    Hardware is C6k 1000Mb 802.3, address is 0005.dce7.8180 
       (bia 0005.dce7.8180)
    Internet address is 10.10.10.100/24
    
    !--- Output omitted
    !--- If the TFTP server and switch management interface are not in the same 
         layer-3 subnet, add a (default) route.
    
    Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
    
    !--- verify IP connectivity between switch and TFTP server
    
    Router#ping 10.20.20.200
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.20.20.200, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
    
    !---Copy the new software image into supervisor bootflash:
    
    Router#copy tftp: sup-bootdisk:
    Address or name of remote host []? 10.20.20.200
    Source filename []? s72033-ipservices_wan-vz.122-33.SXH1
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    
    !--- Output omitted
    
    
  4. Скопируйте конфигурацию активного супервизора, предварительно сохраненную на устройстве CompactFlash, в новый файл конфигурации супервизора startup-config.

    Router#copy disk0:VSS.cfg startup-config
    Destination filename [startup-config]?
    11196 bytes copied in 7.460 secs (1501 bytes/sec)
    Router#

    Примечание: Этот шаг важен, потому что добавлены конфигурация VSS и любые переменные загрузки, требуемые загружать правильный образ программного обеспечения IOS.

    
    !--- Highlighted VSS configuration commands are critical 
         to boot up the supervisor in VSS mode.
    !--- Verify VSS configuration in the startup-config file
    
    Router#more nvram:startup-config
    !
    hostname VSS
    boot system flash sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1
    
    !--- Switch Virtual domain <id> is configured with respective 
         switch priorities
    
    switch virtual domain 1
    switch mode virtual 
    
    !--- this command gets populated upon converting standalone switch to VSS mode. 
         Make sure this command is part the configuration.
    
    switch 1 priority 110
    switch 2 priority 100
    
    
    !--- Verify Virtual Switch Link (VSL) configuration
    
    interface Port-channel1
    no switchport
    no ip address
    switch virtual link 1
    mls qos trust cos
    no mls qos channel-consistency
    !
    interface Port-channel2
    no switchport
    no ip address
    switch virtual link 2
    mls qos trust cos
    no mls qos channel-consistency
    
    !--- Physical interfaces that are part of VSL
    
    interface TenGigabitEthernet1/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet1/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet2/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
    interface TenGigabitEthernet2/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
  5. Настройте код VSS Switch_ID, идентифицирующий коммутатор Catalyst 6500 в домене виртуальной коммутации. Поскольку VSS может состоять только из двух коммутаторов, необходимо выбрать 1 или 2, зависящий от того, какие значения определены на активном коммутаторе. Никакие другие значения, кроме 1 и 2, не допускаются.

    
    !--- Verify active Switch_ID on the active switch
    
    Router#switch read switch_num local
    Read switch_num from Active rommon is 1
    
    !--- Note that since Switch_ID=1 is used for active switch, 
         we would define Switch_ID=2 in the new supervisor.
    
    
    !--- Configure the Switch_ID on the supervisor.
    
    
    !--- Below command sets a Switch_ID ROMMON variable. 
         It is used during VSS boot up to identify a switch within a VSS domain.
    !--- Note that the Switch_ID doesn’t dictate the state (active vs. standby) of the supervisor.
    
    Router#switch set switch_num 2 local
    Set rommon's switch_num to 2
    
    !--- Verify the Switch_ID configuration on the new supervisor.
    
    Router#switch read switch_num local
    Read switch_num from Active rommon is 2
  6. Перезагрузите коммутатор, чтобы при повторном запуске он загрузился в режиме VSS.

    caution Внимание: Не сохраняйте свой running-config к startup-config на этом этапе. Иначе файл startup-config будет заменен конфигурацией по умолчанию, и коммутатор не сможет загрузиться в режиме VSS.

    Пример выходных данных в интерфейсе командной строки:

    Router# reload
    System configuration has been modified. Save? [yes/no]: no
    Proceed with reload? [confirm]
    00:25:07: %SYS-5-RELOAD: Reload requested by console. 
       Reload Reason: Reload Command.
    00:26:49: %SYS-SP-3-LOGGER_FLUSHING: 
       System pausing to ensure console debugging output.
    00:26:49: %OIR-SP-6-CONSOLE: 
       Changing console ownership to switch processor
    
    !--- Output omitted
    !--- SP booting up, pay attention to the name of the image being loaded by SP
    
    System Bootstrap, Version 8.5(1)
    Copyright (c) 1994-2006 by cisco Systems, Inc.
    Cat6k-Sup720/SP processor with 1048576 Kbytes of main memory
    Autoboot executing command: “ boot system flash 
       sup-bootflash:s72033-ipservices_wan-vz.122-33.SXH1”
    Loading image, please wait ...
    Initializing ATA monitor library...
    Self decompressing the image : 
       ######################################
       #####################################
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_sp Software 
       (s72033_sp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:38 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
    
    !--- VSS configuration pre-parsed during bootup
    
    System detected Virtual Switch configuration...
    Interface TenGigabitEthernet 2/8/4 is member of Portchannel 2
    
    
    !--- output omitted
    
    Initializing as Virtual Switch STANDBY processor
    
    !--- VSL module ( supervisor in this scenario) 
         brought up and role is resolved as standby 
         since there is already a active VSS switch.
    
    
    00:00:30: %VSL_BRINGUP-6-MODULE_UP: 
       VSL module in slot 8 switch 2 brought up
    00:00:57: %VSLP-5-VSL_UP: 
       Ready for Role Resolution with Switch=1, 
       MAC=0014.1bc6.1c00 over 8/4
    00:01:01: %VSLP-5-RRP_ROLE_RESOLVED: 
       Role resolved as STANDBY by VSLP
    00:01:01: %VSL-5-VSL_CNTRL_LINK: New VSL Control Link 8/4
    
    !--- RP is booting up
    
    System Bootstrap, Version 12.2(17r)SX5, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 2006 by cisco Systems, Inc.
    Cat6k-Sup720/RP platform with 1048576 Kbytes of main memory
    Download Start
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:04 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
    
    !--- output omitted
    
    Press RETURN to get started!
    
    !--- Look out for –- 
         “%PFREDUN-SW2_SPSTBY-6-STANDBY: Initializing for SSO mode”
         in the active console to make sure stadby is running in SSO mode.
    !--- After standby boots up it’s console is locked
    
    VSS-sdby>
    Standby console disabled
    VSS-sdby>
    Standby console disabled

    Примечание: Для настройки VSS на нескольках подсетей резервная конфигурация не необходима на VSS. Маршрутизатор/шлюзы должны быть установлены как SVI VLAN.

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Несовпадение ПО между модулями управления

Если существует несоответствие программного обеспечения между Supervisor Engine, standy супервизор подходит в режиме резервирования RPR (не в режиме резервирования SSO), и VSS не полностью инициализирует.

Для решения этой проблемы убедитесь в том, что во флеш-памяти резервного супервизора присутствует необходимое программное обеспечение, а операторы начальной загрузки указывают подходящее ПО. Перезагрузите резервный супервизор, чтобы он загрузился с подходящим программным обеспечением и вступил в окружение VSS.


Дополнительные сведения


Document ID: 109334