Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Коммутаторы Catalyst для Примера конфигурации программы балансировки нагрузки сети Майкрософт

28 июля 2013 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (6 июня 2013) | Отзыв

Введение

В этом документе описана настройка коммутаторов Cisco Catalyst для взаимодействия со средством выравнивания нагрузки в сети Microsoft (NLB).

Внесенный Шэшэнком Сингхом, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Выполнение Catalyst 6500 Switch Cisco IOS® Software

  •  Программное обеспечение Cisco IOS выполнения коммутатора Catalyst 4500

  •  Программное обеспечение Cisco IOS выполнения Catalyst 3550 Switch

  •  Программное обеспечение Cisco IOS выполнения Catalyst 3560 Switch

  • Catalyst 3750 программных обеспечений Cisco IOS выполнения коммутатора

  • Microsoft Windows 2000/2003 Серверы

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования. 

Общие сведения

Технология Балансирования сетевой нагрузки (NLB) может использоваться для распределения запросов клиента через ряд серверов. Чтобы удостовериться, что клиенты всегда испытывают уровни приемлемой производительности, Windows NLB часто используется, чтобы гарантировать, что можно добавить дополнительные серверы для масштабирования приложений не сохраняющих состояние, таких как основанные на IIS Web-серверы, как клиентские увеличения загрузки. Кроме того, это сокращает время простоя, вызванное серверами то неправильное функционирование. Конечные пользователи никогда не будут знать, что определенный рядовой сервер в Windows NLB или не работал.

Балансирование Сетевой нагрузки является технологией кластеризации, предлагаемой Microsoft как часть всего Сервера Windows 2000 и операционных систем семейства Windows Server 2003. NLB использует распределенный алгоритм для балансировки нагрузки сетевого трафика через многие серверы.

NLB связывает серверы в одну группу многоадресной рассылки и попытки использовать стандартного IP - адресу многоадресной рассылки и MAC-адрес. В то же время это предоставляет одиночное виртуальное IP для всех клиентов как IP - адрес назначения, что означает, что серверы присоединяются к той же группе многоадресной рассылки, и клиенты ничего не будут знать об этом. Они используют обычный доступ индивидуальной рассылки к VIP.

Можно настроить NLB для работы в одном из этих режимов:

Одноадресный режим

Настройка по умолчанию NLB является одноадресным режимом. В одноадресном режиме NLB заменяет адрес реального MAC каждого сервера в кластере к общему MAC-адресу NLB. Когда весь сервер в кластере имеет тот же MAC-адрес, все пакеты, переданные к тому адресу, передаются всем участникам кластера. Однако проблема с этой конфигурацией состоит в том, когда серверы, кластер NLB связан с тем же коммутатором, у вас не может быть двух портов на регистре коммутатора тот же MAC-адрес. NLB решает эту проблему путем маскировки кластерного MAC-адреса. Коммутатор посмотрел на источник с MAC-адресом в заголовке Фрейма Ethernet, чтобы учиться, какие MAC-адреса привязаны к его портам. NLB создает поддельный MAC-адрес и назначает тот поддельный MAC-адрес на каждый сервер в кластере NLB. NLB назначает каждый сервер NLB другой поддельный MAC-адрес на основе идентификатора хоста участника. Этот адрес появляется в заголовке Фрейма Ethernet.

Например, MAC-адрес кластера NLB является 00-bf-ac-10-00-01. NLB в одноадресном режиме берет кластерный MAC-адрес и для каждого члена кластера, NLB изменяет второй октет так, чтобы это состояло из участника NLB? s идентификатор хоста. Например, сервер количество 1 как поддельный MAC-адрес 00-01-ac-10-00-01, идентификатор хоста количество 2 имеет поддельный MAC-адрес 00-02-ac-10-00-01, и так далее. Если уникальный MAC-адрес зарегистрирован на каждом порту коммутатора, пакеты не отправлены всем участникам массива; скорее пакеты должны все еще быть переданы отдельным портам коммутатора на основе MAC-адреса, назначенного на тот порт. Сделать кадры поставило всем участникам кластера NLB, когда каждый порт коммутатора, связанный с членом кластера NLB, регистрирует другой MAC-адрес, это использует широковещание ARP, используются. Когда маршрутизатор передает запрос ARP за MAC-адресом виртуального IP - адреса, ответ содержит заголовок ARP с фактическим MAC-адресом кластера NLB 00-bf-ac-10-00-01 согласно примеру, данному выше а не поддельным MAC-адресом.

Клиенты используют MAC-адрес в заголовке ARP, не Заголовке ethernet. Коммутатор использует MAC-адрес в Заголовке ethernet, не заголовке ARP. Проблема - когда клиент передает пакет кластеру NLB с MAC - адресом назначения как кластерный MAC-адрес 00-bf-ac-10-00-01, коммутатор посмотрел на таблицу CAM для MAC-адреса 00-bf-ac-10-00-01. С тех пор нет никакого порта, зарегистрированного в MAC-адресе кластера NLB 00-bf-ac-10-00-01, кадр отправлен всем портам коммутатора. Это представляет затопление коммутатора. Когда значительная часть трафика течет и также при наличии других серверов на том же коммутаторе, затопление коммутатора вызывает проблемы. Решение коммутировать затопление состоит в том, чтобы поместить простой концентратор перед членами кластера NLB и затем каналом связи концентратор к порту коммутатора. Это решение даже не должно замаскировать MAC-адрес кластера NLB, потому что порт одного коммутатора, связанный с концентратором, изучает MAC-адрес кластера NLB. Это избегает проблемы двух портов коммутатора, регистрирующих тот же MAC-адрес. Когда клиент передает пакеты MAC-адресу кластера NLB, пакеты идут непосредственно в порт коммутатора, связанный с концентратором и затем членам кластера NLB.

Режим многоадресной рассылки

Другое решение состоит в том, чтобы использовать многоадресный режим в MS GUI конфигурации NLB вместо Одноадресного режима. В режиме многоадресной рассылки System Admin нажимает кнопку IGMP Multicast в MS GUI конфигурации NLB. Этот выбор сообщает, что члены кластера для ответа на ARP для их виртуального адреса используют широковещательный MAC - адрес, например, 0300.5e11.1111 и передать пакеты Отчета о членстве igmp. Если отслеживание IGMP включено на локальном коммутаторе, оно snooping Пакеты IGMP, которые проходят через него. Таким образом, когда клиентские ARP для кластера? s виртуальный IP - адрес, кластер отвечает многоадресной передачей MAC, например, 0300.5e11.1111. Когда клиент передает пакет 0300.5e11.1111, локальный коммутатор передает пакет каждый из портов, связанных с членами кластера. В этом случае нет никакого шанса затопления пакета ARP из всех портов. Проблема с многоадресным режимом является виртуальным IP - адресом, становится недостижимым когда обращено извне локальной подсети, потому что устройства Сisco не принимают ответ arp для однонаправленного IP - адреса, который содержит широковещательный MAC - адрес. Таким образом, часть MAC Записи ARP показывает как неполная. (Выполните команду show arp для просмотра выходных данных.) Как нет никакой части MAC в ответе arp, Запись ARP никогда не появлялась в таблице ARP. Это в конечном счете оставило ARPing и возвратило Недостижимый узел ICMP к клиентам. Чтобы отвергнуть это, используйте статическую Запись ARP для начальной загрузки таблицы ARP как дано ниже. В теории это позволяет устройству Сisco заполнять свой mac-address-table. Например, если виртуальный IP - адрес 172.16.63.241, и широковещательный MAC - адрес является 0300.5e11.1111, используйте эту команду, чтобы заполнить таблицу ARP статически:

arp 172.16.63.241 0300.5e11.1111

Однако, так как входящие пакеты имеют IP - адрес назначения индивидуальной рассылки и пункт назначения широковещания MAC, устройство Сisco игнорирует эту запись и коммутаторы процесса каждый ограниченные кластером пакеты. Во избежание этой коммутации в контексте процесса вставьте запись статического MAC - адреса как дано ниже чтобы к ограниченным коммутаторным кластером пакетам в аппаратных средствах.

mac-address-table static 0300.5e11.1111 vlan 200 interface
fa2/3 fa2/4

Примечание. Статически сопоставляющий MAC ко множественным портам поддерживается только в программном обеспечении на коммутаторе Catalyst 4500. Использование этой конфигурации на коммутаторе Catalyst 4500 может вызвать высокую загрузку CPU.

 

Примечание. Для Cisco Catalyst 6000/6500 коммутаторы Серии, необходимо добавить отключить-snopping параметр. Например:

mac-address-table static 0300.5e11.1111 vlan 200
interface fa2/3 fa2/4 disable-snooping

Отключенный snooping параметр важен и применим только для Cisco Catalyst 6000/6500 коммутаторы серии. Без этого оператора не влияют на поведение.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в данном документе.

 Примечание. Используйте Средство поиска команд (только для зарегистрированных клиентов) для получения дополнительной информации по используемым в данном разделе командам.

Схема сети

В этом документе использованы параметры данной сети.

Конфигурации

Этот документ использует конфигурацию Catalyst 6509, описанную в этом разделе.

Cat6K#show running-config
Building configuration...
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6K
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin
!
redundancy
main-cpu
auto-sync standard
ip subnet-zero
!
!
interface GigabitEthernet1/1
no ip address
shutdown
!
interface GigabitEthernet1/2
no ip address
shutdown
!
interface FastEthernet2/1
description "Uplink to the Default Gateway"
no ip address
switchport
switchport access vlan 100
!
interface FastEthernet2/2
no ip address
shutdown
!
interface FastEthernet2/3
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/4
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/5
no ip address
shutdown
!
interface FastEthernet2/48
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
mac-address-table static 0300.5e11.1111 vlan 200 interface fa2/3 fa2/4 disable-snooping

! --- Creating a static entry in the switch for the multicast virtual mac.

! --- fa2/3 & fa2/4 are the ports connected to server.

!--- The disable-snooping is applicable only for Cisco Catalyst 6000/6500 series switches

arp 172.16.63.241 0300.5e11.1111

! --- 172.16.63.241 is the Virtual IP of 2 servers

interface Vlan100
ip address 172.17.63.240 255.255.255.192

!--- Client Side Vlan
!
interface Vlan200
ip address 10.1.1.250 255.255.255.0

!--- Server Vlan

!--- Important: Configure the default gateway

!--- of the Microsoft Server to this address.

!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.63.193
no ip http server
!
line con 0
line vty 0 4
login
!
end

Примечание. Гарантируйте использование многоадресного режима на кластере NLB. Cisco рекомендует не использовать широковещательные MAC - адреса, которые начинаются 01, потому что у них, как известно, есть конфликт с настройкой IGMP.

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Интерпретатор выходных данных – OIT (только для зарегистрированных пользователей) поддерживает ряд команд show. Посредством OIT можно анализировать выходные данные команд show.

  • show mac-address-table Отображает определенную статичную таблицу MAC-адресов и динамическая запись или статичная таблица MAC-адресов и динамические записи на определенном интерфейсе или VLAN.

    Cat6K#show mac-address-table 0300.5e11.1111

              Mac Address Table
    -------------------------------------------

    Vlan    Mac Address      vType        Ports
    ---- -----------      --------     -----
    200    0300.5e11.1111     STATIC    Fa2/3 Fa2/4
  • show ip arp - Отображает кэш протокола разрешения адресов (ARP).

    Cat6K#show ip arp
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  172.16.1.1            -     0300.5e11.1111  ARPA   Vlan200

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении неполадок.

Дополнительные сведения


Сообщество Cisco Support - Избранные темы

Сообщество Cisco Support - это форум, на котором вы можете задавать свои вопросы и отвечать на вопросы других, предлагать решения и сотрудничать с коллегами. Вот несколько последних и важных тем, представленных на нашем форуме.


Document ID: 107995