Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Коммутаторы Catalyst для Примера конфигурации программы балансировки нагрузки сети Майкрософт

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв

Введение

Этот документ описывает, как настроить коммутаторы Cisco Catalyst для взаимодействия с сетью Microsoft, Балансирующей нагрузку (NLB).

Внесенный Амброузом Тейлором, Дэйлом Миллером, и Шэшэнком Сингхом, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Коммутаторы Cisco Catalyst серии 6500 с Supervisor Engine 2T (Sup2T), которые выполняют Версию 15.1 (1) SY1 программного обеспечения Cisco IOS

  • Коммутаторы Cisco Catalyst серии 4948, которые выполняют версию программного обеспечения Cisco IOS 15.0 (2) SG7

  • Microsoft Windows server

Примечание: Консультируйтесь с соответствующим руководством по конфигурации для команд, которые используются для активации этих опций на других Платформах cisco.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Технология NLB может использоваться для распределения запросов клиента по ряду серверов. Чтобы гарантировать, что клиенты всегда испытывают уровни приемлемой производительности, Microsoft Windows, NLB предоставляет возможность добавить дополнительные серверы так, чтобы можно было масштабировать приложения не сохраняющие состояние, такие как основанные на IIS Web-серверы, как клиентские увеличения загрузки. Кроме того, это уменьшает время простоя, которое вызвано серверами то неправильное функционирование.

NLB Microsoft Windows является технологией кластеризации, которая предлагается как часть всех операционных систем семейства Сервера Windows 2000 и Windows 2003 Server. Это предоставляет одиночный виртуальный IP - адрес для всех клиентов как IP - адрес назначения для всего кластера.

Можно настроить NLB для работы в одном из этих трех режимов:

  • Одноадресный режим
  • Режим многоадресной рассылки
  • Режим Протокола IGMP

Одноадресный режим

Вот некоторые примечания об использовании NLB в Одноадресном режиме:

  • В Одноадресном режиме NLB заменяет фактический Адрес для управления доступом к среде (MAC) каждого сервера в кластере с общим MAC-адресом NLB. Когда все серверы в кластере имеют тот же MAC-адрес, все пакеты, которые переданы тому адресу, переданы всем участникам в кластере. NLB создает фиктивный MAC-адрес и назначает его на каждый сервер в кластере NLB. NLB назначает каждый сервер NLB другой фиктивный MAC-адрес, на основе идентификатора хоста участника. Этот адрес появляется в заголовке Фрейма Ethernet.

  • MAC-адрес используется в заголовке Протокола ARP, не Заголовке ethernet. Коммутатор использует MAC-адрес в Заголовке ethernet, не заголовке ARP. Когда пакет передан к кластеру NLB с MAC - адресом назначения как кластерный MAC-адрес 00-bf-ac-10-00-01, это вызывает проблему. Коммутатор просматривает таблицу ассоциативно-запоминающего устройства (CAM) для MAC-адреса 00-bf-ac-10-00-01, и так как нет никакого порта, зарегистрированного в MAC-адресе кластера NLB 00-bf-ac-10-00-01, кадр отправлен всем портам коммутатора. Это представляет  одноадресную лавинную адресациюВо избежание затопления Cisco рекомендует использовать выделенную сеть VLAN для NLB так, чтобы было ограничено затопление.

Режим многоадресной рассылки

Вот некоторые примечания об использовании NLB в режиме многоадресной рассылки:

  • В режиме многоадресной рассылки системный администратор нажимает кнопку Multicast в GUI конфигурации Microsoft NLB. Этот выбор дает членам кластера команду отвечать на ARP для своего виртуального адреса с использованием MAC-адреса групповой адресации, такие как 0300.5e01.0101.

  • Процесс ARP не завершает для MAC-адресов групповой адресации (это ломает RFC 1812). Статический MAC - адрес требуется для достижения кластера за пределами локальной подсети.

  • Виртуальный IP - адрес 10.100.1.99, и MAC-адрес групповой адресации является 0300.5e01.0101. Введите эту команду для начальной загрузки таблицы ARP статически:
    arp 10.100.1.99 0300.5e01.0101
  • Так как входящие пакеты имеют IP - адрес назначения индивидуальной рассылки и MAC-адрес пункта назначения групповой адресации, устройство Сisco игнорирует эту запись, и индивидуальная рассылка лавинно рассылает каждый ограниченный кластером пакет. Во избежание этого затопления вставьте запись статического MAC - адреса для коммутации ограниченных кластером пакетов в аппаратных средствах:
    mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
    TenGigabitEthernet1/5

Примечание: При статичном сопоставлении MAC-адреса со множественными портами он только поддерживается программным обеспечением на коммутаторе Cisco Catalyst серии 4500. Кроме того, использование этой конфигурации на Коммутаторе серии Catalyst 4500 могло бы вызвать высокую загрузку CPU. Во избежание этой проблемы можно изолировать NLB к определенной VLAN, добавить только статические записи протокола ARP и позволить лавинно рассылать на той VLAN.

Режим IGMP

Вот некоторые примечания об использовании NLB в режиме IGMP:

  • Использование NLB в режиме IGMP требует наименьшего количества суммы настройки вручную. Виртуальный MAC - адрес находится в пределах диапазона Комитета по цифровым адресам в интернете (IANA) и запускается с 0100.5exx.xxxx. Так как MAC-адрес теперь соответствует спецификациям IANA, коммутаторы Cisco могут динамично программировать MAC-адрес с использованием отслеживания IGMP. Это устраняет необходимость вручную программировать MAC-адрес к схемам порта, которые требуются в режиме многоадресной рассылки для предотвращения затопления к VLAN.

  • Отслеживание IGMP программирует виртуальный MAC - адрес для вас, как только коммутатор получает сообщение о принадлежности к группе от участника в кластере. Порт Многоадресного маршрутизатора должен также быть запрограммирован для VLAN NLB с использованием или независимой от протокола многоадресной передачи (PIM) или функции Опрашивающего устройства (Igmp Querier).

  • Так как виртуальный IP - адрес использует MAC-адрес групповой адресации, это недостижимо за пределами локальной подсети. Для адресации к этому необходимо настроить статическую запись протокола ARP на каждом устройстве с интерфейсом 3 уровня (L3) в кластерной VLAN. Завершите это той же формой как с режимом многоадресной рассылки. Например, если виртуальный IP - адрес 10.100.1.99, и MAC-адрес групповой адресации является 0100.5e01.0101, используйте эту команду для начальной загрузки таблицы ARP статически:
    arp 10.100.1.99 0100.5e01.0101

Предупреждения

Вот важные замечания для учета при использовании NLB в режиме IGMP:

  • Как отслежено в идентификаторе ошибки Cisco CSCsw72680, вы не можете использовать PIM на коммутируемом виртуальном интерфейсе (SVI) VLAN NLB с определенными, некоторый версиями кода. Просмотрите подробные информации об ошибке для релизов кода, которые решают эту проблему или используют функцию Snooping Querier IGMP.

  • Как отслежено в идентификаторе ошибки Cisco CSCsy62709, пакеты дублированы для всего трафика, который маршрутизируется к серверам NLB в режиме IGMP. Просмотрите подробные информации об ошибке для версий кода, на которые влияют.

  • Из-за аппаратного ограничения, которое отслежено идентификатором ошибки Cisco CSCug49149, трафик NLB не может быть передан по распределенному Etherchannel на тех же 6708 линейных платах, когда коммутатор выполняется или в PFC3B или в режиме PFC3C. Port-channel должен быть соединен кабелем так, чтобы все участвующие соединения были на том же механизме пересылки.

Настройка

В этом разделе описывается настроить NLB для Cisco Catalyst 6500 и платформы серии 4948, которые работают в режиме IGMP или Групповой адресации.

Схема сети

Конфигурация для режима многоадресной рассылки

В этом разделе описывается настроить NLB для Cisco Catalyst 6500 и платформы серии 4948, которые работают в режиме многоадресной рассылки:

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
interface TenGigabitEthernet1/4
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface TenGigabitEthernet1/5
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface Vlan100
ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.88 0300.5e01.0101 ARPA
!
!
mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
TenGigabitEthernet1/5 TenGigabitEthernet5/5

!
end

Вот некоторые важные замечания об этой конфигурации:

  • Интерфейсное значение IP-адреса Vlan100 настраивает пользовательскую LAN.

  • Интерфейсное значение IP-адреса Vlan200 настраивает VLAN кластера NLB. Важно, чтобы вы настроили шлюз по умолчанию сервера Microsoft к этому адресу.

  • arp 10.100.1.88 0300.5e01.0101 ARPA включает все L3 интерфейсы в VLAN и является виртуальным IP - адресом серверов кластера NLB.

  • Интерфейс mac address-table static 0300.5e01.0101 vlan 200 создает статическую запись MAC к сопоставлению портов в коммутаторе для виртуального MAC - адреса групповой адресации.

Примечание: Гарантируйте использование режима многоадресной рассылки на кластере NLB. Cisco рекомендует не использовать MAC-адреса групповой адресации, которые начинаются 01, потому что у них, как известно, есть конфликт с настройкой IGMP.

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
mac address-table static 0300.5e01.0101 vlan 200 interface Gi1/1 Te1/49 Te1/50
!
!
end

Примечание: Интерфейс mac address-table static 0300.5e01.0101 vlan 200 создает статическую запись в коммутаторе для виртуального MAC - адреса групповой адресации. Важно помнить, что должны быть добавлены все интерфейсы магистрали, которые переносят трафик NLB между коммутаторами. Как только статический MAC - адрес определен, затопление ограничено. Если вы забываете включать интерфейс, NLB кластеризуют разрывы. 

Конфигурация для режима IGMP

В этом разделе описывается настроить NLB для Cisco Catalyst 6500 и платформы серии 4948, которые работают в режиме IGMP:

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
ip igmp snooping querier
!
!
vlan configuration 1,100
 no ip igmp snooping querier
!        
vlan configuration 200
ip igmp snooping querier address 10.200.1.1
!
!
interface TenGigabitEthernet1/4
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/5
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
!
interface Vlan100
 ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
 ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.99 0100.5e01.0101 ARPA
!
!
end

Вот некоторые важные замечания об этой конфигурации:

  • Ip igmp snooping querier активирует опцию опрашивающего устройства наблюдения.

  • Адрес ip igmp snooping querier 10.200.1.1 настраивает опрашивающее устройство наблюдения для VLAN NLB.

  • Пользовательской LAN является интерфейсный Vlan100.

  • VLAN кластера NLB является интерфейсный Vlan200. Важно, чтобы вы настроили шлюз по умолчанию сервера Microsoft к этому адресу (IP-адрес 10.200.1.1 255.255.255.0).

  • arp 10.100.1.99 0100.5e01.0101 ARPA является виртуальным IP - адресом серверов кластера NLB. Статический ARP должен быть на всех L3 интерфейсах в VLAN.

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
end

Примечание: Не требуется для настройки статических записей, поскольку отслеживание IGMP делает это динамично в этом режиме. Кроме того, никакая специальная конфигурация для этого режима не требуется на нисходящем Уровне 2 (L2) коммутаторы.

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Примечание: Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show.      Посредством OIT можно анализировать выходные данные команд show.

Проверка режима многоадресной рассылки

Введите команду show ip arp для просмотра кэша ARP:

6500-1#show ip arp
Protocol Address        Age (min) Hardware Addr  Type  Interface
Internet 10.100.1.99           -  0300.5e01.0101 ARPA

Введите команду show mac address-table static для просмотра определенной статичной таблицы MAC-адресов и динамическая запись или статичная таблица MAC-адресов и динамические записи на определенном интерфейсе или VLAN:

6500-1#show mac address-table static add 0300.5e01.0101

vlan  mac address   type  learn   age     ports
----+---------------+-------+-----+------+-----------------
200 0300.5e01.0101  static  No      - Te1/4 Te1/5 Te5/5
4948-1#show mac address-table static add 0300.5e01.0101

Multicast Entries
vlan   mac address    type  ports
------+---------------+-------+--------------------
200   0300.5e01.0101  static Gi1/1,Te1/49,Te1/50

Проверка режима IGMP

Введите команду show ip arp для просмотра кэша ARP:

6500-1#show ip arp

Protocol Address      Age (min) Hardware Addr  Type  Interface
Internet 10.100.1.99        -  0100.5e01.0101 ARPA

Введите show ip igmp snooping mrouter для просмотра порта Многоадресного маршрутизатора, который запрограммирован запросами, полученными от восходящего опрашивающего устройства наблюдения:

4948-1#show ip igmp snooping mrouter

Vlan   ports
----   -----
 200  Te1/49(dynamic)

Введите igmp snooping show mac address-table multicast для просмотра динамично добавленного MAC-адреса, который изучен из отслеживания IGMP и участвующих портов:

4948-1#show mac address-table multicast igmp-snooping

Multicast Entries
 vlan  mac address    type   ports
------+---------------+------+-------------
 200  0100.5e01.0101 igmp Gi1/1,Te1/49

Введите show ip igmp snooping groups для просмотра списка портов членов кластера, которые присоединились к группе многоадресной рассылки:

4948-1#show ip igmp snooping groups

Vlan     Group      Version   Port List
-----------------------------------------
200      239.1.1.1   v2        Gi1/1

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.