Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Коммутаторы Catalyst для Примера конфигурации программы балансировки нагрузки сети Майкрософт

21 декабря 2013 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (19 декабря 2013) | Отзыв

Введение

В этом документе описана настройка коммутаторов Cisco Catalyst для взаимодействия со средством выравнивания нагрузки в сети Microsoft (NLB).

Внесенный Шэшэнком Сингхом, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Коммутатор Catalyst 6500, который выполняет программное обеспечение Cisco IOS

  • Коммутатор Catalyst 4500, который выполняет  программное обеспечение Cisco IOS

  • Коммутатор Catalyst 3550, который выполняет  программное обеспечение Cisco IOS

  • Коммутатор Catalyst 3560, который выполняет  программное обеспечение Cisco IOS

  • Catalyst 3750 коммутаторов, которые выполняют  программное обеспечение Cisco IOS

  • Microsoft Windows 2000/2003 Серверы

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Технология NLB может использоваться для распределения запросов клиента через ряд серверов. Чтобы удостовериться, что клиенты всегда испытывают уровни приемлемой производительности, Windows NLB часто используется, чтобы гарантировать, что можно добавить дополнительные серверы для масштабирования приложений не сохраняющих состояние, таких как основанные на IIS Web-серверы, как клиентские увеличения загрузки. Кроме того, это сокращает время простоя, вызванное серверами то неправильное функционирование. Конечные пользователи никогда не будут знать, что определенный рядовой сервер в Windows NLB или не работал.

Балансирование Сетевой нагрузки является технологией кластеризации, предлагаемой Microsoft как часть всего Сервера Windows 2000 и операционных систем семейства Windows Server 2003. NLB использует распределенный алгоритм для распределения нагрузки сетевого трафика через многие серверы.

NLB связывает серверы в одну группу многоадресной рассылки и попытки использовать стандартный IP-адрес групповой адресации и MAC-адрес. В то же время это предоставляет одиночное виртуальное IP для всех клиентов как IP - адрес назначения, что означает, что серверы присоединяются к той же группе многоадресной рассылки, и клиенты ничего не будут знать об этом. Они используют обычный доступ индивидуальной рассылки к VIP.

Можно настроить NLB для работы в одном из этих режимов:

Одноадресный режим

Настройка по умолчанию NLB является одноадресным режимом. В одноадресном режиме NLB заменяет адрес реального MAC каждого сервера в кластере к общему MAC-адресу NLB. Когда все серверы в кластере имеют тот же MAC-адрес, все пакеты, переданные к тому адресу, передаются всем участникам кластера. Когда серверы кластер NLB связаны с тем же коммутатором, Однако проблема с этой конфигурацией состоит в том. У вас не может быть двух портов на регистре коммутатора тот же MAC-адрес. Чтобы решить эту проблему, NLB маскирует кластерный MAC-адрес. Коммутатор посмотрел на источник с MAC-адресом в заголовке Фрейма Ethernet, чтобы учиться, какие MAC-адреса привязаны к его портам. NLB создает поддельный MAC-адрес и назначает тот поддельный MAC-адрес на каждый сервер в кластере NLB. NLB назначает каждый сервер NLB другой поддельный MAC-адрес на основе идентификатора хоста участника. Этот адрес появляется в заголовке Фрейма Ethernet.

Например, MAC-адрес кластера NLB является 00-bf-ac-10-00-01. NLB в одноадресном режиме берет кластерный MAC-адрес и для каждого члена кластера, NLB изменяет второй октет так, чтобы это состояло из участника NLB? s идентификатор хоста. Например, сервер количество 1 имеет поддельный MAC-адрес 00-01-ac-10-00-01, идентификатор хоста количество 2 имеет поддельный MAC-адрес 00-02-ac-10-00-01, и так далее. Если уникальный MAC-адрес зарегистрирован на каждом порту коммутатора, пакеты не отправлены всем участникам массива. Скорее пакеты должны все еще быть переданы отдельным портам коммутатора на основе MAC-адреса, назначенного на тот порт. Чтобы отправить кадры всем участникам кластера NLB, когда каждый порт коммутатора, связанный с членом кластера NLB, регистрирует другой MAC-адрес, широковещание Протокола ARP используется. Когда маршрутизатор передает запрос ARP за MAC-адресом виртуального IP - адреса, ответ содержит заголовок ARP с фактическим MAC-адресом кластера NLB 00-bf-ac-10-00-01 согласно примеру, данному выше а не поддельным MAC-адресом.

Клиенты используют MAC-адрес в заголовке ARP, не Заголовке ethernet. Коммутатор использует MAC-адрес в Заголовке ethernet, не заголовке ARP. Когда клиент передает пакет кластеру NLB с MAC - адресом назначения как кластерный MAC-адрес 00-bf-ac-10-00-01, проблема. Коммутатор посмотрел на таблицу ассоциативно-запоминающего устройства (CAM) для MAC-адреса 00-bf-ac-10-00-01. С тех пор нет никакого порта, зарегистрированного в MAC-адресе кластера NLB 00-bf-ac-10-00-01, кадр отправлен всем портам коммутатора. Это представляет затопление коммутатора. Когда существуют другие серверы на том же коммутаторе, затопление коммутатора вызывает проблемы когда значительная часть трафиков и также. Решение затопления коммутатора состоит в том, чтобы поместить простой концентратор перед членами кластера NLB и затем каналом связи концентратор к порту коммутатора. Это решение даже не должно замаскировать MAC-адрес кластера NLB, потому что порт одного коммутатора, связанный с концентратором, изучает MAC-адрес кластера NLB. Это избегает проблемы двух портов коммутатора, которые регистрируют тот же MAC-адрес. Когда клиент передает пакеты MAC-адресу кластера NLB, пакеты идут непосредственно в порт коммутатора, связанный с концентратором и затем членам кластера NLB.

Режим многоадресной рассылки

Другое решение состоит в том, чтобы использовать режим групповой адресации в MS GUI конфигурации NLB вместо одноадресного режима. В режиме групповой адресации системный администратор нажимает кнопку групповой адресации Протокола IGMP в MS GUI конфигурации NLB. Этот выбор дает членам кластера команду реагировать на ARP для своего виртуального адреса с MAC-адресом групповой адресации (например, 0100.5e11.1111) и передавать пакеты Отчета о членстве igmp. Если отслеживание IGMP включено на локальном коммутаторе, оно snooping Пакеты IGMP, которые проходят через него. Таким образом, когда клиентские ARP для кластера? s виртуальный IP - адрес, кластер отвечает MAC групповой адресации (например, 0100.5e11.1111). Когда клиент передает пакет 0100.5e11.1111, локальный коммутатор передает пакет каждый из портов, связанных с членами кластера. В этом случае нет никакого шанса затопления пакета ARP из всех портов. Проблема с режимом групповой адресации является виртуальным IP - адресом, становится недостижимым когда обращено извне локальной подсети, потому что устройства Сisco не принимают ответ ARP для однонаправленного IP - адреса, который содержит MAC-адрес групповой адресации. Таким образом, часть MAC Записи ARP показывает как неполная. (Введите команду show arp для просмотра выходных данных.) Как нет никакой части MAC в ответе ARP, Запись ARP никогда не появляется в таблице ARP. Это в конечном счете оставляет ARPing и возвращает Сообщение ICMP Host Unreachable (ICMP узел недоступен) к клиентам. Чтобы отвергнуть это, используйте статическую Запись ARP для начальной загрузки таблицы ARP как показано здесь. В теории это позволяет устройству Сisco заполнять свою таблицу MAC-адресов. Например, если виртуальный IP - адрес 172.16.63.241, и MAC-адрес групповой адресации является 0100.5e11.1111, введите эту команду, чтобы заполнить таблицу ARP статически:

arp 172.16.63.241 0100.5e11.1111

Однако, так как входящие пакеты имеют IP - адрес назначения индивидуальной рассылки и MAC пункта назначения групповой адресации, устройство Сisco игнорирует эту запись и коммутаторы процесса каждый ограниченный кластером пакет. Во избежание этой коммутации в контексте процесса вставьте элемент таблицы статического MAC - адреса как показано здесь чтобы к ограниченным кластером коммутаторов пакетам в аппаратных средствах.

mac-address-table static 0100.5e11.1111 vlan 200 interface fa2/3 fa2/4

Примечание. Статически сопоставление MAC-адреса ко множественным портам поддерживается только в программном обеспечении на коммутаторе Catalyst 4500. Эта конфигурация могла бы вызвать высокую загрузку CPU на коммутаторе Catalyst 4500.

Примечание. Для коммутаторов Cisco Catalyst серии 6500 необходимо добавить отключить-snopping параметр. Например.

mac-address-table static 0100.5e11.1111 vlan 200 интерфейсов fa2/3 fa2/4 отключенный snooping

Отключенный snooping параметр важен и применим только для коммутаторов Cisco Catalyst серии 6500. Без этого оператора не влияют на поведение.

Обратите внимание на то, что на коммутаторах Cisco Catalyst серии 6500 отключение snooping опции доступно только для 0100.5exx.xxxx и 3333.xxxx.xxxx диапазоны MAC-адресов групповой адресации.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание. Используйте Средство поиска команд (только для зарегистрированных клиентов) для получения дополнительной информации по используемым в данном разделе командам.    

Схема сети

В настоящем документе используется следующая схема сети:

107995-config-catalyst-01.gif

Конфигурации

Этот документ использует конфигурацию Catalyst 6509, описанную в этом разделе.

Cat6K#show running-config
Building configuration...
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6K
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin
!
redundancy
main-cpu
 auto-sync standard
ip subnet-zero
!
!
interface GigabitEthernet1/1
no ip address
shutdown
!
interface GigabitEthernet1/2
no ip address
shutdown
!
interface FastEthernet2/1
description "Uplink to the Default Gateway"
no ip address
switchport
switchport access vlan 100
!
interface FastEthernet2/2
no ip address
shutdown
!
interface FastEthernet2/3
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/4
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/5
no ip address
shutdown
!
interface FastEthernet2/48
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
mac-address-table static 0100.5e11.1111 vlan 200 interface fa2/3 fa2/4 disable-snooping

! --- Creating a static entry in the switch for the multicast virtual mac.

! --- fa2/3 & fa2/4 are the ports connected to server.

!--- The disable-snooping is applicable only for Cisco Catalyst 6500 series switches

arp 172.16.63.241 0100.5e11.1111

! --- 172.16.63.241 is the Virtual IP of 2 servers

interface Vlan100
ip address 172.17.63.240 255.255.255.192

!--- Client Side Vlan

!
interface Vlan200
ip address 10.1.1.250 255.255.255.0

!--- Server Vlan

!--- Important: Configure the default gateway

!--- of the Microsoft Server to this address.

!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.63.193
no ip http server
!
line con 0
line vty 0 4
login
!
end

Примечание. Гарантируйте использование режима групповой адресации на кластере NLB. Cisco рекомендует не использовать MAC-адреса групповой адресации, которые начинаются 01, потому что у них, как известно, есть конфликт с настройкой IGMP.

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Интерпретатор выходных данных – OIT (только для зарегистрированных пользователей) поддерживает ряд команд show. Посредством OIT можно анализировать выходные данные команд show.

  • show mac-address-table Отображает определенную статичную таблицу MAC-адресов и динамическая запись или статичная таблица MAC-адресов и динамические записи на определенном интерфейсе или VLAN.

    Cat6K#show mac-address-table 0100.5e11.1111

    Mac Address Table
    -------------------------------------------

    Vlan Mac Address Type Ports
    ---- ----------- -------- -----
    200 0100.5e11.1111 STATIC Fa2/3 Fa2/4
  • show ip arp - Отображает кэш ARP.

    Cat6K#show ip arp
    Protocol Address Age (min) Hardware Addr Type Interface
    Internet 172.16.1.1 - 0100.5e11.1111 ARPA Vlan200

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Дополнительные сведения


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Document ID: 107995