Коммутаторы : ??????????? Cisco Catalyst ????? 3750

Примеры настройки функций качества обслуживания (QoS) на коммутаторах Cisco Catalyst 3750

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (7 апреля 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Коммутаторы Cisco Catalyst 3750 поддерживают различные функции обеспечения качества обслуживания, например классификацию, маркирование, планирование и ограничение трафика, а также формирование очередей. В документе разъясняется работа этих функций обеспечения качества обслуживания (QoS) и приводятся примеры их настройки.

Предварительные условия

Требования

Cisco рекомендует ознакомиться с правилами Настройки функций обеспечения качества обслуживания (QoS).

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Коммутатор Cisco Catalyst 3750 — WS-C3750-24TS

  • Cisco выпуск ПО IOS� 12.2 (35) SE2

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Обзор QoS

С QoS можно предоставить предпочтительную обработку определенным типам трафика за счет других. Можно дифференцировать трафик с помощью меток QoS. Две наиболее часто используемые метки качества обслуживания IP-заголовка 3-го уровня — это поля "Приоритет IP-пакета" и "DSCP". Метка контроля качества обслуживания заголовка кадра уровня 2 называется классом обслуживания (CoS). Программные средства QoS коммутатора Catalyst могут предоставить предпочтительную обработку или на основе меток QoS Уровня 3 или на основе меток QoS Уровня 2. Этот документ предоставляет различные примеры, которые могут дать вам общее представление об Уровне 2, и QoS Уровня 3 маркирует использование в коммутаторах Cisco Catalyst.

/image/gif/paws/91862/cat3750-qos-config1.gif

Коммутатор Cisco Catalyst 3750 без QoS

QoS отключено по умолчанию на Коммутаторах Catalyst 3750. При отключенном контроле качества обслуживания, все кадры и пакеты передаются через коммутатор без изменений. Например, если кадр класса обслуживания 5 и пакетом внутри кадра со значением DSCP, равным EF передается коммутатору, метки класса обслуживания и DSCP не изменяются. Трафик уезжает с тем же CoS и DSCP-значениями, как это входит. Весь трафик, включая голосовой, доставляется с самым высоким приоритетом.

Switch#show mls qos
QoS is disabled
QoS ip packet dscp rewrite is enabled

!--- Even though it says QoS ip packet dscp rewrite is enabled,
!--- the switch does not alter the DSCP label on the packets when 
!--- the QoS is disabled.

Характеристики QoS коммутатора Cisco Catalyst 3750

После включения режима контроля качества (QoS) обслуживания для коммутатора серии 3750, некоторые функции контроля качества входной и выходной сети включаются по умолчанию. Эта схема показывает представление высокого уровня архитектуры QoS коммутатора:

/image/gif/paws/91862/cat3750-qos-config2.gif

Это - сводка точек на основе схемы:

  • Функции обеспечения качества обслуживания входящего трафика, например классификация, маркирование и ограничение трафика, могут быть настроены отдельно для каждого порта.

  • Входные таблицы карты и входная организация очереди могут быть настроены глобально. Их нельзя настроить отдельно для каждого порта.

  • SRR для входной очереди может быть настроен глобально.

  • Кольцевая пропускная способность стека зависит от кабельного подключения стека. Если стек связан в полной полосе пропускания, вы получаете пропускную способность на 32 Гбит/с. Эта пропускная способность разделена всеми коммутаторами в стеке.

  • Выходные таблицы карты и выходные очереди настроены глобально. Можно определить два набора настроек очереди и применить к порту любой из них.

  • SRR для выходной очереди может быть настроен на на порт.

Входные характеристики QoS

Этот раздел объясняет понятия различных возможных входных конфигураций QoS. В этом разделе рассматриваются следующие темы:

Входная конфигурация QoS по умолчанию

Вот как коммутатор по умолчанию обрабатывает кадры после включения средств обеспечения качества обслуживания:

  • Кадр передается порту коммутатора, и он непомечен (что означает, что порт — это порт доступа и кадр принимается коммутатором, не обладая при этом инкапсуляциями видов ISL или dot1q).

  • Коммутатор выполняет инкапсуляцию кадра методом dot1q (игнорируя ISL, поскольку dot1q используется по умолчанию для всех новых коммутаторов).

  • В состав тега кадра dot1q входят три бита, которые называются доступными битами приоритета 802.1p или, иначе, классом обслуживания. Эти биты установлены в 0.

  • Затем коммутатор вычисляет DSCP-значение на основе таблицы КАРТЫ DSCP COS. Согласно таблице, коммутатор устанавливает значение DSCP равным 0. Значение DSCP находится в заголовке IP пакета.

В общем, значения классов обслуживания и DSCP кадра передаются коммутатору по умолчанию со значением 0 тогда, когда средства обеспечения качества обслуживания включены для этого коммутатора.

Классификация и маркировка

В коммутаторах Cisco Catalyst классификация и маркирование уровней качества обслуживания выполняется иначе, чем в маршрутизаторах. В маршрутизаторах Cisco можно классифицировать пакеты с помощью MQC или на основе DSCP-значения входящего пакета или на основе списка контроля доступа (ACL). Это зависит от того, доверяете ли вы метке QoS входящего пакета или нет. В коммутаторе Cisco Catalyst 3750 кадры можно классифицировать либо с учетом входящих значений класса обслуживания и DSCP, либо на основе списка управления доступом.

Настройка по входящему значению класса обслуживания и DSCP достигается тремя различными способами:

  • Порт базировался, конфигурация с помощью интерфейса mls qos базировала команды

  • MQC базировал конфигурацию с помощью команд class-map и policy-map

  • Настройка на базе сети VLAN

Можно использовать любой из этих трех методов. Вы не можете использовать несколько методов в порту. Например, вы настроили команду mls qos trust cos на порту. При настройке порта с командой <policy-map-name> service-policy input он удаляет команду mls qos trust cos автоматически.

Классификация и маркировка - порт, Базирующийся раздел объясняет порт, базировал конфигурацию.

Классификация и маркировка - MQC, Базирующийся раздел объясняет MQC, базировал классификацию.

Классификация и маркировка - базирующийся порт

Этот раздел объясняет классификацию на основе интерфейсной определенной конфигурации. Вопрос может возникнуть с классификацией и маркировкой названия раздела. Это вызвано тем, что в Коммутаторе Cisco Catalyst 3750, CoS или DSCP-значения кадров (пакет в кадре) отмечены с помощью таблиц карты. Таблицы карты не доступны в маршрутизаторах Cisco. Функции, связанные с использованием таблиц, доступны только в коммутаторах Cisco Catalyst. В этом разделе объясняются функции, которые предполагают использование этих таблиц.

В этом разделе описываются следующие две конфигурации:

/image/gif/paws/91862/cat3750-qos-config3.gif

Классификация — настройка доверенных портов

Входящий пакет или кадр может уже обладать меткой качества обслуживания. Эти вопросы могут возникнуть:

  • Вы доверяете метке QoS входящего пакета / кадр на порту?

  • Если IP-телефон и ПК связаны с портом, вы доверяете меткам QoS телефона, ПК или обоих?

Если вы не доверяете меткам QoS входящего пакета / кадр, необходимо классифицировать пакет на основе access-list и метки QoS марки. Если метки качества обслуживания входящего пакета/кадра являются доверенными, то следующим шагом необходимо определить, следует ли доверять значениям класса обслуживания или DSCP пакета/кадра, поступившего на один из портов? Это зависит от сценария. Вы видите другие сценарии с примерами в этом разделе.

Параметры настройки доверия для порта таковы:

Switch(config-if)#mls qos trust ?
  cos            cos keyword
  device         trusted device class
  dscp           dscp keyword
  ip-precedence  ip-precedence keyword
  <cr>
  • Пример 1. Если порт представляет собой порт доступа или порт уровня 3, необходимо настроить команду mls qos trust dscp. Вы не можете использовать команду mls qos trust cos , потому что кадр от порта доступа или порта Уровня 3 не содержит метка ISL или dot1q. Биты класса обслуживания присутствуют только в кадрах dot1q или ISL.

    interface GigabitEthernet1/0/1
     description **** Layer 3 Port ****
     no switchport
     ip address 192.168.10.1 255.255.255.0
     mls qos trust dscp
    end
    interface GigabitEthernet1/0/2
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     mls qos trust dscp
    end
  • Пример 2. Если используемый порт является магистральным, можно настроить либо команду mls qos trust cos, либо mls qos trust dscp. Если порт настроен к trust dscp, таблица сопоставления CoS dscp используется для вычисления значения CoS. Если порт настроен для доверия CoS, точно так же таблица потому-что-карты-DSCP используется для вычисления DSCP-значения.

    interface GigabitEthernet1/0/3
    description **** Trunk Port ****
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk native vlan 5
    switchport trunk allowed vlan 5,10,20,30,40,50
    mls qos trust cos
    end
    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end
    
    !--- The Cisco IP Phone uses IEEE 802.1Q frames for Voice 
    !--- VLAN traffic.
    
    
  • Пример 3: Если порт будет магистральным портом dot1q, и порт настроен с командой mls qos trust cos, то кадры собственного VLAN будут иметь CoS и DSCP-значения как 0. Поскольку кадры собственного VLAN без меток, и кадр помечен после того, как он введет коммутатор, коммутатор установит значение CoS по умолчанию в 0 и настольные приемники CoS-to-DSCP DSCP-значение к 0.

    Примечание: Значение DSCP пакета, получаемого от собственной сети VLAN, будет установлено равным 0.

    Можно также настроить порт коммутатора на изменение нулевого значения класса обслуживания по умолчанию для неотмеченных тегами кадров на любое другое в диапазоне от 0 до 7 при помощи команды mls qos cos<0-7>. Эта команда не изменяет значений CoS для кадров, отмеченных тегами.

    Например, порт GigabitEthernet1/0/12 настроен с VLAN 10 доступа и голосовым VLAN 20.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    
    !--- The Cisco IP Phone uses IEEE 802.1Q frames for Voice 
    !--- VLAN traffic. Voice VLAN is only supported on access ports and not  
    !--- on trunk ports, even though the configuration is allowed.
    
    end

    По умолчанию ПК передает данные без меток. Неотмеченный тегами трафик от устройства, подключенного к телефону Cisco IP Phone, проходит через телефон без изменений, вне зависимости от состояния доверия порта доступа телефона. Телефон передает маркированные кадры dot1q с идентификатором голосовой VLAN 20. Поэтому, если порт настроен при помощи команды mls qos trust cos, он доверяет значениям класса обслуживания кадров, отправляемых с телефона (кадры, отмеченные тегами), и обнуляет значения класса обслуживания кадров, передаваемых от ПК (кадры, не отмеченные тегами). После этого, настольные приемники КАРТЫ DSCP COS DSCP-значение пакета в кадре к 0, потому что таблица КАРТЫ DSCP COS имеет DSCP-значение 0 для значения CoS 0. Если пакеты от ПК будут иметь какое-либо определенное DSCP-значение, то то значение будет перезагружено к 0. При настройке команды mls qos cos 3 на порту она устанавливает значение CoS всех кадров от ПК до 3 и не изменяет значение CoS кадров с телефона.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     mls qos cos 3
     spanning-tree portfast
    end

    При настройке порта с командой mls qos cos 3 override он устанавливает значения CoS всех кадров (и тэговое и без меток) к 3. Это отвергает ранее настроенные трастовые значения.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     mls qos cos 3 override
    
    !--- Overrides the mls qos trust cos.
    
    
    !--- Applies CoS value 3 on all the incoming packets on both 
    !--- the vlan 10 and 20.
    
     spanning-tree portfast
    end
  • Пример 4. Например, пусть порт gi 1/0/12 настроен следующим образом:

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end

    Если ПК присваивает своему кадру тег идентификатора VLAN 20, это также устанавливает значение класса обслуживания равным пяти. Коммутатор обрабатывает тэговый трафик данных (трафик в типах фрейма IEEE 802.1Q или IEEE 802.1p) от устройства, подключенного к порту доступа на Cisco IP Phone. Поскольку интерфейс настроен на доверие значению класса обслуживания, весь трафик, получаемый через порт доступа телефона IP Cisco Phone, проходит через телефон без изменений. Коммутатор также доверяет и позволяет трафик от ПК и уделяет тому же первостепенное значение как трафику IP-телефона. Это не выбираемый результат, который вы хотите видеть. Этого можно избежать при помощи команды switchport priority extend cos <cos-value>.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     switchport priority extend cos 0
    
    !--- Overrides the CoS value of PC traffic to 0.
    
     spanning-tree portfast
    end

    Команда switchport priority extend cos <cos-value> выполняет настройку IP-телефона таким образом, что в нем происходит обнуление значений класса обслуживания трафика ПК.

  • Пример 5:, Например, в том же интерфейсе, кто-то подключает ПК непосредственно с коммутатором и помечает данные ПК с кадром dot1q с более высоким значением CoS. Это может избегаться использования команда cisco-phone устройства mls qos trust .

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     switchport priority extend cos 0
     mls qos trust device cisco-phone 
    
    !--- Specify that the Cisco IP Phone is a trusted device.
    
     spanning-tree portfast
    end
  • Пример 6: Например, в интерфейсе GigabitEthernet1/0/12, необходимо доверять меткам QoS от ПК. Кроме того, ПК связан с собственным VLAN 10. В этом случае команда mls qos trust cos, не сработает, поскольку пакет, передаваемый от ПК, не содержит необходимого значения класса обслуживания. При помощи тега будет добавлено только значение DSCP. Поэтому коммутатор добавляет, что dot1q структурирует, и настраивает значение CoS по умолчанию к 0. Затем таблица DSCP CoS вычисляет и перезагружает DSCP-значение к 0.

    Решить эту проблему можно двумя способами. Нужно настроить классификацию и маркировку с помощью MQC. Можно создать ACL для соответствия с трафиком компьютера на основе источника, IP - адресов назначения и источника/номеров порта назначения. Затем можно совпасть с этим ACL в class-map. Можно создать policy-map для доверия этому трафику. Это решение описывается в следующем разделе. В этом разделе рассматриваются второй метод. Второй метод должен доверять метке DSCP вместо метки CoS. После этого метка DSCP-CoS используется для вычисления и установки значения класса обслуживания, которое соответствует значению DSCP.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust dscp
     spanning-tree portfast
    end

    Первый метод является предпочтительным, потому что не рекомендуется доверять меткам QoS всего трафика компьютера.

Маркирование — настройка таблиц карт качества обслуживания (QoS)

После включения функций качества обслуживания, таблицы карт создаются со значениями по умолчанию и, затем, применяются.

Distribution1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 24 32 40 48 56

Distribution1#show mls qos maps dscp-cos
   Dscp-cos map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 00 00 00 00 00 00 00 01 01
      1 :    01 01 01 01 01 01 02 02 02 02
      2 :    02 02 02 02 03 03 03 03 03 03
      3 :    03 03 04 04 04 04 04 04 04 04
      4 :    05 05 05 05 05 05 05 05 06 06
      5 :    06 06 06 06 06 06 07 07 07 07
      6 :    07 07 07 07
  • Пример 1 : Если порт настроен к доверие, потому что, всем входящим значениям CoS доверяют, и DSCP-значения отмечены на основе таблицы DSCP CoS. Согласно конфигурации DSCP CoS по умолчанию, значения сопоставлены как показано здесь:

    CoS DSCP (десятичное) DSCP
    0 0 По умолчанию
    1 8 CS1
    2 16 CS2
    3 24 CS3
    4 32 CS4
    5 40 CS5
    6 48 CS6
    7 56 CS7

    Важное значение, которое необходимо принять во внимание, это значение DSCP, которое соответствует классу обслуживания 5. Это - CS5. Пример 2 переговоров об этом значении.

  • Пример 2:, Например, интерфейс GigabitEthernet1/0/12 настроен для доверия CoS.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end

    Cisco IP Phone отмечает речевые данные с CoS 5 и EF DSCP, когда это передает трафик к коммутатору. При входе трафика в порт Gi 1/0/12, коммутатор доверяет значению класса обслуживания. После этого, коммутатор выводит значение DSCP CS5 (40) для значения класса обслуживания 5 из таблицы сопоставления класса обслуживания и DSCP. Все речевые данные с CoS 5 отмечены с DSCP-значением CS5. Использование этого значения нежелательно. Необходимое значение DSCP для полезной голосовой нагрузки — DSCP EF. По умолчанию другие значения CoS к DSCP-значениям сопоставлены правильно согласно RFC.

    Эта конфигурация помогает вам настраивать таблицу КАРТЫ DSCP COS для изменения EF DSCP-значения, который соответствует CoS 5.

    Distribution1(config)# mls qos map cos-dscp 0  8 16 
    24 32 46 48 56
    
    !--- DSCP 46 is EF
    
    

    После этой конфигурации значения сопоставлены как показано здесь:

    CoS DSCP (десятичное) DSCP
    0 0 По умолчанию
    1 8 CS1
    2 16 CS2
    3 24 CS3
    4 32 CS4
    5 46 EF
    6 48 CS6
    7 56 CS7

  • Пример 3: Если порт настроен к trust DSCP, всем входящим DSCP-значениям доверяют, и значения CoS отмечены на основе таблицы CoS DSCP. Согласно Конфигурации CoS DSCP по умолчанию, значения сопоставлены как показано здесь:

    DSCP DSCP (десятичное) CoS
    По умолчанию 0-7 0
    CS1 AF11 AF12 AF13 8-15 1
    CS2 AF21 AF22 AF23 16-23 2
    CS3 AF31 AF32 AF33 24-31 3
    CS4 AF41 AF42 AF43 32-39 4
    CS5 EF 40-47 5
    CS6 48-55 6
    CS7 56-63 7

    Вы не должны изменять эти значения по умолчанию.

Эта таблица суммирует DSCP-значения и значения CoS только для ссылки:

DSCP (десятичное) DSCP CoS
0 По умолчанию 0
     
8 CS1 1
10 AF11 1
12 AF12 1
14 AF13 1
     
16 CS2 2
18 AF21 2
20 AF22 2
22 AF23 2
     
24 CS3 3
26 AF31 3
28 AF32 3
30 AF33 3
     
32 CS4 4
34 AF41 4
36 AF42 4
38 AF43 4
     
40 CS5 5
42   5
44   5
46 EF 5
     
48 CS6 6
     
56 CS7 7

Примечание: В сети все коммутаторы Cisco Catalyst должны иметь идентичные таблицы карты. Другие значения таблицы карты в других коммутаторах вызывают нежелательное поведение QoS.

Классификация и маркировка - базирующийся MQC

Как объяснено в разделе Классификации и маркировки, можно использовать MQC, чтобы классифицировать и отметить пакет. Можно использовать MQC вместо порта определенная конфигурация. Можно также отметить входящие пакеты с policy-map.

Требования данного примера:

  • Доверяйте значениям CoS трафика IP-телефона.

  • DSCP-значение Марка пакетов приложения SoftPhone от ПК, который связан IP-телефон.

  • Не доверяйте всему другому трафику от ПК.

cat3750-qos-config4.gif

Эта схема показывает, что policy-map присоединен к вводу интерфейса. Вы не можете применить policy-map к выходным данным никаких интерфейсов в Коммутаторе Catalyst 3750. Следующая конфигурация представляет схему. Этот раздел не фокусируется на части организации очереди Характеристики QoS. Раздел просто фокусируется на MQC, примененном на интерфейс.

Предполагается VLAN для передачи данных равняется 10, и его адрес подсети является 172.16.10.0/24. Голосовой VLAN равняется 100, и его адрес подсети является 192.168.100.0/24.


!--- Section A

Distribution1(config)#ip access-list extended voice-traffic
Distribution1(config-std-nacl)#permit ip 192.168.100.0 0.0.0.255 any

Distribution1(config-std-nacl)#ip access-list extended
 database-application
Distribution1(config-ext-nacl)#permit tcp any any eq 1521
Distribution1(config-ext-nacl)#permit tcp any any eq 1810
Distribution1(config-ext-nacl)#permit tcp any any eq 2481
Distribution1(config-ext-nacl)#permit tcp any any eq 7778
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map  Class-A
Distribution1(config-cmap)#match access-group name voice-traffic
Distribution1(config-cmap)#exit
Distribution1(config)#class-map  Class-B
Distribution1(config-cmap)#match access-group name
 database-application
Distribution1(config-cmap)#exit


!--- Section B

Distribution1(config)#policy-map sample-policy1
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#trust cos
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#class Class-B
Distribution1(config-pmap-c)#set dscp af21
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Section C

Distribution1(config)#interface gigabitEthernet 1/0/13
Distribution1(config-if)#switchport access vlan 10
Distribution1(config-if)#switchport mode access
Distribution1(config-if)#switchport voice vlan 100
Distribution1(config-if)#spanning-tree portfast
Distribution1(config-if)#service-policy input sample-policy1
Distribution1(config-if)#exit

Раздел A:

  • Классифицирует трафик IP-телефона к Классу A. IP-телефон принадлежит голосовому VLAN и имеет IP-адрес в 192.168.100.0 подсетях.

  • Классификация трафика приложений баз данных как принадлежащего к классу B (Class-B). Трафик компьютера (практически любой трафик согласно заданной конфигурации), направляемый на любой адрес через порты 1521, 1810, 2481 и 7778, классифицируется как принадлежащий карте Class-B.

Раздел B:

  • Трафик совпадает, Класс A настроены для доверия метке CoS. Это означает, что доверяют значениям CoS всего трафика от IP-телефона. Поскольку это показывают в схеме, DSCP-значение получено из таблицы КАРТЫ DSCP COS для трафика Класса A.

  • Трафик совпадает, Класс B настроены для установки DSCP-значения в AF21. Поскольку это показывают в схеме, значение DCoS получено на таблицу Сопоставления CoS DSCP для трафика Класса B.

  • Конфигурации под каждым классом policy-map называют действиями PHB. Маркировка, помещая в очередь, определяя политику, формируя, и предотвращение перегрузки является поддерживаемыми действиями PHB в маршрутизаторах Cisco. Маркировка и применение политик являются единственными поддерживаемыми действиями PHB в Коммутаторе Cisco Catalyst 3750.

    Distribution1(config)#policy-map test
    Distribution1(config-pmap)#class test
    Distribution1(config-pmap-c)#?
    QoS policy-map class configuration commands:
      exit            Exit from QoS class action configuration mode
      no              Negate or set default values of a command
      police          Police
      service-policy  Configure QoS Service Policy
      set             Set QoS values
      trust           Set trust value for the class
      <cr>

    Набор и трастовые команды маркируют действия PHB. Можно настроить или набор или трастовое действие PHB. Вы не можете настроить обоих действия в одном классе policy-map. Однако можно настроить набор в одном классе и доверие другому классу в том же policy-map.

    Команда политики является действием PHB Применения политик. Это обсуждено подробно в следующем разделе.

    Формирование не поддерживается в Коммутаторе Cisco Catalyst 3750. Организация очереди и предотвращение перегрузки поддерживается в Коммутаторе Cisco Catalyst 3750, но не является конфигурируемым MQC использования. Организация очереди и конфигурации предотвращения перегрузки обсуждена подробно позже в этом документе.

C раздела:

  • Policy-map может быть применен только к вводу на интерфейсе. При применении к выходному интерфейсу вы получаете это сообщение об ошибках:

    Distribution1(config)#int gi 1/0/3
    Distribution1(config-if)#service-policy output test
    Warning: Assigning a policy map to the output side of an
             interface not supported
    
    Service Policy attachment failed
    Warning: Assigning a policy map to the output side of an
             interface not supported
  • Если какие-либо другие методы классификации QoS, такие как основанный порт или основанная VLAN, настроены на gns порта 1/0/3, те конфигурации удалены при применении policy-map. Например, GRS порта 1/0/13 настроены для доверия CoS как показано здесь:

    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     mls qos cos 3
     mls qos trust cos
     spanning-tree portfast
  • При применении policy-map к интерфейсу он удаляет трастовую команду.

    Distribution1(config)#int gi 1/0/13
    Distribution1(config-if)#service-policy input sample-policy1
    Distribution1(config-if)#do show run int gi 1/0/13
    Building configuration...
    
    Current configuration : 228 bytes
    !
    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     service-policy input sample-policy1  
     
    !--- It replaces the mls qos trust or mls qos 
    !--- vlan-based command.
    
     mls qos cos 3    
     
    !--- This command is not removed.
    
     spanning-tree portfast
    end

    Здесь наглядно показано, что при применении политик обслуживания на входящем интерфейсе заменяются только команды mls qos trust либо mls qos vlan-based. Это не изменяет другие команды, такие как команды mls qos cos или mls qos dscp-mutation . Таким образом, это заменяет команду классификации QoS и не заменяет маркировки команд QoS.

  • В policy-map вы видите только два карт классов. Класс A совпадает с трафиком IP-телефона, и Класс B совпадает с трафиком приложения базы данных от ПК. Весь другой трафик компьютера (кроме приложения базы данных, определенного в access-list), классифицирован под классом класс по умолчанию policy-map. Это - общий трафик, который ловит трафик, который не совпадает с определенными картами классов, подключенными к policy-map. Поэтому этому трафику, который принадлежит class-default, не доверяет порт, и те пакеты установлены с CoS по умолчанию и метками DSCP как 0. Для данного неклассифицируемого трафика можно задать любое значение CoS или DSCP по умолчанию.

    Задать значение DSCP по умолчанию можно при помощи MQC. Значение CoS получено из таблицы Сопоставления CoS DSCP.

    Distribution1(config)#policy-map sample-policy1
    Distribution1(config-pmap)#class class-default
    Distribution1(config-pmap-c)#set dscp af13
    Distribution1(config-pmap-c)#exit
    

    Значение CoS по умолчанию задается следующим образом. DSCP-значение получено из таблицы КАРТЫ DSCP COS.

    Distribution1(config)#int gi 1/0/13
    Distribution1(config-if)#mls qos cos 3
    Distribution1(config-if)#do show run int gi 1/0/13
    Building configuration...
    
    Current configuration : 228 bytes
    !
    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     service-policy input sample-policy1  
     mls qos cos 3    
     spanning-tree portfast

Установите наивысший приоритет в трафик

В данном примере конфигурация используется для установки наивысшего приоритета в трафик от порта TCP 1494.

  1. Трафику VoIP нужно назначить DSCP-значение EF:

    
    !--- Classifying all traffic coming with dscp value of EF 
    !--- under this class-map.
    
    Switch(config)# class-map match-all AutoQoS-VoIP-RTP-Trust
    Switch(config-cmap)# match ip dscp ef 
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class AutoQoS-VoIP-RTP-Trust
    
    !--- Again setting the dscp value back to EF.
    
    Switch(config-pmap-c)# set dscp ef
    Switch(config-pmap-c)# police 320000 8000 exceed-action 
    policed-dscp-transmit
    
  2. Трафику от TCP 1494 нужно назначить DSCP-значение CS4:

    Switch(config)# access-list 100 permit tcp <source source-wildcard>
                 <destination destination-wildcard> eq 1494
    
    Switch(config)# class-map tcp 
    Switch(config-cmap)# match access-group 100
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class tcp
    Switch(config-pmap-c)# set dscp cs4
    
  3. Всему другому трафику нужно назначить CS3:

    Switch(config)# access-list 200 permit ip any any
    
    Switch(config)# class-map default
    Switch(config-cmap)# match access-group 200
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class default
    Switch(config-pmap-c)# set dscp cs3
    
  4. Примените его под соответствующими интерфейсами:

    Switch(config)# interface <interface-type><interface number>
    
    Switch(config-if)# service-policy <policy-map-name>
    
    

Применение политик

На Коммутаторе Cisco Catalyst 3750 применение политик может только быть настроено на входном порту. Применение политик может только быть настроено через MQC. Это означает, что нет никакой интерфейсной определенной команды для применения политик трафика. Можно настроить применение политик в policy-map, и можно применить policy-map с помощью только команду <policy-name> service-policy input. Вы не можете применить policy-map к стороне вывода интерфейса.

Distribution1(config-if)#service-policy output test
police command is not supported for this interface
Configuration failed!
Warning: Assigning a policy map to the output side of an 
         interface not supported.

В этом разделе рассматриваются эти темы:

Классификация, маркирование и ограничение трафика (действие при превышении — drop)

Этот раздел объясняет настройку ограничителя скорости, которая отбрасывает избыточный трафик. При включенном ограничении входящий трафик измеряется, а его скорость поддерживается на постоянном уровне (в битах в секунду). Поддержка коммутаторов Cisco Catalyst 3750 только одиночная скорость, одиночное применение политик блока. Это означает метры коммутатора только на одной скорости, и она может представить трафик в двух действиях приведения в соответствие и превышения цветов. Схема показывает выборку-policy2 policy-map с тремя картами классов.

Требования данного примера:

  • Ftp политики, pop3, трафик imap к 10 Мбит/с.

  • Доверяйте DSCP-значению пакетов приложения IP-коммуникатора от ПК, который связан с IP-телефоном. Кроме того, требование должно определить политику этот трафик к 1 Мбит/с.

  • Настройте маркирование и ограничение трафика приложения filnet.

cat3750-qos-config5.gif

Эта конфигурация представляет policy-map, упомянутый в схеме:


!--- Create Access-list and Class map Class-A

Distribution1(config)#ip access-list extended BULK-DATA
Distribution1(config-ext-nacl)#permit tcp any any eq ftp
Distribution1(config-ext-nacl)#permit tcp any any eq ftp-data
Distribution1(config-ext-nacl)#permit tcp any any eq pop3
Distribution1(config-ext-nacl)#permit tcp any any eq 143
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name BULK-DATA
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-B

Distribution1(config)#ip access-list extended IP-Communicator
Distribution1(config-ext-nacl)#remark *** Voice Payload ***
Distribution1(config-ext-nacl)#permit udp any any range 16384 32767
Distribution1(config-ext-nacl)#remark *** Voice Signalling ***
Distribution1(config-ext-nacl)#permit tcp any any range 2000 2002
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-B
Distribution1(config-cmap)#match access-group name IP-Communicator
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-C

Distribution1(config)#ip access-list extended application
Distribution1(config-ext-nacl)#remark *** Application for example ***
Distribution1(config-ext-nacl)#permit tcp any any eq 32768
Distribution1(config-ext-nacl)#permit udp any any eq 32768
Distribution1(config-ext-nacl)#permit tcp any any eq 32769
Distribution1(config-ext-nacl)#permit udp any any eq 32769
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-C
Distribution1(config-cmap)#match access-group name application
Distribution1(config-cmap)#exit


!--- Create Policy map

Distribution1(config-cmap)#policy-map sample-policy2
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#police 10000000 8000 exceed-action drop
Distribution1(config-pmap-c)#class Class-B
Distribution1(config-pmap-c)#trust dscp
Distribution1(config-pmap-c)#police 256000 8000 exceed-action drop
Distribution1(config-pmap-c)#class Class-C
Distribution1(config-pmap-c)#set dscp CS2
Distribution1(config-pmap-c)#police 25000000 8000 exceed-action drop
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Apply Policy map to the interface

Distribution1(config)#interface GigabitEthernet1/0/20
Distribution1(config-if)#service-policy input sample-policy2

Пояснения к конфигурации карты политик:

  • Класс А: Класс соответствия трафика A охраняется по курсу 10 Мбит/с. Метки качества обслуживания (QoS) для трафика данного класса не являются доверенными. CoS и DSCP-значения отмечены как 0. Избыточные пакеты отбрасываются ограничителем трафика.

  • Class-B. Для трафика, соответствующего данному классу, возможно выполнение двух действий PHB. Первое действие — доверие, второе — ограничение трафика. DSCP-значению для трафика Класса B доверяют. Значение CoS будет получено таблица CoS DSCP. Кроме того, скорость трафика класса B ограничивается до уровня 256 Кбит/с. Избыточные пакеты отбрасываются ограничителем трафика.

  • Class-С. Для трафика, соответствующего данному классу, возможно выполнение двух действий PHB. Первое действие — маркировка, второе — ограничение трафика. Входящие пакеты, которые совпадают с Классом C, отмечены с DSCP-значением CS2, и значение CoS получено из таблицы CoS DSCP, которая равняется 2. Кроме того, скорость трафика класса С ограничивается до уровня 25 Мбит/с. Избыточные пакеты отбрасываются ограничителем трафика.

Классификация, маркирование и ограничение трафика (действие при превышении - policed-dscp-transmit)

Раздел посвящен настройкам функции ограничения трафика, при которых выполняется маркирование и передача избыточного трафика. На диаграмме показана карта политик sample-policy3 с тремя картами классов:

/image/gif/paws/91862/cat3750-qos-config6.gif

Коммутатор отмечает трафик, который превышает настроенное ограничение скорости на основе табличных значений ОХРАНЯЕМОЙ КАРТЫ DSCP. ОХРАНЯЕМАЯ КАРТА DSCP Используется только, когда она настроена в настройке ограничителя скорости. Таблица ОХРАНЯЕМОЙ КАРТЫ DSCP по умолчанию перечислена здесь:

Distribution1(config)#do show mls qos map policed-dscp
   Policed-dscp map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 01 02 03 04 05 06 07 08 09
      1 :    10 11 12 13 14 15 16 17 18 19
      2 :    20 21 22 23 24 25 26 27 28 29
      3 :    30 31 32 33 34 35 36 37 38 39
      4 :    40 41 42 43 44 45 46 47 48 49
      5 :    50 51 52 53 54 55 56 57 58 59
      6 :    60 61 62 63

От этой таблицы вы видите, что совпадают с теми же DSCP-значениями. Например, DSCP 34 сопоставлен с DSCP 34. Трафик, который соответствует скорости ограничителя, передан, не изменяя DSCP-значение. Трафик, который превышает скорость ограничителя, может быть передан с другим DSCP-значением. Например, это может быть отмечено с DSCP-значением, которое имеет большую вероятность, которая будет отброшена.

При использовании ОХРАНЯЕМЫХ DSCP-ЗНАЧЕНИЙ по умолчанию это не целесообразно использовать применение политик. Например, вы настроили для применения политик трафика по курсу 10 Мбит/с. Входящий пакет имеет DSCP-значение CS4. При хранении DSCP-значения по умолчанию трафик, который приспосабливает 10 Мбит/с, передан с DSCP-значением CS2. Кроме того, трафик, который превышает 10 Мбит/с, передан с DSCP-значением CS2. Это вызвано тем, что значения по умолчанию ОХРАНЯЕМОЙ КАРТЫ DSCP сопоставляют те же значения. Поэтому рекомендуется настроить таблицу ОХРАНЯЕМОЙ КАРТЫ DSCP соответственно для дифференциации DSCP-значений.

Требования данного примера:

  • Настройте таблицу ОХРАНЯЕМОЙ КАРТЫ DSCP для сопоставления:

    • EF сопоставлено с AF31

    • CS3 сопоставлено с AF13

    • CS2 к AF11

  • Доверяйте DSCP-значениям пакетов IP-коммуникатора и определите политику его к 256 Кбит/с. Если трафик превышает 256 Кбит/с, отметьте DSCP-значения с помощью таблицы ОХРАНЯЕМОЙ КАРТЫ DSCP.

  • Настройте маркирование и ограничение трафика приложения filnet. Если трафик превышает 25 Мбит/с, отметьте DSCP-значения с помощью таблицы ОХРАНЯЕМОЙ КАРТЫ DSCP.

Эта конфигурация представляет policy-map, упомянутый в схеме:


!--- Policed DSCP table Configuration

Distribution1(config)#mls qos map policed-dscp 46 to 26
Distribution1(config)#mls qos map policed-dscp 24 to 14
Distribution1(config)#mls qos map policed-dscp 16 to 10


!--- Create Access-list and Class map Class-A

Distribution1(config)#ip access-list extended IP-Communicator
Distribution1(config-ext-nacl)#remark *** Voice Payload ***
Distribution1(config-ext-nacl)#permit udp any any range 16384 32767
Distribution1(config-ext-nacl)#remark *** Voice Signalling ***
Distribution1(config-ext-nacl)#permit tcp any any range 2000 2002
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name IP-Communicator
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-C

Distribution1(config)#ip access-list extended application
Distribution1(config-ext-nacl)#remark *** Application for example ***
Distribution1(config-ext-nacl)#permit tcp any any eq 32768
Distribution1(config-ext-nacl)#permit udp any any eq 32768
Distribution1(config-ext-nacl)#permit tcp any any eq 32769
Distribution1(config-ext-nacl)#permit udp any any eq 32769
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-B
Distribution1(config-cmap)#match access-group name application
Distribution1(config-cmap)#exit


!--- Create Policy map

Distribution1(config-cmap)#policy-map sample-policy3
Distribution1(config-pmap-c)#class Class-A
Distribution1(config-pmap-c)#trust dscp
Distribution1(config-pmap-c)#police 256000 8000 exceed-action 
policed-dscp-transmit
Distribution1(config-pmap-c)#class Class-B
Distribution1(config-pmap-c)#set dscp CS2
Distribution1(config-pmap-c)#police 25000000 8000 exceed-action 
policed-dscp-transmit
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Apply Policy map to the interface

Distribution1(config)#interface GigabitEthernet1/0/21
Distribution1(config-if)#service-policy input sample-policy3

Пояснения к конфигурации карты политик:

  • Policed-DSCP. Три значения из таблицы сопоставлений policed-DSCP изменяются при сопоставлении.

    • EF сопоставлено с AF31

    • CS3 сопоставлено с AF13

    • CS2 к AF11

    Первые два значения изменяются в зависимости от типа трафика, классифицируемого при помощи карт классов Class-A и Class-B.

  • Class-A. Голосовая полезная нагрузка и модуляция голосового сигнала программным телефоном классифицируются при помощи карты Class-A. Голосовой полезный трафик имеет значение DSCP, равное EF, а трафик голосового управления имеет значение DSCP, равное CS3. Согласно конфигурации карты политик эти значения DSCP являются доверенными. Скорость ограничения трафика данного класса: 256 Кбит/с. Трафик, соответствующий данному критерию регулирования, пересылается без изменения значения DSCP на входе. Трафик, превышающий скорость ограничения, перемаркируется при помощи таблицы сопоставления policed-DSCP и передается далее. Согласно заданным настройкам таблица сопоставления policed-DSCP выполняет перемаркировку EF в AF31, а CS3 в AF13. Затем значения CoS получаются при помощи таблицы DSCP-CoS.

  • Class-B. Входящие пакеты, соответствующие критериям данного класса, маркируются значением DSCP, равным CS2. Скорость ограничения трафика данного класса: 25 Мбит/с. Трафик, не превышающий данной скорости, передается со значениям DSCP, равным 2, и со значением CoS, получаемым из таблицы сопоставлений DSCP-CoS (в данном случае 2). Трафик, превышающий скорость ограничения, перемаркируется при помощи таблицы сопоставления policed-DSCP и передается далее. Охраняемая таблица DSCP отметит EF к AF31 и CS3 к AF13 согласно значениям configred. Затем значения CoS получаются при помощи таблицы DSCP-CoS.

Управление перегрузками сети и предотвращение

Управление перегрузками сети и предотвращение являются тремя процессами шага. Это организация очереди, отбрасывание пакетов и планирование нагрузки. Организация очереди размещает пакеты в другие очереди программного обеспечения на основе меток QoS. Коммутатор Cisco Catalyst 3750 имеет две входных очереди. После того, как трафик классифицирован и отмечен с метками QoS, можно назначить трафик в две других очереди на основе меток QoS.

Взвешенное отбрасывание остатка (WTD) используется, чтобы управлять длинами очереди и предоставить приоритеты отбрасывания для других классификаций трафика.

И вход и выходные очереди обслуживаются SRR, который управляет скоростью, на которой переданы пакеты. На входных очередях SRR передает пакеты вызову стека. SRR может работать в двух режимах: профилирования трафика и совместного использования. Для входящих очередей совместное использование является режимом по умолчанию, а также единственным поддерживаемым режимом. В режиме совместного использования очереди в заданной пропорции используют общую полосу пропускания. Полоса пропускания на этом уровне гарантирована, однако им не ограничена.

Этот раздел объясняет три типа конфигураций.

Команды, доступные для настройки их:

Distribution1(config)#mls qos srr-queue input ?

!--- Queueing

  buffers         Configure buffer allocation
  cos-map         Configure cos-map for a queue id
  dscp-map        Configure dscp-map for a queue id

!--- Scheduling

  bandwidth       Configure SRR bandwidth
  priority-queue  Configure priority scheduling

!--- Dropping

  threshold       Configure queue tail-drop thresholds

Организация очереди по умолчанию, понижаясь и планируя конфигурацию

Эти выходные данные показывают метку QoS по умолчанию сопоставлению очередности. Каждая очередь может поддержать три пороговых уровня. По умолчанию каждая поддержка очереди имеет только одно пороговое значение, которое составляет 100%.

cat3750-qos-config7.gif

  • Конфигурация карты очереди по умолчанию:

    Пакеты с CoS 5 (DSCP 40 to 47) размещены в очередь 2. Пакеты, которые остаются, размещены в queue1.

    Distribution1#show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-1 1-1 1-1 1-1 1-1 2-1 1-1 1-1
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
          0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
          5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          6 :  01-01 01-01 01-01 01-01

    Эта таблица представляет CoS/DSCP по умолчанию сопоставлению входной очереди:

    CoS DSCP Входная очередь
    0 От 0 до 7 1
    1 8 - 15 1
    2 16 - 23 1
    3 24 - 31 1
    4 32 - 39 1
    5 40 - 47 2
    6 48 - 55 1
    7 56 - 63 1

  • Конфигурация очереди по умолчанию:

    Буфер Входной очереди разделен 90% очередью 1 и 10% очередью 2. Пороговые уровни 1, 2 и 3 составляют 100%.

    Distribution1#show mls qos input-queue
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100
    
  • Конфигурация планировщика по умолчанию:

    Очередь 2 является приоритетной. В соответствии с заданной пропорцией на обслуживание приоритетной очереди SRR выделяет 10% полосы пропускания. Остальные 90% SRR выделяет для совместного использования обеими входящими очередями и обслуживает их в заданном соотношении. В данном случае на обе очереди (1 и 2) выделяется по 45%.

    Distribution1#show mls qos input-queue
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100

Формирование очередей и планирование нагрузки

Настройка формирования очередей и планирования нагрузки осуществляется в три этапа. Этапы настройки:

  1. Конфигурация карты очереди:

    Настроенная карта очереди используется для распределения пакетов на две входящие очереди в зависимости от значений DSCP или класса обслуживания (CoS).

  2. Конфигурация очереди:

    Конфигурация очереди задает пропорцию (выделение заданного объема), в которой входящий трафик распределяется по двум очередям в буферы ввода.

  3. Конфигурация планировщика:

    SRR configurs соотношение весов, которое управляет частотой исключения из очереди пакетов от очередей к вызову стека.

Очередь и конфигурации планировщика управляют, сколько данных может быть буферизовано, прежде чем пакеты отброшены.

cat3750-qos-config8.gif

В этом разделе не настроены уровни отбрасывания WTD. Т. е. пакеты отбрасываются при 100-процентном заполнении очереди.

  • Конфигурация карты очереди:

    Сначала очередям сопоставляются значения класса обслуживания (CoS). В этом разделе не настроены пороговые значения.

    
    !--- Assign the frames into the queue based on the CoS value.
    
    Distribution1(config)#mls qos srr-queue input cos-map
     queue 1 0 1 
    Distribution1(config)#mls qos srr-queue input cos-map
     queue 2 2 3 4 5 6 7
    
    
    !--- Show output.
    
    Distribution1#show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-1 1-1 2-1 2-1 2-1 2-1 2-1 2-1
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2   0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
         5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         6 :  01-01 01-01 01-01 01-01

    Здесь показан конфликт между картами сопоставлений Cos-inputq-threshold и Dscp-inputq-threshold. Например, класс обслуживания CoS 3 определен для очереди 2 в таблице Cos-inputq-threshold. Однако значение DSCP, равное 24 (которое соответствует классу обслуживания CoS 3) передается очереди 1 согласно условиям карты Dscp-inputq-threshold. Фактически, карта Dscp-inputq-threshold замещает настройки карты Cos-inputq-threshold. Эти сопоставления должны по возможности соответствовать друг другу, чтобы обеспечить предсказуемость операций и упростить устранение проблем. Поэтому карта Dscp-inputq-threshold настраивается таким образом, чтобы обеспечить синхронизацию с картой Cos-inputq-threshold.

    
    !--- Assign the frames into the queue based on the DSCP value.
    
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      16 17 18 19 20 21 22 23
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      24 25 26 27 28 29 30 31
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      32 33 34 35 36 37 38 39
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      48 49 50 51 52 53 54 55
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      56 57 58 59 60 61 62 63
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0   1   2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 02-01 02-01 02-01 02-01
         2 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         3 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         5 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         6 :  02-01 02-01 02-01 02-01
  • Конфигурация очереди:

    IOS выделяет место по умолчанию в буфере для организации очереди входящих пакетов после того, как будет включено QoS. Обе входящие очереди (1 и 2) совместно используют буферное пространство. В коммутаторе Catalyst 3750 можно задать процентное соотношение, в котором это буферное пространство будет использоваться каждой из очередей. 67% общей доступной памяти для входной очереди выделены для организации очереди 1, и 33% выделен для организации очереди 2.

    Distribution1(config)#mls qos srr-queue input buffers 67 33
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100
  • Конфигурация планировщика:

    Эта конфигурация выполнена с командой mls qos srr-queue input bandwidth. Здесь, эта пропускная способность сообщает что сумма битов, обслуживаемых SRR на очередях.

    Distribution1(config)#mls qos srr-queue input bandwidth 90 10
    Distribution1(config)#mls qos srr-queue input priority-queue 2 
    bandwidth 20
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :      90      10
    priority  :       0      20
    threshold1:     100     100
    threshold2:     100     100

    По умолчанию очередь 2 является очередью с приоритетами, и 10% общей внутренней кольцевой пропускной способности выделены очереди с приоритетами. Можно также настроить очередь 1 как очередь с приоритетами. Однако вы не можете настроить обоих очереди как очередь с приоритетами.

    Если у вас есть пропускная способность вызова к 10 Гбит/с, сервисы SRR 20% 10 Гбит/с для организации очереди 2 первых, который составляет 2 Гбит/с. Остающаяся кольцевая пропускная способность на 8 Гбит/с разделена очередью 1 и очередью 2. Согласно конфигурации, обслуживается очередь 1, 90% 8 Гбит/с и очередь 2 снова обслуживаются 10% 8 Гбит/с. Полоса пропускания 8 Гбит/с обслуживается SRR в режиме совместного использования. Это означает, что настроенные проценты полосы пропускания гарантированы, но не ограничены им.

    Примечание: Можно отключить очередь с приоритетами с командой mls qos srr-queue input priority-queue 2 bandwidth 0.

    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :      90      10
    priority  :       0       0
    threshold1:     100     100
    threshold2:     100     100
    Distribution1(config)#

Организация очереди, понижаясь и планируя

В этом разделе пороговые уровни WTD настроены в дополнение к размеру буфера очереди. Можно назначить каждый пакет, который течет через коммутатор очереди и в порог.

cat3750-qos-config9.gif

Ниже показаны примеры конфигураций с соответствующими пояснениями:

  • Конфигурация карты очереди:

    Во-первых, значения CoS сопоставлены с очередями.

    
    !--- Assign the frames into the queue based on the CoS value.
    
    Distribution1(config)#mls qos srr-queue input cos-map queue 1
     threshold 2  1
    Distribution1(config)#mls qos srr-queue input cos-map queue 1
     threshold 3  0
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 1  2
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 2  4 6 7
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 3  3 5
    
    
    !--- Show output.
    
    Distribution1(config)#do show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-3 1-2 2-1 2-3 2-2 2-3 2-2 2-2
    
    Distribution1(config)#do show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
         5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         6 :  01-01 01-01 01-01 01-01

    Здесь показан конфликт между картами сопоставлений Cos-inputq-threshold и Dscp-inputq-threshold., Например, CoS 3 сопоставлен для организации очереди 2 в таблице Cos-inputq-threshold, но DSCP-значение 24 (который соответствует CoS 3) сопоставлено для организации очереди 1 в карте Dscp-inputq-threshold. Фактически, карта Dscp-inputq-threshold замещает настройки карты Cos-inputq-threshold. Эти сопоставления должны по возможности соответствовать друг другу, чтобы обеспечить предсказуемость операций и упростить устранение проблем. Поэтому карта Dscp-inputq-threshold настраивается таким образом, чтобы обеспечить синхронизацию с картой Cos-inputq-threshold.

    
    !--- Assign the frames into the queue based on the DSCP value.
    
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1
     threshold 2 9 10 11 12 13 14 15
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1 
     threshold 3 0 1 2 3 4 5 6 7
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1 
     threshold 3 32
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 1 16 17 18 19 20 21 22 23
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 33 34 35 36 37 38 39 48
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 49 50 51 52 53 54 55 56
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 57 58 59 60 61 62 63
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 3 24 25 26 27 28 29 30 31
    
    Distribution1(config)#do show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-01 01-02
         1 :  01-02 01-02 01-02 01-02 01-02 01-02 02-01 02-01 02-01 02-01
         2 :  02-01 02-01 02-01 02-01 02-03 02-03 02-03 02-03 02-03 02-03
         3 :  02-03 02-03 01-03 02-02 02-02 02-02 02-02 02-02 02-02 02-02
         4 :  02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-02 02-02
         5 :  02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02
         6 :  02-02 02-02 02-02 02-02
  • Конфигурация очереди:

    По умолчанию порог 3 составляет 100% и не может быть изменен.

    Distribution1(config)#mls qos srr-queue input buffers 67 33
    Distribution1(config)#mls qos srr-queue input threshold 1 8 16
    Distribution1(config)#mls qos srr-queue input threshold 2 34 66
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :       4       4
    priority  :       0      10
    threshold1:       8      34
    threshold2:      16      66
  • Конфигурация планировщика:

    После включения функции обеспечения качества обслуживания (QoS) IOS выполняет выделение буферного пространства по умолчанию для каждого входящего порта. Обе очереди совместно используют выделенное буферное пространство. В Catalyst 3560/3750 Коммутатор, можно настроить процент от этого пространства буфера, которое может использовать каждая очередь.

    Distribution1(config)#mls qos srr-queue input bandwidth 90 10
    Distribution1(config)#mls qos srr-queue input priority-queue 2
     bandwidth 20
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :      90      10
    priority  :       0      20
    threshold1:       8      34
    threshold2:      16      66

    По умолчанию очередь 2 является очередью с приоритетами, и 10% общей внутренней кольцевой пропускной способности выделены очереди с приоритетами. Можно также настроить очередь 1 как очередь с приоритетами. Однако вы не можете настроить обе очереди как очередь с приоритетами.

    Если у вас есть пропускная способность вызова к 10 Гбит/с, сервисы SRR 20% 10 Гбит/с для организации очереди 2 первых, который составляет 2 Гбит/с. Остающаяся кольцевая пропускная способность на 8 Гбит/с разделена очередью 1 и очередью 2. Согласно конфигурации, обслуживается очередь 1, 90% 8 Гбит/с и очередь 2 снова обслуживаются 10% 8 Гбит/с. Полоса пропускания 8 Гбит/с обслуживается SRR в режиме совместного использования. Это означает, что настроенные проценты полосы пропускания гарантированы, но не ограничены им.

    Примечание: Можно отключить очередь с приоритетами с командой mls qos srr-queue input priority-queue 2 bandwidth 0.

    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :      90      10
    priority  :       0       0
    threshold1:     100     100
    threshold2:     100     100
    Distribution1(config)#

Выходные характеристики QoS

Управлением перегрузками сети и предотвращением являются выходные Характеристики QoS, поддерживаемые Коммутаторами Cisco Catalyst 3750. Управление перегрузками сети и предотвращение являются тремя процессами шага. Это организация очереди, отбрасывание пакетов и планирование нагрузки.

Организация очереди размещает пакеты в другие очереди программного обеспечения на основе меток QoS. Коммутатор Cisco Catalyst 3750 имеет 4 выходных очереди, 3 порога на очередь. После того, как трафик классифицирован и отмечен с метками QoS, можно назначить трафик в четыре других очереди на основе меток QoS.

Каждая очередь может быть настроена с размером буфера, зарезервированным порогом, пороговыми уровнями и максимальным порогом. Взвешенное отбрасывание остатка (WTD) используется, чтобы управлять длинами очереди и предоставить приоритеты отбрасывания для других классификаций трафика. Параметры входной очереди настроены глобально. Параметры входной очереди не на порт. В отличие от них, параметры исходящей очереди настраиваются для каждого порта отдельно. Даже тогда конфигурация на порт. Вы не можете настроить каждый порт по-другому. Можно настроить каждый порт двумя другими способами. Это называют набором очереди. Можно настроить максимум двух других наборов очереди в глобальной конфигурации. Затем можно применить любой из этих двух наборов на интерфейсе.

И вход и выходные очереди обслуживаются SRR, который управляет скоростью, на которой переданы пакеты. На входных очередях SRR передает пакеты вызову стека. SRR может работать в двух режимах: профилирования трафика и совместного использования. Для входящих очередей совместное использование является режимом по умолчанию, а также единственным поддерживаемым режимом. В режиме совместного использования очереди в заданной пропорции используют общую полосу пропускания. Полоса пропускания на этом уровне гарантирована, однако им не ограничена. В режиме профилированного трафика для исходящих очередей гарантируется процент от пропускной способности канала, и очереди ограничены этим значением. Даже если ссылка является простаивающей, имеющий форму трафик не использует больше, чем выделенная полоса. Формирование предоставляет более ровный поток трафика в течение долгого времени и уменьшает пики и долины пульсирующего трафика. Очередь 1 может быть настроена как очередь с приоритетами.

Выходные команды QoS

Этот раздел категоризирует все доступные выходные команды QoS.

  • Конфигурация карты очереди:

    Для сопоставления значений CoS с выходными очередями:

    Rack1SW1(config)#mls qos srr-queue output cos-map queue ?
      <1-4>  enter cos-map output queue id
    
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold ? <1-3>  enter cos-map threshold id
    
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 1 ? <0-7>  8 cos values separated by spaces

    Чтобы назначить значения класса обслуживания (DSCP) для исходящей очереди, выполните следующие команды:

    Rack1SW1(config)#mls qos srr-queue output dscp-map queue ?
      <1-4>  enter dscp-map output queue id
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold ? <1-3>  enter dscp-map threshold id
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold 1 ? <0-63>  dscp values separated by spaces
     (up to 8 values total)
  • Конфигурация очереди:

    Конфигурация выходной очереди позволяет вам настраивать два набора очереди. Каждая очередь установила, имеет опцию для настройки размера буфера и порогового значения для этих четырех выходных очередей. Затем можно примениться, любая из очереди устанавливает в любой из портов. По умолчанию очередь установила 1, назначен на все порты, когда вы включаете QoS на коммутаторе.

    Rack1SW1(config)#mls qos queue-set output ?
      <1-2>  queue-set id
    
    Rack1SW1(config)#mls qos queue-set output 1 ?
      buffers    assign buffers to each egress queue
      threshold  Assign threshold values to a queue
    

    Для настройки размера буфера для всех этих четырех выходных очередей:

    Rack1SW1(config)#mls qos queue-set output 1 buffers ?
      <0-99>  enter buffer percentage for queue 1 0-99
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 ?
      <1-100>  enter buffer percentage for queue 2 1-100
     (includes CPU buffer)
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 20 ?
      <0-99>  enter buffer percentage for queue 3 0-99
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 20 30 ?
      <0-99>  enter buffer percentage for queue 4 0-99

    Для настройки двух пороговых значений зарезервированный и значения максимального порога для каждой очереди (порог 3 составляет 100% по умолчанию, и это не может быть изменено):

    Rack1SW1(config)#mls qos queue-set output 1 threshold ?
      <1-4>  enter queue id in this queue set
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 ?
      <1-400>  enter drop threshold1 1-400
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 ?
      <1-400>  enter drop threshold2 1-400
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 60 ?
      <1-100>  enter reserved threshold 1-100
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 60
     100 ? <1-400>  enter maximum threshold 1-400

    Для применения queue-set к интерфейсу (по умолчанию, очередь установила 1, назначен на все порты, когда вы включаете qos на коммутаторе):

    Rack1SW1(config-if)#queue-set ?
      <1-2>  the qset to which this port is mapped
  • Конфигурация планировщика:

    Три других конфигурации доступны для интерфейса коммутатора. Конфигурации являются формой пропускной способности, ресурсом общего доступа и пределом. Можно также настроить выходную очередь 1 как очередь с приоритетами. Если очередь с приоритетами включена, SRR обслуживает ее, пока это не пусто прежде, чем обслужить другие три очереди. Однако во входной очереди с приоритетами, SRR обслуживает очередь с приоритетами с установленным значением.

    Rack1SW1(config-if)#srr-queue bandwidth ?
      limit  Configure bandwidth-limit for this interface
      shape  Configure shaping on transmit queues
      share  Configure shared bandwidth
    
    Rack1SW1(config-if)#priority-queue ?
      out  egress priority queue

    Настройка ограничения полосы пропускания:

    Rack1SW1(config-if)#srr-queue bandwidth limit ?
      <10-90>  enter bandwidth limit for interface  as percentage

    Конфигурация формы пропускной способности:

    Rack1SW1(config-if)#srr-queue bandwidth shape ?
      <0-65535>  enter bandwidth weight for queue id 1
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 ?
      <0-65535>  enter bandwidth weight for queue id 2
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 20 ?
      <0-65535>  enter bandwidth weight for queue id 3
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 20 30 ?
      <0-65535>  enter bandwidth weight for queue id 4

    Общая конфигурация пропускной способности:

    Rack1SW1(config-if)#srr-queue bandwidth share ?
      <1-255>  enter bandwidth weight for queue id 1
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 ?
      <1-255>  enter bandwidth weight for queue id 2
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 20 ?
      <1-255>  enter bandwidth weight for queue id 3
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 20 30 ?
      <1-255>  enter bandwidth weight for queue id 4

    Все четыре очереди участвуют в SRR, пока очередь с приоритетами не включена, когда первый вес пропускной способности проигнорирован и не используется в вычислении соотношения. Очередь с приоритетами обслуживается, до пустой, прежде чем другие очереди обслуживаются. Вы включаете очередь с приоритетами при помощи priority-queue команда настройки интерфейса.

!--- конфигурации по умолчанию

Конфигурация карты очереди по умолчанию:

/image/gif/paws/91862/cat3750-qos-config10.gif

Эти сопоставления по умолчанию могут быть изменены согласно требованию:


!--- Map CoS to Egress Queue

Distribution1#show mls qos maps cos-output-q
   Cos-outputq-threshold map:
              cos:  0   1   2   3   4   5   6   7
              ------------------------------------
  queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1


!--- Map DSCP to Egress Queue

Distribution1#show mls qos maps dscp-output-q
   Dscp-outputq-threshold map:
     d1 :d2  0    1    2    3    4    5    6    7    8    9
     ------------------------------------------------------------
     0 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
     1 :  02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
     2 :  03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
     3 :  03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
     4 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
     5 :  04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
     6 :  04-01 04-01 04-01 04-01

Конфигурация очереди по умолчанию:

cat3750-qos-config11.gif

Настройки по умолчанию выходной очереди подходят для большинства ситуаций. Необходимо изменить их только, когда у вас есть полное понимание выходных очередей и если эти параметры настройки не встречают решение QoS.

Выполнена настройка двух наборов очередей, и набор очередей 1 по умолчанию назначается всем портам. Каждая очередь выделена 25 процентов пространства полного буфера. Каждая очередь зарезервирована 50 процентов пространства выделенного буфера, которое составляет 12.5 процентов пространства полного буфера. Сумма всех зарезервированных буферов представляет зарезервированный пул, и остающиеся буферы являются частью общего пула. Конфигурация по умолчанию устанавливает 400 процентов как максимальный объем памяти, который может иметь эта очередь, прежде чем пакеты отброшены.

Distribution1#show mls qos queue-set 1
Queueset: 1
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400

Distribution1#show mls qos queue-set 2
Queueset: 2
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400

Distribution1#show mls qos int gigabitEthernet 1/0/20 buffers
GigabitEthernet1/0/20
The port is mapped to qset : 1
The allocations between the queues are : 25 25 25 25

Конфигурация планировщика по умолчанию:

Очередь с приоритетами отключена. Оба имеющий форму и совместно используемый режим настроены для SRR. Имеющие форму веса режима отвергают совместно используемое значение режима. Поэтому фактический результат является очередью 1, обслуживается в имеющем форму режиме, и очереди 2, 3, и 4 обслуживаются в совместно используемом режиме. Это означает, что очередь 1 обслуживается с абсолютным значением, которое является (1/25) процентом или четырьмя процентами, пропускной способности. Очереди 2, 3 и 4 обслуживаются в 25 процентах пропускной способности. Если пропускная способность доступна, то очереди 2, 3 и 4 могут быть обслужены больше чем в 25 процентах пропускной способности.

Distribution1#show mls qos int gigabitEthernet 1/0/20 queueing
GigabitEthernet1/0/20
Egress Priority Queue : disabled
Shaped queue weights (absolute) :  25 0 0 0
Shared queue weights  :  25 25 25 25
The port bandwidth limit : 100  (Operational Bandwidth:100.0)
The port is mapped to qset : 1

Обработка очереди, сброс пакетов и планирование

Это примеры конфигурации:

  • Конфигурация карты очереди:

    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 3 5
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 1 2 4
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 2 
     threshold 2 3
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 2
     threshold 3 6 7
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 3
     threshold 3 0
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 4
     threshold 3 1
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold 3  46
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  16
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  18 20 22
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  25
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  32
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  34 36 38
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 2  24 26
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 3  48 56
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 3
     threshold 3  0
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 4
     threshold 1  8
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 4
     threshold 3  10 12 14
    
  • Конфигурация очереди:

    Эта конфигурация показывает, что конфигурация и очереди устанавливает 1 и 2. По умолчанию, набор очередей 1 применяется ко всем интерфейсам.

    Rack1SW3(config)#mls qos queue-set output 1 buffers 10 10 26 54
    Rack1SW3(config)#mls qos queue-set output 2 buffers 16 6 17 61
    
    Rack1SW3(config)#mls qos queue-set output 1 threshold 2 70 80
     100 100
    Rack1SW3(config)#mls qos queue-set output 1 threshold 4 40 100
     100 100
    
    Rack1SW3(config)#mls qos queue-set output 2 threshold 1 149 149
     100 149
    Rack1SW3(config)#mls qos queue-set output 2 threshold 2 118 118
     100 235
    Rack1SW3(config)#mls qos queue-set output 2 threshold 3 41 68
     100 272
    Rack1SW3(config)#mls qos queue-set output 2 threshold 4 42 72
     100 242
    
    Rack1SW3(config)#int fa 1/0/11
    Rack1SW3(config-if)#queue-set 2
    

    Интерфейс 1/0/11 применен с набором очереди 2.

    Rack1SW3(config-if)#do show mls qos int fa 1/0/10 buffers
    FastEthernet1/0/10
    The port is mapped to qset : 1
    The allocations between the queues are : 10 10 26 54
    
    Rack1SW3(config-if)#do show mls qos int fa 1/0/11 buffers
    FastEthernet1/0/11
    The port is mapped to qset : 2
    The allocations between the queues are : 16 6 17 61
  • Конфигурация планировщика:

    Rack1SW3(config-if)#srr-queue bandwidth share 1 75 25 5
    Rack1SW3(config-if)#srr-queue bandwidth shape  3  0  0  0
    

    Выходная очередь Cisco Catalyst 3750 не поддерживает очереди с низкой задержкой (LLQ). Это поддерживает постановку в очередь с установлением приоритетa. Когда вы настраиваете priority-queue, очередь 1 всегда обслуживается, когда это имеет пакет.

    Rack1SW3(config-if)#srr-queue bandwidth share 1 75 25 5
    Rack1SW3(config-if)#srr-queue bandwidth shape  3  0  0  0
    Rack1SW3(config-if)#priority-queue out
    

    Настройка этой команды отражается на нагрузке и скорости обработки SRR, поскольку в SRR принимает участие еще одна очередь. Это означает, что weight1 в srr-queue bandwidth shape или команде srr-queue bandwidth share проигнорирован (не используемый в вычислении соотношения).

Это - команда для наблюдения отбрасываний на определенных очередях:

Шаг 1:

1/ #show platform pm if-numbers

Используйте команду show platform pm if-numbers и проверьте сведения о портах, соответствующие интерфейсу (это - исходящий интерфейс на 3750). Например, фас 0/3 будет портом 0/4. Поддержите 4 как значение порта; если первое значение не является нолем, то дайте количество asic после номера порта.

interface gid gpn lpn port slot unit slun port-type lpn-idb gpn-idb
------------------------------------------------------------------------
---------
Gi0/1     1    1    25   0/1  1    1    1    local     Yes     Yes
Gi0/2     2    2    26   0/0  1    2    2    local     Yes     Yes
Fa0/1     3    3    1    0/2  1    1    3    local     Yes     Yes
Fa0/2     4    4    2    0/3  1    2    4    local     Yes     Yes
Fa0/3     5    5    3    0/4  1    3    5    local     Yes     Yes
Fa0/4     6    6    4    0/5  1    4    6    local     Yes     Yes
Fa0/5     7    7    5    0/6  1    5    7    local     Yes     Yes
Fa0/6     8    8    6    0/7  1    6    8    local     Yes     Yes

Значение порта, соответствующее интерфейсу fa 0/3, является 0/4. Теперь вы видите отбрасывание очереди интерфейса fa 0/3 с командой show platform port-asic stats drop port 4.

2/ #show platform port-asic stats drop port 4 
       
Port-asic Port Drop Statistics - Summary
========================================
  RxQueue 0 Drop Stats: 0
  RxQueue 1 Drop Stats: 0
  RxQueue 2 Drop Stats: 0
  RxQueue 3 Drop Stats: 0
...
 
  Port 4 TxQueue Drop Statistics
    Queue 0
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 1
      Weight 0 Frames 0
      Weight 1 Frames 2755160   <--- Here is an example of drops
      Weight 2 Frames 0
    Queue 2
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 3
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 8

Шаг 2 ---- -------------------------------- --------- :

  • Настройка ограничения полосы пропускания:

    Для ограничения максимальных выходных данных на порту настройте команду настройки интерфейса srr-queue bandwidth limit. При настройке этой команды к 80 процентам порт составляет простаивающие 20 процентов времени. Скорость линии спадает до 80 процентов связанной скорости. Эти значения не точны, потому что аппаратные средства отрегулировали скорость линии в инкрементах шесть. Эта команда не доступна на интерфейсе 10 Gigabit Ethernet.

    srr-queue bandwidth limit weight1
    
    

    где weight1 является процентом от скорости порта, которой должен быть ограничен порт. Диапазон равняется 10 - 90.

    Примечание: Настройки по умолчанию выходной очереди подходят для большинства ситуаций. Необходимо изменить их только, когда у вас есть полное понимание выходных очередей и если эти параметры настройки не встречают решение для качества обслуживания (QoS).

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 91862