Интерфейсы и модули Cisco : Сетевые модули Cisco

Пример конфигурации служебного модуля EtherSwitch (ES)

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (29 июля 2008) | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для Сервисного модуля EtherSwitch, установленного в маршрутизаторе с интеграцией служб (ISR). Этот документ не обсуждает пример конфигурации для модуля сети EtherSwitch.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco маршрутизатор серии 2800 на Cisco выпуск ПО IOS� 12.4 (10)

  • NME-16ES-1G-P - 10/100 Сервисный модуль EtherSwitch Cisco с 16 портами

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Эта конфигурация может также использоваться с Series маршрутизаторами Cisco 2600/3600/3700/3800.

Обратитесь к Таблице 6 в Сервисных модулях EtherSwitch Cisco - Таблица данных для получения дополнительной информации.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Модули EtherSwitch - понятия

Это два типа модулей EtherSwitch, доступных для ISR Cisco:

  • Обслуживающий модуль EtherSwitch (ES) – ES модули обладают собственным процессором, коммутирующими устройствами и флэш-памятью, которые используют независимые ресурсы маршрутизатора хоста. После того, как модуль ES установлен в маршрутизаторе, можно подключиться с консоли в модуль ES от узлового маршрутизатора. Затем можно создать VLAN, настроить VLAN, связующее дерево и Протокол виртуального терминала (VTP) от модуля ES. Модули ES основываются на платформе Catalyst 3750. Этот документ показывает пример конфигурации только для модуля ES.

  • Сетевой модуль EtherSwitch (ESW) – модули ESW настроены с помощью маршрутизатора IOS. Эти модули не выполняют отдельное программное обеспечение. Это интегрировано в IOS узлового маршрутизатора. Можно создать VLAN, настроить VLAN, связующее дерево и VTP от узлового маршрутизатора. Маршрутизатор хранит файл базы данных VLAN (vlan.dat) во флэш-памяти.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/network-modules/82288-es-mod-config1.gif

Конфигурации

Эти конфигурации используются в данном документе:

Начальная конфигурация модуля EtherSwitch

После установки модуля ES на маршрутизаторе, отображается новый интерфейс GigabitEthernet x/0 (где "x" является номером слота), распознанный IOS. Эти выходные данные взяты после того, как модуль ES установлен на маршрутизаторе:

Router1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol

GigabitEthernet0/0         1.1.1.3         YES NVRAM  up                    down

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

GigabitEthernet1/0         unassigned      YES unset  administratively down down

Vlan1                      unassigned      YES NVRAM  up                    up

Команда service-module gigabitEthernet x/0 session является привилегированной командой режима EXEC, которая используется для консольного соединения в модуле ES из маршрутизатора хоста. Необходимо подключиться с консоли в модуль ES для настройки его. Чтобы получить консольное соединение с модулем ES, необходимо настроить IP-адрес для интерфейса GigabitEthernet x/0. При попытке подключиться с консоли в модуль, не назначая IP-адрес, вы получаете это сообщение об ошибках:

Router1#service-module gigabitEthernet 1/0 session
IP address needs to be configured on interface GigabitEthernet1/0
Маршрутизатор 1

Find out the router interface connected to the ES module.

Router1#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
Lab-2811     Gi 1/0          157               R     NME-16ES-1G Gi 1/0/2


!--- The Local interface shows the interface 
!--- on the router connected internally to the switch.



Configure the host router to manage the ES module.


Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface gigabitethernet 1/0

Router1(config-if)#ip address 172.16.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#exit


Console into the ES Module


Router1#service-module gigabitEthernet 1/0 session
Trying 172.16.1.1, 2066 ... Open

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: no

Would you like to terminate autoinstall? [yes]:
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Switch-ES
Switch-ES(config)#interface gigabitethernet 1/0/2

Switch-ES(config-if)#no switchport
Switch-ES(config-if)#ip address 172.16.1.2 255.255.255.0
Switch-ES(config-if)#exit

!--- GigabitEthernet 1/0/2 connects the ES module to the router.


Switch-ES(config)#line console 0
Switch-ES(config-line)#password a99l3
Switch-ES(config-line)#exec-timeout 30
Switch-ES(config-line)#exit
Switch-ES(config)#line vty 0 4
Switch-ES(config-line)#password a99l3
Switch-ES(config-line)#login
Switch-ES(config-line)#exec-timeout 30
Switch-ES(config-line)#exit

Данные сведения содержат выходные данные команды show ip interface brief, выполненной на модуле ES. Интерфейс GigabitEthernet1/0/2 подключает модуль ES к интерфейсу GigabitEthernet1/0 маршрутизатора хоста.

Switch-ES#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  unassigned      YES unset  administratively down down
FastEthernet1/0/1      unassigned      YES unset  down                  down
FastEthernet1/0/2      unassigned      YES unset  down                  down
FastEthernet1/0/3      unassigned      YES unset  down                  down
FastEthernet1/0/4      unassigned      YES unset  down                  down
FastEthernet1/0/5      unassigned      YES unset  down                  down
FastEthernet1/0/6      unassigned      YES unset  down                  down
FastEthernet1/0/7      unassigned      YES unset  down                  down
FastEthernet1/0/8      unassigned      YES unset  down                  down
FastEthernet1/0/9      unassigned      YES unset  down                  down
FastEthernet1/0/10     unassigned      YES unset  down                  down
FastEthernet1/0/11     unassigned      YES unset  down                  down
FastEthernet1/0/12     unassigned      YES unset  down                  down
FastEthernet1/0/13     unassigned      YES unset  down                  down
FastEthernet1/0/14     unassigned      YES unset  down                  down
FastEthernet1/0/15     unassigned      YES unset  down                  down
FastEthernet1/0/16     unassigned      YES unset  down                  down
GigabitEthernet1/0/1   unassigned      YES unset  down                  down
GigabitEthernet1/0/2   172.16.1.2      YES manual  up                    up

Если модуль ES или устройства, связанные с этим модулем ES, должны связаться с внешней сетью через узловой маршрутизатор, этот порт (GigabitEthernet1/0/2) должен быть портом Уровня 3, или это должен быть участник VLAN Уровня 3. Посмотрите Настраивать Раздел маршрутизации этого документа, чтобы понять, как настроить маршрутизацию на модуле ES.

Эта схема объясняет узловой маршрутизатор и логическое подключение модуля ES:

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/network-modules/82288-es-mod-config2.gif

Чтобы вернуться к маршрутизатору хоста, необходимо нажать сочетание клавиш Ctrl+Shift+6, затем X.

Если необходимо очистить сеанс из маршрутизатора, подайте команду service-module gigabitEthernet x/0 session clear из привилегированного режима EXEC маршрутизатора.

Настройте VTP и VLAN

По умолчанию режим VTP является сервером, и название VTP domain является пустым в модуле ES. По умолчанию все порты принадлежат vlan1. В данном примере, DHCP-сервер (172.16.10.20) находится в vlan 10. Команда ip helper-address 172.16.10.20 настроена на всех VLAN, за исключением vlan 10, чтобы получить IP-адрес с DHCP-сервера для устройств, расположенных в данных сетях VLAN.

Коммутаторы

VTP Configuration

Switch-ES(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
Switch-ES(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Switch-ES(config)#


Create VLANs


Switch-ES(config)#vlan 10,50,51,100,200
Switch-ES(config-vlan)#exit
Switch-ES(config)#



Configure VLANs


Switch-ES(config)#interface vlan 10
Switch-ES(config-if)#ip address 172.16.10.1 255.255.255.0
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 50
Switch-ES(config-if)#ip address 172.16.50.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 51
Switch-ES(config-if)#ip address 172.16.51.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 100
Switch-ES(config-if)#ip address 172.16.100.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES(config-if)#interface vlan 200
Switch-ES(config-if)#ip address 172.16.200.1 255.255.255.0
Switch-ES(config-if)#ip helper-address 172.16.10.20
Switch-ES(config-if)#no shutdown

Switch-ES#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/7, Fa1/0/8
                                                Fa1/0/9, Fa1/0/10, Fa1/0/11
                                                Fa1/0/12, Fa1/0/13, Fa1/0/14
                                                Fa1/0/15, Fa1/0/16, Gi1/0/1
                                                Gi1/0/2
10   VLAN0010                         active
50   VLAN0050                         active
51   VLAN0051                         active
100  VLAN0100                         active

200  VLAN0200                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
10   enet  100010     1500  -      -      -        -    -        0      0
50   enet  100050     1500  -      -      -        -    -        0      0
51   enet  100051     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0

200  enet  100200     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Switch-ES#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x21 0x51 0xD5 0x4E 0x30 0xA5 0x46 0x3C
Configuration last modified by 0.0.0.0 at 10-27-06 18:28:10

Настройте связующее дерево, транк и Port Channel

В данном разделе показана конфигурация связывающего дерева на модуле ES и коммутаторе Access1. Этот раздел также показывает канал порта и конфигурацию магистрали между модулем ES и коммутатором Access1. Данный пример настраивает быстрое связующее дерево на всех коммутаторах. Модуль ES настроен как корень связующего дерева для всех VLAN.

Коммутаторы

Spanning-Tree Configuration

Switch-ES(config)#spanning-tree mode rapid-pvst
Switch-ES(config)#spanning-tree vlan 10,50,51,100,200 root primary


Trunk & Port Channel Configuration

Switch-ES(config)#interface port-channel 1
Switch-ES(config-if)#switchport trunk encapsulation dot1q
Switch-ES(config-if)#switchport mode trunk
Switch-ES(config-if)#switchport trunk allowed vlan 100,200
Switch-ES(config-if)#exit

Switch-ES(config)#interface range fastethernet 1/0/5-6
Switch-ES(config-if-range)#switchport trunk encapsulation dot1q
Switch-ES(config-if-range)#switchport mode trunk
Switch-ES(config-if-range)#switchport trunk allowed vlan 100,200
Switch-ES(config-if-range)#channel-group 1 mode on
Switch-ES(config-if-range)#exit

Access1

Access1 switch configuration



Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#spanning-tree mode rapid-pvst

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Switch-ES#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: VLAN0001, VLAN0100, VLAN0200
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001                     0         0        0          1          1
VLAN0100                     0         0        0          1          1
VLAN0200                     0         0        0          1          1
---------------------- -------- --------- -------- ---------- ----------
3 vlans                      0         0        0          3          3
Switch-ES#show interface port-channel 1 trunk

Port        Mode         Encapsulation  Status        Native vlan
Po1         on           802.1q         trunking      1

Port      Vlans allowed on trunk
Po1         100,200

Port        Vlans allowed and active in management domain
Po1         100,200

Port        Vlans in spanning tree forwarding state and not pruned
Po1         100,200

Настройте порт доступа

Конфигурация порта доступа подобна стандартной конфигурации коммутатора локальной сети (LAN).

Коммутаторы

Configure the port for server

Switch-ES(config)#interface fastEthernet 1/0/7
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 10
Switch-ES(config-if)#spanning-tree portfast
Switch-ES(config-if)#speed 100
Switch-ES(config-if)#duplex full
Switch-ES(config-if)#exit


Configure Port for Printer

Switch-ES(config)#interface fastethernet 1/0/8
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 51
Switch-ES(config-if)#spanning-tree portfast
Switch-ES(config-if)#exit

Настройте голосовой порт

Настройка голосового порта подобна стандартной конфигурации коммутатора локальной сети (LAN).

Коммутаторы

Configure the port for Voice

Switch-ES(config)#interface fastethernet 1/0/9
Switch-ES(config-if)#switchport mode access
Switch-ES(config-if)#switchport access vlan 51
Switch-ES(config-if)#switchport voice vlan 50
Switch-ES(config-if)#spanning-tree portfast

Настройте маршрутизацию

Данный пример использует статические маршруты для настройки маршрутизации.

Коммутаторы

Configure the default route

Switch-ES(config)#ip routing
Switch-ES(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.1

Маршрутизатор 1

Configure the route to LAN

Router1(config)#ip route 172.16.0.0 255.255.0.0 172.16.1.2

Настройка QoS

Этот раздел использует auto QoS для настройки QoS. Сошлитесь на Описание технологических решений Cisco AutoQoS для получения дополнительной информации о auto QoS.

Коммутаторы

Configure QoS on the port where IP phone is connected

Switch-ES(config)#interface fastethernet 1/0/9
Switch-ES(config-if)#auto qos voip cisco-phone
Switch-ES(config-if)#exit


Configure QoS on the uplink port to the host router.

Switch-ES(config)#interface gigabitEthernet 1/0/2
Switch-ES(config-if)#auto qos voip trust

Маршрутизатор 1

Create Class map

Router1(config)#class-map match-any VoIP-Control
Router1(config-cmap)#match ip dscp AF31
Router1(config-cmap)#exit

Router1(config)#class-map match-any VoIP-RTP
Router1(config-cmap)#match ip dscp EF
Router1(config-cmap)#exit


Create Policy map

Router1(config)#policy-map Policy-VoIP
Router1(config-pmap)#class VoIP-RTP
Router1(config-pmap-c)#priority percent 70
Router1(config-pmap-c)#class VoIP-Control
Router1(config-pmap-c)#bandwidth percent 5
Router1(config-pmap-c)#class class-default
Router1(config-pmap-c)#fair-queue
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit


Apply the policy on the interface connects to the ES Module

Router1(config)#interface gigabitEthernet 1/0
Router1(config-if)#service-policy output Policy-VoIP
Router1(config-if)#exit

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 82288