Интерфейсы и модули Cisco : Сетевые модули Cisco

Пример конфигурации сетевого модуля EtherSwitch (ESW)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (31 июля 2008) | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

Этот документ содержит пример конфигурации модуля EtherSwitch, установленного на маршрутизаторе с интегрированными службами (ISR). В этом документе не обсуждается пример конфигурации модуля служб EtherSwitch.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco маршрутизатор серии 2800 на Cisco Выпуск ПО IOS� 12.4 или позже

  • NM-16ESW-PWR = 16 Модулей сети EtherSwitch порта 10/100 (NM)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Эта конфигурация может также использоваться со следующими версиями программного/аппаратного обеспечения:

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Модули EtherSwitch - понятия

Существует два типа модулей EtherSwitch, доступных для ISR Cisco. Типичные сбои:

  • Модуль сети EtherSwitch (ESW)

  • Сервисный модуль EtherSwitch (ES)

Модули ESW настроены IOS маршрутизатора. Эти модули не выполняют отдельное программное обеспечение. Программное обеспечение интегрировано в IOS узлового маршрутизатора. Можно создать VLAN, настроить VLAN, связующее дерево, Протокол магистральных каналов VLAN (VTP), и т.д от узлового маршрутизатора. Маршрутизатор также хранит файл Базы данных VLAN (vlan.dat) во Флэше. Этот документ показывает пример конфигурации для модуля ESW.

Модули ES имеют свои собственные процессоры, устройства переключения и флэш-память, которые работают независимый от ресурсов узлового маршрутизатора. После того, как модуль ES установлен в маршрутизаторе, можно подключиться с консоли в модуль ES от узлового маршрутизатора. Затем можно создать VLAN, настроить VLAN, связующее дерево, VTP, и т.д от модуля ES. Модули ES основываются на платформе Catalyst 3750.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/82156/ether-switch-nm-config-1.gif

Конфигурации

Эти конфигурации используются в данном документе:

Настройте интерфейсы виртуальной локальной сети (VLAN)

По умолчанию все порты принадлежат VLAN1. Можно создать VLAN только от VLAN database mode. После того, как VLAN созданы от VLAN database mode, файл vlan.dat создается и хранится в Файловой системе флэш-устройства маршрутизатора. Можно просматривать сети VLAN с помощью команды show vlan-switch. В данном примере сервер протокола динамической конфигурации хоста (DHCP) (172.16.10.20) расположен в VLAN 10. Команда ip helper-address настроена во всех сетях VLAN кроме VLAN 10, чтобы получить IP-адрес с сервера DHCP для устройств, расположенных в данных сетях VLAN.

Маршрутизатор 1

Create VLANs


Router1#vlan database
Router1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Router1(vlan)#vlan 51
VLAN 51 added:
    Name: VLAN0051
Router1(vlan)#vlan 50
VLAN 50 added:
    Name: VLAN0050
Router1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Router1(vlan)#vlan 200
VLAN 200 added:
    Name: VLAN0200
Router1(vlan)#exit
APPLY completed.
Exiting....
Router1#



Configure VLANs


Router1(config)#interface vlan 10
Router1(config-if)#ip address 172.16.10.1 255.255.255.0

Router1(config-if)#interface vlan 50
Router1(config-if)#ip address 172.16.50.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 51
Router1(config-if)#ip address 172.16.51.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 100
Router1(config-if)#ip address 172.16.100.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 200
Router1(config-if)#ip address 172.16.200.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4, 
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8,
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active    
50   VLAN0050                         active    
51   VLAN0051                         active    
100  VLAN0100                         active    
200  VLAN0200                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0   
50   enet  100050     1500  -      -      -        -    -        0      0   
51   enet  100051     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
200  enet  100200     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0   
1005 trnet 101005     1500  -      -      1        ibm  -        0      0   

Настройте VTP, транк, Port Channel и связующее дерево

По умолчанию режим VTP является сервером, и доменное имя является пробелом. VTP может быть настроен только от VLAN database mode. Единственный поддерживаемый режим связующего дерева является PVST +. Инкапсуляция магистрали по умолчанию является dot1q. При настройке магистрального порта для разрешения только заданных VLAN, вы могли бы получить сообщение об ошибках, которое говорит Bad VLAN allowed list. В этом случае вы, возможно, должны были бы позволить виртуальные локальные сети (VLAN) по умолчанию 1-2, 1002-1005 наряду с вашим пользовательским списком VLAN. Из-за этого также необходимо позволить виртуальным локальным сетям (VLAN) по умолчанию и пользовательским VLAN на соседнем коммутаторе, связанном с этим магистральным портом избегать несоответствий транка.

Маршрутизатор 1

VTP Configuration


Router1#vlan database
Router1(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.
Router1(vlan)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Router1(vlan)#exit
APPLY completed.
Exiting....



Spanning-Tree Configuration


Router1(config)#spanning-tree vlan 1 root primary
Router1(config)#spanning-tree vlan 10 root primary
Router1(config)#spanning-tree vlan 50 root primary
Router1(config)#spanning-tree vlan 51 root primary
Router1(config)#spanning-tree vlan 100 root primary
Router1(config)#spanning-tree vlan 200 root primary



Trunk and Port Channel Configuration


Router1(config)#interface port-channel 1
Router1(config-if)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if)#switchport trunk allowed vlan 100,200
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Router1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if-range)#channel-group 1 mode on
Router1(config-if-range)#exit

Access1

Access1 Switch Configuration


Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Router1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 52
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x71 0x37 0x29 0x6C 0xB0 0xF2 0x0E
Configuration last modified by 172.22.1.197 at 2-20-07 22:31:06
Router1#
Router1#show interface fastethernet 1/0 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/0     on           802.1q         trunk-inbndl  1
                                      (Po1)

Port      Vlans allowed on trunk
Fa1/0     1,100,200,1002-1005

Port      Vlans allowed and active in management domain
Fa1/0     1,100,200

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/0     1,100,200
Router1#show spanning-tree summary
Root bridge for: VLAN1, VLAN10, VLAN50, VLAN51, VLAN100, VLAN200.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                0        0         0        1          1
VLAN10               0        0         0        1          1
VLAN50               0        0         0        1          1
VLAN51               0        0         0        1          1
VLAN100              0        0         0        1          1
VLAN200              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
             6 VLANs 0        0         0        6          6

Настройте порты доступа

Конфигурация порта доступа подобна стандартной конфигурации коммутатора локальной сети (LAN).

Маршрутизатор 1

Port for Server Configuration


Router1(config)#interface fastEthernet 1/2
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 10
Router1(config-if)#spanning-tree portfast
Router1(config-if)#speed 100
Router1(config-if)#duplex full
Router1(config-if)#exit



Port for Printer Configuration


Router1(config)#interface fastethernet 1/3
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#spanning-tree portfast
Router1(config-if)#exit

Настройте голосовой порт

Настройка голосового порта подобна стандартной конфигурации коммутатора локальной сети (LAN).

Маршрутизатор 1

Configure the port for Voice

Router1(config)#interface fastethernet 1/4
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#switchport voice vlan 50
Router1(config-if)#spanning-tree portfast
Router1(config-if)#mls qos trust cos

Настройте качество обслуживания (QoS)

Это - конфигурация QoS по умолчанию на модуле ESW:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8
wrr-queue bandwidth is disabled

Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4
wrr-queue cos map is disabled

Router1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 26 32 46 48 56

Router1#show mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

Эти разделы объясняют эти конфигурации:

Настройте wrr Очереди

Вы не можете настроить QoS на основе портов на портах Коммутатора уровня 2. Очереди могут быть настроены только от глобальной конфигурации. Пример конфигурации сопоставляет значения CoS с четырьмя другими очередями. Когда пакет вводит механизм Уровня 2 непосредственно от порта коммутатора, это размещено в одну из четырех очередей в динамическом, буфере совместно используемой памяти на 32 МБ. Любые пакеты речевого информационного канала, которые входят от Cisco IP Phone на голосовом VLAN, автоматически размещены в наивысший приоритет (Очередь 4) на основе 802.1p значение (CoS 5), генерируемый IP-телефоном. Очереди тогда обслуживаются на основе взвешенного циклического выбора (WRR). Контрольный трафик, который использует CoS или Тип обслуживания (ToS) 3, размещен в Очередь 3.

Маршрутизатор 1
Router1(config)#wrr-queue cos-map 1 0 1
Router1(config)#wrr-queue cos-map 2 2
Router1(config)#wrr-queue cos-map 3 3 4
Router1(config)#wrr-queue cos-map 4 5 6 7

!--- wrr-queue cos-map <queue-number> <cos values separated by space>

Router(config)#wrr-queue bandwidth 1 16 64 255

!--- wrr-queue bandwidth <Weight of Queue1> <Weight of Queue2> 
!--- <Weight of Queue3> <Weight of Queue4>

Проверьте параметры Очереди:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8 

!--- Default values


WRR Queue  :   1   2   3   4

Bandwidth  :   1  16  64 255 

!--- Configured values


Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4  

!--- Default values

CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  3  3  4  4  4  

!--- Configured values

Эта таблица показывает номер очереди, значение CoS и вес каждой очереди после конфигурации.

Номер очереди Значение CoS Вес
1 0 1 1
2 2 16
3 3 4 64
4 5 6 7 255

Настройте порт для доверия CoS

Маршрутизатор 1
Router1(config)#interface fastethernet1/4
Router1(config-if)#mls qos trust cos

!--- Trust the CoS value of the frames from the IP phone.

Router1(config-if)#mls qos cos override

!--- Reset the CoS value of the frames from PC to 0.

Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#mls qos trust cos

!--- Trust the CoS value of the frames from this trunk link.

Router1(config-if-range)#exit

Настройте ограничитель

Это разделяет, показывает конфигурацию ограничителя скорости на интерфейсе fa1/2 для ограничения трафика FTP 5 Мбит/с.

Маршрутизатор 1
Router1(config)#ip access-list extended ACTIVE-FTP
Router1(config-ext-nacl)#permit tcp any any eq ftp
Router1(config-ext-nacl)#permit tcp any any eq ftp-data
Router1(config-ext-nacl)#exit
Router1(config)#class-map ACTIVE-FTP-CLASS
Router1(config-cmap)#match class ACTIVE-FTP
Router1(config-cmap)#exit
Router1(config)#policy-map ACTIVE-FTP-POLICY
Router1(config-pmap)#class ACTIVE-FTP-CLASS
Router1(config-pmap-c)#police 5000000 conform-action transmit exceed-action drop
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface fastethernet1/2
Router1(config-if)#service-policy input ACTIVE-FTP-POLICY
Router1(config-if)#exit

Существует немного ограничений в конфигурации ограничителя скорости в модулях ESW. Они перечислены здесь:

  • Карты политик с классификацией ACL в исходящем направлении не поддерживаются и не подключаются к интерфейсу с помощью команды конфигурации service-policy input policy-map-name interface.

  • В карте политик не поддерживается названный class-default класса. Коммутатор не фильтрует трафик на основе карты политики, определенной с помощью команды конфигурации class class-default policy-map.

  • Можно создать policy-map и примениться только к входу интерфейсов ESW. И в policy-map, только поддерживается ограничитель.

    Router1#show policy-map
      Policy Map FINANCE-POLICY
        Class FINANCE-CLASS
          set cos 4
    Router1(config)#interface fastethernet1/4
    Router1(config-if)#service-policy input FINANCE-POLICY
    %Error: FastEthernet1/4 Service Policy Configuration Failed.Only Police Action S
    upported
  • Нет никакой поддержки применения политик на уровне коммутируемого виртуального интерфейса (SVI) или VLAN.

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 82156