Беспроводные сети / Мобильные решения : "Беспроводные сети, LAN (WLAN)"

Качество обслуживания на контроллерах беспроводных LAN и пример конфигурации AP Lightweight

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (8 августа 2008) | Английский (20 декабря 2015) | Отзыв


Содержание


Введение

В этом документе представлен пример конфигурации, иллюстрирующий способ настройки механизмов качества обслуживания (QoS) в унифицированной беспроводной сети Cisco (UWN) с использованием контроллеров беспроводных локальных сетей Cisco (WLC) и облегченных точек доступа (LAP).

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

  • Основные сведения о конфигурации точек LAPи контроллеров Cisco WLC

  • Знание того, как настроить базовую маршрутизацию и QoS в проводной сети

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco 2006 WLC, использующий микропрограммное обеспечение версии 4.0

  • Облегченные точки доступа Cisco 1000 серии

  • Беспроводной клиентский адаптер Cisco 802.11a/b/g, использующий микропрограммное обеспечение версии 2.6

  • Маршрутизатор Cisco 3725, который выполняет Cisco Выпуск ПО IOS� 12.3 (4) T1

  • Маршрутизатор Cisco 3640, который выполняет программное обеспечение Cisco IOS версии 12.2 (26)

  • Два коммутатора серии "3500 XL" Cisco, которые выполняют программное обеспечение Cisco IOS версии 12.0(5) WC3b

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

QoS обращается к возможности сети предоставить улучшенное или особое обслуживание ряду пользователей или приложений в ущерб другим пользователям или приложений.

С QoS пропускной способностью можно управлять более эффективно по LAN, который включает WLAN и глобальные сети (WAN). Это - то, как QoS предоставляет улучшенное и надежное использование сети:

  • Выделенная полоса пропускания поддержек для важных пользователей и приложений

  • Управляет дрожанием и задержкой (требуемый трафиком в реальном времени)

  • Управляет и минимизирует перегрузку сети

  • Формирует сетевой трафик для сглаживания трафика

  • Приоритеты сетевого трафика наборов

В прошлом WLAN в основном использовались для транспортировки низкой пропускной способности, трафика, связанного с данными приложений. В настоящее время, с расширением WLAN в вертикальный (таких как розничная продажа, финансы и образование) и среды предприятия, WLAN используются для транспортировки данных приложений, требующих высокой пропускной способности в сочетании с критичным по времени, мультимедийными приложениями. Это требование привело к необходимости беспроводного QoS.

IEEE 802.11e рабочая группа в комитете по стандартам IEEE 802.11 завершил определение стандарта. Однако принятие 802.11e стандарт находится в своих ранних стадиях, и как со многими стандартами существует много дополнительных компонентов. Так же, как, что произошло с безопасностью 802.11 в 802.11i, группы разработчиков, такие как Wi-Fi Alliance и отраслевые лидеры, такие как Cisco определяют ключевые требования в QoS WLAN через их Wi-Fi MultiMedia (WMM) и Cisco Compatible Extensions (CCX) программы. Это гарантирует доставку ключевых характеристик и взаимодействия через их программы сертификации.

Унифицированные беспроводные продукты Cisco поддерживают WMM, систему QoS на основе IEEE 802.11e проект, который был публикован Wi-Fi Alliance.

Контроллер поддерживает четыре уровня QoS:

  • Платина/Голос — Гарантирует высокое качество сервиса для голоса по радио.

  • Золото/Видео — Поддерживает высококачественные видеоприложения.

  • Серебро/Оптимальный уровень — Поддерживает обычную пропускную способность для клиентов. Эта настройка используется по умолчанию.

  • Бронза/Общие сведения — Предоставляет самую низкую пропускную способность для гостевых сервисов.

Передача голоса по IP (VoIP), клиенты должны быть установлены в Платину, Золото или Серебро, в то время как клиенты низкой пропускной способности могут быть установлены в Бронзу.

Можно настроить пропускную способность каждого уровня QoS с помощью профилей QoS и затем применить профили к WLAN. Параметры настройки профиля выдвинуты клиентам, привязанным к тому WLAN. Кроме того, можно создать роли QoS для определения других уровней пропускной способности для постоянного клиента и гостей.

Для получения информации о том, как настроить профили QoS с помощью GUI, обратитесь к Использованию GUI Настроить Профили QoS.

Для получения информации о том, как настроить профили QoS с помощью CLI, обратитесь к Использованию CLI Настроить Профили QoS.

Дополнительные сведения о том, как работает QoS в единой беспроводной сети Cisco см. в разделе Служба QoS в единой беспроводной сети Cisco документа Руководство по планированию корпоративной мобильности.

Этот документ предоставляет пример конфигурации, который иллюстрирует, как настроить QoS на контроллерах и связаться с проводной сетью, настроенной с QoS.

Усовершенствования маркировки пакетов QoS уровня 3

Единая беспроводная сеть Cisco (UWN) поддерживает маркировку Кодовой точки дифференцированных сервисов (DSCP) IP Уровня 3 пакетов, переданных WLC и LAP. Эта функция улучшает, как точки доступа (AP) используют эту информацию сетевого уровня 3, чтобы гарантировать, что пакеты получают корректную беспроводную приоритизацию от AP до беспроводного клиента.

В централизованной архитектуре WLAN данные WLAN туннелированы между AP и WLC через Протокол LWAPP. Для поддержания исходной классификации QoS по этому туннелю параметры настройки QoS инкапсулированного пакета данных должны быть соответственно сопоставлены с Уровнем 2 (802.1p) и поля (IP DSCP) Уровня 3 пакета внешнего туннеля.

Если нет никакого DSCP или 802.1P значение в самом оригинальном пакете, не возможно назначить метку DSCP пакетам между контроллером и LAP.

Контроллер не применяет свое собственное QoS. Поддержка QoS на WLC дает WLC возможность применить тот же приоритет, который установлен на проводе (или приложение).

Поэтому единственное действие, которое сделают WLC или AP, копируют значение оригинального пакета к внешнему заголовку Пакета lwapp. Целая цель параметров gold, silver и bronze QoS на WLC состоит в том, чтобы выполнить надлежащие трансляции QoS между 802.11e/802.1p значениями UP и значениями IP DSCP, которые зависят от приложения или стандарта, который используется. Еще раз QoS на WLC гарантирует, что пакеты получают надлежащую обработку от начала до конца QoS. Контроллер не выполняет свое собственное поведение QoS. Поддержка там для контроллера для подражания примеру, если QoS уже существует и первоочередные нужды, которые будут применены к беспроводным пакетам. У вас не может быть QoS, только существуют на контроллере.

Контроллер не поддерживает значения маркировки Класса обслуживания (CoS) на основе конфигурации WLAN в Режиме LWAPP уровня 2. Рекомендуется использовать LWAPP Уровня 3 для осуществления QoS CoS.

Это - пример того, как QoS работает с WLC. Приложение (например, CallManager), может установить значение параметра качества обслуживания равным Высокое. Поэтому исходный пакет данных, поступающий от приложения, будет снабжен IP-заголовком, котором параметр DCSP принимает значение Высокое. Теперь, пакет достигает контроллера. После этого пакет проходит тест SSID. Но если тест SSID на контроллере настроен на профиль QoS Bronze, то IP-заголовок пакета, в который инкапсулирован пакет LWAPP от контроллера для точки доступа, будет иметь значение Bronze, хотя IP-заголовок исходного пакета от приложения будет иметь высокий приоритет. Этот документ предполагает, что DCSP, установленный приложением и профилем QoS для того SSID на контроллере, является тем же. Это не всегда имеет место.

/image/gif/paws/81831/qos-wlc-lap1.gif

Например, когда 802.11e трафик передается клиентом WLAN, он имеет класс UP (пользовательского приоритета) в своем кадре. AP должен сопоставить это 802.11e классификация в DSCP-значение для Пакета lwapp, который переносит кадр. Это гарантирует, что пакету уделяют соответствующее продвигающееся первостепенное значение WLC. Подобный процесс должен произойти на WLC для Пакетов lwapp, переходящих к AP. Кроме того, механизм необходим для классификации трафика и на AP и на WLC для non-802.11e клиентов, так, чтобы их Пакетам lwapp можно было также уделить соответствующее первостепенное значение. Эта таблица иллюстрирует, как пакеты обрабатываются в каждом устройстве:

# От К UP (802.1p/802.11e) IP DSCP
1 Controller Точка доступа Это НЕ преобразовывает DSCP-значение входящего пакета к AVVID 802.1p значение UP. DSCP-значение, если подарок в пакете, переходит в пакет напрямую. Скопируйте DSCP-значение с входящего пакета.
2 Точка доступа Беспроводной клиент Клиент WMM: Преобразуйте DSCP-значение входящего пакета LWAPP к 802.11e значение UP. Настройте значение, чтобы гарантировать, что это не превышает максимально допустимое значение QoS беспроводной сети, заданное политикой тому клиенту. Разместите пакет в очередь Tx 802.11, соответствующую значению UP. Обычный клиент: Разместите пакет в очередь Tx 802.11 по умолчанию для политики QoS WLAN, назначенной на тот клиент. Н/Д (исходное DSCP-значение сохранено),
3 Точка доступа Controller Н/Д (точки доступа не поддерживают метки 802.1Q/802.1p), Клиент WMM: Определите политику 802.11e значение UP, чтобы гарантировать, что оно не превышает максимальное значение для политики QoS, назначенное на тот клиент; преобразуйте значение в DSCP-значение. Обычный клиент: Используйте 802.11e значение UP для политики QoS, назначенной на тот клиент; преобразуйте значение в DSCP-значение.
4 Controller Коммутатор Ethernet Преобразуйте DSCP-значение входящих пакетов LWAPP к 802.1p значение UP. Н/Д (исходное DSCP-значение сохранено),

Эта следующая таблица предоставляет трансляции, которые происходят между 802.11e/802.1p значениями UP и значениями IP DSCP. Поскольку архитектура Cisco для Голоса, Видео и Итегрированных данных (AVVID) определяет трансляцию от 802.1 До IP DSCP, и IEEE определяет трансляцию от IP DSCP до 802.11e UP, должны использоваться два других набора трансляций.

Cisco AVVID 802.1p ОСНОВАННЫЙ НА UP тип трафика Cisco AVVID IP DSCP Cisco AVVID 802.1p UP IEEE 802.11e UP Примечания
Управление сетью - 7 - Зарезервированный для управления сетью только
Межсетевое управление 48 6 7 (AC_VO) Управление LWAPP
Речь 46 (EF) 5 6 (AC_VO) Контроллер: Профиль QoS Platinum
Видео 34 (AF41) 4 5 (AC_VI) Контроллер: Профиль QoS Gold
Голосовое управление 26 (AF31) 3 4 (AC_VI) -
«Максимальные усилия» 0 (BE) 0 3 (AC_BE) 0 (AC_BE) Контроллер: Профиль QoS Silver -
Общие сведения (общие сведения Cisco AVVID Gold) 18 (AF21) 2 2 (AC_BK) -
Общие сведения (общие сведения Cisco AVVID Silver) 10 (AF11) 1 1 (AC_BK) Контроллер: Профиль QoS Bronze

Примечание: IEEE 802.11e значение UP для DSCP-значений, которые не упомянуты в таблице, вычислен путем рассмотрения 3 битов MSB DSCP. Например, IEEE 802.11e значение UP для DSCP 32 (100 000 в двоичных файлах) было бы преобразованным значением десятичного числа MSB (100), который равняется 4. 802.11e значение UP DSCP 32 равняется 4.

Настройка сети

В этом документе использованы параметры данной сети:

  • Проводная сеть включает эти два маршрутизатора, Router1 и Router2, тот OSPF выполнения между ними. Проводные узлы включают сервер FTP (F1), голосовой клиент (V1) и клиент видео (Vi1). Проводные узлы соединяются с сетью через Коммутатор уровня 2, который связан с Fast Ethernet Маршрутизатора R1.

  • Беспроводная сеть соединяется с сетью через Router2 как показано в схеме. Хосты беспроводные сети включают клиента FTP (не-WMM включил), V1 голосового клиента (телефоны 7920) и клиент видео Vi1 (WMM включил).

  • Голосовым пакетам нужно дать наивысший приоритет, придерживавшийся Видеопакетами. Пакетам FTP нужно дать наименьший приоритет.

  • На проводной сети Взвешенное произвольное раннее обнаружение (WRED) используется для осуществления QoS. Другие типы трафика классифицированы и расположены по приоритетам на основе DSCP-значений. WRED внедрен на приоритезированных пакетах.

  • На беспроводной сети три WLAN должны быть созданы для каждого типа трафика, и включить соответствующие профили QoS.

    • WLAN 1—FTP Clients: Профиль QoS Bronze

    • WLAN 2—Video Clients: Профиль QoS Gold

    • WLAN 3—Voice Clients: Профиль QoS Platinum

Устройства для базового IP - подключения и включают QoS и должны быть настроены на проводной сети и беспроводной сети.

/image/gif/paws/81831/qos-wlc-lap4.gif

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Для настройки устройств для этой настройки они должны быть выполнены:

Настройте беспроводную сеть для QoS

Перед настройкой QoS на WLC необходимо настроить WLC для главной операции и зарегистрировать облегченные точки доступа на контроллере. Этот документ предполагает, что WLC настроен для главной операции и что LAP зарегистрированы к WLC. Если вы - новый пользователь, пытающийся устанавливать WLC для главной операции с LAP, обратитесь к регистрации облегченных точек доступа к Контроллеру беспроводной локальной сети (WLC).

Как только LAP зарегистрированы к WLC, выполняют эти задачи для настройки LAP и WLC для этой настройки:

  1. Настройте WLAN для других классов трафика

  2. Включите профили QoS для WLAN

Выполните эти шаги для создания WLAN на WLC для голосовых клиентов:

  1. Нажмите WLANs в графическом интерфейсе контроллера для создания WLAN.

  2. Нажмите New для настройки новой WLAN.

    В данном примере WLAN называют VoiceClients, и ИДЕНТИФИКАТОР WLAN равняется 1.

  3. Нажмите кнопку Apply.

    qos-wlc-lap5.gif

  4. В окне WLANs > Edit определите параметры для WLAN VoiceClients.

    1. Для WLAN выберите соответствующий интерфейс из поля Interface Name.

      В данном примере WLAN VoiceClients сопоставлен интерфейс Voice.

    2. От раскрывающегося меню Quality of Service (QoS) выберите соответствующий профиль QoS для WLAN.

      В данном примере выбран профиль QoS Platinum. Это дает наивысший приоритет голосовому WLAN.

    3. Для параметра "7920 Phone Support" выберите тип управления контролем доступа (CAC).

      В данном примере используется значение AP CAC Limit (Предел CAC точки доступа).

    4. Выберите другие параметры, которые зависят от требований к проектированию.

      Значения по умолчанию используются в данном примере.

    5. Нажмите кнопку Apply.

      qos-wlc-lap6.gif

      Примечание: Не включайте режим WMM, если телефоны Cisco 7920 Phone используются в сети. Вы не можете включить и режим WMM и режим управляемого клиентом CAC на том же WLAN. Когда режим управляемого точкой доступа CAC включен, AP отсылает собственный информационный элемент (IE) Cisco CAC и не отсылает стандартный IE QBSS.

Развертывания инфраструктуры для передачи голоса по WLAN включают больше, чем простое обеспечение QoS на WLAN. Голосовой WLAN должен рассмотреть требования покрытия обзора сайта, поведение пользователей, требования роуминга и контроль доступа. Это покрыто Руководствами по дизайну IP-телефона Cisco Unified серии 7900.

Точно так же создайте WLAN для клиентов видео и клиентов FTP. Клиенты видео сопоставлены с динамическим интерфейсом Video, и клиенты FTP сопоставлены с динамическим интерфейсом FTP. Это снимки экрана:

Примечание: Этот документ не объясняет, как создать VLAN на WLC. Обратитесь к VLAN на Примере конфигурации Контроллеров беспроводной локальной сети для получения информации о том, как настроить динамические интерфейсы на WLC.

/image/gif/paws/81831/qos-wlc-lap7.gif

qos-wlc-lap8.gif

Примечание: Поддержка клиентов WLAN для WMM не означает, что трафик клиента автоматически извлекает выгоду из WMM. Приложения, которые ищут преимущества WMM, назначают соответствующую приоритетную классификацию на свой трафик, и операционная система должна передать ту классификацию к интерфейсу WLAN. В специальных устройствах, таких как гарнитуры VoWLAN, это сделано как часть дизайна. Однако, если вы внедряете на платформе общего назначения, такой как ПК, классификация трафика приложения и поддержка ОС должны быть внедрены, прежде чем функции WMM могут быть использованы успешно.

Для клиентов видео выбран профиль QoS Gold, и WMM включен. Для клиентов FTP Бронза выбрана как профиль QoS, и WMM отключен, потому что в данном примере клиенты FTP не поддерживают WMM.

qos-wlc-lap9.gif

qos-wlc-lap10.gif

Примечание: Когда контроллер находится в режиме Уровня 2, и WMM включен, необходимо поместить AP на магистральный порт, чтобы позволить им присоединяться к контроллеру.

Выполните эти команды для настройки WLAN и QoS на WLC с помощью CLI:

  • Config wlan create <wlan-id> <wlan-name>, чтобы создать новую WLAN. Для wlan-идентификатора введите идентификатор от 1 до 16. Для имени WLAN введите SSID до 31 алфавитно-цифрового знака.

  • Config wlan enable <wlan-id>, чтобы включить WLAN.

  • Config wlan qos wlan-id {bronze | silver | gold | platinum}, чтобы назначить уровень качества обслуживания WLAN.

  • Config wlan wmm {disabled | allowed | required} wlan-id, чтобы включить режим WMM.

  • Config wlan 7920-support client-cac-limit {enabled | disabled} wlan-id для телефонов, требующих контролируемого клиентом приема вызовов (CAC).

  • Config wlan 7920-support ap-cac-limit {enabled | disabled} wlan-id для телефонов, требующих контролируемого клиентом приема вызовов (CAC).

Настройте проводную сеть для QoS

Для настройки проводной сети для этой настройки необходимо настроить подключение маршрутизаторов для основы и включить QoS в проводной сети. OSPF используется в качестве протокола одноадресной маршрутизации.

Функция WRED использована для осуществления QoS в проводной сети. Функция DiffServ Compliant WRED позволяет WRED использовать DSCP-значение, когда это вычисляет вероятность сброса для пакета.

Это конфигурации для маршрутизаторов R1 и R2:

Маршрутизатор 1
Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP

!--- Classifies FTP Packets based on Access List 103.

  match access-group 103
class-map match-all Video

!--- Classifies Video Packets based on Access List 102.

  match access-group 102
class-map match-all Voice

!--- Classifies Voice Packets based on Access List 101.

  match access-group 101
!
!
policy-map Marking-For-FTP

!--- Sets DSCP value af11 for FTP packets.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice

!--- Sets DSCP value ef for Voice packets.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video

!--- Sets DSCP value af41 for Video packets.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based 

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice

!--- Applies the policy Marking-For-Voice to the interface.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video

!--- Applies the policy Marking-For-Video to the interface.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP

!--- Applies the policy Marking-For-FTP to the interface.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!--- Access list used to classify Voice packets.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any

!--- Access list used to classify Video packets.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any

!--- Access list used to classify FTP packets.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Маршрутизатор 2
Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

Проверка и устранение неполадок

Один раз проводная и беспроводная сеть настроены для основного подключения, и QoS внедрено, пакеты классифицированы, отмечены и переданы на основе политики, настроенной для каждого типа трафика.

Приложение Характеристик QoS не могло бы быть легко обнаружено на слабо загруженной сети. Характеристики QoS начинают влиять на производительность приложения, когда увеличивается нагрузка сети. QoS работает для хранения задержки, дрожания и потери для типов выбранного трафика в приемлемых границах.

Для клиента видео с включенным WMM:

Когда клиент видео на проводной стороне передает данные видео клиенту на беспроводной стороне, эта последовательность событий происходит:

  1. На интерфейсе FastEthernet маршрутизатора Router1 к пакетам видео применяется политика Marking-For-Video и пакетам назначается значение DSCP AF41.

  2. Отмеченные видеопакеты проходят через S3/0 последовательных интерфейсов на Router1 и S0/0 на Router2. Это - то, где вероятность сброса пакета проверена против порога, настроенного для WRED. Когда длина примерной очереди достигает минимального порога (40 пакетов в этом случае для Видеопакетов), WRED случайным образом отбрасывает некоторые пакеты с AF41 DSCP-значения. Точно так же, когда длина примерной очереди превышает максимальный порог (50 пакетов в этом случае для Видео packedts), WRED отбрасывает все пакеты с AF41 DSCP-значения.

  3. Как только Видеопакеты достигают WLC через fastethernet на Router2, WLC преобразовывает DSCP-значение входящего пакета к AVVID 802.1p значение UP и копирует DSCP-значение от входящего пакета до Пакета lwapp как показано здесь. В данном примере AF41 DSCP-значения преобразован в передачу 802.1p, оценивают 4.

    qos-wlc-lap11.gif

  4. Когда пакет достигает LAP, LAP преобразовывает DSCP-значение входящего пакета LWAPP к 802.11e значение UP и настраивает значение, чтобы гарантировать, что это не превышает максимально допустимое значение QoS беспроводной сети, заданное политикой тому клиенту. LAP тогда размещает пакет в очередь Tx 802.11, соответствующую значению UP. В данном примере AF41 DSCP-значения преобразован в передачу 802.11e значение UP 5.

    /image/gif/paws/81831/qos-wlc-lap12.gif

Когда клиент видео на беспроводной стороне передает данные к проводной стороне, эта последовательность событий происходит:

  1. Когда клиент с включенным WMM передает пакет к LAP, LAP определяет политику 802.11e значение UP, чтобы гарантировать, что это не превышает максимальное значение для политики QoS, назначенное на тот клиент. Затем это преобразовывает значение в DSCP-значение. В данном примере WLAN для видео был настроен с профилем QoS Gold, который имеет 802.11e значение UP 4. Это значение преобразовано в соответствующий AF41 DSCP-значения и передается контроллеру.

    /image/gif/paws/81831/qos-wlc-lap13.gif

  2. Контроллер преобразовывает DSCP-значение входящего пакета LWAPP к 802.1p, значение UP как показано и исходное DSCP-значение также передаются неизменные.

    /image/gif/paws/81831/qos-wlc-lap14.gif

  3. Пакеты с DSCP-значением af41 в fastethernet на Router2 проходят через последовательные интерфейсы на Router2 и Router1, и достигают видео клиентов на проводной стороне. Когда пакет пересекает последовательные интерфейсы, вероятность сброса пакета проверена против порога, настроенного для WRED.

Для клиента FTP с выключенным WMM:

Когда сервер FTP на проводной стороне передает данные клиенту FTP на беспроводной стороне, эта последовательность событий происходит:

  1. На интерфейсе FastEthernet маршрутизатора Router1 к пакетам FTP применяется политика Marking-For-FTP и пакетам присваивается значение DSCP, равное AF11.

  2. Отмеченные пакеты FTP проходят через последовательные интерфейсы s3/0 на Router1 и S0/0 на Router2. Это - то, где вероятность сброса пакета проверена против порога, настроенного для WRED. Когда длина примерной очереди достигает минимального порога (30 пакетов в этом случае для пакетов FTP), WRED случайным образом отбрасывает некоторые пакеты с AF11 DSCP-значения. Точно так же, когда длина примерной очереди превышает максимальный порог (40 пакетов в этом случае для пакетов FTP), WRED отбрасывает все пакеты с AF11 DSCP-значения.

  3. Как только пакеты FTP достигают WLC через fastethernet на Router2, WLC преобразовывает DSCP-значение входящего пакета к AVVID 802.1p значение UP и копирует DSCP-значение от входящего пакета до Пакета lwapp как показано здесь. В данном примере AF11 DSCP-значения преобразован в передачу 802.1p, оценивают 1.

  4. Когда пакет достигает LAP, LAP размещает пакет в очередь Tx 802.11 по умолчанию для политики QoS WLAN, назначенной на тот клиент. В данном примере пакет размещен в очередь для профиля QoS Bronze.

Когда клиент FTP на беспроводной стороне передает данные к проводной стороне, эта последовательность событий происходит:

  1. Когда клиент FTP на беспроводной сети передает пакет к LAP, LAP использует 802.11e значение UP для политики QoS, назначенной на тот клиент. Затем LAP преобразовывает значение в DSCP-значение и передает пакет к контроллеру. Поскольку клиент FTP принадлежит профилю QoS бронзовый IEEE 802.11e, значение UP 1 преобразовано в AF11 DSCP-значения.

  2. Контроллер преобразовывает DSCP-значение входящего пакета LWAPP к 802.1p, значение UP как показано и исходное DSCP-значение также передаются неизменные. Пакет тогда передан к Router2 через Коммутатор уровня 2.

  3. Пакеты с AF11 DSCP-значения в fastethernet на Router2 проходят через последовательные интерфейсы на Router2 и Router1, и достигают клиентов видео на проводной стороне. Когда пакет пересекает последовательные интерфейсы, вероятность сброса пакета проверена против порога, настроенного для WRED.

Подобная процедура происходит когда пересечение голосового пакета от проводного до беспроводной сети и наоборот.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

Можно выполнить эти Команды Cisco IOS на маршрутизаторах, чтобы устранить неполадки и проверить конфигурацию QoS:

  • show queue {имя-интерфейса номер-интерфейса} — вывод информации о пакетах в очереди интерфейса.

  • show queueing random-detect interface {имя-интерфейса номер-интерфейса} — вывод конфигурации и статистики средства обработки очереди интерфейса.

  • show policy-map interface {имя-интерфейса номер-интерфейса} — вывод статистики и конфигураций политик ввода и вывода, связанных с интерфейсом. Удостоверьтесь, что использовали эту команду в соответствующем Режиме EXEC.

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • debug qos set — вывод информации о QoS метках пакетов.

На WLC выполните эту команду для просмотра параметров настройки профиля QoS:

  • show qos {bronze/silver/gold/platinum} — вывод информации о профиле QoS, настроенном для WLAN.

    Ниже приведен пример выходных данных команды show qos:

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • show wlan <WLAN-ID> — вывод информации о WLAN. Ниже приведен пример выходных данных:

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 81831