Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Пример конфигурации для переноса связующего дерева с PVST +на MST

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (7 апреля 2008) | Английский (7 октября 2015) | Отзыв


Содержание


Введение

В этом документе приведен пример конфигурации для перевода режима связующего дерева с PVST+ на множественное связующее дерево (MST) в сети комплекса зданий.

Предварительные условия

Требования

См. Понимание Множественного Протокола STP (802.1s) перед настройкой MST.

Эта таблица показывает поддержку MST в Коммутаторах Catalyst и минимальном программном обеспечении, требуемом для той поддержки.

Платформа Catalyst MST с RSTP
Catalyst 2900XL и 3500XL Недоступно
Catalyst 2950 и 3550 Cisco IOS� 12.1 (9) EA1
Catalyst 3560 Cisco IOS 12.1 (9) EA1
Catalyst 3750 Cisco IOS 12.1 (14) EA1
Catalyst 2955 Все версии Cisco IOS
Catalyst 2948G-L3 и 4908G-L3 Недоступно
Catalyst 4000, 2948G, и 2980G (операционная система Catalyst (CatOS)) 7.1
Catalyst 4000 и 4500 (Cisco IOS) 12.1 (12c) EW
Catalyst 5000 и 5500 Недоступно
Catalyst 6000 и 6500 (CatOS) 7.1
Catalyst 6000 и 6500 (Cisco IOS) 12.1(11b)EX, 12.1(13)E, 12.2(14)SX
Catalyst 8500 Недоступно

  • Catalyst 3550/3560/3750: реализация TheMST в Cisco IOS Release 12.2 с 25 SEC основывается на стандарте IEEE 802.1S. MST реализации в более ранних Cisco IOS Release являются предстандартными.

  • Catalyst 6500 (IOS): MST реализация в Cisco IOS Release 12.2 (18) SXF основывается на стандарте IEEE 802.1S. MST реализации в более ранних Cisco IOS Release являются предстандартными.

Используемые компоненты

Этот документ создан с программным обеспечением Cisco IOS версии 12.2 (25) и CatOS 8.5 (8), но конфигурация применима к минимальной версии IOS, упомянутой в таблице.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Общие сведения

MST функция является IEEE 802.1S и является поправкой к 802.1Q. MST расширяется 802.1w алгоритм Быстрого связующего дерева (RST) ко множественным связующим деревьям. Это расширение обеспечивает и быструю сходимость и балансирующий нагрузку в среде VLAN. PVST + и Rapid-PVST + выполненный экземпляр связующего дерева для каждой VLAN. В MST можно сгруппировать VLAN в единственный экземпляр. Это использует версию 3 Блока данных протокола моста (BPDU), которая обратно совместима с 802.1D STP, который использует версию 0 BPDU.

Конфигурация MSTP: конфигурация включает название области, номера версии и MST карты присвоения VLAN К ЭКЗЕМПЛЯРУ. Вы настраиваете коммутатор для области с командой глобальной кофигурации spanning-tree mst configuration.

Регион MST: Регион MST состоит из соединенных мостов, которые имеют ту же конфигурацию MST. Нет никакого предела на количестве регионов MST в сети.

Экземпляры связующего дерева В Регионе MST: экземпляр является только группой VLAN, сопоставленных в команде spanning-tree mst configuration. По умолчанию все VLAN сгруппированы в IST0, который называют Внутренним связующим деревом (IST). Можно вручную создать экземпляры, пронумерованные 1 - 4094, и они маркированы MSTn (n =1 к 4094), но область может поддержать только до 65 экземпляров. Некоторые версии поддерживают только 16 экземпляров. Обратитесь руководство по конфигурации программного обеспечения для своей платформы коммутатора.

IST/CST/CIST: IST является единственным экземпляром, который может передать и получить BPDU в сети MST. Экземпляр MSTn локален для области. IST в других областях соединены через Общее связующее дерево (CST). Набор IST в каждом регионе MST и CST, который подключает IST, называют Общим и Внутренним Связующим деревом (CIST).

Обратная совместимость: MST обратно совместим с PVST +, Rapid-PVST +, и Предстандартный MST (MISTP). MST коммутатор связан с другим STP (PVST + и Rapid-PVST +) коммутаторы Общим связующим деревом (CST). Другой STP (PVST + и Rapid-PVST +) коммутаторы рассматривает весь регион MST как один коммутатор. При соединении предстандартного MST коммутатора со стандартным MST коммутатором необходимо настроить spanning-tree mst pre-standard в интерфейсе стандартного MST коммутатора.

Настройка

Этот пример состоит из двух разделов. В первом разделе приводится текущая конфигурация PVST+. Второй раздел показывает конфигурацию, которая мигрирует от PVST + к MST.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В настоящем документе используется следующая схема сети:

Эта схема включает эти коммутаторы:

  • Коммутаторы Distribution1 и Distribution2 на уровне распределения

  • Два коммутатора уровня доступа с именами Access1 (IOS) и Access2 (CatOS)

  • Два коммутатора для объединения потоков серверов Services1 и Services2

Сети VLAN 10, 30 и 100 для передачи трафика данных. Сети VLAN 20, 40 и 200 для передачи голосового трафика.

/image/gif/paws/72844/MST-1.gif

Конфигурации

Эти конфигурации используются в данном документе:

Конфигурация PVST+

Коммутаторы настраиваются в PVST+ для переноса голоса и данных в соответствии со схемой сети. Ниже приводится краткая сводка конфигурации:

  • Коммутатор Distribution1 настроен для становления основным корневым мостом для VLAN для передачи данных 10, 30, и 100 с Distribution1 (config) # spanning-tree vlan 10 30 100 корневых основных команд и вторичный корневой мост для голосовых VLAN 20, 40, и 200 использования Distribution1 (config) # spanning-tree vlan 20 40 200 корневых дополнительных команд.

  • Коммутатор Distribution2 настроен для становления основным корневым мостом для голосовых VLAN 20, 40, и 200 с Distribution2 (config) # spanning-tree vlan 20 40 200 корневых основных команд и вторичный корневой мост для VLAN для передачи данных 10, 30, и 100 использования Distribution2 (config) # spanning-tree vlan 10 30 100 корневых дополнительных команд.

  • Команда spanning-tree backbonefast настроена на всех коммутаторах для схождения STP более быстро в случае сбоя обходного соединения в сети.

  • Команда spanning-tree uplinkfast настроена на коммутаторах уровня доступа для схождения STP более быстро в случае прямого отказа uplink.

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Вы можете видеть, что порт Fa1/0/24 настроен с помощью команды spanning-tree vlan 20,40,200 port-priority 64. Distribution2 является настроенным, поддерживают VLAN 20,40, и 200. Distribution2 имеет две ссылки на Distribution1: Fa1/0/23 и Fa1/0/24. Оба порта являются назначенными портами для VLAN 20, 40, и 200, потому что Distribution2 является root для тех VLAN. Оба порта имеют одинаковый приоритет 128 (по умолчанию). Кроме того, эти две ссылки имеют ту же стоимость от Distribution1: fa1/0/23 и fa1/0/24. Коммутатор Distribution1 выбирает порт с наименьшим номером и переводит его в состоянии пересылки. Минимальный номер порта является Fa1/0/23, но, согласно схеме сети, голосовые VLAN 20, 40, и 200 могут течь через Fa1/0/24. Этого можно добиться следующими способами:

  1. Уменьшить стоимость порта Fa1/0/24 на коммутаторе Distribution1.

  2. Снизить приоритетность порта Fa1/0/24 на коммутаторе Distribution2.

В примере для пересылки трафика сетей VLAN 20, 40 и 200 через fa1/0/24 снижена приоритетность этого порта.

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Вы видите, что порт Fa0/5 в Services1, и и Fa0/6 и Fa0/48 в Services2 имеет конфигурация приоритета порта и Стоимость порта связующего дерева. В данном случае протокол STP настроен так, что трафик сетей VLAN 100 и 200 коммутаторов Services1 и Services2 может передаваться через магистральные каналы между ними. Если эта конфигурация не применена, Services1 и 2 не может передать трафик через магистральные линии между ними. Вместо этого будет выбран путь между коммутаторами Distribution1 и Distribution2.

Коммутатор Services2 видит два пути с равной стоимостью к корневому мосту сети VLAN 100 (Distribution1): один через Services1 и второй через Distribution2. STP выбирает оптимальный путь (корневой порт) в этом заказе:

  1. Стоимость пути

  2. Идентификатор моста пересылающего коммутатора

  3. Самый низкий приоритет порта

  4. Самый низкий внутренний номер порта

В данном примере оба пути имеют ту же стоимость, но Distribution2 (24576) имеет более низкий приоритет, чем Services1 (32768) для VLAN 100, таким образом, Services2 выбирает Distribution2. В данном примере, стоимости порта на Services1: fa0/5 собирается ниже позволить Services2 выбрать Services1. Стоимость пути переопределяет значение приоритета пересылающего коммутатора.

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

Аналогичный метод используется, чтобы позволить коммутатору Services1 выбрать коммутатор Services2 для пересылки трафика сети VLAN 200. После сокращения стоимости для VLAN 200 в Services2 - fa0/6 Services1 выбирает fa0/47 для передачи VLAN 200. Требование здесь должно передать VLAN 200 через fa0/48. Можно выполнить это с этими двумя методами:

  1. Уменьшить стоимость порта Fa0/48 на коммутаторе Services1.

  2. Снизить приоритетность порта Fa0/48 на коммутаторе Services2.

В примере для пересылки трафика сети VLAN 200 через fa0/48 снижена приоритетность этого порта.

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

MST миграция

Трудно преобразовать все коммутаторы в корпоративной сети к MST в то же время. Из-за обратной совместимости можно преобразовать его фаза фазой. Внедрите изменения в сроке планового обслуживания, потому что изменение конфигурации связующего дерева может разрушить трафик. При включении MST он также включает RSTP. Связующее дерево uplinkfast и функции backbonefast являются PVST + функции, и это отключено при включении MST, потому что те функции созданы в RSTP, и MST полагается на RSTP. В рамках миграции можно удалить те команды в IOS. В catOS backbonefast и uplinkfast, команды автоматически очищены от конфигурации, но конфигурация функций, таких как PortFast, bpduguard, bpdufilter, защита корневого узла и loopguard также применима в режиме MST. Использование этих функций совпадает с в PVST + режим. Если вы уже активировали эти опции в PVST + режим, это остается активным после миграции к режиму MST. Когда вы настраиваете MST, придерживаетесь этих рекомендаций и ограничений:

  • Первый шаг в миграции к 802.1s/w должен должным образом определить точка-точка и порты Edge. Гарантируйте, что все соединения коммутатор-коммутатор, на которых желаем быстрый обмен данными, являются полнодуплексными. Порты Edge определены через Характеристику PortFast.

  • Выберите имя конфигурации и номер версии, которые характерны для всех коммутаторов в сети. Cisco рекомендует разместить как можно больше коммутаторов в одиночную область; не выгодно сегментировать сеть в отдельные области.

  • Тщательно решите, сколько экземпляров необходимо в коммутируемой сети и имеет в виду, что экземпляр преобразовывает в логическую топологию. Избегите сопоставлять любые VLAN на экземпляр 0. Решите, какие VLAN сопоставить на те экземпляры, и тщательно выбрать root и резервную копию поддерживают каждый экземпляр.

  • Гарантируйте, что транки несут все VLAN, которые сопоставлены с экземпляром или не несут VLAN вообще для этого экземпляра.

  • MST может взаимодействовать с прежними мостами, которые выполняют PVST + на для каждого порта основание, таким образом, это не проблема смешать оба типа мостов, если ясно поняты взаимодействия. Всегда пытайтесь поддержать root CST и IST в области. Если вы взаимодействуете с PVST + мост через транк, гарантируете, что MST мост является root для всех VLAN, которые позволены на том транке. Не используйте мосты PVST в качестве root CST.

  • Гарантируйте, что все мосты корня связующего дерева PVST имеют ниже (численно выше) приоритет, чем корневой мост CST.

  • Не отключайте связующее дерево ни на какой VLAN ни в одном из мостов PVST.

  • Не подключайте коммутаторы с соединениями доступа, потому что соединения доступа могут разделить VLAN.

  • Любая конфигурация MST, которая включает большое число или текущих или новых логических портов VLAN, должна быть завершена в периоде технического обслуживания, потому что завершенная MST база данных повторно инициализируется для любого инкрементного изменения, такого как добавление новых VLAN к экземплярам или перемещению VLAN через экземпляры.

В данном примере сеть уровня кампуса имеет один регион MST, названный region1 и двумя экземплярами MST1 - VLAN для передачи данных 10, 30, и 100, и MST2 - голосовые VLAN 20, 40, и 200. Вы видите, что MST выполняет только два экземпляра, но PVST + выполняет шесть экземпляров. Distribution1 выбран в качестве CIST региональный root. Это означает, что Distribution1 является root для IST0. Для распределения нагрузки трафика в сети согласно схеме Distribution1 настроен как root для MST1 (экземпляр для VLAN для передачи данных), и MST2 настроен как root для MST2 (экземпляр для голосовых VLAN).

Необходимо переместить ядро сначала и проложить себе путь вниз к коммутаторам доступа. Прежде чем вы измените режим связующего дерева, настроите конфигурацию MST на коммутаторах. Затем измените тип STP на MST. В этом примере изменение режима выполняется в следующем порядке:

  1. Distribution1 и Distribution2

  2. Services1 и Services2

  3. Access1

  4. Access2

  1. Изменение режима Distribution1 и Distribution2:

    
    !--- Distribution1 configuration:
    
    Distribution1(config)#spanning-tree mst configuration
    Distribution1(config-mst)#name region1
    Distribution1(config-mst)#revision 10
    Distribution1(config-mst)#instance 1 vlan 10, 30, 100
    Distribution1(config-mst)#instance 2 vlan 20, 40, 200
    Distribution1(config-mst)#exit
    Distribution1(config)#spanning-tree mst 0-1 root primary
    Distribution1(config)#spanning-tree mst 2 root secondary
    
    
    !--- Distribution2 configuration:
    
    Distribution2(config)#spanning-tree mst configuration
    Distribution2(config-mst)#name region1
    Distribution2(config-mst)#revision 10
    Distribution2(config-mst)#instance 1 vlan 10, 30, 100
    Distribution2(config-mst)#instance 2 vlan 20, 40, 200
    Distribution2(config-mst)#exit
    Distribution2(config)#spanning-tree mst 2 root primary
    Distribution2(config)#spanning-tree mst 0-1 root secondary
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    
    Distribution1(config)#interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)#interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    !--- STP mode conversion.
    
    Distribution1(config)#spanning-tree mode mst
    Distribution2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic.
    
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#spanning-tree mst 2 port-priority 64
    
    
    !--- PVST+ cleanup.
    
    Distribution1(config)#no spanning-tree backbonefast
    Distribution2(config)#no spanning-tree backbonefast
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#no spanning-tree vlan 20,40,200 port-priority 64
    

    Примечание: Рекомендуется установить root MST0 вручную. В данном примере Distribution1 выбран в качестве root MST0, таким образом, Distribution1 становится root CIST.

    Теперь сеть находится в смешанной конфигурации. Это может быть представлено согласно этой схеме:

    MST-2.gif

    Distribution1 и Distribution2 находятся в MST region1 и PVST +, коммутаторы рассматривают region1 как одиночный мост. Трафик после повторно схождения показывают в Схеме 2. Можно все еще настроить PVST + (spanning-tree VLAN X стоимости) переключает на loadbalance данные и голосовой трафик согласно Схеме 1. После миграции всех других коммутаторов согласно шагам 2 - 4 вы получаете заключительную топологию связующего дерева согласно Схеме 1.

  2. Изменение режима Services1 и Services2:

    
    !--- Services1 configuration:
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)#name region1
    Services1(config-mst)#revision 10
    Services1(config-mst)#instance 1 vlan 10, 30, 100
    Services1(config-mst)#instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    !--- Services2 configuration:
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)#name region1
    Services2(config-mst)#revision 10
    Services2(config-mst)#instance 1 vlan 10, 30, 100
    Services2(config-mst)#instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the 
    !--- VLANs that are mapped to an instance.
    
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    !--- STP Mode conversion:
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic:
    
    Services1(config)#interface fastEthernet 0/46
    Services1(config-if)#spanning-tree mst 2 cost 200000
    Services1(config-if)#exit
    Services1(config)#interface fastEthernet 0/47
    Services1(config-if)#spanning-tree mst 2 cost 100000
    Services1(config-if)#exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)#exit
    
    
    !--- PVST+ cleanup:
    
    Services1(config)#no spanning-tree uplinkfast
    Services1(config)#no spanning-tree backbonefast
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#no spanning-tree vlan 100 cost 18
    Services1(config-if)#exit
    
    Services2(config)#no spanning-tree uplinkfast
    Services2(config)#no spanning-tree backbonefast
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#no spanning-tree vlan 200 cost 18
    Services2(config-if)#exit
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#no spanning-tree vlan 200 port-priority 64
    Services2(config-if)#exit
    
  3. Изменение режима Access1:

    
    !--- Access1 configuration:
    
    Access1(config)#spanning-tree mst configuration
    Access1(config-mst)#name region1
    Access1(config-mst)#revision 10
    Access1(config-mst)#instance 1 vlan 10, 30, 100
    Access1(config-mst)#instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    !--- STP mode conversion:
    
    Access1(config)#spanning-tree mode mst
    
    
    !--- PVST+ cleanup:
    
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
  4. Изменение режима Access2:

    
    !--- Access2 configuration:
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    !--- Ensure that trunks carry all the VLANs that are mapped to an instance:
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    
    !--- Backbonefast and uplinkfast configurations are cleaned up automatically.
    
    

Проверка

Рекомендуется проверять топологию STP при каждом изменении конфигурации.

Проверьте, что коммутатор Distribution1 является корневым мостом для VLAN для передачи данных 10, 30, и 100, и проверьте, что путь переадресации связующего дерева совпадает согласно пути в схеме.

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p


!--- CIST root is Distribution1. All the 
!--- switches are in the same region "region1".
!--- Hence in all the switches in the region1 you can see the path cost as 0.


Distribution2#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 72844