Безопасность : Устройства защиты Cisco PIX серии 500

PIX/ASA 7.x и выше: Почта (SMTP) доступ сервера на примере конфигурации DMZ

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот пример конфигурации демонстрирует, как установить Устройство безопасности PIX/ASA для доступа к ПОЧТЕ/СЕРРЕРУ SMTP, расположенной в сети Demilitarized Zone (DMZ).

Дополнительные сведения о порядке настройки многоконтекстной конфигурации в устройствах защиты см. в документе PIX/ASA версий 7.x и выше: Доступ Почтового сервера на Примере конфигурации Внутренней сети для инструкций о том, как установить Устройство безопасности PIX/ASA для доступа к ПОЧТЕ/СЕРРЕРУ SMTP, расположился на Внутренней сети.

Обратитесь к PIX/ASA 7.x с Доступом Почтового сервера на Примере конфигурации Внешней сети для инструкций о том, как установить Устройство безопасности PIX/ASA для доступа к ПОЧТЕ/СЕРРЕРУ SMTP, расположенной на Внешней сети.

Обратитесь к ASA 8.3 и Позже: Почта (SMTP) Доступ сервера на Примере Конфигурации DMZ для получения дополнительной информации об одинаковой конфигурации на устройстве адаптивной защиты Cisco (ASA) с версией 8.3 и позже.

Примечание: Обратитесь к документации Cisco для межсетевого экрана Cisco Secure PIX для получения дополнительной информации о том, как установить Microsoft Exchange. Выберите версию программного обеспечения и прочитайте соответствующую главу по настройке Microsoft Exchange в руководстве по конфигурации.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Брандмауэр PIX 535

  • Программное обеспечение брандмауэра PIX, выпуск 7.1(1)

    Примечание: В PIX 500 версии 7.x/8.x работает то же ПО, что и в ASA 5500 версии 7.x/8.x. Конфигурации в этом документе применяются к обеим линейкам продуктов.

  • Маршрутизатор Cisco 2600

  • Cisco выпуск ПО IOS� 12.3.14T

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/security/pix-500-series-security-appliances/69374-pix7x-mailserver-1.gif

Примечание: Схемы IP-адресации, которые использованы в данной конфигурации, не поддерживаются официальной маршрутизацией в Интернете. Это адреса RFC 1918 , которые были использованы в лабораторной среде. leavingcisco.com

Конфигурация PIX

В данном документе используется следующая конфигурация:

Конфигурация PIX
PIX Version 7.1(1) 
!
hostname pixfirewall
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0
 shutdown
 nameif BB
 security-level 0
 no ip address
!
interface Ethernet1
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet2
 no nameif
 no security-level
 no ip address
!
interface Ethernet3
 nameif inside
 security-level 100
 ip address 10.1.1.1 255.255.255.0 
!
interface Ethernet4
 nameif outside
 security-level 0
 ip address  192.168.200.225 255.255.255.224 
!
interface Ethernet5
 nameif dmz
 security-level 10
 ip address 172.16.31.1 255.255.255.0 
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system flash:/pix711.bin
ftp mode passive


!--- This access list allows hosts to access 
!--- IP address  192.168.200.227 for the 
!--- Simple Mail Transfer Protocol (SMTP) port.

 
access-list outside_int extended permit tcp any host  192.168.200.227 eq smtp 


!--- Allows outgoing SMTP connections.
!--- This access list allows host IP 172.16.31.10
!--- sourcing the SMTP port to access any host.


access-list dmz_int extended permit tcp host 172.16.31.10 any eq smtp

pager lines 24
mtu BB 1500
mtu inside 1500
mtu outside 1500
mtu dmz 1500  
no failover
no asdm history enable
arp timeout 14400
global (outside) 1  192.168.200.228-192.168.200.253 netmask 255.255.255.224
global (outside) 1  192.168.200.254
nat (inside) 1 10.1.1.0 255.255.255.0


!--- This network static does not use address translation. 
!--- Inside hosts appear on the DMZ with their own addresses.


static (inside,dmz) 10.1.1.0 10.1.1.0 netmask 255.255.255.0


!--- This network static uses address translation. 
!--- Hosts accessing the mail server from the outside 
!--- use the  192.168.200.227 address.


static (dmz,outside)  192.168.200.227 172.16.31.10 netmask 255.255.255.255
access-group outside_int in interface outside
access-group dmz_int in interface dmz
route outside 0.0.0.0 0.0.0.0  192.168.200.226 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
telnet timeout 5
ssh timeout 5
console timeout 0
!
class-map inspection_default
 match default-inspection-traffic
!
!

!--- The inspect esmtp command (included in the map) allows  
!--- SMTP/ESMTP to inspect the application.


policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny 
  inspect esmtp
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip 
  inspect xdmcp 
!

!--- The inspect esmtp command (included in the map) allows  
!--- SMTP/ESMTP to inspect the application.

service-policy global_policy global
Cryptochecksum:2653ce2c9446fb244b410c2161a63eda
: end
[OK]

Конфигурация ESMTP TLS

Примечание: При использовании шифрование Transport Layer Security (TLS) для переписки по электронной почте тогда функция проверки ESMTP (включил по умолчанию) в отбрасываниях PIX пакеты. Чтобы разрешить передачу электронных сообщения при включенном TLS, отключите функцию проверки ESMTP, как показано ниже. Обратитесь к идентификатору ошибки Cisco CSCtn08326 (только зарегистрированные клиенты) для получения дополнительной информации.

pix(config)#policy-map global_policy
pix(config-pmap)#class inspection_default
pix(config-pmap-c)#no inspect esmtp
pix(config-pmap-c)#exit
pix(config-pmap)#exit

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

  • debug icmp trace — Показывает, достигают ли запросы протокола управляющих сообщений интернета (ICMP) от хостов PIX. Для выполнения этой отладки добавьте команду access-list, чтобы разрешить ICMP в вашей конфигурации.

    Примечание: Для использования этой отладки удостоверьтесь, что вы позволяете ICMP в access-list outside_int как показано в выходных данных ниже:

    access-list outside_int extended permit tcp any host  192.168.200.227 eq smtp 
    access-list outside_int extended permit icmp any any 
  • регистрация перед отладкой — Показывает соединения, которые установлены и запрещены хостам, которые проходят через PIX. Эти сведения хранятся в буфере журнала PIX, а данные можно просмотреть с использованием команды show log.

Дополнительные сведения о настройке записей в журнал см. в разделе Настройка системного журнала PIX.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 69374