Беспроводные сети / Мобильные решения : Беспроводная сеть VLAN

Пример конфигурации сетей VLAN на контроллерах беспроводной LAN

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе описан способ настройки виртуальных локальных сетей (VLAN) на контроллерах беспроводных локальных сетей (WLC).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования. Однако при этом предполагается наличие в сети работающего DHCP-сервера, который выделяет IP-адреса точкам доступа, зарегистрированным на контроллере.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Конфигурация А:

    • Коммутатор Catalyst, который выполняет Cisco программное обеспечение IOS� и контроллер беспроводной локальной сети

    • Контроллер беспроводной локальной сети Cisco 4404, который работает под управлением ПО версии 7.0

  • Конфигурация B:

    • Коммутатор Catalyst, который выполняет программное обеспечение операционной системы Catalyst (CatOS) и контроллер беспроводной локальной сети

    • Контроллер беспроводной локальной сети Cisco 4404, который работает под управлением ПО версии 7.0

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Динамические интерфейсы на WLC

Динамические интерфейсы, также известные как интерфейсы виртуальной локальной сети (VLAN), созданы пользователями и разработаны для похожения на VLAN для клиентов Беспроводной локальной сети. Контроллер может поддержать до 512 динамических интерфейсов (VLAN). Каждый динамический интерфейс индивидуально настроен и позволяет отдельным потокам связи существовать на любых из портов системы распределения контроллера. Каждый динамический интерфейс управляет VLAN и другой связью между контроллерами и устройствами всех других сетей, и каждый действует как ретранслятор DHCP для беспроводных клиентов, привязанных к WLAN, сопоставленным с интерфейсом. Можно назначить динамические интерфейсы на порты системы распределения, WLAN, интерфейс управления Уровня 2 и интерфейс менеджера точки доступа Уровня 3. Можно также сопоставить динамический интерфейс с резервным портом.

Можно настроить нуль, один, или множественные динамические интерфейсы на порту системы распределения. Однако все динамические интерфейсы должны быть на другой VLAN или IP-подсети от всех других интерфейсов, настроенных на порту. Если порт без меток, все динамические интерфейсы должны быть на другой IP-подсети от любого другого интерфейса, настроенного на порту.

Настройка динамический интерфейс со вторичной подсетью не поддерживается.

Cisco рекомендует использовать теговые VLAN для динамических интерфейсов.

VLAN с контроллерами беспроводной локальной сети используют эту модель:

/image/gif/paws/68100/wlan_controllers_vlans1.gif

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Конфигурация коммутаторов Catalyst

В этом разделе используются следующие конфигурации:

Коммутатор Catalyst с ПО Cisco IOS
lab1sup720ip1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

Коммутатор Catalyst с ПО CatOS
controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- This command should be on one line.

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.

Настройка VLAN на WLAN контроллере

Конфигурация графического интерфейса пользователя (GUI )

Выполните эти шаги на контроллере беспроводной локальной сети.

  1. От GUI WLC выберите Controller> Interfaces. Страница Interfaces перечисляет все интерфейсы, которые настроены на WLC. Для создания нового динамического интерфейса нажмите New.

    wlan_controllers_vlans2.gif

  2. Введите имя интерфейса (Interface Name) и идентификатор VLAN (VLAN Identifier ). Нажмите Apply.

    wlan_controllers_vlans3.gif

  3. Введите параметры, определенные для этой VLAN. Некоторые параметры включают IP-адрес, маску подсети, шлюз и IP - адрес сервера DHCP, и нажимают Apply.

    Например.

    wlan_controllers_vlans4.gif

    Примечание: IP-адрес, назначенный на этот интерфейс, действует как ретранслятор DHCP для клиента для получения IP-адреса из сервера DHCP. Например, если клиент пытается присоединиться к WLAN/SSID (см. шаг 5 данной процедуры настройки), которые ассоциированы с данным динамическим интерфейсом, тогда для определения DHCP-сервера он выполняет операцию широковещания в местной подсети. Контроллер направляет DHCP-серверу (или самому себе, если он является DHCP-сервером в данном сегменте) запрос, в котором IP-адрес этого динамического интерфейса указан в качестве релейного IP (relay IP), выполняющего переключение на DHCP-сервер, настроенный для данного интерфейса. Из имеющегося диапазона DHCP DHCP-сервер выделяет клиенту IP-адрес.

  4. Проверка конфигурации интерфейса.

    В меню, расположенном в верхней части окна, щелкните вкладку Controller и из меню, расположенного в левой части, выберите Interfaces.

    wlan_controllers_vlans5.gif

  5. Нажмите вкладку WLAN в меню наверху окна и нажмите Create New.

    wlan_controllers_vlans6.gif

  6. Введите Идентификатор набора сервисов (SSID) и Имя профиля и нажмите Apply.

    Для простоты в данном примере используется vlan15.

    wlan_controllers_vlans7.gif

  7. В раскрывающемся списке "Interface Name", расположенном в нижней части окна, выберите vlan15 и нажмите Apply.

    В данном случае SSID "vlan15" привязан к имени интерфейса "vlan15".

    wlan_controllers_vlans8.gif

Конфигурация интерфейса командой строки CLI

Используйте этот раздел для настройки VLAN через интерфейс командной строки (CLI).

  1. Создайте интерфейс и ассоциированный тэг VLAN.

    Команда является config interface create interface_name идентификатор VLAN.

    (lab5wlc4404ip15) >config interface create "vlan 15" 15
    

    Примечание: Если существует пространство на название VLAN/WLAN, как имеет место в данном примере, удостоверьтесь, что название находится в кавычках.

  2. Назначьте IP-адрес и шлюз, используемый по умолчанию.

    Команда является интерфейсом config interface_name IP_address маска подсети шлюз .

    (lab5wlc4404ip15) >config interface address "vlan 15" 192.168.15.10  
    255.255.255.0 192.168.15.1
    
    !--- This command should be on one line.
    
    
  3. Установка DHCP-сервера.

    Команда является динамическим интерфейсом config interface dhcp <interface-name>, основной <основной сервер> [вторичный] <дополнительный сервер> .

    (lab5wlc4404ip15) >config interface dhcp dynamic-interface "vlan 15" primary 1
    2.168.15.15
    
  4. Выполните эту команду для сопоставления интерфейса с физическим портом:

    config interface port operator_defined_interface_name physical_ds_port_number.. Например:

    (Cisco Controller) >config interface port "vlan 15" 2
    
  5. Проверка конфигурации интерфейса.

    Для проверки используйте команду show interface summary.

    (Cisco Controller) >show interface summary
    
    Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Guest
    -------------------------------- ---- -------- --------------- ------- ------ ----
    ap-manager                       2    untagged 10.77.244.207   Static  Yes    N
    
    management                       2    untagged 10.77.244.206   Static  No     N
    
    service-port                     N/A  N/A      50.0.0.1        Static  No     N
    
    virtual                          N/A  N/A      1.1.1.1         Static  No     N
    
    vlan 15                          2    15       192.168.15.10   Dynamic No     N
  6. Установка WLAN.

    Команда является config wlan create wlan_id name.

    (lab5wlc4404ip15) >config wlan create 2 "vlan 15"
    
  7. Установка интерфейса для WLAN.

    Команда является config wlan interface wlan_id interface_name .

    (lab5wlc4404ip15) >config wlan interface 2 "vlan 15"
    
  8. Проверка WLAN и ассоциированного интерфейса.

    Для проверки используйте команду show wlan summary.

    (lab5wlc4404ip15) >show wlan summary 
    
    Number of WLANs.................................. 2
    
    WLAN ID�  WLAN Name�������������� Status���� �� Interface Name����������������� 
    -------� �--------------------�   ---------� ���--------------------------------
    1������� �lab5wlc4404ip15������   Enabled����   management��������������������� 
    2������� �vlan 15����������������� Disabled���   vlan 15������������������������� 
    
    (lab5wlc4404ip15) >

Щелкните по этой ссылке для смотрения видео Сообщества Cisco Support, которое описывает, как настроить VLAN на Контроллерах беспроводной локальной сети:

VLAN на контроллерах беспроводной локальной сети leavingcisco.com

wlan_controllers_vlans9.gif

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Проверка для коммутаторов Catalyst

  • Коммутатор Catalyst, который выполняет программное обеспечение Cisco IOS — interface_type show running-config interface номер интерфейса

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
     
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • Коммутатор Catalyst с ПО CatOS— команда show config mod

    controller-catos> (enable) show config 2
    
    !--- This command shows non-default configurations only.
    !--- Issue the show config mod all command in order to  
    !--- show both default and non-default configurations.
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04 
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)

Проверка VLAN на контроллере WLAN

Посмотрите раздел Конфигурации VLAN Контроллера беспроводной локальной сети этого документа, который включает шаги проверки.

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Процедура устранения неполадок

Завершите эти инструкции для устранения проблем конфигурации.

  1. Выполните ping-тестирование от контроллера WLAN к шлюзу по умолчанию, на котором настроен маршрутизируемый интерфейс VLAN. Затем выполните ping-тестирование в обратном направлении.

    • Контроллер WAN:

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • Маршрутизируемый интерфейс VLAN:

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = �/4 ms
      lab1sup720ip1#
  2. В случае неудачного тестирования на коммутаторе необходимо установить уловитель/анализатор пакетов для того, чтобы проверить правильность тегирования VLAN.

    Примечание: Когда вы инициируете эхо-запрос от своего контроллера до шлюза Уровня 3, который находится в той же подсети как ваш динамический интерфейс, контроллер, кажется, получает эхо-запрос от динамического интерфейса.


Дополнительные сведения


Document ID: 68100