Совместная работа : Cisco ICM Logger

Средство ведения журнала постоянно добавляет утверждения, поскольку таблица Config_Message_Log пуста

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот документ описывает одну причину для повторяющегося утверждения процесса ведения журнала на Logger и предоставляет решение в Среде предприятия Intelligent Contact Management (ICM) или Контактного центра ip (IPCC).

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Cisco ICM

  • Microsoft SQL Server

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco ICM Version 4.5.x и позже

  • Microsoft SQL Server 6.5 и 7.0

  • Сервер Microsoft SQL 2000 года

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Только центральная база данных содержит таблицу Config_Message_Log. Таблица Config_Message_Log хранит сообщения настройки. Таблица содержит эти пять полей:

  1. RecoveryKey: Программное обеспечение ICM использует значение поля RecoveryKey внутренне для отслеживания действительного времени.

  2. LogOperation: поле LogOperation указывает на тип изменения конфигурации. Например, "Добавьте" или "Обновление".

  3. TableName: поле TableName указывает на название таблицы, на которую влияет изменение конфигурации.

  4. DateTime: Когда Logger регистрирует ряд сообщений, поле DateTime отображает дату и времю.

  5. ConfigMessage: поле ConfigMessage содержит все сообщения настройки в транзакции.

Проблема

Lgr или процесс ведения журнала на Logger постоянно утверждают. Другими словами, процесс ведения журнала запускает, отказывает и неоднократно перезапускает.

Соответствующий журнал содержит это сообщение об ошибках:

la-lgr Fail: Assertion failed: syncMsg.UpdateKey == g.checksumInfo.updateKey.
  File: y:\icm\logger\logger\rtinput.cpp.  Line 691

Для просмотра lgr или процесса ведения журнала на Logger, можно просмотреть соответствующее окно процесса. Также используйте Служебную программу Dumplog для просмотра соответствующего журнала процесса.

Причина

Пустая таблица Config_Message_Log является основной причиной проблемы. Чтобы проверить, пуста ли таблица Config_Message_Log, выполните эту команду SQL:

select * from Config_Message_Log

Таблица Config_Message_Log, вероятно, не содержит строк, потому что вы устанавливаете флажок Truncate Config Message Log при выполнении Администрирования базы данных Intelligent Contact Management (icmdba) для экспорта данных о конфигурации.

Решение

Для решения этой проблемы можно выполнить эту команду SQL:

insert into Config_Message_Log values (0, 'LogBegin', 'Config_Message_Log',
 getdate(),0x0000)

Эта команда SQL добавляет строку к таблице Config_Message_Log.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения