Протокол IP : Протоколы IP-маршрутизации

Пример конфигурации маршрутизации на основе политик с функцией отслеживания по нескольким параметрам

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (29 июля 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример настройки для маршрутизации на основе политики с помощью функции Multiple Tracking Options. Эта функция была представлена в Cisco Выпуск ПО IOS� 12.3 (4) T. Дополнительные сведения см. в разделе "Поддержка PBR для нескольких параметров отслеживания".

Данная функция расширяет возможности слежения за целью, проверяя IP-адрес следующего узла до переадресации на него трафика. Метод верификации может быть эхо-тестом по протоколам ICMP или UDP либо запросом GET по протоколу HTTP. Протокол ICMP – это наиболее общий метод верификации, используемый в Интернете. Возможность группового отслеживания наиболее подходит для маршрутизаторов, имеющих множественные Ethernet подключения при следующем переходе. Обычно интерфейсы Ethernet подключаются к цифровой абонентской линии (DSL) или кабельным модемам. В настоящее время не существует метода для обнаружения ошибок восходящего потока в широкополосной сети поставщика Интернет-услуг (ISP). Интерфейс Ethernet остается в рабочем состоянии, а любая форма статической маршрутизации указывает на него. Преимущество этой функции заключается в том, что она позволяет резервировать два интерфейса Ethernet, выбирать тот интерфейс, который является доступным, отправляя запросы "ICMP-эхо" для проверки достижимости, и затем направлять на него трафик.

Предварительные условия

Требования

Прежде чем приступить к данной конфигурации, необходимо убедиться в выполнении следующего требования:

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Настройка

В этом разделе представлены сведения по настройке функций, описанных в данном документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети. В этом сценарии маршрутизатор R1 подключен к двум различным ISP (ISP-1 и ISP-2). R1 отслеживает доступность обоих маршрутизаторов ISP.

/image/gif/paws/48003/pbrtracking_01.gif

!--- конфигурацию

В данном документе используется следующая конфигурация:

_________________________ М1
R1# show running-config 
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability

!--- Track Router 1's reachability.

!         
track 124 rtr 2 reachability

!--- Track Router 2's reachability.

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha

!--- Enable policy routing on the outgoing interface.

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10

!--- Define a route-map to set the next hop depending on 
!--- the state of the tracked routers.

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1

!--- Define and start Router 1.

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2

!--- Define and start Router 2.


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show track – выводит данные отслеживания.

  • show track brief – выводит ограниченные данные отслеживания.

R1# show track           
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

Из выходных данных команды show track brief видно, что оба ISP являются достижимыми. Если отключить интерфейс, который подключен к ISP-1, при отслеживании он будет показан как отключенный.

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1# 

Примечание: PBR требует отслеживания, чтобы определить, активны ли интерфейс или маршрут. Для просмотра статуса отслеживания маршрута можно также использовать команду show route-map.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 48003