Голосовая связь и система унифицированных коммуникаций : Cisco Unified Communications Manager (CallManager)

Выбор конфигурации шлюза Cisco IOS MGCP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Данный документ содержит следующие сведения:

  • Указания по выполнению простой конфигурации протокола управления шлюзами между средами передачи (MGCP)

  • Минимальное количество команд, необходимых для создания конфигурации, работающей для маршрутизатора с двумя портами телефонной станции с международным коммутатором (FXO) и с двумя портами телефонной станции с междугородним коммутатором (FXS)

Примечание: Инструкции в этом документе работают для Голосового шлюза Cisco 200 (VG200) и Cisco 2600 и маршрутизаторы серии "3600", которые выполняют Cisco Выпуск ПО IOS� 12.1 (5) T и позже. См. документацию о ПО Cisco IOS, чтобы получить сведения о поддерживаемых выпусках ПО других шлюзов Cisco IOS MGCP.

Признаки:

Возможно появление следующих признаков при настройке Cisco CallManager со шлюзами Cisco IOS MGCP с аналоговыми портами FXO и FXS:

Данный документ является частью 2, входящей в комплект из следующих шести документов:

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Шлюз Cisco IOS, на котором установлен выпуск ПО Cisco IOS, поддерживающий MGCP с Cisco CallManager

  • Cisco VG200

Примечание: Существуют другие Cisco IOS Software Release Train, которые поддерживают MGCP на маршрутизаторах Cisco. Одним из примеров является выпуск ПО Cisco IOS 12.1XM.

caution  Внимание! Синтаксис некоторых команд MGCP отличается в других выпусках ПО Cisco IOS. Чтобы определить требуемый синтаксис, см. документацию по данной конфигурации.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • 1 * порт Cisco VG200 / 2 X FXS / 2 X FXO / 1 Fast Ethernet 10/100; выпуск ПО Cisco IOS 12.1(5)T

  • 1 * Cisco CallManager 3.0(5a), который работает на MCS7835

  • 2 * Аналоговые гарнитуры

  • 2 * IP-телефоны Cisco 7960

Обратитесь к Cisco Унифицированный CME и Матрицу совместимости версии программного обеспечения Cisco IOS для рекомендуемых выпусков ПО совместимости между Сisco CallManager и шлюзом Cisco IOS.

Примечание: Cisco IOS Software Release 12.2 (11) T и позднее рекомендуется на основе усовершенствований команды ccm-manager. Команда ccm-manager требует выпуска ПО Cisco IOS 12.1(5)XM и позднее на всех маршрутизаторах (2600 и 3600), а также на VG200.

Маршрутизаторы Cisco 2600 и 3600 поддерживают MGCP, если на них установлен выпуск ПО Cisco IOS 12.1(3)T и позднее. Выбор требуемых выпусков ПО зависит от функций, которые необходимо подключить. На сервере Cisco CallManager должен быть установлен выпуск ПО 3.0(5)a или позднее. Конфигурация маршрутизатора одинакова для всех типов маршрутизаторов. Конфигурация Cisco CallManager также одинакова для всех типов маршрутизаторов.

Выпуск ПО Cisco IOS 12.1(5)XM1 и позднее поддерживает VG200. Выбор требуемых выпусков ПО зависит от функций, которые необходимо подключить. Используйте выпуск ПО 3.0(5)a и позднее, даже если VG200 поддерживается на ранних выпусках ПО Cisco CallManager.

Примечание: Существуют другие Cisco IOS Software Release Train, которые поддерживают MGCP на маршрутизаторах Cisco. Одним из примеров является выпуск ПО Cisco IOS 12.1XM.

caution  Внимание! Синтаксис некоторых команд MGCP отличается в других выпусках ПО Cisco IOS. Чтобы определить требуемый синтаксис, см. документацию по данной конфигурации.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Задачи для выполнения

Выполните следующие действия:

  1. Настройте IP-адрес на интерфейсе шлюза Cisco IOS Ethernet.

  2. Присвойте уникальное имя шлюзу Cisco IOS.

  3. Настройте шлюз Cisco IOS, чтобы обеспечить работу MGCP в качестве протокола сигнализации.

  4. Настройте IP-адрес или имя системы доменных имен (DNS) для сервера Cisco CallManager.

  5. Выберите тип codec и функцию передачи DTMF (двухтональная многочастотная сигнализация).

  6. Сообщите шлюзу Cisco IOS, что он связывается с сервером Cisco CallManager.

  7. Установите связь приложения MGCP с голосовыми портами.

  8. Включите голосовые порты.

  9. Установите IP-подключение.

Пошаговый

Примечание: Оставшаяся часть этого документа обращается к VG200. VG200 запускается с конфигурацией по умолчанию, с которой поставляется данное устройство.

Выполните следующие действия:

  1. Настройте IP-адрес на интерфейсе VG200 Ethernet и включите интерфейс.

    router(config)#interface fastethernet 0/0
    router(config-if)#ip address 172.16.1.206 255.255.255.0
    router(config-if)#no shut
    
  2. Присвойте уникальное имя VG200. Это позволяет серверу Cisco CallManager идентифицировать данное устройство.

    router(config)#hostname VG200A 
    
    /* This is how CallManager keeps track of the MGCP network */
    /* devices it is communicating with. This name must be     */
    /* unique.                                                 */
  3. Настройте VG200, чтобы обеспечить работу MGCP в качестве протокола сигнализации.

    VG200A(config)#mgcp
    
  4. Настройте IP-адрес или DNS-имя для сервера Cisco CallManager.

    VG200A(config)#mgcp call-agent 172.16.1.252
    
    VG200A(config)#ccm-manager config server 172.16.1.252
    
    VG200A(config)#ccm-manager config
    

    Команда mgcp call-agent используется для настройки адреса и протокола агента вызовов для конечных точек MGCP на шлюзе между средами передачи. Эту команду можно использовать для указания версии используемого протокола. Чтобы получить дополнительные сведения, см. раздел агент вызовов mgcp call.

    Команда ccm-manager config server используется для указания сервера TFTP, с которого шлюз протокола управления между средами передачи (MGCP) загружает файлы конфигурации Cisco CallManager XML.

    Команда ccm-manager config требуется для загрузки файлов конфигурации Cisco CallManager XML.

    Примечание: Выполните эти команды для настройки избыточных Сisco CallManager в Кластере Cisco CallManager:

    VG200(config)#ccm-manager redundant-host [ip-address |
      dns-name] [ip-address | dns-name] 
    VG200(config)#ccm-manager switchback {graceful | immediate
      |schedule-time hh:mm | uptime-delay minutes} 
  5. Выберите тип codec и функцию передачи DTMF.

    VG200A(config)#mgcp dtmf-relay codec all mode out-of-band
    
  6. Задайте следующую команду, чтобы обеспечить поддержку Cisco CallManager в шлюзе MGCP:

    VG200A(config)#ccm-manager mgcp
    
  7. Установите связь приложения MGCP с голосовыми портами.

    Примечание: Выполните команду show voice port для определения типа портов, которые имеет VG200 и в котором заказе они установлены.

    VG200A(config)#dial-peer voice 1 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/0
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 2 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/1
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 3 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/0
    
    /* FXS port */
    
    VG200A(config)#dial-peer voice 4 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/1
    
    /* FXS port */

    Примечание: Команда application MGCPAPP учитывает регистр в некоторых Cisco IOS Software Release. Всегда задавайте данную команду в верхнем регистре, если только не известно, что данное ПО не является чувствительным к регистру. Изучите выходные данные команды show running-config, чтобы проверить, является ли данное ПО чувствительным к регистру. Выпуск ПО Cisco IOS 12.1(5)T не является чувствительным к регистру.

  8. Убедитесь, что голосовые порты включены.

    Примечание: Завершение и команды no shutdown влияют на оба порта на голосовой интерфейсной карте (VIC). Задайте команду только на одном из данных портов.

    VG200A(config)#voice-port 1/0/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXO port */
    
    VG200A(config)#voice-port 1/1/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXS port */s
  9. Установите IP-подключение.

    Включите IP-маршрутизацию, если некоторые из устройств VoIP, с которыми связывается VG200, расположены в разных подсетях или в сетях VLAN. Также необходимо создать сеть по умолчанию или шлюз последней очереди. На примере следующего действия показан способ выполнения обеих задач:

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway
    
    

    Примечание: VG200 не является маршрутизатором IP. На данном устройстве невозможно запустить такие протоколы IP-маршрутизации, как протокол передачи сведений о маршрутизации (RIP), внутренний протокол маршрутизации шлюзов (IGRP), или протокол предпочтения кратчайшего пути (OSPF). Устройство работает аналогично конечной станции (клиенту), если речь идет о IP-соединении.

    Примечание: Можно настроить протокол маршрутизации вместо статических маршрутов на других шлюзах Cisco IOS, которые являются по существу маршрутизаторами с голосовыми интерфейсами. Важно обеспечить IP-подключение между устройствами VoIP.

    Примечание: Команда ip routing не появляется в конфигурации, потому что это обычно находится на по умолчанию при включении IP routing. Команды по умолчанию, как правило, не отображаются в конфигурации маршрутизатора Cisco. Образы VG200 Cisco IOS заменяют это поведение по умолчанию путем аппаратного программирования команды no ip routing в первоначальной конфигурации. Следующая конфигурация создается, когда образ загружен:

    • На платформе, где команда write erase очистила конфигурацию

    • На устройстве VG200, которое не было настроено

    Команда ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway побуждает VG200 установить шлюз последней очереди в таблице маршрутизации. Команда show ip route подтверждает это. В данном примере IP-адрес шлюза является 172.16.1.1:

    VG200A#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 172.16.1.1 to network 0.0.0.0
    
    C    172.16.0.0/16 is directly connected, FastEthernet0/0
    S*   0.0.0.0/0 [1/0] via 172.16.1.1
    VG200A#

    Примечание: Команда ip classless также требуется для этого шлюза последней очереди быть эффективной. Команда ip classless включена по умолчанию. Эта команда входит в число немногих команд по умолчанию ПО Cisco IOS, которые отображаются в конфигурации при включении, а также отображаются в форме no при отключении. Задайте команду ip classless, чтобы включить ip classless, если конфигурация включает в себя строку no ip classless.

caution  Внимание! Cisco CallManager контролирует все элементы конфигурации, относящиеся к плану нумерации. Не настраивайте данные элементы в шлюзе MGCP для конечных точек под управлением MGCP (конечных точек, установленных командой mgcpapp в определении адресуемой точки вызова). Не настраивайте следующие функции:

  • Для адресуемых точек вызова

    • шаблон назначения

    • адресат сеанса

  • Для голосовых портов

    • connection { plar | tie-line | trunk }

Сводка

Теперь устройство VG200 готово для связи с сервером Cisco CallManager. VG200 периодически отправляет сообщения в попытке установить соединение. Соединение автоматически устанавливается по завершении настройки сервера Cisco CallManager. Дополнительных изменений в VG200 не требуется.

Примечание: Перезагрузите порты шлюза после завершения конфигурации, как показано в примере:

router(config)#voice-port 1/0/0
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

Конфигурации

В данной таблице содержится полная конфигурация VG200A для данного документа:

Конфигурация VG200A
VG200A#show running-config           
Building configuration...

Current configuration : 1244 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname VG200A
!
boot system flash
boot system rom
boot system tftp vg200 172.16.1.253
no logging buffered
logging rate-limit console 10 except errors
no logging console
enable secret #####
enable password #####
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
mgcp
mgcp call-agent 172.16.1.252
mgcp dtmf-relay codec all mode out-of-band
mgcp sdp simple
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
!
!
interface FastEthernet0/0
 ip address 172.16.1.206 255.255.0.0
 no ip mroute-cache
 speed auto
 full-duplex
!
ip default-gateway 172.16.1.1
ip classless
no ip http server
!
snmp-server engineID local 000000090200000196983000
snmp-server community public RO
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0/0
!
dial-peer voice 2 pots
 application mgcpapp
 port 1/0/1
!
dial-peer voice 3 pots
 application mgcpapp
 port 1/1/0
!
dial-peer voice 4 pots
 application mgcpapp
 port 1/1/1
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

VG200A#

Сведения о версии VG200A
VG200A>show version
Cisco Internetwork Operating System Software
IOS (tm) VG200 Software (VG200-I6S-M), Version 12.1(5)T,  
RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by Cisco Systems, Inc.
Compiled Sat 11-Nov-00 10:33 by ccai
Image text-base: 0x80008088, data-base: 0x807D4784

ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE 
SOFTWARE (fc1)

VG200A uptime is 19 hours, 37 minutes
System returned to ROM by reload
System image file is "flash:vg200"

cisco VG200 (MPC860) processor (revision 0x102) with 28672K/
4096K bytes of memory
y.
Processor board ID JAB0414058X (0)
M860 processor: part number 0, mask 49
1 FastEthernet/IEEE 802.3 interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

VG200A>

Устранение неполадок шлюза IOS MGCP

В шлюзе IOS MGCP может произойти сбой одностороннего вызова (отдельно для исходящего или входящего вызова). Чтобы решить данную проблему, перенастройте шлюз MGCP. Обычно это включает изменение конфигурации интерфейсов PRI и/или интерфейсов FXO. Затем перезапуск протокола протокола MGCP на шлюзе, не давая команду IOS протокола MGCP и команду mgcp в режиме глобальной конфигурации.

Не может выполнить вызовы от аналогового телефона, связанного с IOS-шлюзом MGCP. Сигнал занято получен.

Выполните эту процедуру для решения этой проблемы:

  1. Удостоверьтесь, что команда application mgcpapp настроена на применимом порту.

  2. Переупорядочьте точки вызова PlainOld Telephone Service (POTS) (обычная телефонная сеть) для распечатки генерируемых Сisco CallManager точек вызова сначала в списке точки вызова. Гарантируйте, что входящее и исходящее управление вызовами обрабатывается корректной точкой вызова под контролем за MGCP.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения