Коммутация LAN : Маршрутизация между виртуальными локальными сетями (IVR)

Настройка маршрутизации между сетями VLAN с использованием коммутаторов Catalyst 3750/3560/3550 Series

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (6 октября 2015) | Отзыв


Содержание


Введение

В данном документе описана настройка маршрутизации InterVLAN с коммутаторами Cisco Catalyst серии 3750/3560/3550. Данный документ содержит пример конфигурации для маршрутизации interVLAN с использованием коммутаторов Catalyst серии 3550 под управлением ПО EMI (расширенный многослойный образ) в обычном сетевом сценарии. В данном документе в качестве коммутирующих центров уровня 2 (L2), подключенных к Catalyst 3550, используется коммутатор Catalyst серии 2950 и коммутатор Catalyst 2948G. Конфигурация Catalyst 3550 также имеет маршрут по умолчанию для всего трафика, передаваемого в Интернет, когда следующий переход указывает на маршрутизатор Cisco 7200VXR. Маршрутизатор Cisco 7200VXR можно заменить межсетевым экраном или другими маршрутизаторами.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Catalyst 3550-48, который выполняет Cisco Выпуск ПО IOS� 12.1 (12c) EMI EA1

  • Catalyst 2950G-48, который выполняет программное обеспечение Cisco IOS версии 12.1 (12c) EA1 EI

  • Catalyst 2948G, который выполняет версию 6.3 (10) операционной системы Catalyst (CatOS)

Примечание: Конфигурация от Cisco 7200VXR не релевантна, таким образом, этот документ не показывает конфигурацию.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Эта конфигурация может также использоваться со следующими версиями программного/аппаратного обеспечения:

  • Любой Catalyst 3750/3560/3550 коммутатор, который выполняет программное обеспечение EMI или программное обеспечение Cisco IOS версии 12.1(11)EA1 стандартного многослойного образа (SMI) и позже

  • Любой Catalyst 2900XL/3500XL/2950/3550 или модель Коммутатора CatOS, используемая в качестве уровня доступа коммутатора

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Теоретические сведения

В коммутируемой сети все VLAN делят устройства на различные коллизионные домены и подсети третьего уровня модели OSI (L3). Для взаимодействия одного устройства с другим внутри VLAN маршрутизация не требуется. А вот для связи устройств в разных виртуальных локальных сетях требуется устройство маршрутизации.

Коммутаторы только L2 требуют устройство маршрутизации L3. Устройство является внешним по отношению к коммутатору или находится в другом модуле этого шасси. В коммутаторах нового поколения реализована возможность маршрутизации. Например модель 3550. Коммутатор получает пакет, определяет, что он принадлежит другой сети VLAN, и отправляет этот пакет соответствующему порту другой VLAN.

В типичном проекте сеть сегментируется на основе групп или функций, с которыми связано устройство. Например, в техническую сеть VLAN будут входить только те устройства, которые связаны с техническим отделом, в то время как в финансовую сеть VLAN будут входить только устройства, имеющие отношение к финансовому отделу. Если включена маршрутизация, устройства в каждой VLAN могут взаимодействовать одно с другим, даже если они находятся в разных доменах широковещательной рассылки. Такая модель VLAN имеет также дополнительное преимущество. Такая модель позволяет администратору ограничивать взаимодействие между сетями при помощи списков доступа. В примере, приведенном в данном документе, списки доступа можно использовать для ограничения доступа устройств из технической сети VLAN к устройствам VLAN финансового отдела.

Коммутатор не направляет пакеты не-IP между VLAN и маршрутизируемыми портами. Можно передать эти пакеты не-IP с мостовым соединением нейтрализации. Для использования этой функции у вас должен быть Образ IP-служб, раньше известный как расширенный многоуровневый образ (EMI), установленный на вашем коммутаторе.

Вот ссылка на видео (доступный на Сообществе Cisco Support leavingcisco.com), который демонстрирует, как настроить Маршрутизацию между виртуальными локальными сетями (IVR) на Коммутаторе серии Catalyst 3550:

Как настроить маршрутизацию InterVLAN на коммутаторах уровня 3 leavingcisco.com

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

189-a.gif

На этой схеме небольшая сеть с Catalyst 3550 обеспечивает маршрутизацию InterVLAN между различными сегментами. По умолчанию коммутатор Catalyst 3550 функционирует как устройство L2 с отключенной IP маршрутизацией. Чтобы этот коммутатор функционировал как устройство L3 и обеспечивал маршрутизацию interVLAN, необходимо глобально включить IP-маршрутизацию.

Пользователем определены следующие три сети VLAN:

  • VLAN 2 - пользователь VLAN

  • VLAN 3 - сервер VLAN

  • VLAN 10 - управление виртуальной локальной сетью

Конфигурацией шлюза по умолчанию на каждом сервере и основном устройстве должен быть IP-адрес интерфейса виртуальной локальной сети (VLAN), который соответствует на 3550. Например, для серверов шлюз по умолчанию - 10.1.3.1. Коммутаторы уровня доступа, которыми являются Catalyst 2950 и 2948G, соединены двумя магистралями с коммутатором Catalyst 3550.

Маршрут по умолчанию для Catalyst 3550 указывает на маршрутизатор Cisco 7200VXR. Catalyst 3550 использует этот маршрут по умолчанию для передачи трафика, назначенного для Internet. Поэтому трафик, для которого коммутатор 3550 не имеет записи в таблице маршрутизации, направляется маршрутизатору 7200VXR для обработки.

Практические советы

Конфигурации

Эти конфигурации используются в данном документе:

Catalyst 3550 (Catalyst 3550-48 коммутаторов)
Cat3550#show running-config 
Building configuration...

Current configuration : 3092 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
!
ip subnet-zero

!--- Enable IP routing for interVLAN routing.

ip routing
!!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

!
interface FastEthernet0/5
 description to SERVER_1

!--- Configure the server port to be in the server VLAN, VLAN 3.

switchport access vlan 3

!--- Configure the port to be an access port to prevent trunk negotiation delays.

 switchport mode access
 no ip address

!--- Configure PortFast for initial Spanning Tree Protocol (STP) delay. Refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information.

spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/48
 description To Internet_Router

!--- The port that connects to the router converts into a routed (L3) port.

no switchport

!--- Configure the IP address on this port. 

ip address 200.1.1.1 255.255.255.252
!
interface GigabitEthernet0/1
 description To 2950

!--- Configure IEEE 802.1 (dot1q) trunking, with negotiation, on the L2 switch.
!--- If there is not support for Dynamic Trunking Protocol (DTP) on the far switch, 
!--- issue the switchport mode trunk command to force the switch port to trunk mode.
!--- Note: The default trunking mode is dynamic auto. If you establish a trunk link 
!--- with the default trunking mode, the trunk does not appear
!--- in the configuration, even though a trunk has been established on 
!--- the interface. Use the show interfaces trunk command to verify the 
!--- establishment of the trunk. 

switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 description To 2948G
 switchport trunk encapsulation dot1q
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description USER_VLAN

!--- This IP address is the default gateway for users.

 ip address 10.1.2.1 255.255.255.0
!
interface Vlan3
 description SERVER_VLAN

!--- This IP address is the default gateway for servers.

ip address 10.1.3.1 255.255.255.0
!
interface Vlan10
 description MANAGEMENT_VLAN

!--- This IP address is the default gateway for other L2 switches.

 ip address 10.1.10.1 255.255.255.0
!
ip classless

!--- This route statement allows the 3550 to send Internet traffic to 
!--- the default router which, in this case, is the 7200VXR (Fe 0/0 interface).

ip route 0.0.0.0 0.0.0.0 200.1.1.2
ip http server
!
!
!
line con 0
line vty 5 15
!
end

Примечание: Начиная с этих 3550 имеет конфигурацию как сервер Транкингового протокола VLAN (VTP), коммутатор не отображает конфигурацию VTP. Это стандартное поведение. Чтобы создать VTP-сервер с тремя виртуальными локальными сетями, определенными пользователем из режима глобальной настройки, на этом коммутаторе используются следующие команды:

Cat3550(config)#vtp domain cisco
Cat3550(config)#vtp mode server
Cat3550(config)#vlan 2
Cat3550(config-vlan)#name USER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 3
Cat3550(config-vlan)#name SERVER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 10
Cat3550(config-vlan)#name MANAGEMENT
Catalyst 2950 (Catalyst 2950G-48 коммутатор)
Cat2950#show running-config 
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/33
 description HOST_1

!--- Configure HOST_1 to be the user VLAN, VLAN 2.

 
 switchport access vlan 2
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT

!--- This IP address manages this switch. 

ip address 10.1.10.2 255.255.255.0
 no ip route-cache
!

!--- Configure the default gateway so that the switch is reachable from other
!--- VLANs/subnets. The gateway points to the VLAN 10 interface on the 3550.

ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Примечание: Так как Catalyst 2950 имеет конфигурацию как клиент VTP, коммутатор не отображает конфигурацию VTP. Это стандартное поведение. Коммутатор 2950 получает информацию VLAN от VTP-сервера, которым является коммутатор 3550. Следующие команды используются на коммутаторе 2950, чтобы сделать его VTP-клиентом в VTP-домене cisco из режима глобальной настройки:

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client
Коммутатор Catalyst 2948g
Cat2948G> (enable) show config 
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47 
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name  Cat2948G
!       
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- Configure the VTP domain to be the same as the 3550, the VTP server.

set vtp domain cisco

!--- Choose the VTP mode as client for this switch.

set vtp mode client
!
#ip

!--- Configure the management IP address in VLAN 10.

set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down

!--- Define the default route so that the switch is reachable.

set ip route 0.0.0.0/0.0.0.0         10.1.10.1      
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet

!--- Configure HOST_2 and SERVER_3 ports in respective VLANs.

set vlan 2    2/2
set vlan 3    2/23
set port name       2/2  To HOST_2
set port name       2/23 to SERVER_3

!--- Configure trunk to 3550 with dot1q encapsulation.

set trunk 2/49 desirable dot1q 1-1005
end

Проверка

В данном разделе содержатся сведения о проверке работы конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Catalyst 3550

  • show vtp status

    Cat3550#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs        : 8
    VTP Operating Mode              : Server
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
  • show interfaces trunk

    Cat3550#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    Gi0/2     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    Gi0/2     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
  • show ip route

    Cat3550#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 200.1.1.2 to network 0.0.0.0
    
         200.1.1.0/30 is subnetted, 1 subnets
    C       200.1.1.0 is directly connected, FastEthernet0/48
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.1.10.0 is directly connected, Vlan10
    C       10.1.3.0 is directly connected, Vlan3
    C       10.1.2.0 is directly connected, Vlan2
    S*   0.0.0.0/0 [1/0] via 200.1.1.2
    

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs        : 8
    VTP Operating Mode              : Client
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    
  • show interfaces trunk

    Cat2950#show interfaces trunk  
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    Gi0/1     1-3,10
    

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain 
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           client      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8          1023             3               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1       disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk 
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/49     desirable    dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     2/49     1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Процедура устранения неполадок

Выполните следующие действия:

  1. Если нельзя провести эхо-тестирование между двумя устройствами в одной и той же сети VLAN, проверьте распределение портов источника и назначения, чтобы убедиться, что они находятся в одной сети VLAN.

    Чтобы проверить назначение VLAN, выполните команду show port mod/port для CatOS или команду show interface status для ПО Cisco IOS.

    Если порты источника и назначения находятся на разных коммутаторах, убедитесь, что магистральная линия правильно настроена. Чтобы проверить конфигурацию, выполните команду show trunk для CatOS или команду show interfaces trunk для ПО Cisco IOS. Кроме того, проверьте сопоставления собственной VLAN на каждой стороне. Убедитесь, что маски подсети исходного и конечного устройств совпадают.

  2. Если не удается выполнить эхо-тестирование устройств в разных сетях VLAN, убедитесь, что запрос доходит до соответствующего шлюза по умолчанию.

    Примечание: Посмотрите шаг 1.

    Кроме того, следует убедиться, что шлюз по умолчанию ссылается на правильный IP-адрес интерфейса VLAN. И что маски подсети совпадают.

  3. Если не удается подключиться к Интернету, убедитесь, что маршрут по умолчанию на коммутаторе 3550 указывает на правильный IP-адрес, а адрес подсети совпадает с межсетевым Интернет маршрутизатором.

    Чтобы проверить выполните команду show ip interface interface-id и команду show ip route. Убедитесь, что маршрутизатор с функциями Интернет-шлюза имеет маршруты для выхода в Интернет и во внутренние сети.


Дополнительные сведения


Document ID: 41260