Cервисы организации сетевого доступа к приложениям : Cisco LocalDirector серии 400

Устранение неполадок, связанных с распределением нагрузки контента в LocalDirector 4.1.1

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Cisco объявила о конце продажи для Cisco LocalDirector. "Для получения дополнительной информации см. касающиеся LocalDirector 400 Series ""Уведомления об окончании срока эксплуатации и продаж"" и ""Информационные бюллетени по продуктам (End-of-Life and End-of-Sale Notices and Product Bulletins).".


Содержание


Введение

Этот документ предоставляет пример конфигурации и дополнительные команды для устранения проблем функции распределения нагрузки для содержимого, доступной в Cisco LocalDirector 416 (Версия 4.1.1).

Примечание: Несколько проблем с Распределением нагрузки Содержания были исправлены в новых версиях кода для LocalDirector. Строго рекомендуется использовать версию 4.2.4 или выше. См. Страницу загрузки программного обеспечения (только зарегистрированные клиенты) для получения дополнительной информации.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

При разработке и тестировании этой конфигурации использовались следующие версии программного и аппаратного обеспечения:

  • LocalDirector 416 (Version 4.1.1) с клиентами под управлением Windows 2000 Server, Windows NT 4.0 Service Pack 4.0 и Windows 98

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Схема сети

/image/gif/paws/28847/load_balancing.jpg

!--- конфигурацию

Запрос пользователя страниц /index.htm направляются на сервер 172.18.124.205 или 172.18.124.207. Отправляет запросы с /rtp/local-director на сервер 172.18.124.101. Все остальные запросы отправляются на 172.18.124.206.

LocalDirector 416 (Версия 4.1.1.).)
Current configuration:
 syslog output 20.3
 no syslog console
 enable password 000000000000000000000000000000 encrypted
 hostname 38-ld416
 no shutdown ethernet 0
 no shutdown ethernet 1
 no shutdown ethernet 2
 interface ethernet 0 auto
 interface ethernet 1 auto
 interface ethernet 2 auto
 mtu 0 1500
 mtu 1 1500
 mtu 2 1500
 multiring all
 no secure  0
 no secure  1
 no secure  2
 ping-allow 0
 ping-allow 1
 no ping-allow 2
 ip address 172.18.124.209 255.255.255.0
 route 0.0.0.0 0.0.0.0 172.18.124.1 1
 arp timeout 30
 no rip passive
 rip version 1
 failover ip address 0.0.0.0
 no failover
 failover hellotime 30
 password cisco
 snmp-server enable traps
 snmp-server community public
 no snmp-server contact
 no snmp-server location
 no dns-boomerang enable
 content-rule nsteam depth 1024 "/index*.htm*"
 content-rule jahrule depth 1024 "/rtp/local-director/*"
 virtual 172.18.124.219:80:0:tcp:jahrule is
 virtual 172.18.124.219:80:0:tcp is
 virtual 172.18.124.219:80:0:tcp:nsteam is
 service 172.18.124.219:80:0:tcp clb-close
 real 172.18.124.205:80:0:tcp is
 real 172.18.124.101:80:0:tcp is
 real 172.18.124.206:80:0:tcp is
 real 172.18.124.207:80:0:tcp is
 bind 172.18.124.219:80:0:tcp:jahrule 172.18.124.101:80:0:tcp
 bind 172.18.124.219:80:0:tcp 172.18.124.206:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.205:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.207:80:0:tcp
end

Пример выходных данных команды show

show real

Проверьте состояние сервера REAL.

LocalDirector# show real
  Real Machines:  
                                                       No Answer  TCP Reset   DataIn   Machine

                            Connect  State Thresh   Reassigns  Reassigns   Conns  
 172.18.124.205:80:0:tcp       0      IS      8         0          0         0
 172.18.124.101:80:0:tcp       0      IS      8         0          0         0
 172.18.124.206:80:0:tcp       0      IS      8         0          0         0
 172.18.124.207:80:0:tcp       0      IS      8         0          0         0

show server

Проверьте конфигурацию сервиса.

LocalDirector# show service
  Virtual Machine(s)              Service
 172.18.124.219:80:0:tcp         clb-close

show rule

Просмотр правил.

LocalDirector# show rule
  Name            Depth           Content-String
  nsteam          1024            "/index*.htm*"
  jahrule         1024            "/rtp/local-director/*"

Просмотр определенного правила.

LocalDirector# show rule jahrule

  Name            Depth           Content-String
  jahrule         1024            "/rtp/local-director/*"

show bind

Проверить связывания.

LocalDirector# show bind

 Virtual Machine(s)                      Real Machines/Urls
 172.18.124.219:80:0:tcp:jahrule(IS)
 172.18.124.101:80:0:tcp (IS)
 172.18.124.219:80:0:tcp (IS)
 172.18.124.206:80:0:tcp (IS)
 172.18.124.219:80:0:tcp:nsteam(IS)
 172.18.124.205:80:0:tcp (IS)
 172.18.124.207:80:0:tcp (IS)

Правила редактирования

  1. Удалите связь при помощи команды no bind.

  2. Блокируйте виртуальные серверы при помощи правила и команды to no-inservice.

  3. Удаление виртуальных серверов с помощью команды no virtual.

  4. Измените правило, введя команду no rule.


Дополнительные сведения


Document ID: 28847