Голосовая связь : H.323

Объяснение Cisco IOS маршрутизации вызовов системы управления шлюзом

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Привратники Cisco используются для группирования шлюзов в логические зоны и маршрутизации вызовов между ними. Привратники ответственны за решения граничной маршрутизации между телефонной сетью общего пользования (PSTN) и сетью H.323. Привратники Cisco производят основную маршрутизацию вызовов между устройствами в сети H.323 и обеспечивают централизованное управление планом набора. Без привратников Cisco явные IP-адреса для каждого конечного шлюза нужно было бы настраивать на исходном шлюзе и сопоставлять их с одноранговым узлом Voice over IP (VoIP). При наличии привратника Cisco шлюз запрашивает его, когда пытается установить соединения VoIP с удаленными шлюзами VoIP.

Например, когда шлюз получает вызов, он в соответствии с планом набора определяет, куда следует этот вызов направить: на участок телефонии или на участок IP. Если вызов направляется на участок IP, шлюз запрашивает привратник Cisco о выборе лучшей конечной точки. Затем привратник Cisco определяет, является ли вызываемая конечная точка устройством в его логической зоне, или оно расположено в удаленной зоне, контролируемой удаленным привратником Cisco.

Предварительные условия

Требования

Cisco рекомендует изучить раздел Общие сведения о привратниках H.323.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Сообщения ARQ и LRQ

Запрос на доступ (ARQ) и Запрос местонахождения (LRQ) является двумя Регистрацией H.225, Разрешением, Статусом (RAS) сообщения, которые инициируют сторожевое устройство для инициирования процесса решения о маршрутизации вызова.

  • ARQ – сообщения локальной зоны, которые посылаются конечными точками H.323 (обычно шлюзами) на привратник Cisco. Привратники получают сообщения ARQ из конечной точки, если:

    • Конечная точка локальной зоны инициирует вызов. Или

    • Конечная точка локальной зоны запрашивает разрешения принять входящий вызов.

    Привратники отвечают на сообщения ARQ сообщениями Admission Confirm (ACF) или Admission Reject (ARJ). Если привратник Cisco настроен на прием вызова, он отвечает сообщением ACF (которое включает такие сведения, как IP-адрес шлюза назначения). Если нет, он отвечает сообщением ARJ.

  • LRQ – это сообщения, которыми обмениваются привратники. Они используются для межзоновых вызовов (вызовов между удаленными зонами). Например, привратник A получает ARQ от привратника локальной зоны, который запрашивает прием вызова для устройства из удаленной зоны. Сторожевое устройство тогда передает сообщение LRQ к сторожевому устройству B. Сторожевое устройство B ответы на сообщение LRQ или с Местоположением Подтверждает (LCF) или с Отказ в местонахождении (LRJ) сообщение, которое зависит от того, настроено ли это, чтобы допустить или отклонить запрос вызова внутри зоны и зарегистрирован ли запрошенный ресурс.

Дополнительные сведения см. в разделе Общие сведения о привратниках H.323: Поток вызова «привратник – шлюз».

Связанные сообщения H.225 RAS
ARQ Запрос на прием LRQ Запрос местонахождения
ACF Подтверждение приема LCF Подтверждение местонахождения
ARJ Отказ в приеме LRJ Отказ в местонахождении

Важные понятия конфигурации: Префиксы зоны и технологии

Чтобы понять процесс принятия решений о маршрутизации вызовов привратником Cisco, важно знать о зоновых и технологических префиксах. В целом (с некоторыми исключениями), префикс зоны определяет маршрутизацию в зону, а технологический префикс определяет шлюз в эту зону.

Префиксы зоны

Префикс зоны – это часть вызываемого номера, которая указывает зону, в которую уходит вызов. Префиксы зоны обычно используются для связи кода области с конфигурированной зоной.

Привратник Cisco определяет, уходит ли вызов в удаленную зону или обрабатывается локально. Например, согласно этому фрагменту конфигурации, привратник (GK) A направляет вызовы 214....... к GK-B. Вызовы с кодом области (512) обрабатываются локально.

gatekeeper
     zone local GK-A abc.com
     zone remote GK-B abc.com 172.22.2.3 1719
	
!--- The IP address configured above should be the RAS 
 !--- address of the remote gatekeeper.    
 !--- and should be reachable from the local gateway. 
 !--- In order to find out the RAS address on the remote gatekeeper,
 !--- issue the 
show gatekeeper zone status
 command 
 !--- on the remote gateway.
 
     zone prefix GK-B 214.......
     zone prefix GK-A 512.......

Технологические префиксы

Технологический префикс – это дополнительная возможность стандартного H.323, поддерживаемая шлюзами и привратниками Cisco, которая обеспечивает большую гибкость в маршрутизации вызовов в пределах сети H.323 VoIP. Привратник Cisco использует технологические префиксы для группирования конечных точек одного типа. Их можно использовать также для указания типа, класса или пула шлюзов.

Привратники Cisco используют технологические префиксы для маршрутизации вызовов, когда не находят зарегистрированных шлюзом адресов E.164, которые совпадают с вызываемым номером. Фактически, это - общий сценарий, потому что большинство шлюзов Cisco IOS только регистрирует свой ID H.323 (пока им не настроили порты Станции внешнего обмена (FXS)). Без зарегистрированных адресов E.164 привратник Cisco полагается при принятии решения о маршрутизации на два параметра:

  • Параметр Technology Prefix Matches нужен для использования привратником Cisco технологического префикса, присоединенного к вызываемому номеру, для выбора шлюза или зоны назначения.

  • Параметр Default Technology Prefixes нужен привратнику Cisco для назначения шлюзов по умолчанию для маршрутизации неразрешенных адресов вызова. Это назначение основывается на зарегистрированном технологическом префиксе шлюзов.

В данной таблице собраны доступные параметры конфигурации:

На шлюзе
VoIP Interface Эта команда регистрирует шлюз Cisco с определенным технологическим префиксом. Сведения регистрации префикса технологии отравляются на шлюз Cisco сообщением RAS Registration Request (RRQ). Пример:
GWY-B1(config)#interface ethernet 0/0
GWY-B1(config-if)#h323-gateway voip tech-prefix ?
     WORD: A technology prefix that the interface will register
     with the Gatekeeper.
VoIP Dial-peer Эта команда присоединяет технологический префикс спереди вызываемого номера, который сопоставляется одноранговым узлом. Он используется не для регистрации, а для установления соединения с привратником Cisco. Например, вызываемый номер 5551010 превращается в 1#5551010.
GWY-B1(config)#dial-peer voice 2 voip
GWY-B1(config-dial-peer)#tech-prefix ?
     WORD: A string.

Примечание: Модифицированный вызываемый номер также передается конечному шлюзу в настройке вызова. Убедитесь в том, что одноранговые узлы POTS конечного шлюза обновлены и смогут завершить вызов.

На привратнике
Gatekeeper Default Technology Prefix Эта команда устанавливает зарегистрированные шлюзы с указанным префиксом технологии как шлюзы по умолчанию для маршрутизации неразрешенных адресов вызовов. Например, если большинство шлюзов в зоне маршрутизируют один и тот же тип вызовов и они зарегистрированы префиксом технологии 1#, можно настроить привратник Cisco для использования 1# как префикса технологии по умолчанию. Таким образом, для исходных шлюзов исчезает необходимость присоединять 1# к номерам вызова. Вызываемые номера без действительного технологического префикса маршрутизируются на один из шлюзов, зарегистрированный с 1#.
GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# default-technology

Примечание: Если существует несколько шлюзов по умолчанию, можно влиять на приоритет использования шлюза с префиксом зоны <gk_id> <e.164_pattern> команда <0-10> gw-приоритета.

Gatekeeper Hop-Off Zone Конфигурации ухода используются для изменения выбора префикса зоны и принудительного направления вызова в определенную зону, вне зависимости от зонового префикса вызываемого номера. Например, при этой конфигурации все вызовы с технологическим префиксом 2# будут переправлены в зону GK-A.
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 2# hopoff GK-A
Gatekeeper Static Gateway Technology Prefix Registration Используется для статической регистрации технологического префикса для шлюза. Это дает на привратнике тот же результат, которого конфигурация VoIP-интерфейса шлюза добивается на шлюзе. Рекомендуется настраивать этот параметр на шлюзах, если их имеется много. В целом, легче настроить каждый шлюз отдельно с технологическим префиксом, чем настроить привратник со всеми технологическими префиксами для каждого шлюза.
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 1# gw ipaddr ?
     A.B.C.D  Gateway's call signaling IP address

Процесс решения и алгоритм маршрутизации вызова привратника

Эти схемы отображают процесс принятия решения маршрутизации вызова сторожевого устройства после получения ARQ и сообщений LRQ в Cisco IOS Software Release прежде 12.4:

gk-call-routing-1.gif

gk-call-routing-2.gif

Основанная на псевдониме маршрутизация вызова

Маршрутизация вызова сторожевого устройства изменилась в Cisco IOS Software Release 12.4 и позже. ID H.323 и почтовый ID базировались, соответствие выполнено прежде, чем обработать целевые номера E.164 (DNIS). Если какая-либо оконечная точка, как находят, зарегистрировала указанное H.323-ID/email-ID, то ACF передается. Эта схема объясняет новый основанный на псевдониме процесс маршрутизации вызова:

/image/gif/paws/24462/gk-call-routing-2a.gif

Речевая Инфраструктура и Приложение (VIA) функции являются улучшениями программного обеспечения к существующему образу Сторожевого устройства Cisco. С этим усовершенствованием Сторожевое устройство Cisco может распознать две ветви вызовов на той же платформе (шлюз IP-to-IP) и также распределить нагрузку трафик через множественные шлюзы IP-to-IP, которые включены (и шлюзы и сторожевые устройства) в предопределенной зоне VIA. Эти сторожевые устройства находятся в краю сети Internet Telephony Service Provider (ITSP) и походят на пункт передачи VoIP или транзитную зону, куда Трафик VoIP направлен через на пути к удаленному зональному назначению. Шлюзы IP-to-IP в зоне VIA завершают входящие вызовы и повторно инициируют их к их конечным назначениям. См. Удаленный к Локальной сети с Мультисервисной Характеристикой шлюза IP-to-IP Cisco для получения дополнительной информации о зоне VIA.

/image/gif/paws/24462/gk-call-routing-2b.gif

Примечание: Если указанная зона invia или outvia не найдена в конфигурациях (т.е. она не определена или как локальная или как удаленная зона), то сообщение ARJ передается.

Для выбора IP-IP GW, зарегистрированного к выбранному viazone, этот алгоритм используется:

  1. Если tech-prefix найден (в основанном на псевдониме соответствии), просмотрите список шлюзов в указанных viazone, которые зарегистрировали этот tech-prefix.

  2. Если никакой tech-prefix не найден, просмотрите весь список шлюзов, зарегистрированных к указанному viazone.

  3. Выберите первый GW IP-IP, найденный в шаге 1 или 2, который имеет ресурсы в наличии.

  4. Если все GW IP-IP в списке вне ресурсов, выберите первый GW IP-IP, который найден (даже при том, что это могло бы быть вне ресурсов).

  5. Если никакие GW IP-IP не найдены, возвратите сбой.

Примеры вызовов в локальной зоне

В примерах, приведенных в этом разделе, два шлюза регистрируются привратником Cisco с соответствующими идентификаторами H.323. Кроме того, шлюз (GWY) A2 регистрируется с адресом E.164. Данная диаграмма используется для всех примеров в этом разделе:

gk-call-routing-3.gif

Три сценария в этом разделе пошагово объясняют процесс принятия решения, который привратник использует для маршрутизации вызовов на основе сообщений ARQ.

Примечание: Только соответствующие выходные данные показывают в этих перехватах конфигурации.

Сценарий 1: Нет настроенных префиксов технологии

GK-A
!
gatekeeper
zone local GK-A abc.com
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718 

!--- The IP address configured here should 
!--- be the RAS address of GK-A
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status
 
!--- command on GK-A.
 
h323-gateway voip h323-id GW-A1@abc.com 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512

!--- On outgoing calls through POTS dial-peers,
!--- all explicit digit matches are dropped, 
!--- which is the reason
!--- for adding the prefix 512. This has nothing to  
!--- do with technology prefixes.

!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras

!--- Uses RAS messages (GK) to get 
!--- call setup information.


!
gateway
!
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718

!--- The IP address configured here  
!--- should be the RAS address of GK-A.
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status

!--- command on GK-A.
 
h323-gateway voip h323-id GW-A2@abc.com
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0

!--- This is the FXS port.

!
gateway
!

Эти выходные данные, полученные с GK-A, отражают действительные регистрации. Обратите внимание, что GWY-A2 регистрирует также E.164 ID порта FXS.

GK-A#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
--------------- ----- --------------- ----- ---------         ----    --
172.22.1.1      1720  172.22.1.1      49317 GK-A              VOIP-GW
    H323-ID: GW-A1@abc.com
172.22.1.2      1720  172.22.1.2      58196 GK-A              VOIP-GW
    E164-ID: 9725551010
    H323-ID: GW-A2@abc.com
Total number of active registrations = 2

Выполнение первого вызова: пользователь A1 звонит пользователю A2 по номеру 972-555-1010. Используйте диаграмму ARQ для принятия решений.

GK-A получает ARQ от GWY-A1.

  1. Совпадает ли технологический префикс? Нет

  2. Совпадает ли префикс зоны? Нет

  3. Установлена ли команда arq reject-unknown-prefix? Нет, целевая зона равна локальной зоне.

  4. Является ли целевая зона локальной? Да

  5. Был ли технологический префикс найден на этапе 1? Нет

  6. Зарегистрирован ли целевой адрес? Да. Отправить ACF.

Вызов установлен.

Примечание: GWY-A2 имеет целевой зарегистрированный ID E.164 (порт FXS). Таким образом, привратник мог принять вызов.

Выполнение второго вызова: пользователь A2 набирает 512-555-1212 для звонка пользователю A1.

GK-A получает ARQ от GWY-A2.

  1. Совпадает ли технологический префикс? Нет

  2. Совпадает ли префикс зоны? Нет

  3. Установлена ли команда arq reject-unknown-prefix? Нет, целевая зона равна локальной зоне.

  4. Является ли целевая зона локальной? Да

  5. Был ли технологический префикс найден на этапе 1? Нет

  6. Зарегистрирован ли целевой адрес? Нет

  7. Установлен ли технологический префикс по умолчанию? Нет. Отправить ARJ.

Вызов не установлен.

Примечание: Сценарий 2 объясняет, как исправить эту проблему маршрутизации вызова с технологическими префиксами.

Сценарий 2: Технологические префиксы настроены

В данном сценарии сделаны следующие изменения конфигурации:

  • GWY-A1 – добавлена команда h323-gateway voip tech-prefix 1#. GWY-A1 регистрируется в GK-A с технологическим префиксом 1#.

  • GWY-A1 – добавлен одноранговый узел POTS с командой destination-pattern, которая сопоставляет входящие вызываемые номера из GWY-A2 с технологическим префиксом 1#.

  • GK-A – добавлена команда zone prefix GK-A. Она определяет префиксы локальной зоны, которой управляет GK-A.

  • GK-A – добавлена команда arq reject-unknown-prefix. Это заставляет GK-A принимать вызовы ARQ только для префиксов зоны, которой он управляет. В сценарии 1 это не было настроено. Поэтому целевая зона была по умолчанию установлена как локальная зона.

  • GWY-A2 – в конфигурации одноранговых узлов VoIP добавлена команда tech-prefix 1#. В этом случае GWY-A2 присоединяет 1# к исходящим вызовам VoIP. GK-A указывает шаблон 1# для отбора GWY-A1 в качестве шлюза назначения.

GK-A
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
arq reject-unknown-prefix
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 3 pots
incoming called-number 972.......
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
tech-prefix 1#
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

Эти выходные данные, полученные с GK-A, отражают зарегистрированные технологические префиксы:

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#*
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Примечание: Вместо того, чтобы настроить GW-A1 с h323-gateway voip tech-prefix 1# команда, это может быть выполнено тот же путь путем ручной настройки этой информации в GK-A с командой.

GK-A(config-gk)#gw-type-prefix 1#* gw ipaddr 172.22.1.1

Выполнение вызова: пользователь A2 набирает 512-555-1212 для звонка пользователю A1.

GK-A получает ARQ от GWY-A2.

  1. Совпадает ли технологический префикс? Да

    Примечание: После соответствия технологического префикса сторожевое устройство разделяет его для анализа префикса зоны. Этот сброс производится только анализатором привратника. Исходный шлюз по-прежнему использует его при установке соединения с конечным шлюзом.

  2. Совпадает ли префикс зоны? Да. Установить целевую зону равной локальной зоне.

  3. Псевдоним называет (после того, как, разделяя технический префикс), совпадают с каким-либо зарегистрированным GW? Нет. (Если Да, передайте ACF).

  4. Является ли целевая зона локальной? Да

  5. Был ли технологический префикс найден на этапе 1? Да

  6. Был ли найден локальный шлюз с технологическим префиксом? Да. Отправить ACF.

    Вызов установлен.

Эти выходные данные команды GK-A debug иллюстрируют описанное выше поведение.

Примечание: Эта команда отладки является полезной, но скрытой, отладкой. Поэтому синтаксический анализатор отладку не покажет.

GK-A#debug gatekeeper main 5
      
    *Jun 19 09:50:10.086: gk_rassrv_arq: arqp=0x631CC400, crv=0x82, answerCall=0
    *Jun 19 09:50:10.086: gk_dns_locate_gk(): No Name servers
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched tech-prefix 1#
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched zone prefix 512
    *Jun 19 09:50:10.118: gk_rassrv_arq: arqp=0x631CC400, crv=0x1A, answerCall=1

Примечание: Это - альтернативная конфигурация, которая может быть более интуитивной:

  • Выполните команду h323-gateway voip tech-prefix 512, чтобы настроить GWY-A1 для регистрации с технологическим префиксом 512.

  • В этом случае GWY-A2 нет необходимости проводить префикс по VoIP-ветви однорангового соединения, поскольку destination-pattern уже включает 512. Таким образом, следует убрать команду tech-prefix 1# в конфигурации GWY-A2, а также удалить 1# из шаблона назначения в одноранговом узле обычной телефонной сети на GWY-A1.

Ситуация 3: Настроенные технологические префиксы по умолчанию

В данном сценарии GWY-A1 регистрируется с технологическим префиксом 1#, а GK-A настраивается для маршрутизации вызовов без совпадения технологического префикса на шлюза с технологическими префиксами по умолчанию. Таким образом, GWY-A2 может и не быть настроен на передачу технологического префикса назначения.

GK-A
!
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix 
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0 
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com 
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

Эти выходные данные, полученные с GK-A, отражают зарегистрированные технологические префиксы:

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#* (Default gateway-technology)
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Выполнение вызова: пользователь A2 набирает 512-555-1212 для звонка пользователю A1.

GK-A получает ARQ от GWY-A2.

  1. Совпадает ли технологический префикс? Нет

  2. Совпадает ли префикс зоны? Да. Установить целевую зону равной локальной зоне.

  3. Является ли целевая зона локальной? Да

  4. Был ли технологический префикс найден на этапе 1? Нет

  5. Зарегистрирован ли целевой адрес? Нет

  6. Установлен ли технологический префикс по умолчанию? Да. Выбрать локальный шлюз с технологическим префиксом (только один).

  7. Отправить ACF.

    Вызов установлен.

Примеры вызовов в удаленной зоне

В следующих примерах используются две зоны H.323: одна управляется GK-A, а другая – GK-B.

/image/gif/paws/24462/gk-call-routing-4.gif

Сценарии в этом разделе пошагово объясняют процесс принятия решения, который привратник использует для маршрутизации вызовов на основе сообщений ARQ и LRQ.

Примечание: Только соответствующие выходные данные показывают в этих примерах конфигурации.

Сценарий 1: Привратники зоны сконфигурированы с технологическими префиксами по умолчанию

В данном сценарии GWY-A1 регистрируется в GK-A с технологическим префиксом 1#, а GWY-B1 — в GK-B с технологическим префиксом 2#. Оба привратника настраиваются со шлюзами с технологическими префиксами по умолчанию.

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com 172.22.1.3
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix
no shutdown
! 
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 2#* default-technology
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern ..........
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
!
gateway
!

Выполнение вызова: пользователь A1 набирает 214-555-1111 для звонка пользователю B1.

GK-A получает ARQ от GWY-A1.

  1. Совпадает ли технологический префикс? Нет

  2. Совпадает ли префикс зоны? Да. Установить целевую зону равной удаленной зоне GK-B (214).

  3. Является ли целевая зона локальной? Нет

  4. Отправить LRQ на GK-B.

GK-B получает LRQ от GK-A.

  1. Совпадает ли технологический префикс? Нет

  2. Совпадает ли префикс зоны? Да. Установить целевую зону равной локальной зоне.

  3. Является ли целевая зона локальной? Да

  4. Был ли технологический префикс найден на этапе 1? Нет

  5. Зарегистрирован ли целевой адрес? Нет

  6. Установлен ли технологический префикс по умолчанию? Да. Выбрать локальный шлюз с технологическим префиксом (2#).

  7. Отправить LCF на GK-A.

    GK-A получает LCF от GK-D с данными конечного шлюза.

    GK-A отправляет ACF на GWY-A1.

    Вызов установлен.

Сценарий 2: Привратники зоны настроены без технологических префиксов по умолчанию

В данном сценарии GWY-A1 регистрируется в GK-A с технологическим префиксом 1#, а GWY-B1 — в GK-B с технологическим префиксом 2#. GWY-A1 добавляет технологический префикс 2# к строке вызываемого номера, когда совершает звонок на (214), а GWY-B1 добавляет технологический префикс 1# к строке вызываемого номера, когда совершает звонок на (512).

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
gateway
!

Выполнение первого вызова: пользователь B1 набирает 512-555-1212 для звонка пользователю A1.

GK-B получает ARQ от GWY-B2.

  1. Совпадает ли технологический префикс? Нет

  2. Совпадает ли префикс зоны? Нет

    Примечание: Поскольку GK-B не знает 1# технологический префикс, он предполагает, что это - часть вызываемого номера и читает его как префикс зоны.

  3. Является ли целевая зона локальной? Да

    Примечание: GK-B берет целевую зону по умолчанию, равняется локальной зоне, потому что команда arq reject-unknown-prefix является "not set".

  4. Был ли технологический префикс найден на этапе 1? Нет

  5. Зарегистрирован ли целевой адрес? Нет

  6. Установлен ли технологический префикс по умолчанию? Нет

  7. Отправить ARJ на GWY-B1.

    Вызов не установлен.

Следующие выходные данные были взяты с GK-B для дальнейшей иллюстрации этого поведения:


!--- From debug gatekeeper main 5.

      
GK-B#
gk_rassrv_arq: arqp=0x62F6A7E0, crv=0x22, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Tech-prefix match failed
rassrv_get_addrinfo(1#5125551212): unresolved zone prefix, using source zone GK-B
rassrv_get_addrinfo(1#5125551212): unknown address and no default technology defined
gk_rassrv_sep_arq(): rassrv_get_addrinfo() failed (return code = 0x103)

!--- From debug ras.


GK-B#
RecvUDP_IPSockData successfully rcvd message of length 156 from 172.22.2.1:51141
ARQ (seq# 1796) rcvdparse_arq_nonstd: ARQ Nonstd decode succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 4 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendARJ: ARJ (seq# 1796) sent to 172.22.2.1

Чтобы решить эту проблему, настройте привратники для определения технологических префиксов удаленной зоны.

  • Добавьте это в GK-B:

    GK-B(config-gk)#gw-type-prefix 1# hopoff GK-A
    
  • Добавьте это в GK-A:

    GK-A(config-gk)#gw-type-prefix 2# hopoff GK-B
    

Обратите внимание, что одноранговые узлы POTS в конечных шлюзах необходимо было обновить, чтобы сопоставить входящие строки набора с технологическими префиксами.

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
gw-type-prefix 2# hopoff GK-B
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
gw-type-prefix 1# hopoff GK-A
no shutdown
!
GK-B GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!

!--- This dial-peer is used for 
!--- incoming calls from the PSTN.

dial-peer voice 1 pots
incoming called-number 512.......
direct-inward-dial
port 1/0:23
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!

!--- This dial-peer is used to 
!--- terminate (512) calls coming
!--- from the VoIP network. Notice 
!--- that the technology prefix 
!--- is matched to select the dial-peer 
!--- but does not pass it to 
!--- the PSTN.
 
dial-peer voice 3 pots
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 4 voip
destination-pattern 972.......
session target ras
! 
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
incoming called-number 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
dial-peer voice 3 pots
destination-pattern 2#214....... 
port 3/0:23
prefix 214 
! 
gateway
!

Выполнение второго вызова: пользователь B1 набирает 512-555-1212 для звонка пользователю A1.

GK-B получает ARQ от GWY-B2.

  1. Совпадает ли технологический префикс? Да

  2. Существует ли технологический префикс ухода? Да

  3. Отправить LRQ на GK-A.

    Примечание: LRQ включает технологический префикс в вызываемый номер для анализа GK-A.

GK-A получает LRQ от GK-B.

  1. Совпадает ли технологический префикс? Да

  2. Существует ли технологический префикс ухода? Нет

    Примечание: Для продолжения анализа маршрутов вызова GK-A разделяет технологический префикс. Технологический префикс остается в строке вызываемого номера, когда шлюзы устанавливают ветви вызова.

  3. Совпадает ли префикс зоны? Да. Установить целевую зону равной локальной зоне.

  4. Является ли целевая зона локальной? Да

  5. Был ли технологический префикс найден на этапе 1? Да

  6. Был ли найден локальный шлюз с технологическим префиксом? Да

  7. Отправить LCF на GK-B.

    GK-B получает LCF от GK-A с данными конечного шлюза.

    GK-B отправляет ACF на GWY-B1.

    Вызов установлен.

Следующие выходные данные были взяты с GK-B для дальнейшей иллюстрации этого поведения:


!--- From debug gatekeeper main 5.


GK-B#
gk_rassrv_arq: arqp=0x62ED2D68, crv=0x24, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Matched tech-prefix 1#
rassrv_put_remote_zones_from_zone_list() zone GK-A
gk_rassrv_irr: irrp=0x62F0D8FC, from 172.22.2.1:51141
GK-B#
GK-B#

!--- From debug ras.


RecvUDP_IPSockData successfully received message of 
length 156 from 172.22.2.1:51141
ARQ (seq# 1809) rcvdparse_arq_nonstd: ARQ Nonstd decode 
succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 104 from 
172.22.2.3:1719 to 172.22.1.3: 1719
RASLib::RASSendLRQ: LRQ (seq# 1042) sent to 172.22.1.3
IPSOCK_RAS_sendto: msg length 7 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendRIP: RIP (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
131 from 172.22.1.3:1719
LCF (seq# 1042) rcvdparse_lcf_nonstd: LCF Nonstd 
decode succeeded, remlen= 131
IPSOCK_RAS_sendto: msg length 34 from 172.22.2.3:1719 
to 172.22.2.1: 51141
RASLib::RASSendACF: ACF (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
76 from 172.22.2.1:51141

Команды для проверки и устранения неполадок

В данном разделе приводится список команд show и debug, которые используются для проверки и поиска и устранения неисправностей при проблемах маршрутизации вызовов привратником и шлюзом.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • show gateway – используется для регистрации псевдонимов E.164 и H.323 для шлюза.

  • show gatekeeper endpoints – используется для проверки псевдонимов E.164 и H.323, зарегистрированных привратником.

  • show gatekeeper gw-type-prefix – используется для проверки регистраций префиксов E.164 на привратнике.

  • show gatekeeper zone prefix | status – используется для проверки статуса зоны и параметров конфигурации.

  • debug ras – применима для шлюзов и привратников.

  • debug h225 asn1 – применима для шлюзов и привратников.

  • show dial-peer voice – используется для проверки технологических префиксов в точках вызова.


Дополнительные сведения


Document ID: 24462