Голосовая связь и система унифицированных коммуникаций : Универсальные шлюзы Cisco серии AS5300

Использование Dialout/EZ с Cisco Access Server

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Продукт Временного программного обеспечения DialOut/EZ позволяет пользователям рабочего стола LAN совместно использовать порты сервера доступа к сети (NAS) как пул модемов для исходящих асинхронных соединений. Пользователи DialOut/EZ больше не нуждаются в специализированных модемах и телефонных линиях в их рабочих столах, но вместо этого используют связь (COM:) программное обеспечение редиректора порта, чтобы позволить набираемым портам на серверах доступа появляться как локальные модемы к настольным коммуникационным приложениям. Пользователи Windows могут набрать через центральный NAS/сервер доступа, чтобы обратиться к удаленным онлайн сервисам и даже передать факсы от их PC. Cisco Выпуск ПО IOS�, работающий на NAS, должна поддержать Протокол управления COM - порта (RFC 2217). Можно узнать дополнительные сведения о DialOut/EZ Временного программного обеспечения от веб-сайта компании в: http://www.tacticalsoftware.com leavingcisco.com.

Примечание: DialOut/EZ является заменой для служебной программы Cisco dialout utility.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Временное программное обеспечение требует, чтобы программное обеспечение Cisco IOS версии 12.0(9) или позже было установлено на NAS для взаимодействия с DialOut/EZ.

  • Из-за идентификатора ошибки Cisco CSCds28071, Cisco рекомендует выполнить программное обеспечение Cisco IOS версии 12.1(8) или позже.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Установка и конфигурация

Установка требуемых драйверов модема для виртуального COM-порта Dialout/EZ

  1. Установите DialOut/EZ.

    Для завершенной информации об установке DialOut/EZ на клиентской рабочей станции обратитесь к Руководству пользователя на веб-сайте Временного программного обеспечения: DialOut/EZ.

  2. Драйверы модема загрузки.

    Действительные COM - порты DialOut/EZ не имеют никаких модемных устройств подключенными им. Пользователь DialOut/EZ должен использовать соответствующий файл .inf для модемов (установите драйвер модема на действительных COM - портах). MICA, NextPort и файлы .inf Microcom доступны для скачивания от Web - сайта Cisco. Поскольку другие платформы используют указанные файлы .inf.

    Тип модема Платформа Файл .inf
    MICA 3600, AS5200, AS5300, AS5800 mdcsmica.inf
    NextPort AS5350, AS5400, AS5800, AS5850
    Microcom AS5200 mnpv90.inf
    NM-xAM 2600, 3600 Microcom DeskPorte V.34 FAST
    WIC-xAM 2600, 3600 mdmrock5.inf (или стандартный файл модема на 28800 битов в секунду)

    Примечание: Для Windows XP, Cisco, если могут не работать файлы .inf. Попытайтесь использовать Windows встроенный файл .inf вместо этого.

  3. Установите драйверы модема.

    Для установки драйвера модема на Компьютере с операционной системой Windows используйте следующую процедуру:

    1. Пуск> Настройка> Панель управления> Телефон и Параметры модема.

    2. Выберите Modem и Add для добавления нового модема.

    3. Выберите Do not detect my modem; я выберу его из списка, затем нажать Next.

    4. Выберите Manufacturer и Model вашего модема. Выбор Cisco на левом окне отображает Mica на правом окне.

    5. Выберите Have Disk и перейдите к местоположению, где сохранен файл .inf.

    6. В опции Выбранных портов используйте COM - порт, выбранный во время Установки исходящего соединения EZ (например, COM 5).

Настройка сервера доступа

Конфигурация ПО IOS, необходимая для приложений для внешнего телефонного соединения через модем символьного режима только (такой как с DialOut/EZ), идет под конфигурацией с командной строки:

line starting_line_number ending_line_number
     modem dtr-active  
     
! -- If the router is for dialin and dialout use "modem inout" instead

     transport input telnet
     
! -- Or transport input all could be used

     escape-character NONE 
     
! -- Due to Bug CSCdv12194 for the AS5350/AS5400.

     rotary 1 
     
! -- Specifies the use of TCP port 7001 in the Dialout/EZ manager 
     ! -- window to dial out rotary 1

Если внешние модемы используются, то добавьте физический уровень RS232 и параметры формирования кадров под конфигурацией с командной строки, как желаемый:

speed 115200 
    
 ! --  Set to the highest speed supported by the modems

     flowcontrol hardware
     parity even 
     databits 7 
     
! -- Or databits 8

     stopbits 1 
     
! -- Recommended for best throughput

Если вы хотите управлять доступом к линиям подключения к внешней службе, добавьте придерживающееся в режиме конфигурации с командной строки:

password password

Также настройте аутентификацию, авторизацию и учет (AAA) и примените список к линии с:

login authentication listname

Если вы хотите управлять, какие транки используются для вызовов подключения к внешней службе, используйте команду modem dialout controller, представленную в Cisco IOS Software Release 12.1 (t) (на данный момент, поддерживаемый только на AS5300). Для получения дополнительной информации обратитесь к Настройке Интерфейс T1 или E1 для Исходящих аналоговых вызовов Использование Команды modem dialout controller.

Совет: Иногда DialOut/EZ может запутаться сообщением OK Пароля из программного обеспечения IOS. Для предотвращения этой проблемы настройте AAA (локальный или основанный на сервере) на маршрутизаторе. См. AS5xxx с разделом AAA этого документа для примера конфигурации.

Дополнительно: Можно также настроить modemcap для сброса модема к конфигурации по умолчанию после каждого вызова. Используйте команду modem autoconfigure type mica под конфигурацией с командной строки. Этот modemcap (который устанавливает заводскую настройку &F) может быть применен ко всем маршрутизаторам независимо от типа модема (MICA, NextPort, Microcom, и т.д.). Для получения дополнительной информации о modemcaps обратитесь к Рекомендуемым параметрам modemcap для Внутренних цифровых и аналоговых модемов на Cisco Access Server.

Тот же Сервер доступа может использоваться для входящего вызова, а также подключения к внешней службе (приложение). Поскольку всесторонние примеры конфигурации обращаются к Конфигурациям NAS Выборки раздела для Служебной программы dialout/ez.

Устранение неполадок с внешними телефонными соединениями/EZ

Придерживайтесь метода, выделенного ниже для устранения проблем связанных проблем DialOut/EZ:

  1. Обратный доступ по протоколу Telnet к NAS - модему от подсказки командной строки NAS. Гарантируйте, что можно соединиться с модемом путем выдачи команды AT, которая должна возвратить ответ OK. Если можно соединиться с модемом, попытайтесь набрать номер удаленного устройства с помощью atdt ######## команда. Если соединение успешно, то конфигурация маршрутизатора корректна, и аппаратные средства работают правильно.

    Примечание: Используйте диапазон порта TCP двоичного Telnet: 6000+line для использования определенной линии, или 7000 + rotary_number для ротации подключения к внешней службе.

    Пример ниже показов успешный вызов:

    maui-nas-03#telnet 172.22.53.150 7001
    
    ! -- Reverse Telnet to an up/up interface on the router 
    ! -- and use port 7000+rotary
    
    Trying 172.22.53.150, 7001 ... Open
    User Access Verification
    !
    Username: admin
    Password:
    at
    OK
    
    ! -- Modem is responding
    
    atdt 81560
    
    ! -- Dial number 81560 to connect to remote device. 
    ! -- This may take up to 30 seconds.
    
    CONNECT 33600 /V.42/V.42bis
    
    ! -- Call is connected to the remote device.
    
      User Access Verification
    
    ! -- Username prompt by remote device
    
      Username: cisco
      Password: maui-nas-01>

    Если обратный доступ по протоколу Telnet не достигает командного режима AT модема, то NAS неправильно сконфигурирован. Проверьте следующее:

    1. Интерфейс, к IP-адресу которого вы являетесь Telnet - сеансом, должен быть up/up и отвечающий на команду ping от хоста ПК на LAN. Если вы не можете пропинговать устранение неполадок интерфейса маршрутизатора ваша LAN для проблем относящаяся к маршрутизации.

    2. Модемная линия должна иметь ввод-вывод модема (для входящего вызова/подключения к внешней службе) или modem dtr-active (только для подключения к внешней службе).

    3. Линия должна быть настроена с telnet transport input или transport input all.

    Если обратный доступ по протоколу Telnet преуспевает в том, чтобы достигнуть командного режима AT модема, но сбои вызова в ручном режиме, то проблемой могла быть проблема удаленного маршрутизатора или Telco (телефонная компания). Устраните неполадки удаленного маршрутизатора, линии и повторно протестируйте соединение прежде, чем продолжить,. См. Устранение проблем Набираемого Подключения Технологии - Не-ddr выноска для получения дополнительной информации.

  2. Попробуйте обратный доступ по протоколу Telnet от хоста ПК на LAN. Гипертерминал Открытых окон (или Windows Telnet) и Telnet к IP-адресу маршрутизатора и порту вы используете для DialOut/EZ (например, 7001). Если можно достигнуть модема и подключения к внешней службе, то нет ничего неправильно с LAN (мы ранее проверили, что подключение к внешней службе от NAS работает).

  3. Если обратный доступ по протоколу Telnet не достигает командного режима AT модема, то NAS неправильно сконфигурирован, или IP - сеть не работает. Проверьте следующее:

    1. Интерфейс, к IP-адресу которого вы являетесь Telnet - сеансом, должен быть up/up и отвечающий на команду ping от хоста ПК на LAN. Если вы не можете пропинговать устранение неполадок интерфейса маршрутизатора ваша LAN для проблем относящаяся к маршрутизации.

    2. Не должно быть никакого access-class, который блокирует Telnet - подключение.

    Следующие снимки экрана показывают успешный Сеанс гипертерминала:

    hyperterm1.gif

    hyperterm2.gif

    Примечание: При использовании Клиента Telnet Microsoft Windows, и AAA настроен на NAS, вход в систему Windows Telnet может отказать. Этот сбой вызван прикладными режимами и характеризуется неспособностью ввести пароль, таким образом войти сбои. Для исправления значения приложения Telnet для этого сеанса выполните процедуру ниже на ПК хоста:

    1. Пуск> Выполнить> telnet типа, нажмите OK.

    2. Введите команду unset crlf. (Это гарантирует передачу возвратов каретки как <CR> <NUL> Telnet, а не <CR> <LF>.)

    3. Используйте открытый <ip_address> <port> к Telnet к модему.

    4. Вы должны теперь быть связаны с модемами и можете теперь инициировать набор номера вручную с помощью atdt так же, как с Гипертерминалом пример показывает выше. Следующий снимок экрана является примером:

      wintelnet1.gif

  4. Используйте Гипертерминал для прямого соединения с NAS - модемами через эмулированный COM - порт DialOut/EZ. См. Главу руководства пользователя DialOut/EZ на установке на http://www.tacticalsoftware.com leavingcisco.com для получения дополнительной информации. Это проверит, что функционирует эмулированный COM - порт DialOut/EZ.

    Если бы Гипертерминал по эмулированному COM - порту DialOut/EZ НЕ работает, то проблема, казалось бы, была бы специфична для связи DialOut/EZ с IOS. Соберите следующую информацию:

    • Эти отладки определяют, получает ли NAS Telnet - подключение.

      debug telnet 
      debug modem
      
    • Журнал Трассировки DialOut/EZ: Выбор Trace Window menu option открывает окно DialOut/EZ Port Monitor 3.0 с включенной вкладкой Trace Window. Чтобы начать отслеживать, установите Разрешать флажок Трассировки у основания этого окна. Удостоверьтесь, что вы сохраняете журнал на дальнейший анализ. См. Раздел устранения проблем Руководства пользователя на веб-сайте Временного программного обеспечения для получения дополнительной информации.

  5. Так как мы проверили, что DialOut/EZ может соединиться с модемами, затем иметь конечное приложение, инициируют соединение. Если конечные приложения не могут говорить друг с другом использующим соединение DialOut/EZ, то проблема могла быть странной до конца приложение. Журнал Трассировки DialOut/EZ может быть полезным в решении этой проблемы. Также включите журнал модема Windows TAPI, и также любую регистрацию, доступную из приложения. См. веб-сайт Microsoft leavingcisco.com для следующей статьи microsoft: Как Создать и Использовать Файл (Q142730) Modemlog.txt для получения дополнительной информации.

    Если операция все еще не работает, как желаемый, собирает отладки IOS, Журнал Трассировки DialOut/EZ, и (если применимо) журнал модема Windows, и анализирует результаты определить, где отказывает приложение.

    См. Временное программное обеспечение: Часто задаваемые вопросы leavingcisco.com для дополнительных сведений.

Пример конфигураций NAS для служебной программы DialOut/EZ

AS25xx, NM-xAM, WIC-xAM

Придерживающееся является эталонным файлом конфигурации для маршрутизаторов с внешними аналоговыми модемами, такими как Cisco AS2509, Cisco AS2510, Cisco AS2511, или сервер доступа Cisco AS2512, а также маршрутизаторы с внутренними аналоговыми модемами (NM-xAM и WIC-xAM) такой как 26xx, и 36xx series маршрутизаторы.

Пример ниже показов маршрутизатор, способный к входящим и исходящим звонкам. Если маршрутизатор для исходящего использования только, то конфигурация с командной строки - все, что необходимо.

interface Group-Async1
   
! -- Group-Async interface used for dialin calls
   ! -- This is not used for dialout

    ip unnumbered Ethernet0
    no ip mroute-cache
    encapsulation ppp
    no ip route-cache
    async default routing
    async dynamic address
    async mode interactive
    peer default ip address pool local
    dialer in-band
    no cdp enable
    ppp authentication chap
    group-range 1 8
    
! -- Range of lines include 1 through 8
    ! -- Modems 1 through 8 can now be used for incoming or outgoing calls

   !
   line 1 8
    
! -- Line configuration used for Dialout/EZ

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only use "modem dtr-active"

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead

    rxspeed 115200
    txspeed 115200
    
! -- Speed for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM)
 
    flowcontrol hardware
    
! -- Flowcontrol for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM

AS5xxx без AAA

Придерживающееся является эталонным файлом конфигурации для сервера доступа через серии Cisco AS5xxx без AAA.

Данный пример показывает маршрутизатор, внимающий входящим призывам и делающий исходящие вызовы:

controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 6661210
    dialer-group 1
    isdn incoming-voice modem
    
! -- Incoming analog calls will be switched to the modems

    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap
    ppp multilink
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap
    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   line 1 48
   
! -- Line configuration for Dialout/EZ

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout if the line is used for
    ! -- dialout only use, modem dtr-active transport preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport input all
    transport input telnet
    
! -- Configure one or both of the above commands

AS5xxx с AAA

Придерживающееся является эталонным файлом конфигурации для серверов доступа через серии Cisco AS5xxx с настроенной серверной проверкой AAA (проверка подлинности, авторизация и учет).

Следующий пример, показывает сервер доступа, настроенный для вызовов подключения к внешней службе и входящего вызова:

aaa new-model
   aaa authentication login default radius
   
! -- Use the radius server for login on the default list
   ! -- for local AAA replace "radius" with "local" 
   ! -- (make sure to configure the username/password locally as well

   aaa authentication ppp ppptac radius
   
! -- Use the radius server for ppp on the list named ppptac
   ! -- This is used for incoming ppp calls and is not used for outgoing 
   ! -- Dialout/EZ calls
   !

   controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 name test 5551210
    dialer-group 1
    isdn incoming-voice modem
    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap ppptac
    ppp multilink
   !
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap ppptac
    
! -- Use list named ppptac for authentication

    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   !
   radius-server host 10.4.1.10
   radius-server timeout 20
   radius-server key nas1
   
! -- Radius server configuration

   !
   line 1 48
    
! -- Line configuration for Dialout/EZ as well as dialin calls

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only, use modem dtr-active transport 
    ! -- preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead


Дополнительные сведения


Document ID: 23241