Протокол IP : Dynamic Address Allocation and Resolution

Динамическая настройка параметров сервера DHCP

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

DHCP-протокол позволяет автоматически назначать DHCP-клиентам многократно используемые IP-адреса. В данном документе представлен пример настройки DHCP-параметров, например, таких как адреса службы доменных имен (DNS-адрес) и службы имен Интернета для Windows (WINS-адрес), что позволяет отвечать на DHCP-запросы от локальных клиентов, расположенных за абонентским оконечным оборудованием (CPE).

Ранее, администраторы сети должны были вручную настроить Cisco, которую сервер DHCP IOS� на каждом устройстве включил с этой функцией. Обходить все устройства после развертывания очередного маршрутизатора и вносить изменения вручную - занятие долгое, обременительное и дорогое.

Поэтому DHCP-сервер Cisco IOS был улучшен и теперь можно проводить автоматическое обновление сведений о конфигурации. Сетевые администраторы могут настроить один или несколько централизованных серверов DHCP для обновления особых параметров DHCP в рамках пулов DHCP. Удаленные серверы могут запрашивать или импортировать параметры с централизованных серверов.

Предварительные условия

Требования

Компания Cisco также рекомендует пользователям ознакомиться со следующими темами:

  • DHCP

  • Domain Name System (DNS)

  • Сервис имен Интернета для Windows (WINS)

Используемые компоненты

При разработке и тестировании этой конфигурации использовались следующие версии программного и аппаратного обеспечения:

  • Cisco выпуск ПО IOS� 12.2 (27)

  • Два Маршрутизатора Cisco 3660 с NM-1E, используемым для ПК и клиентского соединения

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Примечание: Функция DHCP-сервер Cisco IOS впервые появилась в программном обеспечении Cisco IOS Release 12.0(1)T. Вам нужна Cisco 12.0 (2) T или позднее Выпуска ПО IOS� для использования с Маршрутизаторами серии Cisco 1700. Дополнительные сведения о маршрутизаторах, поддерживающих функцию DHCP-сервера, см. в разделе Поддерживаемые платформы документа под названием DHCP-сервер Cisco IOS.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В данном разделе приводятся сведения о настройке параметров DHCP-сервера для DNS и WINS. "Центральному" маршрутизатору задаются параметры сервера, которые затем импортируются "удаленным" маршрутизатором. Удаленный персональный компьютер или клиент получают эти импортированные параметры от "удаленного" маршрутизатора во время этапа передачи сообщений DHCPACK.

Примечание: Чтобы найти, что дополнительные сведения о командах, используемых в этом документе, обращаются к Командам DHCP или используют Средство поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме:

/image/gif/paws/22920/dhcp_ser_01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Центральный (3660)
Central# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

!--- This range must not be assigned to DHCP clients.

!
ip dhcp pool Central   
   network 10.0.0.0 255.255.255.0

!--- Specify the network number and mask for DHCP clients.
   
   domain-name Central

!--- Specify the domain name for the client.
   
   dns-server 10.0.0.2

!--- Specify the DNS server you want to respond to DHCP clients who


!--- need to correlate the host name to the IP address.
   
   netbios-name-server 10.0.0.2

!--- Specify the Network Basic Input/Output System (NetBIOS)


!--- WINS server (for Microsoft DHCP clients)
 
!
.
.
!
interface FastEthernet0/0 
 ip address 10.0.0.1 255.255.255.0 
 duplex auto 
 speed auto
!
.
.
!
end

Примечание: Когда вы используете маршрутизатор Cisco в качестве сервера DHCP, только один домен позволен на пул DHCP, другими словами, маршрутизатор не может передать аренду DHCP клиентам, которые включают два доменных имени. Не возможно смешать статическое отображение в динамическом пуле. Если это смешано, %, Эта команда не может использоваться с сетью, происхождением, VRF, или релейное сообщение об ошибках пулов появляется.

Удаленный (3660)
Remote# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

!--- This ip address must not be assigned to DHCP clients.

!
ip dhcp pool Client   
   import all

!--- Import DHCP option parameters into the database.
   
   network 192.168.1.0 255.255.255.248

!--- Specify the network number and mask for DHCP clients.

   default-router 192.168.1.1

!--- Specify the default gateway for DHCP clients.
	
!
.
.
!
interface FastEthernet0/0 
 ip address dhcp 
 duplex auto 
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

Команда service config используется в сочетании с boot host или командой boot network. Команда service config введена, чтобы позволить маршрутизатору автоматически настроить систему от файла, заданного boot host или командой boot network.

Команда service config может также использоваться без boot host или команды boot network. Если вы не задаете хост или имена файлов конфигурации сети, маршрутизатор использует файлы конфигурации по умолчанию. Файл конфигурации сети по умолчанию является сетевым config. Файл конфигурации хоста по умолчанию является config хоста, где хост является именем хоста маршрутизатора. Если программное обеспечение Cisco IOS не может решить свое имя хоста, файл конфигурации хоста по умолчанию является config маршрутизатора.

Используйте команду boot host наряду с командой service config. Без команды service config маршрутизатор игнорирует команду boot host и использует сведения о конфигурации в NVRAM. Если сведения о конфигурации в NVRAM недопустимы или пропавшие без вести, команда service config включена автоматически. Сервер сети попытается загрузить два файла конфигурации из удаленных хостов. Первым является файл конфигурации сети, содержащий команды, которые применяются ко всем серверам сети в сети. Используйте команду boot network для определения файла конфигурации сети. Вторым является файл конфигурации хоста, который содержит команды, которые применяются к одному серверу сети в частности. Используйте команду boot host для определения файла конфигурации хоста.

Клиент отсылает широковещание inspite факта, что параметр 150 настроен из-за его характера по умолчанию для внимательности сервера TFTP, и Параметр 150 определен на стороне сервера не клиентская сторона. Кроме TFTP, 150 опций также доступны для них:

  • 150 Etherboot

  • 150 названий пути конфигурации GRUB

Параметры DHCP могут быть настроены со строкой ASCII кода параметра команда имени сервера tftp. Если у вас нет названия сервера и если сервер настроен только с IP-адресом, то используйте команду ip address ip кода параметра .

Проверка

В данном разделе содержатся сведения для проверки правильности конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip dhcp import — Отображает дополнительные параметры, импортированные в базу данных сервера DHCP.

Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
  • show ip dhcp binding — Отображает привязки по адресу на сервере Cisco IOSDHCP.

Central#show ip dhcp binding
IP address       Client-ID/Hardware address	 	Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.        
                 30

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

Выходные данные команды ipconfig /all получены на персональном компьютере или клиенте под управлением операционной системы Microsoft Windows и содержит значения параметров TCP/IP-конфигурации, настроенные с помощью протокола DHCP. См. RFC 2132 leavingcisco.com для получения дополнительной информации о параметрах DHCP.

C:\>ipconfig /all 
  
Windows 2000 IP Configuration 
  
  Host Name . . . . . . . . . . . . : PC 
  Primary DNS Suffix . . . . . . .  : cisco.com 
  Node Type . . . . . . . . . . . . : Hybrid 
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No 
  DNS Suffix Search List. . . . . . : cisco.com 
                                       
Ethernet adapter Local Area Connection :
	 
  Connection-specific DNS Suffix . : Central 
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX) 
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA 
  DHCP Enabled. . . . . . . . . .  : Yes 
  Autoconfiguration Enabled . . .  : Yes 
  IP Address. . . . . . . . . . .  : 192.168.1.2 
  Subnet Mask . . . . . . . . . .  : 255.255.255.248 
  Default Gateway . . . . . . . .  : 192.168.1.1
  DHCP Server . . . . . . . . . .  : 10.0.0.6 
  DNS Servers . . . . . . . . . .  : 10.0.0.2 
  Primary WINS Server . . . . . .  : 10.0.0.2 
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM 
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

Дополнительные сведения


Document ID: 22920