Глобальная сеть (WAN) : Frame Relay

Пример конфигурации Distributed Traffic Shaping

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ обсуждает Distributed Traffic Shaping (dTS) и консолидирует большую часть информации, которая доступна сегодня.

Формирование трафика (TS) предоставляет механизм для управления трафиком на определенном интерфейсе. "Распределенный" TS является функцией, определенной для более современных платформ, таких как Cisco 7500 или IP - маршрутизатор "серии 12000". Эти платформы имеют возможность разгрузить формирование трафика от главного процессора (Процессор переключателей маршрута - RSP или Гигабитный Процессор маршрута - GRP) к процессорам отдельного интерфейса (Многоцелевой интерфейсный процессор - VIP или линейной карте - LC). В сетях, где Distributed Cisco Express Forwarding (dCEF) является Предпочтительным режимом коммутации, DTS на VIP или линейной карте является логическим выбором для формирования трафика.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Почему трафик формы с DTS?

Если вы читаете этот документ, то наиболее вероятно у вас уже есть идея того, почему вы хотите сформировать трафик. Распределенный элемент мозаики должен быть довольно ясным, также - вы распределяете режимы работы главного процессора к отдельным процессорам карты. Относительно формирования много клиентов просто пытаются избежать превышать гарантированную скорость канала на основе соглашения с поставщиком. Это предотвращает падения облака и, в результате уменьшает повторные передачи (с TCP/IP), когда поставщик сбрасывает от пакетов. Общий сценарий, где необходимо сформировать трафик, изображен ниже. В данном примере, не требуется для Центрального узла для передачи трафика на скорости T1, если Филиал компании только имеет 128K канал:

dts-config-01.gif

Существует много дополнительных причин для использования DTS. Преимущества включают выбор связанной функциональности Качества обслуживания (QoS) и дисковод для использования пропускной способности максимально эффективно по различным типам трафика. DTS настраивает формирование трафика в уровне интерфейса, уровне подинтерфейса или уровне логического интерфейса для ATM или Постоянных виртуальных каналов Frame Relay (PVCs).

Формирование может достигнуть массива сетевых целей и может включить придерживающиеся критерии:

  • Весь трафик на медосмотре или логическом интерфейсе

  • Трафик, классифицированный через простой и контроль расширенного IP - доступ, перечисляет (ACL) (IP-адреса, порты TCP/UDP, IP Precedence)

  • Трафик, классифицированный группой QoS (внутренняя метка пакета применилась в восходящем направлении Согласованной скоростью доступа - CAR или QoS Policy Propagation - QPPB),

Когда средний размер пакета составляет 250 байтов или больше, и при использовании VIP2-50 или лучше с 8M статическое ОЗУ (SRAM), DTS поддерживает до 200 очередей формы на VIP, поддерживающий до скоростей OC-3. В отличие от обычной топологии формирование трафика (GTS), DTS не требует, чтобы была включена взвешенная организация очередей (WFQ). Вместо этого DTS использует организацию очереди с весами или распределенный первым прибыл, первым обслужен (FIFO) для сформированной очереди.

Специфические особенности платформы

Эта таблица описывает, как настроить TS в зависимости от платформы - в основном иллюстрирующий, что функция является значительной для современных платформ:

  Серии 12000 Серия 7500 Платформы 7200, 3600, 2600 и другие Non-VIP
Поддерживаемые механизмы управления DTS DTS GTS или Frame Relay TS
Команда конфигурирования команда shape в карте политики команда shape в карте политики скорость трафика или frame-relay traffic-shaping на основном интерфейсе, и с FRTS - команды настройки класса сопоставления для определения параметров формирования трафика
Требует распределенной Cisco Express Forwarding (dCEF) По умолчанию является CEF Да (проверка с помощью команды show cef linecard) Нет

Примечания DTS серии 7500

На Cisco серии 7500 теперь заблокирована возможность настроить Frame Relay Traffic Shaping (FRTS) с помощью команды frame-relay traffic-shaping, так как FRTS выполняется на RSP в нераспределенном режиме. С dCEF и FRTS, смежность "избыточного направления" CEF заставляет все пакеты быть быстро коммутированными RSP, который является субоптимальным для максимальной скорости переадресации.

С Cisco Выпуск ПО IOS� 12.1 (5) T, политики QoS должны работать в распределенном режиме на VIP; маршрут/Коммутатор (RSP) - базирующееся QoS больше не поддерживается. Поэтому необходимо использовать команду формы и другие команды Интерфейса командной строки Модульного QoS (MQC) для осуществления DTS для интерфейсов на VIP на Cisco серии 7500.

В то время как программное обеспечение Cisco IOS версии 12.1(2)T представило поддержку очередей с низкой задержкой (LLQ) на платформах кроме Cisco серии 7500, распределенный LLQ (dLLQ) был представлен в 12.1 (5) T на VIP. Версия для распространения улучшает производительность этой функции. Можно определить уникальную служебную политику для каждого идентификатора канала связи (DLCI). Вы не должны использовать класс сопоставления и можете применить команду service-policy непосредственно к подинтерфейсу или DLCI. Однако Cisco рекомендует настроить dLLQ в классе сопоставления.

Когда применение распределило FRF.12 (фрагментация) Интерфейсу Frame Relay, необходимо определить класс сопоставления и применить политику обслуживания под классом сопоставления. FRF.12 был представлен в версии программного обеспечения Cisco IOS 12.0 (4) T и расширен на Cisco 805, 1600, 1700, 2500, 4500, и 4700 платформ маршрутизатора как от версии программного обеспечения Cisco IOS 12 1 (2) T. Для дополнительных сведений обратитесь к Поддержке FRF.12 на Дополнительных Платформах.

Примечания DTS IP - маршрутизатора "серии 12000"

На быстрой коммутации серии 12000 и коммутации в контексте процесса не опции. Если префикс получателя не может быть решен к записи переадресации в карте входной линии (LC) таблицы, пакет отброшен. Только пакеты, совпадающие с подобранной смежностью, плывутся на плоскодонке к Гигабитному процессору маршрутизации (GRP). Кроме того, на этих 12000, ЦПУ LC не будет пакеты избыточного направления к GRP для функций, и LC передает недостижимый Протокол ICMP (как долго, поскольку команда no ip unreachables не настроена). На этих 12000 единственный трафик, плывший на плоскодонке к GRP, является пакетами, предназначенными к интерфейсу на маршрутизаторе или пакетах из источника от маршрутизатора. Для получения дополнительной информации обратитесь к тому, Какие функции Качества обслуживания (QoS) доступны для IP - маршрутизатора "серии 12000"?

Настройка

Используйте первые два шага для настройки DTS на на основе VIP Интерфейсах Frame Relay (серии 7500):

  1. Используйте эту команду для включения dCEF:

    router(config)#ip cef distributed
    
  2. Гарантируйте, что интерфейс Frame Relay включен для распределенной коммутации:

    router(config-if)#interface serial 2/0/0
    router(config-if)#ip route-cache distributed
    router#show ip interface serial 2/0/0
    Serial8/0/0 is up, line protocol is up
      Internet address is 64.0.0.2/24
      Broadcast address is 255.255.255.255
      ICMP redirects are always sent
      ICMP unreachables are always sent
      ICMP mask replies are never sent
      IP fast switching is enabled
      IP fast switching on the same interface is disabled
      IP Flow switching is disabled
      IP CEF switching is enabled
      IP Distributed switching is enabled
      IP Fast switching turbo vector
      IP CEF switching with tag imposition turbo vector
      IP multicast fast switching is enabled
      IP multicast distributed fast switching is disabled
      IP route-cache flags are Fast, Distributed, CEF
      Router Discovery is disabled
      IP output packet accounting is disabled
  3. Создайте класс трафика. (Требуемый)

  4. Настройте политику трафика DTS. (Требуемый)

  5. Подключите политику трафика и включите DTS. (Требуемый)

  6. Контролируйте и поддержите DTS. Дополнительно

Примечание: Используйте Средство поиска команд Command Lookup Tool (только зарегистрированные клиенты) для получения дополнительной информации о командах, используемых в этом документе.

Создайте класс трафика

Первый шаг к включению любой функции с помощью Modular QoS CLI должен создать класс трафика.

Маршрутизатор (config) #class-map [match-any | match-all] class-name — Задает название и составят ли кто-либо из критериев соответствие.

Для получения информации о Modular QoS CLI и процедуре для создания класса трафика, сошлитесь на Обзор Модульного интерфейса командной строки для обеспечения качества обслуживания.

Настройте политику трафика DTS

Необходимо настроить политику трафика для включения DTS. Можно настроить политику трафика для стольких классов, сколько определены на маршрутизаторе максимум до 256.

Для настройки политики трафика используйте команду policy-map, начинающую в режиме глобальной конфигурации задавать название политики трафика, затем использовать класс и формировать команды настройки для настройки названия класса трафика и формирования трафика.

  1. Маршрутизатор (config) #policy-map policy-name — Задает название политики трафика, которая будет создана.

  2. Маршрутизатор (pmap config) #class class-name — Задает название предопределенного класса трафика, включенного в политику трафика. Класс был определен в предыдущем шаге этого процесса.

  3. Маршрутизатор (config-pmap-c) #shape {среднее число | пик} cir [до н.э] [быть] — Задает формирование трафика пиковой скорости или среднее число.

Трафик направлен к классу по умолчанию политики трафика, если условия соответствия никаких других классов не удовлетворяет, политика которых определена в политике трафика.

Подключите политику трафика и включите DTS

Используйте эту команду в интерфейсе (или класс сопоставления) режим конфигурации для приложения политики трафика к интерфейсу, подинтерфейсу или классу сопоставления и для включения DTS на интерфейсе:

  • Маршрутизатор (config-if) #service-policy выходные данные policy-name — Включает DTS и подключает политику указанного потока данных к интерфейсу или классу сопоставления.

Примечание: Приложениям dLLQ и FRF.12 строго рекомендуют примениться к политике обслуживания класс frame-relay map.

Отнеситесь для Frame Relay Traffic Shaping с Распределенными системами QoS на Cisco серии 7500 для получения дополнительной информации о фрагментации.

Контролируйте и поддержите DTS

Используйте эти команды в Режиме EXEC, чтобы контролировать и поддержать функцию DTS:

  • Show interface Router# [interface-name] форма — Отображает подробный статус формирования трафика.

  • Router# показывают policy-name политики — Отображает конфигурацию всех классов, составляющих политику указанного потока данных.

  • Router# показывают, что class-name класса policy-name политики — Отображает конфигурацию заданного класса политики указанного потока данных.

Для получения дополнительной информации о командах мониторинга QoS, обратитесь к Пониманию Счетчиков пакетов в Выходных данных show policy-map interface.

Примеры конфигураций

DTS на основном интерфейсе

В данном примере трафик, который выходит на интерфейсе pos1/0/0, сформирован по курсу 10Mbits/sec.

router(config)#class-map class-interface-all

router(config-cmap)#match any

router(config-cmap)#exit

router(config)#policy-map DTS-interface-all-action
router(config-pmap)#class class-interface-all

router(config-pmap-c)#shape average 10000000 
router(config-pmap-c)#exit

router(config)#interface pos1/0/0

router(config-if)#service-policy output DTS-interface-all-action

Основанный на классе DTS на основном интерфейсе

В данном примере созданы два класса, и условия соответствия определены на основе номера списка доступа. Трафик, который выходит на интерфейсе fd4/0/0 и совпадает с критериями в списке доступа 10, сформирован к 16 Мбит/с. Трафик, который совпадает с критериями в списке доступа 20, сформирован к 8 Мбит/с.

router(config)#access-list 10 permit 171.69.0.0

router(config)#access-list 20 permit 192.168.0.0

router(config)#class-map class1

router(config-cmap)#match access-group 10

router(config-cmap)#exit

router(config)#class-map class2

router(config-cmap)#match access-group 20

router(config-cmap)#exit

router(config)#policy-map DTS-interface-class-action
router(config-pmap)#class class1

router(config-pmap-c)#shape average 16000000

router(config-pmap-c)#exit

router(config-pmap)#class class2

router(config-pmap-c)#shape average 8000000

router(config-pmap-c)#exit

router(config-pmap)#interface fd4/0/0

router(config-if)#service-policy output DTS-interface-class-action

Примечание: IP-адреса в этой конфигурации являются примерами только.

Для примеров дополнительной настройки обратитесь к Distributed Traffic Shaping Настройки.

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Интерфейс VIP, настроенный с Инкапсуляцией Frame Relay, мог бы завершиться катастрофическим отказом с ошибкой шины, если это применяет стратегию обслуживания, в то время как интерфейс передает трафик. Эта проблема решена в различных версиях программного обеспечения Cisco IOS (идентификатор ошибки Cisco CSCdt88568). Для получения дополнительной информации об этом ddts и дополнительных дефектах, обратитесь к инструментам поддержки Cisco и Ресурсам или Bug Toolkit (только зарегистрированные клиенты).

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 22600