Коммутация LAN : EtherChannel

Установите Второй уровень канала Ethernet, транкинг между серийными коммутаторами 2900XL/3500XL/2950 и коммутаторами Catalyst, которые работают с программным обеспечением Cisco IOS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (29 июля 2008) | Английский (20 октября 2015) | Отзыв


Содержание

DTP

Введение

Этот документ предоставляет примеры конфигурации на IEEE 802.1Q/Inter-Switch Ссылка (ISL) транкинг и Уровень 2 (L2) EtherChannel между Cisco Catalyst 2900 XL/3500 XL или Коммутаторы серии Catalyst 2950 и коммутатором Catalyst 6500/6000, который выполняет Cisco программное обеспечение IOS�. В данном примере также можно использовать коммутатор Catalyst 4500/4000 под управлением ПО Cisco IOS вместо Catalyst 6500/6000. В данном документе рассмотрены наиболее важные аспекты настройки магистрального соединения и передачи данных по каналу между коммутаторами. В документе также приведены примеры конфигураций.

В данном примере четыре порта Fast Ethernet каждого коммутатора соединены с помощью магистрального соединения и сгруппированы в каналы Fast EtherChannel (FEC). Для 3500 XL ISL использовался протокол магистрального соединения, а для примера 2950 использовался 802.1Q.

Примечание: Catalyst 2950 не поддерживает Транкинг ISL. Вместо этого, используйте trunking 802.1Q.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Для создания данных примеров в лабораторной среде использовались данные коммутаторы с ненастроенной конфигурацией:

  • Коммутатор Catalyst 3548 XL под управлением ПО Cisco IOS 12.0(5)WC2

  • Коммутатор Catalyst 2950-24 под управлением ПО Cisco IOS 12.1(6)EA2c

  • Коммутатор Catalyst 6509 с модулем Supervisor Engine II под управлением ПО Cisco IOS 12.1(11b)E

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

DTP

Магистральное соединение между устройствами может быть настроено статически или с помощью протокола DTP. Протокол DTP обеспечивает подключение обоих устройств с согласованием параметров магистрального соединения перед фактической установкой магистрального соединения. Конфигурируемые режимы ПО Cisco IOS коммутируемых портов (магистральных соединений) включают в себя: динамический (порт работает в режиме доступа или в режиме магистрального соединения), магистральное соединение (только магистральное соединение) и режим доступа (порт доступа без поддержки магистрального соединения). Наиболее часто используются параметры комбинированного режима на обоих концах статической (без согласования по DTP) магистрали – "trunk-trunk". Для динамических транков (с согласованием DTP) обычной настройкой является dynamic-dynamic. Допустимы также другие комбинации, но они не рассматриваются в данном документе. При использовании магистрального соединения между коммутатором, поддерживающим протокол агрегации портов (PAgP), и устройством, не поддерживающим протокол PagP, режим магистрального соединения должен быть включен.

Примечание: Большинство маршрутизаторов Cisco и некоторые Коммутаторы Catalyst не поддерживают DTP и требуют статической конфигурации транкинга. Например, маршрутизаторы Cisco Catalyst XL, Catalyst 2948G-L3, Catalyst 4908G-L3, Catalyst 8500, серии 2/3/4/7xxx и другие не поддерживают протокол DTP, и в таких случаях необходима настройка статического магистрального соединения.

Обсуждение 802.1q собственной VLAN

При использовании магистрального соединения 802.1Q применяется вставка 4-байтовое поле тега 802.1Q в рассылаемые по магистрали кадры, содержащие информацию о VLAN. Тег 802.1Q вставляется в каждый кадр, передаваемый по магистрали, за исключением кадров в стандартной VLAN, которые передаются без тегов. В большинстве случаев необходимо совпадение стандартной VLAN на обоих концах магистрали, за исключением редких случаев специальных требования к конфигурации, но они не рассматриваются в данном документе. Если стандартные сети VLAN не соответствуют друг другу, коммутатор заносит в журнал сообщения протокола CDP с указанием несоответствия. Хотя это исправимо, такая настройка приводит к тому, что две разные стандартные VLAN объединяются в один большой домен широковещательной рассылки L2 (VLAN). Эти две VLAN пытаются рассчитать одну общую топологию STP для стандартных виртуальных локальных сетей с мостовым соединением, что в итоге может привести к превышению максимального поддерживаемого диаметра STP.

Примечание: Существует особый случай, когда соседний узел или стороннее устройство требуют, чтобы были теговыми все VLAN. Если это произойдет, можно применить обходной прием для создания фиктивной VLAN и настроить ее как собственную VLAN. Все необходимые сети VLAN буду помечены, а данные через них будут пересылаться с помощью магистрали соседним или сторонним устройствам. Catalyst 6500 под управлением ПО Cisco IOS версии 12.1.11bEX, 12.1.13E и более поздних версий поддерживает возможность магистрального соединения 802.1Q, которое позволяет помечать весь трафик VLAN (в том числе и стандартной VLAN). В режиме глобального конфигурирования необходимо ввести команду vlan dot1q tag native. На коммутаторах Catalyst 4500/4000 под управлением ПО Cisco IOS команда vlan dot1q tag native изначально поддерживалась ПО Cisco IOS версии 12.2(18)EW.

PAgP

Гигабитные каналы EtherChannels (GECs) и FECs между коммутаторами могут быть настроены статически или динамически с помощью PAgP. Протокол PAgP обеспечивает подключение обоих устройств с согласованием параметров перед фактическим формированием канала. Режим настройки PAgP включает в себя: desirable (порт инициирует согласование каналов), auto (по умолчанию, порт не инициирует согласование, но реагирует на согласование с другого конца) и on (устанавливает порт на канал в безусловном режиме, обмен кадрами PAgP не поддерживается). Для соединения между коммутатором, поддерживающим PagP, и устройством, не поддерживающим PagP, необходимо, чтобы модем был включен, для создания канала.

On-on – наиболее часто используемый комбинированный режим для двух концов статического (без согласования PAgP) канала. Для динамических каналов (согласованных с PAgP) стандартными настройками являются desirable-desirable или desirable-auto. Подключенные порты, настроенные в режиме desirable, обеспечивают согласование каналов и проверку перед началом передачи данных по каналу, а также и проверку, не занят ли канал. Из-за дополнительных мер безопасности, предоставляемых PAgP, такая конфигурация рекомендуется, если оба подключенных коммутатора поддерживают функцию PAgP.

Примечание: PAgP имеет некоторые преднамеренные ограничения конфигурации. Для согласования портов каналы должны иметь одинаковую скорость, дуплексный режим, инкапсуляцию магистрального соединения и настройки VLAN. Также алгоритм балансировки нагрузки каналов в соединениях может быть перенастроен на определенных платформах.

Примечание: EtherChannel, как полагают, является одним уникальным портом STP, как только это произошло. Поэтому, чтобы избежать несогласованности протокола STP при настройке несогласованного канала, рекомендуется выполнить следующие действия:

  1. Отключите все порты канала для настройки на обоих концах.

  2. Выполните настройку на обоих концах.

  3. Снова включите все порты.

Попытка настроить этот канал при активированных портах может привести к временной несогласованности STP и (или) появлению петель. Описанные выше шаги можно выполнить, только если не используется PAgP.

Catalyst 2900XL/3500XL

Коммутаторы серии Catalyst 2900 XL/ 3500 XL не поддерживают DTP и PagP, поэтому требуют статической настройки магистрали и канала. Дополнительные сведения см. в примечании выше. Коммутаторы Catalyst 2900 XL/ 3500 XL поддерживают инкапсуляцию для магистральных соединений ISL и 802.1Q. Дополнительные сведения см. в документе:

ISL поддерживается ПО Cisco IOS версии 11.2(8)SA4 и более поздних версий. 802.1Q поддерживается ПО Cisco IOS версии 11.2(8)SA5 и более поздних версий.

На Catalyst 2900XL под управлением ПО Cisco IOS Software 11.2(8)SA1 или 11.2(8)SA2 разрешено использовать четыре канала EtherChannel (групп портов) для одного коммутатора и неограниченное количество портов в одной группе. Балансировка нагрузки трафика по соединениям в канале всегда основана на адресе назначения. Анализатор коммутируемых портов (SPAN) и функции защиты на уровне портов не поддерживаются.

В коммутаторах Catalyst 2900 XL под управлением Cisco IOS 11.2(8)SA3 или более поздних версий, Catalyst 3500 XL под управлением Cisco IOS 11.2(8)SA6 или более поздних версий, а также в Catalyst 2950 балансировка нагрузки по соединениям в канале основана на MAC-адресе источника или назначения. Источник задан по умолчанию. Пересылка на основе источника позволяет использовать в FEC (группа портов) до восьми портов. Перенаправление на основе назначение позволяет иметь неограниченного количество портов в группе портов. Можно настроить до 12 групп портов на одном коммутаторе, причем это могут быть группы как портов-источников, так и портов назначения. Анализатор коммутируемых портов (SPAN) и функции защиты на уровне портов не поддерживаются.

Catalyst 2950

Коммутаторы Catalyst 2950 поддерживают только магистральное соединение 802.1Q, но не поддерживают ISL. Коммутаторы Catalyst 2950 поддерживают протокол DTP, динамическое магистральное соединение PAgP, согласование каналов в Cisco IOS 12.1 и статические режимы только в Cisco IOS 12.0. Для распределения нагрузки EtherChannel можно использовать пересылку на исходный или конечный MAC-адрес. Для настройки способа балансировки нагрузки выполните команду глобальной настройки port-channel load-balance. Данные коммутаторы поддерживают до восьми портов коммутаторов на канал.

Коммутаторы Catalyst 6500 под управлением ПО Cisco IOS

Коммутаторы Catalyst 6500 под управлением ПО Cisco IOS поддерживают конфигурации канала EtherChannel уровня 2 (L2) (порт коммутации) и уровня 3 (L3) (маршрутизируемый порт). Коммутатор Catalyst 6500/6000 поддерживает максимум 64 канала EtherChannel (256 с ПО Cisco IOS версии 12.1(2)E и более ранних версий). Для любого модуля коммутатора Catalyst 6000 можно организовывать канал EtherChannel с максимум восемью портами LAN с совместимой конфигурацией. Исключением являются модули, оснащенные платой DFC (Плата цифровых функций), например, WS-X6816 и др., которые в настоящее время поддерживают использование каналом уровня 2 только портов этой же DFC-платы. Таким образом, канал L3 может быть настроен на любых модулях, оснащенных DFC. На коммутаторы Catalyst 6500/6000 под управлением ПО Cisco IOS 12.1(11b)EX и более поздних версий данное ограничение не распространяется. В данном документе рассматривается настройка канала L2 EtherChannel.

Коммутатор Catalyst 6500/6000 под управлением Cisco IOS позволяет настраивать балансировку нагрузки EtherChannel для использования MAC-адресов, IP-адресов и информации о порте уровня 4 (L4) любого отправителя, адресата или комбинации отправитель-адресат с помощью команды глобальной конфигурации port-channel load-balance. Значение по умолчанию установлено для использования функции хеширования между IP-адресами источника и назначения.

Коммутаторы Catalyst 6500/6000 поддерживают инкапсуляцию для группирования магистральных соединений в ISL и 802.1Q, а также DTP-протокол. Для получения подробных сведений о возможностях порта введите команду show interface interface_id capabilities.

Коммутаторы Catalyst 4000 под управлением ПО Cisco IOS

Коммутаторы Catalyst 4000 под управлением ПО Cisco IOS (с модулями управления Supervisor Engine III и IV) поддерживают конфигурации канала EtherChannel уровня (L2) (порт коммутации) и 3 уровня (L3) (маршрутизируемый порт). Коммутаторы серии Catalyst 4000 поддерживают максимум 64 канала EtherChannels. Для любого модуля и между модулями коммутатора Catalyst 4000 можно организовать Ethernet-канал с максимум восемью Ethernet-интерфейсами с совместимой конфигурацией. На всех каналах EtherChannel должны быть настроены интерфейсы L2 или L3, причем с одинаковой скоростью.

Коммутатор Catalyst 4000 под управлением Cisco IOS позволяет настраивать балансировку нагрузки EtherChannel для использования MAC-адресов, IP-адресов и информации о порте уровня 4 (L4) любого отправителя, адресата или комбинации отправитель-адресат с помощью команды глобальной конфигурации port-channel load-balance. Значение по умолчанию установлено для использования функции хеширования между IP-адресами источника и назначения.

Коммутаторы Catalyst 4000 под управлением ПО Cisco IOS поддерживают инкапсуляцию магистральных соединений ISL и 802.1Q, а также DTP-протокол. На определенных модулях межкоммутаторное соединение (ISL) недоступно. Полный список модулей см. в подразделе Общие сведения о магистральных соединениях VLAN раздела Настройка интерфейсов Ethernet второго уровня. Для получения подробных сведений о возможностях порта новых версий ПО необходимо ввести команду show interface capabilities. В настоящий момент данная команда недоступна.

Конфигурация 1: Магистральное соединение ISL и EtherChannel между коммутаторами Catalyst 3500 XL и Catalyst 6500 под управлением ПО Cisco IOS

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

Данная конфигурация использует следующую настройку сети:

/image/gif/paws/22422/144-a.gif

Catalyst 3524XL

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel 
!--- and then enable them back when the configuration is complete on both switches.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!

!--- Output suppressed.


!
interface FastEthernet0/17
port group 1

!--- Assigned port to port channel 1.


switchport trunk encapsulation isl

!--- Configured the port to use the trunking encapsulation ISL.


switchport mode trunk

!--- Configured the port to be in trunking mode.


!
interface FastEthernet0/18

!--- Repeated the trunk and channel configuration.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!

!--- Output suppressed.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500 (ПО Cisco IOS)

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel, 
!--- and then enable them back when the configuration is complete on both switches.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-cpu  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q

!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


no ip address 
channel-group 1 mode on

!--- Configured the port to participate in port channel 1 with channel mode on.


! 
Interface FastEthernet4/3

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/4

!--- Repeated the trunk and channel configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/5

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500# 

Конфигурация 2: магистральное соединение 802.1Q и EtherChannel с использованием протоколов DTP и PAgP между коммутаторами Catalyst 2950 и Catalyst 6500 под управлением ПО Cisco IOS

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

Данная конфигурация использует следующую настройку сети:

/image/gif/paws/22422/144-b.gif

Catalyst 2950

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1 
switchport mode trunk
!
interface FastEthernet0/1
!         
interface FastEthernet0/2 
switchport mode trunk

!--- Configured port to be in trunking mode.


channel-group 1 mode desirable

!--- Configured port to participate in PAgP-negotiated port channel 1.


!
interface FastEthernet0/3

!--- Repeated trunk and channel configuration.
 

switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/4

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/5

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/6
!

!--- Output suppressed.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1 
ip address 10.10.10.1 255.255.255.0 
no ip route-cache
!
ip http server
!
line con 0 
transport input none
line vty 5 15
!
end 
Cat2950#

Catalyst 6500 (ПО Cisco IOS)

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-CPU  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q


!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


No ip address 
channel-group 1 mode desirable

!--- Configured port to participate in port channel 1 with channel mode desirable.


! 
Interface FastEthernet4/3

!--- Repeated trunk and channel configuration. 


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/4

!--- Repeated trunk and channel configuration.
  

switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/5

!--- Repeated trunk and channel configuration. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500# 

Проверка. : Магистральное соединение ISL

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Catalyst 3500XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

Примечание: Если у вас есть восьмипортовый EtherChannel, выполнение команды show etherchannel summary может завершиться катастрофическим отказом коммутатор при выполнении Cisco IOS Software Release, который является ранее, чем Cisco IOS Software Release 12.0 (5) WC5.

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500 (ПО Cisco IOS)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)   

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

Проверка. : Транкирование 802.1q

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL  
0     00     Fa0/3    desirable-SL  
0     00     Fa0/4    desirable-SL  
0     00     Fa0/5    desirable-SL  

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance 
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Catalyst 6500 (ПО Cisco IOS)

Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL  
3     22     Fa4/3    desirable-SL  
0     44     Fa4/4    desirable-SL  
2     88     Fa4/5    desirable-SL  

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Отсутствует передача трафика на магистрали 802.1Q

Возможная причина проблемы:

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 22422