Голосовая связь : H.323

Средства VoIP QoS для протокола ретрансляции кадров (Frame Relay) при взаимодействии сети ATM с LLQ, PPP LFI и cRTP

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе приведен пример конфигурации сети VoIP с использованием передачи многоканальных пакетов PPP за счет взаимодействия ATM и Frame Relay (VoIP с использованием MLPoATM/MLPoFR). Центром примеров конфигурации является условие Качества обслуживания (QoS) для надлежащей поддержки голоса через ATM / Frame Relay взаимодействовал глобальная сеть (WAN). Примеры конфигурации также используют Сжатый протокол реального времени (cRTP), который поддерживался на ATM начиная с Cisco Выпуск ПО IOS� 12.2 (2) T.

Документ может быть считан автономный из руководства по конфигурации, примеров конфигурации и команд проверки, чтобы использоваться в построении сети. Также предоставляются некоторые общие сведения по вопросам, связанным с использованием взаимодействия ATM / Frame Relay. См. эти документы для получения дополнительной информации о QoS для VoIP over Frame Relay или PPP:

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

Необходимо быть знакомы с этими областями технологии:

  • Списки управления доступом

  • Постоянные виртуальные каналы (PVC) ATM

  • Постоянные виртуальные каналы Frame Relay (идентификаторы каналов передачи данных (DLCI))

  • Управление пропускной способностью

  • LLQ

  • LFI

  • Виртуальные шаблоны и интерфейсы виртуального доступа

  • MLPPP

  • cRTP

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco 3640 как маршрутизатор ATM

  • Cisco 2620 как Маршрутизатор Frame Relay

  • Cisco IOS Software Release 12.2(8)T (IP Plus)

Примечание: Как общее указание, последняя Cisco IOS 12.2 отладочными релизами магистрали является рекомендуемый Cisco IOS Software Release для использования для MLPoATM/FR. Если cRTP используется, Cisco IOS Software Release 12.2T требуется на маршрутизаторе ATM.

Соответствующие функции были представлены в этих Cisco IOS Software Release:

  • Технология LFI была реализована в Cisco IOS Software Release 11.3.

  • LLQ впервые появилась в версии Cisco IOS Software Release 12.0(7)T.

  • LLQ через Frame Relay и ATM для каждой PVC были впервые предложены в Cisco IOS Software Release 12.1(2)T.

  • Многоканальное PPP LFI для виртуальных каналов Frame Relay и ATM реализовано в Cisco IOS Software Release 12.1(5)T.

  • cRTP через ATM был представлен в Cisco IOS Software Release 12.2(2)T.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Основные проблемы в обеспечении минимизированного предотвращения задержки и дрожания при сквозном соединении для VoIP через ATM / Frame Relay взаимодействовал, сеть:

  • Жесткий приоритет для голосового трафика (постановка в очередь с низкой задержкой (LLQ))

  • Фрагментация и чередование каналов (LFI)

  • Frame Relay Traffic Shaping для голоса

  • Формирование трафика ATM

Эти документы предоставляют удобные источники дальнейших общих сведений:

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/22383/voip-qos-fr-atm-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: Следует отметить, что в этой конфигурации, эти два маршрутизатора связаны встречно-параллельные по Frame Relay к межсетевому коммутатору ATM. Тем не менее, в большинстве топологий маршрутизаторы с поддержкой передачи голоса могут быть установлены в любой зоне сети. Обычно голосовые маршрутизаторы используют LAN-подключение к другим маршрутизаторам, подключенным к ATM/Frame WAN. В тех случаях маршрутизаторы, связанные с глобальной сетью (WAN), Frame Relay и ATM, должны быть настроены для LLQ, LFI и MLPPP, таким образом, они могут предоставить QoS, а не голосовые шлюзы как показано в этих конфигурациях.

Маршрутизаторы, использующие ретрансляцию кадров

!--- Note: This configuration is commented and numbered 
!--- in the order that commands should be entered.


version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname FR
!
enable password cisco
!
username ATM password 0 cisco
voice-card 0
dspfarm
!
ip subnet-zero
!
!
!
!


!--- access-list 105 permit ip any any dscp ef specifies 
!--- that all traffic with Differentiated Services Code Point (DSCP)
!--- are set to 40 falls into this access-list.
!--- This class-map command defines a class of traffic called "voice".


access-list 105 permit ip any any dscp ef 
access-list 105 permit udp any any  range 16384 32767
access-list 105 permit ip any any precedence critical
!
class-map match-all voice 
match access-group 105
!

!         
!

!--- This policy-map command defines a policy for LLQ called "VoIP" and 
!--- maps the "voice" class to the "VOIP" policy.
!--- "priority" defines the amount of bandwidth reserved for the priority queue.
!--- "class-default" specifies that the default class is also mapped to this policy.  
!--- "fair-queue" specifies that all other traffic is served in the WFQ.


policy-map VOIP 
  class voice 
    priority 48 
  class class-default  
   fair-queue 


!--- Note: Although it is possible to queue various types of 
!--- real-time traffic to the priority queue, 
!--- Cisco recommends that you direct only voice traffic 
!--- to it. Real-time traffic such as video or voice
!--- could introduce variations in delay. Please note voice and 
!--- video should not be combined in the same PVC.
!--- (the priority queue is a First In First Out (FIFO) 
!--- queue). Voice traffic requires that delay be 
!--- nonvariable in order to avoid jitter.

!--- Note: The sum of the values for priority and 
!--- bandwidth statements needs to be less 
!--- than or equal to 75% of the link bandwidth. 
!--- Otherwise service-policy cannot be 
!--- assigned to the link. When configuring VoIP over a 
!--- 64 Kbps link to support two 
!--- voice calls, it is common to allocate more than 75% 
!--- (48 Kbps) of the link bandwidth to 
!--- the priority queue. In such cases, you can use the  
!--- max-reserved-bandwidth <#%> command in order to raise 
!--- available bandwidth to a value more than 75%.


!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Loopback0
 ip address 10.1.1.2 255.255.255.0
!
!
interface FastEthernet0/0
 ip address 172.17.111.16 255.255.255.224
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache
 no ip mroute-cache
 frame-relay traffic-shaping
!

!--- Choose the frame relay interface to be 
!--- associated with the virtual interface. The
!--- virtual template could equally have been associated 
!--- with the physical interface. 
!--- The "class mlp" associates the virtual template interface 
!--- defined in "interface Virtual-Template1" with a Frame Relay DLCI.
!--- Associates a Frame Relay map class with a DLCI.


interface Serial0/0.1 point-to-point 
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 16 ppp Virtual-Template1 
  class mlp 


!--- The interface command creates a virtual 
!--- template called Virtual-Template1. 
!--- A bandwidth of 64 Kbps is assigned to this 
!--- template interface. This bandwidth is used
!--- by Cisco IOS to calculate the data fragment size as noted regarding
!--- interleaving of PPP segments.

!--- "ip rtp header-compression"—cRTP is supported in an ATM/Frame Relay Interworking 
!--- environment. It requires Cisco IOS Software Release 12.2(2)T on the 
!--- ATM router.

!--- "service-policy output VOIP"—The VoIP policy created earlier is assigned 
!--- to this interface in the outbound direction.
 
!--- PPP multilink is enabled and the 
!--- maximum delay per segment is specified. This bandwidth is   
!--- used by Cisco IOS to calculate the data fragement size as noted.

!--- Interleaving of PPP segments is enabled, which allows 
!--- voice packets to be expedited. Voice  
!--- packets need only wait behind a single segment of 
!--- a previously queued data packet (for example, 10 ms 
!--- delay) rather than wait until the end of the 
!--- entire data packet. Cisco IOS calculates the  
!--- data fragment size using the following formula: 
!--- fragment size = delay x bandwidth/8

!
interface Virtual-Template1 
 bandwidth 64 
 ip unnumbered loopback0
 ip rtp header-compression 
 no ip route-cache
 load-interval 30
 max-reserved-bandwidth 99
 service-policy output VOIP 
 ppp multilink 
 ppp multilink fragment-delay 10 
 ppp multilink interleave 
!


!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
no ip http server
ip pim bidir-enable
!
!
!

!--- A map class called mlp is created.
!--- With "no frame-relay adaptive-shaping", adaptive
!--- shaping is disabled. You do not 
!--- want to exceed CIR and have voice packets
!--- possibly queued within the Frame Relay network. 
!--- Waiting for a BECN to resolve this 
!--- situation could result in poor voice quality.
!--- The frame-relay cir 64000 command forces the router to transmit 
!--- at the desired CIR rate rather than line
!--- rate for the port.
!--- "frame-relay bc 640" configures the Bc value to force the desired 
!--- Tc (shaping interval) value is 10 ms. 
!--- This formula should be used to determine 
!--- the Bc value to use: Tc = Bc/CIR. A 
!--- smaller Tc value reduces the interval a voice 
!--- packet has to wait to be sent.
!--- As in "frame-relay be 0", the Be value should be set to zero
!--- in order to avoid voice being sent as part of a burst
!--- that is not guaranteed by the Frame Relay network.


map-class frame-relay mlp

 no frame-relay adaptive-shaping
 frame-relay cir 64000  
 frame-relay bc 640 
 frame-relay be 0 


!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 123 voip
 destination-pattern 123
 session target ipv4:10.1.1.1
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad
!
dial-peer voice 456 pots
 destination-pattern 456
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
end

Маршрутизатор, подключенный к ATM

!--- Note: This configuration is commented only 
!--- where additional consideration is required from the 
!--- above configuration of the Frame Relay router.


version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname ATM
!
enable password cisco
!
username FR password 0 cisco
memory-size iomem 25
ip subnet-zero
!
!
!
access-list 105 permit ip any any dscp ef
access-list 105 permit udp any any  range 16384 32767
access-list 105 permit ip any any precedence critical
!
class-map match-all voice
 match access-group 105
!
!

!--- Note: Matching commands to the Frame Relay 
!--- router side of the network.


!
!
policy-map VOIP
  class voice
    priority 48
  class class-default
   fair-queue


!--- Note: Matching commands to the Frame Relay 
!--- router side of the network.


!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 2/0
 framing sf
 linecode ami
!
!
!
!
interface ATM0/0
 no ip address
 ip route-cache
 no atm ilmi-keepalive
!

!--- "interface ATM0/0.1 point-to-point" chooses the ATM subinterface.
!---  The physical interface could equally have been used.
!--- "pvc 10/100" creates an ATM PVC. 
!--- "cbr 64"—A VBR PVC has been defined on this example.
!--- This exapmle uses VBR non-realtime and the sustained 
!--- cell rate (SCR) should be equal to the peak
!--- cell rate (PCR)  in order to avoid bursting. 
!--- ATM cell tax and the possibility
!--- of ATM bandwidth expansion due to poor 
!--- fragment/cell alignment, means that it  
!--- cannot be assumed that the PCR/SCR on the ATM 
!--- side should equal the CIR of the Frame Relay side.
!--- Maintain the value of CIR on the Frame-Relay side to define 
!--- our SCR, in this case, 64 kbps. This value may in some networks
!--- require some fine-tuning as the CIR on the Frame side does not
!--- exactly match the SCR on the ATM but makes for a good-enough estimation
!--- for most purposes.
!--- Refer to Designing and Deploying
!--- Multilink PPP over Frame Relay and ATM
!--- for more information. 
!--- "encapsulation aal5snap" is required.
!--- "protocol ppp Virtual-Template1" associates the virtual 
!--- template with the ATM PVC.


interface ATM0/0.1 point-to-point
 ip route-cache
 pvc 10/100 
  cbr 64 
  encapsulation aal5snap 
  protocol ppp Virtual-Template1 


!
!
interface loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet3/0
 ip address 172.17.111.15 255.255.255.224
 half-duplex
!
interface Ethernet3/1
 no ip address
 shutdown
 half-duplex
!
interface Virtual-Template1
 bandwidth 64
 ip unnumbered loopback0
 ip rtp header-compression
 no ip route-cache
 load-interval 30
 max-reserved-bandwidth 99
 service-policy output VOIP
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave


!--- Note: The virtual template is created in 
!--- exactly the same way as for the
!--- Frame Relay router side of the network. 
!--- An additional consideration for
!--- the ATM router is that the fragment size 
!--- should be optimized to fit into
!--- an integral number of ATM cells. 
!--- Refer to Designing and Deploying
!--- Multilink PPP over Frame Relay and ATM 
!--- for more information on this issue.


!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
ip http server
ip pim bidir-enable
!
!
call rsvp-sync
!
voice-port 1/0/0
 description FXS
!
voice-port 1/0/1
!
voice-port 1/1/0
 description FXO
!
voice-port 1/1/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 456 voip
 destination-pattern 456
 session target ipv4:10.1.1.2
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad   
!
dial-peer voice 123 pots
 destination-pattern 123
 port 1/1/0
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
end

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Эти команды показа полезны в проверке рабочего состояния Реле ATM/Frame взаимодействующая среда, которая включает DLCI и статистику канала PVC, физическую и статус виртуального интерфейса, политика (QoS) приложение и сведения cRTP:

  • show ppp multilink interface interface-name – Проверяет, в каком положении находится пучок (up/down), какой из интерфейсов виртуального доступа является пучком (пучком MLPPP) и какие из них являются участниками (канал PPP). Эта команда также проверяет, если ячейки/кадры сбросов несущей (потерял фрагменты <> 0). Единственная допустимая потеря фрагмента — вызванная ошибками контроль циклическим избыточным кодом.

  • show user – отображает сведения о номерах, назначенных интерфейсу виртуального доступа. Выходные данные по этой команде или по команде show ppp multilink можно использовать для вывода статистики интерфейса или для очистки интерфейса.

  • show frame-relay pvc dlci — Отображает информацию, такие как параметры формирования трафика, значения фрагментации и отброшенные пакеты. С помощью этой команды также можно определить, был ли привязан к виртуальному интерфейсу физический.

  • show atm pvc pvc — Отображает все активные постоянные виртуальные каналы ATM и информацию о потоке данных.

  • команда show policy-map interface interface-name отображает все операции LLQ и любые сбросы в PQ. См. Понимание Счетчиков пакетов в выходных данных команды show policy-map interface для получения дополнительной информации о различных полях этой команды.

    Примечание: Организация сложных очередей всегда применяется к интерфейсу Virtual-Access2. Остальные интерфейсы используют очередь FIFO.

  • команда show ip rtp header-compression отображает статистику сжатия RTP-заголовков, если она настроена. Обратите внимание, что статистика относится к интерфейсу virtual-access2, который является групповым интерфейсом.

Примеры этих команд показывают здесь:

FR#show ppp multilink interface virtual-access 2
Virtual-Access2, bundle name is ATM
Bundle up for 00:22:42
0 lost fragments, 0 reordered, 0 unassigned
0 discarded, 0 lost received, 231/255 load
0x2E5 received sequence, 0x10C31 sent sequence
Member links: 1 (max not set, min not set)
Virtual-Access1, since 00:22:42, last rcvd seq 0002E4 160 weight

Эти выходные данные показывают show users на Маршрутизаторе Frame Relay.

FR#show users
Line User Host(s) Idle Location
67 vty 1 idle 00:00:00 10.1.1.1
Interface User Mode Idle Peer Address
Vi1 Virtual PPP (FR ) - 
Vi2 Virtual PPP (Bundle) 00:00:00 10.1.1.1
FR#

Эти выходные данные показывают show users на маршрутизаторе ATM.

ATM#show users 
Line User Host(s) Idle Location
131 vty 1 idle 00:00:00 64.104.207.95
Interface User Mode Idle Peer Address
Vi1 Virtual PPP (ATM ) - 
Vi2 Virtual PPP (Bundle) 00:00:02 10.1.1.2
ATM#

Эти выходные данные показывают команду show frame-relay pvc.

FR#show frame-relay pvc 16
 PVC Statistics for interface Serial0/0 (Frame Relay DTE)
 DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1
  
     input pkts 2301 output pkts 2295 in bytes 152266 
     out bytes 151891 dropped pkts 0 in FECN pkts 0 
     in BECN pkts 0 out FECN pkts 0 out BECN pkts 0 
     in DE pkts 0 out DE pkts 0 
     out bcast pkts 0 out bcast bytes 0 
     5 minute input rate 9000 bits/sec, 9 packets/sec
     5 minute output rate 9000 bits/sec, 9 packets/sec
     pvc create time 23:46:56, last time pvc status changed 00:22:56
     Bound to Virtual-Access1 (up, cloned from Virtual-Template1) 
     
!--- PPP link interface.

     cir 64000 bc 640 be 0 byte limit 80 interval 10 
     mincir 64000 byte increment 80 Adaptive Shaping none
     pkts 2296 bytes 152053 pkts delayed 9 bytes delayed 375
     shaping active 
     traffic shaping drops 0
     Queueing strategy: fifo
     Output queue 0/40, 0 drop, 0 dequeued
FR#

Эти выходные данные показывают команду show atm pvc 10/100 на маршрутизаторе ATM.

ATM#show atm pvc 10/100 
     ATM0/0.1: VCD: 1, VPI: 10, VCI: 100
     CBR, SusRate: 128
     AAL5-LLC/SNAP, etype:0x0, Flags: 0x820, VCmode: 0x0
     OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)
     OAM up retry count: 3, OAM down retry count: 5
     OAM Loopback status: OAM Disabled
     OAM VC state: Not Managed
     ILMI VC state: Not Managed
     InARP frequency: 15 minutes(s)
     Transmit priority 1
     InPkts: 729, OutPkts: 729, InBytes: 49700, OutBytes: 51158
     InPRoc: 0, OutPRoc: 729
     InFast: 729, OutFast: 0, InAS: 0, OutAS: 0
     InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total)
     CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, 
     CPIErrors: 0
     OAM cells received: 0
     F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
     F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
     OAM cells sent: 0
     F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
     F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
     OAM cell drops: 0
     Status: UP
   PPP: Virtual-Access2 from Virtual-Template1 
    
!--- MLPPP bundle interface.

ATM#

Это - policy-map показа на Маршрутизаторе Frame Relay.

FR#show policy-map interface Virtual-Access2
Service-policy output: VoIP
Class-map: voice (match-all)
15483 packets, 959502 bytes
30 second offered rate 24000 bps, drop rate 0 bps
Match: ip dscp 40 
Weighted Fair Queueing 
Strict Priority 

!--- LLQ Strict Priority Queue for voice.

Output Queue: Conversation 24 
Bandwidth 48(kbps) Burst 1500 (Bytes)
(pkts matched/bytes matched) 15536/962784
(total drops/bytes drops) 0/0 

!--- No drops in the voice queue.

Class-map: class-default (match-any)
139 packets, 19481 bytes
30 second offered rate 1000 bps, drop rate 0 bps
Match: any 
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 
(total queued/total drops/no-buffer drops) 0/0/0

Эти выходные данные показывают команду show policy map на маршрутизаторе ATM.

ATM#show policy-map interface Virtual-Access2 
Service-policy output: VOIP
Class-map: voice (match-all)
11293 packets, 699718 bytes
30 second offered rate 24000 bps, drop rate 0 bps
Match: ip dscp 40 
Weighted Fair Queueing
Strict Priority 

!--- LLQ Strict Priority Queue for voice.

Output Queue: Conversation 24 
Bandwidth 48 (kbps) Burst 1500 (Bytes)
(pkts matched/bytes matched) 11352/703376
(total drops/bytes drops) 0/0 

!--- No drops in the voice queue.

Class-map: class-default (match-any)
63 packets, 9772 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any 
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 
(total queued/total drops/no-buffer drops) 0/0/0
ATM#

Эти выходные данные показывают команду show ip rtp header-compression на Маршрутизаторе Frame Relay.

FR#show ip rtp header-compression
RTP/UDP/IP header compression statistics:
Interface Virtual-Access1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions

Interface Virtual-Template1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions

Interface Virtual-Access2:
Rcvd: 23682 total, 23681 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 327 total, 233 compressed,
8821 bytes saved, 5159 bytes sent
2.70 efficiency improvement factor
Connect: 16 rx slots, 16 tx slots,
0 long searches, 94 misses 0 collisions
71% hit ratio, five minute miss rate 0 misses/sec, 0 max

Эти выходные данные показывают команду show ip rtp header-compression на маршрутизаторе ATM.

ATM#show ip rtp header-compression
RTP/UDP/IP header compression statistics:
Interface Virtual-Access1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions, 0 negative cache hits

Interface Virtual-Template1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions, 0 negative cache hits

Interface Virtual-Access2:
Rcvd: 283 total, 233 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 25341 total, 25340 compressed,
955537 bytes saved, 564463 bytes sent
2.69 efficiency improvement factor
Connect: 16 rx slots, 16 tx slots,
0 long searches, 1 misses 0 collisions, 100 negative cache hits
99% hit ratio, five minute miss rate 0 misses/sec, 0 max

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Этот раздел предоставляет некоторые отладки в качестве примера, предназначенные, чтобы разъяснить LFI MLP и служить примерами функционирования для устранения проблем конфигурации.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • команда debug ppp negotiation иллюстрирует процесс клонирования двух интерфейсов виртуального доступа для отображения отдельных и групповых PPP-соединений. Интерфейсом виртуального доступа 1 (Vi1) является Канал "PPP", с которым (ATM или кадр) связан PVC. Виртуальный интерфейс 2 (Vi2) – пакетный канал PPP, к которому применены политики ведения очередей.

  • debug ppp multilink fragment – иллюстрирует концепцию чередования больших пакетов данных с меньшими голосовыми пакетами. Чередование происходит на интерфейсе Vi2 (уровень MLP), так как групповому интерфейсу назначили организацию сложной очереди.

Это - выходные данные команды для команды debug ppp negotiation.

FR(config-if)#no shut
FR(config-if)#^Z
FR#
FR#
6d23h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Mar 7 23:20:42.842: Vi1 PPP: Treating connection as 
a dedicated line 

!--- Vi1 is the PPP link to which the PVC is bound.

*Mar 7 23:20:42.842: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Mar 7 23:20:42.842: Vi1 LCP: O CONFREQ [Closed] id 197 len 19
*Mar 7 23:20:42.842: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2)
*Mar 7 23:20:42.842: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.842: Vi1 LCP: EndpointDisc 1 FR (0x1305014652) 

!--- Router FR at one end of PPP discovery.

*Mar 7 23:20:42.858: Vi1 LCP: I CONFREQ [REQsent] id 14 len 20
*Mar 7 23:20:42.858: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4)
*Mar 7 23:20:42.858: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.858: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D) 

!--- Router ATM at the other end of PPP discovery.

*Mar 7 23:20:42.858: Vi1 LCP: O CONFACK [REQsent] id 14 len 20

*Mar 7 23:20:42.862: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4)
*Mar 7 23:20:42.862: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.862: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D)
*Mar 7 23:20:42.870: Vi1 LCP: I CONFACK [ACKsent] id 197 len 19
*Mar 7 23:20:42.870: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2)
*Mar 7 23:20:42.870: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.870: Vi1 LCP: EndpointDisc 1 FR (0x1305014652)
*Mar 7 23:20:42.870: Vi1 LCP: State is Open
*Mar 7 23:20:42.870: Vi1 PPP: Phase is FORWARDING, Attempting Forward
*Mar 7 23:20:42.874: Vi1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar 7 23:20:42.874: Vi1 PPP: Phase is VIRTUALIZED
*Mar 7 23:20:42.942: Vi2 PPP: Phase is DOWN, Setup
*Mar 7 23:20:43.222: Vi1 IPCP: Packet buffered while building MLP bundle interface
6d23h: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up 

!--- MLP level queuing.

*Mar 7 23:20:43.226: Vi2 PPP: Treating connection as a dedicated line
*Mar 7 23:20:43.226: Vi2 PPP: Phase is ESTABLISHING, Active Open
*Mar 7 23:20:43.226: Vi2 LCP: O CONFREQ [Closed] id 1 len 19
*Mar 7 23:20:43.226: Vi2 LCP: MagicNumber 0xF4412A53 (0x0506F4412A53)
*Mar 7 23:20:43.226: Vi2 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:43.230: Vi2 LCP: EndpointDisc 1 FR (0x1305014652)
*Mar 7 23:20:43.230: Vi2 MLP: 
Added first link Vi1 to bundle ATM 

!--- PVCs make up the bundle.

*Mar 7 23:20:43.230: Vi2 PPP: Phase is UP
*Mar 7 23:20:43.230: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102)
*Mar 7 23:20:43.234: Vi2 PPP: Pending ncpQ size is 1
*Mar 7 23:20:43.234: Vi1 IPCP: Redirect packet to Vi1
*Mar 7 23:20:43.234: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Mar 7 23:20:43.234: Vi2 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Mar 7 23:20:43.266: Vi2 IPCP: I CONFACK [ACKsent] id 1 len 10
*Mar 7 23:20:43.266: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102)
*Mar 7 23:20:43.266: Vi2 IPCP: State is Open
*Mar 7 23:20:43.266: Vi2 IPCP: Install route to 10.1.1.1
*Mar 7 23:20:43.270: Vi2 IPCP: Add link info for cef entry 10.1.1.1

Эти выходные данные команды от команды debug ppp multilink fragment.

*Mar 7 23:16:08.034: Vi2 MLP: 
Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi1 MLP: O frag 0000829B size 160 
*Mar 7 23:16:08.042: Vi1 MLP: I ppp IP (0021) size 64 direct
*Mar 7 23:16:08.046: Vi1 MLP: I ppp IP (0021) size 64 direct

Дополнительные сведения


Document ID: 22383