Качество обслуживания (QoS) : Политики QoS

Настройка CBWFQ на ПВК в сети Frame Relay

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (11 августа 2008) | Английский (22 апреля 2015) | Отзыв


Содержание


Введение

В этом документе представлены примеры конфигураций для настройки объективной организации очереди с весовыми коэффициентами на основе классов (CBWFQ) на интерфейсе Frame Relay. CBWFQ включается с помощью команды bandwidth, настроенной в карте политик с командами модульного интерфейса командной строки для обеспечения качества обслуживания (QoS CLI).

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

CBWFQ поддерживается со следующей Cisco Выпуски ПО IOS� в зависимости от платформы:

  • Ciscox серии 7500 с многоцелевыми интерфейсными процессорами (VIP) (распределенное CBWFQ) - 12.1(5)T

  • Cisco серий 7200, 2600/3600 и другие платформы, не входящие в серию 7500 – 12.1(2)T

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Формирование и Организация очереди

Организация очереди обычно используется в контексте формирования, что уменьшает скорость на выходе и, таким образом, приводит к перегрузке. Используйте CBWFQ со следующими механизмами формирования и командами в зависимости от платформы.

  Серия Cisco 7500 Cisco 7200, 3600, 2600 и другие, отличные от VIP платформы
Поддерживаемые механизмы управления Формирование распределенного трафика (DTS) Формирование трафика Frame Relay (Frame Relay TS)
Команда настройки конфигурации команда shape в карте политики команда frame-relay traffic-shaping на главном интерфейсе, команды конфигурирования map-class для указания параметров формирования
Требуется распределенная скоростная переадресация Cisco (dCEF) Да (проверка с помощью команды show cef linecard) Нет

Cisco 7200, 3600, 2600

Cisco IOS 12.1(2)T вводит поддержку для CBWFQ на 7200, 2600/3600 и других платформах немаршрутизирующего процессора коммутации (RSP). (Дополнительные сведения см. в разделе Организация очередей с низкой задержкой (LLQ) через Frame Relay.). На данных платформах CBWFQ на интерфейсах Frame Relay всегда рассматривается в контексте Frame Relay TS. Используйте команду frame-relay traffic-shaping, чтобы активировать Frame Relay TS. Вы не можете использовать CBWFQ с генерированием формирования трафика (GTS) и команду shape command на этих платформах. Ниже предлагается примерная конфигурация.

Образец конфигурации CBWFQ для маршрутизаторов Cisco серий 7200, 3600, 2600
 policy-map mypolicy 
  class voice 
   priority 16 
  class priority-data 
   bandwidth 16 

!--- Create a policy-map and apply the bandwidth 
!--- command to a class. 

! 
 int s0/0 
  encapsulation frame-relay IETF 
  load-interval 30 
  frame-relay traffic-shaping 

!--- Enable Frame Relay TS. 

! 
 interface Serial0/0.1 point-to-point 
  frame-relay interface-dlci 100 
    class frclass 

!--- Apply the map-class to the Frame Relay PVC. 

! 
 map-class frame-relay frclass 
  service-policy output mypolicy 
  frame-relay cir 64000 
  frame-relay bc 640 

!--- Apply the service policy inside the map-class.

Примечание: Если активировать политики служб непосредственно на главном интерфейсе и не с помощью команды map-class, невозможно применять Frame Relay TS непосредственно к интерфейсу. Важно отметить, что механизмы организации очереди применяются к одной большой очереди интерфейса, а не к очередям каждого виртуального канала (VC)

В Cisco серии 7200, начиная с ПО Cisco IOS версии 12.0(26)S и более поздних, невозможно настраивать политику служб выходных данных в команде frame-relay map-class. Вместо этого необходимо применять конфигурацию Cisco 7500, описанную в следующем разделе. Карта иерархической политики должна быть настроена с формированием на родительском уровне и постановкой в очередь на дочернем. Данная родительская политика затем должна быть привязана к главному интерфейсу или субинтерфейсу. Если попытаться настроить выходные данные политики служб с помощью команды map-class frame-relay, отобразится следующее сообщение об ошибке:

c7200(config)#map-class frame-relay
	 stef
c7200(config-map-class)#frame-relay cir
	 64000
c7200(config-map-class)#service-policy output
	 aan
Frame relay output service policy is not
	 supported

Серия Cisco 7500

Что касается Cisco IOS 12.1(5)T, политики QoS необходимо запускать в распределенном режиме на VIP, так как функции QoS на основе RSP больше не поддерживаются. Таким образом, необходимо использовать команду shape и другие команды модульного QoS CLI, чтобы реализовать DTS для интерфейсов Frame Relay в процессорах VIP на Cisco серии 7500. Формирование графика DTS объединяет GTS и Frame Relay TS. Пример конфигурации представлен в разделе Настройка формирования распределенного трафика и ниже.

Пример конфигурации DTS с иерархической политикой
ip cef distributed 
 !  
 class-map 1  
   match < >  

!--- Define match-on criteria.

 class-map 2  
   match < >

!--- Define match-on criteria.

 !  
 policy-map CBWFQ  
   class 1  
     bandwidth < >  
     !-- Define value in kbps or percent.  
   class 2  
     priority < > 
 
!--- Define value in kbps or percent.

 !  
 Policy-map SHAPE  
    class class-default  
     shape average    
     service-policy CBWFQ  
 !  
 int s0/0/0  
   encapsulation frame-relay  
   ip route-cache distributed  
 !  
 int s0/0/0.1 point-to-point  
   ip address a.b.c.d  
   frame-relay interface-dlci xxx  
    class cisco  
 !  
 map-class frame-relay cisco  
   service-policy output SHAPE

Выбор места применения политики обслуживания

При настройке CBWFQ используйте команды модульного QoS CLI для создания схемы политики по трафику с несколькими классами трафика и одной или несколькими возможностями QoS. В текущих версиях ПО Cisco IOS интерфейсы Frame Relay поддерживают применение карты политики с помощью команды service-policy к интерфейсам, субинтерфейсам и каналам VC. В настоящее время поддерживаются только верные комбинации политик. В приведенной таблице описано, где можно применять политику QoS при формировании трафика.

  Серия Cisco 7500 Cisco серий 7200, 2600/3600 и другие платформы
Основной интерфейс Настройте политику служб на основном интерфейсе Поддерживается, только если функция Frame Relay TS не активирована и механизм организации очереди применяется к одному каналу интерфейса.
Подинтерфейс Настройте политику обслуживания на субинтерфейсе. Настройте политику служб в группе команд map-class Frame Relay и активируйте функцию организации очереди для каждого VC с помощью команды frame-relay traffic-shaping. Можно применить класс сопоставления для подчиненного интерфейса.
Уровень VC   Настройте политику служб в группе команд map-class Frame Relay и активируйте функцию организации очереди для каждого VC с помощью команды frame-relay traffic-shaping. Можно применить команду map-class к VC.

Типичные ошибки

В процессе конфигурации CBWFQ на интерфейсах Frame Relay необходимо учесть следующие предупреждения:

  • После перезагрузки маршрутизатора счетчики совпадений пакетов, используемые политикой службы, могут не увеличиваться при применении политики к основному интерфейсу. Для разрешения данной проблемы убедитесь, что флаги классификации для взвешенной организации очередей (WFQ) скопированы из основного интерфейса в подчиненные.

  • Не поддерживается одновременная конфигурация LLQ и Frame Relay TS на уровне физического интерфейса. Маршрутизатор перемещает политику служб из текущей конфигурации после перезагрузки маршрутизатора. Политика служб должна быть привязана к группам команд map-class, если функция Frame Relay TS активирована на интерфейсе. Конфигурация данной комбинации проводит к появлению сообщения об ошибке CBWFQ: Not supported on this interface (CBWFQ. Не поддерживается на данном интерфейсе).

  • Если политика служб с CBWFQ применяется непосредственно на основном интерфейсе Frame Relay (например, организация очереди не для каждого VC), данную политику можно удалить после перезагрузки маршрутизатора, если операторы bandwidth настроены на субинтерфейсе и на основном интерфейсе. Маршрутизатор может выдавать следующие сообщения регистрации:

    CBWFQ: Not enough available bandwidth for all classes Available 44 (kbps) 
        Needed 1 00 (kbps)
        CBWFQ: Removing service policy on Serial1/0

    Данная проблема решается с помощью изменения поведения CBWFQ с целью игнорирования данных уведомлений, если выражение bandwidth на субинтерфейсе изменено, так как CBWFQ можно настроить вне группы команд map-class Frame Relay только на уровне основного интерфейса. В качестве решения проблемы удалите команду bandwidth из субинтерфейса. В процессе использования выражения bandwidth на субинтерфейсе для влияния на параметры маршрутизации применяйте альтернативный способ "стоимость", как в протоколе предпочтения кратчайшего пути (OSPF), или "задержка", как в усовершенствованном внутреннем протоколе маршрутизации шлюзов (EIGRP).

Примечания по конфигурации

  • Когда команды bandwidth и priority рассчитывают общее количество доступной пропускной способности элемента, применяются следующие инструкции, если элемент является сформированным постоянным виртуальным каналом Frame Relay (PVC):

    • Если минимально допустимая согласованная скорость передачи данных (minCIR) не настроена, CIR делится на два.

    • Если значение minCIR определено, оно используется в расчетах.

    • Полная пропускная способность с вышеуказанной скоростью может быть задана классами полосы и приоритета. Поэтому команда max-reserved-bandwidth не поддерживается на Frame Relay PVCs, хотя необходимо убедиться в том, что объем заданной пропускной способности достаточно большой, чтобы вместить и служебные данные второго уровня (L2). Дополнительные сведения см. в разделе Какие байты учитываются протоколом IP при организации очередей ATM CoS?.

  • Не допускайте установку CIR или minCIR на скорости доступа. Иначе может произойти скопление очередей выхода, что вызовет серьезные задержки в классах CBWFQ. Причина заключается в том, что скорость формирования выбрана без учета служебной информации флага и полей циклического контроля избыточности (CRC), поэтому формирование с линейной скоростью приводит к возникновению избыточной подписки и вызывает перегрузку интерфейса. Нет необходимости ограничивать частоту обращений. Формирование трафика должно всегда производиться на уровне 95% от скорости доступа или, как правило, агрегированная сформированная скорость должна всегда быть ниже уровня 95% от скорости доступа.

  • Когда настроен FRF.12, размер очереди вывода увеличивается, чтобы соответствовать количеству байтов, которые фрагментированы в настоящий момент. Другими словами, осуществляется переход от очереди пакетов к очереди фрагментов.

  • WFQ per VC включен в программную версию Cisco IOS 12.0(7)T.

  • Функция CBWFQ с GTS включена в ПО Cisco IOS версии 12.1(2)T.


Дополнительные сведения


Document ID: 18661