Протокол IP : Протокол EIGRP

Протокол EIGRP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (3 апреля 2008) | Английский (27 апреля 2015) | Отзыв


Интерактивно этот документ предлагает анализ конкретного устройства Cisco.


Содержание


Введение

Протокол EIGRP (усовершенствованный внутренний протокол маршрутизации шлюзов) является внутренним протоколом шлюзов, пригодным для различных топологий и сред. В хорошо спроектированной сети EIGRP хорошо масштабируется и обеспечивает чрезвычайно короткое время согласования с минимальным сетевым трафиком.

Принцип работы EIGRP

Основными преимуществами EIGRP являются:

  • очень низкое использование сетевых ресурсов во время нормальной работы; только пакеты приветствия переданы на стабильной сети

  • когда изменение происходит, только изменения таблицы маршрутизации распространяются, не вся таблица маршрутизации; это уменьшает загрузку, которую сам протокол маршрутизации размещает в сеть

  • короткие времена конвергенции для изменений в топологии сети (в некотором схождении для ситуаций может быть почти мгновенным),

EIGRP – это улучшенный дистанционно-векторный протокол, который вычисляет кратчайший путь к назначению в рамках сети с помощью алгоритма диффузионного обновления (DUAL).

Основные версии протокола

Существует две основных редакции EIGRP, версий 0 и 1. Версии Cisco IOS ранее, чем 10.3 (11), 11.0 (8), и 11.1 (3) выполняют более раннюю версию EIGRP; некоторые пояснения в этой газете могут не примениться к той более ранней версии. Мы настоятельно рекомендуем пользоваться последней версией EIGRP, поскольку она отличается повышенными параметрами производительности и усовершенствованиями надежности.

Теоретические сведения

Типичный протокол маршрутизации по методу вектора расстояния сохраняет следующую информацию при вычислениях оптимального пути назначению: расстояние (distance) (суммарная метрика или расстояние, например, счетчик переходов) и вектор (следующий переход). Например, все маршрутизаторы сети на рис. 1 выполняют протокол RIP. Маршрутизатор 2 выбирает путь к сети A, исследуя число переходов на каждом доступном пути.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp1.gif

Поскольку длина пути, проходящего через Маршрутизатор 3, равна трем переходам, а длина пути через маршрутизатор 1 равна двум переходам, маршрутизатор 2 выбирает путь, идущий через Маршрутизатор 1, и отбрасывает информацию, полученную от Маршрутизатора 3. Если маршрут между маршрутизатором 1 и сетью А становится недоступен, маршрутизатор 2 теряет связь с этим пунктом назначения до тех пор, пока этот маршрут не будет блокирован в таблице маршрутизации по времени простоя (три периода обновления или 90 секунд), а маршрутизатор 3 объявляет маршрут заново (что происходит в RIP примерно каждые 30 секунд). Если не включить период удержания, то маршрутизатору 2 потребуется 90-120 секунд, чтобы перевести путь с маршрутизатора 1 на маршрутизатор 3.

EIGRP, вместо того, чтобы рассчитывать на полные периодические обновления для схождения, строит таблицу топологии по каждому объявлению его соседей (вместо отбрасывания данных) и выполняет схождение либо поиском подходящего свободного от петель маршрута в таблице топологии, либо, если не знает никакого другого маршрута, запрашивая своих соседей. Второй маршрутизатор сохраняет информацию, полученную от первого и третьего маршрутизаторов. Он выбирает путь через маршрутизатор 1 как лучший путь (преемник), а путь через маршрутизатор 3 – как путь без петель (возможный преемник). Когда маршрут через маршрутизатор 1 становится недоступным, маршрутизатор 2 обращается к таблице топологии в поисках возможного преемника и сразу начинает использовать маршрут через маршрутизатор 3.

Из этих кратких пояснений очевидно, что EIGRP должен обеспечить следующее:

  • система, куда это передает только обновления, необходимые в установленный срок; это выполнено через обнаружение соседей и обслуживание

  • способ определения путей без петель маршрутизатором

  • процесс для удаления неверных маршрутов из таблиц топологий для всех маршрутизаторов сети

  • процесс опроса соседних узлов при поиске путей к потерянному адресу назначения

Рассмотрим каждое из этих требований по очереди.

Обнаружение и обслуживание соседей

Для распространения маршрутной информации по сети в EIGRP используется непериодическое последовательное обновление маршрутов. Это означает, что EIGRP пересылает обновления только для изменяющихся маршрутов и только в тот момент, когда такие маршруты изменяются.

Основной недостаток таких обновлений заключается в том, что вы можете не узнать, в какое время маршрут, проходящий через соседний маршрутизатор, стал недоступным. Нельзя блокировать по времени маршруты, ожидающие получение новой таблицы маршрутизации от соседа. Для надежной пересылки изменений в маршрутной таблице в EIGRP используется механизм взаимодействия между соседними маршрутизаторами (два маршрутизатора становятся "соседями" в том случае, если каждый из них получает пакеты "hello" от своего соседа).

EIGRP посылает пакеты hello каждые 5 секунд на каналах с высокой пропускной способностью и каждые 60 секунд - на многоадресных каналах с низкой пропускной способностью.

  • 5-секундный hello:

    • среды трансляции, такие, как Ethernet, Token Ring и FDDI

    • двухточечные последовательные каналы связи, такие как арендуемые каналы PPP или HDLC, двухточечные подинтерфейсы Frame Relay и двухточечные подинтерфейсы ATM

    • высокая пропускная способность (больше, чем T1) многоточечные линии связи, такие как PRI ISDN и Frame Relay

  • 60-секундная задержка:

    • многоточечные линии связи T1 (или более медленные), например многоточечные интерфейсы Frame Relay, многоточечные интерфейсы ATM, виртуальные каналы с коммутацией ATM и интерфейсы ISDN BRI

Скорость, на которой EIGRP передает пакеты приветствия, называют интервалом приветствия, и можно отрегулировать его для интерфейса с командой ip hello-interval eigrp . Время удержания – время, в течение которого маршрутизатор будет считать соседнее устройство действующим, не получая от него пакет приветствия. Время удержания обычно равняется трем hello-интервалам (15 и 180 секунд по умолчанию). Для изменения времени удержания можно использовать команду ip hold-time eigrp.

Учитывайте, что при изменении интервала приветствия время удержания автоматически не корректируется - его необходимо изменить вручную для отражения настроенного интервала приветствия.

Два EIGRP-маршрутизатора могут стать соседями даже в том случае, если таймер hello и таймер удержания не совпадают. Время ожидания включено в пакеты hello, поэтому каждый сосед должен оставаться в рабочем состоянии, даже если интервал hello и таймеры ожидания не совпадают.

В то время как нет никакого прямого способа определить то, что интервал приветствия находится на маршрутизаторе, можно вывести его из выходных данных show ip eigrp neighbors на соседнем маршрутизаторе.

Если у вас есть выходные данные команды show ip eigrp neighbors от устройства Сisco, вы можете использовать Интерпретатор выходных данных (только зарегистрированные клиенты) для показа потенциальных проблем и исправляете. Для использования Output Interpreter необходимо включить JavaScript.

router# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address       Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2      Et1           13 12:00:53   12   300  0  620
0   10.1.2.2      S0           174 12:00:56   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           12 12:00:55   12   300  0  620
0   10.1.2.2       S0           173 12:00:57   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           11 12:00:56   12   300  0  620
0   10.1.2.2       S0           172 12:00:58   17   200  0  645

Значение в колонке Hold выходных данных команды никогда не должно превышать значения времени удержания, а также не должно быть меньше разницы значений времени удержания и интервала между сообщениями приветствия (если, конечно, пакеты приветствия не были утеряны). Если значение в столбце "Hold" обычно варьируется от 10 до 15 секунд, то интервал приветствия составляет 5 секунд, а время удержания – 15 секунд. Если значение в столбце "Hold" обычно варьируется от 120 до 180 секунд, то интервал приветствия составляет 60 секунд, а время удержания – 180 секунд. Если значение не совпадают со значениями таймера, заданными по умолчанию, тогда необходимо проверить соответствующий интерфейс на соседнем маршрутизаторе (таймер "hello" и таймер интервала приветствия могли быть изменены вручную).

Примечание: 

  • EIGRP не создает одноранговые связи с использованием вторичных адресов. Источник всего трафика EIGRP - основной адрес интерфейса.

  • В процессе настройки EIGRP по сети Frame Relay с множественным доступом (многоточечному соединению и др.) следует настроить ключевое слово "broadcast" в операторе "frame-relay map". Смежность двух маршрутизаторов EIGRP не будет создана без ключевого слова broadcast. Более подробно см. раздел "Настройка и устранение неполадок Frame Relay".

  • Количество соседних узлов, поддерживаемых EIGRP, неограничено. Фактическое количество поддерживаемых соседних узлов зависит от характеристик устройства:

    • объем памяти

    • скорость обработки

    • сумма обмененной информации, такой как количество маршрутов передана

    • сложность топологии

    • устойчивость сети

Создание таблицы топологии

Теперь, когда эти маршрутизаторы говорят друг с другом, о чем они говорят? Конечно, о таблицах топологии! EIGRP, в отличие от RIP и IGRP, не использует таблицу маршрутизации (или перенаправления) для хранения всех нужных для функционирования данных. Вместо этого формируется вторая таблица (таблица топологии), на основе которой осуществляется установка маршрутов в таблице маршрутизации.

Примечание: В версиях 12.0T и 12.1 Cisco IOS, протокол RIP поддерживает собственную базу данных, из которой маршруты поступают в таблицу маршрутизации.

Чтобы узнать основной формат таблицы топологии на EIGRP-маршрутизатора, выполните команду show ip eigrp topology. Таблица топологии содержит сведения, необходимые для построения набора расстояний и векторов для каждой достижимой сети, включая:

  • самая низкая пропуская способность в пути к данному назначению согласно сообщениям соседа в восходящем направлении

  • всего задержек

  • надежность пути

  • загрузка пути

  • минимальный путь максимального размера передаваемого блока данных (MTU)

  • допустимое расстояние

  • объявленное расстояние

  • источник маршрута (маркируются внешние маршруты)

Выполнимый и объявленное расстояние обсуждены позже в этом разделе.

Если листинг команды show ip eigrp topology получен с устройства Cisco, то в этом случае для интерпретации результатов можно воспользоваться утилитой Output Interpreter ( только для зарегистрированных клиентов). Данная утилита отображает потенциальные проблемы и предлагает способы их решения. Для использования Output Interpreter необходимо включить JavaScript.

Метрика протокола EIGRP

EIGRP использует минимальную пропускную способность на пути к сети назначения и всей задержке для вычислений метрик маршрутизации. Можно также настроить и другие метрики. Однако мы не рекомендуем делать этого, поскольку в этом случае в вашей сети могут появиться петли по маршрутизации. Метрики пропускной способности и задержки определяются из значений, настраиваемых в интерфейсах маршрутизаторов на пути к сети назначения.

Например, на рисунке 2 маршрутизатор 1 вычисляет наилучший путь к сети А.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp2.gif

Расчет начинается с двух объявлений, касающихся искомой сети: первый маршрут проходит через маршрутизатор 4 (минимальная пропускная способность – 56 и суммарная задержка – 2200), а второй – через маршрутизатор 3 (минимальная пропускная способность – 128 и суммарная задержка – 1200). Маршрутизатор 1 выбирает маршрут с наименьшим значением метрики.

Теперь вычислим метрику. EIGRP вычисляет суммарную метрику путем взвешивания метрики пропускной способности и метрики задержки. Для измерения пропускной способности EIGRP использует следующую формулу:

  • полоса пропускания = (10000000/полоса пропускания(i)) * 256

    где bandwidth(i) – минимальная пропускная способность всех исходящих интерфейсов на маршруте до сети назначения (в килобитах).

EIGRP использует для измерения задержки следующую формулу:

  • задержитесь = задержка (i) * 256

    где delay(i) есть сумма задержек, настроенных на интерфейсах на маршруте к сети назначения, в десятках микросекунд. Задержка, как показано в выходных данных команд show ip eigrp topology или show interface, указана в миллисекундах, поэтому значение необходимо разделить на 10 перед использованием в этой формуле. В этом документе используется задержка, настроенная и показанная на интерфейсе.

Указанные выше значения используются для определения суммарной метрики для искомой сети:

  • метрика = ([K1 * пропускная способность + (K2 * пропускная способность) / (256 - загрузка) + K3 * задержка] * [K5 / (надежность + K4)]) * 256

Примечание: Эти значения K необходимо использовать только после тщательного планирования. Неверные значения K приводят к невозможности построения связей между соседними узлами, в результате чего в вашей сети будет невозможно выполнить сходимость.

Примечание: Если K5 = 0, формула уменьшает до Метрики = ([k1 * пропускная способность + (k2 * пропускная способность) / (256 - загрузка) + k3 * задержка]) * 256.

По умолчанию K имеет следующие значения:

  • K1 = 1

  • K2 = 0

  • K3 = 1

  • K4 = 0

  • K5 = 0

Для поведения по умолчанию можно упростить формулу, как это указано ниже:

metric = bandwidth + delay 

Маршрутизаторы Cisco не выполняют математику с плавающей запятой, поэтому для правильной калькуляции метрики на каждой стадии калькуляции необходимо округлять в меньшую сторону до целого числа. В этом примере общая стоимость через маршрутизатор 4 равна:

В этом примере общая стоимость через маршрутизатор 4 равна:

minimum bandwidth = 56k 

total delay = 100 + 100 + 2000 = 2200 

[(10000000/56) + 2200] x 256 = (178571 + 2200) x 256 = 180771 x 256 = 46277376  

А общая стоимость маршрута через маршрутизатор 3 равна:

minimum bandwidth = 128k 

total delay = 100 + 100 + 1000 = 1200 

[(10000000/128) + 1200] x 256 = (78125 + 1200) x 256 = 79325 x 256 = 20307200  

Таким образом, для достижения сети A маршрутизатор 1 выбирает маршрут через маршрутизатор 3.

Обратите внимание, что значения пропускной способности и задержки конфигурируются на интерфейсе, через который маршрутизатор достигает свой следующий транзитный участок к сети назначения. Например, маршрутизатор 2 объявил о сети А и указал задержку, настроенную на его Ethernet-интерфейсе. Затем маршрутизатор 4 добавил к этому значению задержку, настроенную на его Ethernet-интерфейсе, а маршрутизатор 1 добавил задержку, настроенную на его последовательном порте.

Возможное расстояние, фактическое расстояние и возможный следующий элемент

Допустимое расстояние является лучшей метрикой вдоль пути к сети назначения, включая метрику соседнему узлу, объявляющему тот путь. Объявленное расстояние является суммарной метрикой пути к сети назначения, объявленном восходящим соседом. Возможный заместитель – это маршрут, величина объявленного расстояния которого меньше величины возможного расстояния (текущий наилучший маршрут). На рис. 3 изображен этот процесс:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp3.gif

Маршрутизатор 1 определил, что в сеть А имеются два маршрута: один через маршрутизатор номер 3 и другой - через маршрутизатор номер 4.

  • Стоимость маршрута, проходящего через маршрутизатор 4, равняется 46277376, а объявленное расстояние – 307200.

  • Маршрут через Маршрутизатор 3 имеет стоимость 20307200 и объявленное расстояние 307200.

Обратите внимание на то, что в каждом случае EIGRP вычисляет объявленное расстояние от маршрутизатора, объявляя маршрут к сети. Другими словами, объявленное расстояние от маршрутизатора 4 равно расстоянию, чтобы добраться к сети А от маршрутизатора 4, и объявленное расстояние от маршрутизатора 3 равно расстоянию, чтобы добраться к сети А от маршрутизатора 3. EIGRP выбирает маршрут через маршрутизатор 3 в качестве наилучшего и использует метрику через маршрутизатор 3 как допустимое расстояние. Поскольку заявленное расстояние до этой сети через маршрутизатор 4 меньше допустимого, маршрутизатор 1 считает путь через маршрутизатор 4 подходящим преемником.

Когда связь между маршрутизаторами 1 и 3 прерывается, маршрутизатор 1 перебирает все известные ему пути к сети A, и обнаруживает, что у него есть подходящий преемник, доступный через маршрутизатор 4. Первый маршрутизатор обращается к этому маршруту, используя метрику через четвертый маршрутизатор как новое допустимое расстояние. Конвергенция выполняется мгновенно, а обновления, поступающие к нисходящим соседям, являются единственным трафиком, который генерируется протоколом маршрутизации.

Теперь давайте рассмотрим более сложный случай, показанный на рисунке 4.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp4.gif

От маршрутизатора 1 в сеть А ведут два маршрута: один маршрут проходит через маршрутизатор и имеет метрику 46789376, а другой через маршрутизатор 4 и имеет метрику 20307200. В качестве маршрута в сеть А маршрутизатор 1 выберет наименьшую из двух метрик, которая станет возможным расстоянием. Теперь рассмотрим маршрут, идущий через маршрутизатор 2. Нам необходимо выяснить, подходит ли этот маршрут в качестве возможного преемника. Объявленное расстояние от второго маршрутизатора равно 46277376, и оно больше допустимого расстояния, поэтому этот путь не является возможным преемником. Если рассматривать таблицу топологии маршрутизатора 1 с применением команды show ip eigrp, можно увидеть только одну запись для сети A - через маршрутизатор 4. (В действительности в таблице топологии маршрутизатора 1 имеются две записи, но возможным преемником может быть только одна из них, другая же запись в листинге команды show ip eigrp topology отображена не будет; все маршруты, которые не являются возможными преемниками, можно посмотреть воспользовавшись командой show ip eigrp topology all-links).

Допустим, что соединение между маршрутизаторами 3 и 4 было нарушено. Обнаружив, что единственный путь к сети A утрачен, маршрутизатор 1 начинает опрашивать всех своих соседей на предмет маршрута в сеть А. Поскольку маршрутизатор 2 может предложить маршрут в сеть А, он откликнется на запрос, инициированный маршрутизатором 1. Поскольку наилучший маршрут, идущий через маршрутизатор 4, был утрачен, маршрутизатор 1 принимает маршрут, который идет в сеть A через маршрутизатор 2.

Определение беспетлевого пути

Как EIGRP использует понятия допустимого расстояния, объявленного расстояния и возможного преемника, чтобы определить, допустим ли путь, и не петля? На рисунке 4а показано, что маршрутизатор 3 выполняет оценку маршрутов в сеть А. Поскольку функция "разделенный горизонт" отключена (например, это необходимо при работе с многоточечными интерфейсами Frame Relay), маршрутизатор 3 укажет в сеть А три маршрута: через маршрутизатор 4, через маршрутизатор 2 (путь: два, один, три, четыре) и через маршрутизатор 1 (путь: один, два, три, четыре).

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

Если маршрутизатор 3 доступен на этих маршрутизаторах, это скажется на маршрутной петле. Маршрутизатор 3 полагает, что он сможет попасть в сеть А через маршрутизатор 2, однако прежде чем попасть в сеть А, путь, идущий через маршрутизатор 2, проходит через маршрутизатор 3. Если соединение между маршрутизатором 4 и маршрутизатором 3 будет нарушено, тогда маршрутизатор 3 будет считать, что он сможет достигнуть сети А используя один из оставшихся маршрутов, но из-за действия правил для определения возможных преемников он никогда не будет использовать эти маршруты в качестве альтернативных. Чтобы это понять, обратимся к метрике:

  • суммарная метрика в сеть А через маршрутизатор 4: 20281600

  • суммарная метрика в сеть А через маршрутизатор 3: 47019776

  • суммарная метрика в сеть А через маршрутизатор 1: 47019776

Поскольку путь через маршрутизатор 4 обладает наилучшей метрикой, маршрутизатор 3 устанавливает этот маршрут в таблице перенаправлений и использует метрику 20281600 в качестве возможного расстояния в сеть А. Затем маршрутизатор 3 вычисляет объявленное расстояние в сеть А для путей, идущих через маршрутизаторы 2 и 1: 47019776 соответствует пути через маршрутизатор 2, а 47019776 - пути через маршрутизатор 1. Поскольку обе из этих метрик больше, чем допустимое расстояние, Маршрутизатор 3 не устанавливает ни один маршрут как возможного преемника для Сети A.

Допустим, что соединение между маршрутизаторами 3 и 4 перестает работать. Маршрутизатор 3 запрашивает альтернативный маршрут к сети A у всех соседних узлов. Маршрутизатор 2 получает запрос и, поскольку этот запрос поступает от преемника, выполняет поиск всех записей о возможных преемниках в таблице топологии. Единственная такая запись в таблице топологии принадлежит маршрутизатору 1 (объявленное расстояние этой записи равняется значению последней известной метрике через маршрутизатор 3). Поскольку объявленное расстояние через Маршрутизатор 1 является не менее последним известным допустимым расстоянием, Маршрутизатор 2 отмечает маршрут как недостижимый и делает запрос каждого из его соседних узлов - в этом случае, только Маршрутизатор 1 - для пути к Сети A.

Маршрутизатор 3 также передает запрос за Сетью к Маршрутизатору 1. Маршрутизатор 1 обращается к таблице топологии и обнаруживает, что только один второй маршрут к сети А проходит через маршрутизатор 2 с фактическим расстоянием, равным последнему известному возможному расстоянию через маршрутизатор 3. Поскольку объявленное расстояние через маршрутизатор 2 опять-таки превышает последнее известное возможное расстояние, этот маршрут не является возможным преемником. Маршрутизатор 1 помечает маршрут как недостижимый, и запрашивает путь к сети А только у другого соседа, Маршрутизатора 2.

Это первый уровень запросов. Пытаясь найти маршрут в сеть А маршрутизатор 3 опросил всех своих соседей. В свою очередь маршрутизаторы 1 и 2 пометили маршрут как недостижимый и опросили своих соседей, чтобы найти путь в сеть А. При получении запроса от маршрутизатора 1 маршрутизатор 2 выполняет поиск по своей таблице топологии, в ходе которого обнаруживает, что пункт назначения помечен как недостижимый. Маршрутизатор 2 отвечает маршрутизатору 1, что сеть А недоступна. Когда маршрутизатор 1 получает запрос маршрутизатора 2, он также посылает обратно ответ о том, что сеть А недоступна. Поскольку маршрутизаторы 1 и 2 установили, что сеть А не доступна, они отвечают на первоначальный запрос маршрутизатора 3. Сеть объединяется, и все маршрутизаторы возвращаются в пассивное состояние.

Расщепление горизонта и обратное исправление

В предыдущем примере предполагалось, что разделение горизонта не использовалось для показа использования EIGRP допустимого расстояния и объявленного расстояния для определения, является ли маршрут петлей. Однако в некоторых случаях EIGRP использует расщепленный горизонт, чтобы предотвратить возникновения петель маршрутизации. Прежде чем начать рассматривать особенности использования расщепленного горизонта, необходимо объяснить, что это такое и как это работает. Состояния правила разделения горизонтов:

  • Никогда не объявлять маршрут через интерфейс, посредством которого маршрутизатор узнал о маршруте.

Приведем пример. На рисунке 4a показано, что если маршрутизатор 1 подключен к маршрутизаторам 2 и 3 через единый многоточечный интерфейс (например, Frame Relay) и если при этом маршрутизатор 1 узнает о сети А через маршрутизатор 2, то он не будет использовать тот же самый интерфейс, чтобы объявить маршрутизатору 3 маршрут в сеть А. Маршрутизатор 1 предполагает, что маршрутизатор 3 получит данные сети A непосредственно от маршрутизатора 2.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

Запрет маршрута – это еще один способ предотвратить появление петель. Состояния правил:

  • Узнав о маршруте через интерфейс, объявите его в качестве недостижимого через тот же интерфейс.

Предположим, что на маршрутизаторах, показанных на рисунке 4a, включена функция обратного запрета. Когда Маршрутизатор 1 узнает о Сети A от Маршрутизатора 2, он объявляет Сеть A недостижимой через канал на Маршрутизаторы 2 и 3. В случае если маршрутизатор 3 указывает какой-либо путь в сеть А через маршрутизатор 1, он должен удалить его, поскольку было объявлено о том, что сеть А недостижима через этот путь. EIGRP объединяет эти два правила, чтобы предотвратить возникновение циклов маршрутизации.

EIGRP использует разделение горизонта или объявляет маршрут недостижимым в следующих случаях:

  • два маршрутизатора в режиме запуска (первый обмен таблицами топологии)

  • объявление об изменении таблицы топологии

  • передача запроса

Давайте исследуем каждую из этих ситуаций.

Режим запуска

Когда два маршрутизатора соединяются как соседние узлы, они обмениваются таблицами топологии в режиме запуска. Каждая запись таблицы, принятой маршрутизатором в режиме запуска, декларируется новому соседу с использованием максимальной метрики (маршрут с исправлением).

Изменение таблицы топологии

На рисунке 5 в маршрутизаторе 1 используется дисперсия для балансировки трафика, предназначенного для сети А на отрезке между двумя последовательными каналами - каналом в 56Кбит между маршрутизаторами 2 и 4 и каналом в 128Кбит между маршрутизаторами 3 и 4 (сведения о дисперсии см. в разделе о балансировке нагрузки).

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp5.gif

Маршрутизатор 2 рассматривает путь через маршрутизатор 3 в качестве возможного преемника. Если канал между маршрутизаторами 2 и 4 будет нарушен, то маршрутизатор 2 выполнит сходимость по маршруту, проходящему через маршрутизатор 3. Так как правило разделения горизонта указывает, что никогда не следует объявлять маршрут вне интерфейса, через который получены сведения о нем, маршрутизатор 2 обычно не передает обновление. Однако это оставляет маршрутизатор 1 с недопустимой записью в таблице топологии. Когда маршрутизатор изменяет свою таблицу топологии таким образом, что меняется интерфейс, через который маршрутизатор соединяется с сетью, он отключает разделение горизонта, а исправления меняют все маршруты, исходящие из интерфейсов, в обратном направлении. В этом случае маршрутизатор 2 отключает разделение горизонта для данного маршрута и объявляет сеть A недоступной. Маршрутизатор 1 получает это объявление и удаляет его маршрут к сети A через маршрутизатор 2 из своей таблицы маршрутизации.

Запросы

Запросы приводят к разделению горизонта, но в том случае, если маршрутизатор получает запрос или обновление от преемника, он использует для получателя в запросе. Давайте смотреть на сеть на рисунке 6.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp6.gif

Маршрутизатор 3 получает запрос относительно 10.1.2.0/24 (которого это достигает через Маршрутизатор 1) от Маршрутизатора 4. Если у маршрутизатора 3 отсутствует преемник для данного пункта назначения (по причине переключения линии или из-за другой временной ситуации в сети), этот маршрутизатор отправляет запрос каждому из своих соседей (в данном случае это маршрутизаторы 1, 2 и 4). Однако если маршрутизатор 3 получит от маршрутизатора 1 запрос или обновление (например, изменение метрики) для сети 10.1.2.0/24, тот он не будет отправлять запрос обратно маршрутизатору 1, поскольку последний является его преемником на маршруте к этой сети. Вместо этого он отправит запросы только маршрутизаторам 2 и 4.

Задержка в активных маршрутах

При определенных обстоятельствах для ответа на запрос требуется большой промежуток времени. "Молчание" может быть настолько длительным, что инициировавший запрос маршрутизатор может прекратить ожидание и сбросить соединение с "молчащим" маршрутизатором, при этом происходит фактический перезапуск сеанса связи с соседним узлом. Такая ситуация известна как "затор на активном маршруте" (SIA). Наиболее простые маршруты SIA возникают, если требуется слишком много времени для достижения запросом другого конца сети и возвращения отклика. Например, на рисунке 7 маршрутизатор One записывает большое число маршрутов SIA от маршрутизатора Two.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp7.gif

После рассмотрения вероятная причина проблема сводится к наличию задержки в спутниковом канале между маршрутизаторами 2 и 3. Существуют два возможных решения проблемы этого типа. В первую очередь, необходимо увеличить интервал, в течение которого маршрутизатор ожидает объявление маршрута SIA после передачи запроса. Эту настройку можно изменить с помощью команды timers active-time.

Однако оптимальное решение состоит в том, чтобы перестроить сеть с расчетом на уменьшение диапазона запросов (чтобы через по спутниковому каналу передавалось минимальное количество запросов). Диапазон запросов рассмотрен в соответствующем разделе. Диапазон очереди, по сути – не общая причина для объявленных SIA маршрутов. Значительно чаще некоторые маршрутизаторы в сети не могут ответить на запрос по одной из следующих причин:

  • маршрутизатор слишком занят, чтобы ответить на запрос (обычно из-за высокой загруженности CPU)

  • в маршрутизаторе возникли проблемы с памятью, и он не может выделить память для обработки запроса или создания пакета ответа

  • соединении между двумя маршрутизаторами не достаточно качественно – достаточное для поддержания соседского окружения количество пакетов проходят, но некоторые запросы или ответы теряются между маршрутизаторами

  • однонаправленные соединения (ссылка, на которой трафик может только течь в одном направлении из-за сбоя),

Устранение неполадок маршрутов SIA

Процесс исправления маршрутов SIA обычно состоит из трех этапов:

  1. Сначала необходимо установить маршруты, о которых система из раза в раз сообщает как о маршрутах SIA.

  2. Затем необходимо установить маршрутизатор, который из раза в раз не отвечает на запросы на данных маршрутах.

  3. Определите причину, по которой маршрутизатор не получает запросов или не отвечает на них.

Первый шаг должен быть довольно простым. Если в вашей системе ведется учет консольных сообщений, то при быстром просмотре журнала можно определить, какие маршруты чаще всего помечаются как маршруты SIA. Второй этап более сложный. Для сбора этой информации необходимо использовать команду show ip eigrp topology active:

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

A 10.2.4.0/24, 0 successors, FD is 512640000, Q 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.2.2 (Infinity/Infinity), Serial1 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.3.2 (Infinity/Infinity), r, Serial3 
    Remaining replies: 
         via 10.1.1.2, r, Serial0

Все соседние устройства, отображающие R, должны ответить (активный таймер показывает время, на протяжении которого маршрут был активным). Обратите внимание на то, что соседние узлы могут отсутствовать в разделе "Remaining replies" (ожидаемые отклики). Эти узлы могут появиться среди других RDB. Особое внимание необходимо уделять маршрутам, которые были активны в течение определенного времени (обычно 2-3 минуты), и для которых имеются неподтвержденные ответы. Выполните эту команду несколько раз, и вы узнаете, какие соседи не отвечают на запросы (или у каких интерфейсов много запросов без ответа). Проверьте этот соседний узел, чтобы узнать, находится ли он постоянно в режиме ожидания откликов от своих соседей. Повторяйте эту процедуру до тех пор, пока не найдете маршрутизатор, который из раза в раз не отвечает на запросы. Следует проверить наличие проблем соединения с этим соседом, памятью, использованием CPU и прочих.

Если вы сталкиваетесь с ситуацией, когда по вашему мнению причиной неполадок является диапазон запросов, лучшим решением проблемы будет уменьшить диапазон запроса (а не увеличивать значения таймера SIA).

Перераспределение

Данный раздел содержит описание разных сценариев с выполнением перераспределения. Пожалуйста, помните о том, что в примерах, рассматриваемых ниже, указан минимум, который необходим для настройки перераспределения. Перераспределение может потенциально вызвать проблемы, такие, как маршрутизация ниже оптимального уровня, зацикливание маршрутизации или медленная конвергенция. Чтобы избежать подобных проблем, обратитесь к разделу "Как избежать проблем при перераспределении" в документе "Перераспределение протоколов маршрутизации".

Перераспределение между двумя автономными системами EIGRP

На рисунке 8 маршрутизаторы настроены следующим образом:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp8.gif

Маршрутизатор 1

router eigrp 2000 

!--- The "2000" is the autonomous system 

 network 172.16.1.0 0.0.0.255 

Маршрутизатор 2

router eigrp 2000 
 redistribute eigrp 1000 route-map to-eigrp2000
 network 172.16.1.0 0.0.0.255 
! 
router eigrp 1000 
 redistribute eigrp 2000 route-map to-eigrp1000
 network 10.1.0.0 0.0.255.255

route-map to-eigrp1000 deny 10
match tag 1000
!
route-map to-eigrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

Маршрутизатор 3

router eigrp 1000 
 network 10.1.0.0 0.0.255.255

Маршрутизатор 3 объявляет маршрутизатору 2 о сети 10.1.2.0/24 через автономную систему 1000. Маршрутизатор 2 перераспределяет этот маршрут в автономную систему 2000 и объявляет о нем маршрутизатору 1.

Примечание: Маршруты от EIGRP 1000 помечены 1000 прежде, чем перераспределить их к EIGRP 2000. когда маршруты от EIGRP гарантировать исключающее зацикливание топология, 2000 перераспределен назад к EIGRP 1000, маршрутам с 1000 меток запрещены, Дополнительные сведения о перераспределении среди протоколов маршрутизации см. в разделе "Перераспределение протоколов маршрутизации".

На маршрутизаторе 1 видно:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 2 
      External data: 
        Originating router is 10.1.2.1 
        AS number of route is 1000 
        External protocol is EIGRP, external metric is 46251776 
        Administrator tag is 1000 (0x000003E8)

Обратите внимание, что несмотря на то, что пропускная способность канала между маршрутизаторами 1 и 2 составляет 1,544Мб, минимальная пропускная способность, указанная в таблице топологии, равна 56k. Это значит, что EIGRP сохраняет все измерения при операциях перераспределения между двумя анонимными системами EIGRP.

Перераспределение между EIGRP и IGRP в двух разных автономных системах

На рисунке 9 конфигурации изменены следующим образом:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp9.gif

Маршрутизатор 1

router eigrp 2000 
 network 172.16.1.0

Маршрутизатор 2

router eigrp 2000 
 redistribute igrp 1000 route-map to-eigrp2000
 network 172.16.1.0
! 
router igrp 1000 
 redistribute eigrp 2000 route-map to-igrp1000
 network 10.0.0.0 
!

route-map to-igrp1000 deny 10
match tag 1000
!
route-map to-igrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

Маршрутизатор 3

router igrp 1000 
 network 10.0.0.0

Конфигурация для маршрутизатора 1 приведена ниже:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 1000 (0x000003E8)

Метрики IGRP сохраняются, когда маршруты перераспределяются в EIGRP с другой автономной системой, но они масштабируются путем умножения метрики IGRP на константу 256. Следует обратить внимание на один момент, касающийся перераспределения между IGRP и EIGRP. Если сеть не подключена напрямую к маршрутизатору, который выполняет перераспределений, то она объявляет маршрут с метрикой, равной 1.

Например, сеть 10.1.1.0/24 напрямую подсоединена к маршрутизатору 2, а IGRP выполняет маршрутизацию для этой сети (есть инструкция сети для маршрутизатора IGRP, который обслуживает этот интерфейс). Для этой сети протокол EIGRP не занимается маршрутизацией, но он узнает об этом напрямую подключенном интерфейсе с помощью перераспределения от IGRP. На маршрутизаторе 1 запись в таблице топологии для 10.1.1.0/24 показывает:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
                                    
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 0/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 1000 (0x000003E8)

Обратите внимание, что объявленное расстояние от маршрутизатора 2, который выделен, равно 1."

Перераспределение между EIGRP и IGRP в одной автономной системе

На рисунке 10 в конфигурацию маршрутизатора внесены следующие изменения:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp10.gif

Маршрутизатор 1

router eigrp 2000 
 network 172.16.1.0 

Маршрутизатор 2

router eigrp 2000 
 network 172.16.1.0
! 
router igrp 2000 
 network 10.0.0.0

Маршрутизатор 3

router igrp 2000 
 network 10.0.0.0

Маршрутизатор 1 настроен следующим образом:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 0 (0x00000000)

Эта конфигурация выглядит удивительно похожей на предыдущий результат, когда было использовано перераспределение между двумя разными автономными системами с IGRP и EIGRP. Непосредственно примыкающая 10.1.1.0/24 сеть одинаково регулируется в обоих случаях:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 0 (0x00000000)

Эта сеть, напрямую соединенная с маршрутизатором Router One, перераспределяется от IGRP до EIGRP со значением метрики 1 – такая же метрика используется при перераспределении между двумя различными автономными системами.

Следует обратить внимание на пару моментов, касающихся перераспределения EIGRP/IGRP в пределах одной автономной системы:

  • Внутренние маршруты EIGRP всегда предпочитаются внешним маршрутам EIGRP или IGRP.

  • Метрики внешних маршрутов EIGRP сравниваются с масштабированными метриками IGRP (административное расстояние игнорируется).

Теперь давайте посмотрим, как выглядят эти моменты, о которых следует помнить, на рисунке 11:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp11.gif

Маршрутизатор 1 объявляет маршрут 10.1.4.0/24 в автономной IGRP-системе 100. Маршрутизатор 4 объявляет маршрут 10.1.4.0/24 в автономной EIGRP-системе 100 в качестве внешнего. На маршрутизаторе 2 в автономной системе 100 выполняется как протокол EIGRP, так и IGRP.

Если игнорируется маршрут EIGRP, декларированный маршрутизатором 4 (например, за счет отключения канала между маршрутизаторами 2 и 4), на маршрутизаторе 2 отображается следующее сообщение:

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.1.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.1.2, from 10.1.1.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

Обратите внимание, административное расстояние равно 100. При добавлении EIGRP-маршрута, на маршрутизаторе 2 будет отображено следующее:

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "eigrp 100", distance 170, metric 3072256, type external 
  Redistributing via igrp 100, eigrp 100 
  Last update from 10.1.2.2 on Serial0, 00:53:59 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:53:59 ago, via Serial0 
      Route metric is 3072256, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 1

Обратите внимание, что после масштабирования из IGRP в EIGRP метрики для этих маршрутов одинаковы (см. раздел Метрики):

  • 12001 x 256 = 3072256

где 12001, метрика IGRP, через Маршрутизатор 1; и 3072256, метрика EIGRP, через Маршрутизатор 4.

Второй маршрутизатор предпочитает внешний маршрут EIGRP с такой же метрикой (после масштабирования) и большим административным расстоянием. Это справедливо в случае автоматического перераспределения между EIGRP и IGRP в одной автономной системе. Маршрутизатор всегда выбирает путь с наименьшей стоимостью метрики и игнорирует административное расстояние.

Двустороннее перераспределение для других протоколов

Перераспределение между EIGRP и другими протоколами, например RIP и OSPF, работает так же, как и любое другое перераспределение. При выполнении перераспределения между протоколами рекомендуется всегда использовать метрику по умолчанию. Необходимо иметь представление о следующих двух проблемах во время перераспределения между EIGRP и другими протоколами:

Перераспределение статических маршрутов к интерфейсам

При установке статического маршрута на интерфейс и настройке инструкции сети с использованием EIGRP маршрутизатора, который включает в себя статический маршрут, EIGRP перераспределяет этот маршрут так, как если бы это был интерфейс, подключенный напрямую. Рассмотрим сеть на рисунке 12.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp12.gif

Маршрутизатор 1 имеет статический маршрут к сети 172.16.1.0/24, настроенный через интерфейс Serial 0:

ip route 172.16.1.0 255.255.255.0 Serial0

Маршрутизатор 1 также имеет инструкцию сети для данного пункта этого статического маршрута:

router eigrp 2000 
 network 10.0.0.0 
 network 172.16.0.0 
 no auto-summary 

Маршрутизатор 1 перераспределяет этот маршрут, даже если это не перераспределяемые статические маршруты, поскольку EIGRP воспринимает это как непосредственно подключенную сеть. Для первого маршрутизатора это выглядит так:

two# show ip route 
    .... 
        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
    C       10.1.1.0/24 is directly connected, Serial0
    D       10.1.2.0/24 [90/2169856] via 10.1.1.1, 00:00:47, Serial0
         172.16.0.0/24 is subnetted, 1 subnets 
    D       172.16.1.0 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

Обратите внимание, что маршрут в сеть 172.16.1.0/24 выглядит на маршрутизаторе 2 как внутренний EIGRP-маршрут.

Суммирование

В EIGRP существуют два вида суммирования: автоматическое суммирование и суммирование вручную.

Автоуплотнение

EIGRP выполняет автоуплотнение каждый раз, когда он пересекает границу между двумя другими крупными сетями. Например, на рисунке 13 маршрутизатор 2 объявляет маршрутизатору 1 только сеть 10.0.0.0/8, потому что интерфейс, который использует маршрутизатор 2, чтобы добраться до маршрутизатора 1, находится в другой крупной сети.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp13.gif

Для первого маршрутизатора это выглядит так:

one# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 11023872 
  Routing Descriptor Blocks: 
  172.16.1.1 (Serial0), from 172.16.1.2, Send flag is 0x0 
      Composite metric is (11023872/10511872), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 40000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1

Этот маршрут не помечается как суммарный маршрут: он выглядит как внутренний маршрут. Метрика – лучшая метрика из всех суммарных маршрутов. Обратите внимание, что минимальная пропускная способность на этом маршруте равна 256 Кбит, несмотря на то, что в сети 10.0.0.0 существуют каналы с пропускной способностью равной 56 Кбит.

На маршрутизаторе, выполняющем объединение, создается маршрут null0 для сводного адреса:

two# show ip route 10.0.0.0 
Routing entry for 10.0.0.0/8, 4 known subnets 
  Attached (2 connections) 
  Variably subnetted with 2 masks 
  Redistributing via eigrp 2000 

C       10.1.3.0/24 is directly connected, Serial2 
D       10.1.2.0/24 [90/10537472] via 10.1.1.2, 00:23:24, Serial1 
D       10.0.0.0/8 is a summary, 00:23:20, Null0 
C       10.1.1.0/24 is directly connected, Serial1

Маршрут к сети 10.0.0.0/8 помечается как суммарный через Null0. Запись, размещенная в таблице топологии для данного суммарного маршрута, выглядит следующим образом:

two# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10511872 
  Routing Descriptor Blocks: 
  0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0 
          (note: the 0.0.0.0 here means this route is originated by this router) 
      Composite metric is (10511872/0), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 0

Чтобы маршрутизатор 2 начал декларировать компоненты сети 10.0.0.0 вместо предоставления сводки, следует настроить автосводку в процессе EIGRP маршрутизатора 2:

На маршрутизаторе 2

router eigrp 2000 
 network 172.16.0.0 
 network 10.0.0.0 
 no auto-summary

При выключенной автосводке маршрутизатор 1 видит все компоненты сети 10.0.0.0:

one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.3.0/24, 1 successors, FD is 46354176 
         via 20.1.1.1 (46354176/45842176), Serial0 
P 10.1.2.0/24, 1 successors, FD is 11049472 
         via 20.1.1.1 (11049472/10537472), Serial0 
P 10.1.1.0/24, 1 successors, FD is 11023872 
         via 20.1.1.1 (11023872/10511872), Serial0 
P 172.16.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0

Некоторые предупреждения, которые необходимо учитывать при суммировании внешних маршрутов, рассмотрены ниже в разделе "Автоматическое суммирование внешних маршрутов".

Ручное уплотнение

Окружение EIGRP позволяет суммировать внутренние и внешние маршруты фактически на любом внешнем битовом интерфейсе с помощью суммирования маршрутов вручную. Например, на рис. 14 показано, как маршрутизатор 2 суммирует 192.1.1.0/24, 192.1.2.0/24 и 192.1.3.0/24 в блок CIDR 192.1.0.0/22. .

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp14.gif

Ниже приведена конфигурация маршрутизатора 1:

two# show run 
.... 
! 
interface Serial0 
 ip address 10.1.50.1 255.255.255.0 
 ip summary-address eigrp 2000 192.1.0.0 255.255.252.0 
 no ip mroute-cache 
! 
.... 

two# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status

P 10.1.10.0/24, 1 successors, FD is 45842176 
         via Connected, Loopback0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.1.0/24, 1 successors, FD is 10511872 
         via Connected, Serial1 
P 192.1.0.0/22, 1 successors, FD is 10511872 
         via Summary (10511872/0), Null0 
P 192.1.3.0/24, 1 successors, FD is 10639872 
         via 192.1.1.1 (10639872/128256), Serial1 
P 192.1.2.0/24, 1 successors, FD is 10537472 
         via 192.1.1.1 (10537472/281600), Serial1

Примечание команда ip summary-address eigrp под интерфейсным Serial0 и объединенный маршрут через Null0. На маршрутизаторе 1 это отображается как внутренний маршрут:

  one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.10.0/24, 1 successors, FD is 46354176 
         via 10.1.50.1 (46354176/45842176), Serial0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.0.0/22, 1 successors, FD is 11023872 
         via 10.1.50.1 (11023872/10511872), Serial0

Автоматическое суммирование внешних маршрутов

EIGRP не будет автосуммировать внешние маршруты, пока не имеется компонент той же самой крупной сети, являющийся внутренним маршрутом. Для примера давайте рассмотрим рисунок 15.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp15.gif

Маршрутизатор 3 внедряет (инжектирует) внешние маршруты в 192.1.2.0/26 и 192.1.2.64/26 в EIGRP используя для этого команду redistribute connected (см. конфигурационные листинги ниже).

Маршрутизатор 3

interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Ethernet2
 ip address 10.1.2.1 255.255.255.0
!router eigrp 2000 
 redistribute connected 
 network 10.0.0.0 
 default-metric 10000 1 255 1 1500

При этой конфигурации маршрутизатора 3 маршрутная таблица на маршрутизаторе 1 показывает:

  one# show ip route
.... 
     10.0.0.0/8 is subnetted, 2 subnets 
D       10.1.2.0 [90/11023872] via 10.1.50.2, 00:02:03, Serial0 
C       10.1.50.0 is directly connected, Serial0 
     192.1.2.0/26 is subnetted, 1 subnets 
D EX    192.1.2.0 [170/11049472] via 10.1.50.2, 00:00:53, Serial0 
D EX    192.1.2.64 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

Несмотря на то, что обычно при автосуммировании маршрутизатор 3 суммирует маршруты 192.1.2.0/26 и 192.1.2.64/26 в один основной пункт назначения (192.1.2.0/24), в данном случае этого не произойдет, поскольку оба маршрута являются внешними. Однако, если перенастроить канал между маршрутизаторами Два и Три на адрес 192.1.2.128/26, а также добавить сетевые операторы для данной сети на маршрутизаторах Два и Три, в этом случае автоматическое суммирование 192.1.2.0/24 формируется на маршрутизаторе Два.

Маршрутизатор 3

 interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Serial0 
 ip address 192.1.2.130 255.255.255.192 
! 
router eigrp 2000 
 network 192.1.2.0

Теперь маршрутизатор 2 создает сводные данные для 192.1.2.0/24:

two# show ip route 
.... 
D       192.1.2.0/24 is a summary, 00:06:48, Null0
....

Маршрутизатор 1 показывает только объединенный маршрут:

 one# show ip route 
.... 
     10.0.0.0/8 is subnetted, 1 subnets 
C       10.1.1.0 is directly connected, Serial0 
D    192.1.2.0/24 [90/11023872] via 10.1.50.2, 00:00:36, Serial0

Обработка и область запросов

При обработке маршрутизатором запроса от соседа применяются следующие правила:

Запрос от Состояние маршрута Действие
сосед (не текущий преемник) пассивный ответ с информацией о текущем преемнике
преемник пассивный попытайтесь найти нового преемника; в случае успеха, ответ с новой информацией; если не успешный, отметьте недостижимое назначение и сделайте запрос всех соседних узлов кроме предыдущего наследника
любой сосед путь через данного соседа до получения запроса отсутствует ответ с оптимальным путем, в настоящее время известным
любой сосед неизвестно до запроса ответьте, что назначение недостижимо
сосед (не текущий преемник) активный если для этого направления не находится текущего продолжения (как обычно и происходит), следует ответ о недоступности
если есть подходящий преемник, отошлите текущую информацию о маршруте
преемник активный попытайтесь найти нового преемника; в случае успеха, ответ с новой информацией; если не успешный, отметьте недостижимое назначение и сделайте запрос всех соседних узлов кроме предыдущего наследника

Действия в таблице выше влияют на диапазон запроса в сети путем определения, сколько маршрутизаторы получают и отвечают на запрос, прежде чем сеть будет сходиться на новой топологии. Для просмотра обработки влияний этих правил на запрос пути нужно просмотреть схему 16 в сети, которая работает в нормальном режиме.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16.gif

Ожидается, что следующее может произойти с сетью 192.168.3.0/24 (крайняя правая сторона):

  • Маршрутизатор 1 имеет два маршрута к адресу 192.168.3.0/24:

    • через второй маршрутизатор при расстоянии 46533485 и подтвержденном расстоянии 20307200

    • посредством маршрутизатора 3 с расстоянием 20563200 и объявленному расстоянию 20307200

  • Маршрутизатор 1 выбирает путь через маршрутизатор 3 и сохраняет путь через маршрутизатор 2 в качестве вероятного приемника

  • Маршрутизаторы Два и Три показывают один путь к 192.168.3.0/24 через Маршрутизатор 4

Допустим, сбой на 192.168.3.0/24. Какая активность ожидается в данной сети? Рисунки 16a – 16h иллюстрируют данный процесс.

Маршрутизатор 5 отмечает 192.168.3.0/24 как недоступный и отправляет запрос маршрутизатору 4:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16a.gif

Маршрутизатор 4 при получении запроса от своего преемника пытается найти нового подходящего преемника для этой сети. Если таковой не будет обнаружен, тогда он пометит сеть 192.168.3.0/24 как недостижимую и отправит запросы маршрутизаторам 2 и 3:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16b.gif

В свою очередь маршрутизаторы 2 и 3 обнаружат, что они утратили единственно возможный маршрут в сеть 192.168.3.0/24. Соответственно с этим они пометят данный адрес как недостижимый и направят запросы маршрутизатору 1:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16c.gif

Для простоты предположим, что маршрутизатор 1 первым получит запрос от маршрутизатора 3 и пометит маршрут как недостижимый. Затем маршрутизатор 1 получает запрос от маршрутизатора 2. Хотя возможна другая последовательность, конечный результат будет один и тот же.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16d.gif

Маршрутизатор один отвечает на оба запроса откликами "недостижим" и в настоящий момент находится в пассивном режиме для 192.168.3.0/24:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16e.gif

Маршрутизаторы 2 и 3 отвечают на запрос маршрутизатора 4 и в настоящий момент находятся в пассивном режиме для 192.168.3.0/24:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16f.gif

Получив отклик от маршрутизатора 4, маршрутизатор 5 удалит из своей маршрутной таблицы запись о сети 192.168.3.0/24. В настоящий момент маршрутизатор 5 находится в пассивном режиме для сети 192.168.3.0/24. Он отправляет маршрутизатору 4 пакеты обновления, и таким образом маршрут удаляется из таблиц топологии и маршрутизации на всех оставшихся маршрутизаторах.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16g.gif

Необходимо понимать, что несмотря на то, что в сети могут существовать другие пути для запросов и что запросы могут обрабатываться в другой последовательности, все имеющиеся в сети маршрутизаторы все равно будут обрабатывать запрос для сети 192.168.3.0/24 в случае, если этот канал будет нарушен. Некоторые маршрутизаторы могут прекращать обработку более чем одного запроса (маршрутизатор 1 в этом примере). Если бы запросы действительно поступили на маршрутизаторы в другом порядке, тогда оказалось бы, что некоторые маршрутизаторы обрабатывали бы три или четыре запроса. Это наглядный пример несвязанного запроса в сети EIGRP.

Как влияет объединение точек на область запроса

Теперь давайте посмотреть на пути к 10.1.1.0/24 в той же сети:

  • В таблице топологии маршрутизатора 2 содержится запись для сети 10.1.1.0/24 со стоимостью равной 46251885 (через маршрутизатор 1).

  • Третий маршрутизатор содержит запись таблицы топологии для сети 10.1.1.0/24 с ценой 20281600 через первый маршрутизатор.

  • Маршрутизатор 4 имеет в таблице топологии запись для сети 10.0.0.0/8 (потому что маршрутизаторы 2 и 3 автосуммируются к границе главной сети) через маршрутизатор 3 с метрикой 20307200 (объявленное расстояние через маршрутизатор 2 больше, чем полная метрика через маршрутизатор 3, поэтому маршрутизатор 2 не является подходящим преемником).

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17.gif

Если сеть 10.1.1.0/24 перестает работать, маршрутизатор 1 помечает ее как недоступную и запрашивает у всех соседних узлов (маршрутизаторов 2 и 3) новый путь к этой сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17a.gif

Маршрутизатор Два, получив запрос от маршрутизатора Один, помечает маршрут как недостижимый (поскольку запрос идет от его преемника) и затем запрашивает маршрутизаторы Четыре и Три:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17b.gif

Когда маршрутизатор 3 получает запрос от маршрутизатора 1, он помечает назначение как недоступное и посылает запросы на маршрутизаторы 2 и 4:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17c.gif

Маршрутизатор 4, получая сообщение от Маршрутизатора 2 и 3, отвечает, что 10.1.1.0/24 не достигаем (заметьте, что маршрутизатор 4 не имеет данных о подсети, так как в него данные загружены только по маршруту 10.0.0.0/8):

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17d.gif

Второй и третий маршрутизаторы отвечают друг другу, что 10.1.1.0/24 недоступен:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17e.gif

Поскольку у второго и третьего маршрутизаторов нет невыполненных запросов, они отвечают первому маршрутизатору, что 10.1.1.0/24 недоступен:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17f.gif

Запрос в этом случае связывается автосведением на маршрутизаторах 2 и 3. Маршрутизатор 5 не участвует в запросе и в повторной сходимости сети. Запросы могут быть ограничены ручным суммированием, границами автономной системы и списками распространения.

Как границы автономной системы влияют на диапазон запросов

Если маршрутизатор повторно распределяет маршруты между двумя автономными системами EIGRP, он отвечает на запрос в рамках обычных правил обработки и отправляет новый запрос в другую автономную систему. Например, если соединение с сетью, подключенной через маршрутизатор 3, прерывается, маршрутизатор 3 помечает маршрут как недоступный и запрашивает у маршрутизатора 2 новый путь:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18.gif

Маршрутизатор 2 отвечает, что данная сеть недостижима, и запускает запрос в автономную систему 200 в направлении маршрутизатора 1. Как только маршрутизатор 3 получает ответ на свой исходный запрос, он удаляет маршрут из таблицы. Маршрутизатор 3 теперь пассивен для этой цепи:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18a.gif

Первый маршрутизатор отвечает второму маршрутизатору, и маршрут переходит в пассивный статус:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18b.gif

Так как исходный запрос не распространился через сеть (он был ограничен автономными границами системы), исходный запрос попадает во вторую автономную систему в виде нового запроса. Таким образом можно предотвратить проблемы зависания в активном состоянии (SIA) в сети, ограничив число маршрутизаторов, через которое должен пройти запрос до отправления ответа, но нельзя решить проблему в целом, заключающуюся в том, что запрос должен обрабатываться каждым маршрутизатором. Фактически, применение данного метода ограничения запроса может только ухудшить состояние за счет запрета автоматического объединения маршрутов, которые при других обстоятельствах были бы объединены (объединение внешних маршрутов не выполняется за исключением тех случаев, когда в данной крупной сети присутствуют внешние компоненты).

Как списки рассылки влияют на диапазон запросов

Вместо того, чтобы блокировать распространение запроса, листы распространения в EIGRP отмечают любой ответ запроса как недостижимый. В качестве примера рассмотрим схему на рисунке 19.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19.gif

В этой схеме:

  • Маршрутизатор 3 имеет список распределения, примененный для своих последовательных интерфейсов, который разрешает ему оповещать только сеть В.

  • Маршрутизаторы Один и Два не знают, что Сеть A достижима через Маршрутизатор 3 (Маршрутизатор 3 не используется в качестве транзитной точки между Маршрутизаторами Один и Два).

  • Маршрутизатор 3 использует маршрутизатор 1 в качестве предпочтительного пути в сеть А.и не использует маршрутизатор 2 в качестве возможного преемника.

При утрате связи с сетью А маршрутизатор 1 помечает этот маршрут как недостижимый и отправляет запрос маршрутизатору 3. Маршрутизатор 3 не объявляет путь к сети A из-за списка распределения для последовательных портов.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19a.gif

Маршрутизатор 3 отмечает этот маршрут как недоступный и отправляет запрос маршрутизатору 2:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19b.gif

Маршрутизатор 2 производит поиск в своей таблице топологии, в результате которого определяет, что у него есть разрешенное соединение с сетью А:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19c.gif

Маршрутизатор 2 отвечает, что сеть А достижима. Теперь у маршрутизатора 3 есть разрешенный путь:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19d.gif

Маршрутизатор 3 формирует ответ на запрос маршрутизатора 1, в котором из-за списка распределения указывается, что сеть A недоступна, хотя маршрутизатор 3 имеет допустимый маршрут к сети A:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19e.gif

Пошаговое продвижение пакетов

Некоторые протоколы маршрутизации в процессе адаптации к изменениям в сети используют всю доступную полосу пропускания каналов с низкой пропускной способностью. EIGRP избегает таких перегрузок, управляя скоростью продвижения пакетов в сети, во время которого используется только часть пропускной способности. Конфигурация EIGRP по умолчанию предусматривает использование до 50 процентов имеющейся пропускной способности, но это можно изменить следующей командой:

router(config-if)# 
ip bandwidth-percent eigrp 2 ? 
  <1-999999>  Maximum bandwidth percentage that EIGRP may use

В сущности, всякий раз, когда EIGRP ставит в очередь пакет, предназначенный для отправки через интерфейс, то для того чтобы определить задержку перед отправкой, он использует следующую формулу:

  • (8 * 100 * размер пакета в байтах) / (пропускная способность в кбит/с * процентная доля пропускной способности)

Например, если EIGRP помещает в очередь пакет, который будет передаваться по последовательному интерфейсу, который имеет пропускную способность 56k, и пакет составляет 512 байтов, EIGRP ждет:

  • (8 * 100 * 512 байтов) / (56000 битов в секунду * 50%-я пропускная способность) (8 * 100 * 512) / (56000 * 50) 409600 / 2800000 0.1463 секунды

Это позволяет пакету (или группы пакетов) по крайней мере 512 байтов быть переданным на этой ссылке, прежде чем EIGRP передаст свой пакет. Пошаговый таймер определяет время отправления пакета и обычно выражается в миллисекундах. Для пакета, указанного выше, время задержки перед отправкой составляет 0,1463 секунды. В интерфейсе show ip eigrp есть поле, которое отображает таймер регулирования скорости, как показано ниже:

router# show ip eigrp interface
IP-EIGRP interfaces for process 2	

                    Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0            1        0/0        28       0/15         127           0
Se1            1        0/0        44       0/15         211           0
router#

Отображенное время – это интервал продвижения MTU, самого большого пакета, который можно отправить через интерфейс.

Маршрутизация по умолчанию

В EIGRP маршрут по умолчанию можно создать двумя способами: 1) перераспределить статический маршрут; 2) выполнить суммирование в сеть 0.0.0.0/0. Используйте первый метод, если вам необходимо направить весь трафик, имеющий неизвестный пункт назначения, по маршруту по умолчанию, который находится в центральной части сети. Этот метод хорошо работает для объявления соединений с Интернетом. Например: :

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet) 
! 
router eigrp 100 
 redistribute static 
 default-metric 10000 1 255 1 1500

Статический маршрут, перенаправляемый в EIGRP, не обязательно должен быть сетевым адресом 0.0.0.0. При использовании другой сети необходимо воспользоваться командой ip default-network для установки сети в качестве сети по умолчанию. Более подробно см. "Настройка шлюза последней очереди".

Суммирование в маршрут по умолчанию действует, только когда требуется обеспечить удаленные сайты маршрутом по умолчанию. Поскольку суммирование настраивается для каждого интерфейса в отдельности, вам не потребуется прибегать к использованию листов распространения или других механизмов для того, чтобы предотвратить распространение маршрута по умолчанию в центральную часть (ядро) сети. Заметьте, что сводка на 0.0.0.0/0 замещает маршрут по умолчанию, полученный от любого другого протокола маршрутизации. Единственный способ настроить маршрут по умолчанию на маршрутизаторе с помощью этого метода состоит в том, чтобы настроить статический маршрут к 0.0.0.0/0. (Начинающийся в программном обеспечении Cisco IOS 12.0 (4) T, можно также настроить административное расстояние на конце команды ip summary-address eigrp , таким образом, локальная сводка не отвергает маршрут 0.0.0.0/0).

router eigrp 100 
 network 10.0.0.0 
! 
interface serial 0 
 encapsulation frame-relay 
 no ip address 
! 
interface serial 0.1 point-to-point 
 ip address 10.1.1.1 
 frame-relay interface-dlci 10 
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0

Балансировка нагрузки

Для четырех равноценных маршрутов в таблице маршрутизации протокол EIGRP указывает маршрутизатор, выравнивающий нагрузку. Тип балансировки нагрузки (по пакетам или по назначению) определяется типом коммутации, выполняемой на маршрутизаторе. EIGRP, однако, может распределять нагрузку по каналам с неодинаковой стоимостью.

Примечание: При использовании максимального числа путей можно настроить EIGRP для использования до шести равноценных путей.

Допустим, у нас имеется четыре пути к требуемому пункту назначения и эти пути имеют следующие метрики:

  • путь 1: 1100

  • путь 2: 1100

  • путь 3: 2000

  • путь 4: 4000

По умолчанию маршрутизатор направляет трафик как по пути 1, так и по пути 2. В протоколе EIGRP вы можете воспользоваться командой variance, чтобы указать маршрутизатору направлять трафик и по путям 3 и 4. Команда variance выполняет перемножение: трафик будет передан на любой канал, метрика которого меньше, чем наилучший путь, умноженный на дисперсию. Чтобы равномерно распределить нагрузку по путям 1, 2 используйте дисперсию равную 2, поскольку 1100 x 2 = 2200. Получающееся зачение выше значения метрики через путь 3. Подобным же образом, для того чтобы добавить путь 4, используйте дисперсию равную 4 при команде router eigrp. Более подробно см. Как работает распределение нагрузки c неравной стоимостью путей (дисперсия) в IGRP и EIGRP.

Каким же образом маршрутизатор будет распределять трафик по этим путям? Значение метрики каждого пути будет поделено на наибольшую метрику. Полученный результат будет округлен до ближайшего целого числа, а затем это число будет использовано в качестве счетчика совместного трафика.

router# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.2.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

В нашем примере счетчики совместного трафика имеют следующие значения:

  • для путей 1 и 2: 4000/1100 = 3

  • для пути 3: 4000/2000 = 2

  • для пути 4: 4000/4000 = 1

Таким образом, маршрутизатор отправит первые три пакета по пути 1, следующие три пакета – по пути 2, следующие два пакета – по пути 3, а затем следующие 4 пакета будут отправлены по пути 4. После этого маршрутизатор вернется в исходное положение и снова отправит первые три пакета по пути 1 и т.д.

Примечание: Даже при настроенной дисперсии EIGRP не будет отправлять трафик по пути с неравной стоимостью, если отмеченное расстояние превышает допустимое для данного конкретного маршрута значение. Дополнительные сведения см. в разделе "Возможное расстояние, фактическое расстояние и возможные следующие узлы".

Использование метрик

When you initially configure EIGRP, remember these two basic rules if you are attempting to influence EIGRP metrics:

  • Пропускная способность должна быть всегда равной фактической пропускной способности интерфейса (исключение составляют многоточечные последовательные каналы и другие ситуации, связанные с изменениями скорости из-за несовпадающих типов носителей).

  • Задержку всегда следует использовать для воздействия на решения о маршрутизации протокола EIGRP.

Поскольку для того чтобы определить скорость пересылки пакетов, EIGRP использует значение пропускной способности интерфейса, очень важно, чтобы это значение было задано правильно. Всегда используйте задержку, если вам требуется воздействовать на процесс выбора пути протоколом EIGRP.

При меньшей пропускной способности величина пропускной способности оказывает значительное воздействие на суммарную метрику; при более высокой пропускной способности задержка также оказывает значительное воздействие на суммарную метрику.

Использование административных тегов в перераспределении

Внешние административные теги полезны для разрыва петель при обмене маршрутами между EIGRP и другими протоколами. Выполняя маркировку маршрута, когда он перераспределяется в EIGRP, можно блокировать перераспределение из EIGRP во внешний протокол. Не возможно модифицировать административное расстояние для шлюза по умолчанию, который был изучен из внешнего маршрута, потому что в EIGRP модификация административного расстояния только просит внутренние маршруты. Для повышения метрики используйте route-map со списком префиксов; не изменяйте административное расстояние. Ниже мы приведем общий пример настройки этих тегов. Однако этот пример не демонстрирует всю процедуру настройки, которая используется для разрыва петель перераспределения.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20.gif

Маршрутизатор 3, распределяющий маршруты, связанные с EIGRP, показывает:

three# show run 

.... 

interface Loopback0 
 ip address 172.19.1.1 255.255.255.0 
! 
interface Ethernet0 
 ip address 172.16.1.1 255.255.255.0 
 loopback 
 no keepalive 
! 
interface Serial0 
 ip address 172.17.1.1 255.255.255.0 

.... 

router eigrp 444 
 redistribute connected route-map foo  
 network 172.17.0.0 
 default-metric 10000 1 255 1 1500 

.... 

access-list 10 permit 172.19.0.0 0.0.255.255 
route-map foo permit 10 
 match ip address 10 
 set tag 1 

.... 

three# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
         via Redistributed (2169856/0) 
P 172.16.1.0/24, 1 successors, FD is 281600 
         via Redistributed (281600/0) 
P 172.19.1.0/24, 1 successors, FD is 128256, tag is 1 
         via Redistributed (128256/0)

Маршрутизатор 2, перераспределяющий маршруты от EIGRP в RIP, показывает:

two# show run 

.... 

interface Serial0 
 ip address 172.17.1.2 255.255.255.0 
! 
interface Serial1 
 ip address 172.18.1.3 255.255.255.0 

.... 

router eigrp 444 
 network 172.17.0.0 
! 
router rip 
 redistribute eigrp 444 route-map foo 
 network 10.0.0.0 
 network 172.18.0.0 
 default-metric 1 
! 
no ip classless 
ip route 1.1.1.1 255.255.255.255 Serial0 
route-map foo deny 10 
 match tag 1 
! 
route-map foo permit 20 

.... 

two# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 172.16.1.0/24, 1 successors, FD is 2195456 
         via 172.17.1.1 (2195456/281600), Serial0 
P 172.19.1.0/24, 1 successors, FD is 2297856, tag is 1 
         via 172.17.1.1 (2297856/128256), Serial0

Обратите внимание на тег 1 на 172.19.1.0/24.

Маршрутизатор 1, получающий маршруты RIP, перенаправленные маршрутизатором 2, показывает:

one# show run

.... 

interface Serial0 
 ip address 172.18.1.2 255.255.255.0 
 no fair-queue 
 clockrate 1000000 

router rip 
 network 172.18.0.0 

.... 

one# show ip route 

Gateway of last resort is not set 

R    172.16.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
R    172.17.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
     172.18.0.0/24 is subnetted, 1 subnets 
C       172.18.1.0 is directly connected, Serial0

Обратите внимание, что 172.19.1.0/24 отсутствует.

Основные сведения о выходных данных команды EIGRP

show ip eigrp traffic

Эта команда используется для отображения информацию о EIGRP, названном конфигурациями и анонимной системой EIGRP (AS) конфигурации. Выходные данные этой команды показывают информацию, которой обменялись между соседним маршрутизатором EIGRP. Пояснения к каждой строке листинга приводятся после таблицы.

show ip eigrp traffic

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20a.gif

Описания конфигурации

  • Hellos передал/получил, показывает количество пакетов приветствия, передаваемых и полученных (передаваемый - 1927/received - 1930).

  • Обновления передали/получили показам количество обновленных пакетов, передаваемых и полученных (sent-20/received-39).

  • Запросы передали/получили средствам количество пакетов запроса, передаваемых и полученных (sent-10/received-18).

  • Ответы передали/получили, показывает количество пакетов ответа, передаваемых и полученных (sent-18/received-16).

  • Acks передал/получил, обозначает количество пакетов подтверждения, передаваемых и полученных (sent-66/received-41).

  • Запросы SIA передали/получили количество средств всунутых активных пакетов запроса, передаваемых и полученных (sent-0/received-0).

  • Ответы SIA передали/получили показам количество всунутых активных пакетов ответа, передаваемых и полученных (sent-0/received-0).

  • ID Процесса Hello является привет идентификатором процесса (270).

  • ID Процесса PDM обозначает идентификатор процесса IOS модуля иждивенца протокола (251).

  • Сокетная Очередь отображает IP к EIGRP счетчики очереди сокета Процесса Hello (current-0/max-2000/highest-1/drops-0).

  • Входная очередь показывает EIGRP Процесс Hello счетчикам очереди сокета PDM EIGRP (current-0/max-2000/highest-1/drops-0).

show ip eigrp topology

Эта команда только отображает возможных преемников. Для отображения всех записей в таблице топологии используйте команду show ip eigrp topology all-links . Пояснения к каждой строке листинга приводятся после таблицы.

show ip eigrp topology

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp22.gif

Описания конфигурации

  • A означает "активный". Также может отображаться "Р", что означает "пассивный".

  • 10.2.4.0/24 – адрес назначения или маска.

  • 0 successors указывает на количество преемников (или путей), имеющихся для данного адреса назначения; если слово "successors" написано заглавными буквами, это означает, что маршрут находится в переходном режиме.

  • FD 512640000, показывает допустимое расстояние, которое является лучшей метрикой для достижения этого назначения или лучшей метрики, известной, когда маршрут пошел активный.

  • тэг 0x0 можно задать и/или отфильтровать при помощи карт маршрутизации с командами set tag и match tag.

  • Q означает, что запрос ожидает обработки. В данном поле также может быть указано: "U" (ожидание обновления); "R" (ожидание ответа).

  • 1 replies показывает количество незаконченных ответов.

  • active 00:00:01 показывает, как долго этот маршрут был активен.

  • происхождение запроса: Local origin указывает на то, что источником запроса (local origin) является данный маршрут. В данном поле также может быть указано: несколька источников, означая, что множественные соседние узлы передали запросы на этом назначении, но не преемнике; или Исходящий от преемника, означая преемника инициировал запрос.

  • посредством 10.1.2.2 показывает, что мы узнали про этот маршрут от соседа, чей адрес 10.1.2.2. В данном поле также может быть указано: Connected (подключен) – если сеть напрямую подключена к этому маршрутизатору; Redistributed (перераспределен) – если этот маршрут перераспределяется в EIGRP на данном маршрутизаторе; Summary (суммарный) – если данный маршрут является суммарным маршрутом, созданном на данном маршрутизаторе.

  • (Бесконечность/Бесконечность) показывает метрику для достижения этого пути через этот соседний узел в первом поле и объявленного расстояния через этот соседний узел во втором поле.

  • "r" показывает, что данному соседу был послан запрос и ожидается ответ.

  • Q – это флаг посылки для этого маршрутизатора, означающий, что есть незаконченная очередь. В данном поле также может быть указано: "U" (ожидание обновления); "R" (ожидание ответа).

  • Serial1 – это интерфейс, через который можно получить доступ к этому соседнему узлу.

  • VIA 10.1.1.2 показывает соседнее устройство, от которого ожидается ответ.

  • r означает, что у этого соседа был запрошен маршрут и ответ еще не получен.

  • Serial0 – интерфейс, через который этот сосед достижим.

  • Serial1 посредством 10.1.2.2 (512640000/128256) показывает, что используется этот маршрут (указывает, какой путь выберет следующий путь/назначение при наличии нескольких равноценных маршрутов).

show ip eigrp topology <сеть>

Эта команда отображает все записи в таблице топологии для этого назначения, а не только вероятных наследников. Пояснения к каждой строке листинга приводятся после таблицы.

show ip eigrp topology network

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp23.gif

Описания конфигурации

  • Состояние Пассивно, означает, что сеть находится в пассивном состоянии, или, другими словами, мы не ищем путь к этой сети. В стабильной сети маршруты почти всегда находятся в пассивном состоянии.

  • Флаг начала запроса равен 1. Если этот маршрут активен, это поле предоставляет сведения о том, кто послал запрос.

    • 0: данный маршрут является активным, но для него не был сформирован запрос (поиск возможного преемника осуществляется локально).

    • 1: данный маршрутизатор сформировал запрос для данного маршрута (или маршрут является пассивным).

    • 2: для данного запроса выполняются множественные диффузионные расчеты. Этот маршрутизатор получил более одного запроса на данный маршрут от нескольких источников.

    • 3: маршрутизатор, от которого был получен маршрут в эту сеть, запрашивает другой маршрут.

    • 4: множество источников запроса для данного маршрута, включая маршрутизатор, с которого был получен этот маршрут. Сходен с 2, но также означает наличие строки источника запроса, которая описывает запросы, ожидающие выполнения для данного пути.

  • 2 Successor(s) означает, что существуют два возможных пути в эту сеть.

  • FD – 307200, показывающий лучшую текущую метрику для этой сети. Если маршрут активен, это указывает метрику пути, ранее использовавшегося для направления пакетов в эту сеть.

  • Routing Descriptor Blocks Каждая из последующих записей характеризует один путь в эту сеть.

    • 10.1.1.2 (Ethernet1) – это следующий узел сети и интерфейс, через который доступен следующий узел.

    • от 10.1.2.2 источник этой информации о пути.

    • Флаг отправки:

      • 0x0: При наличии пакетов, которые необходимо отправить в связи с данной записью, данный параметр указывает тип пакета.

      • 0x1: Этот маршрутизатор получил запрос на эту сеть и нуждается в отправке одноадресного ответа.

      • 0x2: Данный маршрут активен, и следует разослать пакеты очереди многоадресной рассылки.

      • 0x3: Данный маршрут изменился, и следует разослать пакеты многоадресной рассылки.

  • Комбинированная метрика (307200/281600) отображает общие посчитанные расходы сети. В скобках: первое число – это суммарные расходы до этой сети при использовании этого пути, включая расходы до следующего узла. . Второе число в скобках – это объявленное расстояние, или, другими словами, затраты маршрутизатора следующего узла.

  • "Внутренний маршрут" означает, что этот маршрут изначально был внутри этой анонимной системы (AS) EIGRP. Если маршрут был перераспределен в EIGRP AS, данное поле будет указывать на то, что маршрут является внешним.

  • Vector metric показывает индивидуальные метрики, используемые EIGRP для расчета расходов в какую-либо сеть. EIGRP не распространяет по всей сети информацию об общих расходах. Вместо этого распространяются векторные метрики, и каждый маршрутизатор самостоятельно рассчитывает расходы и объявленное расстояние.

    • Минимальная пропускная способность 10000 кбит показывает самую низкую пропускную способность пути к этой сети.

    • Общая задержка 2000 мкс соответствует сумме значений задержки в пути для данной сети.

    • Значение надежности 0/255 указывает на фактор надежности. Данное число рассчитывается динамически, но при этом оно не является числом, используемым по умолчанию при расчете метрик.

    • Load is 1/255 указывает величину нагрузки на линию. Это значение вычисляется динамически, но не используется по умолчанию при расчете EIGRP стоимости использования пути.

    • Минимальное значение MTU составляет 1500. Данное поле не используется при вычислении метрики.

    • Hop count is 2 Данное поле не используется при расчете метрик. Однако указанное значение ограничивает максимальный размер EIGRP AS. Максимальное количество переходов, принимаемое EIGRP по умолчанию, составляет 100, хотя максимальное число переходов в соответствии с метрикой при настройке может достигать 220.

Для внешних маршрутов (External Route) добавляется приведенная ниже информация. Пояснения к каждой строке листинга приводятся после таблицы.

External Route

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp24.gif

Описания конфигурации

  • Вызывающий маршрутизатор показывает, что это маршрутизатор, который вставил этот маршрут в EIGRP AS.

  • Внешняя AS указывает автономную систему, являющуюся источником этого маршрута (если таковая имеется).

  • Внешний протокол показывает, от какого протокола (если такой есть) поступил данный маршрут.

  • external metric отображает внутреннюю метрику внешнего протокола.

  • Administrator Tag (Тег администратора) может быть установлен и/или отфильтрован с помощью карт маршрутов с командами set tag и match tag.

show ip eigrp topology [активный | ожидающий | нулевые преемники]

Тот же формат выходных данных, что и у команды show ip eigrp topology, но также отображает часть таблицы топологии.

show ip eigrp topology all-links

Такой же формат выходных данных, как и для топологии show ip eigrp, но вместо вероятных наследников отображаются все каналы в таблице топологии.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 16406