Cервисы организации сетевого доступа к приложениям : Cisco LocalDirector серии 400

Настройка стандарта и обработки отказа в LocalDirector

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Cisco объявила о конце продажи для Cisco LocalDirector. "Для получения дополнительной информации см. касающиеся LocalDirector 400 Series ""Уведомления об окончании срока эксплуатации и продаж"" и ""Информационные бюллетени по продуктам (End-of-Life and End-of-Sale Notices and Product Bulletins).".


Содержание


Введение

Информация в этих Технических примечаниях применяется ко всем версиям программного и аппаратного обеспечения Cisco LocalDirector в конфигурации аварийного переключения.

Два типа аварийного переключения могут быть внедрены в LocalDirector: стандартное переключение при отказе и statefull-переключение при отказе. в стандарте (non-statefull) аварийное переключение, вся информация о существующем соединении потеряна на аварийное переключение; однако полноценное переключение при отказе сохраняет сведения о сеансе, а также о сеансе с однонаправленными запросами.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Этот документ применяется ко всем версиям программного и аппаратного обеспечения Cisco LocalDirector в конфигурации аварийного переключения.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Команды обработки отказа

  • failover ip address ip_address - настраивает IP-адрес для переключения при отказе. Аргумент ip_address указывает на IP-адрес, используемый резервным модулем для передачи с активным модулем. Используйте этот IP-адрес с командой ping для проверки состояния резервного устройства. Этот адрес должен принадлежать той же сети, что и IP-адрес системы. Например, если системный IP-адрес - 192.168.1.1, установите IP-адрес для ситуации отказа в 192.168.1.2.

  • команда failover [active] дает доступ к дополнительной функции отказа. С помощью дополнительного активного аргумента LocalDirector устанавливается в качестве активного устройства.

  • реплицируйте интерфейс interface_number — Включает аварийное переключение с учетом состояния и задает интерфейс для передачи реплицированных данных. Аргумент interface_number указывает номер интерфейса, с помощью которого активный модуль LocalDirector отправляет данные репликации соединений резервному модулю. Значение по умолчанию - интерфейс 0.

  • команда failover alias ip address ip_address назначает альтернативный IP-адрес в случае переключения при отказе. Этот IP-адрес используется резервным модулем для взаимодействия с активным модулем.

  • failover reset – выводит устройство из неисправного состояния.

  • show failover – отображает состояние LocalDirector после отказа, состояние кабельного соединения, первичное и вторичное состояние хоста и характеристики интерфейса.

  • завершение работы Ethernet | fddi interface_number — Отключает интерфейс.

Для получения дополнительной информации обратитесь к Справочнику по командам LocalDirector.

Конфигурации

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

LocalDirector в механизме стандартного переключения при отказе (Standard Failover)

Это - базовая конфигурация LocalDirector в стандартном аварийном переключении:

LocalDirector в механизме стандартного переключения при отказе (Standard Failover)
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 auto 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp 
: end 
[OK] 
localdirector(config)#

LocalDirector в механизме Statefull Failover

Ниже пример конфигурации LocalDirector в аварийном переключении с учетом состояния. Модули переключения при отказе с учетом состояния совместно используют информацию о подключении для активных соединений и могут настраиваться для каждой виртуальной частной сети в отдельности. При каждом изменении состояния соединения по протоколу управления передачей, Transmission Control Protocol (TCP) данные посылаются на дежурный LocalDirector по протоколу LocalDirector-statefull. Это позволяет текущему состоянию всех сеансов TCP быть отраженным к резервному LocalDirector.

Протокол LocalDirector-statefull использует пакеты UDP для отправки изменений состояния на резервный протокол LocalDirector через интерфейс Ethernet. Используйте отдельный Интерфейс Ethernet для передачи сообщений аварийного переключения с учетом состояния. С аварийным переключением с учетом состояния нет никакого прерывания сервиса клиенту. Этот вариант идеален для критически-важных приложений и обеспечивает высокую доступность.

Примечание: В этом примере для передачи сведений о состоянии используется интерфейс Ethernet 2 с соединением между двумя LocalDirector. Данный пример также использует, они реплицируют команды:

replicate interface 2 
replicate 10.1.1.5:0:0:tcp

Эти команды сообщают средству LocalDirector, что для всей Ethernet 2 нужно скопировать состояние соединения из активных модулей в ожидающие и, кроме того, скопировать все сведения о состояниях из виртуальной 10.1.1.5 в ожидающий модуль.

LocalDirector в механизме Statefull Failover
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
no shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 100full 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
replicate interface 2 
replicate 10.1.1.5:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp

Примечание: Все интерфейсы первоначально находятся в режиме ожидания, означая, что не запустился мониторинг сети. После того, как сетевые интерфейсы входят в обычный режим, мониторинг сети начинается. Это случается, когда сообщения LocalDirector-HELLO рассылаются каждые пять секунд.

Если прошёл 30-секундный интервал без доставки сообщения LocalDirector-HELLO, модуль переходит в режим testing для определения, какой модуль неисправен. Если последовательный кабель отсоединить, модули сохранят свою текущую роль. Если модуль не пройдет тест, то это станет отказавшим, и другой модуль станет активным. Каждый раз? состояние? из изменений TCP - подключения данные передаются резервному LocalDirector через Localdirector-statefull протокол. Состояние всех сеансов TCP копируется в резервный LocalDirector. Если действительное изменено для поддержки аварийного переключения с учетом состояния тогда, информация о состоянии для только новых соединений передается резервному LocalDirector. Протокол состояний LocalDirector не копирует состояние существующих TCP сеансов.

Проверка статуса устранения неисправности

Команда show failover может использоваться для отображения текущего статуса аварийного переключения модулей и их интерфейсов, как показано в данном примере:

Failover Off 
Cable status: My side not connected 
        This host: Secondary - Active 
                Active time: 1 weeks, 3 days, 1 hours, 2 minutes, 5 seconds 
                Interface 5 (10.86.16.225): Normal (Waiting) 
                Interface 4 (10.86.16.225): Normal (Waiting) 
                Interface 3 (10.86.16.225): Normal (Administratively down) 
                Interface 2 (10.86.16.225): Normal (Administratively down) 
                Interface 1 (10.86.16.225): Normal (Waiting) 
                Interface 0 (10.86.16.225): Normal (Waiting) 
        Other host: Secondary - Standby 
                Interface 5 (0.0.0.0): Normal (Waiting) 
                Interface 4 (0.0.0.0): Normal (Waiting) 
                Interface 3 (0.0.0.0): Normal (Administratively down) 
                Interface 2 (0.0.0.0): Normal (Administratively down) 
                Interface 1 (0.0.0.0): Normal (Waiting) 
                Interface 0 (0.0.0.0): Normal (Waiting)

Это показывает, что пакеты приветствия пересылаются от одного модуля к другому и обратно и что два интерфейса на LD отключены.


Дополнительные сведения


Document ID: 15060