Коммутация LAN : Маршрутизация между виртуальными локальными сетями (IVR)

Настройка маршрутизации InterVLAN и транка ISL/802.1Q на коммутаторах Catalyst 2900XL/3500XL/2950 с использованием внешнего маршрутизатора

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (20 октября 2015) | Отзыв


Содержание


Введение

В данном документе представлены примеры настройки канала InterSwitch (ISL) и транкинга 802.1Q между коммутатором Catalyst 3512-XL и маршрутизатором Cisco 2600; отображены результаты выполнения каждой команды. Чтобы получить такие же результаты в сценариях, представленных в данном документе, можно использовать маршрутизаторы Cisco 3600, 4500/4700 или семейства Cisco 2600 с интерфейсами FastEthernet, а также любые коммутаторы Catalyst 2900XL, 3500XL, 2940, 2950 или 2970.

С помощью транкинга осуществляется трафик между двумя устройствами из нескольких сетей VLAN через двухточечное соединение. Транкинг Ethernet может быть реализован двумя способами:

  • ISL (частный протокол Cisco, и не поддерживаемый 2940 или коммутаторами серии "2950")

  • 802.1Q (стандарт Института инженеров по электротехнике и электронике IEEE)

Мы создадим магистраль, которая будет передавать трафик из двух VLAN (VLAN1 и VLAN2) через один канал между коммутатором Catalyst 3500 и маршрутизатором Cisco 2600.

Для создания маршрутизации между сетями VLAN1 и VLAN2 используется маршрутизатор Cisco 2600. Коммутаторы Catalyst 2900XL/3500XL/2940/2950/2970 - это коммутаторы уровня 2 (L2), не способные осуществлять маршрутизацию и коммуникацию между VLAN. Для получения дальнейшей информации на Маршрутизации между виртуальными локальными сетями (IVR), обратитесь к Маршрутизации Между Главой обзора Виртуальных локальных сетей Cisco Руководство по конфигурации Сервисов коммутации IOS�, релиз 12.1.

Для создания примеров этого документа в лабораторных условиях эксплуатации с чистыми конфигурациями использовались следующие коммутаторы:

  • Cisco IOS 12.0 выполнения коммутатора Catalyst 3512XL (5.x) XU

  • Маршрутизатор Cisco 2621 под управлением операционной системы Cisco IOS версии 12.1(3)T

  • Cisco IOS 12.1 (1) T выполнения маршрутизатора Cisco 2621

Конфигурации, рассматриваемые в этом документе, были реализованы в изолированной среде. Перед использованием любой конфигурации и команды необходимо изучить потенциальное воздействие не сеть до их использования. Для приведения каждого устройства к единой конфигурации по умолчанию настройки на всех устройствах были очищены при помощи команды write erase.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Важные примечания

Для Catalyst 2900XL/3500XL/2940/2950/2970 Коммутаторы:

Коммутаторы Catalyst 2940 и 2950 поддерживают только транкинг 802.1Q и не поддерживают ISL-транкинг.

На коммутаторе Catalyst 2900XL с модулем DRAM в 4 Мб группирование каналов поддерживается только на следующих модулях:

  • WS-X2914-XL-V: 4-портовый модуль коммутации 10/100 ISL/802.1Q

  • WS-X2922-XL-V: с 2 портами 100BaseFX модуль коммутатора ISL/802.1Q

  • WS-X2924-XL-V: с 4 портами 100BaseFX модуль коммутатора ISL/802.1Q

  • WS-X2931-XL: Восходящий канал 1000BaseX для коммутатора Catalyst 2900 XL

  • WS-X2932-XL: Восходящий канал 1000BaseT для Catalyst 2900 XL

См. Таблицу 1 ниже для текущего списка моделей коммутатора, которые поддерживают транкинг:

Таблица 1

Модели коммутаторов Минимальные требования к транкингу ISL Минимальная версия, необходимая для транка IEEE 802.1Q Текущий выпуск, необходимый для группирования каналов (ISL/802.1Q)
WS-C2916M-XL (4-мегабайтный коммутатор) 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Enterprise Edition) 11.2(8.6)SA6 (Original Edition)
C2912-XL 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Enterprise Edition) 12.0(5)WC(1) или более поздняя версия
C2924-XL 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Enterprise Edition) 12.0(5)WC(1) или более поздняя версия
WS-C2924C-XL 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Enterprise Edition) 12.0(5)WC(1) или более поздняя версия
WS-C2924M-XL 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Enterprise Edition) 12.0(5)WC(1) или более поздняя версия
WS-C2912MF-XL 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Enterprise Edition) 12.0(5)WC(1) или более поздняя версия
WS-C2924M-XL-DC 12.0 (5) XU 12.0 (5) XU 12.0(5)WC(1) или более поздняя версия
WS-C3508G-XL 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Enterprise Edition) 12.0(5)WC(1) или более поздняя версия
WS-C3512-XL 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Original Edition) 12.0(5)WC(1) или более поздняя версия
WS-C3524-XL 11.2(8)SA4 (Enterprise Edition) 11.2(8)SA5 (Enterprise Edition) 12.0(5)WC(1) или более поздняя версия
WS-C3548-XL 12.0(5)XP (Enterprise Edition) 12.0(5)XP (Enterprise Edition) 12.0(5)WC(1) или более поздняя версия
WS-C3524-PWR-XL 12.0 (5) XU 12.0 (5) XU 12.0(5)WC(1) или более поздняя версия
WS-C2940-8TF ISL не поддерживается 12.1 (13) AY 12.1(13)AY или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2940-8TT ISL не поддерживается 12.1 (13) AY 12.1(13)AY или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950-12 ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950-24 ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950C-24 ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950T-24 ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950G-12-EI ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950G-24-EI ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950G-48-EI ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950SX-24 ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2950-24-EI-DC ISL не поддерживается 12.0 (5) ТУАЛЕТ (1) 12.0(5)WC(1) или более поздняя версия для 802.1Q. ISL не поддерживается.
WS-C2955T-12 ISL не поддерживается 12.1 (13) EA1 12.1 (13) EA1 или позже для 802.1Q. ISL не поддерживается.
WS-C2955S-12 ISL не поддерживается 12.1 (13) EA1 12.1 (13) EA1 или позже для 802.1Q. ISL не поддерживается.
WS-C2955C-12 ISL не поддерживается 12.1 (13) EA1 12.1 (13) EA1 или позже для 802.1Q. ISL не поддерживается.
WS-C2970G-24T 12.1 (11) AX 12.1 (11) AX 12.1(11)AX или более поздней версии
WS-C2970G-24TS 12.1 (14) EA1 12.1 (14) EA1 12.1 (14) EA1 или позже

Примечание: В вышеупомянутой таблице только WS-C2916M-XL является коммутатором с ОЗУ на 4 МБ. Другие коммутаторы, приведенные в списке, имеют 8 Мб DRAM. Чтобы определить объем памяти коммутатора (4 Мб или 8 Мб динамического ОЗУ), на уровне пользователя введите команду "show version". Для получения дополнительной информации см. раздел "Как определить объем памяти коммутатора с помощью интерфейса командной строки" в документе "Обновление программного обеспечения коммутаторов Catalyst 2900-XL/3500-XL с помощью интерфейса командной строки (CLI)".

Примечание: В Catalyst 2900XL/3500XL/2940/2950/2970 коммутаторы, интерфейс виртуальной локальной сети (VLAN), например, внутренний VLAN 1, внутренний VLAN 2, внутренний VLAN x, может быть создан для каждой VLAN, которая настроена на коммутаторе. Однако одновременно в качестве управляющей виртуальной сети можно использовать только одну сеть. IP-адрес назначается только интерфейсу VLAN для управляющей сети. Если назначить IP-адрес интерфейсу другой сети VLAN, которая не используется как VLAN управления, этот интерфейс не будет активизирован. Желательно создать интерфейс VLAN только для управляющей VLAN.

Для маршрутизаторов Cisco 2600:

Для группирования магистралей 802.1Q одна сеть VLAN не маркируется. Такая виртуальная сеть VLAN называется собственной VLAN. Сеть Native VLAN используется для передачи неразмеченного трафика, когда порт находится в режиме транкинга 802.1Q. При настройке транкинга 802.1Q крайне важно учитывать то, что собственная виртуальная локальная сеть должна быть одинаково настроена на каждой стороне магистральной линии. Это общая ошибка - не согласовывать внутренние локальный виртуальные сети при настройке конфигурации 802.1Q тракинга между маршрутизатором и коммутатором. Для получения дополнительной информации на собственных VLAN, обратитесь к разделу IEEE 802.1Q Использования моста между сетями VLAN IEEE 802.1Q в Новых характеристиках в Релизе 12.1 (3) T.

В этом примере конфигурации собственным VLAN является VLAN1, по умолчанию, и на маршрутизаторе Cisco 2621 и на Коммутаторе Catalyst 3512XL. В зависимости от требований сети, возможно, следует использовать стандартную VLAN вместо установленной по умолчанию VLAN1. В разделе "Конфигурации" этого документа были упомянуты команды о том, как изменить собственную VLAN на маршрутизаторе Cisco 2600 и коммутаторе Catalyst 3500XL.

Представленные в этом документе примеры конфигураций можно использовать для маршрутизаторов серий Cisco 2600/3600/4500/4700 с интерфейсами Fast Ethernet или сетевыми модулями Fast Ethernet. Также нужно убедиться, что используется версия Cisco IOS, поддерживающая группирование магистралей виртуальных локальных сетей ISL/802.1Q. Полный список маршрутизаторов Cisco 2600/3600/4500/4700, поддерживающих транкинг виртуальных локальных сетей ISL/802.1Q, и поддерживаемые версии Cisco IOS, см. ниже в таблице 2.

Таблица 2

Модели маршрутизатора Минимальные требования к транкингу ISL Минимальная версия, необходимая для транка IEEE 802.1Q Минимальные требования к набору возможностей (ISL/802.1Q)
Cisco 2620 11.3 (3a) T 12.0 (1) T IP PLUS / IP PLUS
Cisco 2621 11.3 (3a) T 12.0 (1) T IP PLUS / IP PLUS
Cisco 2620 12.1 (3a) T 12.1 (3a) T IP PLUS / IP PLUS
Cisco 2650 12.1 (3a) T 12.1 (3a) T IP PLUS / IP PLUS
Cisco 3620 11.3 (1) T 12.0 (1) T IP PLUS / IP PLUS
Cisco 3640 11.3 (1) T 12.0 (1) T IP PLUS / IP PLUS
Cisco 3661 12.0 (5) T 12.0 (5) T IP PLUS / IP PLUS
Cisco 3662 12.0 (5) T 12.0 (5) T IP PLUS / IP PLUS
Cisco 4500-M 11.3 (1) T 12.0 (1) T IP PLUS / IP PLUS
Cisco 4700-M 11.3 (1) T 12.0 (1) T IP PLUS / IP PLUS

Примечание: Таблица 2 только перечисляет минимум или текущее обслуживание / основные релизы, которые поддерживают этот пример конфигурации. Модели маршрутизаторов с определенными сетевыми модулями могут иметь различные минимальные версии Cisco IOS. Для получения полного списка минимально поддерживаемого программного обеспечения для любого семейства маршрутизаторов используйте средство Software Advisor (только для зарегистрированных пользователей) .

Примечание: Минимальный уровень поддержки релиза может не обязательно быть рекомендуемым релизом. Для определения наилучшей отладочной версии для конкретного продукта Cisco см. списки ошибок по компонентам продукта с помощью средства Bug Toolkit (только для зарегистрированных пользователей).

Примечание: Таблица 2 перечисляет минимальный набор функций, требуемый сделать Маршрутизацию между виртуальными локальными сетями (IVR) IP и соединяющий магистралью для поддержки этого примера конфигурации. Для полного списка других наборов функций, поддерживаемых в других версиях Cisco IOS и на других платформах, используйте область загрузки ПО.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме.

/image/gif/paws/14976/50a.jpg

Конфигурации

В данном документе используются следующие конфигурации.

Примечание: Модели маршрутизаторов с определенными сетевыми модулями могут иметь различные минимальные версии Cisco IOS, поддерживающие ISL-транкинг.

  • Catalyst 3512-XL

  • Маршрутизатор Cisco 2600

  • Конфигурация 802.1Q на маршрутизаторе для версий Cisco IOS до 12.1(3)T

Catalyst 3512-XL

Примечание: Следующие снимки экрана показывают команды, которые были введены на коммутаторе 3512XL. Комментарии между командами, написанные синим курсивом, служат для объяснения определенных команд и шагов.


!-- Set the privileged mode


!-- and Telnet password on the switch.

switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z


!-- Set the IP address and default gateway for VLAN1 for management purposes.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end

!-- Set the VTP Mode.
!-- In our example, we have set the mode to be transparent.
!-- Depending on your network, set the VTP Mode accordingly.
!-- For details on VTP,
!-- refer to
!-- Creating and Maintaining VLANs on Catalyst 2900XL and 3500XL Switches.

3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.


!-- Adding VLAN2. VLAN1 already exists by default.

3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....


!-- Enable trunking on the interface fastEthernet 0/1.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk


!-- Enter the trunking encapsulation as either isl

3512xl(config-if)#switchport trunk encapsulation isl

!-- or as dot1q:


3512xl(config-if)#switchport trunk encapsulation dot1q

!-- In case of 2940/2950 series switches, none of the above two commands are used,
!-- 2940/2950 series switches only support 802.1q encapsulation which is configured automatically,
!-- when trunking is enabled on the interface by using switchport mode trunk command.

!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- Depending on your network needs, you may change
!-- the native VLAN to be other than VLAN1,
!-- but it is very important that you change the native VLAN
!-- on the router accordingly.
!-- You may change the native VLAN, if needed, by using the following command:
!-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>

!-- Allow all VLANs on the trunk.

3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit


!-- The following set of commands will place FastEthernet 0/2
!-- into VLAN2 and enable portfast on the interface.

3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit


!-- FastEthernet 0/3 is already in VLAN1 by default.
!-- Enable portfast on the interface.

3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z

!-- For details on why to enable portfast,
!-- refer to:
!-- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.
!-- Remember to save the configuration.

3512xl#write memory
Building configuration...

3512xl#

--------------------------------------------------------------------------------

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
  switchport mode trunk
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/1:
!-- interface FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk

!
interface FastEthernet0/2
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

Маршрутизатор 2600

Примечание: На следующих экранных снимках показаны команды, введенные в маршрутизаторе Cisco 2600. Комментарии между командами, написанные синим курсивом, служат для объяснения определенных команд и шагов.


!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.
!-- No L2 or Layer 3 (L3) configuration is done here.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.1.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.1


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 1


!-- or as dot1q:
!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- On the router, configure VLAN1 as the native VLAN.

c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  <cr>
c2600(config-subif)#encapsulation dot1Q 1 native

!-- On the switch, if you have a native VLAN other than VLAN1,
!-- on the router, configure the same VLAN to be the native VLAN,
!-- by using the above command.

Примечание: Исходная команда инкапсуляции dot1Q 1 добавлена в Cisco IOS версия 12.1(3)T. Если используется более ранняя версия Cisco IOS, для настройки транкинга 802.1q маршрутизатора см. раздел данного документа 802.1q Настройка Cisco IOS версий старше 12.1(3)T.


!-- Configure L3 information on the sub-interface 0/0.1.

c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.2.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.2


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 2


!-- or as dot1q:

c2600(config-subif)#encapsulation dot1Q 2


!-- Configure L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

Примечание: Чтобы эта система заработала, а между рабочими станциями 1 и 2 успешно проходили ping-пакеты, следует убедиться, что шлюзы по умолчанию на обеих станциях настроены верно. Для рабочей станции 1 шлюзом по умолчанию должен быть 10.10.11.1, а для рабочей станции 2 шлюзом по умолчанию должен быть 10.10.10.1. Подробные сведения о настройке шлюзов по умолчанию на рабочих станциях см. в соответствующих разделах настоящего документа.

Примечание: Следующий параграф применяется при конфигурировании транкинга 802.1Q между маршрутизатором или коммутатором.

Примечание: Если вы придерживались действий настройки, перечисленных в вышеупомянутых разделах, и все еще не в состоянии пропинговать через VLAN (между workstation1 и workstation2), то существует возможность, что вы столкнулись с Предупреждением CSCds42715, в котором ключевое слово исходной виртуальной локальной сети (VLAN) 802.1Q не функционирует должным образом, когда включена быстрая коммутация. Исправление этой ошибки было внедрено в следующие версии кода: 12.2(0.5), 12.2(0.5)T, 12.1(5)DC, 12.1(5)YB, 12.2(0.18)S, 12.1(5)YD02, 12.2(2)B, 12.2(15)ZN. Проверить наличие и краткое описание ошибки можно с помощью средства Bug Toolkit (только для зарегистрированных пользователей), введя идентификатор ошибки CSCds42715.


--------------------------------------------------------------------------------

c2600#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.1:
!-- interface FastEthernet0/0.1
!-- encapsulation dot1Q 1 native
!-- ip address 10.10.10.1 255.255.255.0

!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.2:
!-- interface FastEthernet0/0.2
!-- encapsulation dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

Конфигурация 802.1Q на маршрутизаторе для версий Cisco IOS до 12.1(3)T
Как было сказано выше в этом документе, при настройке транкинга 802.1Q очень важно добиться совпадения с собственной виртуальной локальной сетью на линии. В версиях программного обеспечения Cisco IOS младше 12.1(3)T невозможно точно указать собственную виртуальную локальную сеть, поскольку команда "encapsulation dot1Q 1 native" недоступна в подчиненном интерфейсе. В ранних версиях Cisco IOS важно настраивать интерфейс виртуальной локальной сети не как подчиненный интерфейс, который в нашем примере - VLAN1. При неправильной настройке маршрутизатор будет ожидать фрейма "tag dot1q" на VLAN1, а коммутатор не ожидает тега на VLAN1. В результате между VLAN1 на коммутаторе и маршрутизаторе не будет проходить трафик. В подобных ситуациях всегда определяйте конфигурацию собственной виртуальной локальной сети в основном интерфейсе, а при транкинге создавайте подчиненный интерфейс для всех остальных VLAN. В текущей лабораторной установке выполните следующие действия для настройки маршрутизатора Cisco 2600:

!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut


!-- Note that the IP address for VLAN1 is configured on the main interface,
!-- and no encapsulation for VLAN1 will be done under the sub-interface.

c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit


!-- Configure dot1q encapsulation for VLAN 2
!-- on sub-interface fastEthernet 0/0.2.

c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#


!-- Configuring L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

Примечание: Чтобы эта система заработала, а между рабочими станциями 1 и 2 успешно проходили ping-пакеты, следует убедиться, что шлюзы по умолчанию на обеих станциях настроены верно. Для рабочей станции 1 шлюзом по умолчанию должен быть 10.10.11.1, а для рабочей станции 2 шлюзом по умолчанию должен быть 10.10.10.1. Для получения дополнительной информации об установке шлюзов по умолчанию на рабочих станциях обратитесь к соответствующим разделам данного документа.

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

команды "debug" и "show"

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

На коммутаторе Catalyst 2900XL/3500XL/2950 используйте следующие команды:

  • покажите интервал {FastEthernet | GigabitEthernet} порт коммутатора <module/port>

  • show vlan

  • show vtp status

На Маршрутизаторе Cisco 2600 используйте следующие команды:

  • show vlan

  • show interface

Пример выходных данных команды show

Catalyst 3500XL Switch

покажите интервал {FastEthernet | GigabitEthernet} порт коммутатора <module/port>

Эта команда используется для проверки административного и рабочего статуса порта. Она также используется для проверки соответствия собственной VLAN по обе стороны транка. Сеть Native VLAN используется для передачи неразмеченного трафика, когда порт находится в режиме транкинга 802.1Q. Для получения подробных сведений о собственных виртуальных локальных сетях см. раздел "Создание и обслуживание виртуальных локальных сетей на коммутаторах Catalyst 2900XL и 3500XL".

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

Примечание: Для транкинга 802.1q результат предыдущей команды изменяется следующим образом:

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

Эта команда используется для проверки того, что интерфейсы (порты) принадлежат правильной VLAN. В приведенном примере только интерфейс Fa0/2 принадлежит VLAN2. Оставшиеся интерфейсы принадлежат VLAN1.

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

...(output suppressed)

show vtp status

Эта команда используется для проверки конфигурации магистрального протокола виртуальной локальной сети (VTP) на коммутаторе. В нашем примере использован прозрачный режим. Правильный режим VTP зависит от топологии вашей сети. Для получения подробных сведений о VTP см. раздел "Создание и обслуживание виртуальных локальных сетей на коммутаторах Catalyst 2900XL и 3500XL".

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Маршрутизатор Cisco 2600

show vlan

Эта команда показывает, какие сведения уровня L2 или L3 сконфигурированы для каждой VLAN.

c2600#show vlan
 
Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38
 
Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

Примечание: Для транкинга 802.1q результат предыдущей команды изменяется следующим образом:

c2600#show vlan
 
Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
 This is configured as native Vlan for the following interface(s): FastEthernet0/0
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2
 
Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

Примечание: Для транкинга 802.1Q, с версиями Cisco IOS ранее тогда 12.1 (3) T, выходные данные команды изменяются следующим образом:

c2600#show vlan

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

Примечание: Для любого из подчиненных интерфейсов сети VLAN1 не отображается инкапсуляция IEEE 802.1Q.

show interface

Эта команда используется для проверки административного статуса и статуса эксплуатации интерфейса.

c2600#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

Примечание: Для транкинга 802.1q результат предыдущей команды изменяется следующим образом:

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

Дополнительные сведения


Document ID: 14976