Протокол IP : Протокол HSRP

Разделение нагрузки с HSRP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (21 мая 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ содержит пример настройки протокола маршрутизатора горячего резервирования (HSRP), которая позволит использовать несколько путей для доступа к определенному получателю.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Теоретические сведения

HSRP часто используется для повышения отказоустойчивости сетей, но использование этого протокола может также привести к снижению эффективности передачи данных в сети. В примере в данном документе присутствуют два пути от сети узла к сети сервера. Для обеспечения избыточности HSRP поддерживается между R1 и R2, каждый из которых может стать активным маршрутизатором и "завладеть" виртуальным IP-адресом HSRP. Второй маршрутизатор становится резервным, но может вновь стать активным, если предыдущий активный маршрутизатор перестает работать. Дополнительная информация об активном и резервном маршрутизаторах представлена в разделе "Как использовать команды standby preempt и standby track".

Адрес шлюза по умолчанию хостов назначен как их виртуальный IP - адрес HSRP. Когда главным узлам требуется послать пакеты на серверную сеть, они посылают их на свои шлюзы по умолчанию или на любой активный маршрутизатор. Поскольку только один маршрутизатор активен, пакеты с хостов на серверы пересекают только один из этих двух доступных путей.

Примечание: Зависящий от о том, как вы настраиваете R3, пакеты, которые возвращаются от серверов до хостов, могли бы или не могли бы использовать оба адреса возврата. Также пакеты, возвращаемые с серверов на узлы, не должны проходить через активный маршрутизатор.

Чтобы использовать оба маршрута от сети хоста к сети сервера, вам нужно настроить протокол HSRP для нескольких групп (MHSRP) на участке между маршрутизаторами R1 и R2. В основном R1 настраивается с двумя группами HSRP (например группа 1 и группа 2); R2 настраивается с теми же группами HSRP. Для группы 1, R1 является активным маршрутизатором, а R2 – резервным. Для второй группы R2 является активным маршрутизатором, а R1 - резервным. Затем половина шлюзов узлов по умолчанию настраивается с использованием виртуального IP-адреса группы 1 HSRP, а другая половина – с использованием виртуального IP-адреса группы 2 HSRP.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/13781/7a.gif

Конфигурации

Эти конфигурации используются в данном документе:

Конфигурация R1 MHSRP
Current configuration:

interface Ethernet0
        ip address 171.16.6.5 255.255.255.0

        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

Конфигурация R2 MHSRP
Current configuration:

interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

Обратите внимание, что в конфигурациях, где два маршрутизатора вначале используют HSRP, значение приоритетности по умолчанию R1 равно 100 для группы 1 и 95 для группы 2. Приоритетность по умолчанию маршрутизатора R2 составляет 100 для группы 2 и 95 для группы 1. Следовательно, R1 является активным маршрутизатором для группы 1, а R2 - активным маршрутизатором для группы 2. В этом примере показано, что можно выполнить процедуру разделения нагрузки с помощью MHSRP. Тем не менее, для этого необходимо использовать приоритетность HSRP и команду preempt. HSRP не влияет на ответный трафик. Путь, взятый ответным трафиком, зависит от протокола маршрутизации, настроенного на маршрутизаторе.

Примечание: Когда значение приоритета режима ожидания и команды standby preempt настроены, это обязательное для явного упоминания номера группы., если не упомянутый, то значение 0 по умолчанию. Количество группы по умолчанию 0.

ВАЖНОЕ ПРИМЕЧАНИЕ

У некоторых контроллеров Ethernet (Lance и QUICC) в продуктах младших моделей может быть только один MAC-адрес для одноадресной рассылки в фильтре адресов. На этих платформах разрешена только одиночная HSRP группа, а адрес интерфейса изменяется на виртуальный HSRP MAC-адрес, когда группа активизируется. Разделение нагрузки на платформах с данным ограничением невозможно при использовании HSRP. Для исправления ошибок, возникающих при использовании HSRP с продуктами младших моделей, была введена команда use-bia. К примеру, при выполнении HSRP и DECnet на одном интерфейсе возникают проблемы, связанные с попытками DECnet и HSRP изменить MAC-адрес. С помощью команды use-bia HSRP может использовать MAC-адрес, созданный в результате процесса DECnet. Однако необходимо осознавать, что использование команды use-bia связано с некоторыми недостатками:

  • Когда маршрутизатор становится активным, виртуальный IP-адрес перемещается в другой МАС-адрес. Ставший активным маршрутизатор передает самообращенный ответ протокола преобразования адресов (ARP), однако не для всех вариантов реализации хостов поддерживается правильная обработка подобных сообщений ARP.

  • Конфигурация use-bia нарушает работу прокси-ARP. Резервный маршрутизатор не может заменить утерянную базу данных прокси-ARP неисправного активного маршрутизатора.

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13781