Протокол IP : Протокол HSRP

Использование команд "standby preempt" и "standby track"

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе описывается совместное использование команд standby preempt и standby track, а также принципы их использования.

Команда standby preempt делает маршрутизатор протокола маршрутизации горячего резервирования (HSRP) с наивысшим приоритетом активным маршрутизатором. Приоритет определяется сначала по сконфигурированному значению приоритета, а затем по IP-адресу. В любом случае чем больше значение, тем выше приоритет. Когда маршрутизатор с большим приоритетом становится приоритетным, маршрутизатор посылает сообщение Coup. Когда активный маршрутизатор с меньшим приоритетом получает сообщение Coup или приветственное сообщение от активного маршрутизатора с большим приоритетом, он переходит в состояние разговора и отправляет сообщение об отказе.

Команда standby track позволяет указать другой интерфейс маршрутизатора, который будет отслеживаться процессом HSRP, с целью изменения приоритета HSRP для данной группы. Если протокол линии указанного интерфейса отключается, приоритет HSRP уменьшается. Это означает, что другой маршрутизатор HSRP с более высоким приоритетом может стать активным маршрутизатором в том случае, если включена команда standby preempt.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco выпуск ПО IOS� 12.2 (10b)

  • Маршрутизаторы Cisco 2503

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

На схеме далее показан пример использования команды standby preempt вместе с командой standby track.

6a.gif

Примеры конфигураций

В схеме сети HSRP настроен следующим образом:

  • R1 является активным маршрутизатором и отслеживает состояние интерфейса serial 0. Когда R1 становится активным маршрутизатором, весь трафик с хоста (хост 1, 2, 3) на серверы направляется через R1.

  • R2 является резервным маршрутизатором и отслеживает состояние интерфейса serial 1 R2.

  • Если интерфейс R1 serial 0 перестает работать, приоритет HSRP маршрутизатора R1 уменьшается на 10. На этом этапе приоритет HSRP у маршрутизатора R2 выше, чем у R1, и R2 становится активным маршрутизатором. Когда R2 становится активным маршрутизатором, весь трафик с хоста на серверы направляется через R2.

Примечание: Шлюз по умолчанию для Хостов 1, 2, и 3 настроен с виртуальным IP - адресом HSRP (171.16.6.100, в этом случае). Протокол маршрутизации, например RIP, настраивается на маршрутизаторах для обеспечения связи между хостами и серверами.

Далее показана конфигурация каждого маршрутизатора:

Маршрутизатор 1 (Cisco 2503)
interface Ethernet0 
ip address 171.16.6.5 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects 
standby 1 ip 171.16.6.100

!--- Assigns a standby group and standby IP address

standby 1 priority 105

!--- Assign a priority (105 in this case) to the router interface (e0)
!--- for a particular group number (1). The default is 100.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial0

!--- Indicates that HSRP tracks Serial0 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.

interface Serial0 
ip address 171.16.2.5 255.255.255.0

Маршрутизатор 2 (Cisco 2503)
interface Ethernet0
ip address 171.16.6.6 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects
standby 1 ip

!--- Indicates the hot standby group. Here the IP address of the virtual router 
!--- is not configured. See the note after this table.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial1

!--- Indicates that HSRP tracks Serial1 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.
!--- The priority is also not configured and hence the default 
!--- priority value of 100 is applied.

interface Serial1
ip address 171.16.7.6 255.255.255.0

Примечание: При настройке R2 не используется резервный IP-адрес. Это делается умышленно для того, чтобы продемонстрировать, что это допустимая конфигурация. После обмена приветствиями HSRP между R1 и R2 R2 получает резервный IP-адрес от R1. Настройка R2 с резервным IP-адресом (тот же резервных адрес используется при настройке R1) также является допустимой конфигурацией.

R1# show standby
Ethernet0 - Group 1
Local state is Active, priority 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Virtual IP address is 171.16.6.100 configured
Active router is local
Standby router is 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface    Decrement  State
Serial0         10      Up
 
R2# show standby
Ethernet0 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Virtual IP address is 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Хотя R2 не использует приоритет HSRP, выходные данные определяют приоритет R2 в качестве значения по умолчанию HSRP (100). Выходные данные двух маршрутизаторов показывают, что маршрутизаторы отслеживают состояние интерфейса serial 0. R1 является активным маршрутизатором, а R2 - резервным. В итоге оба маршрутизатора настраиваются с помощью команды standby preempt.

Что произойдет, если последовательный интерфейс 0 маршрутизатора R1 перестанет работать? Выходные данные команды show standby выглядят таким образом:

R1# show standby
Ethernet0 - Group 1
Local state is Standby, priority 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
Standby router is local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 0 up:
Interface    Decrement  State
Serial0         10      Down
   
R2# show standby
Ethernet0 - Group 1
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
Active router is local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Выходные данные показывают, что приоритет HSRP маршрутизатора R1 сократился на 10 и составил 95. В результате приоритет R2 стал выше (100). R2 настраивался с помощью команды standby preempt, и приоритет этого маршрутизатора стал выше, поэтому R2 становится активным маршрутизатором, а R1 - резервным. Теперь, если интерфейс serial 0 маршрутизатора R1 снова заработает, приоритет R1 будет равен 105. Если это происходит, R1 становится преимущественным и снова является активным маршрутизатором HSRP.

Примечание: Если бы standby preempt не настроен на R2, R2 не передал бы сообщение Coup к R1, который заставляет R2 становиться активным. Вместо этого активным маршрутизатором должен был стать R1.

Рассмотрим, например, следующую конфигурацию:

standby priority 120
standby track serial 0
standby track serial 1

Приоритет HSRP, равный 120, настраивается с помощью команды standby priority, а настройки HSRP позволяют отслеживать состояние двух интерфейсов - Serial0 и Serial 1. Поскольку в команде standby track не определено значение декремента, при отказе работы интерфейса приоритет HSRP уменьшается на значение, равное 10 по умолчанию. Исходно оба интерфейса находятся в рабочем состоянии, и приоритет HSRP интерфейса составляет 120, как указано в выходных данных команды show standby:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Up
    Serial1                       10      Up
R1#

Затем интерфейс Serial 0 перестает работать.

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

Это уменьшает приоритет HSRP на 10: со 120 до 110. Чтобы проверить это, можно использовать команду show standby:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Up
R1#

Затем прекращает работу второй интерфейс Serial 1:

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

Это вновь уменьшает приоритет HSRP на 10: с 110 до 100. Чтобы проверить это, можно использовать команду show standby:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Down  (line protocol down)
R1#

При выходе из строя любого отслеживаемого последовательного интерфейса (serial 0 или serial 1) приоритетность составляет 110. Если прекращают работать оба интерфейса (serial 0 и serial 1), приоритетность равна 100.

Примечание: Если вы явно не определяете значение декремента в команде standby track, в определенных, некоторый более старых версиях Cisco IOS декремент в приоритете HSRP не кумулятивен. Для получения дополнительных сведений см. идентификатор ошибки CSCdp72834 (только для зарегистрированных пользователей).

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13780