Протокол IP : Протокол BGP

Распределение нагрузки в одно- и многоканальной среде BGP: Примеры конфигураций

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Распределение нагрузки – принцип, позволяющий маршрутизатору распределять исходящий и входящий трафик между несколькими путями. Пути возникают либо статически, либо с помощью динамических протоколов, как, например:

  • Протокол маршрутной информации (RIP)

  • Enhanced Interior Gateway Routing Protocol (EIGRP)

  • Протокол OSPF

  • Enhanced Interior Gateway Routing Protocol (IGRP)

По умолчанию Протокол BGP выбирает только одиночный оптимальный путь и не выполняет распределение нагрузки. Данный документ показывает, как распределить нагрузку в различных сценариях с помощью BGP. Дополнительные сведения о распределении нагрузки см. в разделе "Как работает средство распределения нагрузки"?.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Распределение нагрузки с использованием адреса обратной петли как соседнего узла BGP

В этом сценарии объясняется, как выполнить распределение нагрузки при использовании нескольких (максимум 6) каналов равной стоимости. В одноканальной среде BGP каналы прерываются в локальной автономной системе (AS) в одном маршрутизаторе и в удаленной AS в другом маршрутизаторе. В качестве примера приведена схема сети.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном разделе используются следующие настройки сети:

/image/gif/paws/13762/40a.gif

Конфигурации

В этом разделе используются следующие конфигурации:

Маршрутизатор А
interface loopback 0
 ip address 1.1.1.1 255.255.255.0

interface serial 0
 ip address 160.20.20.1 255.255.255.0
 no ip route-cache
  
interface serial 1
 ip address 150.10.10.1 255.255.255.0
 no ip route-cache
  
router bgp 11
neighbor 2.2.2.2 remote-as 10
neighbor 2.2.2.2 update-source loopback 0

!--- Use the IP address of the loopback interface for TCP connections.

neighbor 2.2.2.2 ebgp-multihop

!--- You must configure ebgp-multihop whenever the external BGP (eBGP)
!--- connections are not on the same network address.


router eigrp 12
network 1.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary

Маршрутизатор В
interface loopback 0
 ip address 2.2.2.2 255.255.255.0

interface serial 0
 ip address 160.20.20.2 255.255.255.0
 no ip route-cache

interface serial 1
 ip address 150.10.10.2 255.255.255.0
 no ip route-cache

router bgp 10
neighbor 1.1.1.1 remote-as 11
neighbor 1.1.1.1 update-source loopback 0

!--- Use the IP address of the loopback interface for TCP connections.


neighbor 1.1.1.1 ebgp-multihop

!--- You must configure ebgp-multihop whenever the eBGP connections
!--- are not on the same network address.

router eigrp 12
network 2.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary

Примечание: Можно использовать статические маршруты вместо протокола маршрутизации для представления двух равноценных путей для достижения назначения. В данном случае используется протокол маршрутизации EIGRP.

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Выходные данные команды show ip route показывают, что оба пути к сети 2.2.2.0 получены по протоколу EIGRP. Выходные данные команды traceroute показывают, что нагрузка распределяется между двумя последовательными каналами. В данном сценарии распределение нагрузки происходит на основании каждого пакета. Чтобы выполнить распределение нагрузки на уровне назначения, выполните команду ip route-cache в последовательных интерфейсах. Также настройку распределения на основании пакетов и назначения можно выполнить с помощью Cisco Express Forwarding. Дополнительная информация о настройке Cisco Express Forwarding представлена в разделе Настройка Cisco Express Forwarding.

RouterA# show ip route

!--- Output suppressed.

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/2297856] via 150.10.10.2, 00:00:45, Serial1
                [90/2297856] via 160.20.20.2, 00:00:45, Serial0
     160.20.0.0/24 is subnetted, 1 subnets
C       160.20.20.0 is directly connected, Serial0
     150.10.0.0/24 is subnetted, 1 subnets
C       150.10.10.0 is directly connected, Serial1

RouterA# traceroute 2.2.2.2 

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 16 msec
    150.10.10.2 8 msec *

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Распределение нагрузки при двойном подключении к одному поставщику Интернет-услуг (ISP) через один локальный маршрутизатор

В этом сценарии показано, как добиться распределения нагрузки при наличии нескольких каналов между удаленной и локальной AS. Эти каналы прерываются в одном маршрутизаторе локальной AS и в нескольких маршрутизаторах на удаленной AS в одноканальной среде BGP. В качестве примера такой сети приведена Схема сети.

В данном примере конфигурации используется команда maximum-paths. По умолчанию BGP выбирает один наилучший путь среди возможных равноценных путей, предоставленных одной AS. Тем не менее, можно изменить максимальное количество допустимых параллельных путей одинаковой стоимости. Чтобы воспользоваться этой возможностью, выполните команду maximum-paths paths в конфигурации BGP. В качестве аргумента paths используйте значение от 1 до 6.

Схема сети

В данном разделе используются следующие настройки сети:

40b.gif

Конфигурации

В этом разделе используются следующие конфигурации:

Маршрутизатор А
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial 0
 ip address 160.20.20.1 255.255.255.0
!
!  
interface Serial 1
 ip address 150.10.10.1 255.255.255.0
!
! 
router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 150.10.10.2 remote-as 10
network 1.0.0.0
maximum-paths 2

!--- This command specifies the maximum number of paths
!--- to install in the routing table for the specific destination.

Маршрутизатор В
interface Ethernet0 
 ip address 2.2.2.1 255.255.255.0
!
interface Serial 0
 ip address 160.20.20.2 255.255.255.0
!
!
router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0
auto-summary

МАРШРУТИЗАТОР C
interface Ethernet0 
 ip address 2.2.2.2 255.255.255.0
!
interface Serial 1
 ip address 150.10.10.2 255.255.255.0
!
!
router bgp 10
neighbor 150.10.10.1 remote-as 11
network 2.0.0.0 
auto-summary

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Выходные данные команды show ip route показывают, что оба пути к сети 2.2.2.0 получены по протоколу BGP. Выходные данные команды traceroute показывают, что нагрузка распределяется между двумя последовательными каналами. В данном сценарии распределение нагрузки происходит на основании пункта назначения. Команда show ip bgp позволяет получить действующие записи для сети 2.0.0.0.

RouterA# show ip route

!--- Output suppressed.

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
B    2.0.0.0/8 [20/0] via 150.10.10.2, 00:04:23
               [20/0] via 160.20.20.2, 00:04:01
     160.20.0.0/24 is subnetted, 1 subnets
C       160.20.20.0 is directly connected, Serial0
     150.10.0.0/24 is subnetted, 1 subnets
C       150.10.10.0 is directly connected, Serial1
 
RouterA# traceroute 2.2.2.2 

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 16 msec
    150.10.10.2 8 msec * 

RouterA# show ip bgp

BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete 
	
Network 	Next Hop 	Metric 	LocPrf 	Weight Path    
*> 1.0.0.0 	0.0.0.0 	        	0 	32768  i    
*> 2.0.0.0 	160.20.20.2  0 			0 	10 i    
*               150.10.10.2  0 			0 	10 i

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Распределение нагрузки при двойном подключении к одному поставщику Интернет-услуг (ISP) через несколько локальных маршрутизаторов

В этом сценарии демонстрируется распределение нагрузки при использовании нескольких каналов к одному ISP через несколько локальных маршрутизаторов. Два узла eBGP прерываются на двух отдельных локальных маршрутизаторах. Распределение нагрузки по двум каналам невозможно, поскольку BGP выбирает один лучший путь между сетями, полученными от eBGP и внутреннего протокола BGP (iBGP). Распределение нагрузки между несколькими путями к AS 10 является следующим лучшим вариантом. При этом типе распределения нагрузки трафик к сетям проходит по двум каналам на основании заранее определенной политики. Кроме того, каждый канал выступает в качестве резервной копии другого канала на случай его отказа.

Для простоты предположим, что используется следующая политика маршрутизации BGP для AS 11:

  • AS 11 принимает локальные маршруты от AS 10 вместе со значениями по умолчанию от остальных Интернет-маршрутов.

  • Используется следующая политика исходящего трафика:

    • Весь трафик из канала R101, предназначенный для Интернета, проходит через канал R101-R103.

    • Если канал R101-R103 дает сбой, весь трафик в направлении Интернета от R101 идет через R102 к AS 10.

    • Таким же образом, весь трафик из канала R102, предназначенный для Интернета, проходит через канал R102-R104.

    • Если канал R102-R104 дает сбой, весь трафик в интернете от R102 проходит в диапазоне от R101 to AS 10.

  • Используется следующая политика входящего трафика:

    • Трафик, предназначенный для сети 192.168.11.0/24 из Интернета, должен пройти через канал R103-R101.

    • Трафик, предназначенный для сети 192.168.12.0/24 из Интернета, должен пройти через канал R104-R102.

    • При отказе одного канала к AS10, другой канал должен прокладывать маршрут трафика для всех сетей обратно к AS11 из Интернета.

Для этого параметр AS_PATH сети 192.168.11.0 объявляется на пути от R101 к R103 более коротким, чем от R102 к R104. AS 10 находит лучший путь через канал R103-R101. Аналогично, путь 192.168.12.0 объявляется более коротким для канала R102-R104. AS 10 отдает предпочтение каналу R104-R102 для трафика, привязанного к 192.168.12.0 в AS 11.

Для исходящего трафика BGP определяет лучший путь на основании маршрутов, полученных через eBGP. Этим маршрутам отдается предпочтение перед маршрутами, полученными через iBGP. Таким образом, R101 получает 10.10.34.0 от R103 через eBGP и от R102 через iBGP. Внешний путь выбирается поверх внутреннего. Таким образом, из таблицы BGP в конфигурации R101 видно, что маршрут к 10.10.34.0 проходит через канал R101-R103 со следующим узлом 10.10.13.3. В конфигурации R102 маршрут к 10.10.34.0 проходит через канал R102-R104 со следующим узлом 10.10.24.4. Это позволяет провести распределение нагрузки трафика, направленного к 10.10.34.0. Точно так же это происходит для маршрутов по умолчанию в R101 и R102. Дополнительные сведения о критериях выбора пути BGP см. раздел Алгоритм выбора наилучшего пути BGP.

Схема сети

В данном разделе используются следующие настройки сети:

40c.gif

Конфигурации

В этом разделе используются следующие конфигурации:

R101
hostname R101

!
interface Ethernet0/0
 ip address 192.168.11.1 255.255.255.0 secondary
 ip address 192.168.12.1 255.255.255.0
!
interface Serial8/0
 ip address 10.10.13.1 255.255.255.0
!
router bgp 11
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 network 192.168.12.0
 neighbor 10.10.13.3 remote-as 10
 neighbor 10.10.13.3 route-map R101-103-MAP out

!--- The AS_PATH is increased for 192.168.12.0.

 neighbor 192.168.12.2 remote-as 11
 neighbor 192.168.12.2 next-hop-self
 maximum-paths 2
 no auto-summary
!
access-list 1 permit 192.168.12.0
access-list 2 permit 192.168.11.0
route-map R101-103-MAP permit 10
 match ip address 1
 set as-path prepend 11 11 11
!         
route-map R101-103-MAP permit 20
 match ip address 2

R102
hostname R102
!

interface Ethernet0/0
 ip address 192.168.11.2 255.255.255.0 secondary
 ip address 192.168.12.2 255.255.255.0
!
interface Serial8/0
 ip address 10.10.24.2 255.255.255.0
!
router bgp 11
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 network 192.168.12.0
 neighbor 10.10.24.4 remote-as 10
 neighbor 10.10.24.4 route-map R102-104-MAP out

!--- The AS_PATH is increased for 192.168.11.0.

 neighbor 192.168.12.1 remote-as 11
 neighbor 192.168.12.1 next-hop-self
 no auto-summary
!
access-list 1 permit 192.168.11.0
access-list 2 permit 192.168.12.0
route-map R102-104-MAP permit 10
 match ip address 1
 set as-path prepend 11 11 11
!         
route-map R102-104-MAP permit 20
 match ip address 2
!

R103
hostname R103
!
interface Ethernet0/0
 ip address 10.10.34.3 255.255.255.0
!
interface Serial8/0
 ip address 10.10.13.3 255.255.255.0
!
router bgp 10
no synchronization
 bgp log-neighbor-changes
 network 10.10.34.0 mask 255.255.255.0
 neighbor 10.10.13.1 remote-as 11
 neighbor 10.10.13.1 default-originate
 neighbor 10.10.34.4 remote-as 10
 neighbor 10.10.34.4 next-hop-self
 no auto-summary
 !

R104
hostname R104
!

interface Ethernet0/0
 ip address 10.10.34.4 255.255.255.0

!
interface Serial8/0
 ip address 10.10.24.4 255.255.255.0
!
router bgp 10
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.24.2 remote-as 11
 neighbor 10.10.24.2 default-originate
 neighbor 10.10.34.3 remote-as 10
 neighbor 10.10.34.3 next-hop-self
 no auto-summary
!

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Проверка, что оба канала между AS 11 и AS 10 работают

Проверка исходящего трафика

Примечание: Знак больше (>) в выходных данных команды show ip bgp представляет оптимальный путь для использования для той сети среди возможных путей. Дополнительнче сведения см. в "Алгоритм выбора наилучшего пути BGP".

В таблице BGP в R101 показано, что наилучший путь для всего исходящего трафика к Интернету проходит через канал R101-R103. Выходные данные команды show ip route подтверждают информацию о маршрутах в таблице маршрутизации.

R101# show ip bgp

BGP table version is 5, local router ID is 192.168.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i0.0.0.0          192.168.12.2                  100      0 10 i
*>                  10.10.13.3                             0 10 i  
!--- This is the next hop of R103.

* i10.10.34.0/24    192.168.12.2                  100      0 10 i
*>                  10.10.13.3               0             0 10 i  
!--- This is the next hop of R103.

* i192.168.11.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R101# show ip route

!--- Output suppressed.

Gateway of last resort is 10.10.13.3 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.13.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.13.3, 00:08:53 
!--- This is the next hop of R103.

B*   0.0.0.0/0 [20/0] via 10.10.13.3, 00:08:53     
!--- This is the next hop of R103.

Далее представлены BGP и таблицы маршрутизации для R102. В соответствии с политикой R102 должен направить весь трафик к AS 10 через канал R102-R104:

R102# show ip bgp

BGP table version is 7, local router ID is 192.168.12.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          10.10.24.4                             0 10 i   
!--- This is the next hop of R104.

* i                 192.168.12.1                  100      0 10 i
*> 10.10.34.0/24    10.10.24.4                             0 10 i   
!--- This is the next hop of R104.

* i                 192.168.12.1             0    100      0 10 i
* i192.168.11.0     192.168.12.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R102# show ip route

!--- Output suppressed.

Gateway of last resort is 10.10.24.4 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.24.4, 00:11:21   
!--- This is the next hop of R104.

B*   0.0.0.0/0 [20/0] via 10.10.24.4, 00:11:21       
!--- This is the next hop of R104.

Проверка входящего трафика от AS 10 до AS 11

Сети 192.168.11.0 и 192.168.12.0 принадлежат AS 11. Согласно политике, AS 11 должен предпочесть ссылку R103-R101 для трафика, который предназначен к сети 192.168.11.0 и ссылке R104-R102 для трафика, который предназначен к сети 192.168.12.0.

R103# show ip bgp

BGP table version is 4, local router ID is 10.10.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.34.0/24    0.0.0.0                  0         32768 i
*> 192.168.11.0     10.10.13.1               0             0 11 i             
!--- The next hop is R101.

*  192.168.12.0     10.10.13.1               0             0 11 11 11 11 i   
*>i                 10.10.34.4               0    100      0 11 i             
!--- The next hop is R104.


R103# show ip route

!--- Output suppressed.

Gateway of last resort is not set

B    192.168.12.0/24 [200/0] via 10.10.34.4, 00:04:46  
!--- The next hop is R104.

B    192.168.11.0/24 [20/0] via 10.10.13.1, 00:04:46   
!--- The next hop is R101.

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.13.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Лучший путь для сети 192.168.11.0 в R103 - через канал R103-R101, а для сети 192.168.12.0 - через R104 к AS 11. В этом случае кратчайший путь - самый лучший.

Аналогичным образом это происходит для R104; BGP и таблица маршрутизации это подтверждает:

R104# show ip bgp

BGP table version is 13, local router ID is 10.10.34.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.34.0/24    10.10.34.3               0    100      0 i
*>i192.168.11.0     10.10.34.3               0    100      0 11 i
*                   10.10.24.2               0             0 11 11 11 11 i
*> 192.168.12.0     10.10.24.2               0             0 11 i

R104# show ip route

!--- Output suppressed.

Gateway of last resort is not set

B    192.168.12.0/24 [20/0] via 10.10.24.2, 00:49:06    
!--- The next hop is R102.

B    192.168.11.0/24 [200/0] via 10.10.34.3, 00:07:36   
!--- The next hop is R103.

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Проверка при сбое канала R101-R103

При сбоях каналов R101-R103 весь трафик должен быть перенаправлен через R102. Это изменение отражено в диаграмме далее:

40d.gif

Для того чтобы смоделировать данную ситуацию, отключите канал R103-R101 в R103.

R103(config)# interface serial 8/0
R103(config-if)# shutdown

*May 1 00:52:33.379: %BGP-5-ADJCHANGE: neighbor 10.10.13.1 Down Interface flap  
*May 1 00:52:35.311: %LINK-5-CHANGED: Interface Serial8/0, changed state to 
 administratively down
*May 1 00:52:36.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial8/0, changed 
 state to down

Проверьте исходящий маршрут к AS 10.

R101# show ip bgp

BGP table version is 17, local router ID is 192.168.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          192.168.12.2                  100      0 10 i   
!--- This is the next hop of R102.

*>i10.10.34.0/24    192.168.12.2                  100      0 10 i   
!--- This is the next hop of R102.

* i192.168.11.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R101# show ip route

!--- Output suppressed.

Gateway of last resort is 192.168.12.2 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.34.0 [200/0] via 192.168.12.2, 00:01:34
B*   0.0.0.0/0 [200/0] via 192.168.12.2, 00:01:34      
!--- All outbound traffic goes through R102.

     
R102# show ip route

!--- Output suppressed.

Gateway of last resort is 10.10.24.4 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.24.4, 00:13:22
B*   0.0.0.0/0 [20/0] via 10.10.24.4, 00:55:22         
!--- All outbound traffic on R102 goes through R104.

Проверьте маршрут входящего трафика в случае возникновения сбоя R101-R103.

R103# show ip bgp

BGP table version is 6, local router ID is 10.10.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.34.0/24    0.0.0.0                  0         32768 i
*>i192.168.11.0     10.10.34.4               0    100      0 11 11 11 11 i
*>i192.168.12.0     10.10.34.4               0    100      0 11 i

R103# show ip route

!--- Output suppressed.

Gateway of last resort is not set

B    192.168.12.0/24 [200/0] via 10.10.34.4, 00:14:55      
!--- The next hop is R104.

B    192.168.11.0/24 [200/0] via 10.10.34.4, 00:05:46      
!--- The next hop is R104.

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.34.0 is directly connected, Ethernet0/0

В R104 трафик для 192.168.11.0 и 192.168.12.0 проходит через канал R104-R102.

R104# show ip route

!--- Output suppressed.

Gateway of last resort is not set

B    192.168.12.0/24 [20/0] via 10.10.24.2, 00:58:35    
!--- The next hop is R102.

B    192.168.11.0/24 [20/0] via 10.10.24.2, 00:07:57    
!--- The next hop is R102.

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Распределение нагрузки в многосетевой среде на двух Интернет-провайдеров через один локальный маршрутизатор

В этом сценарии распределение нагрузки не поддерживается в многосетевой среде, поэтому можно провести только разделение нагрузки. Распределение нагрузки невозможно, поскольку BGP выбирает только один лучший путь к месту назначения из маршрутов BGP, получаемых от различных AS. Цель - установка лучшей метрики для маршрутов в диапазоне от 1.0.0.0 до 128.0.0.0, полученных от ISP(A), и выбор лучшей метрики для остальных путей, полученных от ISP(B). В качестве примера приведена схема сети.

Дополнительная информация представлена в разделе Образец конфигурации BGP с двумя разными провайдерами услуг (многоканальное подключение).

Схема сети

В данном разделе используются следующие настройки сети:

40e.gif

Конфигурации

В этом разделе используются следующие конфигурации:

Маршрутизатор А
interface Serial 0
 ip address 160.20.20.1 255.255.255.0
 no ip route-cache
    
interface Serial 1
 ip address 150.10.10.1 255.255.255.0
 no ip route-cache
   
router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 160.20.20.2 route-map UPDATES-1 in

!--- This allows only the networks up to 128.0.0.0.

neighbor 150.10.10.2 remote-as 12
neighbor 150.10.10.2 route-map UPDATES-2 in

!--- This allows anything above the 128.0.0.0 network.

auto-summary
  
route-map UPDATES-1 permit 10
match ip address 1
set weight 100
 
route-map UPDATES-1 permit 20
match ip address 2
  
route-map UPDATES-2 permit 10
match ip address 1
  
route-map UPDATES-2 permit 20
match ip address 2
set weight 100
  
access-list 1 permit 0.0.0.0  127.255.255.255
access-list 2 deny 0.0.0.0 127.255.255.255
access-list 2 permit any

Маршрутизатор В
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
int loopback 1
 ip address 170.16.6.5 255.255.255.0
 
interface Serial 0
 ip address 160.20.20.2 255.255.255.0
 no ip route-cache
  
router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0
network 170.16.0.0
auto-summary

МАРШРУТИЗАТОР C
interface Loopback0 
 ip address 170.16.6.6 255.255.255.0
 
interface Loopback1 
 ip address 2.2.2.1 255.255.255.0
  
interface Serial 1
 ip address 150.10.10.2 255.255.255.0
 no ip route-cache
  
router bgp 12
neighbor 150.10.10.1 remote-as 11
network 2.0.0.0 
network 170.16.0.0
auto-summary

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Выходные данные команд show ip route и traceroute показывают, что все сети менее 128.0.0.0 покидают маршрутизатор RouterA через 160.20.20.2. Данный маршрут является следующим выходом из интерфейса serial 0. Остальные сети покидают маршрутизатор через 150.10.10.2, что является следующим выходом для интерфейса serial 1.

RouterA# show ip route

!--- Output suppressed.

Gateway of last resort is not set
B 	170.16.0.0/16 [20/0] via 150.10.10.2, 00:43:43		 
!--- This is the next hop out through serial 1.

B 	2.0.0.0/8 [20/0] via 160.20.20.2, 00:43:43			 
!--- This is the next hop out through serial 0.

    160.20.0.0/24 is subnetted, 1 subnets
C 		160.20.20.0 is directly connected, Serial0
    150.10.0.0/24 is subnetted, 1 subnets
C 		150.10.10.0 is directly connected, Serial1

RouterA# show ip bgp

BGP table version is 3, local router ID is 160.20.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 Network Next Hop Metric LocPrf Weight Path
   Network          Next Hop            Metric LocPrf Weight Path
*  2.0.0.0          150.10.10.2              0             0 12 i
*>                  160.20.20.2              0           100 10 i
*  170.16.0.0       160.20.20.2              0             0 10 i
*>                  150.10.10.2              0           100 12 i
  
RouterA# traceroute  2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2 

1   160.20.20.2 16 msec * 16 msec 

RouterA# traceroute  170.16.6.6

Type escape sequence to abort.
Tracing the route to 170.16.6.6

1   150.10.10.2 4 msec * 4 msec

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Распределение нагрузки в многосетевой среде на двух Интернет-провайдеров через несколько локальных маршрутизаторов

В многосетевой среде с двумя Интернет-провайдерами распределение нагрузки невозможно. BGP выбирает только один лучший путь к месту назначения из путей BGP, полученных от различных AS, что делает распределение нагрузки невозможным. Но, распределение нагрузки возможно в таких сетях BGP с несколькими интерфейсами. На основании заранее определенных политик поток трафика контролируется различными атрибутами BGP.

В этом разделе обсуждается наиболее часто используемая многосетевая конфигурации. Данная настройка позволяет добиться разделения нагрузки. См. схему сети, в которой многосетевая конфигурация AS 100достигает высокого уровня надежности и осуществляет разделение нагрузки.

Примечание: IP-адреса в данном примере придерживаются RFC 1918 leavingcisco.com стандартов для Частного пространства адресов и не маршрутизируемы в Интернете.

Для простоты предположите, что Политика маршрутизации BGP для AS 100:

  • AS 100 принимает локальные маршруты от двух поставщиков вместе со значениями по умолчанию от остальных Интернет-маршрутов.

  • Используется следующая политика исходящего трафика:

    • Трафик, предназначенный для AS 300, проходит через канал R1-ISP(A).

    • Трафик, предназначенный для AS 400, проходит через канал R2-ISP(B).

    • Весь остальной трафик должен отдавать предпочтение маршруту по умолчанию 0.0.0.0 через канал R1-ISP(A).

    • В случае сбоя канала R1-ISP(A) весь трафик должен идти через канал R2-ISP(B).

  • Используется следующая политика входящего трафика:

    • Трафик, предназначенный для сети 10.10.10.0/24 из Интернета, должен пройти через канал ISP(A)-R1.

    • Трафик, предназначенный для сети 10.10.20.0/24 из Интернета, должен пройти через канал ISP(B)-R2.

    • Если один ISP вышел из строя, другой ISP должен направить трафик для всех сетей обратно на AS 100 из Интернета.

Схема сети

В данном разделе используются следующие настройки сети:

40f.gif

Конфигурации

В этом разделе используются следующие конфигурации:

_________________________ М2
interface Ethernet0
 ip address 192.168.21.2 255.255.255.0
 !
interface Serial0
  ip address 192.168.42.2 255.255.255.0  
router bgp 100  
 no synchronization  
 bgp log-neighbor-changes  

!--- The next two lines announce the networks to BGP peers.

 network 10.10.10.0 mask 255.255.255.0  
 network 10.10.20.0 mask 255.255.255.0  

!--- The next line configures iBGP on R1.
 
  neighbor 192.168.21.1 remote-as 100  
  neighbor 192.168.21.1 next-hop-self  

!--- The next line configures eBGP with ISP(B).
 
 neighbor 192.168.42.4 remote-as 400  

!--- This is the incoming policy route map for the application 
!--- of attributes to specific routes.
 
 neighbor 192.168.42.4 route-map AS-400-INCOMING in  

!--- This is the outgoing policy route map for the application 
!--- of attributes to specific routes.
 
 neighbor 192.168.42.4 route-map AS-400-OUTGOING out  
 no auto-summary  
!  
!  

!--- This line sets the AS path access list.
!--- The line permits all routes within the routing domain of the provider.

ip as-path access-list 1 permit ^400$  
!  

!--- These two lines set the access list.
 
access-list 10 permit 10.10.10.0 0.0.0.255  
access-list 20 permit 10.10.20.0 0.0.0.255  

!--- The next three lines configure LOCAL_PREF for routes 
!--- that match AS path access list 1.
 
route-map AS-400-INCOMING permit 10  
 match as-path 1  
 set local-preference 150  

!--- Here, the route map prepends AS 100 to BGP updates for networks 
!--- that are permitted by access list 10.
 
route-map AS-400-OUTGOING permit 10  
 match ip address 10  
 set as-path prepend 100  

!--- This line announces the network that is permitted by
!--- access list 20 without any changes in BGP attributes.
 
route-map AS-400-OUTGOING permit 20  
 match ip address 20

_________________________ М1
interface Serial0/0   
 ip address 192.168.31.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.21.1 255.255.255.0  
!  
router bgp 100  
 no synchronization  
 bgp log-neighbor-changes  
 network 10.10.10.0 mask 255.255.255.0  
 network 10.10.20.0 mask 255.255.255.0
   
!--- IBGP peering with R2 
neighbor 192.168.21.2 remote-as 100  
neighbor 192.168.21.2 next-hop-self  
! 

!--- This line sets eBGP peering with ISP(A).
 
neighbor 192.168.31.3 remote-as 300  
!  

!--- This is the incoming policy route map for the application 
!--- of attributes to specific routes.
 
 neighbor 192.168.31.3 route-map AS-300-INCOMING in  
!  

!--- This is the outgoing policy route map for the application 
!--- of attributes to specific routes.
 
neighbor 192.168.31.3 route-map AS-300-OUTGOING out  
 no auto-summary  
  

!--- This line sets the AS path access list.
!--- The line permits all routes within the routing domain of the provider.

ip as-path access-list 1 permit ^300$  
!  

!--- These two lines set the IP access list.

access-list 10 permit 10.10.20.0 0.0.0.255  
access-list 20 permit 10.10.10.0 0.0.0.255  


!--- The next three lines configure LOCAL_PREF for routes that match 
!--- AS path access list 1.
 
route-map AS-300-INCOMING permit 10  
 match as-path 1  
 set local-preference 200  
!  

!--- Here, the route map prepends AS 100 to BGP updates for networks 
!--- that are permitted by access list 10.
 
route-map AS-300-OUTGOING permit 10  
 match ip address 10  
 set as-path prepend 100  
!  

!--- This line announces the network that is permitted 
!--- by access list 20 without any changes in BGP attributes.
 
route-map AS-300-OUTGOING permit 20  
 match ip address 20  
!

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Для проверки функционирования политики входящего/исходящего трафика, выполните команду show ip bgp.

Примечание:  Знак "больше" (>) в выходных данных команды show ip bgp определяет наилучший из возможных для данной сети путь. Дополнительнче сведения см. в "Алгоритм выбора наилучшего пути BGP".

R1# show ip bgp

BGP table version is 6, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

BGP table version is 6, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.31.3                  200      0 300 i

!--- This line shows that the default route 0.0.0.0/0 is preferred 
!--- through AS 300, ISP(A).

* i10.10.10.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 30.30.30.0/24    192.168.31.3             0    200      0 300 i
*>i40.40.40.0/24    192.168.21.2             0    150      0 400 i

!--- The route to network 30.30.30.0/24 (AS 300) is preferred 
!--- through the R1-ISP(A) link.
!--- The route to network 40.40.40.0/24 (AS 400) is preferred 
!--- through the R2-ISP(B) link.

Теперь рассмотрим выходные данные команды show ip bgp на R2:

R2# show ip bgp 

BGP table version is 8, local router ID is 192.168.42.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  0.0.0.0          192.168.42.4                  150      0 400 i  
*>i                 192.168.21.1                  200      0 300 i

!--- This line shows that the default route 0.0.0.0/0 is preferred
!--- through AS 300, through the R2-ISP(B) link.

*> 10.10.10.0/24    0.0.0.0                  0         32768 i
* i                 192.168.21.1             0    100      0 i
*> 10.10.20.0/24    0.0.0.0                  0         32768 i
* i                 192.168.21.1             0    100      0 i
*>i30.30.30.0/24    192.168.21.1             0    200      0 300 i 
*> 40.40.40.0/24    192.168.42.4             0    150      0 400 i

!--- The route to network 30.30.30.0/24 (AS 300) is preferred 
!--- through the R1-ISP(A) link.
!--- The route to network 40.40.40.0/24 (AS 400) is preferred 
!--- through the R2-ISP(B) link.

Выполните команду show ip bgp на маршрутизаторе 6, чтобы получить информацию о политике входящего трафика для сетей 10.10.10.0/24 и 10.10.20.0/24:

R6# show ip bgp

BGP table version is 15, local router ID is 192.168.64.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    192.168.63.3                           0 300 100 100 i

!--- This line shows that network 10.10.10.0/24 is routed through AS 300
!--- with the ISP(A)-R1 link.

*                   192.168.64.4                           0 400 100 100 100 i
*  10.10.20.0/24    192.168.63.3                           0 300 100 100 i
*>                  192.168.64.4                           0 400 100 i

!--- This line shows that network 10.10.20.0/24 is routed through AS 400
!--- with the ISP(B)-R2 link.

*> 30.30.30.0/24    192.168.63.3             0             0 300 i
*> 40.40.40.0/24    192.168.64.4             0             0 400 i

Отключите канал R1-ISP(A) на R1 и ознакомьтесь с таблицей BGP. Весь Интернет-трафик должен направляться через канал R2-ISP(B):

R1(config)# interface serial 0/0
R1(config-if)# shutdown
 
*May  2 19:00:47.377: %BGP-5-ADJCHANGE: neighbor 192.168.31.3 Down Interface flap 
*May  2 19:00:48.277: %LINK-5-CHANGED: Interface Serial0/0, changed state to 
 administratively  down 
*May 23 12:00:51.255: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed 
 state to down 

R1# show ip bgp 

BGP table version is 12, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          192.168.21.2                  150      0 400 i  

!--- The best default path is now through the R2-ISP(B) link.

* i10.10.10.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*>i40.40.40.0/24    192.168.21.2             0    150      0 400 i

R2# show ip bgp 

BGP table version is 14, local router ID is 192.168.42.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.42.4                  150      0 400 i  

!--- The best default route is now through ISP(B) with a 
!--- local preference of 150.

* i10.10.10.0/24    192.168.21.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 40.40.40.0/24    192.168.42.4             0    150      0 400 i

Просмотрите маршрут для сети 10.10.10.0/24 в маршрутизаторе 6:

R6# show ip bgp 

BGP table version is 14, local router ID is 192.168.64.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    192.168.64.4                           0 400 100 100 i  

!--- Network 10.10.10.0 is reachable through ISP(B), which announced
!--- the network with AS path prepend.
 
*> 10.10.20.0/24    192.168.64.4                           0 400 100 i
*> 30.30.30.0/24    192.168.63.3             0             0 300 i
*> 40.40.40.0/24    192.168.64.4             0             0 400 i

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13762