Многопротокольная коммутация по меткам (MPLS) : MPLS

Настройка основного расчета трафика MPLS с помощью IS-IS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот пример конфигурации показывает, как внедрить средства регулирования трафика (TE) в существующей сети с многопротокольной коммутации по меткам (MPLS) с использованием Frame Relay и протоколом взаимодействия промежуточных систем (IS-IS). В данном примере реализуются два динамических туннеля (автоматически установленный входными коммутирующими маршрутизаторами на основе меток [LSR]) и два туннеля с использованием явных путей.

TE является общим именем, которое соответствует использованию других технологий для оптимизации использования данной емкости магистрали и топологии.

Технологии организации трафика MPLS (MPLS TE) позволяют интегрировать достигнутые в этой области возможности (например, в использовании протоколов 2-го уровня, таких как ATM) в протоколы 3-го уровня (IP). MPLS TE использует расширение для существующих протоколов (Протокол резервирования ресурсов (RSVP) [RSVP], IS-IS, Открытый кратчайший путь сначала [OSPF]), чтобы вычислить и установить однонаправленные туннели, которые установлены согласно ограничениям сети. Потоки трафика сопоставляются в разных туннелях в зависимости от их пункта назначения.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco выпуски ПО IOS� 12.0 (11) S и 12.1 (3a) T

  • Маршрутизаторы Cisco 3600

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Функциональные компоненты

Компонент Описание
Интерфейсы IP-туннелей Уровень 2: Интерфейс туннеля MPLS является головным в пути коммутации меток (LSP). Он сконфигурирован с набором потребностей в ресурсах, таких как полоса пропускания и приоритет. Третий уровень: Интерфейс туннеля LSP является головной частью одностороннего виртуального канала к конечной точке туннеля.
RSVP с расширением TE RSVP используется, чтобы установить и поддержать Туннели LSP на основе рассчитанного пути с помощью ПУТИ и сообщений RESV. Спецификация протокола RSVP была расширена, так что сообщения RESV также распространяют сведения меток.
IGP состояния канала (IS-IS или OSPF с расширением TE) Используется для непрерывной передачи сведений о топологии и ресурсах из модуля управления каналом. IS-IS использует новые Типы - Длина-Значения (TLV), и использование OSPF вводит 10 Объявлений о состоянии канала (также названный Непрозрачными LSA).
Модуль вычисления пути MPLS TE Действует только на заголовок LSP и определяет путь, используя сведения из базы данных состояний каналов.
Модуль управления связью MPLS TE При каждой пересылке пути коммутации по метке этот модуль выполняет контроль использования полосы пропускания канала для сигнальных сообщений RSVP и учет сведений о топологии и ресурсах, передаваемых OSPF или IS-IS.
Переадресация коммутации меток Основной механизм пересылки MPLS на основе меток.

Настройка

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/13737/mplsteisis1.gif

Конфигурации

Руководство быстрых настроек

Эта процедура может использоваться для выполнения быстрой настройки. Для более подробной информации обратитесь к Регулированию трафика MLPS и Усовершенствованиям.

  1. Установите сеть со стандартной конфигурацией (в этом случае, Frame Relay используется).

    Примечание: Это является обязательным для устанавливания интерфейса обратной связи с маской IP 32 битов.

    Этот адрес используется для установленной из сети MPLS и TE протоколом маршрутизации. Этот адрес обратной линии должен быть достижим с помощью таблицы глобальной маршрутизации.

  2. Настройте протокол маршрутизации для сети MPLS. Это должен быть протокол маршрутизации с учетом состояния линий (IS-IS или OSPF). В режиме конфигурации протокола маршрутизации войдите:

    • Для IS-IS:

      metric-style wide (or metric-style both) 
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
    • Для OSPF:

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. Активируйте функцию MPLS TE. Введите "ip cef" (либо "ip cef distributed", если доступно, чтобы улучшить производительность) в общем режиме настройки. Разблокировать многопротокольный коммутатор метки (MPLS) (ip коммутации тегов) на каждом соответствующем интерфейсе. Введите туннель с техническими средствами регулирования трафика mpls для включения MPLS TE, а также RSVP для Туннелей TE нулевой пропускной способности.

  4. Включите RSVP путем ввода ip rsvp bandwidth XXX на каждом участвующем интерфейсе для ненулевых туннелей пропускной способности.

  5. Настройте туннели, которые будут использоваться для техники обеспечения трафика (TE). Имеется много параметров, которые можно настроить для туннеля MPLS TE, но команда tunnel mode mpls traffic-eng обязательна. Команда tunnel mpls traffic-eng autoroute announce сообщает о присутствии туннеля по протоколу маршрутизации.

Примечание: Не забудьте использовать ip unnumbered loopbackN для IP-адреса интерфейсов туннеля.

Этот пример конфигурации показывает два динамических туннеля с другой пропускной способностью (и приоритеты), которые идут от маршрутизатора Pescara до маршрутизатора Pesaro и двух туннелей, которые используют явный путь, который идет от Pesaro до PEscara.

Файл конфигурации

Включены только соответствующие части файлов конфигурации. В то время как команды, определенные для TE (включая RSVP), полужирным, команды, используемые для включения MPLS, выделены курсивом.

Pesaro
Current configuration:
 !
 version 12.1
 !
 hostname Pesaro
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.6 255.255.255.255
  ip router isis 
 !
 interface Tunnel158
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 2 2
  tunnel mpls traffic-eng bandwidth 158
  tunnel mpls traffic-eng path-option 1 explicit name low
 !
 interface Tunnel159
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 4 4
  tunnel mpls traffic-eng bandwidth 159
  tunnel mpls traffic-eng path-option 1 explicit name straight
 !

 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.22 255.255.255.252
  ip router isis 
  tag-switching ip
  mpls traffic-eng tunnels 
  frame-relay interface-dlci 603   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0006.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 !
 ip classless
 !
 ip explicit-path name low enable
  next-address 10.1.1.21 
  next-address 10.1.1.10 
  next-address 10.1.1.1 
  next-address 10.1.1.14 
 !
 ip explicit-path name straight enable
  next-address 10.1.1.21 
  next-address 10.1.1.5 
  next-address 10.1.1.14 
 !
 end

PEscara
Current configuration:
 !
 version 12.0
 !
 hostname Pescara
 !

 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.4 255.255.255.255
  ip router isis 
 !
 interface Tunnel1
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 5 5
  tunnel mpls traffic-eng bandwidth 25
  tunnel mpls traffic-eng path-option 2 dynamic
 !
 interface Tunnel3
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 6 6
  tunnel mpls traffic-eng bandwidth  69
  tunnel mpls traffic-eng path-option 1 dynamic
 !

 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.14 255.255.255.252

  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 401   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0004.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 end

Pomerol
Current configuration:

 version 12.0
 !
 hostname Pomerol
 !
 ip cef
 !
 mpls traffic-eng tunnels
!
 interface Loopback0
  ip address 10.10.10.3 255.255.255.255
  ip router isis 
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.6 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
   frame-relay interface-dlci 301   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.9 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 302   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.3 point-to-point
  bandwidth 512
  ip address 10.1.1.21 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 306   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0003.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pulligny
Current configuration:
 !
 version 12.1
 !
 hostname Pulligny
 !
 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.2 255.255.255.255
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.2 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 201   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.10 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 203   
  ip rsvp bandwidth 512 512
 !
 router isis 
  passive-interface Loopback0
  net 49.0001.0000.0000.0002.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pauillac
!
 version 12.1
 !
 hostname pauillac
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.1 255.255.255.255
  ip router isis 
 !
 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.1 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 102   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.2 point-to-point
  bandwidth 512
  ip address 10.1.1.5 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 103   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.3 point-to-point
  bandwidth 512
  ip address 10.1.1.13 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 104   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0001.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Проверка.

команды "show"

В данном разделе содержатся сведения о проверке работы конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show mpls traffic-eng tunnels brief

  • название Pesaro_t158 show mpls traffic-eng tunnels

  • show ip rsvp interface

  • назначение show mpls traffic-eng topology path 10.10.10.6 пропускных способностей 75

Другие полезные команды (не проиллюстрированный здесь) включают:

  • show isis mpls traffic-eng advertisements

  • show tag-switching forwarding-table

  • show ip cef

  • show mpls traffic-eng tunnels summary

Образец команды show output

На любом LSR можно использовать show mpls traffic-eng tunnels для проверки существования и состояния туннелей. Например, на Pesaro, вы видите в общей сложности четыре туннеля, два, которые достигают Pesaro (Pescara_t1 и t3) и два, которые запускаются с Pesaro (t158 и t159):

Pesaro#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 606 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pesaro_t158                      10.10.10.4       -         Se0/0.1   up/up
Pesaro_t159                      10.10.10.4       -         Se0/0.1   up/up     
Pescara_t1                       10.10.10.6       Se0/0.1   -         up/up     
Pescara_t3                       10.10.10.6       Se0/0.1   -         up/up     
Displayed 2 (of 2) heads, 0 (of 0) midpoints,2 (of 2) tails

Это - то, что замечено в то время как на среднем маршрутизаторе:

Pulligny#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 406 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pescara_t3                       10.10.10.6       Se0/1.1   Se0/1.2   up/up
Pesaro_t158                      10.10.10.4       Se0/1.2   Se0/1.1   up/up
Displayed 0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails

Подробная конфигурация любого туннеля может быть замечена использующая это:

Pesaro#show mpls traffic-eng tunnels name Pesaro_t158

Name: Pesaro_t158                         (Tunnel158) Destination: 10.10.10.4
  Status:
    Admin: up         Oper: up     Path: valid       Signaling: connected

    path option 1, type explicit low (Basis for Setup, path weight 40)

  Config Parameters:
    Bandwidth:  158      kbps  Priority: 2  2   Affinity: 0x0/0xFFFF
    AutoRoute:  enabled   LockDown: disabled    

  InLabel  :  - 
  OutLabel : Serial0/0.1, 17
  RSVP Signaling Info:
       Src 10.10.10.6, Dst 10.10.10.4, Tun_Id 158, Tun_Instance 1601
    RSVP Path Info:
      My Address: 10.10.10.6   
      Explicit Route: 10.1.1.21 10.1.1.10 10.1.1.1 10.1.1.14 
 10.10.10.4 
      Record   Route:  NONE
      Tspec: ave rate=158 kbits, burst=8000 bytes, peak rate=158 kbits
    RSVP Resv Info:
      Record   Route:  NONE
      Fspec: ave rate=158 kbits, burst=8000 bytes, peak rate=4294967 kbits
  History:
    Current LSP:
      Uptime: 3 hours, 33 minutes
      Selection: reoptimation
    Prior LSP:
      ID: path option 1 [1600]
      Removal Trigger: configuration changed

В этом случае путь является явным и указанным в сообщении RSVP (поле, которое переносит путь, также известен как Explicit Route Object [ERO]). Если этот путь не может придерживаться, Устройство MPLS TE использует следующий параметр Path, который может быть другим явным маршрутом или динамическим маршрутом.

RSVP определенная информация является доступными использующими стандартными командами RSVP. В этих выходных данных существует два резервирования, сделанное на Pulligny, один Pesaro_t158 (158K) и другим Pescara_t3 (69k).

Pulligny#show ip rsvp interface
interface    allocated  i/f max  flow max pct UDP  IP   UDP_IP   UDP M/C 
Se0/1        0M         0M       0M       0   0    0    0        0       
Se0/1.1      158K       512K     512K     30  0    1    0        0 
Se0/1.2      69K        512K     512K     13  0    1    0        0

Если вы хотите знать, какой путь ТЕ используется для индивидуального пункта назначения (и определенная пропускная способность), не создавая туннель, можно использовать эту команду:

Примечание: Обратите внимание на то, что эта команда обернута к второй линии по пространственным причинам.

Pescara#show mpls traffic-eng topology path destination 
                          10.10.10.6 bandwidth 75
Query Parameters:
  Destination: 10.10.10.6
    Bandwidth: 75
   Priorities: 0 (setup), 0 (hold)
     Affinity: 0x0 (value), 0xFFFFFFFF (mask)
Query Results:
  Min Bandwidth Along Path: 385 (kbps)
  Max Bandwidth Along Path: 512 (kbps)
  Hop  0: 10.1.1.14      : affinity 00000000, bandwidth 512 (kbps)
  Hop  1: 10.1.1.5       : affinity 00000000, bandwidth 385 (kbps)
  Hop  2: 10.1.1.21      : affinity 00000000, bandwidth 512 (kbps)
  Hop  3: 10.10.10.6

Если сеть делает распространение IP TTL (обратитесь к ТТЛ-схеме ip mpls, распространяются ), выполните команду traceroute и посмотрите, что придерживавшийся путь является туннелем и что туннель направляет согласно тому, что настроено:

Pescara#traceroute 10.10.10.6

Type escape sequence to abort.
Tracing the route to 10.10.10.6

  1 10.1.1.13 [MPLS: Label 29 Exp 0] 540 msec 312 msec 448 msec
  2 10.1.1.2 [MPLS: Label 27 Exp 0] 260 msec 276 msec 556 msec
  3 10.1.1.9 [MPLS: Label 29 Exp 0] 228 msec 244 msec 228 msec
  4 10.1.1.22 112 msec *  104 msec

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13737