Многопротокольная коммутация по меткам (MPLS) : MPLS

Выбор базовой конфигурации для MPLS VPN

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Когда Протокол BGP или Протокол RIP присутствуют на узле клиента, этот документ предоставляет пример конфигурации VPN Многопротокольной коммутации по меткам (MPLS).

Использование функции виртуальной частной сети с многопротокольной коммутацией на основе признаков позволяет нескольким узлам взаимодействовать прозрачным образом посредством сети поставщика услуг. Одна сеть поставщика услуг может поддерживать несколько различных IP-сетей VPN. Любая из этих сетей для пользователей является частной сетью, отделенной от других сетей. В пределах сети VPN с каждого узла могут быть переданы IP-пакеты на другой узел этой же сети.

Каждая сеть VPN связана с одним или более коммутируемым или пересылаемым экземпляром (VRF). VRF состоит из таблицы IP-маршрутизации, производной таблицы Cisco Express Forwarding (CEF) и набора интерфейсов, использующих таблицу передачи.

Маршрутизатор поддерживает отдельную маршрутизацию и таблицу CEF для каждого VRF. Эта возможность предотвращает передачу данных за пределы сети VPN и разрешает использование одной подсети в нескольких VPN без дублирования IP-адресов.

Маршрутизатор, использующий мультипротокол BGP (MP-BGP), распространяет сведения о маршрутизации VPN, используя расширенные сообщества MP-BGP.

Для получения дополнительной информации о распространении обновлений через VPN, обратитесь к этим документам:

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

Маршрутизаторы P и PE

  • Cisco Выпуск ПО IOS� 12.2 (6-й) включает функцию MPLS VPN.

  • Все маршрутизаторы Cisco серии 7200 или выше поддерживают функции P. Маршрутизаторы Cisco серий 2691, 3640 и выше поддерживают функции PE.

Маршрутизаторы C и CE

  • Можно использовать любой маршрутизатор, который может обмениваться сведениями о маршрутизации с его Периферийным маршрутизатором.

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Родственные продукты

Для реализования опции MPLS у вас должен быть маршрутизатор из диапазона Cisco 2600 или выше. Чтобы выбрать требуемое ПО Cisco IOS с функцией MPLS, воспользуйтесь Software Advisor (только для зарегистрированных клиентов). Проверьте, чтобы оперативной и флэш-памяти было достаточно для запуска средства MPLS на маршрутизаторах. Можно использовать WIC-1T, WIC-2T и другие последовательные интерфейсы.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Приведенные ниже буквы соответствуют различным типам используемых маршрутизаторов и коммутаторов.

  • P - Основной маршрутизатор провайдера.

  • PE - маршрутизатор на стороне поставщика.

  • CE – Граничный маршрутизатор клиента.

  • C – маршрутизатор клиента.

На данной диаграмме показана типичная конфигурация, иллюстрирующая описанные выше условия.

/image/gif/paws/13733/mplsvpn.gif

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/13733/new_mpls_vpn_basic1.gif

Процедуры конфигурации

См. Виртуальные частные сети MPLS для получения дополнительной информации.

Включение ip cef

Используйте эту процедуру для включения ip cef . Для улучшения производительности используйте ip cef distributed (при наличии) . Выполните эти шаги на PE после того, как MPLS будет установлен (настраивающий tag-switching ip на интерфейсах).

  1. Создайте одну VRF для каждой VPN, подключенной с помощью команды ip vrf <VPN routing/forwarding instance name >.

    При этом выполните следующие действия:

    • Укажите правильный отличительный признак маршрута, который используется для данной виртуальной частной сети (VPN). Это используется для расширения IP-адресов, чтобы можно было определить их принадлежность к VPN.

      
      rd <VPN route distinguisher>
      
      
    • Задайте свойства импорта и экспорта для расширенных сообществ MP-BGP. Данные свойства используются для фильтрации процессов экспорта-импорта.

      
      route-target [export|import|both] <target VPN extended community>
      
      
  2. Настройте сведения о переадресации для соответствующих интерфейсов с помощью команды name> маршрутизации/экземпляра VRF <VPN ip vrf forwarding и не забудьте устанавливать IP-адрес после выполнения этого.

  3. В зависимости от используемого на участке PE-CE протокола маршрутизации вы можете настроить между PE и CE статичные маршруты, либо задействовать протоколы маршрутизации (RIP, выбор кратчайшего пути [OSPF] или BGP). Подробные настройки доступны на странице поддержки MPLS через ATM.

Настройка конфигурации MP-BGP

Настройте MP-BGP между периферийными маршрутизаторами. Существует несколько способов настроить протокол BGP, например с помощью отражателя маршрутов или методов конфедерации. Используемый здесь метод - настройка непосредственного соседа - является наиболее простым и наименее масштабируемым решением.

  1. Объявите различных соседей.

  2. Введите команду name> маршрутизации/экземпляра VRF <VPN VRF ipv4 address-family для каждого подарка VPN в этом Периферийном маршрутизаторе.

    При необходимости выполните одно или несколько следующих действий:

    • Перераспределяет статическую маршрутную,RIP или OSPF информацию.

    • Перераспределите данные о подключенных маршрутах.

    • Включите соседство BGP с CE-маршрутизаторами.

  3. Перейдите в режим address-family vpnv4 и выполните следующие действия:

    • Активируйте соседей.

    • Укажите необходимость использования расширенного сообщества. Данное действие является обязательным.

Конфигурации

Эти конфигурации используются в данном документе:

PEscara
Current configuration:
!
version 12.2
!
hostname Pescara
!
ip cef
!


!--- Customer A commands.

ip vrf Customer_A

!--- Enables the VPN routing and forwarding (VRF) routing table.
!--- This command can be used in global or 
!--- router configuration mode. 

 rd 100:110

!--- Route distinguisher creates routing and forwarding 
!--- tables for a VRF.

 route-target export 100:1000

!--- Creates lists of import and export route-target extended 
!--- communities for the specified VRF.

 route-target import 100:1000
!


!--- Customer B commands.

ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
 ip router isis


!--- Customer A commands.

interface Loopback101
ip vrf forwarding Customer_A

!--- Associates a VRF instance with an interface or subinterface.

 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 and 102 use the same IP address, 200.0.4.1. 
!--- This is allowed because they belong to two 
!--- different customers' VRFs. 

 no ip directed-broadcast
!


!--- Customer B commands.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 and 102 use the same IP address, 200.0.4.1. 
!--- This is allowed because they belong to two 
!--- different customers' VRFs.
 
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no fair-queue
!
interface Serial2/0.1 point-to-point
 description link to Pauillac
 bandwidth 512
 ip address 10.1.1.14 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 401   
!
router isis 
 net 49.0001.0000.0000.0004.00
 is-type level-1
!         
router bgp 100
 bgp log-neighbor-changes

!--- Enables logging of BGP neighbor resets.

 neighbor 10.10.10.6 remote-as 100

!--- Adds an entry to the BGP or multiprotocol BGP neighbor table.

 neighbor 10.10.10.6 update-source Loopback0

!--- Enables BGP sessions to use a specific operational 
!--- interface for TCP connections.

!
 

!--- Customer A and B commands.

 address-family vpnv4

!--- To enter address family configuration mode 
!--- for configuring routing sessions, such as BGP, 
!--- that use standard VPN version 4 address prefixes.

 neighbor 10.10.10.6 activate
 neighbor 10.10.10.6 send-community both
 
!--- Sends the community attribute to a BGP neighbor.

 exit-address-family
 !


!--- Customer B commands.

 address-family ipv4 vrf Customer_B

!--- To enter address family configuration mode 
!--- for configuring routing sessions, such as BGP, 
!--- that use standard VPN version 4 address prefixes.

 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 

!--- Customer A commands.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
!
ip classless
!
end

Pesaro
Current configuration:
!
version 12.1
!
hostname Pesaro
!


!--- Customer A commands.

ip vrf Customer_A
 rd 100:110
 route-target export 100:1000
 route-target import 100:1000
!


!--- Customer B commands.

ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
ip cef

!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
 ip router isis 


!--- Customer A commands.

interface Loopback101
 ip vrf forwarding Customer_A
 ip address 200.0.6.1 255.255.255.0
!


!--- Customer B commands.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.6.1 255.255.255.0
!


!--- Customer A commands.

interface Loopback111
 ip vrf forwarding Customer_A
 ip address 200.1.6.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 random-detect
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwidth 512
 ip address 10.1.1.22 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 603   
!
router isis 
 net 49.0001.0000.0000.0006.00
 is-type level-1
!
router bgp 100
 neighbor 10.10.10.4 remote-as 100
 neighbor 10.10.10.4 update-source Loopback0
 !


!--- Customer B commands.

 address-family ipv4 vrf Customer_B
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Customer A commands.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Customer A and B commands.

 address-family vpnv4
 neighbor 10.10.10.4 activate
 neighbor 10.10.10.4 send-community both
 exit-address-family
!
ip classless
!         
end

Pomerol
Current configuration:
!
version 12.0
!
hostname Pomerol
!
ip cef

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis 

!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.6 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching mtu 1520
 tag-switching ip 
 frame-relay interface-dlci 301   
!
interface Serial0/1.2 point-to-point
 description link to Pulligny
 ip address 10.1.1.9 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 303   
!
interface Serial0/1.3 point-to-point
 description link to Pesaro
 ip address 10.1.1.21 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip

 frame-relay interface-dlci 306   
!
router isis 
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny
Current configuration:
!
version 12.1
!
hostname Pulligny
!
!
ip cef

!
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.2 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 201   
!
interface Serial0/1.2 point-to-point
 description link to Pomerol
 ip address 10.1.1.10 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 203   
!
router isis 
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1
!
ip classless
!
end

Pauillac
!
version 12.1
!
hostname pauillac
!
ip cef

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis  
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 tag-switching ip
 no fair-queue
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwith 512
 ip address 10.1.1.1 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 102   
!
interface Serial0/0.2 point-to-point
 description link to Pulligny ip address 10.1.1.5 255.255.255.252

 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 103   
!
interface Serial0/0.3 point-to-point
 description link to Pescara
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 104   
!
router isis 
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show ip vrf — Проверяет, что существует корректный VRF.

  • show ip vrf interfaces — Проверяет активированные интерфейсы.

  • Customer_A show ip route vrf — Проверяет сведения о маршрутизации на Периферийных маршрутизаторах.

  • Customer_A VRF traceroute 200.0.6.1 — Проверяет сведения о маршрутизации на Периферийных маршрутизаторах.

  • show ip bgp vpnv4 tag — Проверяет BGP.

  • Customer_A show ip cef vrf 200.0.6.1 подробностей — Проверяет сведения о маршрутизации на Периферийных маршрутизаторах.

О многих командах подробно рассказано в руководстве по устранению неполадок решений MPLS VPN.

Пример выходных данных команды show ip vrf приводится ниже.

Pescara#show ip vrf 
  Name                             Default RD          Interfaces
  Customer_A                       100:110             Loopback101
  Customer_B                       100:120             Loopback102

Пример выходных данных команды show ip vrf interfaces.

Pesaro#show ip vrf interfaces 
Interface              IP-Address      VRF                              Protocol
Loopback101            200.0.6.1       Customer_A                       up      
Loopback111            200.1.6.1       Customer_A                       up      
Loopback102            200.0.6.1       Customer_B                       up      

В в выходных данных команд show ip route vrf присутствует одинаковый префикс 200.0.6.0/24. Это связано с тем, что удаленный маршрутизатор PE предоставляет одну и ту же сеть для двух клиентов, Customer_A и Customer_B. Это реализуется в рамках стандартного решения MPLS VPN.

Pescara#show ip route vrf Customer_A
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR

Gateway of last resort is not set

C    200.0.4.0/24 is directly connected, Loopback101
B    200.0.6.0/24 [200/0] via 10.10.10.6, 05:10:11
B    200.1.6.0/24 [200/0] via 10.10.10.6, 04:48:11
 
Pescara#show ip route vrf Customer_B
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
	   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
	   * - candidate default, U - per-user static route, o - ODR       
	   P - periodic downloaded static route
	    
Gateway of last resort is not set
C 200.0.4.0/24 is directly connected, Loopback102
 
B 200.0.6.0/24 [200/0] via 10.10.10.6, 00:03:24

С помощью трассировки маршрута между двумя узлами клиента Customer_A можно увидеть стек меток, используемый сетью MPLS (если это поддерживается конфигурацией с помощью команды mpls ip ttl ...)...).

Pescara#traceroute vrf Customer_A 200.0.6.1

Type escape sequence to abort.
Tracing the route to 200.0.6.1

  1 10.1.1.13 [MPLS: Labels 20/26 Exp 0] 400 msec 276 msec 264 msec
  2 10.1.1.6 [MPLS: Labels 18/26 Exp 0] 224 msec 460 msec 344 msec
  3 200.0.6.1 108 msec *  100 msec

Примечание:  Для QoS используется экспериментальное поле Exp 0.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 13733