Протокол IP : Протокол EIGRP

Задание предпочтительного маршрута путем влияния на метрики EIGRP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (21 мая 2008) | Английский (22 августа 2015) | Отзыв


Интерактивно этот документ предлагает анализ конкретного устройства Cisco.


Содержание


Введение

В настоящем документе описывается процесс создания предпочтительного пути посредством воздействия на метрику расширенного протокола внутренней маршрутизации между шлюзами (Enhanced Interior Gateway Routing Protocol – EIGRP). Для топологии, показанной на схеме сети, в этом документе описано несколько способов воздействия на IP-трафик от клиентов к серверам с тем, чтобы предпочтительным был путь R1> R2> R3. Цель состоит в том, чтобы сделать путь R1> R2> R4 в запасным и использовать его только в случае сбоя в R3.

Предварительные условия

Требования

Использование данного документа предполагает наличие базовых знаний о маршрутизации IP и EIGRP. Для получения дополнительной информации по IP-маршрутизации и протоколу EIGRP см. следующие документы:

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения.

  • EIGRP поддерживается в Cisco Выпуск ПО IOS� 9.21 и позже. Сведения, содержащиеся в этом документе, были получены в результате использования программного обеспечения Cisco IOS версии 12.3(3).

  • Протокол EIGRP может быть настроен на всех маршрутизаторах (например маршрутизаторы Cisco серии 2500 и серии 2600), а также на всех коммутаторах 3-го уровня.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

Существует несколько методов настройки предпочтительного маршрута путем воздействия на метрику протокола EIGRP. В этом документе описаны эти методы и подробно освещены их преимущества и недостатки. В этом документе также обсуждается влияние изменения пропускной способности, несмотря на то, что это не является приемлемым средством изменения пути в данном примере.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/13673-14-a.gif

Щелкните диаграмму сети, чтобы отобразить ее отдельном окне браузера (в дальнейшем ее можно использовать в качестве вспомогательного материала).

Две из команд, используемых всюду по этому документу для подтверждения поведения EIGRP, являются show ip eigrp topology и сетевым ip show ip eigrp topology команды subnet-mask .

Примечание: Для дополнительных сведений о командах, используемых в этом документе, обратитесь к Средству поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Если у вас есть выходные данные команды show ip eigrp topology или сетевого ip show ip eigrp topology команда subnet-mask от устройства Сisco, вы можете использовать Интерпретатор выходных данных (только зарегистрированные клиенты) для показа потенциальных проблем и исправляете. Для использования служебной программы Output Interpreter (только длязарегистрированных клиентов) необходимо выполнить вход в систему и разрешить использование сценариев JavaScript.

Общие сведения – основы метрик EIGRP

Обновления протокола EIGRP содержат пять метрик: минимальная пропускная способность, задержка, загрузка, надежность и максимальный размер передаваемого блока данных (MTU). По умолчанию для подсчета оптимального пути из всех пяти метрик используются только минимальная пропускная способность и задержка. В отличие от большинства метрик, значение минимальной пропускной способности устанавливается для всего пути. Это значение не учитывает количество сегментов сети или количество каналов с низкой пропускной способностью, входящих в состав данного пути. Задержка является суммарной величиной. Она складывается из значений задержки каждого сегмента пути. Более подробно о метриках протокола EIGRP см. официальный документ Техническое описание протокола EIGRP.

Возможные конфигурации

Эти конфигурации могут быть использованы для установки предпочитаемого маршрута.

Стандартная конфигурация распределения нагрузки

_________________________ М1

R1# show run

Current configuration: 640 bytes
!
version 12.3
!
hostname R1
!
interface Serial0
 no ip address
 encapsulation frame-relay

!--- Enables Frame Relay encapsulation.

!
interface Serial0.201 point-to-point

!--- Enables a point-to-point link on the sub-interface.

 ip address 10.1.1.1 255.255.255.0
 frame-relay interface-dlci 201

!--- Assigns a data-link connection identifier (DLCI)
!--- to a Frame Relay sub-interface.

!
router eigrp 1
 network 10.0.0.0
!
end

Примечание: Коммутатор Frame Relay не показан на схеме сети.

R1# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/2221056] via 10.1.1.2, 00:07:08, Serial0.201
D       10.1.2.0 [90/2195456] via 10.1.1.2, 00:07:08, Serial0.201
C       10.1.1.0 is directly connected, Serial0.201

R1# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
  Routing Descriptor Blocks:
  10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
      Composite metric is (2221056/307200), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 22000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2

_________________________ М2

R2# show run

Current configuration: 618 bytes
!
version 12.3
!
hostname R2
!
interface Ethernet0
 ip address 10.1.2.2 255.255.255.0
 no ip directed-broadcast
!
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.101 point-to-point
 ip address 10.1.1.2 255.255.255.0
 frame-relay interface-dlci 101
!
router eigrp 1
 network 10.0.0.0
!
end

R2# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/307200] via 10.1.2.4, 00:03:47, Ethernet0
                 [90/307200] via 10.1.2.3, 00:03:48, Ethernet0
C       10.1.2.0 is directly connected, Ethernet0
C       10.1.1.0 is directly connected, Serial0.101

Примечание: R2 имеет два равноценных пути к 10.1.3.0/24 через R3 (10.1.2.3) и R4 (10.1.2.4).

R2# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 307200
  Routing Descriptor Blocks:
  10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
  10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

Примечание: Оба пути имеют ту же Составную метрику (Расстояние/Объявленное расстояние). Возможное расстояние (FD) до маршрутизатора R1 объявлено, и потом оно становится фактическим расстоянием для R1.

R3

R3# show run

Current configuration: 556 bytes
!
version 12.3
!
hostname R3
!
interface Ethernet0/0
 ip address 10.1.2.3 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 10.1.3.3 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
!
end

R3# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Ethernet0/1
C       10.1.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/20537600] via 10.1.2.2, 00:16:14, Ethernet0/0

R3# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  10.1.2.4 (Ethernet0/0), from 10.1.2.4, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

R3# show interface ethernet0/1

Ethernet0/1 is up, line protocol is up
  Hardware is AmdP2, address is 0050.7329.52e1 (bia 0050.7329.52e1)
  Internet address is 10.1.3.3/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     291 packets input, 28402 bytes, 0 no buffer
     Received 283 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     500 packets output, 50876 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

R4

R4# show run

Current configuration: 549 bytes
!
version 12.3
!
hostname R4
!
interface Ethernet0/0
 ip address 10.1.2.4 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 10.1.3.4 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
!
end

R4# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Ethernet0/1
C       10.1.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/20537600] via 10.1.2.2, 00:17:08, Ethernet0/0

R4# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  10.1.2.3 (Ethernet0/0), from 10.1.2.3, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

Измените параметр задержки на интерфейсе (маршрутизатор R4)

Поскольку изменения в метрике задержки передаются на все нисходящие маршрутизаторы, то для данных двух сценариев изменение параметра задержки интерфейса будет наиболее предпочтительным способом повлиять на выбор пути:

  • Сегмент Ethernet 10.1.3.0/24 содержит только серверы, и другие подсети за подсетью 10.1.3.0/24 отсутствуют. (Это идеальная конфигурация для серверной фермы.).)

  • Вы хотите влиять на выбор пути для всех маршрутов, полученных от соседей EIGRP на сегменте 10.1.3.0/24.

  1. Прежде чем вносить какие-либо изменения, необходимо определить задержку на интерфейсе.

    В настоящий момент величина этой задержки такая же, как и величина задержки на маршрутизаторе R3.

    R4# show interface ethernet0/1
    
    Ethernet0/1 is up, line protocol is up
      Hardware is AmdP2, address is 0050.7329.5321 (bia 0050.7329.5321)
      Internet address is 10.1.3.4/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:02, output 00:00:02, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         284 packets input, 27914 bytes, 0 no buffer
         Received 276 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 input packets with dribble condition detected
         482 packets output, 49151 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  2. Измените значение задержки для сегмента 10.1.3.0/24.

    Следует очень осторожно выбирать новое значение задержки. Нежелательно увеличивать задержку до величины, когда R2 больше не будет рассматривать маршрут как реальное продолжение.

    R4# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R4(config)# interface ethernet0/1
    
    R4(config-if)# delay 120
    
    !--- Delay is entered in tens of microseconds.
    
    R4(config-if)# end
    
    R4#
  3. Подтвердите новое значение задержки – 12000 микросекунд – для данного интерфейса.

    R4# show interface ethernet0/1
    
      Hardware is AmdP2, address is 0050.7329.5321 (bia 0050.7329.5321)
      Internet address is 10.1.3.4/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1200 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:03, output 00:00:00, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         345 packets input, 33508 bytes, 0 no buffer
         Received 333 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 input packets with dribble condition detected
         575 packets output, 57863 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  4. Подтвердите, что только R2 имеет один "наилучший" маршрут к 10.1.3.0, через R3.

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:02:43, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101
    
    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (312320/286720), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2200 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

    Команда show ip eigrp topology показывает, что, как и ожидалось, метрика времени задержки, объявленная маршрутизатором R4, была увеличена в 200 раз (до 2200 микросекунд). Это увеличение ведет к разнице в стоимости двух маршрутов и невозможности распределения нагрузки для R2.

    Примечание: Поскольку расстояние, объявленное R4 (286720), является меньше, чем расстояние, объявленное R2 (допустимое расстояние, 307200), путь считают исключающим зацикливанием. Поскольку путь, объявленный маршрутизатором R4, считается беспетлевым, то он становится вероятным заместителем и будет установлен сразу же после того, как маршрутизатор R3 прекратит объявлять маршрут к 10.1.3.0/24.

    R1# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/2221056] via 10.1.1.2, 00:25:27, Serial0.201
    D       10.1.2.0 [90/2195456] via 10.1.1.2, 00:25:27, Serial0.201
    C       10.1.1.0 is directly connected, Serial0.201
    
    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/307200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

Используйте список смещений на R4 для изменения составной метрики на R2

Составная метрика на R2 может модифицироваться с помощью offset-list на маршрутизаторе R4. В результате установки значения списка смещения, равного 20, комплексная метрика для пути R2-R4 на маршрутизаторе R2 увеличивается на 20. Поэтому путь R2-R4 используется в качестве резервного для пути R2-R3. Метод списка смещений следует в следующих случаях:

  • Если требуется воздействовать на объявленный конкретный путь.

  • К подсети 10.1.3.0/24 подключены дополнительные маршрутизаторы и воздействие на пути, образованные данными маршрутизаторами, нежелательно.

  1. Настройте список смещений на маршрутизаторе R4, при котором задержка для любого пути, начинающегося с 10.1.3.x, будет увеличена на 20.

    R4# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R4(config)# access-list 99 permit 10.1.3.0 0.0.0.255
    
    R4(config)# router eigrp 1
    
    R4(config-router)# offset-list 99 out 20 e0/0
    
    R4(config-router)# end
    
    R4#
  2. Из данного вывода видно, что список смещений не изменяет таблицу топологии EIGRP на R4.

    Метрика изменяется только при объявлении маршрута.

    R4# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
      Routing Descriptor Blocks:
      0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
          Composite metric is (281600/0), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 1000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 0
      10.1.2.3 (Ethernet0/0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
  3. На маршрутизаторе R2 подтвердите, что маршрут, проходящий через маршрутизатор R3 (10.1.2.3), является единственным оптимальным путем.

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:00:20, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101

    В таблице топологий EIGRP отражено повышение задержки от R4 (10.1.2.4).

    Вероятное расстояние R4 (281600) + список смещений R4 (20) = фактическое расстояние R4 (281620).

    Примечание: Мелкий дефект в программном обеспечении Cisco IOS версии 12.0(7) препятствует тому, чтобы увеличенное время задержки было точно отражено в разделе Всей задержки выходных данных, показанных здесь.

    DDTS Описание
    CSCdp36097 (только зарегистрированные клиенты) EIGRP: список смещений добавляет неверное значение задержки

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (307220/281620), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

Настройка административного расстояния на маршрутизаторе R2

Процедуру выбора пути можно также изменить, воздействуя на административное расстояние (на маршрутизаторе R2) маршрута, полученного от маршрутизатора R4. По сравнению с другими методами этот метод менее оптимален. Его использование может увеличить вероятность возникновения петель маршрутизации:

  • Административное расстояние, как правило, используется для определения метода, при помощи которого был получен маршрут. При неправильной установке административного расстояния отдельный маршрутизатор не сможет выбрать перераспределенный маршрут взамен имеющегося оптимального пути.

  • Административное расстояние не передается на другие маршрутизаторы. Протоколы маршрутизации основаны на том факте, что все маршрутизаторы выбирают один и тот же путь с одинаковым набором параметров. Изменение параметров на отдельном маршрутизаторе может стать причиной возникновения петель маршрутизации.

  1. Измените конфигурацию маршрутизатора R2 таким образом, чтобы при обнаружении обновления маршрутизации, объявляемого маршрутизатором R4 (10.1.2.4) для сети 10.1.3.0/24, административное расстояние увеличивалось до 91.

    Значение 91 выбрано потому, что оно на 1 больше стандартного административного расстояния EIGRP для внутренних устройств (равного 90). Стандартное административное расстояние для внешних устройств EIGRP (маршруты, перераспределенные в EIGRP) равно 170. Чтобы узнать стандартные значения для всех протоколов маршрутизации, см. Таблицу значений для расстояния по умолчанию в документе Что такое административное расстояние.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# access-list 99 permit 10.1.3.0 0.0.0.255
    
    R2(config)# router eigrp 1
    
    R2(config-router)# distance 91 10.1.2.4 0.0.0.0 99
    
    R2(config-router)# end
    
    R2#
  2. На данном этапе может понадобиться выполнить команду clear ip route. Это необходимо для того, чтобы привести внесенные изменения в действие.

    Примечание: Теперь существует только один путь к 10.1.3.0/24 через R3 (10.1.2.3).

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:05:28, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101

    Примечание: Ничто в таблице топологии EIGRP не изменилось.

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

Возможные проблемы

Для иллюстрации проблемы, которую может вызвать этот метод в случае его неосмотрительного использования, представьте, что R1 и R2 используют протокол открытого поиска кратчайшего пути (OSPF), при котором административное расстояние составляет 110, для сети 11.0.0.0/8. Также представим, что маршрутизатор R4 имеет статический маршрут для 11.1.1.0/24, который указывает на R2 (10.1.2.2). R4 распределяет статические маршруты в EIGRP, так что новые маршрутизаторы в 10.1.3.0/24 могут получить доступ к 11.1.1.0/24.

Обычно R2 получает внешний маршрут EIGRP для 11.1.1.0/24 от R4 (административное расстояние равно 170). Поскольку данное значение выше, чем значение маршрута OSPF (110), этот маршрут не будет установлен.

Приведенные ниже выходные данные являются примером неправильного использования команды настройки расстояния, указанной выше.

R2# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)# access-list 99 permit 11.1.1.0 0.0.0.255

R2(config)# router eigrp 1

R2(config-router)# distance 91 10.1.2.4 0.0.0.0 99

R2(config-router)# end

R2#

Такая конфигурация ведет к возникновению петли маршрутизации между R2 и R4 для подсети 11.1.1.0/24. Теперь R2 предпочитает использовать путь к 11.1.1.0/24, который был объявлен R4. Произошло это потому, что административное расстояние (91) меньше административного расстояния для маршрута OSPF (110).

Измените пропускную способность на маршрутизаторе R2

Использование пропускной способности для влияния на пути EIGRP не рекомендуется по двум причинам:

  • Изменение пропускной способности может оказать воздействие, которое будет выходить за рамки метрики EIGRP. Например, службе качества обслуживания (QoS) также необходима пропускная способность на интерфейсе.

  • EIGRP включает регулирование, чтобы использовать 50 процентов от установленной пропускной способности. Уменьшение пропускной способности может стать причиной возникновения различных проблем. Например, из-за уменьшившейся пропускной способности соседи EIGRP могут прекратить получать приветственные пакеты.

Изменение задержки не влияет на другие протоколы и не заставляет EIGRP уменьшать пропускную способность.

  1. Прежде чем вносить какие-либо изменения, необходимо проверить таблицу топологии для маршрутизатора R1.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/307200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2
  2. Проверьте начальные значения для интерфейса ethernet0 на маршрутизаторе R2.

    R2# show interface ethernet0
    
    Ethernet0 is up, line protocol is up
      Hardware is Lance, address is 0010.7b3c.6786 (bia 0010.7b3c.6786)
      Internet address is 10.1.2.2/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:01, output 00:00:02, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1938 packets input, 165094 bytes, 0 no buffer
         Received 1919 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 input packets with dribble condition detected
         1482 packets output, 124222 bytes, 0 underruns
         0 output errors, 0 collisions, 18 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  3. Уменьшите пропускную способность, чтобы проверить воздействие на R1.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# interface ethernet0
    
    R2(config-if)# bandwidth 5000
    
    R2(config-if)# end
    
    R2#
  4. Подтвердите изменения.

    R2# show interface ethernet0
    
    Ethernet0 is up, line protocol is up
      Hardware is Lance, address is 0010.7b3c.6786 (bia 0010.7b3c.6786)
      Internet address is 10.1.2.2/24
      MTU 1500 bytes, BW 5000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:02, output 00:00:01, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1995 packets input, 169919 bytes, 0 no buffer
         Received 1969 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 input packets with dribble condition detected
         1525 packets output, 127831 bytes, 0 underruns
         0 output errors, 0 collisions, 18 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  5. Убедитесь, что пропускная способность также изменилась в таблице топологии EIGRP.

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 2 Successor(s), FD is 563200
      Routing Descriptor Blocks:
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (563200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 5000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (563200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 5000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
  6. Проверьте, есть ли изменения в таблице топологии EIGRP на маршрутизаторе R1.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/563200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

    Изменения отсутствуют, поскольку соединение Frame Relay между R1 и R2 по-прежнему остается каналом с наименьшей скоростью. Изменение можно увидеть, только если уменьшить полосу пропускания интерфейса ethernet0 для R2 до значения меньше 1544.

  7. Уменьшите пропускную способность до 1000 на интерфейсе ethernet0 маршрутизатора R2.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# interface ethernet 0
    
    R2(config-if)# bandwidth 1000
    
    R2(config-if)# end
    
    R2#
  8. Проверьте, есть ли изменения в таблице топологии EIGRP на маршрутизаторе R1.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): Topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 312320
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (3123200/2611200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1000 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения

Нажмите для открытия в новом окне.


Document ID: 13673