Протокол IP : Serial Tunnel (STUN)

Настройка соединений BSTUN Point-to-Point с локальным подтверждением по сети Frame Relay

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Bisync Serial Tunnel (BSTUN), который функция включает поддержке устройств, которые используют Протокол bisync. Этот протокол позволяет предприятиям транспортировать трафик BiSync (двоичная синхронная передача данных) по той же сети, которая поддерживает их Системную сетевую архитектуру (SNA) и мультипротокольный трафик, который избавляет от необходимости отдельные средства синхронной передачи двоичных данных. С Frame Relay можно использовать функцию локального подтверждения для обеспечения локального завершения сеанса на Одноранговом телефонном соединении BSTUN.

В данном примере Функция BSTUN точка-точка настроена с Локальным Ackowledgement по Frame Relay. Соответствующие состояния в выходных данных команды show bstun выделены в этом документе.

Примечание: Несмотря на то, что debug bstun packet/event и команды debug bsc packet/event не должны вызывать чрезмерную загрузку ЦП, команда logging buffered используется для копирования выходных данных к файлу журнала.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на Cisco Выпуск ПО IOS� 12.1 (5).

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

bstun_p2p_localack_over_fr-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Kilcot
Building configuration 
!
version 12.1
service timestamps debug datetime msec
!
hostname kilcot
!
! 
bstun peer-name 100.1.1.1
bstun protocol-group 72 bsc-local-ack
!
! 
interface Loopback0
ip address 100.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 10.1.1.1 255.0.0.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Serial1/0
no ip address
ip directed-broadcast
encapsulation bstun
no ip mroute-cache
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc secondary
bstun route all tcp 200.2.2.2
!
!
router rip
network 10.0.0.0
network 100.0.0.0
!
end

Сторона
Building configuration...

version 12.1
! 
service timestamps debug datetime msec
!
hostname party
!
bstun peer-name 200.2.2.2
bstun protocol-group 72 bsc-local-ack
!
!
interface Loopback0
ip address 200.2.2.2 255.255.255.0
! 
interface Serial0
no ip address
encapsulation bstun
load-interval 30
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc primary
bstun route all tcp 100.1.1.1
!
interface Serial1
ip address 10.1.1.2 255.0.0.0
encapsulation frame-relay IETF
no ip mroute-cache
frame-relay interface-dlci 17
frame-relay lmi-type ansi
!
!
router rip
network 10.0.0.0
network 200.2.2.0
!
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show bstun

  • show bsc

kilcot#show bsc
BSC local-ack on Serial1/0:
secondary state is CU_Idle.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Initializing.
   Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
   Rx Counts: 3 frames(total). 0 frames(data). 15 bytes.
 
Total Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
Total Rx Counts: 19 frames(total). 0 frames(data). 59 bytes.

kilcot#show bstun
This peer: 100.1.1.1
 
*Serial1/0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       200.2.2.2                 open         1       3        0

party#show bsc
BSC local-ack on Serial0:
primary state is TCU_Polled.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Inactive.
   Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
   Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Total Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
Total Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
party#show bstun
This peer: 200.2.2.2
 
*Serial0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       100.1.1.1                 open          3       2        0

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Отладка bstun пакет/событие и отладка bsc выходные данные пакета/события были скопированы к файлу журнала. Когда вы интерпретируете эти выходные данные отладки:

  • Поступление данных, передаваемых последовательно (SDI) — Пакеты получены от интерфейса Протокола SDLC.

  • Поступление сетевых данных (NDI) — Пакеты, извлеченные из пакета от глобальной сети (WAN).

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

kilcot#show log
Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 5088 messages logged
    Trap logging: level informational, 70 message lines logged
          
Log Buffer (100000 bytes):

Dec 28 09:43:21.748: BSC: Serial1/0: POLLEE-FSM event:  E_LineUp old_state: CU_Down.  new_state: CU_Idle.
Dec 28 09:43:21.756: BSC: Serial1/0: SDI-rx: Data (5 bytes):   40407F7F2D
Dec 28 09:43:36.756: BSTUN bsc-local-ack: Serial1/0 SDI:   Data:   401100
Dec 28 09:43:36.756: BSTUN: Change state for peer  (all[72])200.2.2.2/1976 (closed->opening)
Dec 28 09:43:36.756: BSC: Serial1/0: POLLEE-FSM  event: E_RxEnq 
Dec 28 09:43:36.760: BSTUN: Change state for peer   (all[72])200.2.2.2/1976 (opening->open wait)
Dec 28 09:43:36.764: %BSTUN-6-OPENING: CONN:  opening peer (all[72])200.2.2.2/1976, 3
Dec 28 09:43:36.792: bsttcpd_connect:  Refreshing tcp_encaps for group 72
Dec 28 09:43:36.792: %BSTUN-6-OPENED: CONN:  peer (all[72])200.2.2.2/1976 opened, [previous state open wait]
Dec 28 09:43:36.792: BSTUN: Change state for  peer (all[72])200.2.2.2/1976 (open wait->open)
Dec 28 09:43:36.844: BSTUN bsc-local-ack:  Serial1/0 NDI: Data:   401400
Dec 28 09:43:36.848: BSC: Serial1/0: NDI-rx:  Data (3 bytes):  401400
Dec 28 09:43:37.640: %SYS-5-CONFIG_I:  Configured from console by vty0

party#show log
Syslog logging: enabled (0 messages 
   dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 114 messages logged
        Logging to: vty2(114)
    Buffer logging: level debugging, 5199 messages logged
    Trap logging: level informational, 79 message lines logged
          
Log Buffer (100000 bytes):

ec 28 09:48:09.816: %BSTUN-6-PASSIVEOPEN:   passive open 100.1.1.1(11017) -> 1976
Dec 28 09:48:09.836: %BSTUN-6-OPENED: PHDR:  peer (all[72])100.1.1.1/1976 opened, [previous state closed]
Dec 28 09:48:09.836: BSTUN: Change state for  peer (all[72])100.1.1.1/1976 (closed->open)
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 NDI: Data:   401100
Dec 28 09:48:09.836: BSC: Serial0: NDI-rx:  Data (3 bytes):  401100
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 SDI: Data:   401400
Dec 28 09:48:09.836: BSC: Serial0: SDI-tx:  Data (10 bytes):  37FF32323240407F7F2D

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12347