Интерфейсы и модули Cisco : Процессоры канального интерфейса Cisco

Выполнение OROUTED для обмена маршрутными обновлениями RIP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ дает пример конфигурации, требуемой на маршрутизаторе и на мейнфрейме к обновлениям маршрутизации по протоколу обмена RIP с помощью Процедуры OROUTED. OROUTED является процедурой, которая работает на мейнфрейме и которая выполняет по существу ту же функцию как тогда, когда вы выполняете разбитого демона на хосте UNIX. OROUTED выполняется или от Виртуального хранилища OpenEdition/Multiple (OMVS) адресное пространство или как запущенная задача.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

При разработке и тестировании этой конфигурации использовались следующие версии программного и аппаратного обеспечения:

  • Cisco Выпуск ПО IOS� 12.1 (2) с Адаптером порта Канала главной станции (XCPA) микрокод xcpa27-7.

    Это было последней версией освобожденного кода в то время, но эти функции должны поддерживаться во всех в настоящее время поддерживаемых основных версиях кода.

  • Маршрутизатор является Cisco 7206 с PCPA (Адаптер порта Параллельного канала).

OROUTED требует этих двух файлов конфигурации на мейнфрейме в Пространстве для адреса OMVS с переменными среды, которые указывают к их местоположению:

  • экспортируйте ROUTED_PROFILE =/etc/orouted.profile

  • экспортируйте RESOLVER_CONF =/etc/resolv.conf

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

Для начала OROUTED выполните эти команды из OMVS:

cd /usr/lpp/tcpip/sbin

orouted

На консоли MVS можно выполнить эту команду для обнаружения количества процесса Процесса OROUTED:

d omvs,u=p390

Примечание: p390 является идентификацией входа в систему, при которой был запущен OROUTED.

Можно также запустить Процесс OROUTED через язык управления заданиями (JCL) как запущенная задача. Если при запуске его с OMVS, изменяетесь, 520 портов в TCP/IP представляют набор данных к OMVS.

Это примеры наборов данных:

/etc/orouted.profile
RIP_SUPPLY_CONTROL: RIP1
RIP_RECEIVE_CONTROL: ANY
RIP2_AUTHENTICATION_KEY:
/etc/resolv.conf
TCPIPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

TCP/IP profile dataset configuration changes
--------------------------------------------

; ----------------------------------------------------------------------- ;

;
orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask      Dest Addr
BSDROUTINGPARMS false
LDIPTG         1500       0     255.255.255.240  10.64.3.33
VIPALINK       1500       0     255.255.255.240  0
ENDBSDROUTINGPARMS
; -----------------------------------------------------------------------
RIP

Конфигурация

Маршрутизатор процессора канального интерфейса (CIP)
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname diplodocus
!
boot system flash slot1:c7200-a3js-mz.121-2.bin
!
!
!
!
!
microcode pcpa slot1:xcpa27-9
microcode reload
!
interface Channel2/0
ip address 10.64.3.33 255.255.255.240
no keepalive
csna 0100 41
csna 0100 42
cmpc 0100 24 DIPTG READ
cmpc 0100 25 DIPTG WRITE
lan TokenRing 0
source-bridge 4 1 1
adapter 0 4000.0000.0001
adapter 1 4000.0000.0002
adapter 2 4000.0000.0003
adapter 3 4000.0000.0004
adapter 4 4000.0000.0005
lan TokenRing 1
source-bridge 5 1 1
adapter 7 4000.0000.0001
tn3270-server
pu PU1	    01712444 10.64.3.35      token-adapter 1  04 rmac
4000.0000.0001   lu-seed DIPL###
pu PU2	    01712555 10.64.3.36      token-adapter 1  08 rmac
4000.0000.0001   lu-seed DIPL2##
tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
!
!
router eigrp 1
redistribute rip
passive-interface Channel2/0
network 10.0.0.0
passive-interface Ethernet6/1
passive-interface Ethernet6/3
network 10.0.0.0
!
no auto-summary
!
router rip
redistribute eigrp 1
passive-interface Serial1/3
  
 passive-interface TokenRing5/0

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12258