Голосовая связь : Качество голосовой связи

VoIP через Frame Relay с QoS (фрагментация, формирование трафика, приоритет RTP IP/LLQ)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание

LLQ

Введение

В документе описан пример настройки сети с VoIP через Frame Relay с качеством обслуживания (QoS). В этот документ включены общие технические сведения о настроенных возможностях, Руководство по проектированию и описания основных стратегий проверки и устранения неполадок.

Важно отметить, что пример настройки в этом документе содержит 2 голосовых маршрутизатора, подсоединенных к сети Frame Relay. Тем не менее, во многих топологиях маршрутизаторы с поддержкой передачи голоса могут быть установлены в любой зоне сети. Обычно голосовые маршрутизаторы используют LAN-подключение к другим маршрутизаторам, подключенным к WAN. Это важно, потому что если голосовые маршрутизаторы не подключаются напрямую через Frame Relay, все команды конфигурации WAN должны быть настроены на маршрутизаторах, подключенных к WAN, а не на голосовых маршрутизаторах, как показано в примере ниже.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Маршрутизатор Cisco 3640 с Cisco выпуск ПО IOS� 12.2.6a (Enterprise Plus)

  • Маршрутизатор Cisco 2621 с Cisco IOS Software Release 12.2.6a (Enterprise Plus)

  • Организация очереди с низким временем ожидания (LLQ) в постоянных виртуальных каналах Frame Relay. Данная функция представлена в ПО Cisco IOS версии 12.1(2)T.

  • Приоритет Протокола RTP IP Frame Relay, который представлен в программном обеспечении Cisco IOS версии 12.0(7)T.

  • Frame Relay Forum (FRF).12 Фрагментаций, которые представлены в программном обеспечении Cisco IOS версии 12.0(4)T.

  • Версии ПО Cisco IOS выше 12.0.5T обладают улучшенными характеристиками для сжатого RTP (cRTP).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Руководство по проектированию QoS для передачи голосовых вызовов по протоколу IP по технологии Frame Relay

Существует два основных требования для хорошего качества голосовой связи:

Для удовлетворения упомянутых требований следуйте инструкциям:

Строгая очередность для голосового трафика (приоритеты LLQ или IP RTP)

Для голосового трафика существуют 2 способа предоставления жесткого приоритета:

  • Приоритет IP RTP (также называется очередь с приоритетом/ взвешенная управление очередями (PQ/WFQ))

  • LLQ (или PQ/очереди с весами на основе классов (PQ/CBWFQ))

Ip rtp priority

Frame Relay IP RTP Priority создает очередь строго по приоритету на Постоянной виртуальной сети Frame Relay PVC для ряда потоков пакета RTP, которые принадлежат диапазону протокола датаграмм пользователя (UDP) (UDP) порты назначения. В то время как фактические порты используют динамическое согласование между конечными устройствами и шлюзами, все продукты Cisco VoIP используют один и тот же диапазон UDP-портов (с 16384 до 32767). После распознания маршрутизатором трафика VoIP он будет помещен в строго приоритетную очередность. Когда PQ пустая, остальные очереди обрабатываются на основе стандартной программы WFQ. Механизм IP RTP Priority активизируется только при возникновении перегрузок в интерфейсе. На рисунке представлен механизм работы приоритета IP RTP:

/image/gif/paws/12156/pq-wfq.gif

Примечание: Когда существует доступная пропускная способность на очереди по умолчанию (WFQ), IP RTP приоритет позволяет разрывать PQ. Однако он жестко ограничивает содержание PQ, если интерфейс перегружен.

LLQ

LLQ – это метод, который обеспечивает строго приоритетную очередность (PQ) для CBWFQ. LLQ включает единую строгую PQ в рамках CBWFQ на уровне класса. При использовании LLQ отправка данных, для которых важно время задержки и которые находятся в приоритетной очереди (PQ), выполняется вне очереди. В VoIP с установленной LLQ голосовой трафик размещается в строгом соответствии с приоритетом очередности (PQ).

Алгоритм приоритетной очередности (PQ) реализован так, чтобы справедливые очереди не испытывали недостатка пропускной способности. При настройке PQ следует указать в Кбитах максимальную ширину канала, доступную PQ. Когда интерфейс перегружен, организация очередей с приоритетами (PQ) обслуживается до тех пор, пока нагрузка не достигает установленного значения скорости в Кбит/с в приоритете оператора. После этого лишний трафик отбрасывается, чтобы избежать проблем нехватки полосы пропускания для PQ с низкими приоритетами, характерных для традиционных очередей Cisco с приоритетами.

Примечание: C помощью LLQ для Frame Relay очереди настраиваются через PVC. Каждый постоянный виртуальный канал имеет очередь приоритетов и назначенное число обычных очередей.

/image/gif/paws/12156/llq.gif

Этот метод более комплексный и гибкий чем метод приоритета IP протокола реального времени (RTP). Выбор метода должен основываться на видах трафика в реальной сети и актуальных потребностях.

Сравнение приоритета IP RTP и LLQ

Эта таблица суммирует основные различия между LLQ и IP RTP приоритетом и предоставляет рекомендации того, когда использовать каждый метод.

LLQ Ip rtp priority
Сопоставление голосового трафика основано на:
  • Списки доступа. Например, поля UDP port range, hosts addresses, IP header Type of Service (ToS) (например, IP Precedence, Differentiated Services Code Point (DSCP).
  • Диапазон портов IP RTP.
  • Поля IP ToSDSCP и/или приоритет IP-пакета.
  • Протоколы и входные интерфейсы.
  • Все действительные критерии совпадения, используемые в CBWFQ.
Преимущества:
  • Больше гибкости в процессе сопоставления потока данных и направления его на определенные PQ и CBWFQ.
  • Можно настроить дополнительные классы для гарантированной пропускной способности для другого трафика, такого как сигналы VoIP и видео.
Недостатки: Комплексная конфигурация.
Сопоставление голосового трафика основано на:
  • Исходя из диапазона портов RTP/UDP: 16384-32767
Преимущества: Простая настройка Недостатки:
  • Трафик протокола RTCP (сигнализация VoIP), обслуживаемый в WFQ-очереди.

    Примечание: Протокол RTP использует RTCP для управления доставкой пакетов RTP. Порты RTP используют четные числа, порты RTCP - нечетные в диапазоне 16384-32767. Приоритет IP RTP помещает порты RTP в PQ, если порты RTCP обслуживаются в очереди WFQ по умолчанию.

  • Обслуживание трафика VoIP в PQ. Однако любой трафик, которому необходимо приоритетное обслуживание и гарантированная полоса пропускания, обслуживается в WFQ. WFQ позволяет различать потоки по весу (на основе приоритета IP-адреса), но не обеспечивает гарантированной полосы пропускания для любого потока.
Рекомендации:
  • Выбор между ними следует делать на основе моделей трафика в своей реальной сети и своих фактических потребностей.
  • Если необходимо установить строгий приоритет для голосового трафика, и другой трафик можно принять за однотипный (данные), то приоритет IP RTP окажется очень полезным для сети с простой конфигурацией.
  • Если планируется назначить приоритеты голосовому трафику на основе критериев, отличных от портов UDP. Например, поведение дифференцированных служб (DiffServ) на каждом переходе (PHB) и LLQ.

FRTS для голосового трафика

FRTS предоставляет параметры, которые полезны для управления перегрузкой сетевого трафика. FRTS позволяет решить проблему узких мест в сетях Frame Relay с высокоскоростным соединением с центральным узлом и низкоскоростными соединениями с удаленными офисами. Чтобы ограничить скорость передачи данных с виртуального канала (VC) на центральный узел, можно настроить значения контроля за скоростью.

Следующие определения относятся к FRTS:

  • Согласованная скорость передачи данных (CIR) скорость (бит в секунду), гарантируемая поставщиком услуг Frame Relay для передачи данных. Значения CIR устанавливаются поставщиком услуг Frame Relay и настраиваются пользователем на маршрутизаторе.

    Примечание: Порт/скорость доступа к интерфейсу может быть выше, чем CIR. Скорость усреднена по Согласованному интервалу измерения скорости (Tc) период времени.

  • Согласованный пакет (Bc) максимальное количество битов, которое сеть Frame Relay может передать за время Tc. Tc = Bc / CIR.

  • Избыточный пакет (Be) максимальное количество несогласованных битов, которое сеть Frame Relay пытается передать за время Tc со скоростью выше CIR.

  • Фиксированный интервал измерения согласованной скорости (Tc) интервал времени, за который передаются биты Bc или (Bc+ Be). Tc вычисляется следующим образом: Tc = Bc / CIR. Значение Tc не просто настраивается на маршрутизаторах Cisco. Оно рассчитывается после настройки значений Bc и CIR. Значение Tc не должно превышать 125 мс.

  • Пакет обратного явного уведомления о перегрузке (BECN) бит в заголовке Frame Relay, означающий перегрузку сети. Когда коммутатор Frame Relay обнаруживает перегрузку, он задает бит BECN на кадрах, направленных на исходный маршрутизатор, предписывая ему снизить скорость передачи.

Настройка FRTS для голосового трафика отличается от настройки трафика, предназначенного только для передачи данных. При настройке FRTS на характеристики голоса приходится изменять некоторые настройки трафика данных. Для получения дополнительной информации обратитесь к разделу Фрагментация (FRF.12) этого документа.

Фрагментация FRF.12

Серьезной проблемой при интеграции речи и данных является контроль максимальной однонаправленной задержки связи без переприема для такого зависимого от времени трафика, как голос. Для хорошего качества голоса задержка не должна быть больше 150 мсек. Большая часть этой задержки приходится на задержку сериализации интерфейса. Cisco рекомендует значение 10 мсек; в любом случае значение не должно превышать 20 мсек. Задержка сериализации - это фактическое время, затрачиваемое на помещение битов в интерфейс.

Serialization Delay = frame size (bits) / link bandwidth (bps)

Например, 1500-байтовому пакету требуется 214 мс, чтобы покинуть маршрутизатор через канал 56 кбит/с. Если посылаются пакеты данных размером 1500 байт в нереальном времени, то пакеты реального времени (голосовые) помещаются в очередь до тех пор, пока не закончится передача большого пакета данных. Такая задержка недопустима для голосового трафика. Если пакеты данных в нереальном времени фрагментируются на более мелкие кадры, то они перемежаются кадрами реального времени (голосовыми). Таким образом, и речевые, и информационные кадры могут передаваться вместе по низкоскоростным каналам, не вызывая чрезмерной задержки для голосового трафика в реальном времени.

/image/gif/paws/12156/lfi.gif

Дополнительные сведения о фрагментации см. в разделе "Фрагментация для передачи голосовых данных в Frame Relay".

Примечание: В случаях, где у вас есть выделенное половинное подключение t1 (768 кбит/с), вам, вероятно, не нужно средство фрагментации. Однако вам все равно необходим механизм QoS (в данном случае приоритет IP RTP или LLQ). Половина T1 или большие скорости дают достаточную пропускную способность, чтобы речевые пакеты могли входить и выходить из очереди в рекомендованном диапазоне задержки сериализации (10 мсек, не позднее чем 20 мсек). Кроме того, в случае полного соединения T1 можно обойтись без протокола сжатия в реальном времени (cRTP), который обеспечивает экономию полосы пропускания за счет сжатия заголовков IP RTP.

Сокращение полосы пропускания

cRTP

На основе RFC 2508 leavingcisco.comфункция cRTP сжимает заголовок пакета IP/UDP/RTP от 40 байтов до 2 или 4 байтов. Это позволяет уменьшить использование полосы пропускания. Эта схема сжатия действует на уровне переходов, поэтому протокол cRTP необходимо настроить на обоих концах канала (если не настроен параметр passive.

Примечание: для обеспечения хорошего качества голосовой связи cRTP не требуется. Эта функция позволяет уменьшить использование полосы пропускания. После выполнения всех требуемых условий и настройки хорошего качества голосовой связи настройте cRTP. Данная процедура может ускорить устранение неисправностей, изолировав потенциальные проблемы cRTP.

Проконтролируйте загрузку ЦП маршрутизатора. Отключите cRTP, если она выше 75%. При больших значениях скорости канала, выгоды от экономии пропускной способности cRTP могут быть сведены на нет из-за дополнительной нагрузки ЦП. Рекомендуется использовать cRTP только в каналах со скоростью ниже 768 Кбит/с, если только маршрутизатор не работает с низким коэффициентом загруженности ЦП.

Примечание: В отсутствие единого стандарта был разработан протокол cRTP для Frame Relay, совместимый с собственным механизмом инкапсуляции Cisco. Поэтому он не совместим с инкапсуляцией IETF (Инженерной группы по развитию Интернета) для Frame Relay. В последнее время FRF.20 был усовершенствован для возможности сжатия заголовков RTP на инкапсуляции IETF. Однако на момент последнего обновления этого документа (май 2000 года) FRF.20 не поддерживается.

Дополнительные сведения см. в разделе "Сжатый транспортный протокол реального времени".

Кодер/Декодер (Кодек) Выбор

Используйте низкоскоростные кодеки в ветке вызова VoIP. По умолчанию для каждой точки вызова VoIP установлен кодек G.729 (8 Kбит/сек).

Примечание: Когда высокоскоростные голосовые кодеки используются (такие как G.711), низкоскоростные кодеки (такие как G.729 и G.723.1), высоко оптимизированы для шаблонов голосового сигнала и имеют тенденцию искажать Тоны DTMF, несмотря на то, что двухтональный многочастотный набор (DTMF) обычно транспортируется точно. Этот подход может вызвать проблемы доступа к системам интерактивного голосового ответа (IVR). Команда dtmf relay решает проблему искажения DTMF. Она передает тональные сигналы DTMF вне полосы или отдельно от кодированного голосового потока. При использовании низкоскоростных кодеков (G.729, G.723) включите команду dtmf relay для адресуемой конечной точки вызова VoIP.

Включение функции определения активности речи (VAD)

Обычный разговор мог бы потенциально содержать 35 - 50 процентов тишины. Пакеты молчания сжимаются при использовании VAD. При планировании пропускной способности VoIP предполагается, что функция VAD уменьшает полосу пропускания на 35 %. Опознавание активности речи (VAD) сконфигурировано по умолчанию в VoIP для равноправного коммутируемого элемента.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

LLQ

Используйте эту процедуру для настройки LLQ:

  1. Создайте карту классов для трафика VoIP и определите критерии совпадения.

    Эти команды объясняют, как выполнить задание:

    maui-voip-sj(config)#class-map ?
           WORD 		class-map name
           match-all 	Logical-AND all matching statements under this classmap
           match-any 	Logical-OR all matching statements under this classmap
    maui-voip-sj(config)#class-map match-all voice-traffic 
    
    !--- Choose a descriptive class_name. 
    
    
    maui-voip-sj(config-cmap)#match ?
      access-group         Access group
      any                  Any packets
      class-map            Class map
      cos                  IEEE 802.1Q/ISL class of service/user priority values
      destination-address  Destination address
      input-interface      Select an input interface to match
      ip                   IP specific values
      mpls                 Multi Protocol Label Switching specific values
      not                  Negate this match result
      protocol             Protocol
      qos-group            Qos-group
      source-address       Source address
    
    !--- In this example  the access-group matching 
    !--- option is used for its flexibility (it uses an access-list).
    
    
    maui-voip-sj(config-cmap)#match access-group ?
      <1-2699>  Access list index
      name      Named Access List
    maui-voip-sj(config-cmap)#match access-group 102 
    
    
    !--- Create the access-list to match the class-map access-group:
    
    
    maui-voip-sj(config)#access-list 102 permit udp any any range 16384 32767
    
    !--- The safest and easiest way is to match with UDP port range 16384-32767.
    !--- This is the port range Cisco IOS H.323 products utilize to transmit 
    !--- VoIP packets.
    
    

    Эти списки доступа также используются для поиска соответствий голосового трафика с помощью команды match access-group:

    access-list 102 permit udp any any precedence critical
    
    !--- This list filters traffic based on the IP packet TOS: Precedence field.  
    !--- Note: Ensure that the other non-voice traffic does not use the 
    !--- same precedence value.
    
    
    access-list 102 permit udp any any dscp ef
    
    !--- In order for this list to work, ensure that VoIP packets are tagged 
    !--- with the dscp ef code before they exit on the LLQ WAN interface. 
    !--- For more information on DSCP, refer to 
    !--- Implementing Quality of Service Policies with DSCP.
    !--- Note: If endpoints are not trusted on their packet marking, 
    !--- mark incoming traffic by applying an inbound service policy on an 
    !--- inbound interface. This procedure is out of the scope 
    !--- of this document. 
    
    
    access-list 102 permit udp host 192.10.1.1 host 192.20.1.1
    
    !--- This access-list can be used in cases where the VoIP 
    !--- devices cannot do precedence or DSCP marking and you 
    !--- cannot determine the  VoIP UDP port range.
     

    Существуют другие методы поиска соответствий, которые можно использовать вместо команд групп доступа:

    • Начиная с Cisco IOS выпуска 12.1.2.T, функция IP RTP Priority внедрена для LLQ. Эта функция сопоставляет содержимое класса приоритета, которое настроено на порты UDP. Обслуживание только четных портов в PQ ограничено.

      class-map voice
        match ip rtp 16384 16383
      
    • Предполагается, что эти два метода приемлемы, если пакеты VoIP маркированы на исходном хосте или сопоставлены и маркированы в маршрутизаторе до выполнения исходящей операции LLQ:

      class-map voice 
         match ip precedence 5
      

      Или

      class-map voice
         match ip dscp ef
      

      Примечание: В Cisco IOS Software Release 12.2.2T и позже, узлы коммутации VoIP могут отметить речевой информационный канал и пакеты сигнализации до операции LLQ. Это позволяет сделать масштабируемыми маркирование и установку соответствий VoIP-пакетов с помощью значений кодов DSCP для LLQ. За более подробной информацией обратитесь к Классификации передачи сигналов и средств связи протокола VoIP с DSCP для QoS.

      Router(config-dial-peer)#ip qos dscp ?
      
  2. Создайте схему класса для передачи сигналов VoIP и определите критерии соответствия (необязательно).

    Используйте следующие команды для выполнения этого задания:

    class-map voice-signaling
      match access-group 103
    !
    access-list 103 permit tcp any eq 1720 any
    access-list 103 permit tcp any any eq 1720
    

    Примечание: Вызовы VoIP можно устанавливать с помощью H.323, протокола инициализации сеанса (SIP), протокола управления шлюзами между средами передачи (MGCP) или облегченного протокола контроля вызовов (SCCP) (это собственный протокол, используемый в Cisco Call Manager). Приведенный выше пример предполагает наличие H.323 Fast Connect. Этот список содержит справочную информацию о портах, используемых каналами сигнализации и управления VoIP:

    • H.323/H.225 = TCP 1720

    • H.323/H.245 = TCP 11xxx (стандартное соединение)

    • H.323/H.245 = TCP 1720 (быстрое соединение)

    • H.323/H.225 RAS = UDP 1718 (К GateKeeper)

    • SCCP = TCP 2000-2002 (вызов на бис CM)

    • ICCP = TCP 8001-8002 (кабельный модем Encore)

    • MGCP = UDP 2427, TCP 2428 (CM Encore)

    • SIP= UDP 5060, TCP 5060 (настраиваемый)

  3. Создайте карту политики и свяжите ее со схемами классов VoIP.

    Цель схемы политик - определить, как ресурсы линии распределяются или приписываются различным классам сопоставления. Используйте следующие команды для выполнения этого задания:

    maui-voip-sj(config)#policy-map VOICE-POLICY
    
    !--- Choose a descriptive policy_map_name.
    
    
    maui-voip-sj(config-pmap)#class voice-traffic
    maui-voip-sj(config-pmap-c)#priority ?
     <8-2000000>  Kilo Bits per second
    
    !--- Configure the voice-traffic class to the strict PQ
    !--- (priority command) and assign the bandwidth.
    
    
    maui-voip-sj(config-pmap)#class voice-signaling
    maui-voip-sj(config-pmap-c)#bandwidth 8
    
    !--- Assign 8 Kbps to the voice-signaling class.
    
    
    maui-voip-sj(config-pmap)#class class-default
    maui-voip-sj(config-pmap-c)#fair-queue 
    
    !--- The remaining data traffic is treated as WFQ.
    
    

    Примечание: Несмотря на то, что возможно ставить в очередь различные типы трафика в реальном времени к PQ, Cisco рекомендует направить только голосовой трафик к нему. Трафик в реальном времени, такой как видеоматериалы, может привести к вариации задержки (PQ относится к очередям FIFO). Голосовой трафик требует, чтобы задержки не были переменными, чтобы избежать "дрожания".

    Примечание: Сумма значений для приоритета и инструкций для пропускной способности должна быть меньше чем или равна minCIR для PVC. Иначе команда service-policy не может быть присвоена линии. minCIR в два раза меньше CIR по умолчанию. Чтобы получить сообщения об ошибке, убедитесь в активности команды logging console для консольного доступа и команды terminal monitor для доступа через Telnet.

    Для получения более подробной информации по пропускной способности и приоритетных командах перейдите к сравнению пропускной способности и приоритетных команд политики качества обслуживания (QoS) и класса предоставляемых услуг передачи данных.

  4. Включите LLQ, применив карту политики к исходящему интерфейсу WAN.

    Чтобы включить LLQ, используйте следующие команды:

    maui-voip-sj(config)#map-class frame-relay VoIPovFR
    maui-voip-sj(config-if)#service-policy output VOICE-POLICY
    
    !--- The service-policy is applied to the PVC 
    !--- indirectly by configuring 
    !--- it under the map-class associated to the PVC.
    
    

Ip rtp priority

Если вы не используете LLQ, используйте эти рекомендации:

Router(config-map-class)#frame-relay ip rtp priority starting-rtp-port  
port-range  bandwidth 
  • команда starting-rtp-port—отображает начальный номер узла UDP. Самый низкий номер порта, на который отправляются пакеты. Для VoIP задайте номер 16384.

  • port-range - диапазон портов с назначением UDP. Номер, добавляемый к starting-rtp-port, дает самый высокий номер узла UDP. Для VoIP укажите значение 16383.

  • bandwidth — Максимально допустимое ширина полосы пропускания в кбит/с для очереди с приоритетами. Установите этот номер на основе количества спонтанных звонков, добавляя для каждого звонка ширину полосы пропускания каждого звонка, поддерживаемую системой.

Пример конфигурации:

map-class frame-relay VoIPovFR  frame-relay cir 64000
 frame-relay BC 600
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80
 frame-relay ip rtp priority 16384 16383 45

Формирование трафика для голосовой связи

Используйте эти рекомендации при настройке формирования трафика для голоса:

  • Не следует превышать CIR для PVC.

  • Отключите адаптивное управление Frame Relay.

  • Установите низкое значение Bc, так чтобы Tc (интервал формирования) был равен 10 мсек (Tc = Bc/CIR). Чтобы получить ожидаемое значение Tc, настройте значение Bc.

  • Укажите для Be значение 0.

Для получения дополнительной информации обратитесь к разделу Формирование трафика Frame Relay для VoIP и VoFR.

Примечание: Некоторые пользователи используют раздельные ПВК для данных и голоса. Если, имея два PVC, вы хотите использовать PVC для пакета данных, оставаясь на уровне CIR или ниже, для голосового PVC, качество голоса будет так же неудовлетворительным, т.к. каналы PVC используют один и тот же физический интерфейс. В таких случаях поставщик услуг Frame Relay и маршрутизатора, должны обеспечить первостепенный приоритет голосового PVC. Последнее можно реализовать с помощью Очередей приоритетов на уровне интерфейса PVC (PIPQ), доступных на базе Cisco IOS выпуск 12.1(1)T.

Фрагментация FRF.12

Для низкоскоростных каналов (менее 768 кбит/с) включите фрагментацию. Установите размер фрагмента таким образом, чтобы голосовые пакеты не подлежали фрагментации; задержка сериализации при этом не должна превышать 20 мсек. Установите размер фрагмента на основе самой низкой скорости портов всех маршрутизаторов. Например, если в топологии звездообразной сети Frame Relay концентратор работает на скорости Т1, а удаленные маршрутизаторы имеют порты 64 Кб, то размер фрагмента на обоих маршрутизаторах должен устанавливаться как для 64 Кб портов. Другие PVC, имеющие тот же самый физический интерфейс, необходимо настроить на размер фрагмента, установленный для голосового PVC. Используйте приведенную таблицу для определения размера фрагмента.

Наименьшая скорость связи на пути Рекомендованный размер фрагментации (для 10 мс сериализации)
56 Кбит/с 70 байт
64 кбайт/сек 80 байт
128 Кбит/с 160 байт
256 Кбит/с 320 байт
512 Кбит/с 640 байт
768 кбит/с 1000 байт
1536 кбит/сек 1600 байт

Пример конфигурации:

map-class frame-relay VoIPovFR 

!--- Some output is omitted.

 frame-relay fragment 80

Примечание: Для 1536 кбит/с не технически необходима никакая фрагментация. Однако фрагментация необходима при включении системы двойной очереди FIFO для получения высокого качества голоса. Размер фрагмента 1600 байт позволяет организовать двойную FIFO. Однако, т.к. значение 1600 байт выше стандартного максимального размера передаваемого блока данных (MTU), большие пакеты данных не подлежат фрагментации.

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме:

/image/gif/paws/12156/VoIP_FR.gif

Конфигурации

В данном документе используется следующая конфигурация:

  • maui-voip-sj (Cisco 3640)

  • maui-voip-austin (Cisco 3640)

maui-voip-sj (Cisco 3640)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname maui-voip-sj
!
logging buffered 10000 debugging
enable secret 5 $1$MYS3$TZ6bwrhWB25b2cVpEVgBo1
!
ip subnet-zero
!

!--- Definition of the voice signaling and traffic class maps.
!--- "voice-traffic" class uses access-list 102 for its matching criteria.
!--- "voice-signaling" class uses access-list 103 for its matching criteria.

class-map match-all voice-signaling
 match access-group 103
class-map match-all voice-traffic
  match access-group 102
!

!--- The policy map defines how the link resources are assigned
!--- to the different map classes. In this configuration, strict PQ
!--- is assigned to the voice-traffic class 
!--- with a maximum bandwidth of 45 Kbps.
 

policy-map VOICE-POLICY
  class voice-traffic
  priority 45
  class voice-signaling
  bandwidth 8


!--- Assigns a queue for voice-signaling traffic that ensures 8 Kbps.
!--- Note that this is optional and has nothing to do with good voice
!--- quality. Instead, it is a way to secure signaling.


  class class-default
  fair-queue


!--- The class-default class is used to classify traffic that does
!--- not fall into one of the defined classes.
!--- The fair-queue command associates the default class WFQ queueing.

!
interface Ethernet0/0
  ip address 172.22.113.3 255.255.255.0
  half-duplex
!
interface Serial0/0
 bandwidth 128
 no ip address
 encapsulation frame-relay
 no fair-queue
frame-relay traffic-shaping
 frame-relay ip rtp header-compression

!--- Turns on traffic shaping and cRTP. If traffic-shaping is not
!--- enabled, then map-class does not start and FRF.12 and LLQ  does
!--- not work.

!
interface Serial0/0.1 point-to-point
 bandwidth 128
 ip address 192.168.10.2 255.255.255.252
 frame-relay interface-dlci 300
  class VOIPovFR

!--- This command links the subinterface to a VoIPovFR map-class.
!--- See the map-class frame-relay VoIPovFR command  here:
!--- Note: The word VoIPovFR is selected by the user.
!

ip classless
ip route 172.22.112.0 255.255.255.0 192.168.10.1
!
map-class frame-relay VOIPovFR
 no frame-relay adaptive-shaping

!--- Disable Frame Relay BECNS. Note also that Be equals 0 by default.

frame-relay cir 64000
 frame-relay bc 640

!--- Tc = BC/CIR. In this case Tc is forced to its minimal
!--- configurable value of 10 ms.

frame-relay be 0
 frame-relay mincir 64000

!--- Although  adaptive shaping is disabled, make CIR equal minCIR
!--- as a double safety. By default minCIR  is half of CIR.

service-policy output VOICE-POLICY

!--- Enables LLQ on the PVC.

frame-relay fragment 80

!--- Turns on FRF.12 fragmentation and sets the fragment size equal to 80 bytes.
!--- This value is based on the port speed of the slowest path link.
!--- This command also enables dual-FIFO.

!
access-list 102 permit udp any any range 16384  32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!

!--- access-list 102 matches VoIP traffic 
!--- based on the UDP port range.
!--- Both odd and even ports are put into the PQ.
!--- access-list 103 matches VoIP signaling protocol. In this
!--- case, H.323 V2 is uesd with the fast start feature.

!
voice-port 1/0/0
!
dial-peer voice 1 pots
 destination-pattern 5000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 6000
 session target ipv4:192.168.10.1
 dtmf-relay cisco-rtp
 ip precedence 5

maui-voip-austin (Cisco 3640)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname maui-voip-austin
!
boot system flash slot1:c3640-is-mz.122-6a.bin
logging buffered 1000000 debugging
!
ip subnet-zero
!
class-map match-all voice-signaling
match access-group 103
class-map match-all voice-traffic
  match access-group 102
!
policy-map voice-policy
  class voice-signaling
   bandwidth 8
  class voice-traffic
    priority 45
  class class-default
   fair-queue
!
interface Ethernet0/0
 ip address 172.22.112.3 255.255.255.0
 no keepalive
 half-duplex
!
interface Serial0/0
 bandwidth 64
 no ip address
 encapsulation frame-relay
 no ip mroute-cache 
 no fair-queue
 frame-relay traffic-shaping
 frame-relay ip rtp header-compression
!
interface Serial0/0.1 point-to-point
 bandwidth 64
 ip address 192.168.10.1 255.255.255.252
 frame-relay interface-dlci 400
  class VOIPovFR
!
ip classless
ip route 172.22.113.0 255.255.255.0 192.168.10.2
!
map-class frame-relay VOIPovFR
no frame-relay adaptive-shaping
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 service-policy output voice-policy
 frame-relay fragment 80
access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
voice-port 1/0/0
!
dial-peer voice 1 pots
 destination-pattern 6000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 5000
 session target ipv4:192.168.10.2
 dtmf-relay cisco-rtp
 ip precedence 5

Проверка и устранение неполадок

В этом разделе дается информация для проверки правильности функционирования вашей конфигурации.

Некоторые команды show поддерживаются интерпретатором выходных данных (только для зарегистрированных пользователей). Это позволяет просмотреть анализ выходных данных команды show.

Команды LLQ / IP RTP Priority

Они показывают, и команды отладки помогают вам проверять свой LLQ и конфигурации IP RTP приоритета.

Команды фрагментации

Используйте эти команды debug и show, чтобы проверить и устранить неполадки Настроек фрагментации.

  • show frame-relay fragment о Фрагментации Frame Relay, которая имеет место в маршрутизаторе Cisco.

  • debug frame-relay fragment — событие Displays или сообщения об ошибках отнеслись к Фрагментации Frame Relay. Функционирует только на уровне PVC выбранного интерфейса.

Команды Frame Relay/интерфейса

Используйте эти команды показа, чтобы проверить и устранить неполадки Frame Relay / Конфигурации интерфейса.

  • интерфейс show traffic-shape queue — Отображает информацию об элементах, помещенных в очередь на уровне идентификатора подключения соединения данных (DLCI) (DLCI) VC. Используется для проверки механизма работы приоритета IP RTP через Frame Relay. При перегрузке линии связи речевые потоки идентифицируются с весом 0. Это означает, что речевой поток использует PQ. См. пример выходных данных.

  • show traffic-shape отображает такую информацию, как заданные значения Tc, Bc, Be и CIR. См. пример выходных данных.

  • команда show frame-relay pvc dlci отображает сведения о параметрах формирования трафика, значениях фрагментации и отброшенных пакетах. См. пример выходных данных. Также см. раздел "Устранение неполадок Frame Relay".

Типичные ошибки

Ошибка была определена при помощи LLQ для каждого VC, где PQ была строго ограничена, даже когда на интерфейсе не происходило перегрузок. Ошибка была устранена, и несоответствующие голосовые пакеты сбрасываются только в случае перегрузки VC. LLQ на основе VC при этом становятся похожими на другие интерфейсы, использующие LLQ. Изменения были внесены для ПО Cisco IOS выпуска 12.2(3) и выше.

Пример выводов команд show и debug

Это - типовой показ и результаты выполнения команды debug, используемые для проверки и устранения проблем.


!--- To capture sections of this output, the LLQ PQ bandwidth
!--- is lowered and large data traffic  is placed
!--- on the link to force packets drops. 
      
!--- Priority queue bandwidth  is lowered to 10 Kbps to force drops from the PQ.
!--- Note: To reset counters, use the clear counters command. 


maui-voip-sj#show policy-map inter ser 0/0.1
  Serial0/0.1: DLCI 300 -

  Service-policy output: VOICE-POLICY

Class-map: voice-traffic (match-all)
         26831 packets, 1737712 bytes
         5 minute offered rate 3000 bps, drop rate 2000 bps
         Match: access-group 102
         Weighted Fair Queueing
         Strict Priority
         Output Queue: Conversation 24
         Bandwidth 10 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 26311/1704020
         (total drops/bytes drops) 439/28964

   Class-map: voice-signaling (match-all)
         80 packets, 6239 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 62/4897
         (depth/total drops/no-buffer drops) 0/0/0
    
   Class-map: class-default (match-any)
         14633 packets, 6174492 bytes
         5 minute offered rate 10000 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 0/0/0

      

!--- These  commands are useful to verify the LLQ configuration.
 
      
maui-voip-austin#show policy-map voice-policy
  Policy Map voice-policy
   Class voice-signaling
        Weighted Fair Queueing
           Bandwidth 8 (kbps) Max Threshold 64 (packets)
   Class voice-traffic
        Weighted Fair Queueing
         Strict Priority
             Bandwidth 45 (kbps) Burst 1125 (Bytes)
   Class class-default
        Weighted Fair Queueing
           Flow based Fair Queueing Max Threshold 64 (packets)

maui-voip-austin#show class-map
 Class Map match-all voice-signaling (id 2)
         Match access-group  103
 Class Map match-any class-default (id 0)
         Match any
 Class Map match-all voice-traffic (id 3)
         Match access-group 102


!--- Frame Relay verification command output.


maui-voip-sj#show frame-relay fragment
interface         dlci  frag-type    frag-size  in-frag    out-frag   dropped-frag
Serial0/0.1       300   end-to-end      80         4          4          0

maui-voip-sj#show frame-relay pvc 300

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 300, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 7 output pkts 7 in bytes 926
         out bytes 918 dropped pkts 0 in FECN pkts 0
         in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
         in DE pkts 0 out DE pkts 0
         out bcast pkts 2 out bcast bytes 598
         pvc create time 1w2d, last time pvc status changed 1w2d
      service policy VOICE-POLICY

 Service-policy output: VOICE-POLICY

 Class-map: voice-traffic (match-all)
         0 packets, 0 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 102
         Weighted Fair Queueing
      Strict Priority
         Output Queue: Conversation 24
         Bandwidth 45 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 0/0
         (total drops/bytes drops) 0/0

 Class-map: voice-signaling (match-all)
         0 packets, 0 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 0/0
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: class-default (match-any)
         7 packets, 918 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 0/0/0


 Output queue size 0/max total 600/drops 0
 fragment type end-to-end fragment size 80
 cir 64000 bc 640 be 0 limit 80 interval 10
 mincir 64000 byte increment 80 BECN response no
 frags 13 bytes 962 frags delayed 8 bytes delayed 642
 
 shaping inactive
 traffic shaping drops 0


!--- In this Frame Relay verification command 
!--- output, the PQ bandwidth is lowered and heavy traffic 
!--- is placed on the interface to force drops.


maui-voip-sj#show frame-relay pvc 300

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 300, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 483 output pkts 445 in bytes 122731
         out bytes 136833 dropped pkts 0 in FECN pkts 0
         in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
         in DE pkts 0 out DE pkts 0
         out bcast pkts 4 out bcast bytes 1196
         pvc create time 1w2d, last time pvc status changed 1w2d
         service policy VOICE-POLICY

 Service-policy output: VOICE-POLICY

 Class-map: voice-traffic (match-all)
         352 packets, 22900 bytes
         5 minute offered rate 2000 bps, drop rate 2000 bps
         Match: access-group 102
         Weighted Fair Queueing
         Strict Priority
         Output Queue: Conversation 24
         Bandwidth 10 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 352/22900
         (total drops/bytes drops) 169/11188

 Class-map: voice-signaling (match-all)
         7 packets, 789 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 7/789
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: class-default (match-any)
         79 packets, 102996 bytes
         5 minute offered rate 4000 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 5/0/0
         Output queue size 5/max total 600/drops 169
         fragment type end-to-end fragment size 80
         cir 64000 bc 640 be 0 limit 80 interval 10
         mincir 64000 byte increment 80 BECN response no
         frags 2158 bytes 178145 frags delayed 1968 bytes delayed 166021

 shaping active
         traffic shaping drops 169


!--- Notice that the Tc interval equals 10 ms, 
!--- CIR equals 64000 BPS, and BC equals 640. 

     
maui-voip-sj#show traffic-shape
Interface  Se0/0.1
       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
300           64000     80     640       0          10        80         -



!--- This output is captured on an isolated lab enviroment where
!--- the routers are configured with IP RTP Priority instead of LLQ.
 

maui-voip-austin#show frame-relay PVC 100

PVC Statistics for interface Serial0/1 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1.1

  input pkts 336           output pkts 474          in bytes 61713
  out bytes 78960          dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0         
  PVC create time 1w0d, last time PVC status changed 1w0d
 Current fair queue configuration:   
   Discard      Dynamic       Reserved
   threshold    queue count   queue count
   64            16              2
 Output queue size 0/max total 600/drops 0 
  fragment type end-to-end        fragment size 80
  cir 64000     BC   640      be 0     limit 125    interval 10
  mincir 32000    byte increment 125   BECN response no
  frags 1091      bytes 82880     frags delayed 671      bytes delayed 56000
  shaping inactive
  traffic shaping drops 0
  ip rtp priority parameters 16384 32767 45000


!--- This command displays information of the VoIP dial-peers.
 
      
maui-voip-austin#show dial-peer voice 2
VoiceOverIpPeer2
        information type = voice,
        tag = 2, destination-pattern = `5000',
        answer-address = `', preference=0,
        group = 2, Admin state is up, Operation state is up,
        incoming called-number = `', connections/maximum = 0/unlimited,
        application associated: 
     type = voip, session-target = `ipv4:192.168.10.2',  
        technology prefix:
     ip precedence = 5, UDP checksum = disabled,
         session-protocol = cisco, req-qos = best-effort, 
         acc-qos = best-effort, 
     dtmf-relay = cisco-rtp, 
        fax-rate = voice,   payload size =  20 bytes
     codec = g729r8,    payload size =  20 bytes,
        Expect factor = 10, Icpif = 30,signaling-type = cas,
     VAD = enabled, Poor QOV Trap = disabled, 
        Connect Time = 165830, Charged Units = 0,
        Successful Calls = 30, Failed Calls = 0,
        Accepted Calls = 30, Refused Calls = 0,
        Last Disconnect Cause is "10",
        Last Disconnect Text is "normal call clearing.",
        Last Setup Time = 69134010.

Дополнительные сведения


Document ID: 12156