Коммутация LAN : EtherChannel

Пример конфигурации EtherChannel между коммутаторами Catalyst 3550/3560/3750 Series и коммутаторами Catalyst Switches под управлением системного программного обеспечения Cisco IOS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (7 апреля 2008) | Английский (7 октября 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для того, как установить EtherChannel между Catalyst 3550 и Catalyst 6500/6000 рабочая Cisco Системное программное обеспечение IOS�. EtherChannel может называться Fast EtherChannel или Gigabit EtherChannel в зависимости от скорости интерфейсов или портов, используемых для формирования EtherChannel.

Примечание: Команды EtherChannel, применяемые в данном документе к коммутатору Catalyst 3550, могут также применяться и к коммутаторам серии Catalyst 3750.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Коммутатор Catalyst серии 3550 с Cisco IOS Software Release 12.1(14)EA

  • Коммутатор Catalyst 6500/6000, выполняющий программное обеспечение Cisco IOS, выпуск 12.1(13)E1

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Теоретические сведения

В этом документе описывается пример, когда два интерфейса Gigabit Ethernet на коммутаторе Catalyst 3550 (интерфейс GigabitEthernet на коммутаторе 3500 представляет собой согласованный интерфейс Ethernet 10/100/1000) связаны в канал Fast EtherChannel с двумя интерфейсами Fast Ethernet коммутатора Catalyst 6500/6000 под управлением системного ПО Cisco IOS для формирования EtherChannel уровня 2 (L2).

Примечание: Упоминаемые в документе каналы Fast EtherChannel, Gigabit EtherChannel, канал порта и группа каналов относятся к EtherChannel.

Конфигурация коммутатора Catalyst в данном документе применима к любому коммутатору серии Catalyst 6500/6000 или Catalyst 4500/4000 с системным ПО Cisco IOS.

В этом документе показаны файлы конфигурации только для коммутаторов, так же как и примеры выходных данных соответствующих команд show. Более подробные сведения о настройке EtherChannel см. в следующих документах:

  • Раздел Настройка каналов EtherChannel уровня 2 документа Настройка EtherChannel (коммутатор Catalyst 3550)

  • Раздел Настройка каналов EtherChannel уровня 3 документа Настройка EtherChannel (коммутатор Catalyst 3560)

  • Раздел Настройка каналов EtherChannel уровня 2 документа Настройка EtherChannel (коммутатор Catalyst 3750)

  • Настройка каналов EtherChannel уровня 2 и 3 (Catalyst 6500/6000 с системным ПО Cisco IOS)

  • Раздел Настройка каналов EtherChannel уровня 2 документа Основные сведения и настройка EtherChannel (Catalyst 4500/4000 с системным ПО Cisco IOS)

Важные примечания

Канал EtherChannel можно настроить вручную с помощью соответствующих команд. EtherChannel также можно настроить автоматически при помощи протокола PAgP, чтобы коммутатор согласовывал канал с другой стороной. Дополнительные сведения о протоколе PAgP см. в следующих документах:

  • Раздел Общие сведения о протоколе PAgP документа Настройка EtherChannel (коммутатор Catalyst 3550)

  • Раздел Общие сведения о протоколе PAgP документа Настройка EtherChannel (коммутатор Catalyst 3560)

  • Раздел Протокол PAgP документа Настройка EtherChannel (коммутатор Catalyst 3750)

  • Раздел Общие сведения о протоколе PAgP документа Настройка EtherChannel (Catalyst 6500/6000 с системным ПО Cisco IOS)

  • Раздел Общие сведения о протоколе PAgP документа Основные сведения и настройка EtherChannel (Catalyst 4500/4000 с системным ПО Cisco IOS)

В данном документе конфигурации реализуются с использованием выбираемого режима. Если планируется настраивать EtherChannel вручную, то создайте канал порта, выполнив описанные действия. Это позволяет избежать проблем с протоколом STP в процессе настройки. Протокол STP может блокировать некоторые порты в состоянии "отключенный из-за ошибки" (err-disable), если одна сторона настроена как канал до того, как аналогичным образом может быть настроена другая сторона.

Выполните следующие действия, чтобы создать канал порта:

  1. Оставьте интерфейсы, которые должны использоваться при объединении портов в канал, в состоянии административного выключения.

  2. Создайте канал порта (группу каналов) на коммутаторе Catalyst 6500/6000.

    Убедитесь, что для режима канала задано значение on, например channel-group 1 mode on.

  3. Создайте каналы порта на коммутаторе Catalyst 3550, 3560 или 3570.

    Убедитесь, что для режима канала задано значение on.

  4. Снова включите интерфейсы, которые были отключены ранее, на коммутаторе Catalyst 6500/6000 с помощью команды no shut.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме:

/image/gif/paws/12033/89-a.gif

Примечание: Интерфейс Gigabit Ethernet на Catalyst 3550 является согласованным интерфейсом Ethernet на 10/100/1000 Мбит/с. Порт Gigabit коммутатора Catalyst 3550 можно также подключить к порту FastEthernet (100 Мбит/с) коммутатора Catalyst 6500/6000.

Примечание: Коммутаторы серии Catalyst 3750 поддерживают межстековый канал EtherChannel, позволяющий объединять разные стековые коммутаторы в одну группу EtherChannel. Для получения дополнительной информации on�EtherChannel в a�stacked среде коммутаторов, обратитесь к EtherChannel и разделу Стеков коммутаторов Настройки документацию EtherChannels для коммутаторов серии Catalyst 3750.

Конфигурации

Эти конфигурации используются в данном документе:

Catalyst 3550
Building configuration...
Current configuration : 1610 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
enable password ww
!
ip subnet-zero
no ip finger
!
!
!
!
!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

interface Port-channel 1


!--- In this example, the L2 EtherChannel is configured.
!--- A Layer 3 (L3) EtherChannel can also be configured on the Catalyst 3550 switches.
!--- For more information, refer to the document Configuring EtherChannel.

switchport mode access no ip address snmp trap link-status!

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a 
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

!--- The port is a member of channel group 1.

interface GigabitEthernet0/1
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!


!--- The port is a member of channel group 1.

interface GigabitEthernet0/2
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!
interface GigabitEthernet0/3
 switchport mode access
 no ip address
 snmp trap link-status
!


!--- Output suppressed.

interface GigabitEthernet0/12
 switchport mode access
 no ip address
 snmp trap link-status


!--- Interface VLAN1 is required for management purposes.

interface Vlan1
 ip address 10.1.1.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
 transport input none
line vty 5 15
!
end

Для Catalyst 6500/6000
Building configuration...
  
 Current configuration : 5869 bytes
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname cat6500
 !
 boot buffersize 126968
 boot bootldr bootflash:c6msfc-boot-mz.121-4.E1
 enable password ww
 !
 redundancy
  main-cpu
   auto-sync standard
 ip subnet-zero
 !
 !
 no ip finger
 !
 !
 !
 !


!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

 interface Port-channel 1
  no ip address
  switchport
  switchport mode access
 !
 interface GigabitEthernet1/1
  no ip address
  shutdown
 !
 interface GigabitEthernet1/2
  no ip address
  shutdown
 !

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

 interface FastEthernet3/1
  no ip address


!--- In this example, the L2 EtherChannel is configured.
!--- An L3 EtherChannel can also be configured on the Catalyst 6500/6000 running
!--- Cisco IOS System Software. For more details, refer to the document
!--- Configuring EtherChannel.

!--- On a Catalyst 6500/6000, you must issue the switchport
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;
!--- no additional command is required.

 switchport

!--- This command puts the interface in VLAN1, by default.

 switchport mode access

!--- The port is a member of channel group 1.

 channel-group 1 mode desirable
 !
 interface FastEthernet3/2
  no ip address

!--- On a Catalyst 6500/6000, you must issue the switchport 
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;  
!--- no additional command is required.

  switchport

!--- This command puts the interface in VLAN1, by default.

  switchport mode access

!--- The port is a member of channel group 1.

  channel-group 1 mode desirable
 !
 interface FastEthernet3/3
  no ip address
 switchport
  switchport mode access
 !


!--- Output suppressed.

 !
 interface FastEthernet3/48
  no ip address
 switchport
  switchport mode access
 !


!--- Interface VLAN1 is required for management purposes.

 interface Vlan1
  ip address 10.1.1.2 255.255.255.0
 !
 ip classless
 no ip http server
 !
 !
 !
 line con 0
  transport input none
 line vty 0 4
 !
 end

Примечание: В этом примере показана конфигурация EtherChannel с каналами доступа. Аналогичная конфигурация применяется к магистральным каналам EtherChannel. Выполните команду switchport mode trunk или позвольте коммутаторам выполнять согласование о режиме с динамическим выбираемым режимом. Дополнительную информацию о настройке режима магистрального соединения см. в разделе Настройка магистралей VLAN документа Настройка сетей VLAN.

Port-Channel конфигурация интерфейса Sub

Другой пример конфигурации Port-Channel с sub взаимодействует в коммутаторе Catalyst 3560 рабочее программное обеспечение Cisco IOS версии 12.2 (25).

Catalyst 3560
Building configuration...
  
Current configuration : 2480 bytes
!
version 12.2
!
interface Port-channel5
no switchport
no ip address
!
interface Port-channel5.690
!
interface Port-channel10
no switchport
no ip address
!
interface Port-channel10.1
!
interface Port-channel10.690
!
interface Port-channel11
no switchport
no ip address

Проверка

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Чтобы проверить канал порта в коммутаторах Catalyst 6500/6000 и Catalyst 3500 с системным ПО Cisco IOS, выполните следующие команды:

Чтобы проверить состояние протокола STP на коммутаторах Catalyst 6500/6000 и Catalyst 3500 с системным ПО Cisco IOS, выполните следующую команду:

Catalyst 3550

Cat3550#show interface port-channel 1
Port-channel1 is up, line protocol is up
Hardware is EtherChannel, address is 0002.4b28.db02 (bia 0002.4b28.db02)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
 Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
 Members in this channel: Gi0/1 Gi0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:03:27, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
26 packets input, 5344 bytes, 0 no buffer
Received 17 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
59 packets output, 5050 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Cat3550#show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0002.4b28.db01
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:00:38 ago
          from Port-channel1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 0
 
 Port 65 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 128.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 34, received 0 

Cat3550# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
        U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Gi0/1(P)   Gi0/2(P)

Cat3550# ping 10.1.1.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Для Catalyst 6500/6000

Cat6500# show interface port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0002.7ef1.36e1 (bia 0002.7ef1.36e1)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s
  Members in this channel: Fa3/1 Fa3/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/2000, 0 drops
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     407 packets input, 34994 bytes, 0 no buffer
     Received 311 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     93 packets output, 16598 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Cat6500# show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.024f.6001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0002.4b28.db01
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:02:13 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300
 
 Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 0, received 66

Cat6500# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa3/1(P)   Fa3/2(P)

Cat6500# ping 10.1.1.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Устранение неполадок

Состояние Err-Disable

Общая проблема, возникающая при настройке EtherChannel, заключается в том, что интерфейсы переключаются в режим err-disable. Это может произойти, когда EtherChannel переключается в режим "Включено" на одном коммутаторе, а другой коммутатор не настраивается немедленно. Если это состояние сохраняется в течение примерно минуты, протокол STP на коммутаторе, на котором включен канал EtherChannel, считает, что возникла петля. Это вызывает переключение канальных портов в состояние err-disable. Дополнительную информацию о том, как определить, находятся ли интерфейсы EtherChannel в состоянии err-disable, см. в следующем примере:

%SPANTREE-2-CHNL_MISCFG: Detected loop due to etherchannel misconfiguration of Gi0/9
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/9 in err-disable state
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/10 in err-disable state
Switch1#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SD)         -        Gi0/9(D)    Gi0/10(D)

Switch1#show interfaces GigabitEthernet 0/9 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/9                        err-disabled 1            auto   auto 10/100/1000BaseTX

Switch1#show interfaces GigabitEthernet 0/10 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/10                       err-disabled 1            auto   auto 10/100/1000BaseTX

В сообщении об ошибке указывается, что в EtherChannel возникла петля в дереве STP. Для решения вопроса установите канальный режим в выбираемый с обеих сторон соединения, и затем реактивируйте интерфейсы:

Switch1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#interface gi0/9
Switch1(config-if)#channel-group 10 mode desirable

В этом случае обе стороны должны формировать канал только после достижения обоюдной договоренности. Если соглашение о формировании канала не достигнуто, они продолжают работать как обычные порты.

После установки режима канала desirable на обеих сторонах соединения выполните команды shutdown и no shutdown на соответствующем интерфейсе, чтобы заново вручную включить порты:

Switch1(config-if)#shutdown
Switch1(config-if)#no shutdown

"Команда" nonegotiate скорости не Появляется в Рабочей конфигурации

Команда nonegotiate скорости, настроенная на канале порта, не всегда появляется в рабочей конфигурации. Это происходит, потому что nonegotiate на интерфейсе порт-канал зависит от того из связанных портов. Когда канал порта активен и на основе конфигурации портов отдельного канала, это вставлено.


Дополнительные сведения


Document ID: 12033