Технологии коммутируемого доступа в сеть : Асинхронные подключения

Конфигурирование терминала/общего сервера

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (10 ноября 2015) | Отзыв


Содержание


Введение

Терминал или сервер связи обычно предоставляет внеполосный доступ для нескольких устройств. Терминальный сервер - это маршрутизатор с большим количеством низкоскоростных асинхронных портов, которые подключены к другим устройствам последовательного интерфейса, например, модемам или консольным портам на маршрутизаторах или коммутаторах.

Терминальный сервер позволяет вам пользоваться единой точкой для доступа к консольным портам многих устройств. Использование сервера терминалов снимает необходимость в настройке резервных сценариев, например, модемов на вспомогательных портах для каждого устройства. Один модем можно подключить к вспомогательному порту терминального сервера; этот модем обеспечит возможность соединения с другими устройствами при сбое в работе сети.

В данном документе показан способ настройки терминального сервера для доступа только к консольным портам других маршрутизаторов с помощью функции Reverse Telnet. Функция Reverse Telnet позволяет осуществлять сеанс Telnet с устройства, на котором выполняется Telnet, но на другом интерфейсе. Для получения дополнительной информации об Обратном доступе по протоколу Telnet ссылаются на Управляющие сеансы Telnet.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Кабельное подключение

В Cisco 2509 - 2512 series routers используется 68-контактный разъем и кабель с врезкой. Данный кабель (CAB-OCTAL-ASYNC) предоставляет восемь асинхронных портов скрученного кабеля RJ-45 на каждом 68-контактном разъеме. Можно подключить каждый асинхронный порт с перекрученным кабелем RJ-45 к порту консоли устройства. Маршрутизатор 2511 поддерживает удаленный доступ не более чем к 16 устройствам. Кроме того, для маршрутизаторов Cisco серии 2600 и 3600 доступны асинхронные сетевые модули с высокой плотностью NM-16A или NM-32A, которые поддерживают ту же функцию. Дополнительная информация о кабельных соединениях представлена в документах "Руководство по подключению последовательного кабеля" и "Руководство по прокладке кабелей для консольных и вспомогательных портов".

Примечание: Асинхронные порты с 68-штырьковым разъемом являются устройствами терминального оборудования (DTE). Для устройств DTE-DTE небходим перекрученный кабель (нуль-модемный), а для устройств DTE - оборудование DCE необходимо прямое кабельное соединение. CAB-OCTAL-ASYNC - перекрученный кабель. Следовательно, каждый кабель можно подключать непосредственно к портам консоли устройств с интерфейсами RJ-45. Однако, если порт консоли устройства, к которому производится подключение, является 25-контактным интерфейсом (DCE), используйте кабель RJ-45 к 25-контактному адаптеру, помеченному "Modem" (чтобы отменить "перекрутку"), для завершения подключения.

В таблице далее показаны типы портов для консоли и вспомогательных портов на маршрутизаторах и коммутаторах Cisco:

Тип интерфейса Интерфейс DB25 Интерфейс RJ-45
Консоль DCE DTE
AUX DTE DTE

Стратегия проектирования

Настройте терминальный сервер таким образом, чтобы доступ к нему можно было получить из любого места. Чтобы сделать терминальный сервер доступным, назначьте ему зарегистрированный общедоступный Интернет-адрес и расположите его за брандмауэром. После этого проблемы с брандмауэром не будут оказывать влияние на подключение. Это гарантирует возможность постоянно поддерживать подключение к терминальному серверу и получать доступ к подсоединенным устройствам. Чтобы решить проблемы с безопасностью, настройте списки доступа таким образом, чтобы разрешить доступ к терминальному сервере только для избранных адресов. Чтобы гарантировать большую безопасность, настройте на сервере функции аутентификации, авторизации и учета (ААА); например, RADIUS или TACACS+. Для получения дополнительной информации о AAA обратитесь к Аутентификации, авторизации и учету (AAA).

Можно настроить модем на вспомогательный порт терминального сервера для резервного коммутируемого канала по телефонной линии, в случае, если основное подключение (через Интернет) перестанет работать. Это устраняет необходимость в настройке резервирования вызова для каждого устройства. Терминальный сервер подключен через асинхронные порты к консольным портам других устройств. Дополнительная информация о подключении модема к вспомогательному порту представлена в документе "Руководство по установке соединения между модемом и маршрутизатором".

Используйте утверждение ip default gateway и укажите маршрутизатор следующего узла в Интернете. Эта команда позволяет подключаться к терминальному серверу через Интернет даже при отключенной маршрутизации. Например, терминальный сервер работает в режиме мониторинга ROM (ROMMON), причиной чему явился неверный перезапуск после отключения электроэнергии.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/dial-access/asynchronous-connections/5466-Com-Srv.gif

Конфигурации

В данном документе используется следующая конфигурация:

  • Cisco 2511

Cisco 2511
aus-comm-server#show running-config
!
version 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

!--- The host 3600-3 is connected to port 14 of the comm server.


!--- Ensure that the IP address is that of an interface on the comm server.

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

!--- This address is used in the IP host commands.


!--- Work with loopback interfaces, which are virtual and always available.

 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

!---  Use a public IP address to ensure connectivity. 

No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

!--- This is the default gateway when routing is disabled.


!--- For example, if the router is in boot ROM mode.

ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

!--- Set the default route for the external network.

no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

!--- The session times out after 20 minutes of inactivity. 

no exec

!--- Unwanted signals from the attached device do not launch.
 

!--- An EXEC session ensures that the line never becomes unavailable 


!--- due to a rogue EXEC process.

 exec-timeout 0 0

!--- This disables exec timeout transport input all.


!--- Allow all protocols to use the line.


!--- Configure lines 1 - 16 with at least transport input Telnet.

line aux 0

!--- Auxiliary port can provide dial backup to the network.


!--- Note: This configuration does not implement modem on AUX port modem InOut. 


!--- Allow auxiliary port to support dialout and dialin connections.

 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted> 
login
!
end

Примечание: При использовании 3600 в качестве сервера доступа, обратитесь к тому, Как Асинхронные линии Пронумерованы в Маршрутизаторах серии Cisco 3600 для подробных данных номера строки.

Перечень команд

ip host — Используйте эту команду для определения сопоставления имен и адресов статического хоста в кэше хоста. для удаления сопоставления имен и адресов используйте эту команду с параметром no.

  • название ip host [tcp-port-number] address1 [address2... ... address8]

    • название — Это поле указывает на название хоста. Поле имени не соответствует действительному имени маршрутизатора, к которому происходит подключение. Однако убедитесь, что указано имя, которое будет использоваться в сеансе Reverse Telnet. При использовании этой команды и поля имени вы не должны знать фактический номер порта удаленного устройства.

    • tcp-port-number — Это поле представляет номер порта TCP, с которым вы хотите соединиться при использовании определенного имени хоста наряду с подключением EXEC или командой telnet. В нашем примере конфигурации мы используем обратный доступ по протоколу Telnet, таким образом, номер порта должен быть 2000+line номер.

    • address1 — это поле представляет cвязанный IP-адрес. В нашем примере конфигурации мы используем IP - адрес обратной связи.

transport input — Используйте эту команду для определения протоколов для использования, когда вы соединитесь с определенной линией маршрутизатора.

  • transport input {все | lat | швабра | nasi | ни один | не дополняет | rlogin | telnet | v120}

    • все — Все выбирает все протоколы.

    • ни один — Ни один не предотвращает выбора протокола на линии. В этом случае порт нельзя использовать для входящих соединений.

    Примечание: В данном примере асинхронные каналы используют минимальную конфигурацию команды transport input telnet. Таким образом, вы можете Telnet к устройствам на асинхронной линии.

telnet — Используйте эту команду EXEC для вхождения в хост, который поддерживает Telnet.

  • хост telnet [порт] [ключевое слово]

    • разместите Это поле, указывает на имя хоста или IP-адрес. Хост может быть одним из полей имени, определенных в команде ip host.

    • порт — Это поле указывает на десятичный номер порта TCP. Порт маршрутизатора Telnet (десятичное число 23) для хоста является десятичным номером порта TCP по умолчанию. Для сеанса Reverse Telnet номером порта является 2000 + линия. В данной конфигурации используются номера линий от 1 до 16. Чтобы узнать о доступных каналах связи, используйте команду show line.

Коммутация между активными сеансами

Выполните эти шаги для коммутации между активными сеансами:

  1. Используйте escape-последовательность Ctrl-Shift-6 тогда x для выхода из текущего сеанса.

  2. Чтобы отобразить все открытые соединения, используйте команду show sessions.

    aus-comm-server#show sessions 
    Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3

    Примечание: Символ "звездочка" (*) указывает на текущий сеанс терминала.

  3. Чтобы подключиться к соответствующему устройству, укажите номер сеанса (conn). К примеру, чтобы подключиться к 2511-1, наберите цифру 1, которая является номером подключения. Однако при нажатии клавиши ввода происходит подключение к текущему сеансу терминала, который в данном случае является маршрутизатором 2511-3.

Завершение активных сеансов

Выполните эти шаги для завершения сеанса конкретного сервера Telnet:

  1. Используйте escape-последовательность Ctrl-Shift-6 тогда x для выхода из текущего сеанса Telnet.

    Примечание: Гарантируйте, что можно надежно выполнить escape-последовательность для приостановки сеанса Telnet. Некоторые пакеты эмулятора терминала неспособны передать корректную последовательность, Ctrl-Shift-6 тогда x.

  2. Чтобы отобразить все открытые соединения, используйте команду show sessions.

  3. Чтобы выйти из определенного сеанса, выполните команду disconnect [connection].

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip interface brief, подключен ли интерфейс, который вы используете для сеанса Telnet.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Процедура устранения неполадок

Для устранения неполадок конфигурации выполните следующие действия.

Если невозможно подключиться к выбранному маршрутизатору с помощью имени, настроенного в команде ip host, проверьте следующее:

  1. Проверьте, правильно ли настроен адрес порта.

  2. Проверьте, работает ли адрес (интерфейс), используемый для сеанса Reverse Telnet. Эта информация содержится в выходных данных команды show ip interface brief. Компания Cisco рекомендует использовать возвратные петли, поскольку они всегда активны.

  3. Убедитесь, что используется правильный тип кабеля. К примеру, нельзя использовать разделительный кабель, чтобы увеличить длину. Дополнительные сведения см. в разделе "Кабельные соединения".

  4. Установите подключение Telnet к порту IP-адреса, чтобы проверить прямое соединение. Необходимо использовать протокол telnet как от внешнего устройства, так и от сервера терминала. К примеру, telnet 172.21.1.1 2003.

  5. Убедитесь, что команда transport input telnet используется для канала целевого устройства. Целевое устройство - это устройство, подключенное к серверу терминала.

  6. Для прямого подключения к консоли целевого маршрутизатора используйте терминал PC/dumb. Целевой маршрутизатор - это устройство, подключенное к серверу терминала. На этом этапе можно выявить наличие проблемы с портом.

  7. Если произошло отключение, проверьте время ожидания. Этот параметр можно удалить или настроить.

    Примечание: При обнаружении с ошибками проверки подлинности помните, что сервер терминала выполняет первую аутентификацию (если настроено), в то время как устройство, с которым вы пытаетесь соединиться, выполняет вторую аутентификацию (если настроено). Проверьте, правильно ли настроены функции AAA на сервере терминала и подключаемом устройстве.


Дополнительные сведения


Document ID: 5466