Качество обслуживания (QoS) : Политики QoS

Параметры качества обслуживания (QoS) на туннельных интерфейсах GRE

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (29 июля 2008) | Английский (22 апреля 2015) | Отзыв


Содержание


Введение

В этом документе приводится обзор функций качества обслуживания (Quality of Service, QoS), которые можно настраивать на туннельных интерфейсах с использованием протокола GRE (общая инкапсуляция маршрутов). Туннели, настраиваемые по протоколу IPsec (межсетевой протокол безопасности), находятся за пределами рассмотрения данного документа.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Обзор GRE

Прежде чем рассматривать QoS по туннелям GRE, необходимо понять формат туннелируемого пакета.

Туннельный интерфейс является действительным или логическим интерфейсом на маршрутизаторе рабочий Cisco программное обеспечение IOS�. Он обеспечивает виртуальное двухточечное соединение между двумя маршрутизаторами Cisco на удаленных пунктах объединенной IP-сети.

GRE – это протокол инкапсуляции, поддерживаемый системой IOS и определенный в стандарте RFC 1702 . leavingcisco.comПротоколы туннелирования инкапсулируют пакеты в пределах протокола транспортного уровня.

Туннельный интерфейс поддерживает заголовок для каждого из следующих протоколов:

  • Протокол переноса или инкапсулируемый протокол, например IP, AppleTalk, DECnet (Digital Equipment Corporation Network, сеть корпорации цифрового оборудования) и IPX (Internetwork Packet eXchange, межсетевой пакетный обмен).

  • Протокол носителя (GRE в данном случае).

  • Транспортный протокол (только IP в данном случае).

Формат туннельного пакета проиллюстрирован ниже:

http://www.cisco.com/c/dam/en/us/support/docs/quality-of-service-qos/qos-policing/10106-qostunnel-01.gif

Дополнительные сведения о настройке туннелей GRE см. в документе Настройка логических интерфейсов.

Cisco QoS для туннелей GRE

Туннельный интерфейс поддерживает большинство тех же функций QoS, что и физический интерфейс. В следующих разделах описываются поддерживаемые функции QoS.

Формирование

В системе Cisco IOS версии 12.0(7)T предоставляется поддержка для применения протокола GTS (Формирование общего трафика) непосредственно на туннельном интерфейсе. Нижеследующая эталонная конфигурация формирует туннельный интерфейс для общей скорости вывода 500 Кб/с. Дополнительные сведения см. в документе Настройка формирования общего трафика.

interface Tunnel0 
  ip address 130.1.2.1 255.255.255.0 
  traffic-shape rate 500000 125000 125000 1000 
  tunnel source 10.1.1.1 
  tunnel destination 10.2.2.2

В системе Cisco IOS версии 12.1(2)T появилась поддержка формирования трафика на основе классов с использованием MQC (modular QoS command-line interface, модульный интерфейс командной строки качества обслуживания). Следующий пример конфигурации показывает, как применить ту же политику формирования к интерфейсу туннеля с помощью команд MQC. Дополнительные сведения см. в документе Настройка формирования трафика на основе классов.

policy-map tunnel 
  class class-default 
    shape average 500000 125000 125000 
interface Tunnel0 
  ip address 130.1.2.1 255.255.255.0 
  service-policy output tunnel 
  tunnel source 130.1.35.1 
  tunnel destination 130.1.35.2

Применение политик

Когда интерфейсы перегружены и пакеты начинают скапливаться в очереди, можно применить очередной метод к пакетам, ожидающим передачи. Логические интерфейсы Cisco IOS в действительности не поддерживают состояние перегруженности и не поддерживают прямое приложение служебной политики, применяющей метод постановки в очередь. Вместо этого необходимо применить иерархическую политику следующим образом:

  1. Создайте "дочернюю" политику или политику нижнего уровня, которая настраивает механизм организации очереди: построение очереди с низкой задержкой с помощью команды priority или объективную организацию очереди с весовыми коэффициентами на основе классов (CBWFQ, class-based weighted fair queueing) с помощью команды bandwidth. Дополнительные сведения см. в документе Управление перегрузкой.

    policy-map child 
     class voice 
      priority 512
  2. Создайте родительскую или высокоуровневую политику, применяющую формирование на основе класса. Примените дочернюю политику как команду родительской политики, так как контроль на входе дочернего класса основан на скорости формирования трафика родительского класса.

    policy-map tunnel 
     class class-default 
      shape average 2000000 
      service-policy child 
  3. Примените родительскую политику к туннельному интерфейсу.

    interface tunnel0 
       service-policy tunnel

Когда туннельный интерфейс настраивается с помощью политики обслуживания, которая применяет организацию очереди, не используя формирование, маршрутизатор печатает следующее сообщение журнала событий.

router(config)# interface tunnel1
router(config-if)# service-policy output child
 Class Based Weighted Fair Queueing not supported on this interface

Туннельные интерфейсы также поддерживают назначение политик на основе классов, но не предусматривают фиксированную скорость доступа (committed access rate, CAR).

Примечание: Служебная политика не поддерживается в туннельных интерфейсах 7500.

Предотвращение перегрузок

Cisco IOS Software Release 11.3T представил маркировку Туннеля GRE и DSCP или Значения приоритета IP-трафика, который настраивает маршрутизатор для копирования значений двоичного значения приоритета IP-трафика байта ToS в туннель или IP - заголовок GRE, который инкапсулирует внутренний пакет. Раньше эти биты были равны нулю. На промежуточных маршрутизаторах между конечными точками туннеля могут использоваться значения IP-приоритета, чтобы классифицировать пакеты для таких функций QoS, как маршрутизация на основе политик, объективная организация очереди с весовыми коэффициентами (WFQ, weighted fair queueing) и случайное взвешенное предварительное обнаружение (WRED, Weighted Random Early Detection).

Команда qos pre-classify

Если пакеты инкапсулируются в заголовки туннелей или зашифрованные заголовки, QoS не может прочитать исходные заголовки пакетов и правильно их классифицировать. Пакеты, перемещающиеся по одному туннелю, имеют идентичные заголовки туннеля, поэтому пакеты обрабатываются одинаково в том случае, если интерфейс переполнен. С введением функции качества обслуживания для виртуальных частных сетей (VPN) пакеты можно классифицировать перед выполнением туннелирования и шифрования.

В следующем примере tunnel0 – это название туннеля. Команда qos pre-classify включает систему QoS для функции VPN на tunnel0:

Router(config)# interface tunnel0
Router(config-if)# qos pre-classify

Примечание: Команда qos pre-classify может использоваться для классификации трафика на основе значений кроме IP precedence или DSCP. Например, вы могли бы хотеть классифицировать пакеты на основе IP flow или информации сетевого уровня 3, такие как IP - адрес источника и получателя, для которого может использоваться эта команда. Команда qos pre-classify требуется, только если вы классифицируете трафик на IP, протоколе или порту. Если классификация основывается на коде DSCP, то qos pre-classify не требуется.

Описание трафика для политики QoS

При настройке политики обслуживания сначала может возникнуть необходимость описать характеристики трафика, проходящего по туннелю. Cisco IOS поддерживает Netflow и учет IP Cisco Express Forwarding (CEF) на логических интерфейсах вроде туннелей. Дополнительные сведения см. в документе Руководство по решениям и службам NetFlow.

Как обратиться к политике обслуживания?

Служебную политику можно применить либо к туннельному интерфейсу, либо к основному физическому интерфейсу. Выбор интерфейса, где следует применить политику, зависит от целей качества обслуживания. Это также зависит от того, какой заголовок нужен для классификации.

  • Когда нужно классифицировать пакеты на основе заголовка перед туннелем, применяйте политику к туннельному интерфейсу, не используя qos-preclassify.

  • Если же необходимо классифицировать пакеты на основе заголовка после туннеля, следует применять политику к физическому интерфейсу, не используя qos-preclassify. Кроме того, применяйте политику к физическому интерфейсу при формировании трафика туннеля, а физический интерфейс поддерживает несколько туннелей.

  • Примените политику к физическому интерфейсу и включите qos - предварительно классифицируют на туннельном интерфейсе, когда вы хотите классифицировать пакеты на основе заголовка перед туннелем.

Интерфейсы многоточечного туннеля

На многоточечном интерфейсе технология CBWFQ в пределах формирования трафика на основе классов не поддерживается. Если использовать исправление ошибки Cisco с идентификатором CSCds87191, то при отклонении политики маршрутизатор будет выдавать сообщение об ошибке.

Типичные ошибки

В редких случаях применение политики обслуживания, настроенной с помощью команды shape, приводит к высокой загрузке процессора и ошибкам выравнивания. Перегрузка процессора происходит вследствие регистрации ошибок выравнивания, которые, в свою очередь, вызываются методом CEF, неверно устанавливающим выходной интерфейс, и данными о перезаписи смежности. Эта проблема касается только платформ начального уровня, имеющих тип, отличный от RSP, и платформ, использующих метод коммутации CEF на основе частиц, и решается с помощью исправлений ошибок Cisco с идентификаторами CSCdu45504 и CSCuk30302. Кроме того, можно использовать следующие приемы:

  • Заменa инкапсуляции GRE на tunnel mode ipip.

  • Замену команды shape на police.

  • Настройку формирования трафика на физическом интерфейсе, который поддерживает туннель.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10106