Коммутация LAN : Сети VLAN

Создание сетей Ethernet VLAN на коммутаторах Catalyst

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (20 октября 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет основные сведения о том, как создать VLAN на Коммутаторах Catalyst, которые выполняют операционную систему Catalyst (CatOS) и Cisco Системное программное обеспечение IOS�. В примерах команд для каждого раздела используется один коммутатор Catalyst из каждого раздела конфигурации.

Предварительные условия

Требования

Cisco рекомендует ознакомиться с информацией, содержащейся в данном разделе.

Сети VLAN – это структура, которая позволяет сетевым администраторам создавать логические домены широковещательной передачи, способные охватывать один или более коммутаторов, независимо от физического местонахождения самих устройств. Такой механизм позволяет сокращать размер доменов широковещательной передачи, а также логически группировать пользователей или объединять группы, не прибегая при этом к физическому размещению объектов в одном конкретном месте.

Создавая сети VLAN, необходимо получить ответы на следующие вопросы:

  • Какое доменное имя Транкингового протокола VLAN (VTP) и режим VTP для использования на этом коммутаторе

  • Какие порты на коммутаторе принадлежат который VLAN

  • Если у вас должна быть связь между VLAN, или если они изолированы

    При требовании связи между VLAN необходимо использовать устройство маршрутизации Уровня 3, такое как внешний маршрутизатор Cisco или модуль встроенного маршрутизатора. Рассмотрим примеры:

    • Карта WS-X4232-Layer для коммутаторов Catalyst 4500/4000 с Supervisor Engine I и Supervisor Engine II

    • Модульный коммутатор с функциями маршрутизатора (RSM) или плата маршрутизации для коммутатора (RSFC) для коммутаторов Catalyst 5500/5000

    • Многоуровневый коммутатор (MSM) или Функциональная Карта Многоуровневого Коммутатора (MSFC) для коммутаторов Catalyst 6500/6000

    Некоторые коммутаторы имеют встроенную поддержку в программном и аппаратном обеспечении, чтобы сделать маршрутизацию между виртуальными локальными сетями (IVR). Маршрутизация между сетями VLAN не требует использования каких-либо внешних устройств, модулей или дочерних плат. Приведем несколько примеров таких коммутаторов:

    • Catalyst 3550/3750/6500 с модулем управления Supervisor Engine 720

    • Catalyst 4500/4000 с Supervisor Engine II +, Supervisor Engine III и Supervisor Engine IV

См. эти документы для получения дополнительной информации о конфигурации маршрутизации между виртуальными локальными сетями (IVR) на MSFC, RSM, RSFC или внешнем маршрутизаторе:

Примечание: Этот документ предполагает, что у вас есть основное подключение к коммутатору, или через консоль или через доступ Telnet. Чтобы узнать, каким образом осуществляется базовое подключение к коммутаторам, см. следующие документы:

Используемые компоненты

Сведения в документе приведены на основе данных версий аппаратного и программного обеспечения:

  • Коммутатор Catalyst 6009, который выполняет CatOS 5.5 (x) программное обеспечение

  • Коммутатор Catalyst 3524XL, который выполняет Cisco IOS Software Release 12.0 (5.x) XU

  • Коммутатор Catalyst 4507 с Supervisor Engine IV (WS-X4515), который выполняет EW1 программного обеспечения Cisco IOS версии 12.1(13)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Сведения в этом документе могут также использоваться с этими коммутаторами:

  • Catalyst 4500/4000/2948G/2980G/4912G Коммутаторы

  • Catalyst 5000/серии 2926G Коммутаторов

  • Коммутаторы серии Catalyst 6500/600

  • Catalyst 2900XL/3500XL/2950/3550/3750 Коммутаторы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Различия между ПО для CatOS и Cisco IOS

Операционная система CatOS на Supervisor Engine and программное обеспечение Cisco IOS на плате MSFC (Hybrid): можно использовать образ CatOS в качестве системного программного обеспечения для запуска процессора управляющего модуля на коммутаторах Catalyst 6500/6000. Если установлен дополнительный модуль MSFC, для его запуска используется отдельный образ программного обеспечения Cisco IOS.

Программное обеспечение Cisco IOS для модуля Supervisor Engine и для платы MSFC (встроенной): можно использовать один образ программного обеспечения CatOS в качестве системного программного обеспечения для запуска процессора управляющего модуля и платы MSCF на коммутаторах Catalyst 6500/6000.

Примечание: См. раздел Сравнение операционных систем Cisco Catalyst и Cisco IOS для коммутаторов серии Cisco Catalyst 6500 для получения более полной информации.

Настройте VLAN на коммутаторах Catalyst который выполненный CatOS

Создайте VLAN и порты

Выполните шаги в этом разделе для создания VLAN.

Перед созданием виртуальной локальной сети (VLAN) коммутатор следует перевести в режим сервера VTP или прозрачный режим VTP. Если коммутатор является VTP-сервером, то перед добавлением виртуальных локальных сетей (VLAN) необходимо определить имя домена VTP.

  1. Определите доменное имя VTP.

    Доменное имя VTP должно быть определено вне зависимости от следующих факторов:

    • Количество коммутаторов в сети, ли один или несколько

    • Используете ли вы VTP для распространения VLAN к другим коммутаторам в сети

    Это - конфигурация режима VTP по умолчанию на коммутаторе:

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    Чтобы установить доменное имя и режим, воспользуйтесь командой set vtp.

    CatosSwitch> (enable)set vtp domain ?
    
      <name>                     Domain name
    
    CatosSwitch> (enable)set vtp domain cisco ?
    
      mode                       Set VTP mode
      passwd                     Set VTP password
      pruning                    Set VTP pruning
      v2                         Set VTP version 2
    
    CatosSwitch> (enable)set vtp domain cisco mode ?
    
      client                     VTP client mode
      server                     VTP server mode
      transparent                VTP transparent mode
    
    CatosSwitch> (enable)set vtp domain cisco mode server
    
    VTP domain cisco modified

    Примечание: Дополнительную информацию о VTP см. в документе «Общие сведения о протоколе VTP».

  2. Чтобы проверить конфигурацию протокола VTP воспользуйтесь командой show vtp domain.

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             1               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    Примечание: Если у вас есть выходные данные команды show vtp domain от вашего устройства Сisco, можно использовать Интерпретатор выходных данных (только зарегистрированные клиенты), чтобы отобразить потенциальные проблемы и исправляете.

  3. После того, как домен VTP был установлен и проверен, можно начать создание сетей VLAN на коммутаторе.

    По умолчанию для всех портов существует только одна сеть VLAN. Такая сеть VLAN называется сетью по умолчанию. Сеть VLAN 1 не может быть переименована или удалена.

    Команда show vlan отображает параметры для всех сетей VLAN, настроенных в административном домене.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/1-48
                                                            4/1-16
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      ibm  -        0      0
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    1    static     disabled
    1002 static     disabled
    1003 static     disabled
    1004 static     disabled
    1005 static     disabled
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
    1003 7       7       off
    1. Чтобы создать сети VLAN воспользуйтесь командой set vlan.

      CatosSwitch> (enable)set vlan
      
      Usage: set vlan <vlan> <mod/port>
             (An example of mod/port is 1/1,2/1-12,3/1-2,4/1-12)
             set vlan <vlan_num> [name <name>] [type <type>] [state <state>]
                                 [pvlan-type <pvlan_type>]
                                 [said <said>] [mtu <mtu>]
                                 [ring <hex_ring_number>]
                                 [decring <decimal_ring_number>]
                                 [bridge <bridge_number>] [parent <vlan_num>]
                                 [mode <bridge_mode>] [stp <stp_type>]
                                 [translation <vlan_num>] [backupcrf <off|on>]
                                 [aremaxhop <hopcount>] [stemaxhop <hopcount>]
                                 [rspan]
             (name = 1..32 characters, state = (active, suspend)
              type = (ethernet, fddi, fddinet, trcrf, trbrf)
              said = 1..4294967294, mtu = 576..18190
              pvlan-type = (primary,isolated,community,none)
              hex_ring_number = 0x1..0xfff, decimal_ring_number = 1..4095
              bridge_number = 0x1..0xf, parent = 2..1005, mode = (srt, srb)
              stp = (ieee, IBM, auto), translation = 1..1005
              hopcount = 1..13)
      Set vlan commands:
      ----------------------------------------------------------------------------
      set vlan                     Set vlan information
      set vlan mapping             Map an 802.1q vlan to an Ethernet vlan
      
      CatosSwitch> (enable)set vlan 2 name cisco_vlan_2
      
      Vlan 2 configuration successful
    2. Чтобы проверить конфигурацию сети VLAN, воспользуйтесь командой show vlan.

      CatosSwitch> (enable)show vlan
      
      VLAN Name                             Status    IfIndex Mod/Ports, Vlans
      ---- -------------------------------- --------- ------- --------------------
      1    default                          active    5       1/1-2
                                                              3/1-48
                                                              4/1-16
      2    cisco_vlan_2                     active    75      
      1002 fddi-default                     active    6       
      1003 token-ring-default               active    9       
      1004 fddinet-default                  active    7       
      1005 trnet-default                    active    8       
      
      
      VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
      ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
      1    enet  100001     1500  -      -      -      -    -        0      0
      2    enet  100002     1500  -      -      -      -    -        0      0
      1002 fddi  101002     1500  -      -      -      -    -        0      0
      1003 trcrf 101003     1500  -      -      -      -    -        0      0
      1004 fdnet 101004     1500  -      -      -      -    -        0      0
      1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
      
      !--- Output suppressed.
      
      
    3. Если вы хотите добавить порты к VLAN, выполнить vlan_number set vlan команда mod/port.

      CatosSwitch> (enable)set vlan 2 3/1-12
      
      VLAN 2 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      2     3/1-12
            15/1

      Примечание: Можно также создать VLAN и добавить порты к той VLAN со всей информацией в одиночной команде.

      Например, если необходимо создать третью по счету сеть VLAN, а затем назначить этой сети порты с 3/13 по 3/15, можно воспользоваться следующей командой:

      CatosSwitch> (enable)set vlan 3 3/13-15
      
      Vlan 3 configuration successful
      VLAN 3 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      3     3/13-15
            15/1
  4. Чтобы проверить конфигурацию сети VLAN, воспользуйтесь командой show vlan.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/16-48
                                                            4/1-16
    2    cisco_vlan_2                     active    75      3/1-12
    3    VLAN0003                         active    76      3/13-15
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    2    enet  100002     1500  -      -      -      -    -        0      0
    3    enet  100003     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
    
    !--- Output suppressed.
    
    

Удалите порты или VLAN

Для удаления портов из VLAN выполните vlan_number set vlan команда mod/port и место порты в другой VLAN. В сущности, процесс удаления происходит в момент назначения порта любой сети VLAN, поскольку первоначально все порты принадлежат сети VLAN 1.

Чтобы удалить сеть VLAN воспользуйтесь командой clear vlan. При этом имеющиеся порты деактивируются, потому что они являются частью удаляемой сети VLAN, которая больше не существует. Коммутатор выводит предупреждение и предоставляет возможность отменить текущий запрос.

CatosSwitch> (enable)clear vlan 3

This command will deactivate all ports on vlan 3
in the entire management domain.
Do you want to continue(y/n) [n]? y

Vlan 3 deleted

CatosSwitch> (enable)show vlan

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- ------------------------
1    default                          active    5       1/1-2
                                                        3/16-48
                                                        4/1-16
2    cisco_vlan_2                     active    75      3/1-12
1002 fddi-default                     active    6
1003 token-ring-default               active    9
1004 fddinet-default                  active    7
1005 trnet-default                    active    8

VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1    enet  100001     1500  -      -      -      -    -        0      0
2    enet  100002     1500  -      -      -      -    -        0      0
1002 fddi  101002     1500  -      -      -      -    -        0      0
1003 trcrf 101003     1500  -      -      -      -    -        0      0
1004 fdnet 101004     1500  -      -      -      -    -        0      0
1005 trbrf 101005     1500  -      -      -      IBM  -        0      0

!--- Output suppressed.

Примечание: Порты 3/13 через 3/15 не отображены в выходных данных команды show vlan, потому что удаление VLAN 3 деактивировало эти порты. Эти порты не будут отображаться до тех пор, пока они снова не будут добавлены в какую-либо сеть VLAN.

Советы по поиску и устранению неполадок

Этот раздел предоставляет советы по устранению проблем для типичных проблем, с которыми можно встретиться при создании VLAN на Коммутаторах Catalyst, которые выполняют CatOS:

  • Если при создании VLAN не было определено доменное имя протокола VTP, будет выведено следующее сообщение об ошибке:

    Cannot add/modify VLANs on a VTP server without a domain name.

    Чтобы исправить ошибку, создайте доменное имя VTP на коммутаторе. Данная процедура описана в разделе Создание портов и сетей VLAN.

  • Если сеть VLAN создается на коммутаторе, работающем в режиме клиента VTP, тогда отображается следующее сообщение об ошибке:

    Cannot add/modify VLANs on a VTP client.

    Примечание: Коммутатор может только создать VLAN, если это находится в режиме сервера VTP или прозрачном режиме VTP. Дополнительную информацию о VTP см. в документе «Общие сведения о протоколе VTP».

  • В выходных данных команды show port mod/port статус портов указан как неактивный (inactive). Это означает, что сеть VLAN, к которой эти порты принадлежали первоначально, была удалена (что обусловлено особенностями протокола VTP). Можно либо создать сеть VLAN заново, либо исправить конфигурацию VTP таким образом, что сеть VLAN будет заново восстановлена в домене VTP. Ниже приведены выходные данные команды show port mod/port:

    CatosSwitch> (enable)show port 3/1
    
    Port  Name               Status     Vlan       Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ----- ------------
     3/1                     inactive   2            auto  auto 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status     InlinePowered     PowerAllocated
                                       Admin Oper   Detected mWatt mA @42V
    ----- ------------- -------------- ----- ------ -------- ----- --------
     3/1  none          none           -     -      -        -     -
    
    !--- Output suppressed.
    
    

    Если выходные данные команды show-tech support получены с устройства Cisco, то в этом случае для интерпретации результатов можно воспользоваться утилитой Output Interpreter (только для зарегистрированных пользователей). Данная утилита отображает потенциальные проблемы и предлагает способы их решения.

    CatosSwitch> (enable)show vlan 2
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
  • Интерфейсы VLAN, созданные в модулях и платах маршрутизации (RSM, RSFC, MSM или MSFC), становятся активными только тогда, когда на коммутаторе существует соответствующая сеть VLAN. Для того чтобы интерфейс VLAN работал в полнофункциональном режиме (это означает, что интерфейс является активным в плане администрирования и что протокол линии также активирован), необходимо убедиться в том, что существует, по крайней мере, один порт, являющийся членом данной сети VLAN и имеется активное устройство подключенное к порту. Информация о процедуре настройки приведена в разделе "Требования" настоящего документа.

Настройте VLAN на Catalyst 2900XL, 3500XL, 2950, 2970, и коммутаторы серии 2940

Создайте VLAN и порты

Примечание: Выходные данные, которые вы видите, могут отличаться от некоторых выходных данных команды, которые отображает этот раздел. Эти различия зависят от модели используемого коммутатора.

Чтобы создать сеть VLAN, необходимо выполнить следующие действия.

  1. Сначала необходимо решить, будет ли использоваться протокол VTP в вашей сети.

    С помощью VTP можно централизованно изменять конфигурацию на одном коммутаторе, а затем автоматически применить изменения ко всем коммутаторам сети. По умолчанию на коммутаторах Catalyst 2900XL, 3500XL, 2950, 2970 и 2940 установлен серверный режим протокола VTP. Дополнительную информацию о VTP см. в документе «Общие сведения о протоколе VTP».

    Примечание: Выполните команду show vtp status для проверки статуса VTP на Коммутаторах Серии XL.

    3524XL#show vtp status
    
    VTP Version                     : 2
    Configuration Revision          : 0
    Maximum VLANs supported locally : 254
    Number of existing VLANs        : 5
    VTP Operating Mode              : Server
    
    !--- This is the default mode.
    
    VTP Domain Name                 : 
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0xBF 0x86 0x94 0x45 0xFC 0xDF 0xB5 0x70 
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
  2. После того, как домен VTP был установлен и проверен, можно начать создание сетей VLAN на коммутаторе.

    По умолчанию для всех портов существует только одна сеть VLAN. Такая сеть VLAN называется сетью по умолчанию. Сеть VLAN 1 не может быть переименована или удалена.

    Чтобы получить информацию о сети VLAN, воспользуйтесь командой show vlan.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

    Чтобы создать другую сеть VLAN, в привилегированном режиме используйте набор команд:

    3524XL#vlan database
    
    !--- You must enter into VLAN database in order to configure any VLAN.
    
    3524XL(vlan)#vtp server
    
    Device mode already VTP SERVER.
    
    !--- You can skip this command if the switch is already in server mode and you
    !--- want the switch to be in server mode.
    
    

    Примечание: Коммутатор может только создать VLAN, если это находится в режиме сервера VTP или прозрачном режиме VTP. Дополнительную информацию о VTP см. в документе «Общие сведения о протоколе VTP».

    524XL(vlan)#vlan ?
    
      <1-1005>  ISL VLAN index
    
    3524XL(vlan)#vlan 2 ?
    
      are        Maximum number of All Route Explorer hops for this VLAN
      backupcrf  Backup CRF mode of the VLAN
      bridge     Bridging characteristics of the VLAN
      media      Media type of the VLAN
      mtu        VLAN Maximum Transmission Unit
      name       Ascii name of the VLAN
      parent     ID number of the Parent VLAN of FDDI or Token Ring type VLANs
      ring       Ring number of FDDI or Token Ring type VLANs
      said       IEEE 802.10 SAID
      state      Operational state of the VLAN
      ste        Maximum number of Spanning Tree Explorer hops for this VLAN
      stp        Spanning tree characteristics of the VLAN
      tb-vlan1   ID number of the first translational VLAN for this VLAN (or zero
                 if none)
      tb-vlan2   ID number of the second translational VLAN for this VLAN (or zero
                 if none)
    
    3524XL(vlan)#vlan 2 name ?
    
      WORD  The ASCII name for the VLAN
    
    3524XL(vlan)#vlan 2 name cisco_vlan_2
    
    VLAN 2 added:
        Name: cisco_vlan_2
    
    3524XL(vlan)#exit
    
    !--- You must exit from the VLAN database in order for the changes 
    !--- to be committed.
    
    APPLY completed.
    Exiting....
    3524XL#

    Примечание: Режим VTP может измениться от клиентского режима до прозрачного режима, если коммутатор пытается изучить или передать большее количество VLAN, чем это поддерживает. Необходимо всегда проверять, чтобы коммутаторы, работающие в клиентском режиме, поддерживали то же количество сетей, которое передается коммутаторами в серверном режиме.

  3. Чтобы убедиться в том, что сеть VLAN была создана, воспользуйтесь командой show vlan.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1
  4. К вновь созданной сети VLAN можно добавить порты (интерфейсы).

    Для каждого интерфейса, который нужно добавить в новую VLAN, необходимо перейти в режим настройки интерфейса.

    Примечание: Можно назначить порты Коммутатора Catalyst Уровня 2 к несколько интерфейсов VLAN, но коммутатор только поддерживает один интерфейс виртуальной локальной сети (VLAN) активного управления за один раз, и другие коммутируемые виртуальные интерфейсы (SVI) не делают up/up из-за функциональности Уровня 2. Поэтому поддержка коммутаторов только один адрес Уровня 3 активного управления. На Коммутаторе Catalyst Уровня 2 можно выполнить дополнительную команду управления под новым SVI для автоматического завершения VLAN 1, и передайте IP-адрес новой VLAN.

    Switch#configure terminal
    
    Switch(config)#interface vlan 2
    
    Switch(config-subif)#management
    
    Switch(config-subif)#^Z
    
    Switch#show ip interface brief
    Interface                  IP-Address      OK? Method Status   Protocol
    VLAN1                      10.0.0.2        YES manual up       down    
    VLAN2                      20.0.0.2        YES manual up       up      
    FastEthernet0/1            unassigned      YES unset  up       up      
    FastEthernet0/2            unassigned      YES unset  up       up
    
    !--- Output suppressed.
    
    

    Чтобы добавить соответствующий интерфейс к сети VLAN, в привилегированном режиме используйте набор команд:

    3524XL#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    3524XL(config)#interface fastethernet 0/2
    
    3524XL(config-if)#switchport access ?
    
      vlan  Set VLAN when interface is in access mode
    
    3524XL(config-if)#switchport access vlan ?
    
      <1-1001>  VLAN ID of the VLAN when this port is in access mode
      dynamic   When in access mode, this interfaces VLAN is controlled by VMPS
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/2 to VLAN 2.
    
    3524XL(config-if)#exit
    
    3524XL(config)#interface fastethernet 0/3
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/3 to VLAN 2.
    
    3524XL(config-if)#end
    
    3524XL#
    00:55:26: %SYS-5-CONFIG_I: Configured from console by console
    
    3524XL#write memory
    
    !--- This saves the configuration.
    
    Building configuration...
  5. Чтобы проверить конфигурацию сети VLAN, воспользуйтесь командой show vlan.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    Fa0/2, Fa0/3
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Удалите порты или VLAN

Для удаления портов из VLAN не выполните switchport access vlan в режиме конфигурации интерфейса. После удаления из сети VLAN (отличной от сети VLAN 1, которая является сетью заданной по умолчанию) этот порт будет автоматически добавлен в сеть VLAN, заданную по умолчанию.

Например, если требуется удалить интерфейс Fast Ethernet 0/2 из cisco_vlan_2 (VLAN 2), то в привилегированном режиме необходимо использовать такую последовательность команд:

3524XL#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

3524XL(config)#interface fastethernet 0/2

3524XL(config-if)#no switchport access vlan 2

!--- These two commands remove interface Fast Ethernet 0/2 from VLAN 2.

3524XL(config-if)#end

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,

!--- Note: Fast Ethernet 0/2 is added back to the default VLAN.

                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
2    cisco_vlan_2                     active    Fa0/3
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Чтобы удалить сеть VLAN, в режиме базы данных используйте команду no vlan vlan_number. Интерфейсы, относящиеся к удаляемой сети VLAN, остаются частью этой сети. Эти интерфейсы будут деактивированы, поскольку уже не принадлежат ни к одной сети VLAN.

Например, если на коммутаторе необходимо удалить сеть cisco_vlan_2, в привилегированном режиме используйте следующий набор команд:

3524XL#vlan database

!--- This command enters you into the VLAN database mode.

3524XL(vlan)#no vlan 2

!--- This command removes the VLAN from the database.

Deleting VLAN 2...

3524XL(vlan)#exit

APPLY completed.
Exiting....

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

!--- Output suppressed.

Обратите внимание на то, что порт Fast Ethernet 0/3 не отображен в выходных данных команды show vlan. При удалении сети VLAN 2 этот порт деактивируется. До тех пор, пока этот порт не будет добавлен в одну из имеющихся сетей VLAN, он не будет отображаться и его нельзя будет использовать.

3524XL#show interfaces fastethernet 0/3

FastEthernet0/3 is down, line protocol is down

!--- Output suppressed.

Для того чтобы интерфейсом можно было пользоваться, необходимо, чтобы он принадлежал к какой-нибудь сети VLAN. В примере, приводимом в настоящем разделе, показано, что для того чтобы можно было использовать интерфейс Fast Ethernet 0/3, его необходимо добавить в сеть VLAN по умолчанию (VLAN 1).

Если выходные данные команды show-tech support получены с устройства Cisco, то в этом случае для интерпретации результатов можно воспользоваться утилитой Output Interpreter (только для зарегистрированных пользователей). Данная утилита отображает потенциальные проблемы и предлагает способы их решения.

Примечание: В случае Коммутаторов Catalyst 3550 можно все еще использовать интерфейс без добавления интерфейса к VLAN. Однако для этого его необходимо настроить как интерфейс 3-го уровня. Более подробно об интерфейсах 3-го уровня на коммутаторах Catalyst 3550 см. Настройка интерфейсов 3-го уровня в разделе Настройка параметров интерфейса .

Настройка порта для нескольких сетей VLAN на коммутаторах Catalyst 2900XL/3500XL

Функция порта для нескольких сетей VLAN (Multi-VLAN), реализованная в коммутаторах Catalyst 2900 XL/3500 XL, позволяет настраивать один порт для двух или более VLAN. Эта функция позволяет пользователям разных сетей VLAN получить доступ к серверу или маршрутизатору, не прибегая к использованию функции маршрутизации между виртуальными локальными сетями (InterVLAN routing). Порт Multi-VLAN выполняет обычные функции коммутации для всех сетей VLAN, принадлежащих к данному порту. Трафик VLAN, проходящий через порт multi-VLAN, не инкапсулируется (в отличие от того, как это происходит в случае транкинга).

Примечание: Это ограничения к реализации функций порта для нескольких VLAN:

  • Нельзя настроить порт мульти-VLAN при настроенном магистральном канале на коммутаторе. Порт multi-VLAN может быть подключен только к маршрутизатору или серверу. Коммутатор автоматически переходит в прозрачный режим VTP, если включена функция порта multi-VLAN (VTP при этом отключается). Настройка VTP не требуется.

  • Функция "порт multi-VLAN" поддерживается только на коммутаторах серии Catalyst 2900 XL/3500 XL. Коммутаторы Catalyst серии 4000/5000/6000, серии 6500/6000, а также другие коммутаторы Catalyst эту функцию не поддерживают.

  1. Необходимо определить, какой порт можно настроить как порт multi-VLAN.

    В данном примере на коммутаторе Catalyst 3512XL созданы три сети VLAN, а один из портов коммутатора подключен к внешнему маршрутизатору. Порт, подключенный к маршрутизатору, будет настроен как порт multi-VLAN.

    6-3512xl#show vlan
    
    VLAN Name                             Status      Ports
    ---- -------------------------------- ---------   -----------------------------
    1    default                          active      Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                      Fa0/8, Fa0/9, Fa0/10, Fa0/11,
                                                      Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active      Fa0/2, Fa0/4
    3    VLAN0003                         active      Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
    6    VLAN0006                         active

    В этом примере порт Fast Ethernet 0/1 подключен к внешнему маршрутизатору. Более подробно о создании сети VLAN и назначении VLAN портов см. в разделе Настройка сети VLAN на коммутаторах Catalyst 2900XL, 3500XL, 2950, 2970 и 2940 данного документа.

  2. Настройка порта Fast Ethernet 0/1 в режиме multi-VLAN и добавление сетей VLAN к порту multi-VLAN.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface fastethernet 0/1
    
    6-3512xl(config-if)#switchport mode multi
    
    !--- This command changes the port Fast Ethernet 0/1 mode to multi.
    
    6-3512xl(config-if)#switchport multi vlan ?
    
      LINE    VLAN IDs of VLANs to be used in multi-VLAN mode
      add     add VLANs to the current list
      remove  remove VLANs from the current list
    
    6-3512xl(config-if)#switchport multi vlan 1,2,3
    
    !--- This command assigns VLANs 1, 2, and 3 to multi-VLAN port Fast Ethernet 0/1.
    
    6-3512xl(config-if)#^Z
     
    6-3512xl#
  3. Чтобы проверить конфигурацию, воспользуйтесь командой show interface interface_id switchport и командой show vlan.

    6-3512xl#show interface fastethernet 0/1 switchport
    
    Name: Fa0/1
    Operational Mode: multi
    
    !--- The port is in multi-VLAN mode.
    
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE
    
    Priority for untagged frames: 0
    
    Override vlan tag priority: FALSE
    
    Voice VLAN: none
    
    Appliance trust: none
    
    6-3512xl#show vlan brief
    
    VLAN Name                             Status       Ports
    ---- -------------------------------- ---------    ----------------------------
    1    default                          active       Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                       Fa0/8, Fa0/9, Fa0/10, Fa0/1
                                                       Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active       Fa0/1, Fa0/2, Fa0/4
    
    !--- Note: Previously, port Fast Ethernet 0/1 was only in VLAN 1.
    !--- Now the port is assigned to multiple VLANs 1, 2, and 3.
    
    3    VLAN0003                         active       Fa0/1, Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
  4. Чтобы проверить функционирование сети VLAN, воспользуйтесь командой ping.

    Команда ping получает отклик от маршрутизатора всякий раз, когда управляющий IP-адрес назначается одной из сетей VLAN – VLAN 1, 2 или 3.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#ip address 192.168.1.1 255.255.255.0
    
    !--- The management IP address is assigned to VLAN 1.
    
    6-3512xl(config-if)#^Z
    
    6-3512xl#
    23:56:54: %SYS-5-CONFIG_I: Configured from console by console
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 1.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#no ip address
    
    !--- The management IP address is removed from VLAN 1.
    
    6-3512xl(config-if)#shutdown
    
    6-3512xl(config-if)#exit
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shutdown
    
    !--- The management IP address is assigned to VLAN 2.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 2.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1004 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#no ip address
    
    !--- The management IP address is removed from VLAN 2.
    
    6-3512xl(config-subif)#shutdown
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#interface vlan 3
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shut
    
    !--- The management IP address is assigned to VLAN 3.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 3.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/205/1004 ms

Настройте VLAN на Catalyst 3550, 3750, 4500/4000, и Коммутаторы 6500/6000 Который Выполненное программное обеспечение Cisco IOS

Создайте VLAN и порты

Этот раздел использует Коммутатор Catalyst 4500 для команд примера конфигурации, но задачи конфигурации также применяются к другим коммутаторам, которые выполняют Уровень 3 (или программное обеспечение Cisco IOS). К таким коммутаторам относятся коммутаторы Catalyst серий 3550, 3570 и 6500, работающие под управлением программного обеспечения Cisco IOS. Перед созданием виртуальной локальной сети (VLAN) коммутатор следует перевести в режим сервера VTP или прозрачный режим VTP. Если коммутатор является VTP-сервером, то перед добавлением виртуальных сетей необходимо определить доменное имя VTP. Доменное имя VTP должно быть установлено вне зависимости от следующих факторов:

  • Количество коммутаторов в сети, ли один или несколько

  • Используете ли вы VTP для распространения VLAN к другим коммутаторам в сети

См. Понимание и VTP Настройки для получения дополнительной информации о том, как настроить VTP на Catalyst 4500/4000 Модули Supervisor Engine на основе ПО Cisco IOS. Чтобы получить информацию по настройке VTP для коммутаторов Catalyst других серий, см. "Руководство по настройке программного обеспечения". Необходимое "Руководство по настройке программного обеспечения" можно найти на Страницах поддержки продуктов LAN.

Сети VLAN можно создавать либо в режиме базы данных, либо в режиме глобальной настройки. В режиме глобальной настройки создаваемые сети VLAN должны иметь номера больше 1005. Для того чтобы создать эти сети VLAN, необходимо установить прозрачный режим VTP. VTP не объявляет сети VLAN, номера которых больше числа 1005. Кроме того, сети VLAN с номерами больше 1005 хранятся не в файле VLAN .dat, а в файле настроек коммутатора. В случае коммутаторов Catalyst 4000, оснащенных модулем Supervisor Engine IV, файл VLAN .dat, по умолчанию, находится в директории cat4000_flash.

Switch#dir cat4000_flash:

Directory of cat4000_flash:/

1 -rw- 676 <no date> vlan.dat

524260 bytes total (523584 bytes free)

Примечание: Коммутатор Catalyst 6500, который выполняет программное обеспечение Cisco IOS, позволяет вам создавать VLAN в режиме сервера без названия домена VTP.

Команда show vtp status выводит информацию о VTP на данном коммутаторе.

Switch#show vtp status

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xA4 0x18 0x78 0x52 0x5A 0x1B 0x2E 0x14
Configuration last modified by 0.0.0.0 at 5-28-01 05:17:02
Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface)
  1. Чтобы получить информацию о сети VLAN, воспользуйтесь командой show vlan.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Gi1/1, Gi1/2, Gi3/1, Gi3/2
                                                    Gi3/3, Gi3/4, Gi3/5, Gi3/6
                                                    Gi3/7, Gi3/8, Gi3/9, Gi3/10
                                                    Gi3/11, Gi3/12, Gi3/13, Gi3/14
                                                    Gi3/15, Gi3/16, Gi3/17, Gi3/18
    
    !--- Output suppressed.
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    
    Primary Secondary Type              Ports 
    ------- --------- ----------------- ------------------------------------------
  2. Установите требуемый режим работы (либо режим базы данных, либо режим глобальной настройки).

    Для того чтобы перейти в режим базы данных VLAN, в привилегированном режиме используйте команду vlan database.

    Switch#vlan database
    
    Switch(vlan)#
  3. Чтобы настроить сеть VLAN, воспользуйтесь командой vlan vlan_number.

    Switch(vlan)#vlan 2
    
    VLAN 2 added:
    Name: VLAN0002
    
    Switch(vlan)#apply
    
    APPLY completed.

    Примечание: Для конфигурации для вступления в силу можно или выполнить применять команду или выйти из VLAN database mode. Такие методы выхода из режима базы данных, как ключевое слово end или комбинация клавиш Ctrl-Z в режиме базы данных не функционируют. Чтобы выйти из режима базы данных, воспользуйтесь командой exit.

    Для того чтобы выполнить настройку сети VLAN в режиме глобальной настройки, используйте следующие команды:

    Switch(config)#vlan 3
    
    Switch(config-vlan)#exit
    
    Switch(config)#
  4. Для того чтобы в текущей конфигурации отобразить сети VLAN, имеющие номера выше 1005, используйте команду show run.

    Switch#show running-config
    
    Building configuration...
    
    Current configuration : 2975 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname Switch
    !
    !
    ip subnet-zero
    !
    spanning-tree extend system-id
    !
    redundancy
    mode rpr
    main-cpu
    auto-sync standard
    !
    !
    vlan 2000
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    
    !--- Output suppressed.
    
    

В программном обеспечении Cisco IOS интерфейсы (в отличие от коммутаторов, работающих под управлением CatOS) по умолчанию выключены (т.е. находятся в состоянии shutdown). При работе под управлением CatOS порт становится активным в том случае, если он определил наличие физического канала.

По умолчанию на коммутаторах Catalyst серий 3550, 3750 и 4500 интерфейсы программного обеспечения Cisco IOS являются интерфейсами 2-го уровня. На коммутаторах Catalyst серии 6500/6000 эти интерфейсы являются интерфейсами 3-го уровня. В режиме настройки интерфейса интерфейс можно настроить как интерфейс 2-го уровня, воспользовавшись для этого командой switchport. Если интерфейс работает в режиме 3-го уровня, тогда эту команду необходимо выполнить до того, как сети VLAN будет назначен интерфейс. Чтобы назначить интерфейс сети VLAN, используйте команду switchport access vlan vlan_number.

Примечание: Если интерфейс настроен как Интерфейс уровня 3, что означает, что команда no switchport настроена, вы не можете назначить интерфейс на VLAN.

Для того чтобы в ПО Cisco IOS можно было присоединить порты к сетям VLAN, необходимо выполнить следующие минимальные настройки:

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport

!--- This command is required if the interface is in Layer 3 mode.

Switch(config-if)#switchport access vlan 2

Switch(config-if)#no shutdown

Чтобы проверить статус интерфейса 2-го уровня, используйте команду show interface gigabitethernet module/interface switchport.

Switch#show interface gigabitethernet 3/1 switchport

Name: Gi3/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 2 (VLAN0002)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Voice VLAN: none (Inactive)
Appliance trust: none

Если порт настроен в качестве магистрального (т.е. он может передавать более одной сети VLAN), тогда можно воспользоваться командой switchport trunk native vlan. Данной командой можно воспользоваться в том случае, если собственная сеть VLAN данного интерфейса была изменена или если для нее требуется изменить установки по умолчанию. Собственная сеть VLAN - это такая сеть VLAN, которая используется в случае, если интерфейс требуется преобразовать в интерфейс 2-го уровня. Если собственная сеть VLAN не была задана явным образом, тогда сеть VLAN 1 по умолчанию становится собственной сетью VLAN. Обратите внимание, что в случае, когда данные пересылаются по собственной сети VLAN, заголовок IEEE 802.1Q не добавляется. Убедитесь, что на обоих соединенных устройствах магистральные порты (trunk ports) имеют одну и ту же собственную сеть VLAN. Несовпадение собственных сетей VLAN может, помимо прочего, вызвать проблемы с маршрутизацией между сетями VLAN.

Когда на двух коммутаторах Cisco обнаружено несовпадение собственных сетей VLAN, выводится следующее сообщение:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEhernet1/1 (2),
 with D-R3550-9B GigabitEthernet0/1 (1)

В данном примере на одном из коммутаторов собственной сетью VLAN является VLAN 2, в то время как на соседнем коммутаторе это сеть VLAN 1.

Чтобы получить информацию о собственной сети VLAN, об инкапсуляции и транкинге, используйте команду show interfaces module/interface trunk.

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 1
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

При использовании конфигурации по умолчанию собственной сетью VLAN является сеть VLAN 1. Чтобы изменить собственную сеть VLAN на интерфейсе, осуществляющем транкинг, используйте команду switchport trunk native vlan vlan_number.

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport trunk native vlan 2

Данная команда используется для того, чтобы проверить:

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 2
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Назначьте множественные порты на одиночную VLAN

Можно назначить несколько интерфейсов на коммутаторе к одиночной VLAN. Введите следующие команды:

  1. Switch(config)#interface range fastethernet [mod/slot - mod/slot]
    
  2. Switch(config-if-range)#switchport access vlan vlan_number
    
    
  3. Switch(config-if-range)#switchport mode access
    
  4. Switch(config-if-range)#no shut
    

Примечание: Команда interface range не поддерживается во всех выпусках ПО. Команда interface range поддерживается программным обеспечением Cisco IOS Release 12.1(13)EW и выше.

Удалите VLAN

Для удаления VLAN из Базы данных VLAN не выполните команду vlan vlan_number или в VLAN database mode или в режиме глобальной конфигурации. В этом примере для удаления сети VLAN 2 используется режим базы данных.

Switch#vlan database

Switch(vlan)#no vlan 2

Deleting VLAN 2...

Switch(vlan)#apply

APPLY completed.

При работе в режиме глобальной настройки сообщение об удалении сети VLAN в консоль не выводится. Однако чтобы убедиться в том, что сеть VLAN была удалена, можно воспользоваться командой show vlan.

Переименуйте VLAN

Для переименования VLAN от Базы данных VLAN выполните название vlan_name команда или в VLAN database mode или в режиме глобальной конфигурации.

Данный пример использует VLAN database mode для переименования VLAN 3:

Switch#vlan database

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Switch(vlan)#apply

APPLY completed.

Данный пример использует режим глобальной конфигурации для переименования VLAN 3:

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Для проверки выполните краткое описание show vlan или команду show vlan-switch brief.

switch#show vlan brief

VLAN  Name                             Status    Ports
---- -------------------------------- --------- -----------
 3    CISCO                            active    Fa0/3

Примечание: Когда вы переименовываете VLAN, необязательно для удаления VLAN, назначенной на порт с помощью команды vlan_number switchport access vlan.

Как изолировать Communiation между двумя VLAN

Этот раздел не обсуждает частные VLAN. Частные VLAN предоставляют изоляцию Уровня 2 между портами в то же частное VLAN (выделенный VLAN) или между частными VLAN (VLAN сообщества).

Существует два сценария для того, когда вы пытаетесь изолировать две VLAN.

Изоляция между двумя VLAN уровня 2

VLAN Уровня 2 является VLAN, созданной в коммутаторе и не настроенная с командой interface vlan <vlan_number>. Хосты в других VLAN Уровня 2 не могут связаться друг с другом.

Выполните эти шаги, чтобы создать VLAN Уровня 2 и изолировать ее от более старых VLAN:

  1. Создайте новую сеть VLAN в базе данных. При выходе из vlan database mode изменения конфигурации применены.

    Switch#vlan database
    
    !--- You must enter into VLAN database mode in order to 
    !--- configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#vlan 6
    VLAN 6 added:
        Name: VLAN0006
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. Удостоверьтесь, что VLAN создана в базе данных VLAN. Новая VLAN должна появиться в выходных данных команды show vlan.

  3. Сделайте "not set" IP-адрес к недавно созданные виртуальные локальные сети VLAN.

  4. Настройте физические интерфейсы для подключения клиента к соответствующей сети VLAN.

    Switch(config)#interface fastEthernet 2/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    
    witch(config)#interface fastEthernet 2/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 6
    Switch(config-if)#no shut
    
  5. Назначьте на каждый статический IP - адрес хоста A, маску подсети, и сделайте "not set" шлюз по умолчанию. Это заставляет хосты на портах fa 2/1 и 2/2 не связываться друг с другом. Устройства, которые принадлежат одной VLAN, не достигают ничего больше кроме устройств в той же VLAN.

Изоляция между двумя VLAN уровня 3

Когда вы создаете VLAN и назначаете IP-адрес с командой interface vlan <vlan_number>, VLAN становится VLAN Уровня 3. В Коммутаторах 3 уровня хосты между этими двумя VLAN могут связаться друг с другом (если хосты настроены со шлюзом по умолчанию как IP-адрес интерфейса виртуальной локальной сети (VLAN)). Можно использовать ACL для запрета связи между VLAN.

Этот раздел показывает пример того, как изолировать связь между недавно созданной VLAN Уровня 3 и более старой VLAN.

В данном примере эти 3750 коммутаторов имеют две старых VLAN (VLAN 1 и VLAN 2). Недавно созданная виртуальная локальная сеть VLAN является VLAN 5. VLAN 1, VLAN 2 и VLAN 5 являются VLAN Уровня 3. ACL внедрены для запрета трафика так, чтобы VLAN 1 и VLAN 2 не могли связаться с VLAN 5 и так, чтобы VLAN 5 не связывался или с VLAN 1 или с VLAN 2.

  • VLAN 1 - 10.10.10.0 / 24

  • VLAN 2 - 172.16.1.0 / 24

  • VLAN 5 - 192.168.1.0 / 24

  1. Создайте новую сеть VLAN в базе данных. В этом случае новая VLAN является VLAN 5. При выходе из vlan database mode изменения конфигурации применены.

    Switch#vlan database
    
    !--- You must enter into VLAN database mode
    !--- in order to configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. Удостоверьтесь, что VLAN создана в базе данных VLAN. Проверьте выходные данные команды show vlan.

  3. Установите IP-адрес для недавно созданная виртуальная локальная сеть VLAN.

    Switch(config)#interface vlan 5
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config)#no shut
    
  4. Настройте физические интерфейсы для подключения клиента к соответствующей сети VLAN.

    Switch(config)#interface fastEthernet 2/1 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    

    Необходимо настроить три access-lists, один для каждой VLAN.

    • Этот список доступа запрещает трафик, который прибывает из VLAN 1 для получения до VLAN 5.

      
      !--- Some of the commands in this output are wrapped
      !--- to a second line due to spatial reasons.
      
      Switch#configure terminal
      Switch(config)#access-list 101 deny 
      ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 101 permit ip 10.10.10.0 0.0.0.255 any
      
    • Этот список доступа запрещает трафик, который прибывает из VLAN 2 для получения до VLAN 5.

      Switch#configure terminal
      Switch(config)#access-list 102 deny ip 172.16.1.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 102 permit ip 172.16.1.0 0.0.0.255 any
      
    • Этот список доступа запрещает трафик, который прибывает из VLAN 5 для получения до VLAN 1 и VLAN 2.

      Switch#configure terminal
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 10.10.10.0 0.0.0.255
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
      Switch(config)#access-list 105 permit ip 192.168.1.0 0.0.0.255 any
      

    И как только они настроены, применяют списки доступа к interface VLAN 1, interface VLAN 2 и interface VLAN 5.

    Switch#configure terminal
    Switch(config)#interface vlan 1
    Switch(config-if)#ip access-group 101 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 2
    Switch(config-if)#ip access-group 102 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 5
    Switch(config-if)#ip access-group 105 in
    Switch(config-if)#end
    

Как настроить виртуальные локальные сети с расширенным диапазоном в коммутаторе серии Catalyst 6500

Для настройки расширенных VLAN на Коммутаторах серии Catalyst 6500 рабочая Cisco IOS необходимо ввести команду spanning-tree extend system-id. Затем расширенная VLAN должна быть создана в режиме конфигурации а не от vlan database mode.

Выполните эти шаги для создания расширенных VLAN на Коммутаторах серии Catalyst 6500, которые выполняют Cisco IOS:

  1. Подключитесь к коммутатору через консольный порт:

    Switch>enable
    Switch#
  2. Переход в режим конфигурирования:

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#
  3. Введите команду spanning-tree extend system-id в режим конфигурации:

    Switch(config)#spanning-tree extended system-id
    
  4. Введите команду vtp mode transparent в режим конфигурации:

    Switch(config)#vtp mode transparent
    
  5. Создайте VLAN в режиме конфигурации:

    Switch(config)#vlan 1311
    Notice
    Switch(config-vlan)#exit
    
  6. Выйдите из режима конфигурирования:

    Switch(config)#exit
    
  7. Чтобы получить информацию о сети VLAN, воспользуйтесь командой show vlan.

    Switch#show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    
    101  VLAN0101                         active    Gi4/8, Gi4/10
    1002 fddi-default                     act/unsup 
    1003 token-ring-default               act/unsup 
    1004 fddinet-default                  act/unsup 
    1005 trnet-default                    act/unsup 
    1311 VLAN1311                         active    
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0   
    101  enet  100101     1500  -      -      -        -    -        0      0   
    1002 fddi  101002     1500  -      -      -        -    -        0      0   
    1003 tr    101003     1500  -      -      -        -    -        0      0   
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0   
    1311 enet  101311     1500  -      -      -        -    -        0      0   

Советы по поиску и устранению неполадок

Этот раздел предоставляет советы по устранению проблем для типичных проблем, с которыми можно встретиться во время создания VLAN на Коммутаторах Catalyst, которые выполняют программное обеспечение Cisco IOS.

На коммутаторах, работающих под управлением программного обеспечения Cisco IOS, маршрутизацию между сетями VLAN можно реализовать при помощи самого коммутатора, не прибегая к использованию внешнего маршрутизатора. При создании интерфейса SVI сеть VLAN не создается в базе данных 2-го уровня автоматически. Чтобы включить интерфейс SVI, необходимо создать сеть VLAN в режиме базе данных VLAN или (в случае использования последних версий Cisco IOS) в режиме глобальной настройки. Для того чтобы интерфейс SVI работал в полнофункциональном режиме (это означает, что интерфейс активен в плане администрирования и что протокол линии передачи данных также активен), необходимо убедиться в том, что существует, по крайней мере, один порт, являющийся членом данной сети VLAN и имеется активное устройство подключенное к порту.

То же справедливо и для случаев, когда производится копирование настроек другого коммутатора или восстановление конфигураций тех сетей VLAN, которые были созданы в режиме базы данных VLAN. Также необходимо либо заменить файл базы данных VLAN (vlan.dat), либо создать сети VLAN повторно (см. процедуру в разделе Создание портов и сетей VLAN). При копировании настроек другого коммутатора база данных VLAN скопирована не будет.

Если VLAN Уровня 2 не создана на коммутаторе, интерфейсы SVI показывают как UP/DOWN в выходных данных команды show ip interface brief, когда конфигурация применена к коммутатору. Убедитесь в том, что все предыдущие сети VLAN были созданы в режиме базы данных VLAN. Либо убедитесь в том, что режим глобальной настройки сохранился после копирования конфигурации на данный коммутатор.

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Противоречивая ошибка значения TLB на коммутаторах IOS

Противоречивое трансляционное объединение с помощью мостов (TLB), ошибка значения происходит при создании VLAN на коммутаторе Cisco IOS, который недавно получил обновление VTP от Коммутатора CatOS или который был преобразован из CatOS. Это вызвано тем, что CatOS и Cisco IOS имеют некоторые другие значения по умолчанию для моста VLAN трансляции. Переводные VLAN преобразовывают Интерфейс для передачи распределенных данных по волоконно-оптическим каналам (FDDI) или Token Ring к Ethernet. Мост трансляции (TB) VLAN для VLAN 1, 1002 и 1003 являются другими в CatOS и 0 по умолчанию. VLAN моста трансляции заводской настройки в коммутаторах Cisco IOS:

Vlan ID      tb1        tb2
--------     -----     -----
1            1002      1003
1002         1         1003
1003         1         1002

Коммутатор Cisco IOS, который недавно получил обновление VTP от Коммутатора CatOS или который был преобразован из CatOS, перезаписывает значения TB по умолчанию. Когда вы пытаетесь создать любую VLAN после этого она генерирует это сообщение об ошибках:

VLAN 1002 TLB 1 VLAN 1 has inconsistent TLB values (0 / 0)

Как обходной путь для этой проблемы, измените значения по умолчанию TB коммутатора Cisco IOS для VLAN 1, 1002 и 1003 для соответствия со значениями CatOS.

switch#vlan data
switch(vlan)#no vlan 1002 tb-vlan1 tb-vlan2
switch(vlan)#no vlan 1003 tb-vlan1 tb-vlan2
switch(vlan)#apply
APPLY completed.
switch(vlan)#exit
APPLY completed.Exiting....

Восстановите Файл vlan.dat на Коммутаторах IOS

Для коммутаторов Cisco Catalyst, которые выполняют программное обеспечение Cisco IOS, сведения о виртуальной локальной сети (VLAN) находятся на отдельном файле, названном vlan.dat. Если файл vlan.dat удален случайно, и коммутатор повторно загружен, все VLAN, которые были доступны на коммутаторе, потеряны. Пока коммутатор не повторно загружен, сведения о виртуальной локальной сети (VLAN) присутствуют в коммутаторе.

Выполните эти шаги для восстановления файла vlan.dat:

  1. Выполните команду show vlan для подтверждения доступности сведений о виртуальной локальной сети (VLAN).

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/10, Fa0/11, Fa0/12, Gi0/1
                                                    Gi0/2
    10   VLAN0010                         active
    11   VLAN0011                         active
    20   VLAN0020                         active
    21   VLAN0021                         active
    30   VLAN0030                         active
    31   VLAN0031                         active
    40   VLAN0040                         active
    41   VLAN0041                         active
    50   Vlan50                           active
    100  100thVLAN                        active
  2. Если коммутатор находится в Сервере VTP или Прозрачном режиме, сделайте любые модификации к Базе данных VLAN.

    Модификации к Базе данных VLAN могут быть любым из них:

    • Создайте сеть VLAN.

    • Удалите сеть VLAN.

    • Модифицируйте свойства любой существующей VLAN.

    Если коммутатор находится в режиме Клиента VTP, сделайте модификации к Базе данных VLAN в любом Сервере VTP того же домена.

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 50
    
    Switch(config-vlan)#name 50thVLAN
    
    Switch(config-vlan)#end
    Switch#

    Как только любое изменение было сделано к Базе данных VLAN, коммутатор автоматически создает файл vlan.dat.

  3. Выполните команду show flash: для проверки создания файла vlan.dat.

    Switch#show flash:
    
    Directory of flash:/
    
        2  -rwx           5   Mar 01 1993 00:04:47  private-config.text
        3  -rwx     2980487   Mar 02 1993 06:08:14  c2950-i6q4l2-mz.121-19.EA1a.bin
        4  -rwx        1156   Mar 01 1993 01:51:27  vlan.dat
       16  -rwx        1014   Mar 01 1993 00:04:47  config.text
        6  drwx        4096   Mar 02 1993 03:49:26  html
        7  -rwx     3121383   Mar 02 1993 03:47:52  c2950-i6q4l2-mz.121-22.EA9.bin
    
    7741440 bytes total (65536 bytes free)

Подведенный для создания VLAN в расширенном диапазоне

Ошибка 1

% Failed to create VLANs [dec]
VLAN(s) not available in Port Manager.

Порты LAN (локальной сети) уровня 3, Интерфейсы WAN и подинтерфейсы, и некоторые программные характеристики, такие как RSPAN, используют внутренние виртуальные сети в расширенном диапазоне. Вы не можете использовать виртуальную локальную сеть с расширенным диапазоном, которая выделена для внутреннего пользования.

Для отображения VLAN, используемых внутренне, выполните команду show vlan internal usage. Можно настроить возрастающее внутреннее размещение VLAN (от 1006 и) или убывающее внутреннее размещение VLAN (от 4094 и вниз).

Switch(config)#vlan internal allocation policy {ascending | descending}


!--- Enter the ascending keyword to allocate internal VLANs from 1006 and up. 
!--- Enter the descending keyword to allocate internal VLAN from 4094 and down.

Switch(config)#end 
Switch#reload

caution Внимание: Вы не должны сразу выполнять команду повторной загрузки. Выполните команду повторной загрузки во время окна планового техобслуживания. Политика внутреннего размещения VLAN применена только после повторной загрузки.

Если перезагрузка устройства не является опцией как обходной путь, можно использовать Преобразование VLAN. На магистральных портах можно преобразовать один номер виртуальной локальной сети (VLAN) в другой номер виртуальной локальной сети (VLAN), который передает весь трафик, полученный в одной VLAN к другой VLAN. См. раздел Преобразования VLAN Настройки VLAN Настройки для получения дополнительной информации.

Примечание: Коммутаторы, которые выполняют программное обеспечение Семейства продуктов Catalyst, не поддерживают конфигурацию VLAN 1006-1024. Если вы настраиваете VLAN 1006-1024, гарантируете, что VLAN не расширяются ни на какие коммутаторы, которые выполняют программное обеспечение Семейства продуктов Catalyst.

Ошибка 2

%Failed to commit extended VLAN(s) changes

Когда вы пытаетесь создать Расширенные VLAN в Сервере или Клиентском режиме VTP, вы могли бы получить это сообщение.

Удостоверьтесь, что устройство (Коммутатор или маршрутизатор) находится в Прозрачном режиме при создании виртуальных локальных сетей с расширенным диапазоном. См. Протокол магистральных каналов VLAN раздел Рекомендаций Расширенного ИДЕНТИФИКАТОРА VLAN для получения дополнительной информации.

Подведенный для Настройки VLAN от Startup-Config

SW-VLAN-4-BAD-STARTUP-VLAN-CONFIG-FILE: Failed to configure VLAN from 
startup-config. Fallback to use VLAN configuration file from non-volatile memory

Это сообщение указывает, что программное обеспечение VLAN было не в состоянии использовать конфигурацию VLAN от файла загрузочной конфигурации. Конфигурация VLAN сохранена в файле vlan.dat. Файл vlan.dat находится в долговременной памяти. Когда Модуль супервизора заменен, vlan.dat пуст (0). На загрузке коммутатор сравнивает название домена VTP и режим VTP в файле загрузочной конфигурации и файле vlan.dat. Если значения не совпадают, коммутатор использует конфигурацию в файле vlan.dat.

Для выполнения завершенной резервной копии конфигурации файл vlan.dat должен быть включен в резервную копию с конфигурацией. Администратор сети должен загрузить и файл vlan.dat и файл конфигурации для восстановления завершенной конфигурации.

Резервная копия и Восстановление vlan.dat на Коммутаторах Cisco IOS

Для создания копии vlan.dat выполните этот шаг:

Скопируйте файл vlan.dat от NVRAM устройства до сервера TFTP или внешней карты PCMCIA.

copy const_nvram:vlan.dat tftp:

Примечание: Место в памяти, где файл vlan.dat хранится, варьируется с устройства на устройство. В Cisco Catalyst 6500/6000 Коммутаторы Серии, это - const_nvram:. Так же для коммутаторов Catalyst 4500/4000, это - cat4000_flash:. См. документацию соответствующего продукта прежде, чем дать команду копии.

Для восстановления файла vlan.dat выполните эти шаги:

  1. Скопируйте файл vlan.dat в NVRAM устройства от сервера TFTP или внешней карты PCMCIA.

    copy tftp: const_nvram:
  2. Повторно загрузите коммутатор, поскольку vlan.dat только для чтения во время процесса загрузки.

Сбои Создания VLAN с VLAN 1003 порождают Сообщение об ошибках пропавших без вести VLAN

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 102
Switch(config-vlan)#name marketing
Switch(config-vlan)#exit
VLAN 1003 parent VLAN missing
APPLY VLAN changes failed.
Switch(config)#end
Switch#

Неверная конфигурация на коммутаторе может заставить обновления конфигурации VTP отказывать. В большинстве случаев проблема состоит в том, что новая VLAN, созданная в коммутаторе сервера VTP, не распространяется к коммутаторам клиента VTP, который создает проблемы с подключением хоста.

Типичная причина для этой проблемы является несоответствием версии VTP между коммутаторами в домене VTP. Версия VTP 1 и версия VTP 2 не совместимы на сетевых устройствах в том же домене VTP. Способное сетевое устройство версии VTP 2 может работать с сетевым устройством, которое выполняет версию VTP 1, при условии, что версия VTP 2 отключена на версии VTP 2 способное сетевое устройство. Версия VTP 2 отключена по умолчанию. Каждое сетевое устройство в домене VTP должно использовать ту же версию VTP. Проверьте версию VTP, которая работает на коммутаторе. Если версия VTP 2 включена, отключите ее для решения этого вопроса.

Проверьте, настроен ли коммутатор должным образом для других параметров VTP:

  • Проверьте, что коммутаторы связаны через магистральные линии, потому что обновлениями VTP только обмениваются по магистральным линиям.

  • Проверьте, что название домена VTP является точно тем же на соответствующих коммутаторах. Имя чувствительно к регистру. Обновлениями VTP только обмениваются между коммутаторами в том же домене VTP.

  • Проверьте, что пароль VTP является точно тем же на всех коммутаторах в домене. Пароль учитывает регистр. Если пароль настроен, это должно быть настроенный на всех коммутаторах в домене, и пароль должен быть тем же.

В случае проблемы конвергенции VTP, где клиент VTP не обновляет сведения о виртуальной локальной сети (VLAN), обходной путь должен вызвать конвергенцию VTP созданием, тогда удалением фиктивной VLAN на сервере VTP. Это инкрементно увеличивает номер версии и вынуждает все клиенты VTP обновить свою Базу данных VLAN.


Дополнительные сведения


Document ID: 10023