Протокол IP : Групповая IP-адресация

Краткое руководство по настройке многоадресной конфигурации

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание

PGM
MRM

Введение

Мультиадресная рассылка IP — это технология, предназначенная для экономии пропускной способности. Она сокращает объем трафика за счет параллельной доставки одного информационного потока тысячам корпоративных получателей и домовладений. В числе приложений, которые получат преимущества при использовании мультиадресной рассылки видеоконференции, корпоративные коммуникации, дистанционное обучение и распространение программного обеспечения, котировок акций и новостей. В этом документе рассматриваются основы конфигурации мультиадресной рассылки для различных сетевых сценариев.

Предварительные условия

Требования

Cisco рекомендует, чтобы читателям данной документации передавали базовые знания в многоадресном режиме о Протоколе IP.

Примечание: См. документацию Групповой адресации Протокола Интернета для получения дополнительной информации.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Режим уплотнения

Cisco рекомендует по возможности использовать разреженный режим PIM (Protocol Independent Multicast), в частности Auto-RP, особенно в новых средах. Однако, если необходим режим высокой плотности, настройте глобальную команду ip multicast-routing и команду интерфейса ip pim sparse-dense-mode для каждого интерфейса, который должен обрабатывать многоадресный трафик. Общее для всех конфигураций в этом документе требование – это глобальное настраивание многоадресной рассылки и настраивание PIM для интерфейсов. С Cisco IOS� Sotware Выпуск 11.1, можно настроить интерфейсный режим уплотнения ip pim команд и ip pim sparse-mode одновременно с команда ip pim sparse-dense-mode . В этом случае считается, что интерфейс находится в режиме высокой плотности, если группа в этом режиме. Если группа находится в режиме sparse-mode (например, если RP известен), то интерфейс также рассматривается как sparse-mode.

Примечание: Источник во всех примерах этого документа – это источник многоадресного трафика, а Получатель – получатель многоадресного трафика.

/image/gif/paws/9356/mcast1.gif

Конфигурация RouterA
ip multicast-routing 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode  

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode

Конфигурация маршрутизатора B
ip multicast-routing 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Разреженный режим с одним RP

В этом примере маршрутизатор А — процессор маршрутизации, который, как правило, является ближайшим маршрутизатором к источнику. Для статической конфигурации RP необходимо наличие одинаковой конфигурации команд ip pim rp-address на всех доменах PIM. Можно настроить несколько RP, но только по одному RP на группу.

/image/gif/paws/9356/mcast2.gif

Конфигурация RouterA
ip multicast-routing 
ip pim rp-address 1.1.1.1
 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address 1.1.1.1 255.255.255.0 
ip pim sparse-dense-mode 

Конфигурация маршрутизатора B
ip multicast-routing 
ip pim rp-address 1.1.1.1 


interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Разреженный режим с несколькими процессорами маршрутизации

В этом примере источник Source-A отправляет данные по адресам 224.1.1.1, 224.1.1.2 и 224.1.1.3. Источник Source-B отправляет данные по адресам 224.2.2.2, 224.2.2.3 и 224.2.2.4. Один из маршрутизаторов — RP 1 или RP 2 — может быть процессором маршрутизации для всех групп. Однако, если вы хотите, чтобы разные процессоры маршрутизации обрабатывали разные группы, все маршрутизаторы должны включать группы, которые будет обслуживать процессор маршрутизации. Данный тип конфигурации статического процессора маршрута требует, чтобы все маршрутизаторы домена PIM имели одинаково настроенные команды ip pim rp-addressaddress acl. Кроме того, для создания подобной конфигурации можно использовать более простую в настройке функцию Auto-RP.

/image/gif/paws/9356/mcast3.gif

Конфигурация RP 1
ip multicast-routing 
 
ip pim RP-address 1.1.1.1 2
ip pim RP-address 2.2.2.2 3 
 
access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4

Конфигурация RP 2
ip multicast-routing
  
ip pim RP-address 1.1.1.1 2 
ip pim RP-address 2.2.2.2  3
 
access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3 
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4 

Конфигурация маршрутизаторов 3 и 4
ip multicast-routing 
ip pim RP-address 1.1.1.1  2 
ip pim RP-address 2.2.2.2  3
 

access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3 
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4 

Автоматическая обработка маршрутов с одним обработчиком

Для функции Auto-RP необходимо настроить процессоры маршрутизации на объявление о своей доступности в качестве процессоров маршрутизации и агентов сопоставления. Процессоры маршрутизации используют адрес 224.0.1.39 для отправки объявлений. Агент сопоставления RP прослушивает объявленные пакеты из протоколов RP и направляет результаты сопоставления RP и группы в сообщении об обнаружении, направляемом в 224.0.1.40. Эти сообщения обнаружения используются оставшимися маршрутизаторами для составления их карты RP-to-group. Можно использовать один процессор маршрутизации, который также будет служить агентом сопоставления, или настроить несколько процессоров маршрутизации и агентов сопоставления для избыточности.

Обратите внимание, что при выборе интерфейса для объявлений процессоров маршрутизации Cisco рекомендует использовать интерфейс возвратной петли вместо физического интерфейса. Кроме того, возможно использовать Коммутируемые Интерфейсы виртуальной локальной сети (VLAN) (SVI). Если интерфейс виртуальной локальной сети (VLAN) используется для объявления об адресе RP, то опция interface-type в ip pim [vrf-name VRF] send-rp-announce {interface-type interface-number | IP-адрес} команда значения ТТЛ-схемы области должна содержать интерфейс виртуальной локальной сети (VLAN) и номер виртуальной локальной сети (VLAN). Например, команда похожа на ip pim send-rp-announce , которого Vlan500 определяют объем 100. Если вы выбираете физический интерфейс, необходимо гарантировать его постоянную доступность. Это не всегда возможно, и если физический интерфейс отключается, маршрутизатор перестанет объявлять себя процессором маршрутизации. В то же время, интерфейс возвратной петли никогда не отключается, что позволяет маршрутизатору объявлять себя процессором маршрутизации через любой доступный интерфейс. Он продолжает работу, даже если один или несколько физических интерфейсов маршрутизатора выходят из строя. Интерфейс возвратной петли должен поддерживать PIM и объявляться с помощью протокола IGP, или он должен быть достижим с помощью статической маршрутизации.

/image/gif/paws/9356/mcast4.gif

Конфигурация RouterA
ip multicast-routing 
 
ip pim send-rp-announce loopback0 scope 16


ip pim send-rp-discovery

 scope 16 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Конфигурация маршрутизатора B
ip multicast-routing 


interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Автоматическая процедура восстановления с несколькими процедурами

Приведенные в примере списки доступа позволяют использовать процессоры маршрута (RP) только для указанных групп. Если не настроен ни один список доступа, то процессоры маршрута доступны для всех групп. Когда два процессора маршрутизации объявляют о своей готовности стать процессором маршрутизации в одной и той же группе (группах), агент (агенты) разрешают такие конфликты в пользу обладателя наибольшего IP-адреса.

Когда два маршрутизатора объявляют себя процессорами маршрутизации для этой группы, настройте адрес возвратной петли на каждом маршрутизаторе, чтобы определить, какой маршрутизатор будет процессором маршрутизации для той или иной группы. Установите более высокий IP-адрес для предпочтительного процессора маршрутизации, затем используйте интерфейс возвратной петли в качестве источника пакетов объявления ip pim send-RP-announce loopback0. При использовании нескольких агентов сопоставления каждый из них объявляет одну группу для сопоставлений RP и группы обнаружения 224.0.1.40.

mcast5.gif

Конфигурация RP 1
ip multicast-routing
 
interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode  
 
ip pim send-RP-announce loopback0 scope 16 group-list 1
ip pim send-RP-discovery scope 16 


access-list 1 permit 239.0.0.0 0.255.255.255 

Конфигурация RP 2
ip multicast-routing
 
interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
ip pim send-RP-announce loopback0 scope 16 group-list 1
ip pim send-RP-discovery scope 16 


access-list 1 deny 239.0.0.0 0.255.255.255 
access-list 1 permit 224.0.0.0 15.255.255.255 

См. Руководство к Конфигурации auto-rp и Диагностике для получения дополнительной информации о Auto-RP.

DVMRP

Поставщик услуг Интернета (ISP) может предложить создать туннель протокола DVMRP к ISP для того, чтобы получить доступ к магистрали мультиадресной рассылки в Интернете (mbone). Минимальный набор команд, необходимый для настройки туннеля DVMRP, приведен ниже:

interface tunnel0  
ip unnumbered <any pim interface>
tunnel source <address of source>
tunnel destination <address of ISPs mrouted box> 
tunnel mode dvmrp  
ip pim sparse-dense-mode

Как правило, ISP размещает туннель на компьютере UNIX в режиме "mrouted" (DVMRP). Если ISP размещает туннель на другом устройстве Cisco, необходимо использовать режим туннеля GRE по умолчанию.

Если вы хотите создавать мультиадресные пакеты для других пользователей магистрали мультиадресной рассылки (mbone), а не получать их, необходимо объявить исходные подсети. Если адрес узла мультиадресной рассылки — 131.108.1.1, необходимо объявить о существовании этой подсети в магистрали mbone. Напрямую связанные сети по умолчанию объявляются с метрикой 1. Если ваш источник не имеет прямого подключения к маршрутизатору с туннелем DVMRP, задайте следующие параметры для интерфейса tunnel0:

ip dvmrp metric 1 list 3  
access-list 3 permit 131.108.1.0 0.0.0.255

Примечание: Необходимо включать список доступа с этой командой для предотвращения объявления всей таблицы одноадресной маршрутизации к mbone.

Если ваша конфигурация аналогична конфигурации, представленной здесь, и необходимо распространить маршруты DVMRP через домен, настройте команду ip dvmrp unicast-routing на интерфейсах serial0 маршрутизаторов A и B. Это действие позволит пересылать данные маршрутов DVMRP соседям PIM, имеющим таблицу маршрутизации DVMRP, которая используется для функции RPF (Reverse Path Forwarding). Известные DVMRP маршруты имеют приоритет в переадресации по обратному пути над остальными протоколами, за исключением непосредственно связанных маршрутов.

/image/gif/paws/9356/mcast6.gif

MBGP

Протокол MBGP — это основной метод переноса двух наборов маршрутов: один набор для одноадресной маршрутизации и второй — для мультиадресной. MBGP предоставляет управления непосредственно для задания пропускания потока многоадресных пакетов. PIM использует маршруты, связанные с мультиадресной маршрутизацией, для создания деревьев распространения данных. MBGP обеспечивает путь RPF, а не создание многоадресного состояния. Однако PIM необходим для пересылки мультиадресных пакетов.

/image/gif/paws/9356/mcast7.gif

Конфигурация RouterA
ip multicast-routing 


interface loopback0 
ip pim sparse-dense-mode 
ip address 192.168.2.2 255.255.255.0 


interface serial0 
ip address 192.168.100.1 255.255.255.0 


interface serial1 
ip pim sparse-dense-mode 
ip address 192.168.200.1 255.255.255.0 


router bgp 123 
network 192.168.100.0 nlri unicast 
network 192.168.200.0 nlri multicast 
neighbor 192.168.1.1 remote-as 321 nlri unicast multicast 
neighbor 192.168.1.1 ebgp-multihop 255 
neighbor 192.168.100.2 update-source loopback0 
neighbor 192.168.1.1 route-map setNH out 


route-map setNH permit 10 
match nlri multicast 
set ip next-hop 192.168.200.1 


route-map setNH permit 20 

Конфигурация маршрутизатора B
ip multicast-routing 


interface loopback0 
ip pim sparse-dense-mode 
ip address 192.168.1.1 255.255.255.0 


interface serial0 
ip address 192.168.100.2 255.255.255.0 


interface serial1 
ip pim sparse-dense-mode 
ip address 192.168.200.2 255.255.255.0 


router bgp 321 
network 192.168.100.0 nlri unicast 
network 192.168.200.0 nlri multicast 
neighbor 192.168.2.2 remote-as 123 nlri unicast multicast 
neighbor 192.168.2.2 ebgp-multihop 255 
neighbor 192.168.100.1 update-source loopback0 
neighbor 192.168.2.2 route-map setNH out 


route-map setNH permit 10 
match nlri multicast 
set ip next-hop 192.168.200.2 


route-map set NH permit 20 

Если ваша индивидуальная рассылка и топология групповой адресации являются конгруэнтными (например, они пробегаются через ту же ссылку), основное различие в конфигурации с командой nlri unicast multicast. Пример выходных данных команды приводится ниже:

network 192.168.100.0 nlri unicast multicast

Совмещающиеся топологии с MBGP имеют преимущество, несмотря на то, что трафик проходит через один путь, к одноадресному и мультиадресному потокам BGP можно применить разные политики.

Дополнительные сведения о MBGP см. в документе Что такое MBGP.

MSDP

MSDP (Multicast Source Discovery Protocol) подключает несколько доменов PIM-SM. Каждый домен PIM-SM использует собственный, независимый процессор (процессоры) маршрутизации и не зависит от процессоров маршрутизации в других доменах. MSDP позволяет обнаруживать в доменах источники многоадресной рассылки из других доменов. Если вы также используете BGP-подключение к узлу MSDP необходимо использовать один IP-адрес для MSDP и BGP. Когда MSDP выполняет одноранговые PRF проверки, MSDP ожидает, что одноранговый адрес MSDP будет совпадать с адресом, который выдает BGP/MBGP при выполнении поиска в таблице маршрутизации по RP в SA сообщении. Однако вам не обязательно запускать BGP/MBGP на одноранговом устройстве MSDP, если между одноранговыми MSDP уже имеется маршрут на основе BGP/MBGP. Если путь BGP/MBGP отсутствует и имеется несколько точек вызова MSDP, следует использовать команду ip msdp default-peer. В следующем примере показано, что процессор маршрутизации A является процессором маршрутизации для своего домена, а процессор маршрутизации B — процессором маршрутизации для своего домена.

mcast8.gif

Конфигурация RouterA
ip multicast-routing 


ip pim send-RP-announce loopback0 scope 16
ip pim send-RP-discovery scope 16 


ip msdp peer 192.168.100.2 
ip msdp sa-request 192.168.100.2 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface serial0 
ip address 192.168.100.1 255.255.255.0 
ip pim sparse-dense-mode 

Конфигурация маршрутизатора B
ip multicast-routing 

ip pim send-RP-announce loopback0 scope 16 
ip pim send-RP-discovery scope 16 


ip msdp peer 192.168.100.1 
ip msdp sa-request 192.168.100.1 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface serial0 
ip address 192.168.100.2 255.255.255.0 
ip pim sparse-dense-mode 

Маршрутизация с мультивещанием

Многоадресная маршрутизация с использованием заглушек позволяет настроить удаленные маршрутизаторы с заглушками в качестве агентов IGMP-прокси. Вместо того, чтобы принимать полноценное участие в PIM, эти шлейфные маршрутизаторы переадресуют сообщения IGMP от узла (узлов) мультиадресному маршрутизатору более высокого уровня.

/image/gif/paws/9356/mcast9.gif

Конфигурация маршрутизатора 1
int s0 
ip pim sparse-dense-mode 
ip pim neighbor-filter 1 


access-list 1 deny 140.1.1.1

Команда ip pim neighbor-filter нужна затем, чтобы маршрутизатор 1 не распознал маршрутизатор 2 в качестве соседа PIM. Если маршрутизатор 1 настроен для работы в разреженном режиме, использование фильтра соседа не требуется. Маршрутизатор 2 не должен работать в разреженном режиме. Работая в режиме уплотнения, шлейфные источники мультиадресных пакетов могут выполнять лавинную рассылку среди маршрутизаторов магистрали.

Конфигурация второго маршрутизатора
ip multicast-routing 
int e0 
ip pim sparse-dense-mode 
ip igmp helper-address 140.1.1.2 


int s0 
ip pim sparse-dense-mode 

IGMP UDLR для спутниковых каналов связи

Протокол UDLR (Unidirectional Link Routing) предоставляет методы переадресации мультиадресных пакетов через ненаправленные спутниковые каналы в шлейфные сети с обратным каналом. Это аналогично многоадресной маршрутизации с использованием заглушек. Без этой функции маршрутизатор восходящей линии не сможет динамически получать групповые IP-адреса по каналу с однонаправленной маршрутизацией, т. к. маршрутизатор нисходящей линии не сможет передавать данные.

mcast10.gif

Конфигурация Uplink-RTR
ip multicast-routing 


interface Ethernet0 
description Typical IP multicast enabled interface 
ip address 12.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 


interface Ethernet1 
description Back channel which has connectivity to downlink-rtr 
ip address 11.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 


interface Serial0 
description Unidirectional to downlink-rtr 
ip address 10.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp unidirectional-link 
no keepalive 

Конфигурация нисходящего маршрутизатора
ip multicast-routing 


interface Ethernet0 
description Typical IP multicast enabled interface 
ip address 14.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp helper-address udl serial0 


interface Ethernet1 
description Back channel which has connectivity to downlink-rtr 
ip address 13.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 


interface Serial0 
description Unidirectional to uplink-rtr 
ip address 10.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp unidirectional-link 
no keepalive 

PIMv2 BSR

Если все маршрутизаторы сети используют PIMv2, можно настроить BSR вместо Auto-RP. Функции BSR и Auto-RP очень похожи. Для конфигурации BSR необходимо настроить кандидаты в BSR (аналогично объявлению процессоров маршрутизации в Auto-RP) и BSR (аналоги агентов сопоставления в Auto-RP). Чтобы настроить BSR, выполните следующие действия:

  1. На коммутаторе BSR конфигурируют:

    ip pim bsr-candidate interface hash-mask-len pref

    Где interface содержит IP-адреса кандидатов в BSR. Рекомендуется (но не требуется), чтобы значение hash-mask-Len было одинаковым для всех BSR-кандидатов. Кандидат BSR с наибольшим значением pref будет выбран BSR для данного домена.

    Пример использования команды приведен ниже:

    ip pim bsr-candidate ethernet0 30 4

    PIMv2 BSR собирает данные о кандидате в процессоры маршрутизации, а также распространяет данные о наборах процессоров маршрутизации, связанных с каждым групповым префиксом. Чтобы исключить критическую точку отказа, можно настроить несколько маршрутизаторов в домене в качестве кандидатов в BSR.

    BSR выбирается из кандидатов в BSR автоматически, на основе заданных значений "pref". Чтобы быть кандидатом в BSR маршрутизатор должен быть подключен и находиться в магистрали сети, а не в области коммутируемых соединений.

  2. Настройка маршрутизаторов — кандидатов в процессоры маршрутизации. В этом примере изображается кандидат в процессоры маршрутизации на интерфейсе ethernet0, для всего диапазона адресов admin-scope:

    access-list 11 permit 239.0.0.0 0.255.255.255
    ip pim rp-candidate ethernet0 group-list 11

CGMP

Чтобы настроить протокол CGMP (Group Management Protocol), задайте следующие параметры интерфейса маршрутизатора, к которому подключен коммутатор:

ip pim sparse-dense-mode 
ip cgmp

Затем задайте следующие параметры на коммутаторе:

set cgmp enable

Отслеживание IGMP

Отслеживание IGMP (Internet Group Management Protocol) доступно в версии 4.1 модели Catalyst 5000. Для отслеживания IGMP требуется плата Supervisor III. Для отслеживания IGMP на маршрутизаторе требуется только настройка PIM. Маршрутизатор с ограничением рассылки сообщение IGMP по-прежнему необходим для обеспечения запроса IGMP.

В примере показано, как включить отслеживание IGMP на маршрутизаторе:

Console> (enable) set igmp enable  
IGMP Snooping is enabled.  
CGMP is disabled. 

Если попытаться включить IGMP при включенном CGMP, то будет выдано следующее:

Console> (enable) set igmp enable  
Disable CGMP to enable IGMP Snooping feature. 

PGM

Прагматическая общая многоадресная передача (PGM) является надежным протоколом многоадресной передачи данных для приложений, которым необходимо осуществлять доставку упорядоченных недублированных многоадресных данных от нескольких источников к нескольким получателям. PGM гарантирует, что приемник в группе либо принимает все пакеты данных из трансляций и ретрансляций, либо может обнаружить безвозвратную потерю пакета данных.

Не существует глобальных команд PGM. Протокол PGM настраивается для отдельных интерфейсов с помощью команды ip pgm. Необходимо настроить мультиадресную маршрутизацию на маршрутизаторе с интерфейсом, на котором включен PIM.

MRM

Инструмент MRM (Multicast Routing Monitor) упрощает автоматизированное обнаружение ошибок в крупных средах мультиадресной маршрутизации. Функция MRM предназначена для оповещения сетевого администратора о возникающих проблемах многоадресной маршрутизации режиме, приближенном к режиме реального времени.

В MRM входит два компонента: Тестер MRM (MRM Tester) и диспетчер MRM (MRM Manager). Тестер MRM является отправителем и/или получателем.

Инструмент MRM доступен в программном обеспечении Cisco IOS версии 12.0(5)T и выше. Только тестеры и управляющие программы системы управления ресурсами среды требуют выполнения программ Cisco, поддерживающих MRM, версии IOS.

/image/gif/paws/9356/mcast11.gif

Конфигурация тестового передающего устройства
interface Ethernet0 
  ip mrm test-sender 

Конфигурация получателя тестовых сообщений
interface Ethernet0 
  ip mrm test-receiver 

Конфигурация диспетчера тестирования
ip mrm manager test1 
 manager e0 group 239.1.1.1 
 senders 1 
 receivers 2 sender-list 1 


 access-list 1 permit 10.1.1.2 
 access-list 2 permit 10.1.4.2 

Выходные данные от команды show ip mrm manager на Менеджере проверки показывают здесь:

Test_Manager# show ip mrm manager 
   Manager:test1/10.1.2.2 is not running 
     Beacon interval/holdtime/ttl:60/86400/32 
     Group:239.1.1.1, UDP port test-packet/status-report:16384/65535 
     Test sender: 
       10.1.1.2 
     Test receiver: 
       10.1.4.2

Запустите тест с помощью следующей команды. Диспетчер проверки отправляет сообщения об управлении отправителю и получателю теста согласно настройкам в параметрах теста. Компонент Test Receiver присоединяется к группе и отслеживает тестовые пакеты от компонента Test Sender.

Test_Manager# mrm start test1 
 *Feb  4 10:29:51.798: IP MRM test test1 starts ......  
Test_Manager#

Для отображения отчета о состоянии для компонента Test Manager, введите следующую команду:

Test_Manager# show ip mrm status  

IP MRM status report cache:  
Timestamp        Manager          Test Receiver   Pkt Loss/Dup (%)       Ehsr  
*Feb  4 14:12:46 10.1.2.2         10.1.4.2        1            (4%)      29  
*Feb  4 18:29:54 10.1.2.2         10.1.4.2        1            (4%)      15  
Test_Manager#

Выходные данные показывают, что получатель отправил два отчета о состоянии (по одной строке каждый) для указанной временно метки. Каждый отчет содержит данные об одной потере пакета в рамках окна интервала (одна секунда по умолчанию). Значение "Ehsr" представляет следующее (приблизительное) значение порядкового номера для компонента Test Sender. Если компонент Test Receiver обнаруживает дублированные пакеты, он выводит отрицательное число в столбце "Pkt Loss/Dup".

Чтобы остановить тест, введите следующую команду:

Test_Manager# mrm stop test1 
*Feb  4 10:30:12.018: IP MRM test test1 stops  
Test_Manager# 

При запуске теста компонент MRM Sender начинает отправлять RTP-пакеты по настроенному групповому адресу с интервалом по умолчанию 200 мс. Компонент MRM Receiver отслеживает (ожидает) получение одинаковых пакетов через одинаковый интервал по умолчанию. Если приемник обнаруживает потерю пакета в течение интервала окна по умолчанию, равного 5 секундам, то он посылает отчет диспетчеру MRM. Чтобы получить отчет о состоянии получателя, введите команду show ip mrm status в MRM Manager.

Устранение неисправностей

Некоторые из распространенных проблем внедрения мультиадресной рассылки IP в сети возникают, когда маршрутизатор не переадресует мультиадресный трафик из-за сбоя RPF или параметров TTL. См. руководство по устранению неполадок многоадресного IP для получения подробных сведений об этих и других распространенных проблемах, симптомах и решениях.


Дополнительные сведения


Document ID: 9356