Протокол IP : Протокол HSRP

Функции и компоненты протокола маршрутизатора горячего резерва

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (23 марта 2008) | Английский (22 августа 2015) | Отзыв


Содержание

ISL

Введение

В этом документе описываются функции и возможности протокола HSRP (Hot Standby Router Protocol).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Фоновый режим и операции HSRP

Единственным способом добиться почти 100-процентного времени доступности сети является использование протокола HSRP, который предоставляет избыточность сети для IP-сетей, обеспечивая немедленное и прозрачное восстановление пользовательского трафика, начиная от сбоев первого узла в граничных сетевых устройствах или каналах доступа.

Благодаря разделению IP-адреса и MAC-адреса (уровень 2), два и более маршрутизатора могут действовать как единый "виртуальный" маршрутизатор. Члены группы виртуальных маршрутизаторов продолжительно обмениваются сообщениями статуса. Это позволяет маршрутизаторам подменять другие маршрутизаторы при их запланированном или незапланированном отключении. Узлы продолжают перенаправлять IP-пакеты на согласованный IP- и MAC-адрес, и переключение устройств, производящих маршрутизацию, происходит прозрачно.

Механизмы обнаружения динамического маршрутизатора

Ниже приведены описания динамических механизмов обнаружения маршрутизатора, которые доступны узлам. Многие из этих механизмов не обеспечивают способность сети к восстановлению, требуемую сетевыми администраторами. Это может произойти, так как протокол не был изначально предназначен для обеспечения устойчивости сети или управление протоколом не осуществимо для хостов в сети. Помимо сведений, которые приводятся ниже, важно учесть, что многие узлы допускают только настройку шлюза по умолчанию.

Протокол разрешения адреса прокси

Некоторый Ip host использует протокол разрешения proxy - адресации (ARP) для выбора маршрутизатора. Если узел выполняет задачу ARP прокси, он посылает запрос ARP на IP-адрес удаленного сайта, с которым требуется установить связь. Маршрутизатор А в сети отвечает от имени удаленного хоста и сообщает свой собственный МАС-адрес. С прокси-ARP хост функционирует так, как будто удаленный хост подключен к тому же самому сегменту сети. Если на маршрутизаторе A возникнет сбой, узел продолжит пересылать пакеты по назначению удаленному узлу по MAC-адресу маршрутизатора A, даже если этим пакетам некуда пересылаться и они являются потерянными. Можно либо дождаться запроса протоколом ARP MAC-адреса другого маршрутизатора (маршрутизатора Б) в локальном сегменте путем передачи нового ARP-запроса, либо перезагрузить узел, что вынудит его послать ARP-запрос. В обоих случаях узел будет не в состоянии обмениваться данными с удаленным узлом в течение значительного периода времени, несмотря на то, что ситуация предусмотрена протоколом, а маршрутизатор Б готов передавать пакеты, которые должны были проходить через маршрутизатор А.

Протокол динамической маршрутизации

Некоторый выполненный Ip host (или ищейка) протокол динамической маршрутизации, такой как Протокол RIP или Открытый путь Shortes сначала (OSPF) для обнаружения маршрутизаторов. Недостаток использования RIP заключается в том, что он медленно адаптируется к изменениям топологии. Выполнение протокола динамической маршрутизации на каждом хосте может не быть допустимым по некоторым причинам, включая административные издержки, издержки обработки данных, проблемы безопасности или недостаточность реализации протокола на некоторых платформах.

Протокол обнаружения маршрутизатора ICMP

leavingcisco.comКогда маршрут становится недоступным, некоторый более новый Ip host использует Протокол обнаружения маршрутизатора ICMP (IRDP) (RFC 1256) для обнаружения нового маршрутизатора. Хост, на котором запущен протокол IRDP, отслеживает мультиадресные сообщения приветствия от текущего маршрутизатора, и выбирает альтернативный маршрутизатор, когда перестает получать эти сообщения. Значения таймера по умолчанию IRDP показывают, что он не применим для обнаружения сбоев при первом переходе. Стандартная частота оповещения – один раз в 7-10 минут, а стандартный срок действия – 30 минут.

Протокол динамической настройки узла сети

Протокол DHCP (динамического конфигурирования узла) (RFC 1531 leavingcisco.com) предоставляет механизм для мимолетных сведений о конфигурации к хостам в сети TCP/IP. Узел, использующий DHCP-клиент, запрашивает сведения о конфигурации с DHCP-сервера при загрузке в сети. Обычно эти данные включают IP-адрес и шлюз по умолчанию. Механизм переключения на альтернативный маршрутизатор при сбое шлюза по умолчанию отсутствует.

Работа HSRP

Большой класс устаревших реализаций главного хоста, которые не поддерживают динамическое обнаружение, способен к настройке маршрутизатора по умолчанию. Запуск механизма динамического обнаружения маршрутизатора на каждом главном компьютере может быть невыполним по нескольким причинам, включая административные затраты и затраты на обработку, проблемы безопасности или невозможность реализации протокола для некоторых платформ. HSRP предоставляет таким узлам возможности аварийного переключения.

При использовании HSRP несколько маршрутизаторов могут работать совместно, создавая иллюзию одного виртуального маршрутизатора для узлов локальной сети. Эта серия известна как группа HSRP или резервная группа. Один маршрутизатор, выбранный из группы, отвечает за пересылку пакетов, которые узлы посылают на виртуальный маршрутизатор. Этот маршрутизатор известен как активный. Еще один маршрутизатор выбирается резервным маршрутизатором. В случае сбоя активного маршрутизатора, резервный берёт на себя обязанности по переадресации пакетов активного маршрутизатора. Хотя HSRP может работать на любом количестве маршрутизаторов, только активный маршрутизатор может переадресовать пакеты, отправленные на виртуальный.

Чтобы минимизировать сетевой трафик, только активные маршрутизаторы и маршрутизаторы в режиме ожидания посылают периодические сообщения HSRP после завершения протоколом процесса выбора. Если происходит сбой активного маршрутизатора, то начинает работу резервный маршрутизатор. Если резервный маршрутизатор отключается или становится активным маршрутизатором, в качестве резервного выбирается другой маршрутизатор.

В особой LAN несколько горячих резервных групп могут сосуществовать и перекрывать друг друга. Каждая группа эмулирует один виртуальный маршрутизатор. Отдельные маршрутизаторы могут принимать участие в нескольких группах. В этом случае маршрутизатор поддерживает отдельные состояние и таймеры для каждой группы.

Каждая резервная группа имеет единственный известный МАС-адрес, а также IP-адрес.

Адресация по протоколу маршрутизатора горячего резервирования (HSRP)

В большинстве случаев при установке маршрутизаторов в качестве части группы HSRP они ожидают HSRP MAC-адрес этой группы, а также свои собственные закрепленные MAC-адреса. Исключением являются маршрутизаторы, Ethernet-контроллеры которых могут распознавать только один MAC-адрес (например, контроллер Lance на маршрутизаторе Cisco 2500 и Cisco 4500). Эти маршрутизаторы используют MAC-адреса HSRP, когда играют роль активных маршрутизаторов и прошитый адрес, когда не являются активными.

HSRP использует следующие MAC-адреса для всех сред, кроме Token Ring:

0000.0c07.ac**   (where ** is the HSRP group number)

В интерфейсах Token Ring для MAC-адреса HSRP используются функциональные адреса. Функциональные адреса — единственный доступный механизм групповой адресации. Существует ограниченное число доступных функциональных адресов Token Ring, и многие из них зарезервированы под другие функции. Можно использовать следующие три адреса с HSRP:

c000.0001.0000   (group 0)
c000.0002.0000   (group 1)
c000.0004.0000   (group 2)

Примечание: Когда выполнения HSRP в многокольцовой среде мостового соединения с маршрутизацией от источника (SRB) и маршрутизаторах HSRP находятся на других вызовах, использование функциональных адресов может вызвать беспорядок Поля маршрутной информации (RIF). Например, в среде SRB возможно размещение резервного маршрутизатора HSRP на другом кольце, а не на активном маршрутизаторе. Когда этот маршрутизатор в режиме ожидания становится активным, станции на одном кольце с прежним активным маршрутизатором требуют нового RIF, чтобы посылать пакета на новый активный маршрутизатор. Однако станции не осведомлены о необходимости отправить проводники для нового RIF, т.к. резервный (новый активный) маршрутизатор использует тот же функциональный адрес, что и предыдущий. По этой причине была введена команда use-bia.

Cisco IOS Release и матрица функциональных возможностей HSRP

Этот документ показывает, какие функции HSRP поддерживаются в который Cisco Выпуски ПО IOS�. Щелкните функцию, чтобы посмотреть подробное описание. Номер промежуточной версии указывает, версию, в которой функция появилась впервые, или версию, в которой были изменены функциональные особенности этой функции.

Функция 10.0 10.2 10.3 11.0 11.1 11.2 11.3 12.0 12.0T 12.1 12.1T
Приоритетное прерывание обслуживания X X X X X X X X X X X
Несколько групп (MHSRP) X X X X X X X X X
Ethernet 802.10 SDE X X X X X X X
Отслеживание интерфейсов X X X X X X X
Использование BIA 8.0 X X X X X X
Задержка приоритетного прерывания обслуживания X X 6.1 X X X
Ethernet LANE X X X X X X
LANE в Token Ring X X X X X
ISL X X X X X
Поддержка системного журнала X X X X X
Интервал обновления MAC 1.0 X X X
SNMP MIB 3.0 X X
MHSRP и использование BIA 3.4 X X
IP-резервирование 3.4 X X
BVI 6.2 X X
802.1Q 8.1 X X
Улучшенная отладка HSRP 0.2 X
Переадресация HSRP ICMP 3
HSRP MPLS VPNs 3

Загрузочные образы Cisco IOS и функциональные возможности HSRP

Функциональность HSRP была включена в загрузочные образы Cisco IOS до интеграции Cisco Bug ID CSCec16720 (только для зарегистрированных клиентов). Cisco Bug ID CSCec16720 подразумевает к удаление HSRP из загрузочных образов за исключением:

  • c7200-boot-mz

  • c7200-kboot-mz

  • c10k-eboot-mz

  • c4500-boot-mz

  • c7200-boot-mz

  • c7200-kboot-mz

  • c7400-kboot-mz

  • ubr7200-boot-mz

  • c6400r-boot-mz

  • загрузочный mz rpm

  • rpmxf-boot-mz

  • Rsp-boot-mz

  • urm-wboot-mz

  • c5350-boot-mz

  • c5400-boot-mz

  • c7301-boot-mz

  • c5850-boot-mz

  • c4gwy-cboot-mz

  • ubr910-rboot-mz

  • ubr910-rboot-mz

  • ubr925-k8boot-mz

  • c5850tb-boot-mz

Функции HSRP

Приоритетное прерывание обслуживания

Функция приоритетного прерывания обслуживания HSRP включает маршрутизатор с самым высоким приоритетом, он немедленно становится активным маршрутизатором. В первую очередь приоритет определяется по установленному значению приоритета и затем по IP-адресу. В любом случае чем больше значение, тем выше приоритет.

При прерывании обслуживания маршрутизатор с более высоким приоритетом отправляет сообщение coup маршрутизатору с более низким приоритетом. Когда активный маршрутизатор с меньшим приоритетом получает сообщение coup или приветственное сообщение от активного маршрутизатора с большим приоритетом, он переходит состояние разговора и отправляет сообщение об отказе.

Задержка приоритетного прерывания обслуживания

Вытеснять функция задержки позволяет приоритетному прерыванию обслуживания быть задержанным для настраиваемого периода времени, позволяя маршрутизатору заполнить его таблицу маршрутизации прежде, чем стать активным маршрутизатором.

Когда маршрутизатор перезагрузился, перед программным обеспечением Cisco IOS версии 12.0(9) запустилась задержка. В Cisco IOS выпуска 12.0(9) задержка начинается, когда впервые предпринимается приоритетное прерывание обслуживания.

Чтобы настроить приоритет и приоритетное прерывание обслуживания HSRP, используйте команду standby [группа] [priority номер] [preempt [delay [minimum] секунды] [sync секунды]].

Дополнительные сведения о настройке HSRP см. в Документации по HSRP.

Отслеживание интерфейсов

Отслеживание интерфейсов позволяет определить другой интерфейс на маршрутизаторе для процесса HSRP для контроля с целью изменения приоритета HSRP для данной группы.

Если происходит сбой указанного линейного протокола интерфейса, приоритет HSRP этого маршрутизатора уменьшается, позволяя другому маршрутизатору HSRP с более высоким приоритетом стать активным (если у него включено приоритетное прерывание обслуживания).

Для настройки функций отслеживания интерфейса HSRP используйте команду standby [группа] track interface [приоритет].

Когда выключается множество отслеженных интерфейсов, приоритет уменьшается на совокупную величину. При явном задании значения декремента значение уменьшается заданным образом при отказе интерфейса, при этом происходит накопление декрементов. Если явное значение декремента не задано, то оно уменьшается на 10 для каждого интерфейса, вышедшего из строя. Декременты накапливаются.

В следующем примере используется конфигурация со значением декремента по умолчанию (10).

Примечание: Если номер группы HSRP не указан, по умолчанию устанавливается номер группы 0.

interface ethernet0
     ip address 10.1.1.1 255.255.255.0
     standby ip  10.1.1.3 
     standby priority 110
     standby track serial0 
     standby track serial1

Поведение HSRP с этой конфигурацией:

  • 0 интерфейсы отключены = отсутствует увеличение (приоритет- 110)

  • 1 интерфейс ниже = уменьшение на 10 (приоритет становится 100)

  • 2 интерфейса отключены = увеличение на 10 (приоритет становится 90)

Описанное поведение HSRP имеет место, даже если значения отрицательного приращения настроены явно, как показано ниже.

interface ethernet0
     ip address 10.1.1.1 255.255.255.0
     standby ip  10.1.1.3 
     standby priority 110
     standby track serial0 10
     standby track serial1 10

Перед Cisco IOS Release 12.1 при начале маршрутизатора с отключенного интерфейса отслеживание интерфейса HSRP расценивает интерфейс как.

Этот дефект имеет идентификатор Cisco Bug ID CSCdp32289 (только для зарегистрированных клиентов).

Использование прошитого адреса

Использование средства прошитого адреса (BIA) позволяет группам HSRP использовать прошитый MAC-адрес интерфейса вместо MAC-адреса HSRP. Функция BIA была включена впервые в Cisco IOS release 11.1(8). Чтобы настроить HSRP для использования BIA, используйте команду standby use-bia [scope interface].

Команду use-bia ввели для того, чтобы избежать ограничений в использовании функционального адреса для MAC-адреса HSRP в интерфейсах Token Ring.

Примечание: Если HSRP работает в многокольцевой среде мостовой передачи с маршрутизацией от источника и маршрутизаторы HSRP находятся на разных кольцах, использование функциональных адресов может привести к конфликтам в поле сведений о маршрутизации (RIF). По этой причине была введена команда use-bia.

Функция use-bia также позволяет использовать MAC-адрес DECnet (BIA) в качестве MAC-адреса HSRP, что дает возможность пользоваться DECnet, сетевыми системами Xerox (XNS) и HCRP на одном маршрутизаторе. Команда use-bia полезна также в сетевых сценариях, когда BIA-адрес устройства настроен на других устройствах в локальной сети.

Однако команда use-bia имеет несколько недостатков:

  • Когда маршрутизатор становится активным, виртуальный IP-адрес перемещается в другой МАС-адрес. Только что включенный маршрутизатор посылает неспровоцированный ARP-отклик, но не все реализации хостов правильно поддерживают неспровоцированные сообщения ARP.

  • При настройке use-bia происходит сбой агента ARP. Резервный маршрутизатор не может заменить утерянную базу данных ARP-прокси неисправного активного маршрутизатора.

  • До выпуска 12.0(3.4)T Cisco IOS была разрешена только одна группа HSRP для конфигурации use-bia.

При настройке команды use-bia в субинтерфейсе она отображается только на главном интерфейсе и применяется ко всем субинтерфейсам. В выпуске 12.0(6.2) Cisco IOS и выше команда use-bia расширена дополнительными ключевыми словами интерфейсных областей для возможности их применения к одному подчиненному интерфейсу.

Эта ошибка имеет идентификатор Cisco bug ID CSCdp32289 (только для зарегистрированных клиентов).

Несколько групп HSRP

Возможность нескольких групп HSRP (MHSRP) была добавлена в Cisco IOS release 10.3. Эта функция повышает возможности избыточности и распределения нагрузки внутри сетей, а также позволяет более эффективно использовать избыточные маршрутизаторы. Пока маршрутизатор перенаправляет трафик одной группы HSRP, он может находится в режиме ожидания или прослушивания по отношению к другой группе.

В версии Cisco IOS 12.0(3.4)T команду use-bia можно использовать, если включены несколько групп HSRP.

Обратитесь к Распределению нагрузки с HSRP для настройки HSRP для использования преимуществ разнообразных путей.

Настраиваемый MAC-адрес

Обычно вы используете HSRP, чтобы помочь конечным станциям определять местоположение первого шлюза перехода для IP routing. Для конечных станций указывается маршрутизатор по умолчанию. Однако HSPR может обеспечить избыточность первого узла для других протоколов. Некоторые протоколы, такие APPN, используют MAC-адрес для определения первого перехода в маршрутизации.

В данном случае часто возникает необходимость указать виртуальный MAC-адрес при помощи команды standby mac-address. Виртуальный IP-адрес для этих протоколов несущественен. Реальный синтаксис команды: standby [group] mac-address mac-address.

Примечание: Вы не можете использовать эту команду на Интерфейсе Token Ring.

Поддержка системного журнала

Поддержка обмена сообщениями системного журнала для получения информации HSRP была добавлена в Cisco IOS Release 11.3. Эта функция позволяет более эффективно регистрировать и отслеживать текущие активные и резервные маршрутизаторы на серверах Syslog.

Отладка HSRP

Перед Cisco IOS Release 12.1 команда отладки HSRP была относительно проста. Для включения отладки HSRP просто используйте команду debug standby, которая задействует выходные данные о состоянии HSRP и сведения о пакете для всех резервных групп на всех интерфейсах.

Условие отладки, добавленное в версии Cisco IOS 12.0(2.1), позволяет фильтровать выходные данные команды standby debug в зависимости от интерфейса и числа групп. В этой команде используется парадигма debug condition, представленная в версии Cisco IOS 12.0, как показано в следующем примере: debug condition standby interface group. Необходимо указать допустимый интерфейс с поддержкой HSRP. Группа может быть любой (0-255).

Можно задавать условия отладки и для несуществующих групп, что позволяет получать данные отладки во время инициализации новой группы.

Необходимо включить standby debug order для всех выходных данных отладки. Если вы не указали никаких условий резервной отладки, выход отладки предоставляется для всех групп всех интерфейсов. При настройке конфигурации хотя бы одного условия резервной отладки результат фильтруется в соответствии со всеми условиями.

Улучшенная отладка HSRP

Перед Cisco IOS Release 12.1 (0.2), отладка HSRP имела ограниченное использование, потому что информация была потеряна в шуме из периодических сообщений приветствия. Поэтому расширенная функция отладки была добавлена в Cisco IOS 12.1(0.2).

В приведенной таблице описываются параметры команды enhanced debugging.

Команда Описание
debug standby Вывод всех ошибок, событий и пакетов HSRP.
debug standby terse Отображает все ошибки HSRP, события и пакеты, кроме привет и объявляющие пакеты.
debug standby errors Отображает ошибки HSRP.
debug standby events [[все | краткий] | [icmp | протокол | резервирование | дорожка]] [подробность] Отображает события HSRP.
debug standby packets [[все | краткий] | [дают объявление |, удачный ход | привет | уходит в отставку]] [подробность] Показывает пакеты HSRP.

Можно отфильтровать вывод отладки с помощью интерфейса и условной отладки группы HSRP. Чтобы включить условную отладку интерфейса, используйте команду debug condition interface interface. Чтобы включить условную отладку HSRP, используйте команду debug condition standby interface group.

Условие отладки интерфейса применяется только если не задано резервных условий отладки. Отладка HSRP далее улучшена в программном обеспечении Cisco IOS версии 12.1 (1.3), на основе улучшений, которые были сделаны к таблице состояний HSRP.

Данный дефект имеет идентификатор ошибки Cisco CSCdp57811 (только для зарегистрированных клиентов) .

Эти усовершенствования отображают события таблицы состояний HSRP. В выходных данных ниже параметры a/, b/, c/ и т. д. относятся к событиям конечного автомата HSRP, описанных в стандарте RFC 2281 . leavingcisco.com

SB1: Ethernet0/2 Init: a/HSRP enabled
SB1: Ethernet0/2 Active: b/HSRP disabled (interface down)
SB1: Ethernet0/2 Listen: c/Active timer expired (unknown)
SB1: Ethernet0/2 Active: d/Standby timer expired (20.0.0.3)
SB1: Ethernet0/2 Speak: f/Hello rcvd from higher pri Speak router
SB1: Ethernet0/2 Active: g/Hello rcvd from higher pri Active router
SB1: Ethernet0/2 Speak: h/Hello rcvd from lower pri Active router
SB1: Ethernet0/2 Standby: i/Resign rcvd
SB1: Ethernet0/2 Active: j/Coup rcvd from higher pri router
SB1: Ethernet0/2 Standby: k/Hello rcvd from higher pri Standby router
SB1: Ethernet0/2 Standby: l/Hello rcvd from lower pri Standby router
SB1: Ethernet0/2 Active: m/Standby mac address changed
SB1: Ethernet0/2 Active: n/Standby IP address configured

Authentication

Функция проверки подлинности HSRP состоит из разделяемых незашифрованных ключей, содержащихся внутри пакетов HSRP. Эта функция предотвращает получение маршрутизатором нижнего приоритета резервного IP-адреса и значений резервного таймера от маршрутизатора более высокого приоритета.

Настройка строки аутентификации HSRP выполняется с помощью команды standby authentication string.

IP-резервирование

HSRP предоставляет избыточность, не имеющую состояния для IP routing. Сам протокол HSRP ограничен поддержкой собственного состояния. Он предполагает, что все маршрутизаторы создают и поддерживают собственные таблицы маршрутизации независимо от других маршрутизаторов. Функция избыточности IP предоставляет механизм, который позволяет HSRP обслуживать клиентские приложения, обеспечивая аварийное переключение с учетом состояния.

Избыточность IP не предоставляет одноранговым приложениям механизм обмена данными о состоянии. Реализация этой функции возложена на сами приложения. Это необходимо, если приложения должны обеспечивать аварийное переключение с учетом состояния.

В настоящий момент (январь 2006 г.) избыточность IP реализована только для приложения Mobile IP Home Agent. Ниже приводится пример конфигурации:

configure terminal
 router mobile
 ip mobile home-agent standby hsrp-group1
!
interface e0/2
 no shutdown
 ip address 20.0.0.1 255.0.0.0
 standby 1 ip 20.0.0.11
 standby 1 name hsrp-group1

Примечание: Для Cisco IOS release 12.1(3)T избыточность ключевого слова принимается дополнительно к резервированию ключевого слова. Ключевое слово standby будет исключено в следующих выпусках Cisco IOS. Правильная форма команды будет выглядеть следующим образом: ip mobile home-agent redundancy hsrp-group1.

В будущем использование IP-резервирования может включать:

  • NAT — избыточные шлюзы.

  • IPSEC – необходимо синхронизировать сведения о состоянии для возможности функционировании при использованном HSRP.

  • Сервер DHCP - серверы DHCP, реализованные в различных маршрутизаторах.

  • NBAR, CBAC – требуется отобразить состояния межсетевого экрана для асимметричной маршрутизации.

  • GPRS - необходим способ отслеживания состояния TCP.

  • PIX

База сведений управления SNMP

Информационная база управления SNMP (MIB) поддержка была добавлена к Cisco IOS Release 12.0 (3.0) T. Существуют две важных MIBs для HSRP:

  • ciscoMgmt 106: Модуль MIB для управления HSRP

  • ciscoMgmt 107: Расширенный MIB-модуль для управления HSRP

В выпусках Cisco IOS, предшествующих 12.0(6.1)T, обход расширенной базы HSRP MIB при наличии виртуального интерфейса мостовой группы (BVI) вызывает аварийный отказ маршрутизатора.

Эта ошибка имеет идентификатор Cisco bug ID CSCdm61257 (только для зарегистрированных клиентов).

Поддержка HSRP виртуальных частных сетей с многопротокольной коммутацией на основе меток

Поддержка HSRP для виртуальных частных сетей с многопротокольной коммутацией на основе меток (MPLS VPN) добавлена в выпуске Cisco IOS 12.1(3)T.

HSRP используется в интерфейсе VPN с коммутацией MPLS, если имеется соединение Ethernet между двумя периферийными маршрутизаторами провайдеров (PE) и соблюдено одно из следующих условий:

  • Оконечное устройство абонентской сети (CE) с маршрутом по умолчанию к виртуальному IP-адресу HSRP.

  • Один или несколько узлов с виртуальным IP-адресом HSRP настроены в качестве шлюза по умолчанию.

На сетевой дейтаграмме ниже указаны два PE с HSRP, действующим между их маршрутизирующими/передающими VPN интерфейсами (VRF). CE был настроен с помощью виртуального IP-адреса HSRP в качестве маршрута по умолчанию. Протокол HSRP настроен на отслеживание интерфейсов, соединяющих PE с остальной частью сети поставщика. Например, в случае отказа интерфейса E1 в PE1 приоритет HSRP снижается, и пересылка пакетов по виртуальному IP- или MAC-адресу передается PE2.

http://www.cisco.com/c/dam/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/9234-hsrpguide4a.gif

Это конфигурации:

Маршрутизатор PE1 Маршрутизатор РЕ2
conf terminal
!
ip cef
!
ip vrf vrf1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface ethernet0
 no shutdown
 ip vrf forwarding vrf1
 ip address 10.2.0.1 255.255.0.0
 standby 1 ip 10.2.0.20
 standby 1 priority 105
 standby 1 preempt delay minimum 10
 standby 1 timers 3 10
 standby 1 track ethernet1 10
 standby 1 track ethernet2 10
conf terminal
!
ip cef
!
ip vrf vrf1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface ethernet0
 no shutdown
 ip vrf forwarding vrf1
 ip address 10.2.0.2 255.255.0.0
 standby 1 ip 10.2.0.20
 standby 1 priority 100
 standby 1 preempt delay minimum 10
 standby 1 timers 3 10
 standby 1 track ethernet1 10
 standby 1 track ethernet2 10

Чтобы проверить, что виртуальный IP-адрес HSRP представляет правильный VRF ARP, и таблицы пересылки Cisco Express, можно использовать следующие команды:

ed1-pe1# show ip arp vrf vrf1
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.0.1                -   00d0.bbd3.bc22  ARPA   Ethernet0/2
Internet  10.2.0.20               -   0000.0c07.ac01  ARPA   Ethernet0/2   

ed1-pe1# show ip cef vrf vrf1
Prefix              Next Hop             Interface
0.0.0.0/0           10.3.0.4             Ethernet0/3
0.0.0.0/32          receive
10.1.0.0/16         10.2.0.1             Ethernet0/2
10.2.0.0/16         attached             Ethernet0/2
10.2.0.1/32         receive
10.2.0.20/32        receive                                                
224.0.0.0/24        receive
255.255.255.255/32  receive

Поддержка HSRP для перенаправлений ICMP

HSRP основан на концепции, что равные маршрутизаторы HSRP, защищающие подсеть, могут предоставить доступ всем другим подсетям, входящим в состав сети. Поэтому не имеет значения, какой маршрутизатор становится активным маршрутизатором HSRP, поскольку все они имеют пути к каждой подсети.

HSRP использует специальные виртуальные IP-адреса и виртуальные MAC-адреса, логически подключенные к активному маршрутизатору HSRP. Перенаправления ICMP автоматически отключаются в интерфейсе при использовании в нем HSRP. Начиная с версии IOS 12.1(3)T функция перенаправления ICMP поддерживается в интерфейсах, использующих HSRP. Дополнительные сведения см. в документе Поддержка перенаправлений ICMP в протоколе HSRP. Это делается для того, чтобы предотвратить ситуацию перенаправления хостов от виртуального IP-адреса HSRP. Возможно, что два (или более) маршрутизатора в подсети не имеют идентичного подключения к остальной сети. То есть для определенного IP адреса назначения в одном или другом из маршрутизаторов может указываться лучший путь к этому адресу, или он может оказаться единственным маршрутизатором, соединенным с этим адресом.

Протокол ICMP позволяет маршрутизатору заставить конечную станцию пересылать пакеты в определенное место назначения через другой маршрутизатору в той же подсети, если первому маршрутизатору известно, что другой маршрутизатор имеет лучший путь к этому месту назначения. Как и в случае с шлюзами по умолчанию, если маршрутизатор, к которому была перенаправлена конечная станция для конкретного назначения, дает сбой, то пакеты конечной станции до этого назначения не будут доставлены. Это как раз то, что может случиться в стандартном HSRP. По этой причине рекомендуется отключать переадресацию ICMP, если включен HSRP.

Решение этой проблемы может быть получено путем расширения связи перенаправлений ICMP и протокола HSRP, которое позволит использовать преимущества протокола HSRP и перенаправлений ICMP одновременно. Две (или более) группы HSRP работают в каждой подсети, причем по меньшей мере с таким количеством настроенных групп HSRP, которое соответствует числу задействованных маршрутизаторов. Приоритеты настроены таким образом, что каждый из маршрутизаторов является основным как минимум в одной HSRP-группе. Если один из маршрутизаторов решает перенаправить конечную станцию на другой маршрутизатор при работе с определенным местом назначения, вместо перенаправления конечной станции на IP-адрес этого маршрутизатора он находит группу HSRP, поддерживаемую этим маршрутизатором, и перенаправляет конечную станцию на соответствующий виртуальный IP-адрес. Если затем имеет место отказ целевого маршрутизатора, HSRP обеспечивает выполнение его работы другим маршрутизатором и перенаправляет конечную станцию на другой, тоже виртуальный маршрутизатор.

Поддержка интерфейса и среды передачи данных HSRP

В этом разделе приведены сведения о поддержке протоколом HSRP интерфейсов и сред, а также об особенностях работы HSRP с этими средами.

Начиная с версии Cisco IOS 10.0 функциональность HSRP доступна для интерфейсов Ethernet, Token Ring и Fiber Distributed Data Interface (FDDI). HSRP также поддерживает интерфейсы высокоскоростной Ethernet и ATM.

Виртуальные LAN (VLAN) позволяют логическим сетевым топологиям производить наложение на физическую коммутируемую инфраструктуру таким образом, чтобы любой произвольный набор портов LAN мог объединяться в автономную пользовательскую группу или сообщество интересов. Поддержка HSRP VLAN была добавлена в версии Cisco IOS 11.1 для IEEE 802.10 Secure Data Exchange (SDE) и Cisco IOS 11.3 для Cisco Inter-Switch Link (ISL).

Ethernet

Несколько контроллеров Ethernet (Lance и QUICC) в младших продуктах могут иметь лишь один индивидуальный MAC-адрес в фильтре. На этих платформах разрешена только одиночная HSRP группа, а адрес интерфейса изменяется на виртуальный HSRP MAC адрес, когда группа активизируется. Если HSRP используется на маршрутизаторе с несколькими интерфейсами данного типа, необходимо настроить различные номера группы HSRP для каждого интерфейса.

Примечание: Маршрутизатор Cisco 7200 также использует контроллер Lance Ethernet, однако для него предусмотрена программная поддержка MHSRP.

Компания Cisco рекомендует задействовать на более 24-х интерфейсных процессоров Ethernet (EIP) на HSRP, поскольку обновление адресных фильтров для HSRP занимает достаточно длительное время. Наличие более двадцати четырех HSRP EIP может вызвать нестабильность и избыточную загрузку CPU.

Эта ошибка имеет идентификатор Cisco Bug ID CSCdj29595 (только для зарегистрированных клиентов).

При наличии более двадцати четырех EIP, попробуйте заменить их модулями VIP и адаптерами портов Ethernet. VIP были одобрены примерно для восьмидесяти групп HSRP. Можно также сократить число групп HSRP и увеличить время приветствия и удержания HSRP.

Token Ring

Одно ограничение рабочего HSRP на Интерфейсе Token Ring - то, что вы не можете перепрограммировать фильтр адреса на комплектах микросхем Token Ring тем же путем, вы можете на Ethernet, FDDI или эмуляции ATM. Token Ring использует функциональные адреса, лишь малая часть которых не вызывает конфликтов с другими устройствами, использующими пространство функциональных адресов.

Выполнение HSRP в среде соединения "источник-маршрут" (SRB) с использованием функциональных адресов может вызвать конфликт RIF. Более подробно см. раздел адресации HSRP. Кроме того, попробуйте настроить команду use-bia.

802.1Q

Cisco рекомендует использовать программное обеспечение Cisco IOS версии 12.0 (8.1) T или позже для HSRP по 802.1Q.

ISL

Протокол HSRP через ISL доступен в версиях Cisco IOS 11.2(6)F, 11.3, 12.X. Во избежание проблем, описанных в отчете Cisco об ошибке CSCdm68811 (доступном только для зарегистрированных клиентов), рекомендуется использовать выпуск 12.0(7) или более поздний.

FDDI

Адаптер порта FDDI снимает кадры с кольца, если видит один из своих собственных MAC-адресов в источнике MAC. Если событие в сети вызывает активацию обоих маршрутизаторов, оба они отсылают пакеты приветствия HSRP с одним и тем же виртуальным MAC-адресом. Оба маршрутизатора по ошибке сбрасывают пакеты приветствия и остаются активными.

Этот дефект имеет идентификатор ошибки Cisco CSCdj30049 (только для зарегистрированных клиентов).

Решение данной проблемы в Cisco IOS release 11.2(11.1) заключается в том, что маршрутизаторы HSRP в среде FDDI должны использовать свой уникальный прошитый MAC-адрес для обмена сообщениями и выполнения протокола HSRP. Для этого мосты и коммутаторы записывают в кэш правильную запись порта для виртуальных MAC-адресов, активный маршрутизатор также отправляет периодические обновленные сообщения, используя MAC-адреса HSRP.

Примечание: Аппаратное ассоциативное запоминающее устройство (CAM) маршрутизатора Cisco 4500 на интерфейсе FDDI после перезагрузки может быть заполнено неверно, если было сконфигурировано несколько сетей RIP и групп HSRP. Единственный способ решения этой проблемы в настоящий момент — очистка интерфейсов для восстановления CAM. Этот дефект имеет код ошибки Cisco CSCdm93122 (доступно только для зарегистрированных клиентов).

Обновите MAC

Маршрутизаторы HSRP в среде FDDI используют свой собственный уникальный неизменный MAC - адрес для сообщений Exchange и выполняют протокол HSRP. Для этого мосты и коммутаторы записывают в кэш правильную запись порта для виртуальных MAC-адресов, активный маршрутизатор также отправляет периодические обновленные сообщения, используя MAC-адреса HSRP. Этот дефект имеет идентификатор ошибки Cisco CSCdj30049 (только для зарегистрированных клиентов).

Если в сети нет коммутаторов или обучающихся мостов, можно запретить отсылку пакетов обновлений, как показано ниже:

interface fddi 1/0/0
 ip address 10.1.1.1 255.255.255.0 
 standby ip 10.1.1.250 
 standby mac-refresh 0

Виртуальный интерфейс мостовой группы

Поддержка HSRP в виртуальных интерфейсах группы мостовой передачи (BVI) была добавлена в Cisco IOS release 12.0(6.2)T.

Подинтерфейсы

Группы HSRP на субинтерфейсах должны иметь уникальный номер группы среди всех групп для всех субинтерфейсов одного интерфейса. Это вызвано тем, что субинтерфейсы не получают уникальный индекс интерфейса SNMP. Если имеются две группы с номером N на разных субинтерфейсах, то в MIB группа N на субинтерфейсе 1 и группа N на субинтерфейсе 2 будут выглядеть как одна и та же группа.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 9234