Коммутация LAN : 802.1Q

802.1Q Транкинг между коммутаторами под управлением CatOS Catalyst и программным обеспечением системы Cisco IOS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (8 августа 2008) | Английский (7 октября 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет примеры конфигурации для транкинга IEEE 802.1Q между Коммутаторами Catalyst рабочее системное программное обеспечение операционной системы Catalyst (CatOS) и модульный Уровень 3 (L3) коммутаторы рабочий Cisco Системное программное обеспечение IOS�. �Switches рабочий CatOS включают Catalyst 4500/4000, 5500/5000, и 6500/6000 коммутаторы серии. Модульные коммутаторы L3, работающие под управлением программного обеспечения Cisco IOS, включают Catalyst 4500/4000 and Catalyst 6500/6000 series switches. В примерах конфигурации используются Catalyst 4000 (CatOS) и Catalyst 6500 (программное обеспечение Cisco IOS), но те же результаты возможно получить с любым из упомянутых коммутаторов.

С помощью транкинга осуществляется трафик между двумя устройствами из нескольких сетей VLAN через двухточечное соединение. Два способа применения группировки каналов Ethernet:

  • Протокол Inter-Switch Link (ISL) (частный протокол Cisco)

  • 802.1q (IEEE стандарт)

Предварительные условия

Требования

Для системных требований, рекомендаций и ограничений, отнесенных к 802.1Q и ISL на Коммутаторах Catalyst, обращаются к: Страница поддержки технологии магистрального соединения.

Используемые компоненты

Для создания примеров в этом документе эти коммутаторы использовались:

  • Коммутатор Catalyst 4000 с Supervisor Engine II (WS-X4013), на котором запущено программное обеспечение CatOS версии 8.1.3

  • Catalyst 6509 с модулем Supervisor Engine 2 и платой MSFC2 под управлением Cisco IOS Software Release 12.1(20)E2 на Supervisor Engine и MSFC2

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Теоретические сведения

В данном документе рассматриваются только примеры файлов конфигурации для коммутаторов, а также выходные данных соответствующих команд show. Дополнительную информацию по конфигурации транка 802.1Q между коммутаторами Catalyst см. в разделе "Страницы технической поддержки продуктов LAN".

В группировании каналов 802.1Q все пакеты VLAN помечаются на магистральном канале, за исключением собственной VLAN. Собственные пакеты VLAN отправляются по каналу транка без разметки. Поэтому стандартная VLAN должна быть одинаковой на обоих коммутаторах, настроенных на группирование магистралей. Таким образом, можно вывести, которой VLAN кадр принадлежит при приеме кадра без метки. По умолчанию VLAN 1 является стандартной для всех коммутаторов.

  • В CatOS стандартную VLAN можно изменить с помощью команды set vlan vlan-id mod/port, где "mod/port" - магистральный порт.

  • В ПО Cisco IOS собственную виртуальную сеть можно переопределить, задав команду switchport trunk native vlan vlan-id interface, которая настраивается в магистральном порту.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Конфигурации, рассматриваемые в этом документе, были реализованы в изолированной среде. Перед использованием любой конфигурации и команды необходимо изучить потенциальное воздействие не сеть до их использования. Конфигурации на всех приборах были освобожены с командами clear config all и write erase обеспечить что они имели конфигурацию по умолчанию.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов). leavingcisco.com

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/8760/67-a.gif

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: Замечания и пояснения выделены синим курсивом.

Catalyst 4000 Switch
#version 8.1(3)
!
!
#system web interface version(s)
!
#system
set system name  cat4000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp domain cisco

!--- In this example, the VLAN Trunk Protocol (VTP) domain name is the same
!--- on both sides. This is required for the autonegotiation of the trunk
!--- by the Dynamic Trunking Protocol (DTP).


set vtp mode client vlan

!--- In this example, the VTP mode is set to client.
!--- Set the VTP mode according to your network requirements.

!--- For more details, refer to
!--- Understanding and Configuring VLAN Trunk Protocol (VTP).


!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!--- This is the IP address used for management.

!--- Output suppressed.

!
#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 empty
!
#module 3 empty
!
#module 4 empty
!
#module 5 : 48-port Inline Power Module
set vlan 2    5/13-24

!--- Ports 5/13-24 have been assigned to VLAN 2.



set trunk 5/1  desirable dot1q 1-1005,1025-4094

!--- The trunking mode is set to desirable mode, which means
!--- the port automatically tries to form a trunk with a
!--- neighboring port set to desirable, auto, or on mode.

!--- For recommended trunk mode settings, refer to
!--- the Dynamic Trunking Protocol section of
!--- Best Practices for Catalyst 4500/4000, 5500/5000, and 6500/6000 
Series Switches Running CatOS Configuration and Management.

!--- Output suppressed.


set spantree portfast    5/2-24 enable
set port channel 5/2-24 mode off

!--- The macro command set port host 5/2-24 was used to do three things:
!--- disable trunking, disable port channeling, and enable spantree portfast.

!--- For details on using the set port host command, refer to
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays.

!
#module 6 empty
end

Коммутатор Catalyst 6500
Current configuration : 4408 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot system flash sup-bootflash:c6sup22-jsv-mz.121-20.E2
enable password mysecret

!--- This is the privileged mode password used in the example.


!
ip subnet-zero
!
!
!
mls flow ip destination
mls flow ipx destination
!
redundancy
 mode rpr-plus
 main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
 no ip address
 shutdown
!
interface GigabitEthernet2/2
 no ip address
 shutdown
!
interface fastethernet3/1
 switchport

!--- The switchport command must be entered once,  
!--- without any keywords, to configure the interface as a Layer 2 port.
!--- The interface is now automatically configured with the default command
!--- switchport mode dynamic desirable.

!--- This means the interface is ready to autonegotiate trunking
!--- encapsulation and form a trunk link (using DTP) with a neighbor port
!--- in desirable, auto, or on mode.

!--- For recommended trunk mode settings, refer to
!--- the "Dynamic Trunking Protocol" section of
!--- Best Practices for Catalyst 6500/6000 Series and Catalyst 4500/4000 
Series Switches Running Cisco IOS Software.



!
interface FastEthernet3/2
 switchport
 switchport mode access
 spanning-tree portfast


!--- The interface range fastethernet mod/beginport - endport 
!--- command is used to configure interfaces 3/2 - 24 at once.

!--- Next, the switchport command is issued (if this has not been done already).


switchport mode access
 spanning-tree portfast

!--- Next, issue the macro command switchport host 3/2 - 24 to automatically
!--- configure these ports as access ports and to enable spantree portfast.

!--- For details on using the switchport host command, refer to
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays.


!
interface FastEthernet3/13
 switchport
 switchport access vlan 2

!--- Interfaces 3/13 - 24 are placed in VLAN 2
!--- using the switchport access vlan 2 command.


 switchport mode access
 spanning-tree portfast


!--- Output suppressed.


!
interface FastEthernet3/24
 shutdown
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast


!--- Output suppressed.

!
interface FastEthernet3/48
 no ip address
 shutdown
!
interface vlan 1
 ip address 10.10.10.3 255.255.255.0

!--- This is the IP address used for management.

!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
 password mysecret


!--- This is the Telnet password used in the example.


 login
 transport input lat pad mop telnet rlogin udptn nasi
!
!
end

cat6500#

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

команды "show"

Некоторые команды show поддерживаются средством Интерпретатор выходных данных (только для зарегистрированных клиентов), который позволяет выполнять анализ выходных данных команды show. leavingcisco.com

В коммутаторах Catalyst под управлением ОС CatOS используют следующие команды:

  • show port capabilities module/port

  • show port модуль/порт

  • show trunk module/port

  • show vtp domain

На коммутаторах Catalyst 6000 с программным обеспечением Cisco IOS используйте следующие команды:

  • show interfaces interface-type module/port trunk

  • show vlan

Пример выходных данных команды show

Catalyst 4000 Switch

Команда show port capabilities module/port служит для проверки возможности данного порта установить магистральное соединение.

cat4000> (enable) show port capabilities 5/1
Model                    WS-X4148-RJ45V
Port                     5/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         802.1Q
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  5/1-48
Flow control             no
Security                 yes
Dot1x                    yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(2q1t)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
Inline power             auto,off,static
AuxiliaryVlan            1..1000,1025..4094,untagged,none
SPAN                     source,destination,reflector
Link debounce timer      yes
IGMPFilter               yes
Dot1q-all-tagged         no
cat4000> (enable)

Команда show port module/port показывает статус отдельного порта и сведения о том, участвует ли он в магистральном соединении.

cat4000> (enable) show port status 5/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
cat4000> (enable)

Команда show trunk используется для проверки состояния и конфигурации магистрального соединения.

cat4000> (enable) show trunk
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 5/1      desirable    dot1q          trunking      1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 5/1      1-1005,1025-4094

Port      Vlans allowed and active in management domain
--------  ---------------------------------------------------------------------
 5/1      1-2

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 5/1      1-2
cat4000> (enable)

Команда show vtp domain используется для проверки данных VTP.

cat4000> (enable) show vtp domain 
Version      : running VTP1 (VTP3 capable)
Domain Name  : cisco                            Password  : not configured
Notifications: disabled                         Updater ID: 10.10.10.3

Feature        Mode           Revision
-------------- -------------- -----------
VLAN           Client         21

Pruning             : disabled
VLANs prune eligible: 2-1000

Коммутатор Catalyst 6500

Команда show interfaces interface-type module/port trunk сообщает, участвует ли данный порт в магистральном соединении.

cat6500# show interfaces fastethernet 3/1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa3/1     desirable    n-802.1q       trunking      1

Port      Vlans allowed on trunk
Fa3/1     1-4094

Port      Vlans allowed and active in management domain
Fa3/1     1-2

Port      Vlans in spanning tree forwarding state and not pruned
Fa3/1     1-2
cat6500#

Команда show vlan дает информацию о сетях VLAN и портах, принадлежащих определенной сети VLAN.

cat6500# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa3/2, Fa3/3, Fa3/4, Fa3/5
                                                Fa3/6, Fa3/7, Fa3/8, Fa3/9
                                                Fa3/10, Fa3/11, Fa3/12
2    VLAN0002                         active    Fa3/13, Fa3/14, Fa3/15, Fa3/16
                                                Fa3/17, Fa3/18, Fa3/19, Fa3/20
                                                Fa3/21, Fa3/22, Fa3/23, Fa3/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup


!--- Output suppressed.
    
cat6500#

Примечание: Отображаются только порты, настроенные как немагистральные порты уровня 2.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 8760